Subject: RE: Formalizing Design Teams

From: "Joel M. Halpern" <[email-masked]>
Date: Fri, 20 Dec 2002 16:26:02 -0500

I would disagree.
For Policy Framework, there was a design team for each document.
Within some of the design teams a specific individual was identified as editor.
When we did not do so, it produced confusion.
When we did have a clear editor, it made it very easy to know whom to turn 
to perform simple questions like "what is that state of the document?" and 
"have the changes the WG asked for been made?".
Thus, we had clear and identified design teams for each problem, and 
generally an editor for each document.  Whether we identified the editor or 
the design team as the authors was a matter of practice.  Given current 
approaches, doing it now I would identify the editor on the front, and the 
authors within the document.

As far as I can tell, there is no particular problem that requires a more 
formalized notion of "design team".  I like many of the properties we have 
now.
And the editor structure we frequently use seems to work.
The biggest difficulty I see is that the editor needs to understand the 
amount of work being signed up for.

We are currently checking for the existence of sufficiently many active 
participants to finish off the last two documents for Policy 
Framework.  Part of that will involve finding a specific editor from among 
the design team volunteers.

Yours,
Joel M. Halpern

At 03:27 PM 12/20/2002 -0500, Eastlake III Donald-LDE008 wrote:
>The whole concept of "The Editor" seems like something that
>either grew out of early small IETF WGs or other standards
>bodies. I'm almost never been involved with a WG where there
>was The Editor the way it seems to be contemplated in IETF
>process documents. The IETF documents geneally list the
>people who, to the greatest extent, have their hands on the
>text. They usually write a lot of it. There is no way to
>cleanly separate authors and editors unless perhaps you have
>authors who prepare a complete document and then pass it off
>to editors who are required to make no techncial changes,
>an arrangement that almost never occurs in the IETF. The W3C
>likes the top level people to be called Editor(s) while in
>the IETF the term Author(s) is more common but there isn't
>much difference that I can see in how it works on a day to
>day basis.
>
>If whoever has their hands on the text and is doing the edits
>won't follow WG direction, they have to be replaced and their
>name moved to a "contributors" section or the like (unless
>they go off in a huff and specifically ask that their name
>be left out). That's all there is to it.
>
>Donald
>
>-----Original Message-----
>From: Kurt D. Zeilenga [mailto:[email-masked]]
>Sent: Friday, December 20, 2002 2:37 PM
>To: James Luciani
>Cc: Marshall Rose; Margaret Wasserman; [email-masked]
>Subject: RE: Formalizing Design Teams
>
>The most problematic design teams I've come across is the one
>often referred to as "the authors".  It seems "the editor"
>forgets that "the authors" are providing input to the WG and
>that this input has no more weight than input from others.
>
>One of things that might help remind "the authors" that they
>are given no more weight is not to list them at the top of
>the WG I-D.
>
>For this reason, I would like the IETF adopt a practice that
>IETF documents list only the Editor in the header.
>
>Kurt

---

From: "Harrington, David" <[email-masked]>
Date: Sun, 22 Dec 2002 10:29:17 -0500

> From: Tony Hain [mailto:[email-masked]]
> Sent: Friday, December 20, 2002 6:34 PM
> To: 'Pete Resnick'
> Cc: 'Marshall Rose'; 'Margaret Wasserman'; [email-masked]
> If all we are ever going to take on in the IETF are
> small incremental changes, short-term narrow-focus groups are
> appropriate. If we need to make significant changes like replacing the
> predominate protocol at a given layer, that isn't going to happen
> quickly, and no it is not research. What it means is that the 
> breadth of
> the problem space is not well understood by the majority of the
> participants. 
> 
or that the problem space has changed in some way, and the majority of participants have not updated their understanding of the problem space.

dbh

---

From: [email-masked]
Date: Mon, 30 Dec 2002 06:47:25 +0200

Hi Scott,

> >  I think some basic groundrules on
> > design teams are needed, at least to provide additional
> > transparancy.
> 
> 
> see http://www.ietf.org/IESG/STATEMENTS/Design-Teams.txt

Thanks for the pointer.  In a number of cases, I think that
the guidences has not been followed, so perhaps we need
more vigilance in monitoring design teams.

John

---

From: "Spencer Dawkins" <[email-masked]>
Date: Mon, 30 Dec 2002 11:40:33 -0600

My impression is that design teams were used more frequently in Sub-IP than in most other areas, and that's the area where I most frequently overheard people saying things like "I need to be on the design team, because it will be too late when they provide text to the working group". 

Is this the impression of others?

Spencer

> From: Eastlake III Donald-LDE008 [mailto:[email-masked]]
> Sent: Monday, December 30, 2002 11:33 AM
> To: [email-masked]
> This isn't really a specific reply but rather some general comments.
> 
> As I recall it, at the time the process documents were modified to
> explicitly mention design teams, there were two reasons. One was
> the existence of semi-organized groups that were drafting documents
> or otherwise providing input to WGs and were perhaps even designated
> by the WG chair in a some cases. The other was to answer frequent
> complaints that because WGs and their mailing lists were supposed
> to be open, therefore no private discussion of any sort was permitted
> in connection with any topic that was, or might be before a WG. This
> is, of course, nonsense. People are permitted to bump into each other
> in the hall and discuss whatever they want. People are permitted to
> telephone a WG chair, and vice versa, and discuss a matter before the
> WG without having to publish a transcript of the call on the mailing
> list, etc. The mention of design teams in the process documents is
> supposed to be flexible and permit both semi-formal design teams but
> also stave off these frequent unreasable demands for absolute
> openness and transparency, I.E., to permit peole who wish to
> voluntarily work together on a matter which is or will be considered
> by a WG to exclude others from their discussions and not have to
> report the details of such discussions.
> 
> Be careful not to concentrate on only one end of the spectrum and
> adopt rules which screw up the other when those rules are used (or
> abused) in ways you don't expect.
> 
> By being increasingly stringent in monitoring them and yielding to
> complaints about design teams being to too closed or lacking
> transparency, all you would do is recreate working groups. The result
> would be a need for new text to allow two members of these now WGized
> design teams to meet in the hall and talk privately, etc., etc.
> 
> While I sometimes have some doubts about design teams set up and
> blessed by a WG chair, as being a temptation towards bias, I don't
> think the practice needs any further regulation and I would say 
> that it is important that "design teams" be able to be closed and
> opaque, no matter how politically incorrect that may sound.
> 
> Donald
> 
> From: [email-masked] [mailto:[email-masked]]
> Sent: Sunday, December 29, 2002 11:47 PM
> To: [email-masked]
> Cc: [email-masked]

---

From: [email-masked]
Date: Mon, 30 Dec 2002 19:56:43 +0200

Donald,

> opaque, no matter how politically incorrect that may sound.

My fear about this is that it favors 'IETF insiders' - I have met
a lot of good, technical people who have dropped out of active
IETF participation because of the assumption that only insiders'
opinions count.  

The text Scott refered to: http://www.ietf.org/IESG/STATEMENTS/Design-Teams.txt
is a good one, in my opinion.  I do not ask for more.  If all
design teams were run according to the suggestions outlined in the
note above, I would be happy.  I have sufficient experience to with
design teams that indicate many are not run according to the rules
set above.

br,
John

---

From: [email-masked]
Date: Mon, 30 Dec 2002 21:03:46 -0500

> ...
> Has anyone thought about extending the insurance coverage to
> these "blessed" design teams in case questions of anti-competitive
> behaviour arise?

IANAL, but as long as the design team is producing "input" to the WG,
and its results are treated accordingly, that shouldn't be an issue
(e.g., the WG as a whole does not have the insurance coverage that
the WG chairs do).

There are a couple of meanings of the word "opaque" that ought to be
distinguished here.  A design team should be able to do its work in
private, but must be able to provide good technical rationale and
justification for what it did when its results are presented to the
WG.  An effective process that I've seen used a few times is to form
a design team to get a -00 version of a draft done and then disband
the design team.

Thanks,
--David
----------------------------------------------------
David L. Black, Senior Technologist
EMC Corporation, 176 South St., Hopkinton, MA  01748
+1 (508) 293-7953 **NEW**     FAX: +1 (508) 293-7786
[email-masked]        Mobile: +1 (978) 394-7754
----------------------------------------------------