Subject: RE: Anonymous RFCs (was RE: Formalizing Design Teams)

From: "Harrington, David" <[email-masked]>
Date: Mon, 23 Dec 2002 12:27:50 -0500

Hi,

I'll respond to this, although I am NOT a proponent of anonymous RFCs or I-Ds.

Having a person's name (and especially their company affiliation) on an RFC is a good opportunity for marketing departments to show how the company is a leader in developing industry standards. Having your name on a number of IETF RFCs is also good for one's resume.

The problem is one of basic economics. If a behavior is somehow rewarded, there will be a tendency to behave in a particular way to get those rewards. If we took away the marketing and resume rewards by having your name and affiliation removed from the RFCs, we could presumably minimize the tendency to write RFCs just to get your name and affiliation greater exposure. 

The downside of such an approach is also one of basic economics. Without any promise of the marketing and/or resume rewards, companies will not be motivated to sponsor people to spend months editing IETF documents, and authors will not be motivated to spend their own time editing IETF documents. This is likely to reduce the number of clued-in people who are willing to help design IETF protocols and edit the RFCs documenting the protocols. That's why I am NOT a proponent of anonymous RFCs.

dbh
---
David Harrington            
[email-masked]           
co-chair, IETF SNMPv3 WG

> -----Original Message-----
> From: Pat Calhoun [mailto:[email-masked]]
> Sent: Monday, December 23, 2002 11:52 AM
> To: Andy Bierman
> Cc: James V. Luciani; Carsten Bormann; Eastlake III Donald-LDE008;
> [email-masked]
> Subject: Re: Anonymous RFCs (was RE: Formalizing Design Teams)
> 
> 
> > I would like a proponent of anonymous RFCs to explain to me
> > what problem you are trying to solve by removing the authors
> > names from an I-D when it is published as an RFC.
> 
> Include me on the list, because I don't get it either.
> 
> PatC
> 
> 
>

---

From: Bernard Aboba <[email-masked]>
Date: Mon, 23 Dec 2002 08:58:42 -0800 (PST)

> If we took away the marketing and resume rewards by having your name and
> affiliation removed from the RFCs, we could presumably minimize the
> tendency to write RFCs just to get your name and affiliation greater exposure.

Presumably we could also decide not to take on as WG work items
documents that have little or no technical value? Or publish such
documents if they get out of the WG? Or even to re-charter WGs that
produce such documents?

Remember -- we're not trying to discourage production of all
documents (we're discouraged enough, thank you) -- just *bad* ones.

---

From: "Randy Presuhn" <[email-masked]>
Date: Mon, 23 Dec 2002 10:19:08 -0800

Hi -

My experience in ISO/ITU-land was that the relative anonymity of
the editors had several effects.  Whether these are bugs or features
is an open question.
    1) companies provide support for editors because they care
        about getting a standard, not because of any marketing value.
    2) editors do it because their employers pay them to, and it's
        still something one can put on one's resume.
    3) the editors tend to focus on carrying out the editing instructions,
        and generally don't go on some of the ego trips we've all seen
        in the IETF.
    4) the "technical hot-shots" generally *don't* become editors, because
        the amount of work required to get a change agreed is the same
        whether one is an editor or not, and no one enjoys wrestling
        with MS-word.
    5) the overwhelming majority of the document text comes from the
        working group, rather than the editor.

The dynamic is quite different from the IETF norm.  It demands that the
working group be much more actively engaged in the writing of the
document than is sometimes the case in the IETF.  It also means that
if the WG is *not* actively engaged,  "timeout" rules can kill the project.
It also tends to result in a different sort of participant being chosen as
editor.

Randy

---

From: Melinda Shore <[email-masked]>
Date: Mon, 23 Dec 2002 13:26:06 -0500

> Having a person's name (and especially their company affiliation) on an =
> RFC is a good opportunity for marketing departments to show how the =
> company is a leader in developing industry standards. Having your name =
> on a number of IETF RFCs is also good for one's resume.

And if you work for certain companies, good for one's
pocketbook, too - at least one company offers bonuses to
anyone who has an RFC published with his/her name on it, and
it tends to lead to the sort of behavior you'd expect to
see.

Melinda