Subject: Re: Anonymous RFCs (was RE: Formalizing Design Teams)

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Fri, 20 Dec 2002 13:29:40 -0800

At 12:59 PM 12/20/2002, Eastlake III Donald-LDE008 wrote:
>There are problems here.

Yes.  Personally, I don't support "anonymous" RFCs.  But I do
support listing only "the editor" in the header and giving other
attribution (authorship, etc.) in the body of the document.

>Consider individual submissions, what sense would it be for them to be
>anonymous? And there is really a sort of spectrum from individual sub-
>missions that become Informational or Experimental to individual sub-
>missions that get blessed as standards or BCP by the IESG to WG documents
>that were written/edited almost in their entirety by one person, to WG
>document that were edited/coordinated by one person with pieces of text
>written by many.
>
>Then there are the copyright questions. Currently the IETF does not take
>exclusive rights. Listing editors/authors/contributors makes it clear who
>else has concurrent rights in all or some of the document. And under the
>moral rights laws of many countries, authors might have a legal right to
>require their name to appear somewhere on the document.
>
>All things considered, I think the current arrangement works well enough
>and changes to try to make RFCs anonymous are problematic.
>
>Donald
>
>
>-----Original Message-----
>From: James Luciani [mailto:[email-masked]]
>Sent: Friday, December 20, 2002 3:35 PM
>To: Eastlake III Donald-LDE008; [email-masked]
>Subject: RE: Formalizing Design Teams
>
>I suppose it is too radical to suggest that names (except thank yous) are
>not placed on RFCs at all? During draft, it is necessary to find "editor"
>though.  And if anyone "REALLY" needs to talk with the editor after RFC then
>I am sure there are archives to check on such things.

---

From: Eastlake III Donald-LDE008 <[email-masked]>
Date: Fri, 20 Dec 2002 16:31:31 -0500

In case I wasn't clear, by individual submissions I meant documents
submitted directly to the RFC Editor. I have such submissions intended
to be published as Informational currently pending and have successfully
sumbitted such documents in the past. They are my statements and it
makes no sense to make them anonymous and thus appear to be the voice of
the IETF.

Donald
-----Original Message-----
From: James Luciani [mailto:[email-masked]]
Sent: Friday, December 20, 2002 4:14 PM
To: Eastlake III Donald-LDE008
Cc: [email-masked]
Subject: RE: Anonymous RFCs (was RE: Formalizing Design Teams)

> There are problems here.

The first sentence of the suggestion said, "except during draft stage".
Other than that, what value does having names serve since there are always
archives etc if you need to get in touch.

> document that were edited/coordinated by one person with pieces of text

I find this argument a tad hard to accept since some of the people who
worked on the draft are currently having their names removed at IESG last
call.  LIke I said, put their names in the thank you section if you need
their name there.

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Fri, 20 Dec 2002 13:54:03 -0800

>makes no sense to make them anonymous and thus appear to be the voice of

I thought every RFC was produced by "Network Working Group"...  :-)

Kurt

---

From: Eastlake III Donald-LDE008 <[email-masked]>
Date: Sat, 21 Dec 2002 11:11:05 -0500

No, Network Working Group is the primordial name of the organization
which evolved into the various I* and which has always indicated the
author(s) and their primary affiliation on its publications.

Donald
-----Original Message-----
From: Kurt D. Zeilenga [mailto:[email-masked]]
Sent: Friday, December 20, 2002 4:54 PM
To: Eastlake III Donald-LDE008
Cc: [email-masked]
Subject: RE: Anonymous RFCs (was RE: Formalizing Design Teams)

Kurt

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Sat, 21 Dec 2002 09:12:14 -0800

>author(s) and their primary affiliation on its publications.

For informational/experimental RFCs, are readers to assume the
editor/author speaks for themselves, their primary affiliations,
or one (or more) of the I*?  Does it matter?

Kurt

---

From: "King, Kimberly S." <[email-masked]>
Date: Mon, 23 Dec 2002 12:11:32 -0500

> > I would like a proponent of anonymous RFCs to explain to me
> > what problem you are trying to solve by removing the authors
> > names from an I-D when it is published as an RFC.
> 
> Include me on the list, because I don't get it either.

I bet they will include you on that list, just not at the top of the page.
:-)

---

From: "Lars-Erik Jonsson (EAB)" <[email-masked]>
Date: Mon, 23 Dec 2002 18:54:17 +0100

> > I think it's a question of balancing contribution and
> > reward.  The IETF's current approach maximizes the
> > visbility of the document editor/author, and minimizes
> > that of the working group.  Consequently, individual
> > working group members have less personal investment in
> > the document, and the editor, since his/her name is on
> > it, takes much greater repsonsibility for the content.
> > In other fora, editors simply do the bidding of the
> > working group, and the working group's responsibility
> > is to get it right.  (I know it's supposed to work that
> > way here too, but there's a BIG difference in degree.)
>
> In WGs people come and go. The people that are stuck
> throughout the whole process are the chairs and the
> editors. There is a long term commitment to being an
> editor, and I really do believe that providing them
> credit for their effort is well deserved.

WG's (should) also come and go, while people (at least
some of a few authors) are usually reachable on a much
longer term. Individuals also tend to be much more
concerned about the content and document quality, than
when only a larger "group" (non-individuals) are
collectively responsible for a document. Most people
refuse to be listed as responsible for documents the
do not agree with or can stand up for. What we (as
chairs) should do is to ensure the right people are
listed, i.e. those who have done the work and therefore
both deserve credit and can stand up for the document.

/L-E

---

From: Andy Bierman <[email-masked]>
Date: Mon, 23 Dec 2002 10:43:24 -0800

At 12:27 PM 12/23/2002 -0500, Harrington, David wrote:
>Hi,
>
>I'll respond to this, although I am NOT a proponent of anonymous RFCs or I-Ds.
>
>Having a person's name (and especially their company affiliation) on an RFC is a good opportunity for marketing departments to show how the company is a leader in developing industry standards. Having your name on a number of IETF RFCs is also good for one's resume.
>
>The problem is one of basic economics. If a behavior is somehow rewarded, there will be a tendency to behave in a particular way to get those rewards. If we took away the marketing and resume rewards by having your name and affiliation removed from the RFCs, we could presumably minimize the tendency to write RFCs just to get your name and affiliation greater exposure. 

As I suspected -- the purpose of anonymous RFC authorship is a social
engineering experiment, intended to make people participate in the
IETF for the *right* reasons.  There is no evidence whatsoever that
this would improve the quality or timeliness of technical specifications. 

>The downside of such an approach is also one of basic economics. Without any promise of the marketing and/or resume rewards, companies will not be motivated to sponsor people to spend months editing IETF documents, and authors will not be motivated to spend their own time editing IETF documents. This is likely to reduce the number of clued-in people who are willing to help design IETF protocols and edit the RFCs documenting the protocols. That's why I am NOT a proponent of anonymous RFCs.

I agree.  I don't think the natural tendencies of marketing departments
would be thwarted, even if the author's names were removed.  In fact,
it could have the opposite effect -- now it would be even easier for
companies whose employees had little or nothing to do with the development
of a document to make false marketing claims.

>dbh
>---
>David Harrington            
>[email-masked]           
>co-chair, IETF SNMPv3 WG

Andy

>> From: Pat Calhoun [mailto:[email-masked]]
>> Sent: Monday, December 23, 2002 11:52 AM
>> To: Andy Bierman
>> Cc: James V. Luciani; Carsten Bormann; Eastlake III Donald-LDE008;
>> [email-masked]
>> Subject: Re: Anonymous RFCs (was RE: Formalizing Design Teams)
>> 
>> 
>> PatC

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Thu, 26 Dec 2002 21:17:54 -0500

Nortel certainly does not.

> From: [email-masked] [mailto:[email-masked]] 
> Sent: Thursday, December 26, 2002 12:37 PM
> Cc: 'Melinda Shore'; [email-masked]
> > I tend not to believe this unless you post specifics. 
> Before I worked 
> > for IBM I heard repeated rumors that people there were automaticly 
> > given bonuses for having their name on RFCs. Then I worked 
> for IBM for 
> > 18 months, produced RFCs, and never got a penny. Not only 
> that, when 
> > at IBM, I never heard anything from anyone at IBM, 
> including from my 
> > management, about getting a bonus for such publications. 
> (Of course, I 
> > can't prove there isn't some part of an organization as big as IBM 
> > that does something like this and, at any organization, if your job 
> > descpriton included standards development, having your name on 
> > standards couldn't hurt your reviews.)
> 
> AFAIK Sun doesn't offer such bonuses either.
> 
> 				Ned
> 
>

---

From: "Spencer Dawkins" <[email-masked]>
Date: Fri, 27 Dec 2002 08:14:25 -0600

I think the key is not "dollars for RFCs", but "if your job description includes standards development, your choices at evaluation time are (1) 'I chair this working group', (2) 'I authored these standards', or (3) 'as you can clearly see by grepping the working group archives, I contributed to these standards'".

Surprised that it's more straightforward to say (1) or (2) than (3)?

Spencer