Subject: RE: engineering discipline WAS: stats from the text conferencing experiment

From: "Spencer Dawkins" <[email-masked]>
Date: Tue, 3 Dec 2002 10:16:54 -0600

Comment below...

> -----Original Message-----
> From: Margaret Wasserman [mailto:[email-masked]]
> Sent: Tuesday, December 03, 2002 8:49 AM
> Subject: Re: engineering discipline WAS: stats from the text
> conferencing experiment
> 
> >
> >Most WG members want WG chairs to be "above the fray." In 
> particular, this 
> >means
> >that they do not want WG chairs to have technical opinions 
> about matters 
> >before
> >the WG. Basically, the current popular model of WG chairs is 
> that they are 
> >there
> >to facilitate the process and nothing more.
> 
> Unfortunately, this doesn't match my opinion, or the the stated
> expectations of most of the IESG members that I work with, regarding
> the role of WG chairs...
> 

I chaired a BOF in Atlanta (TRIGTRAN), and I have opinions about how the work should be done, so I'm not entirely objective here, but what I was thinking was, at least one WG chair should care more about getting the work done than s/he cares about which specific decisions are made while doing the work.

If this is true, it may be OK for ONE of the WG chairs to have opinions about which choice is chosen - the phenomenon to avoid is the one where a WG chair is trying to run the meeting while running to the back of the mike line to speak as an individual. If you spend all your time switching hats, you eventually go bald...

Spencer

---

From: Harald Tveit Alvestrand <[email-masked]>
Date: Wed, 04 Dec 2002 10:42:18 +0100

--On tirsdag, desember 03, 2002 10:16:54 -0600 Spencer Dawkins 
<[email-masked]> wrote:

> I chaired a BOF in Atlanta (TRIGTRAN), and I have opinions about how the
> work should be done, so I'm not entirely objective here, but what I was
> thinking was, at least one WG chair should care more about getting the
> work done than s/he cares about which specific decisions are made while
> doing the work.

I think this is a crucial distinction.

The WG Chair(s) should have as their main concern getting the job done well.
"Well" in this case means having working group consensus behind a document 
that is good enough to achieve the aims of the effort.

A chair seeing a way forward to getting the job done shouldn't have to be 
silent about it just because he's chair - but if there's controversy about 
his vision, he needs either a co-chair for that topic or someone else to 
advocate his idea.

But I *never* want to see the case where a chair feels compelled to send 
forward a document for approval that he knows is obviously broken.

                Harald

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 04 Dec 2002 14:39:12 +0100

Harald Tveit Alvestrand wrote:
...
> forward a document for approval that he knows is obviously broken.

I think the real problem is when there is a deep and passionate division 
in the WG about whether something is broken or not, and the chair(s) happen
to be on one side of that division. Chairs are after all humans, not
pieces of furniture, so they will end up in this situation once in
a while. 

In such a case, it's best for the chair(s) to come clean about their
views, and get the AD or other trusted party to act as chair for that 
issue. But the problem can recurse, if the trusted party then also forms a
deep and passionate opinion. This also happens.

Ten years ago, it was still possible for Vint Cerf or Phil Gross to wander
into a WG session and resolve such an issue by gentle persuasion. I
don't think that works any more.

   Brian

---

From: Frank Kastenholz <[email-masked]>
Date: Wed, 04 Dec 2002 09:33:58 -0500

Here's a radical thought.

It seems to me that the problem with w.g. output is
that it's design by committee. We all know that a
camel is a flea that was designed by a committee...

So get rid of the committee-aspect of working groups.
Make them dictatorships. Person X has a "bright idea"
and wants to standardize it. X becomes the main 
technical arbiter for what does and does not go into
the proposal. The working group is there to provide 
feedback and alternative views that X must consider 
but need not adopt. for the most part, the decision is
solely X's. <handwave-mode>Some things that the WG
raises, X must adopt -- where those things are 'critical'
to the Internet architecture/etc</handwave-mode>

The chair of the WG has a couple of roles. First is
simply administrative (asking for meeting slots and so on).
The second is to facilitate orderly discussion in the WG,
keep the group on-charter, and so on. The third role
is as someone who can direct X to do things, when those
things are 'critical bits of internet architecture'
(in other words, the WG Chair is the Keeper Of The
Internet Architecture)

The WG chair can also recommend to the IESG that the WG 
be terminated (or a new X/idea found) if the WG decides
that X is being sufficiently open-minded about listening
to and taking the critique of the working group.  X and the
WG do not have a choice here. In other words, if X goes on 
an ego-trip, the WG chair can shut it down. 

If there are competing visions to doing the same thing,
instead of trying to merge them, then
a) The competing vision gets its own X and its own
   document set, etc, etc -- in effect we create parallel
   efforts
b) Neither effort goes forward as a standards-track document
   but they go as experimental (which they obviously are since
   it's not obvious who the "winner" is). At some point in the
   future the adoption of the ideas can be examined and both 
   can be standardized, one standardized and one historicalized,
   or both historicalized...

Yes, this multitracking is not to vendors liking since we all 
want The One True Standard and all that. But let's face it,
we vendors have been a big contributor to this mess, we should
bear some of the costs of it...

F

---

From: Andy Bierman <[email-masked]>
Date: Wed, 04 Dec 2002 11:32:40 -0800

>So get rid of the committee-aspect of working groups.

This goes against the very concept of "open standards".
If we wanted proprietary solutions rubber-stamped as
standards then your approach would be appropriate.
I would rather see us improve the way committees operate
in the IETF.

>and wants to standardize it. X becomes the main 

WG chartered efforts are limited. Who decides which 'person X'
gets to use the WG as their rubber-stamp tool? What about the
concept of rough consensus? What if the WG doesn't support
the decisions of person X?

>(in other words, the WG Chair is the Keeper Of The

The most important role of the WG Chair is to be the technical
arbiter for the output of the WG.  The document author is the
last person who should be given this role.  This is an obvious
conflict of interest.

>   or both historicalized...

These are overly expensive solutions compared to the traditional path
of open debate and cooperation.  Shutting down a WG and starting over
is not going to improve quality and timeliness.

>bear some of the costs of it...

Andy

---

From: Randy Bush <[email-masked]>
Date: Wed, 04 Dec 2002 13:40:15 -0800

> standards then your approach would be appropriate.

uh, i missed where he said anything about proprietary
solutions, rubber stamps, closed standards , ...

seems to me frank is just rediscovering what was called
the "lead programmer team" back in the seventies, likely
as an attempt to produce less camels.  

i suspect this idea has other problems, but the ones you
characterize seem inappropriate to me.

randy

---

From: Andy Bierman <[email-masked]>
Date: Wed, 04 Dec 2002 14:08:29 -0800

>characterize seem inappropriate to me.

I think the notion of placing a document author in charge
of the standards process for that document will lead to
closed, rubber-stamped standards.  This idea would give
the author too much power.  The author could effectively
say "agree with me or we'll end up shutting down the WG
or wasting a lot of time starting up and then choosing
between alternative proposals."  In all but the most
monumental, show-stopper deadlocks, the WG will let the
author/dictator win every time, rather than face
a restart or shutdown situation.

Andy

---

From: "Dean Willis" <[email-masked]>
Date: Wed, 4 Dec 2002 18:51:11 -0600

Frank said:
> we vendors have been a big contributor to this mess, we 
> should bear some of the costs of it...
> 
> F

Sheesh, I though that was what we were doing now. At least it describes
my own philosophy of chairing fairly accurately. In the groups I'm
active in that actually move, we usually have several such Xs working,
and their work progresses if they can convince enough of the WG to go
along (I think of it as "critical mass influencing a benevolent
dictatorship"). Sometimes the critical mass overrules the dictator (we
DO still have forking in SIP, despite my repeated attempts to convince
the world otherwise). We often have parallel efforts -- sometimes they
converge, sometimes they don't and we have to deal with it. Moderately
divergent stuff may get published as individual informationals "reviewed
by the WG". Truly divergent ideas often get booted via "scope
management" and creative use of the charter.

Sometime back, we had a couple of divergent approaches to instant
messaging and presence pop up that weren't going to reconcile. We moved
forward by setting up interop and security requirements and then running
different WGs for each divergent implementation idea. As it worked out,
a couple of groups died, one group published something beautiful that
nobody used, and the other group is still working on it. Of course, that
has its problems -- a NEW group is now working in the same area, they
don't want to be constrained by the interop and security requirements
established to govern the earlier diaspora, and the surviving "old
group" is basically saying "Hey, you made US jump through those hoops,
we're going to be mad if we get screwed because you don't make the new
guys do it too!" I think some sort of consistency in the oversight
policy is needed.

Sometimes, it doesn't hurt to have multiple standards that "sortof do
the same thing" as long as they don't clobber each other. Look at POP3
and IMAP4, for instance. Do you know which one I use? Do you really
care? How about forks and chopsticks? The trick is discovering exactly
when such diversity is appropriate, and I'm afraid that is usually a
market decision, not an engineering one.

--
Dean