Subject: RE: engineering discipline WAS: stats from the text conferencing experiment

From: [email-masked]
Date: Sun, 1 Dec 2002 21:26:34 +0200

Hi Margaret,

> As bodies grow, it is usual for the central "government" to have
> fewer and fewer duties...  Which duties have remained with the
> executive committee in the IEEE?  Who does the rest of the work
> that the IESG currently does in the IETF?

Thinking about this a bit and having some discussions with folks
around in Atlanta, one reasonable approach would be to have a 
specified division of powers between IAB and IESG, for example.
One could define certain policies (policies on protocol extensibility,
for example) while the other one carries out the policy (i.e. - 
ensure that protocols don't excede protocol extensibility).  
This could be a reasonable approach, as it would require that
policies be documented and that then ignorance of documented
policies is no excuse.

Just a thought.

John

---

From: Yakov Rekhter <[email-masked]>
Date: Mon, 02 Dec 2002 11:45:06 -0800

Randy,

> we, as individuals, have to be willing to stand up and say "sorry,
> but that makes me uneasy.  

Sure. After all, making everyone "easy" is a non-goal.

> is it *really* necessary?  

That is certainly *not* for the IESG to decide, as whether a
particular technology is *really* necessary is determined by the
marketplace (unless the IESG wants to play the role of the Politburo
for the TCP/IP-based technologies).

> is it clearly the simplest and best way to meet a real need?"

Ditto.

Yakov.

---

From: [email-masked]
Date: Mon, 2 Dec 2002 22:03:32 +0200

Marshall,

> > but that makes me uneasy.  is it *really* necessary?  is it clearly
> > the simplest and best way to meet a real need?"
> 
> randy - at the risk of speaking plainly: if the iesg would simply make
> statements like this in a timely, open fashion (i.e., explain 
> their reasoning), then i doubt there would be any meaningful pushback.

No matter what, there would be pushback - meaningful probably depends
on which end your are at.

> a great deal of the perceived problems come from a lack of either timeliness
> ("let's sit on it until they go away") or less-than-openness 
> ("let's say no, but not tell them why").

Let's that this kind of behavior gives rise to conspiracy theories.
 
John

---

From: "Steven M. Bellovin" <[email-masked]>
Date: Mon, 02 Dec 2002 18:43:39 -0500

In message <[email-masked]>, Erik Guttman writes:
>Steven M. Bellovin wrote:

>WG chairs who are also document author/editors obviously should not
>have the power to silence debate.  (One could argue WG chairs should not
>be document author/editors in the first place.  Like it or not, this
>configuration sees a large fraction of the work in the IETF through.)
>
I haven't done a census of WGs to see where that's the case, but it's 
actively discouraged by the IESG and by 2418:

6.3. Document Editor

   ...
   
   As a general practice, the Working Group Chair and Document Editor
   positions are filled by different individuals to help ensure that the
   resulting documents accurately reflect the consensus of the working
   group and that all processes are followed.

		--Steve Bellovin, http://www.research.att.com/~smb (me)
		http://www.wilyhacker.com ("Firewalls" book)

---

From: "Presuhn, Randy" <[email-masked]>
Date: Mon, 2 Dec 2002 17:02:55 -0600

Hi -

> From: Melinda Shore [mailto:[email-masked]]
> Sent: Monday, December 02, 2002 14:51
> To: Erik Guttman
> Cc: [email-masked]
> Subject: Re: engineering discipline WAS: stats from the text
> conferencing experiment
...
> >- The best way would be publishing only anonymous RFCs.
>
> I've thought about that quite a bit.  In addition to the
> problems you highlight it might discourage land rush
> behavior when a new working group is formed.  At the same
> time, it's hard enough to get volunteers to do work as it
> is.  I'm not sure that it's true that dedicated smart people
> would be just as willing to pitch in if they didn't get
> their names on documents.
...

I think the experience in ISO / ITU demonstrates that one *can*
get smart people to do the editing without giving them the kind
of recognition that comes from having one's name on an RFC.
Perhaps not the same people as would volunteer in the IETF,
but this may be a feature rather than a bug.

 ------------------------------------------------------
 Randy Presuhn          BMC Software, Inc.  1-3141
 [email-masked]  2141 North First Street
 Tel: +1 408 546-1006   San José, California 95131  USA
 ------------------------------------------------------
 My opinions and BMC's are independent variables.
 ------------------------------------------------------

---

From: Margaret Wasserman <[email-masked]>
Date: Tue, 03 Dec 2002 11:34:15 -0500

>
>If this is true, it may be OK for ONE of the WG chairs to have opinions 
>about which choice is chosen - the phenomenon to avoid is the one where a 
>WG chair is trying to run the meeting while running to the back of the 
>mike line to speak as an individual. If you spend all your time switching 
>hats, you eventually go bald...

There is a balancing act that we need to play here...

I agree that it isn't right for the WG chair to put forth his own ideas, and
to block other ideas.  However, I do think that WG chairs should consider
themselves responsible for ensuring that their groups product technically
sound and useful work.

Note that there may be multiple technically sound and useful proposals,
and it is the WGs job to choose between them (or merge them or whatever),
but I think it is the WG chairs job to make sure that the end result
is technically sound and useful.  Clearly this is a judgement call, and
I think that it is our job to use our judgement in that matter.

Margaret

---

From: "Spencer Dawkins" <[email-masked]>
Date: Wed, 4 Dec 2002 16:45:26 -0600

If I got the drift from Frank's note, the idea was that we have experimental RFCs, not standards, when we can't agree on one alternative.

Spencer 

> -----Original Message-----
> From: Andy Bierman [mailto:[email-masked]]
> Sent: Wednesday, December 04, 2002 4:08 PM
> To: Randy Bush
> Cc: Frank Kastenholz; [email-masked]
> Subject: RE: engineering discipline WAS: stats from the text
> conferencing experiment
> 
> I think the notion of placing a document author in charge
> of the standards process for that document will lead to
> closed, rubber-stamped standards.  This idea would give
> the author too much power.  The author could effectively
> say "agree with me or we'll end up shutting down the WG
> or wasting a lot of time starting up and then choosing
> between alternative proposals."  In all but the most
> monumental, show-stopper deadlocks, the WG will let the
> author/dictator win every time, rather than face
> a restart or shutdown situation.
> 
> 
> >randy
> 
> Andy
> 
> 
> 
>

---

From: "Spencer Dawkins" <[email-masked]>
Date: Wed, 4 Dec 2002 17:16:16 -0600

Sorry - I should have kept typing - 

and one of the things we talked about in Atlanta was the desirability of using Experimental as a jumping-off point to Proposed Standard. 

The recently-approved ABC draft includes an IESG note that says "this is Experimental, because it's TCP and we hate it when the Internet collapses, but if we get deployment experience that ABC DOESN'T collapse the Internet, we'll put it on the standards track" (the actual text is more formal, but you get the idea).

Do we have a common view as to whether this is a good thing (based on the observation that many RFCs don't move past Proposed Standard, no matter how widely deployed the technology)?

Spencer

> From: Spencer Dawkins 
> Sent: Wednesday, December 04, 2002 4:45 PM
> To: [email-masked]
> If I got the drift from Frank's note, the idea was that we 
> have experimental RFCs, not standards, when we can't agree on 
> one alternative.
> 
> Spencer 
>

---

From: [email-masked]
Date: Wed, 4 Dec 2002 17:45:43 -0600

> 
> Do we have a common view as to whether this is a good thing 
> (based on the observation that many RFCs don't move past 
> Proposed Standard, no matter how widely deployed the technology)?

I think that the experimental RFC route is a good thing and one that
allows protocols that are actually useful and have been *experimented*
with (which provides a lot more understanding of its behavior than
a PS stamp would). The current process of the IETF which moves RFCs
from PS to DS is ineffective. So either we change the process or we
simply agree that PS is as good as it gets and hence anything else 
should be experimental until proven otherwise.

> Spencer

-Basavaraj

---

From: "Spencer Dawkins" <[email-masked]>
Date: Thu, 5 Dec 2002 09:34:21 -0600

To echo Jonathan's comment - I've been joking that the TRIGTRAN BoF started on Sunday afternoon when Carl and I were standing in the registration line and continued without a break until Wednesday. This actually worked really well for us - and we made significant changes to what we thought the problem statement was, based on lots of one-on-one and small-group conversations during that 72 hours. So I'd say we did more work outside the meeting than during the meeting...

Spencer

> From: Jonathan Rosenberg [mailto:[email-masked]]
> Sent: Wednesday, December 04, 2002 10:31 PM
> To: Pat Calhoun
> Cc: Andy Bierman; James Kempf; Erik Guttman; Frank Kastenholz; Bernard
> Aboba; Randy Bush; Marshall Rose; [email-masked]
> Pat Calhoun wrote:
> >><rant>
> >>In my experience in the IETF, no significant standard has 
> ever been completed
> >>without at least one multi-day interim meeting. IMO, the 
> easiest way to improve
> >>quality and timeliness is to acknowledge the importance of 
> these face to face
> >>meetings.  The current IETF meeting format (e.g., 2 hours * 
> 3 times a year)
> >>is a joke.  The only useful purpose they serve is as a 
> document revision deadline.
> >></rant>
> > 
> > I have to agree. Let's face it, once people leave the IETF 
> meeting, they
> > get busy, and there is rarely a pressing need (or pressure) 
> to get work
> > completed before the next meeting. Having regular interim 
> meetings (ala
> > 802) would certainly help in shortening the process.
> 
> I agree as well. In fact, I have noticed an increasing trend in my 
> groups to use the IETF itself as the "interim meeting". That is, more 
> time at IETF is spent in design team meetings than in the sessions 
> themselves. After all, everyone is at the IETF, what better 
> time to hold 
> meetings for the various design teams?
> 
> -Jonathan R.
> -- 
> Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
> Chief Scientist                             First Floor
> dynamicsoft                                 East Hanover, NJ 07936
> [email-masked]                     FAX:   (973) 952-5050
> http://www.jdrosen.net                      PHONE: (973) 952-5000
> http://www.dynamicsoft.com
> 
>