Subject: RE: WG Chairs' training/information/resources?

From: "Spencer Dawkins" <[email-masked]>
Date: Tue, 3 Dec 2002 08:58:39 -0600

OK, my memory IS returning - I'm remembering the "all RFCs must have security sections" discussion in Atlanta (Scott Bradner was talking - I'm THINKING we had this conversation in IPR). Sounds like a reasonable requirement, but does it apply to BCP-track procedural RFCs? 

This was the kind of "deltas in procedure" I was thinking about - we may not have changes in procedures between every pair of IETFs, but when we do, I'm not sure where they are either discussed (outside of IESG?) or announced (so that WG chairs can conform to them proactively).

Spencer

> -----Original Message-----
> From: Harald Tveit Alvestrand [mailto:[email-masked]]
> Sent: Tuesday, December 03, 2002 2:01 AM
> To: [email-masked]
> Subject: WG Chairs' training/information/resources?

[deleted down to]

> 
> - focus on providing info on deltas in procedure (changes 
> since last IETF) 
> to WG chairs, either using this list or using workshops at 
> the IETF or both
> 
> 
> thoughts?
> 
>                 Harald
> 
>

---

From: Harald Tveit Alvestrand <[email-masked]>
Date: Tue, 03 Dec 2002 16:35:38 +0100

--On tirsdag, desember 03, 2002 08:58:39 -0600 Spencer Dawkins 
<[email-masked]> wrote:

> OK, my memory IS returning - I'm remembering the "all RFCs must have
> security sections" discussion in Atlanta (Scott Bradner was talking - I'm
> THINKING we had this conversation in IPR). Sounds like a reasonable
> requirement, but does it apply to BCP-track procedural RFCs?

yes, it does. Some BCPs impact security, but not all.
It's easier to add a section that explains why it doesn't affect security 
than to make exceptions to that particular rule. IMHO, at least.

> This was the kind of "deltas in procedure" I was thinking about - we may
> not have changes in procedures between every pair of IETFs, but when we
> do, I'm not sure where they are either discussed (outside of IESG?) or
> announced (so that WG chairs can conform to them proactively).

the IESG has tried to remember to announce policy documents on 
ietf-announce....

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 03 Dec 2002 17:38:53 +0100

Harald Tveit Alvestrand wrote:
...
> the IESG has tried to remember to announce policy documents on

I'm sure you have. However, I remember discovering experimentally 
that the RFC Editor wanted Normative and Informative references 
separated, before any announcement had been made. It was even during 
an Authors' 48 I think, which was certainly a late surprise. This isn't 
a complaint, just an observation that procedural changes shouldn't 
be implemented before they've been agreed and announced.

  Brian

---

From: Bill Sommerfeld <[email-masked]>
Date: Tue, 03 Dec 2002 14:00:41 -0500

> It was even during an Authors' 48 I think, which was certainly a
> late surprise. This isn't a complaint, just an observation that
> procedural changes shouldn't be implemented before they've been
> agreed and announced.

Not to mention having some way to grandfather documents "in flight"
where appropriate..

						- Bill