Subject: RE: Anonymous RFCs (was RE: Formalizing Design Teams)

From: "James V. Luciani" <[email-masked]>
Date: Sat, 21 Dec 2002 10:18:07 -0500

Wow... this is frightening.  So you feel that Informational RFC should be a 
form of legalized self aggrandizement?

At 04:31 PM 12/20/02 -0500, Eastlake III Donald-LDE008 wrote:
>In case I wasn't clear, by individual submissions I meant documents
>submitted directly to the RFC Editor. I have such submissions intended
>to be published as Informational currently pending and have successfully
>sumbitted such documents in the past. They are my statements and it
>makes no sense to make them anonymous and thus appear to be the voice of
>the IETF.
>
>Donald
>-----Original Message-----
>From: James Luciani [mailto:[email-masked]]
>Sent: Friday, December 20, 2002 4:14 PM
>To: Eastlake III Donald-LDE008
>Cc: [email-masked]
>Subject: RE: Anonymous RFCs (was RE: Formalizing Design Teams)
>
> > There are problems here.
>
>The first sentence of the suggestion said, "except during draft stage".
>Other than that, what value does having names serve since there are always
>archives etc if you need to get in touch.
>
> > Consider individual submissions, what sense would it be for them to be
> > anonymous? And there is really a sort of spectrum from individual sub-
> > missions that become Informational or Experimental to individual sub-
> > missions that get blessed as standards or BCP by the IESG to WG documents
> > that were written/edited almost in their entirety by one person, to WG
> > document that were edited/coordinated by one person with pieces of text
> > written by many.
>
>I find this argument a tad hard to accept since some of the people who
>worked on the draft are currently having their names removed at IESG last
>call.  LIke I said, put their names in the thank you section if you need
>their name there.
>
> > Then there are the copyright questions. Currently the IETF does not take
> > exclusive rights. Listing editors/authors/contributors makes it clear who
> > else has concurrent rights in all or some of the document. And under the
> > moral rights laws of many countries, authors might have a legal right to
> > require their name to appear somewhere on the document.
> >
> > All things considered, I think the current arrangement works well enough
> > and changes to try to make RFCs anonymous are problematic.
> >
> > Donald
> >
> >
> > -----Original Message-----
> > From: James Luciani [mailto:[email-masked]]
> > Sent: Friday, December 20, 2002 3:35 PM
> > To: Eastlake III Donald-LDE008; [email-masked]
> > Subject: RE: Formalizing Design Teams
> >
> > I suppose it is too radical to suggest that names (except thank yous) are
> > not placed on RFCs at all? During draft, it is necessary to find "editor"
> > though.  And if anyone "REALLY" needs to talk with the editor
> > after RFC then
> > I am sure there are archives to check on such things.
> >

---

From: "James V. Luciani" <[email-masked]>
Date: Sat, 21 Dec 2002 18:14:17 -0500

I must have missed that part in my IETF orientation class 10 years ago when 
they talked about the reasons for publishing an RFC as having to do with 
compensation.

As for "pointless", I have frequently observed that name calling (either 
toward an idea or a person) occurs when someone is not able to sustain 
their position through other means.

In any case, I concede.

At 05:11 PM 12/21/02 +0100, Carsten Bormann wrote:
>>Wow... this is frightening.  So you feel that Informational RFC should be 
>>a form of legalized self aggrandizement?
>
>We have a shorter word for "legalized self aggrandizement", it's called 
>"literature".
>Actually a cornerstone for what we call "culture", "science", etc.
>
>Again, the point is that removing the author list from RFCs takes away 
>some form of compensation for the work put into them.
>Economic theory would suggest that removing this compensation will cause 
>less work put into them, in particular work from those who do not receive 
>any other compensation (such as return on patents, which is exactly what 
>we don't want to be the remaining motivation).
>In the problem statement group, the underlying theme of many proposals is 
>"get clued people to do more work".
>(The fact that this change also would reduce motivation for those people 
>who are not qualified to write an RFC makes a rather curious argument.)
>
>I actually like the inverse argument: If you actually manage to get an 
>incompetent RFC published under your name, you can't get rid of it for the 
>rest of your life.  You'll have to change your name.
>
>(And, as another data point, Donald was right -- according to German 
>"Urheberrecht" I have certain rights in any non-trivial work I actually 
>can't even give up, including the right to be named as an author.
>Whether I would want to exercise them is another issue, of course.)
>
>I think it would help to terminate this entirely pointless discussion.
>
>Gruesse, Carsten

---

From: Andy Bierman <[email-masked]>
Date: Sat, 21 Dec 2002 17:03:02 -0800

At 06:14 PM 12/21/2002 -0500, James V. Luciani wrote:
>I must have missed that part in my IETF orientation class 10 years ago when they talked about the reasons for publishing an RFC as having to do with compensation.
>
>As for "pointless", I have frequently observed that name calling (either toward an idea or a person) occurs when someone is not able to sustain their position through other means.
>
>In any case, I concede.

I would like a proponent of anonymous RFCs to explain to me
what problem you are trying to solve by removing the authors
names from an I-D when it is published as an RFC.

thanks,
Andy

>>>Wow... this is frightening.  So you feel that Informational RFC should be a form of legalized self aggrandizement?
>>
>>We have a shorter word for "legalized self aggrandizement", it's called "literature".
>>Again, the point is that removing the author list from RFCs takes away some form of compensation for the work put into them.
>>Economic theory would suggest that removing this compensation will cause less work put into them, in particular work from those who do not receive any other compensation (such as return on patents, which is exactly what we don't want to be the remaining motivation).
>>In the problem statement group, the underlying theme of many proposals is "get clued people to do more work".
>>(The fact that this change also would reduce motivation for those people who are not qualified to write an RFC makes a rather curious argument.)
>>
>>I actually like the inverse argument: If you actually manage to get an incompetent RFC published under your name, you can't get rid of it for the rest of your life.  You'll have to change your name.
>>
>>(And, as another data point, Donald was right -- according to German "Urheberrecht" I have certain rights in any non-trivial work I actually can't even give up, including the right to be named as an author.

---

From: "Randy Presuhn" <[email-masked]>
Date: Sun, 22 Dec 2002 20:34:47 -0800

Hi -

> From: "Andy Bierman" <[email-masked]>
> To: "James V. Luciani" <[email-masked]>
> Cc: "Carsten Bormann" <[email-masked]>; "Carsten Bormann" <[email-masked]>;
"Eastlake III Donald-LDE008" <[email-masked]>;
<[email-masked]>
> Sent: Saturday, December 21, 2002 5:03 PM
> Subject: Re: Anonymous RFCs (was RE: Formalizing Design Teams)
...
> names from an I-D when it is published as an RFC.
...

Though I couldn't support making RFCs in general anonymous, I do
like the idea of standards-track publications being credited to the
working group or area that produced them.

I think it's a question of balancing contribution and reward.  The IETF's
current approach maximizes the visbility of the document editor/author,
and minimizes that of the working group.  Consequently, individual working
group members have less personal investment in the document, and the
editor, since his/her name is on it, takes much greater repsonsibility for
the content.  In other fora, editors simply do the bidding of the working
group, and the working group's responsibility is to get it right.  (I know
it's supposed to work that way here too, but there's a BIG difference
in degree.)

(One might also comment on how author lists are sometimes developed,
but I don't want to go into that particular snake-pit just now.)

Randy

---

From: Pat Calhoun <[email-masked]>
Date: 23 Dec 2002 08:51:55 -0800

> names from an I-D when it is published as an RFC.

Include me on the list, because I don't get it either.

PatC

---

From: Pat Calhoun <[email-masked]>
Date: 23 Dec 2002 08:55:36 -0800

> it's supposed to work that way here too, but there's a BIG difference

In WGs people come and go. The people that are stuck throughout the
whole process are the chairs and the editors. There is a long term
commitment to being an editor, and I really do believe that providing
them credit for their effort is well deserved.

btw, it's also a good way to attract talent.

PatC

---

From: Carsten Bormann <[email-masked]>
Date: Sat, 21 Dec 2002 17:11:15 +0100

> Wow... this is frightening.  So you feel that Informational RFC should
> be a form of legalized self aggrandizement?

Again, the point is that removing the author list from RFCs takes away
some form of compensation for the work put into them.
Economic theory would suggest that removing this compensation will
cause less work put into them, in particular work from those who do not
receive any other compensation (such as return on patents, which is
exactly what we don't want to be the remaining motivation).
In the problem statement group, the underlying theme of many proposals
is "get clued people to do more work".
(The fact that this change also would reduce motivation for those
people who are not qualified to write an RFC makes a rather curious
argument.)

I actually like the inverse argument: If you actually manage to get an
incompetent RFC published under your name, you can't get rid of it for
the rest of your life.  You'll have to change your name.

Gruesse, Carsten