Subject: RE: engineering discipline WAS: stats from the text conferencin g experiment

From: "Presuhn, Randy" <[email-masked]>
Date: Tue, 3 Dec 2002 13:39:30 -0600

Hi -

> From: Brian E Carpenter [mailto:[email-masked]]
> Sent: Tuesday, December 03, 2002 08:27
> To: [email-masked]
> Subject: Re: engineering discipline WAS: stats from the text
> conferencing experiment
...
> They also need a lot of technical breadth, because actually
> the chairs
> are the first line of defence against ideas that look good at first
> sight but happen to be broken. If the chairs spot this, there are
> ways of making the idea go away (like no agenda time, no draft-ietf-*
> filename, and "outside charter" closedowns on email threads). If the
> chairs let a broken idea through, it develops a life of its own.
...

The good/broken dichotomy contributes to our difficulties, I think.
Even if something is technically sound, useful, and within the broad
scope of a working group's charter, it still doesn't necessarily make
sense to expend the effort to make it a standard or even a BCP.  The
good news is that if there isn't sufficient need/interest, the threads
*usually* die on their own.  I think it makes sense to be generous in
permitting topics to come up for discussion, but much stricter in
taking something on as a work item.  To those who persistently push
their pet projects, we need to be able to say "no" for legitimate
reasons other than "out of charter", "it's broken" or "you have no
clue."  The "why do we need to standardize this" question does not
get asked as often as it should.

 ------------------------------------------------------
 Randy Presuhn          BMC Software, Inc.  1-3141
 [email-masked]  2141 North First Street
 Tel: +1 408 546-1006   San José, California 95131  USA
 ------------------------------------------------------
 My opinions and BMC's are independent variables.
 ------------------------------------------------------

---

From: Eastlake III Donald-LDE008 <[email-masked]>
Date: Wed, 4 Dec 2002 13:22:23 -0500

I don't know why you way that IEEE specification don't have explicitly authored specifications. While it's not on the front page, at least in IEEE 802.11, specifications list the working group and task group officers, including the "editor", who would be called the "author" in the IETF, in bold face type. They also list "contributors", around 60 people for the current 802.11i draft, with less prominence. IEEE 802 makes a big deal out of getting a standard through the whole process, giving out plaques, etc.

Donald

-----Original Message-----
From: James Kempf [mailto:[email-masked]]
Sent: Tuesday, December 03, 2002 11:54 AM
To: Erik Guttman; Andy Bierman
Cc: Frank Kastenholz; Bernard Aboba; Randy Bush; Marshall Rose;
[email-masked]

> I disagree strongly with this approach. Author credit is also
> author accountability.  It's hard enough to get WG authors to
> make frequent updates and address every detail and I-D nit as it is.
> Maintaining technical quality and finishing on time will be much
> harder to achieve if there's no author accountability.
>

This certainly hasn't been the case with other standards groups that don't have
explicitly authored specifications. The technical quality of IEEE specifications
tends to be high, and that's also the case for 3GPP specifications, regardless
of one's opinion on 3GPP's underlying architecture. Getting rid of authored
specifications would also remove the incentive for companies to require authored
drafts as part of people's performance evaluations, and the tendency in some
quarters to view IETF meetings as equivalent to technical conferences, where the
authors give research papers.

That said, the RFC series is really set up to be much like an authored
publication process, and changing this underlying assumption would be a big
deal.

            jak