Subject: RE: Response requested: Proposal regarding milestones

From: "King, Kimberly S." <[email-masked]>
Date: Thu, 12 Dec 2002 14:14:25 -0500

> Response requested: Working group chairs that feel that this 
> would be a
> wise change to our procedures, please say so. 

This sounds fine to me.  The only difficulty could be the additional work in
(d) created for the secretariat to keep up with milestones and email to
chairs/ADs but this could be somewhat automated.

Kimberly

---

From: "Presuhn, Randy" <[email-masked]>
Date: Thu, 12 Dec 2002 17:11:14 -0600

Hi -

> From: Fred Baker [mailto:[email-masked]]
> Sent: Thursday, December 12, 2002 13:34
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: Response requested: Proposal regarding milestones
...
> As to AD comments "hat on", I can argue myself a couple of 
> directions. As a
> document author/editor, I often get private emails from folks 
> saying "I
> found the following 18 spelling errors and other nits" or 
> "would that <x>
> were true about your document". I send nits privately and appreciate
> receiving them privately. Substantive comments on drafts in 
> progress, I
> think, are statements to the working group, not the author, 
> regardless of
> who sends them. IMHO, they should get sent to the list so 
> that they can be
> discussed and edited into the document as consensus develops.
> Meta-comments, I would argue, always belong on the list.
...

Both as a WG chair and as a document editor, I strongly prefer
that *ALL* comments (including "nits" and AD or IESG feedback)
be sent to the working group mailing list.  It's a simple matter
of fairness and transparency.

The recent brouhaha over the title of the informational RFC-to-be
introducing SNMP amply demonstrates that even the most well-
intentioned and seemingly benign editorial change has the
potential to cause grief.

It'd be interesting to see what would happen if WGs were
apprised of AUTH-48 goings-on.

 ------------------------------------------------------
 Randy Presuhn          BMC Software, Inc.  1-3141
 [email-masked]  2141 North First Street
 Tel: +1 408 546-1006   San José, California 95131  USA
 ------------------------------------------------------
 My opinions and BMC's are independent variables.
 ------------------------------------------------------

---

From: [email-masked]
Date: Fri, 13 Dec 2002 14:58:43 -0500

On Fred's original proposals:

(a) Show original and completed dates for WG milestones.

The completed dates are a Good Idea, as they would
indicate when the "Done" events happened, which is both
useful and impossible to determine from the currently displayed
info.  I'm a bit less sure about showing the original dates,
as there are a variety of reasons for schedule change.

(b) Figure out and deploy a better update process.

I'd like to hear from the ADs and Secretariat about whether what
we have is broken.  If a web form would take load off the over-
burdened Secretariat, I'm all in favor.  OTOH, I'd definitely
been operating in the "nobody seems to care, don't bother the ADs
as they have more important things t worry about" domain ...
until both of my ADs pinged me on milestone updates earlier this
week, with the result that updates for both of my WGs are now in
the mail queue at the Secretariat, complete with AD approval.

(c) WG without milestones cannot meet.

Might be overkill -- as an alternate, we could consider such
a WG to be a virtual BOF and use the BOF scheduling process/
priority for its meeting time requests.

     WG with milestones gets automatic approval of meeting requests,
     possibly without AD involvement.

Did I miss something here?  I thought the first meeting slot
was already scheduled in this fashion with AD notification, but
no requirement for approval.  I think AD notification is important
(helps the ADs track what's going on), ditto AD approval for any
WG that wants more than one meeting slot (puts the ADs "in the
loop" for resource management of scarce meeting time).

(d) Secretariat should ping WG Chair as milestone dates are reached.

Ok.

Thanks,
--David

---

From: [email-masked]
Date: Thu, 19 Dec 2002 22:12:34 +0200

Hi Melinda,

> > The company who can get their employees into the meeting / on the
> > list wins.
> 
> Part of the idea behind consensus process is that it
> provides a means for synthesis that voting does not, and
> that because of that it produces better-quality results.
> Voting is less process-y.

Further more, voting does not make a proposal technically 
correct.  Voting would bring a whole mess of other problems,
in my opinion - what is a majority (50 %, 66%) - how to
measure it?  Who asks the questions for voting?  Does anyone
have veto power?  What about overrides?  I do not think 
voting would add anything.

John

---

From: [email-masked]
Date: Thu, 19 Dec 2002 22:22:48 +0200

James,

> as opposed to the company who can get their employees as 
> chairs or ADs or... if we go down that path of FUD then we all 
> ought to give up.

Do you think that this is a problem now, packing of the chairs
& the ADs?  I haven't really noticed this.  However, I have
noted in other SDOs that do vote a tendancy for companies 
to try to stack the deck when it comes to voting. This is
something that I hope does not happen explicitly in the IETF.
 
> besides, you can make that argument now.

You could, but I don't agree with it. I would say that active
participation in draft writing and contributing is still the
primary mode we are working in.  I would rather have work 
progress because people are commited to getting the work
done, then taking votes.

John

---

From: Jonathan Trostle <[email-masked]>
Date: Thu, 19 Dec 2002 17:00:09 -0500 (EST)

Sounds reasonable.

Jonathan

---

From: [email-masked]
Date: Fri, 20 Dec 2002 06:11:18 +0200

Hi Margaret,

> So, which of the following jobs would you assign to a WG chair:
> 
>          (1) Drive the process to produce the best technical
>                  result, and send that result to the IESG, or
>          (2) Manage a process that is driven by the consensus
>                  of the WG, make sure that the documents
>                  pass ID-nits, and send the consensus result
>                  to the IESG?
> 
> I used to think that we were supposed to do (2), but I've recently
> been told by my ADs that I should be doing more of (1).  Maybe
> the correct balance is somewhere in between?

I think we should all be doing (1) as long as we don't run over 
consensus in the process.  It isn't so much unlike most of our 
day jobs, if we are working a product, we don't try to achieve
consensus with our co-workers as the primary result, but creating
a compelling product is the goal.  As WG chairs, our goals should
be creating compelling products (i.e. - RFCs).

John

---

From: "Spencer Dawkins" <[email-masked]>
Date: Fri, 20 Dec 2002 08:42:54 -0600

OK, I wasn't there, so ... I'm wondering if there are other anecdotes about ways that IETF has dealt with several competing proposals that we would be proud to use as precedents?

Marshall shared the SGMP v. CMIP v. HEMS story. Others?

Spencer

---

From: "Harrington, David" <[email-masked]>
Date: Fri, 20 Dec 2002 10:39:20 -0500

Hi,

I'm not sure I understand what picking at old wounds gains us. If we want to compare war stories, then let's include discussion of how the problem was resolved successfully. Let's not dig up buried hatchets.

dbh
---
David Harrington            
[email-masked]           
co-chair, IETF SNMPv3 WG

> -----Original Message-----
> From: Margaret Wasserman [mailto:[email-masked]]
> Sent: Friday, December 20, 2002 10:27 AM
> To: Spencer Dawkins
> Cc: [email-masked]
> Subject: RE: Response requested: Proposal regarding milestones
> 
> 
> 
> 
> Well, there were several versions of IPng and one was picked
> to become the next generation Internet protocol (IPv6).  I
> wasn't around for that choice...  I don't think it went
> very smoothly, but maybe the results were okay?
> 
> There was also a conflict between IS-IS and OSPF at some
> point.  Today we have both, which doesn't seem like a bad
> outcome...
> 
> I can't think of any other _big_ choices, but I'm sure that
> there must have been some in areas that I don't frequent.
> 
> Margaret
> 
> 
> 
> 
>

---

From: "Spencer Dawkins" <[email-masked]>
Date: Fri, 20 Dec 2002 09:39:23 -0600

OK, Margaret has already identified two scenarios (if I remember correctly) - wasn't there a Highlander moment for IPng ("there can be only one"), where people showed up with SIPP, TUBA, etc?

And this is not what we did with OSPF/IS-IS/RIP2 (if http://www.ietf.org/html.charters/OLD/ripv2-charter.html means what I think it does).

Others?

Spencer

> Sent: Friday, December 20, 2002 9:27 AM
> To: Spencer Dawkins
> Cc: [email-masked]

---

From: "Spencer Dawkins" <[email-masked]>
Date: Fri, 20 Dec 2002 09:41:59 -0600

Yes, definitely. My original request was 

> OK, I wasn't there, so ... I'm wondering if there are other 
> anecdotes about ways that IETF has dealt with several 
> competing proposals that we would be proud to use as precedents?

If we aren't proud enough of it to repeat the experience, let's let it lie for now.

Spencer

> From: Harrington, David [mailto:[email-masked]]
> Sent: Friday, December 20, 2002 9:39 AM
> To: Margaret Wasserman; Spencer Dawkins
> Cc: [email-masked]
> I'm not sure I understand what picking at old wounds gains 
> us. If we want to compare war stories, then let's include 
> discussion of how the problem was resolved successfully. 
> Let's not dig up buried hatchets.
> 
> dbh
> ---
> David Harrington            
> [email-masked]           
> co-chair, IETF SNMPv3 WG

---

From: "Presuhn, Randy" <[email-masked]>
Date: Thu, 19 Dec 2002 17:09:59 -0600

Hi -

> From: Bernard Aboba [mailto:[email-masked]]
> Sent: Thursday, December 19, 2002 13:57
> To: Ted Hardie
> Cc: Spencer Dawkins; [email-masked]
...
> The reality is that completing a standards effort is very 
> time consuming
> -- it typically takes years of work, on a continuous basis. 
> As part of the
> nomcom process, we require nominees for the IAB and IESG to 
> get written
> commitments from their management indicating that they understand the
> level of commitment and agree to that level of support. I 
> wonder how many
> WGs can demonstrate a "core" with that level of commitment.
...

I know some other standards organizations have similar requirements
for WG chairs.  Might it make sense for us to do the same?  Would
it make sense to get a similar level of commitment for WG document
editors?

---

From: Fred Baker <[email-masked]>
Date: Thu, 19 Dec 2002 15:36:05 -0800

At 05:28 PM 12/19/2002 -0600, [email-masked] wrote:
>I believe that
>the vast majority are simply willing to be lead and hence the lack of
>contribution.

In my view, they are not so much "willing to be lead" but "observing". If
something happens they don't like, they will either pipe up publicly or
take someone aside in the hall.

---

From: "Lars-Erik Jonsson (EAB)" <[email-masked]>
Date: Fri, 20 Dec 2002 13:09:37 +0100

> > > "we reject kings, presidents, and voting. we favor only
> > > rough concensus and running code."
> > >
> > > voting introduces a host of problems, not the least of
> > > which is having to qualify the voters and having to deal
> > > with election fraud.
> >
> > I certainly agree with this. However, voting also has one
> > salutory feature: it actually provides an incentive for
> > participants to read the specifications!
>
> mtr: err, there's no causation here. in fact, idon't there's
> even correlation.

I think one could rather get the opposite effect from pure voting,
i.e. that participants do not even read the documents or try to
understand the technology. If their vote would count anyway, why
should they even bother? (*sarcasm*)   I've seen this in other
SDO's, where technical decisions are often taken based only on
political motives, through voting where many participants have
no clue of what they are really deciding about. In these bodies,
it can often be impossible to question a decision based on sound
technical arguments.

It might sometimes be easier to rule a process where all
decisions are based on pure voting, but our technology-focused
way of taking decisions is superior when it comes to producing
technically sound solutions. It puts a heavier burden on the
WG chairs, who have to understand all aspects themselves, read
all expressed opinions, and weigh all opinions expressed based
on how well the participant have motivated their opinions. When
we use "rough consensus" to take decisions, our decisions might
of course be questioned, but I rather defend my judgments based
on technical grounds than by pointing to formal voting policies.

As DB wrote earlier, the cases when we ask meeting attendees to
raise their hands (as a way of getting the "sense of the room")
should not be confused with the sort of formal votes that go on
in other standards organizations. The latter is really scary!

Cheers,
/L-E

---

From: "Spencer Dawkins" <[email-masked]>
Date: Fri, 20 Dec 2002 13:31:10 -0600

There are topics in this thread that seem like the obviously-right thing to do. Is there ANY downside to asking for this level of commitment from document editors?

Spencer

> From: Presuhn, Randy [mailto:[email-masked]]
> 
> editors?>

---

From: "Spencer Dawkins" <[email-masked]>
Date: Fri, 20 Dec 2002 13:55:28 -0600

Fred, thank you for the background - this was WAY before my time. I saw the ODV description, but didn't know what it was.

Spencer

> Sent: Friday, December 20, 2002 1:50 PM
> To: Spencer Dawkins
> Cc: [email-masked]
> At 09:39 AM 12/20/2002 -0600, Spencer Dawkins wrote:
> >And this is not what we did with OSPF/IS-IS/RIP2 (if 
> >http://www.ietf.org/html.charters/OLD/ripv2-charter.html 
> means what I 
> >think it does).
> 
> there was indeed a "pick one" model for IGPs. And BTW, there 
> was an "Open 
> Distance vector" proposal at one time, based on Cisco IGRP. 
> The intention 
> of the "pick one" model was not to make there be only one 
> protocol, but to 
> require that one in particular be imlpemented by all routers. 
> The result 
> was the following statement in RFC 1812:
> 
>     A router that implements any routing protocol (other than static
>     routes) MUST IMPLEMENT OSPF (see Section [7.2.2]).  A router MAY
>     implement additional IGPs.
> 
>

---

From: Fred Baker <[email-masked]>
Date: Fri, 20 Dec 2002 11:49:53 -0800

At 09:39 AM 12/20/2002 -0600, Spencer Dawkins wrote:
>http://www.ietf.org/html.charters/OLD/ripv2-charter.html means what I
>think it does).

there was indeed a "pick one" model for IGPs. And BTW, there was an "Open
Distance vector" proposal at one time, based on Cisco IGRP. The intention
of the "pick one" model was not to make there be only one protocol, but to
require that one in particular be imlpemented by all routers. The result
was the following statement in RFC 1812:

---

From: "Presuhn, Randy" <[email-masked]>
Date: Fri, 20 Dec 2002 16:35:30 -0600

Hi -

> From: Marshall Rose [mailto:[email-masked]]
> Sent: Friday, December 20, 2002 10:45
> To: Presuhn, Randy
> Cc: [email-masked]
> > If, after technical discussion of the alternatives, it comes down
> > to a 51% majority, then perhaps it doesn't really matter too much
> > which of the alternatives is chosen.
> 
> uh, no, because you're assuming that all votes are 
> equally-informed and
> all votes are made by people with equal insights.
> 
> democracy works great for social institutions because the 
> alternative is
> civil wars. it doesn't work great for technical institutions 
> when pesky
> things like the laws of physics can't be legislated away (even by 100%
> of the votes).

Voting does not imply democracy, and we've had our share of civil wars
in the IETF without so much as a single vote.

In the context of a WG technical discussion:

   1) those who don't know or don't care can generally be counted on
      to abstain; this is very prevalent in the ISO work I am familiar
      with, as a WG chair I've also seen it when getting a "sense of
      the room";

   2) if we're really talking about "laws of physics", a WG vote won't
      come down to 51%.  If it does, there's something seriously wrong
      with the WG participants, and we should just close up shop.

      (Even if there is a WG consensus, that doesn't mean laws of physics
      won't be violated.  The interpretations of the infamous "as if
      simultaneously" in RFC 1157 4.1.5 come to mind.)

> > Whether the process uses voting or "rough consensus", the
> > quality of the discussion leading up to the decision is
> > what matters.
> 
> sure, and voting doesn't change that.
...

Precisely.  I think WG's too often get hung up arguing between
alternatives when, in the larger picture, the choice doesn't
matter, as long as the group picks ONE.  I think SNMP is a
good case in point.  In retrospect, it is in many ways suboptimal,
but it was good enough for the job and has been wildly successful.
Technical excellance is important, but sometimes it gets in the
way of "done", and we need a way to bring closure in cases where
clear, overwhelming consensus is unlikely.