Subject: RE: Response requested: Proposal regarding milestones

From: "Spencer Dawkins" <[email-masked]>
Date: Thu, 19 Dec 2002 13:29:57 -0600

Ted,

There are a lot of nice things about this proposal.

I am thinking that there are actually a number of proposals in one bag, including - 

- a distinction between "contributors" and "commentors" (my word) - I like this, mostly because it helps a working group chairs know when they have enough "contributors" to get the work done - or not. You know how many EDITORS you have, but for contributors - well, if you have lots of people at your face-to-face meeting today, this may not mean anything except it's too cold in Atlanta in November for people to wander around outside...

- a definition of "community" - Carl Williams and I have peeked at the TRIGTRAN mailing list subscribers to see who's reading the e-mail, but we would like to know who's really signed up to contribute, who's signed up to comment, who's signed up to watch us carefully in case we screw up TCP (oops!)... self-identifying contributors plus commentors would help us to know if we're hearing from a significant portion of contributors, etc. I like this one, too.

- a definition of "commitment" - ideally, the criteria you proposed ("I'll read ALL the chartered drafts") would be the right one. For some working groups, ("DCCP"), it's a reasonable criteria. There are working groups that contain two or more communities (the TSVWG charter contains deliverables from TCP weenies, SCTP weenies, and MIB weenies), and we have lots more protocol geniuses than MIB wizards, and some working groups just have plenty of chartered documents (I'm thinking of MPLS before the Sub-IP split into MPLS, CCAMP, IPO, PWE3, PPVPN - an extreme case, but you get the drift). So I think it's likely that lots of contributors would read SOME of the chartered drafts, but in lots of cases, they wouldn't read ALL of them. So I think this needs tuning. but I like where you're heading.

- a definition of "membership" - It makes sense to me to know who the contributors are, and who the commentors are. I'm not clear on why you would put an obstacle ("WG chair approval") into the path of someone who laid down their membership at some point in the past. Is it just to prevent block voting (the same reason IEEE working groups require attendance at a couple of plenaries before you get voting privileges)?

- A definition of "feedback" - I'm not sure that your "send an e-mail to the list with a box checked" is any more or less voting than current humms and shows of hands, which we immediately disclaim as binding until we confirm it on a mailing list anyway. I'm curious about the opportunity for minimal computer system support ("oh, PLEASE don't ask even a couple of dozen people to say 'I agree, too' on the mailing list!") to make this more practical and less burdensome on the chairs.

- a definition of "consensus" - I'm not clear on how your proposal differs from today's practice, unless it's limiting the survey to the "membership" (contributors?).

Could you say a few more words about these last three points? I agree with the parts I understand, I just don't understand these parts!

Thank you,

Spencer

---

From: Ted Hardie <[email-masked]>
Date: Thu, 19 Dec 2002 12:04:25 -0800 (PST)

> 
> - a definition of "membership" - It makes sense to me to know who the =
> contributors are, and who the commentors are. I'm not clear on why you =
> would put an obstacle ("WG chair approval") into the path of someone who =
> laid down their membership at some point in the past. Is it just to =
> prevent block voting (the same reason IEEE working groups require =
> attendance at a couple of plenaries before you get voting privileges)?

I didn't intend to do that; I was thinking instead of someone who
agreed to meet a set of obligations and failed to do it (hence the
focus on not meeting the requirement of comment on chartered items).
If someone withdrew from membership, it would seem fair to re-admit
them to membership at any time.  I was more worried about the case of
"last time you said you'd do this, you didn't; what's changed so that
I can count on your contribution?"

> 
> - A definition of "feedback" - I'm not sure that your "send an e-mail to =
> the list with a box checked" is any more or less voting than current =
> humms and shows of hands, which we immediately disclaim as binding until =
> we confirm it on a mailing list anyway. I'm curious about the =
> opportunity for minimal computer system support ("oh, PLEASE don't ask =
> even a couple of dozen people to say 'I agree, too' on the mailing =
> list!") to make this more practical and less burdensome on the chairs.

Again, my poor writing on this point is not getting across what I
mean.  As I said to Bert, I believe that definite statements about the
quality of the documents are the ideal.  I see "no objection"
statements as the minimum, but probably something which would occur
late in the process when the technical comments have been addressed.
This would mean you would not get a flood of "me, too" except when a
document is close to done.  You *should* get a flood of comments on a
document when the chair asks for a wg review (or at least one comment
per active wg member, which may end up being a trickle).  Since I was
really trying to get at increased feedback, I don't think I agree that
moving this off the mailing list is a good idea; that changes the
"official" forum for the working group to something other than the
mailing list, which is a different change.

> - a definition of "consensus" - I'm not clear on how your proposal =
> differs from today's practice, unless it's limiting the survey to the =
> "membership" (contributors?).

Again, I don't want to limit anyone's right to make a technical
comment.  I do think it is valuable to have a sense of who has agreed
to take on the work, so that the "rough consensus of the working
group" can be based on a sense of who the working group is.  Taken in
the form of positive statements by folks who have committed to reading
the documents that "yes, this document is a clear specification of
good engineering for this problem", I think we'd be miles ahead of
where we are now.

There is a risk, as I noted in my initial statement and has been noted
since, that this degenerates into voting by very narrow interests.
That's bad from my view not because its voting, but because the narrow
interests may overwhelm good engineering from the view of the Internet
as a whole.  Since I see the point of the IETF as being a forum for
problems which benefit from a view of the Internet as a whole, I
really want to avoid changes which might erode that role.

> 
> Could you say a few more words about these last three points? I agree =
> with the parts I understand, I just don't understand these parts!

Hope this helps.  To comment on one other bit, I agree with you that
some current working groups have document loads which would make it
difficult to find members who could read and comment on all of them.
This may be a warning sign to the working group chairs and ADs.  It
might be possible to use something similar with sign up for specific
chartered drafts, appropriate threads, and all minutes, but there is a
real question then of why those aren't different groups.
Unfortunately, there are some cases (like MIB review) that don't fit
neatly into that prescription. 

				regards,
					Ted Hardie