Subject: FW: RFC bandwith, packet size and latency

From: "Spencer Dawkins" <[email-masked]>
Date: Tue, 28 Jan 2003 08:41:57 -0600

This posting just appeared on the problem-statement mailing list. It seems to confirm that there's actually a disadvantage to renaming an I-D when it's accepted as a working group deliverable (makes it harder to track how long things take in the IETF).

Have we ever identified an ADVANTAGE?

In the working group chair training sessions, Steve Coya just says that "working group deliverable" isn't based on the name of the draft (it's a separate field in the database). He doesn't encourage or discourage the name changes.

Henning also points out the difficulty this creates for IPR searches and suggests that the RFC Editor could tie the versions together. This solves the IPR problem if you get as far as an RFC...

Any thoughts on whether renaming drafts is worth the effort?

Spencer

> -----Original Message-----
> From: Henning Schulzrinne [mailto:[email-masked]]
> Sent: Monday, January 27, 2003 8:57 PM
> To: Harald Tveit Alvestrand; [email-masked]
> Subject: RFC bandwith, packet size and latency
> 
> 
> I've gathered some additional data on the RFC publication process and 
> imported the data into EDAS (a publication management system that I 
> wrote). The results are at 
> http://www.cs.columbia.edu/~hgs/internet/rfc.shtml
> 
> The results differ slightly from the earlier ones since I was able to 
> match additional RFCs by their I-D tag. However, the basic 
> gist is the 
> same and the trend has taken a large tick upwards in 2002: 
> the average 
> delay for RFCs published in 2002 was 2 years and 2 months. 
> (The maximum 
> was 5 years and 2 months!) As discussed in more detail on the 
> web page, 
> this estimate is likely low, since there seems to be an increasing 
> tendency in some working groups to let a draft go through a number of 
> draft-personal stages before becoming draft-ietf-wg. If the draft 
> changed its title during that time, I cannot match it and thus only 
> measure the time from draft-ietf.
> 
> As others have pointed out, it's amazing how painful 
> gathering this data 
> is. Since everything is in more-or-less random text format, with 
> occasional changes, parsing is prone to errors. I did a few sanity 
> checks, but this is a good project for a forensical statistician.
> 
> Also, in recent years, even the IMR is incomplete in its I-D list, so 
> that I have no data on a number of -00 records. This explains some of 
> missing data points (where the number of published RFCs is 
> much larger 
> than the number of measured RFCs).
> 
> It would be trivial for the RFC editor to gather the "first 
> draft" time 
> from the authors. (This would also be helpful for IPR issues.)
> 
> If somebody wants to play with the data, let me know and I 
> can give them 
> SQL access. (No, not Microsoft SQL...)
> 
> Henning
> 
>

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 28 Jan 2003 16:59:43 +0100

I'm a very strong proponent of the naming convention.

Speaking as a member of the IETF at large:
It's the main criterion I use to decide whether to read a draft
that's in a peripheral area of interest for me. During the weeks
before an IETF, it's a life-saver.

Speaking as a WG chair:
It's a useful management tool and a very effective filter for
off-charter or non-consensual darfts.

Henning's statistics are fascinating, by the way.

   Brian

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 28 Jan 2003 16:59:43 +0100

Speaking as a WG chair:

   Brian

---

From: Harald Tveit Alvestrand <[email-masked]>
Date: Fri, 31 Jan 2003 09:35:09 -0800

not relevant to what the posting is about:

note that Henning's statistics are for the time of the whole IETF process - 
from the posting of internet-draft -00 to the publication of the finished 
RFC.

This doesn't tell us anything about how long the WG, the IESG or the RFC 
Editor spends on the document - it's the sum of all those times.

                      Harald

--On 28. januar 2003 08:41 -0600 Spencer Dawkins 
<[email-masked]> wrote:

> This posting just appeared on the problem-statement mailing list. It
> seems to confirm that there's actually a disadvantage to renaming an I-D
> when it's accepted as a working group deliverable (makes it harder to
> track how long things take in the IETF).