Subject: Complex topics (RE: Formalizing Design Teams)

From: Harald Tveit Alvestrand <[email-masked]>
Date: Thu, 02 Jan 2003 08:55:21 +0100

Happy new year everyone!
I just wanted to pick up on this thread from before Christmas....

it seems that we have different sets of problems:

- they're small, isolated, and we understand how to solve them: a short 
focused IETF WG is the most likely answer
- we don't understand how to attack the problem: an IRTF WG, or "waiting 
until the research is done", may be the answer
- we aren't sure how to solve the problem, or don't know how big the 
problem is, or we're not sure how it interacts with other things: We tend 
to create some mechanism that doesn't quite fit with our defined structure.

The mechanisms include long-lived WGs (IPv6), ad-hoc or new areas (SNMP, 
SubIP, IPv6), WG "clusters" (LDAPEXT/LDAPBIS/LDUP, DNSEXT/DNSOPS, 
SIP/SIPPING/SIMPLE), non-area directorates (Wireless, DNS) and more.

We the IETF might want to think about whether we want to have formal 
constructs that fit better into this space than "areas" or "WGs".

But then again, this discussion probably belongs on problem-statement; 
wgchairs is not an open list....

                    Harald

--On 20. desember 2002 15:33 -0800 Tony Hain <[email-masked]> wrote:

>> > we may decide initially that a temporary area is required
>> > to establish a level of focus across a range of groups. Over
>> time that
>> > will evolve to a point where a complex WG is sufficient to
>> maintain the
>> > necessary focus on the critical architectural issues.
>>
>> Isn't that supposed to be an IRTF working group?
>
> Not necessarily. If all we are ever going to take on in the IETF are
> small incremental changes, short-term narrow-focus groups are
> appropriate. If we need to make significant changes like replacing the
> predominate protocol at a given layer, that isn't going to happen
> quickly, and no it is not research. What it means is that the breadth of
> the problem space is not well understood by the majority of the
> participants. Just figuring out what people need to have spelled out
> takes time.

---

From: "Spencer Dawkins" <[email-masked]>
Date: Thu, 2 Jan 2003 09:11:20 -0600

Hi, Harald,

There's at least one other "complexity" floating around - problems that we understand most of, but we need to think more about some underlying aspect (often, but not always, of infrastructure) - security, congestion control aspects of application protocols, and per-connection router state being recent examples I'm wrestling with.

We've come up with security maevens and MIB doctors, and this helps us think about some edges of the problem domain, but we haven't solved all the problems yet (PWE3 was placed in TSV just because of the potential for transport-level disaster - putting working groups in TSV probably isn't the general solution!)

Spencer

p.s. will you be moving this thread to the problem statement list?

> -----Original Message-----
> From: Harald Tveit Alvestrand [mailto:[email-masked]]
> Sent: Thursday, January 02, 2003 1:55 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Complex topics (RE: Formalizing Design Teams)
> 
> 
> Happy new year everyone!