Subject: RE: Fwd: I-D ACTION:draft-hardie-wg-stuckees-00.txt

From: "Spencer Dawkins" <[email-masked]>
Date: Fri, 21 Feb 2003 14:47:36 -0600

Ted,

Speaking only for myself, it would be easier to survey stuckees than trying to envision how many people in the room (which may be packed because of tourists), on the mailing list (high lurker-to-poster ratio), or even on a variety of design teams (if you weren't at the meeting) REALLY care.

We just finished a document that changed stuckees at about version 10, but there was no way for the principal author to say, "I'm done" - so we idled at one update per IETF for a couple of IETFs, until we figured out that this had happened (in hindsight). If we asked, at every IETF, "and who is the stuckee on this document until next time", this would have been more straightforward.

Spencer

> -----Original Message-----
> From: Ted Hardie [mailto:[email-masked]]
> Sent: Thursday, February 20, 2003 9:07 PM
> To: The Purple Streak, Hilarie Orman
> Cc: [email-masked]
> Subject: Re: Fwd: I-D ACTION:draft-hardie-wg-stuckees-00.txt
> 
> 
> Hi Hilarie,
>          Thanks for you comments.  A few responses.
> 
> At 07:43 PM 2/20/2003 -0700, The Purple Streak, Hilarie Orman wrote:

[deleted down to]

> 
> >But, despite all the mechanism, I'm not sure what the advantage is
> >over having the chairs say, as they often do, "if no one is 
> interested
> >enough in this work to comment on it, then we will seek 
> dissolution of
> >the WG".  The stuckee method is just a very complicated way 
> of getting
> >at the same idea ("the number of stuckees has fallen below 
> the minimum
> >level for WG").
> 
> It isn't very different.  The only real difference is that 
> the role may be
> just formal enough for people to actually be able to gauge the level
> of effort a bit better.  I know lots of well intentioned folk 
> who agree
> that a particular work item would be valuable, but gauge 
> poorly the work
> *they* need to put in to see it happen.  This provides a potential
> method to help them gauge that (by setting out what they will
> do and on what time schedule) and to help those managing the
> effort know that they have at least N folks willing to make actual
> assertions about the quality of the work.

---

From: [email-masked]
Date: Sun, 23 Feb 2003 09:07:50 +0200

Hi Ted,

I basically agree with what you propose, in principle, but I do
think it would be difficult to get this to work in practice.

Reading your draft made me think about something.  In some WGs I
participate in, the ADs and WG chairs are very active in reading
documents, pushing the authors/editors to get the work done, etc.  In
others, document authors are very active in getting their work
done.  These are signs of a successful WG.  In WGs that are not
so successful, there usually is a lot of confusion about who
should be driving the work.  The chairs wait for the doc 
authors to publish the work, the authors sit and wait for
comments from the wg, and not too much happens.

Active management is better than passive management, but also
having clear divisions of responsibilities is always helpful.

br,
John

> From: ext Ted Hardie [mailto:[email-masked]]
> Sent: 14 February, 2003 21:24
> To: [email-masked]
> Subject: Fwd: I-D ACTION:draft-hardie-wg-stuckees-00.txt
> 
> 
> Howdy,
>          During December we had a discussion on the list of how
> to retain the openness of the IETF process but have a better
> sense of who had committed to taking on the work of a working
> group.  In that discussion, I proposed having a category 
> "working group member"
> with specific responsibilities.  I was never very happy with the term,
> though, as I was afraid that membership implied rights and
> privileges rather than responsibilities.
>          It struck me the other day that the IETF has a perfectly
> good term for this role, "stuckee" (as in the oft-heard "Who is the
> stuckee on that draft?").  I accordingly have re-worked my
> original proposal with that term and some of the other suggested
> changes.  Below is a URL to the draft; comments welcome.
>          I do plan to give a pointer to CRISP to the draft and
> ask folks if they would be willing to take on the "working group
> stuckee" role.  I'd be interested to know if other folks do the
> same for their working groups.
>                          regards,
>                                  Ted
> 
> 
> 
> >http://www.ietf.org/internet-drafts/draft-hardie-wg-stuckees-00.txt
> 
> 
> 
> 
> 
>