Subject: RE: "Stuckees?"

From: "Eric Burger" <[email-masked]>
Date: Tue, 4 Mar 2003 09:25:35 -0500

This is a very real issue.

Can I, as a WG Chair, get away with "Key Contributors" on the web page?  I like the concept.  However, I'm worried that there will be *someone* who feels they should be listed...  I can envision lots of rules and regulations on who can or cannot be listed, and the process for appealing listing decisions, etc., etc.

For that matter, do we need rules and regulations for Key Contributors?  I much prefer the informal approach to a formal approach, ESPECIALLY given that we are a 100% volunteer organization.

If you cannot get anyone to do work, then the solution is simple.  The work group is finished.  Either people will come forward, or we release the IETF resources being consumed by a group that is not doing anything.

> -----Original Message-----
> From: Lisa Dusseault [mailto:[email-masked]]
> Sent: Wednesday, February 26, 2003 2:09 PM
> To: 'Avri Doria'; 'wgchairs'
> Subject: RE: "Stuckees?"
> 
> 
> If we don't have any other way to recognize key contributors, 
> some will
> insist on draft authorship, and some will stop participating. 
>  Since we
> now seem to have a policy limiting authorship on IETF 
> documents, this is
> an actual problem for me.  I have been asked by a valued 
> contributor to
> add his name to a draft because otherwise his manager might reduce the
> hours he gets to work on this (unfortunately, the draft now has more
> than the allowed limit of authors).  So for some people, it really is
> about getting a permission slip. Do we lose these people because we
> aren't willing to write permission slips?
> 
> So what if chairs put a "Key Contributors" on a working group 
> home page
> or in drafts or something? The benefit of this is that it helps people
> show their managers they are recognized as contributers and 
> thus they're
> meeting their review goals. It may help them get travel budgets - the
> WebDAV WG has many key contributors who rarely get to travel to
> meetings.  The recognition alone may motivate people (even independent
> contributors) to act responsibly and think of themselves in this way.
> It might keep somebody contributing long after their initial 
> job-related
> impetus is over (I know draft authorship does the same thing for many
> people). It's a pragmatic commitment consistency tool.
> 
> A "Key Contributors" list could be started by just one WG, but it
> wouldn't have the same force of recognition. Some IETF-wide guidelines
> as to what makes a key contributor (technical/process participation in
> the past year, for example) would help give it the force of 
> recognition
> to make it a powerful tool for chairs.  
> 
> Lisa
> 
> > -----Original Message-----
> > From: [email-masked] 
> > [mailto:[email-masked]] On Behalf Of Avri Doria
> > Sent: Tuesday, February 25, 2003 12:07 PM
> > To: wgchairs
> > Subject: Re: "Stuckees?"
> > 
> > 
> > 
> > I have 2 issues:
> > 
> > - I don't really think there is a need for a special
> > name for strong contributors.  It is a state that
> > some people reach defacto when they become members
> > of special teams (e.g. design or editing).  Perhaps
> > some extra effort in recruiting people onto these
> > teams is warranted
> > 
> > - I think that people should be responsible for their
> > own time commitments. The idea of asking someone if
> > they specifically have their boss's permission is akin
> > to getting a parent's permission slip for a school
> > trip.  In addition it doesn't make sense to me.  Some
> > participants are independent contractors and some are
> > willing to put in time outside their jobs to meet IETF
> > commitments.
> > 
> > a.
> > 
> > 
> > 
> > 
> > 
> 
> 
> 
>

---

From: Harald Tveit Alvestrand <[email-masked]>
Date: Tue, 04 Mar 2003 23:07:26 +0100

--On tirsdag, mars 04, 2003 09:25:35 -0500 Eric Burger 
<[email-masked]> wrote:

> Can I, as a WG Chair, get away with "Key Contributors" on the web page?
> I like the concept.  However, I'm worried that there will be *someone*
> who feels they should be listed...  I can envision lots of rules and
> regulations on who can or cannot be listed, and the process for appealing
> listing decisions, etc., etc.
>
> For that matter, do we need rules and regulations for Key Contributors?
> I much prefer the informal approach to a formal approach, ESPECIALLY
> given that we are a 100% volunteer organization.

I'd really like to see someone actually try this - one of the groups that 
already has an extra webpage hanging off their charter could just start 
listing key contributors. Then when their next RFC is done, they copy & 
paste that into the "contributors" section - all stuff that is allowed 
under the current rules. No need for a rule change to try....