Subject: mailing list size

From: Aaron Falk <[email-masked]>
Date: Wed, 19 Mar 2003 14:45:15 -0800

Attention all wg chairs-

Please send me the current size of your working group mailing list.
I'd prefer a simple message of the form:

dccp	   263

I will summarize and post.

Thanks,

--aaron

PS.  Please be considerate and DO NOT copy the wgchairs list on your
reply. -af

Aaron Falk wrote:
> In the interests of collecting real data, it might be useful for
> someone to volunteer to collect, from the wg chairs, and post a single
> snapshot of mailing list sizes for all working groups.
> 
> --aaron
> 
> Margaret Wasserman wrote:
> > 
> > I don't have any numbers on mailing list size, but the IPv6 WG
> > is usually the most heavily attended WG, according to blue sheet
> > signatures.  IPv6 usually has 400+ signatures on the blue sheets
> > (with considerably more people than that in the room), while the
> > next largest WGs usually run in the mid-to-high 200s.
> > 
> > Margaret
> > 
> > 
> > At 10:27 AM 3/10/2003 -0500, Keith Moore wrote:
> > >> Is your experience tilted more towards lists that are (1) at the
> > >> application level, and (2) not telephony/SubIP-related?
> > >
> > >yes.  apparently I was under the mistaken impression that some of the
> > >apps groups (e.g. those related to web things) were the largest ones
> > >in IETF...
> > >
> > >Keith
> >

---

From: Aaron Falk <[email-masked]>
Date: Wed, 19 Mar 2003 14:54:24 -0800

Joel M. Halpern wrote:
> I have no idea how to determine this information.  My WG email list is 
> hosted by IETF.

Joel-

If you go to your mailman page,
https://www1.ietf.org/mailman/admin/<your-wg-name>, and follow the
link to "Membership management", you'll see the total list members
listed at the top of the table.

--aaron

---

From: Aaron Falk <[email-masked]>
Date: Wed, 19 Mar 2003 15:29:13 -0800

Matthew J Zekauskas wrote:
> However, if you've had the list running with mailman for a long
> time, there may be a significant number of entries that have
> 'nomail' turned on because the mail addresses bounced.
> Using your own address and admin password, you can also get
> the whole list off the public information page.  That list
> is a single page showing non-digest-subscribed members,
> digest-subscribed members, and ones that have "nomail" set are
> italicised in parenthesis.

Indeed.  The pilc list changes from 672 to 496 when disabled email
accounts are subtracted.

--aaron

---

From: Aaron Falk <[email-masked]>
Date: Wed, 19 Mar 2003 16:05:39 -0800

Working groups hosted by the IETF, i.e., <wgname>@ietf.org, use
mailman.

--aaron

Derek Atkins wrote:
> That presumes the use of mailman.  None of my WGs use mailman
> 
> -derek
> 
> Aaron Falk <[email-masked]> writes:
> 
> > Joel M. Halpern wrote:

---

From: Ralph Droms <[email-masked]>
Date: Wed, 19 Mar 2003 19:12:34 -0500

Is there a way to automatically subtract disabled accounts
from the total reported by mailman?

- Ralph

---

From: Aaron Falk <[email-masked]>
Date: Wed, 19 Mar 2003 16:19:54 -0800

> from the total reported by mailman?

Nope.  Here's what I did:

 1. save single page listing of subscriptions as a text file
 2. open in emacs; 
 3. regex substitution of s/(.*)// (this because emacs is helpful and
 ignores parentheses in alphabetical sort)
 4. alphabetical line sort
 5. count non-blank lines

---

From: Derek Atkins <[email-masked]>
Date: 19 Mar 2003 19:29:55 -0500

> Working groups hosted by the IETF, i.e., <wgname>@ietf.org, use

Which is fine, but none of my groups' lists are hosted @ietf.org.
Two are @vpnc.org, and one is @iastate.edu.  Most use majordomo.
That makes it hard to get this information for you....  I'll go
ask the particular people involved, but I can't guarantee I'll
get an answer.

-derek

-- 
       Derek Atkins
       Computer and Internet Security Consultant
       [email-masked]             www.ihtfp.com

---

From: Joe Macker <[email-masked]>
Date: Wed, 19 Mar 2003 19:37:07 -0500

>That makes it hard to get this information for you....  I'll go

When I used majordomo ...before moving to ietf.org I would just find the membership file (its text formatted) and use the following commandline to count the lines.

wc -l <membershipfile>

---

From: Paul Hoffman / VPNC <[email-masked]>
Date: Wed, 19 Mar 2003 18:29:00 -0800

>ask the particular people involved, but I can't guarantee I'll

To everyone who has a list run at IMC or VPNC: don't worry, I'll take 
care of this for all of you.

--Paul Hoffman, Director
--VPN Consortium

---

From: Matthew J Zekauskas <[email-masked]>
Date: Wed, 19 Mar 2003 18:11:23 -0500

(I wish I could get it through the admin interface that way
too; I hate having each page limited to 20 (or so) names.)

general info page at
https://www1.ietf.org/mailman/listinfo/<your-wg-name>

--matt

---

From: Jaap Akkerhuis <[email-masked]>
Date: Thu, 20 Mar 2003 01:37:43 +0100

-derek

Try  who <listname

	at majordom@server

Correct working depends on the config, but if uou have the adminpasswd,
you can change that.

	jaap