Subject: Re: WG Chairs Training

From: [email-masked]
Date: Tue, 18 Mar 2003 12:27:19 -0500

Regarding the naming of drafts - there is also the problem of someone
putting a working group name in the title and on the draft itself, yet
there has been no discussion with the WG on either the list or otherwise.
People sometimes assume that since this is "about" a topic that a WG is
managing then it is ok to say the draft is part of that WG.  When this new
draft is not on that WG's charter, life gets interesting.

                      Spencer Dawkins                                                                                                  
                      <spencer_dawkins@        To:       Aaron Falk <[email-masked]>, Margaret Wasserman <[email-masked]>             
                      yahoo.com>               cc:       [email-masked]                                                             
                      Sent by:                 Subject:  Re: WG Chairs Training                                                        
                      owner-wgchairs@ie                                                                                                
                      tf.org                                                                                                           

                      03/18/03 12:31 AM                                                                                                

It's probably worth mentioning that I see many working groups
that just kind of absorb individual drafts as working group
drafts, without the kind of major decision point, and discussion
of editor rights and responsibilities, that Margaret has in the
training material, and that Aaron is providing input on below.

And this unstudied absorbing is Not A Feature...

Spencer

p.s. a process nit, not a presentation nit - we're still
confused about whether draft-ietf-wgname draft names matter or
not. Steve Coya has been pointing out that there's no link
between a draft name and whether it's REALLY a working group
draft or not, in the working group chair training for multiple
years, but I'm hearing more reports of IESG and IAB members
basing the decision to look closely at a draft on the name, and
not on whether it's actually a working group draft or not.

We should be a lot clearer on whether we expect all working
group drafts to be explicitly named to reflect this or not.
IMHO, of course.

--- Aaron Falk <[email-masked]> wrote:
[deleted down to]
>
> 3. My approach is to make clearly charge the document editor
> with
>    ownership of extracting feedback and consensus from the
> mailing
>    list.  The editor is responsible for tracking and getting
> closure
>    on open issues.  An important part of this is having the
> editor
>    send issue summaries to the list (sometimes with proposed
>    solutions, sometimes not).  YMMV.
>
> Hope this helps,
>
> ---aaron

__________________________________________________
Do you Yahoo!?
Yahoo! Platinum - Watch CBS' NCAA March Madness, live on your desktop!
http://platinum.yahoo.com

---

From: "Rik Drummond" <[email-masked]>
Date: Tue, 18 Mar 2003 11:49:48 -0600

This is why only the wg lead should be allowed to submit drafts to the
ieft under their responsibility. If this happen the control points are
in place to manage this issue.... Best regards, rik
Chair ietf ediint wg

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of [email-masked]
Sent: Tuesday, March 18, 2003 11:27 AM
To: Spencer Dawkins
Cc: Aaron Falk; Margaret Wasserman; [email-masked];
[email-masked]
Subject: Re: WG Chairs Training

Regarding the naming of drafts - there is also the problem of someone
putting a working group name in the title and on the draft itself, yet
there has been no discussion with the WG on either the list or
otherwise. People sometimes assume that since this is "about" a topic
that a WG is managing then it is ok to say the draft is part of that WG.
When this new draft is not on that WG's charter, life gets interesting.

                      Spencer Dawkins

                      <spencer_dawkins@        To:       Aaron Falk
<[email-masked]>, Margaret Wasserman <[email-masked]>             
                      yahoo.com>               cc:
[email-masked]

                      Sent by:                 Subject:  Re: WG Chairs
Training                                                        
                      owner-wgchairs@ie

                      tf.org

                      03/18/03 12:31 AM

It's probably worth mentioning that I see many working groups that just
kind of absorb individual drafts as working group drafts, without the
kind of major decision point, and discussion of editor rights and
responsibilities, that Margaret has in the training material, and that
Aaron is providing input on below.

Spencer

p.s. a process nit, not a presentation nit - we're still confused about
whether draft-ietf-wgname draft names matter or not. Steve Coya has been
pointing out that there's no link between a draft name and whether it's
REALLY a working group draft or not, in the working group chair training
for multiple years, but I'm hearing more reports of IESG and IAB members
basing the decision to look closely at a draft on the name, and not on
whether it's actually a working group draft or not.

We should be a lot clearer on whether we expect all working group drafts
to be explicitly named to reflect this or not. IMHO, of course.

>
> 3. My approach is to make clearly charge the document editor with

---

From: Aaron Falk <[email-masked]>
Date: Tue, 18 Mar 2003 11:01:08 -0800

> draft is not on that WG's charter, life gets interesting.

I believe the wg chair needs to approve any docs of the form
draft-ietf-wgname-xxx-00.  So, these docs shouldn't be surprises.  But
having the wg name in the filename can be helpful in allowing people
to find related work.  I find it useful to have non-wg drafts take the
format draft-author-wgname-xxx.  Note the lack of 'ietf' in the
filename.

--aaron

---

From: Spencer Dawkins <[email-masked]>
Date: Tue, 18 Mar 2003 10:45:46 -0800 (PST)

Dear all -

I'm talking about the OTHER condition - a working group draft is
called (I'm dreaming, but)
draft-dawkins-trigtran-framework-01.txt, because a working group
liked it.

For the last several years, the working group chairs training
has been ambiguous as to whether this is a good idea or not,
leaning slightly toward "yes", because you lose continuity when
you change the draft name and reset to revision 00.

The real answer MAY BE "no", because no one will read it unless
they click on it from the working group home page, so go ahead
and change the name and revision number.

But I'm still not sure what the real answer IS.

Having me pop up with
draft-ietf-v6ops-wonderful-idea-about-site-local-00.txt is the
mirror-image problem, not the one I was pointing out for the
working group chair training. It's also an interesting problem,
of course...

Spencer

---

From: Spencer Dawkins <[email-masked]>
Date: Tue, 18 Mar 2003 10:49:43 -0800 (PST)

And my apology to Rik and Pete, because after re-reading, they
were very clearly raising a different issue as well as the one I
was talking about...

But the wgchairs social was still worth it, even if I'm in a
coma this morning!

Spencer

--- [email-masked] wrote:
> otherwise.
>                       <spencer_dawkins@        To:       Aaron
> Falk <[email-masked]>, Margaret Wasserman <[email-masked]>
>
>                       yahoo.com>               cc:
> [email-masked]
>
>                       Sent by:                 Subject:  Re:
> WG Chairs Training
>
>                       owner-wgchairs@ie
>
>
>                       tf.org
>
>
>
>
>
>
>
>
>                       03/18/03 12:31 AM
>
>
>
>
>
>
>
>
>
>
>
>

---

From: Spencer Dawkins <[email-masked]>
Date: Tue, 18 Mar 2003 11:11:04 -0800 (PST)

OK, trying again (to be awake), if I got Pete's point, the
surprise was the e-mail saying "will you approve this unforeseen
apparently-working-group ID?", and the subsequent rats-nest
trying to explain why the ID can't be approved (typically 45
minutes before a 00 ID cutoff date)...

And I echo Aaron's preference for draft-author-targetWG prefixes
- again, helps me think "I should read this draft".

Spencer

---

From: Avri Doria <[email-masked]>
Date: Wed, 19 Mar 2003 12:11:23 -0500

> and change the name and revision number.

I have another argument for  changing the name when a draft
becomes a WG draft. It is a concrete marker of the transition
of change-rights from the individual author(s) to the WG.  In effect
a document becomes a new thing when it becomes a WG document so a
loss of continuity is, in effect, a good thing.  Remembering also that
the primary editorship can be handed over to another WG participant
anytime in the continuing lifetime of the document it makes even less
sense to keep the initial author's name in the title.

a.

---

From: Spencer Dawkins <[email-masked]>
Date: Wed, 19 Mar 2003 11:32:03 -0800 (PST)

Hi, Avri,

This makes sense. In my own experience, the move to working
group draft was a lot less formal that what we're kicking around
today.

Interestingly, I'm sitting in v6ops where an old draft is now 00
because it moved from ngtrans. Yet another case, probably not
common, but worth mentioning (once!)

Spencer