Subject: RE: Compendium of "red flags"

From: "Putzolu, David" <[email-masked]>
Date: Fri, 7 Mar 2003 09:58:04 -0800

While I agree with Avri that it would be a way of
defining architecture (or at least, some architectural
principles),  I think such an effort would actually be
a good thing to do.  The architectural ideas are already
out there in people's heads and affecting the process
today,  I'd rather they where out in the open and 
documented (or at least debated).

I like the nit document. It performs a valuable editorial
function. Having an equivalent in a technical sense would
be valuable.

I would think there would be area-specific technical nits 
as well as some IETF-wide technical nits.

-David

> -----Original Message-----
> From: avri [mailto:[email-masked]] 
> Sent: Friday, March 07, 2003 9:14 AM
> To: [email-masked]
> Subject: Re: Compendium of "red flags"
> 
> It strikes me as yet another nit document.  And the relation
> of red flags to sacred cows would be a problem.
> 
> I fear that this document once created would be yet another
> barrier to getting a document through the process.  I think
> it would also be a back door way of defining an architecture.
> I.e. this is what we don't do ...
> 
> I personally would not be happy to see it.
> 
> a.
> 
> Bernard Aboba wrote:
> > It has occurred to me that it might be useful to have a document
> > summarizing the most common technical problems encountered 
> in drafts that
> > have passed WG last call.
> >
> > These are things that if present in a draft tend to be "red 
> flags" --
> > items that are often of questionable technical merit, and 
> will tend to
> > draw scrutiny.
> >
> > That doesn't mean that such items can never be included -- 
> just that the
> > WG should be prepared to make a persuasive argument for them.
> >
> > It might make sense to group the "red flags" by Area -- Transport,
> > Security, Routing, etc. so that we can make sure to have 
> come up with a
> > "well rounded" set of issues.
> >
> > Do people think that such a document would be valuable? How 
> many "red
> > flags" might be reasonable to discuss in such a document? 10? 25?
> >
> >
> >
> 
> 
> 
> 
> 
> 
>

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 08 Mar 2003 14:20:12 +0100

Perhaps the answer is that the id-nits document should become
an openly debated consensus document instead of an IESG
edict. (I don't mean to imply there is anything objectionable
in it today.)

   Brian

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 08 Mar 2003 14:20:12 +0100

Brian

"Putzolu, David" wrote:
> > > That doesn't mean that sX-Mozilla-Status: 0009 included --
> > just that the