Subject: RE: Checking I-Ds for nits.

From: [email-masked]
Date: Wed, 23 Apr 2003 16:54:41 -0500

I think, most of the newcomers start with microsoft word which probably is the worst choice :-(

Do we ask the contributors to submit just the txt file or also the xml/rtf etc file too ? If the author submits the txt file, how should chair make sure that all the ID-nits requirements are met before the chair submits the draft to IESG ?

Checking the formatting manually doesn't seem like a viable choice.

> -----Original Message-----
> From: ext Marshall Rose [mailto:[email-masked]]
> Sent: Wednesday, April 23, 2003 2:02 PM
> To: Gupta Mukesh (IPRG/MtView)
> Cc: [email-masked]
> Subject: Re: Checking I-Ds for nits.
> 
> 
> > Hi All,
> > 
> > How do people make sure that the draft submitted to the WG 
> are compliant to ID
> > nits on this page ? http://www.ietf.org/ID-nits.html
> > 
> > Is there any tool available to help in doing this ??
> 
> ideally, it would be nice if there was an automated service 
> to do something like
> this (kind of like the mib-checker from a decade ago... is 
> that still running?)
> 
> alternatively, you can write your I-Ds in XML according to 
> the rules in rfc 2629
> and use an automated processor to generate the text, cf.,
> http://xml.resource.org/
> 
> /mtr
>

---

From: Marshall Rose <[email-masked]>
Date: Wed, 23 Apr 2003 15:08:11 -0700

> Do we ask the contributors to submit just the txt file or also the xml/rtf etc
> file too ? If the author submits the txt file, how should chair make sure that
> all the ID-nits requirements are met before the chair submits the draft to
> IESG ?
i think that [email-masked] will accept the .xml file along with the
.txt file. but there's no need to submit both. just submit the .txt...

> Checking the formatting manually doesn't seem like a viable choice.

well, that's pretty much the way it ends up getting done, either by the
secretariat, an AD, or, ultimately, the RFC editor...

/mtr

---

From: Joseph Reagle <[email-masked]>
Date: Wed, 23 Apr 2003 18:46:41 -0400

On Wednesday 23 April 2003 17:54, [email-masked] wrote:
> Do we ask the contributors to submit just the txt file or also the
> xml/rtf etc file too ?

If you are using XML, then it's not to hard to write an XSLT that can check 
for a number of things. The W3C's RFC rules are "pubrules" and there's an 
XSLT that checks most of those rules:
	http://www.w3.org/2001/07/pubrules-form

---

From: "Elizabeth Rodriguez" <[email-masked]>
Date: Fri, 25 Apr 2003 16:29:50 -0700

I have found this to be the case as well (use MS Word).
Unfortunately, as of about a month or so ago, I reviewed the currently
available MS Word template and it is itself full of nits.

I have not found any good automated way of checking for nits.
I have a few tools I have developed (very rudimentary perl) which checks for
#columns, ending -, etc. but for the most part need to review manually
before sending to the ADs.

EGR
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
[email-masked]
Sent: Wednesday, April 23, 2003 2:55 PM
To: [email-masked]
Cc: [email-masked]
Subject: RE: Checking I-Ds for nits.

I think, most of the newcomers start with microsoft word which probably is
the worst choice :-(

Do we ask the contributors to submit just the txt file or also the xml/rtf
etc file too ? If the author submits the txt file, how should chair make
sure that all the ID-nits requirements are met before the chair submits the
draft to IESG ?