Subject: RE: A question about requirements

From: "Lars-Erik Jonsson (LU/EAB)" <[email-masked]>
Date: Mon, 22 Sep 2003 11:40:50 +0200

> As I watch discussions in some other groups, and am possibly 
> approaching such an issue in my WG, I have started wondering 
> about the force of requirements documents published as 
> Informational.
>
<snip>
> 
> yet fill them with words like MUST, MUST NOT, SHOULD etc...

Are there really documents published as Informational, using 
these words? In ROHC, we were about to do that a few years ago,
but we were told by the AD to rewrite the document and only
use regular words (must, should, etc). 

If the words are used as defined by 2119, I interpret them as
only intended for standards track documents. If used in e.g.
informational documents, I think the meaning of the words
should be defined within such documents.

/L-E

---

From: Harald Tveit Alvestrand <[email-masked]>
Date: Mon, 22 Sep 2003 09:19:18 -0700

> should be defined within such documents.

repeated bone of contention when discussing documents in the IESG.
I believe, and I think the IESG currently believes, that the uppercase 
words are a tool for making a specification clear; as such, it does not 
make sense to deny the tools for clarity to documents just because we are 
not making them IETF-approved standards track documents.

it makes perfect sense to claim that you implement an Informational 
protocol (people do that all the time); I think it's in the best interests 
of the Internet that those protocols' specifications be as clear as 
possible.

                       Harald