Subject: RE: XML Doctors???

From: Adam Roach <[email-masked]>
Date: Fri, 14 Nov 2003 09:34:31 -0600

On the topic: I've heard conflicting information about the
current opinion of the IESG regarding the use of Schema
versus the use of DTDs. There seems to be a widespread
belief that any new work is expected to use only Schema;
however, I've received third- or fourth-hand information
that DTDs are just fine as long as they serve the purpose.

In other words: "If you can't express what you're trying
to say using DTDs, then use Schema; otherwise, it's the
document editor's choice."

Is that accurate?

/a

> -----Original Message-----
> From: Cullen Jennings [mailto:[email-masked]]
> Sent: Thursday, November 13, 2003 10:57
> To: [email-masked]
> Subject: XML Doctors???
> 
> 
>    
> Do we have some group of people that are very experienced at 
> XML and Schema?
> It would be nice to have some help in various WGs to sort out 
> the syntax
> details of XML documents.
> 
> Thanks, Cullen
> 
>

---

From: [email-masked]
Date: Sun, 16 Nov 2003 11:34:32 -0800 (PST)

> Is that accurate?

Reasonably so, I think. RFC 3470, BCP 70, "Guidelines for the Use of Extensible
Markup Language (XML) within IETF Protocols", certainly agrees. It discusses
the various approaches and concludes by saying that "Protocols should use an
appropriate formalism for defining validity of XML protocol elements."

I think what people are reacting to is a sense that some IESG members prefer
Schema because of its ability to more tighly constrain what's valid and what is
not. But saying documents that use a DTD where a DTD is sufficient will be
rejected on that basis is (hopefully) a stretch.

It may also be the case that at some point we want to have a stronger
preference for Schema. An update to BCP 70 would be in order should this come
to pass.

				Ned

---

From: Michael StJohns <[email-masked]>
Date: Mon, 17 Nov 2003 13:04:26 -0500

Hmm... general comment.  If this (that DTD is acceptable where sufficient)
isn't clear in the documentation probably need to update the document to
reduce confusion.  In otherwords - we're should probably update BCP70
regardless.

Mike