Subject: Re: Good deed before the holidays: Documents in REF state

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 01 Dec 2003 15:04:30 -0500

Harald,

I may be treading into dangerous territory, but...

Is there any way to have rfc-editor or IANA prioritize their work 
based on number of dependencies (I realize that there are many sources 
of delays, and editors are frequently the point of bottleneck)? Eight 
of the drafts below (including several of mine) are dependent on 
draft-mealling-iana-xmlns-registry, and so a lot could be cleared if 
that draft were moved through quickly. Indeed, that draft is also 
listed below, and the entry:

2002/01/23-I  draft-mealling-iana-xmlns-registry-05.txt
REF           draft-mealling-iana-urn-02.txt
IANA          APPR 8/26/03
M. Mealling
The IETF XML Registry
Bytes: 17674

indicates a normative dependency on iana-urn. However, that draft has 
since been published as RFC3553. I assume xmlns-registry is instead 
blocked on IANA action?

Thanks,
Jonathan R.

Harald Tveit Alvestrand wrote:

> Greetings,
> 
> now that the holiday season is looming nearby for many of us here in the 
> Western world, it may be time to think of good deeds that you can do for 
> your fellow IETFers, in following up and resolving some things that are 
> holding up the publication of documents.
> 
> One of the things that leads to documents being stuck "forever" in the 
> publishing process is the pesky issue of normative references - 
> documents that must be read in order to understand a protocol well 
> enough to implement it. The RFC Editor insists, justifiably, that such 
> references be published no later than the referring document.
> 
> There are a few documents in the RFC Editor's queue, some of which have 
> been there for a while.... you can recognize them by their REF state 
> flag in <http://www.rfc-editor.org/queue.html>, or by their presence in 
> the list below.
> 
> Before you take time off for the holiday season - perhaps you might 
> spend a few minutes in looking at the list below and seeing which 
> documents that YOU are responsible for that is held up because of a 
> normative dependency - and try to figure out what happened to the other 
> end of the references?
> 
> More information on each draft is, of course, available from the RFC 
> Editor's URL above and from the I-D tracker.
> 
> Good luck!
> 
>                      Harald
> 
> REF          68.8 draft-ema-vpim-cb-02.txt
> REF          60.0 draft-ietf-fax-service-v2-05.txt
> REF          52.9 draft-ietf-tewg-te-metric-igp-02.txt
> REF          52.9 draft-ietf-isis-ext-lsp-frags-02.txt
> REF          50.7 draft-ietf-mpls-lsp-hierarchy-08.txt
> REF          49.4 draft-ietf-mpls-bundle-04.txt
> REF          42.8 draft-ietf-ipo-impairments-04.txt
> REF          42.7 draft-ietf-midcom-protocol-eval-06.txt
> REF          37.3 draft-ietf-opes-protocol-reqs-03.txt
> REF          37.3 draft-ietf-opes-architecture-04.txt
> REF          36.6 draft-ietf-sipping-reg-event-00.txt
> REF          36.3 draft-ietf-ips-ifcp-14.txt
> REF          36.3 draft-ietf-ips-fcovertcpip-12.txt
> REF          34.9 draft-ietf-smime-symkeydist-09.txt
> REF          32.8 draft-ietf-idwg-requirements-10.txt
> REF          32.8 draft-ietf-idwg-beep-idxp-07.txt
> REF          32.7 draft-ietf-policy-core-schema-16.txt
> REF          28.3 draft-ietf-ips-security-19.txt
> REF          26.6 draft-ietf-ccamp-gmpls-sonet-sdh-08.txt
> REF          24.8 draft-ietf-ccamp-gmpls-architecture-07.txt
> REF          22.6 draft-ietf-ips-iscsi-20.txt
> REF          18.4 draft-ietf-provreg-epp-ext-03.txt
> REF          10.8 draft-ietf-mmusic-sdpng-trans-04.txt
> REF           9.7 draft-ietf-provreg-epp-tcp-06.txt
> REF           9.1 draft-ietf-simple-winfo-package-05.txt
> REF           9.1 draft-ietf-simple-winfo-format-04.txt
> REF           9.1 draft-ietf-simple-presence-10.txt
> REF           9.1 draft-ietf-provreg-epp-host-07.txt
> REF           9.1 draft-ietf-provreg-epp-domain-07.txt
> REF           9.1 draft-ietf-provreg-epp-contact-07.txt
> REF           9.1 draft-ietf-provreg-epp-09.txt
> REF           9.1 draft-ietf-printmib-mib-info-15.txt
> REF           9.0 draft-ietf-mobileip-mipv6-ha-ipsec-06.txt
> REF           9.0 draft-ietf-l3vpn-framework-00.txt
> REF           4.5 draft-ietf-vpim-vpimv2r2-dur-03.txt
> REF           4.5 draft-ietf-vpim-vpimv2r2-32k-03.txt
> REF           4.5 draft-ietf-vpim-vpimv2r2-05.txt
> REF           4.5 draft-ietf-vpim-address-03.txt
> REF           4.1 draft-ietf-ldup-lcup-06.txt
> REF           3.1 draft-mealling-iana-xmlns-registry-05.txt
> REF           3.1 draft-ietf-smime-x400transport-09.txt
> REF           2.0 draft-ietf-smime-x400wrap-09.txt
> REF           2.0 draft-ietf-ieprep-ets-general-04.txt
> REF           0.7 draft-ietf-secsh-dns-05.txt
> REF           0.7 draft-ietf-impp-srv-04.txt
> REF           0.7 draft-ietf-impp-pres-04.txt
> REF           0.7 draft-ietf-impp-im-04.txt
> REF           0.7 draft-ietf-impp-cpim-pidf-08.txt
> REF           0.0 draft-ietf-sigtran-sctp-mib-10.txt
> REF           0.0 draft-ietf-ipr-wg-guidelines-05.txt
> REF           0.0 draft-ietf-ipr-submission-rights-08.txt
> 
> 

-- 
Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
Chief Technology Officer                    Parsippany, NJ 07054-2711
dynamicsoft
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

---

From: Harald Tveit Alvestrand <[email-masked]>
Date: Mon, 01 Dec 2003 12:49:36 -0800

--On 1. desember 2003 15:04 -0500 Jonathan Rosenberg 
<[email-masked]> wrote:

> Is there any way to have rfc-editor or IANA prioritize their work based
> on number of dependencies (I realize that there are many sources of
> delays, and editors are frequently the point of bottleneck)?

The IESG can ask the RFC Editor to prioritize documents, when needed. 
Generally we do it when someone makes a convincing argument that a document 
needs to be published before some deadline for publishing another document 
in some other standards body - that's an easily documentable reason.
There isn't much formal procedure otherwise - things just roll out. But I 
know several people are making sure the xmlns registration document doesn't 
block unnecessarily....

                 Harald