Subject: IETF mailing lists use lots of received lines?

From: "Theodore Ts'o" <[email-masked]>
Date: Wed, 14 Apr 2004 12:45:20 -0400

We are in the midst of transitioning the IPSEC mailing list to
[email-masked], and we seem to have run into an interesting problem.
The IETF mailing list system seems to use a large number of
intervening hops:

When this is combined with systems whose internal mailers use a
largish number of hops in order to transit out of their intranet,
through their firewall, and to the outside world (see below for one
example), the net result trips anti-looping schemese.  

For example, hotmail.com will bounce any mail message that contains
more than 10 Received: lines.  Given that the IETF mail system is
adding a minimum of six Received: lines, it doesn't take much more to
trip hotmail's anti-looping mechanism.  Surely Toshiba is somewhat
extreme that outgoing mail messages will go through nine (9!!!)
mailers before reaching the outside world, but the net result is that
people who are using hotmail will be losing some number of messages
sent to the [email-masked] mailing list.

Is this something that can be fixed on the ietf.org side, perhaps by
filtering out or transmuting some of the internal the IETF-added
Received: lines to "X-Received:"?  That way the information is still
there for debugging purposes, but it won't trip relatively naive
anti-looping mechanisms, such as those currently in use at hotmail.

Also, has any other wg chairs who have their mailing lists homed at
ietf.org noticed this?  If I had been automatically filter bounce
messages that come from virii, I might not have noticed this bounce
message.  Fortunately this was during a transition, so I was paying
close attention in order to assure that everything was going smoothly,
or it might have gotten filtered out and flushed.

Finally, folks at Toshiba might want to be warned that they may also
want to do similar filtering.  Given that Toshiba is adding nine
levels of Received: headers, and hotmail apparently bounces any
messages with more than 10, my guess is that some number of messages
from Toshiba may not be reaching their intended recipients.

						- Ted

+0900 (JST)

Subject: Delivery Status Notification (Failure)
From: [email-masked]
To: [email-masked]
Date: Wed, 14 Apr 2004 06:29:25 -0700
List-Id: IP Security <ipsec.ietf.org>

This is an automatically generated Delivery Status Notification.

Unable to deliver message to the following recipients, because the message was forwarded more than the maximum allowed times. This could indicate a mail loop.

       [email-masked]
       [email-masked]
       [email-masked]
       [email-masked]
       [email-masked]
       [email-masked]
       [email-masked]
       [email-masked]

Subject: Re: [Ipsec] ipsec on WLAN
From: Yoshihiro Ohba <[email-masked]>
To: Giacomo Pisano <[email-masked]>
Cc: yo2lux <[email-masked]>, [email-masked]
Date: Tue, 13 Apr 2004 17:19:39 -0700
List-Id: IP Security <ipsec.ietf.org>

An IPsec usage in WLAN is being discussed in the PANA WG.  
There are several drafts related to the usage:

draft-ietf-pana-ipsec-02.txt
draft-ohba-pana-framework-00.txt

Regards,

Yoshihiro Ohba

On Wed, Apr 14, 2004 at 10:45:13AM +0200, Giacomo Pisano wrote:
> I have one client (possibly Windows) one AP and a server (possibly Windows).......do you think it's possible to make the server act as a getway for the LAN?? I need to build an IPSec Tunnel between the wi-fi client and the server. The server then has to relay the data on the LAN and viceversa.
> 
> What I'm trying to secure is just the radio link
> 
> ----- Original Message ----- 
>   From: yo2lux 
>   To: Giacomo Pisano ; [email-masked] 
>   Sent: Wednesday, April 14, 2004 10:13 AM
>   Subject: Re: [Ipsec] ipsec on WLAN
> 
> 
>   you want to make an IPSec between OpenBSD and Windows ? 
>     ----- Original Message ----- 
>     From: Giacomo Pisano 
>     To: [email-masked] 
>     Sent: Wednesday, April 14, 2004 10:03 AM
>     Subject: [Ipsec] ipsec on WLAN
> 
> 
>     Hi, I'm a novice but i'm trying to make IPSec work on WLAN in order to use level3 security instead of level2. Has anyone of you tried to do the same?? I don't have any idea of what to do!
> 
>     TNX
> 

_______________________________________________
Ipsec mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipsec

---

From: Brett Thorson <[email-masked]>
Date: 14 Apr 2004 13:00:20 -0400

The server migration that I am in the middle of performing (some steps
being spam, majordomo migration, etc) should address these issues.

--Brett

On Wed, 2004-04-14 at 12:45, Theodore Ts'o wrote:
> Received: from optimus.ietf.org (optimus22.ietf.org [132.151.6.22])
>         by fort-point-station.mit.edu (8.12.4/8.9.2) with ESMTP id i3EDUosM018893;
>         Wed, 14 Apr 2004 09:30:51 -0400 (EDT)
> Received: from localhost.localdomain ([127.0.0.1] helo=www1.ietf.org)
>         by optimus.ietf.org with esmtp (Exim 4.20)
>         id 1BDkL7-0005ld-6v; Wed, 14 Apr 2004 09:22:05 -0400
> Received: from odin.ietf.org ([132.151.1.176] helo=ietf.org)
>         by optimus.ietf.org with esmtp (Exim 4.20)
>         id 1BDkHl-0004qq-LQ
>         for [email-masked]; Wed, 14 Apr 2004 09:18:37 -0400
> Received: from ietf-mx (ietf-mx.ietf.org [132.151.6.1])
>         by ietf.org (8.9.1a/8.9.1a) with ESMTP id JAA23122
>         for <[email-masked]>; Wed, 14 Apr 2004 09:18:34 -0400 (EDT)
> Received: from ietf-mx ([132.151.6.1])
>         by ietf-mx with esmtp (Exim 4.12)
>         id 1BDkHk-0002Ew-00
>         for [email-masked]; Wed, 14 Apr 2004 09:18:36 -0400
> Received: from exim by ietf-mx with spam-scanned (Exim 4.12)
>         id 1BDkGr-00028Q-00
>         for [email-masked]; Wed, 14 Apr 2004 09:17:41 -0400
> 
> Received: from inet-tsb.toshiba.co.jp ([202.33.96.40])
>         by ietf-mx with esmtp (Exim 4.12)
>         id 1BDkGP-00021d-00
>         for [email-masked]; Wed, 14 Apr 2004 09:17:13 -0400
> Received: from tsb-wall.toshiba.co.jp ([133.199.160.134])
>         by inet-tsb.toshiba.co.jp  with ESMTP id i3EDH8gH029360;
>         Wed, 14 Apr 2004 22:17:08 +0900 (JST)
> Received: (from root@localhost)
>         by tsb-wall.toshiba.co.jp  id i3EDH8Rc001649;
>         Wed, 14 Apr 2004 22:17:08 +0900 (JST)
> Received: from tis2 [133.199.160.66] by tsb-wall.toshiba.co.jp with SMTP id YAA01648 ; Wed, 14 Apr2004 22:17:08 +0900
> Received: from mx4.toshiba.co.jp by tis2.tis.toshiba.co.jp
>         id WAA04448; Wed, 14 Apr 2004 22:17:07 +0900 (JST)
> Received: from tsb-sgw2.toshiba.co.jp by toshiba.co.jp id WAA12933; Wed, 14 Apr 2004 22:17:07
> +0900 (JST)
> Received: from tsbpo1.po.toshiba.co.jp
>         by tsb-sgw2.toshiba.co.jp  with ESMTP id i3EDH6a3001756;
>         Wed, 14 Apr 2004 22:17:06 +0900 (JST)
> Received: from steelhead ([172.30.24.114]) by tsbpo1.po.toshiba.co.jp
>  (Sun Internet Mail Server sims.3.5.1999.01.13.19.49.p4)
>  with ESMTP id <[email-masked]>; Wed,
>  14 Apr 2004 22:17:05 +0900 (JST)
> Received: from ohba by steelhead with local (Exim 3.36 #1 (Debian))
>  id 1BDY7v-0003eB-00; Tue, 13 Apr 2004 17:19:39 -0700
> 
> ______________________________________________________________________
> 
> Date: 14 Apr 2004 06:29:25 -0700
> 
> ______________________________________________________________________
> 
> Reporting-MTA: dns;mc10-s16.hotmail.com
> Received-From-MTA: dns;mc10-f37.hotmail.com
> Arrival-Date: Wed, 14 Apr 2004 06:29:25 -0700
> 
> Original-Recipient: 
> Final-Recipient: rfc822;[email-masked]
> Action: failed
> Status: 4.4.6
> 
> Original-Recipient: 
> Final-Recipient: rfc822;[email-masked]
> Action: failed
> Status: 4.4.6
> 
> Original-Recipient: 
> Final-Recipient: rfc822;[email-masked]
> Action: failed
> Status: 4.4.6
> 
> Original-Recipient: 
> Final-Recipient: rfc822;[email-masked]
> Action: failed
> Status: 4.4.6
> 
> Original-Recipient: 
> Final-Recipient: rfc822;[email-masked]
> Action: failed
> Status: 4.4.6
> 
> Original-Recipient: 
> Final-Recipient: rfc822;[email-masked]
> Action: failed
> Status: 4.4.6
> 
> Original-Recipient: 
> Final-Recipient: rfc822;[email-masked]
> Action: failed
> Status: 4.4.6
> 
> Original-Recipient: 
> Final-Recipient: rfc822;[email-masked]
> Action: failed
> Status: 4.4.6
> 
> ______________________________________________________________________
> 
> Date: 13 Apr 2004 17:19:39 -0700
> 
> Received: from mc10-f37.hotmail.com ([65.54.166.173]) by mc10-s16.hotmail.com with Microsoft SMTPSVC(5.0.2195.6824);
> 	 Wed, 14 Apr 2004 06:29:25 -0700
> Received: from optimus.ietf.org ([132.151.6.22]) by mc10-f37.hotmail.com with Microsoft SMTPSVC(5.0.2195.6824);
> 	 Wed, 14 Apr 2004 06:27:13 -0700
> Received: from localhost.localdomain ([127.0.0.1] helo=www1.ietf.org)
> 	by optimus.ietf.org with esmtp (Exim 4.20)
> 	id 1BDkL6-0005lX-Q5; Wed, 14 Apr 2004 09:22:04 -0400
> Received: from odin.ietf.org ([132.151.1.176] helo=ietf.org)
> 	by optimus.ietf.org with esmtp (Exim 4.20)
> 	id 1BDkHl-0004qq-LQ
> 	for [email-masked]; Wed, 14 Apr 2004 09:18:37 -0400
> Received: from ietf-mx (ietf-mx.ietf.org [132.151.6.1])
> 	by ietf.org (8.9.1a/8.9.1a) with ESMTP id JAA23122
> 	for <[email-masked]>; Wed, 14 Apr 2004 09:18:34 -0400 (EDT)
> Received: from ietf-mx ([132.151.6.1])
> 	by ietf-mx with esmtp (Exim 4.12)
> 	id 1BDkHk-0002Ew-00
> 	for [email-masked]; Wed, 14 Apr 2004 09:18:36 -0400
> Received: from exim by ietf-mx with spam-scanned (Exim 4.12)
> 	id 1BDkGr-00028Q-00
> 	for [email-masked]; Wed, 14 Apr 2004 09:17:41 -0400
> Received: from inet-tsb.toshiba.co.jp ([202.33.96.40])
> 	by ietf-mx with esmtp (Exim 4.12)
> 	id 1BDkGP-00021d-00
> 	for [email-masked]; Wed, 14 Apr 2004 09:17:13 -0400
> Received: from tsb-wall.toshiba.co.jp ([133.199.160.134])
> 	by inet-tsb.toshiba.co.jp  with ESMTP id i3EDH8gH029360;
> 	Wed, 14 Apr 2004 22:17:08 +0900 (JST)
> Received: (from root@localhost)
> 	by tsb-wall.toshiba.co.jp  id i3EDH8Rc001649;
> 	Wed, 14 Apr 2004 22:17:08 +0900 (JST)
> Received: from tis2 [133.199.160.66] by tsb-wall.toshiba.co.jp with SMTP id YAA01648 ; Wed, 14 Apr 2004 22:17:08 +0900
> Received: from mx4.toshiba.co.jp by tis2.tis.toshiba.co.jp 
> 	id WAA04448; Wed, 14 Apr 2004 22:17:07 +0900 (JST)
> Received: from tsb-sgw2.toshiba.co.jp by toshiba.co.jp id WAA12933; Wed, 14 Apr 2004 22:17:07 +0900 (JST)
> Received: from tsbpo1.po.toshiba.co.jp 
> 	by tsb-sgw2.toshiba.co.jp  with ESMTP id i3EDH6a3001756;
> 	Wed, 14 Apr 2004 22:17:06 +0900 (JST)
> Received: from steelhead ([172.30.24.114]) by tsbpo1.po.toshiba.co.jp
>  (Sun Internet Mail Server sims.3.5.1999.01.13.19.49.p4)
>  with ESMTP id <[email-masked]>; Wed,
>  14 Apr 2004 22:17:05 +0900 (JST)
> Received: from ohba by steelhead with local (Exim 3.36 #1 (Debian))
>  id 1BDY7v-0003eB-00; Tue, 13 Apr 2004 17:19:39 -0700
> In-reply-to: <001101c421fc$cde9bfe0$2101a8c0@cappone>
> Message-id: <20040414001939.GN11313@steelhead>
> MIME-version: 1.0
> Content-type: text/plain; charset=iso-2022-jp
> Content-disposition: inline
> User-Agent: Mutt/1.5.5.1+cvs20040105i
> References: <012c01c421ee$9b83dda0$2101a8c0@cappone>
>  <002101c421f8$58105d50$040aa8c0@yo2lux>
>  <001101c421fc$cde9bfe0$2101a8c0@cappone>
> X-Spam-Checker-Version: SpamAssassin 2.60 (1.212-2003-09-23-exp) on 
> 	ietf-mx.ietf.org
> X-Spam-Status: No, hits=0.2 required=5.0 tests=AWL,DATE_IN_PAST_12_24 
> 	autolearn=no version=2.60
> Sender: [email-masked]
> Errors-To: [email-masked]
> X-BeenThere: [email-masked]
> X-Mailman-Version: 2.0.12
> Precedence: bulk
> List-Unsubscribe: <https://www1.ietf.org/mailman/listinfo/ipsec>,
> 	<mailto:[email-masked]?subject=unsubscribe>
> List-Post: <mailto:[email-masked]>
> List-Help: <mailto:[email-masked]?subject=help>
> List-Subscribe: <https://www1.ietf.org/mailman/listinfo/ipsec>,
> 	<mailto:[email-masked]?subject=subscribe>
> Return-Path: [email-masked]
> X-OriginalArrivalTime: 14 Apr 2004 13:27:16.0681 (UTC) FILETIME=[346AFB90:01C42224]
>

---

From: "Douglas E. Engert" <[email-masked]>
Date: Wed, 14 Apr 2004 13:19:31 -0500

This is not an IETF specific problem. With the introduction of SPAM 
and virus scanners at senders, mail lists and receiving sites, 25 is 
much more realistic.  

We have seen a similar problem on the ietf-krb list, when mail 
coming from internal Microsoft addresses to the mailing list was sent
to some sites using Exchange.  The older Exchange systems had a hop 
count of 15. We had seen a recommendation for Microsoft to raise the 
hop count to 25, and most sites appear to have done this. 

Theodore Ts'o wrote:
>   ---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
> 
>   ---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
>   ---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
> 
> CC: yo2lux <[email-masked]>, [email-masked]

-- 

 Douglas E. Engert  <[email-masked]>
 Argonne National Laboratory
 9700 South Cass Avenue
 Argonne, Illinois  60439 
 (630) 252-5444