Subject: Re: IETF mailing lists use lots of received lines?

From: Bill Fenner <[email-masked]>
Date: Wed, 14 Apr 2004 10:31:49 -0700

Wouldn't it be more effective to ask hotmail to follow the SHOULD advice
in RFC 2821 and set their loop threshold to 100?

I've found the individual ietf.org Received: headers invaluable recently
in determining where inside ietf.org some delays were occurring; if they
were not available after the message was forwarded outside ietf.org this
task would have been much more difficult.

  Bill

---

From: [email-masked]
Date: Wed, 14 Apr 2004 13:51:48 -0400

Ted,

I've seen this on the rddp mailing list, but only with
a corporate site that apparently added this limit check at
some point after the list was up and functioning.

Pointed email to both the postmaster and affected recipients
at the site about what was going on and why seemed to cause
it to get fixed.  I'm not sure this "tail" would be enough to
wag the hotmail "dog" though ...

--David

> -----Original Message-----
> From: Theodore Ts'o [mailto:[email-masked]] 
> Sent: Wednesday, April 14, 2004 12:45 PM
> To: [email-masked]; [email-masked]
> Cc: [email-masked]; [email-masked]; 
> [email-masked]
> Subject: IETF mailing lists use lots of received lines?
> 
> 
> We are in the midst of transitioning the IPSEC mailing list to
> [email-masked], and we seem to have run into an interesting problem.
> The IETF mailing list system seems to use a large number of
> intervening hops:
> 
> Received: from optimus.ietf.org (optimus22.ietf.org [132.151.6.22])
>         by fort-point-station.mit.edu (8.12.4/8.9.2) with 
> ESMTP id i3EDUosM018893;
>         Wed, 14 Apr 2004 09:30:51 -0400 (EDT)
> Received: from localhost.localdomain ([127.0.0.1] helo=www1.ietf.org)
>         by optimus.ietf.org with esmtp (Exim 4.20)
>         id 1BDkL7-0005ld-6v; Wed, 14 Apr 2004 09:22:05 -0400
> Received: from odin.ietf.org ([132.151.1.176] helo=ietf.org)
>         by optimus.ietf.org with esmtp (Exim 4.20)
>         id 1BDkHl-0004qq-LQ
>         for [email-masked]; Wed, 14 Apr 2004 09:18:37 -0400
> Received: from ietf-mx (ietf-mx.ietf.org [132.151.6.1])
>         by ietf.org (8.9.1a/8.9.1a) with ESMTP id JAA23122
>         for <[email-masked]>; Wed, 14 Apr 2004 09:18:34 -0400 (EDT)
> Received: from ietf-mx ([132.151.6.1])
>         by ietf-mx with esmtp (Exim 4.12)
>         id 1BDkHk-0002Ew-00
>         for [email-masked]; Wed, 14 Apr 2004 09:18:36 -0400
> Received: from exim by ietf-mx with spam-scanned (Exim 4.12)
>         id 1BDkGr-00028Q-00
>         for [email-masked]; Wed, 14 Apr 2004 09:17:41 -0400
> 
> When this is combined with systems whose internal mailers use a
> largish number of hops in order to transit out of their intranet,
> through their firewall, and to the outside world (see below for one
> example), the net result trips anti-looping schemese.  
> 
> For example, hotmail.com will bounce any mail message that contains
> more than 10 Received: lines.  Given that the IETF mail system is
> adding a minimum of six Received: lines, it doesn't take much more to
> trip hotmail's anti-looping mechanism.  Surely Toshiba is somewhat
> extreme that outgoing mail messages will go through nine (9!!!)
> mailers before reaching the outside world, but the net result is that
> people who are using hotmail will be losing some number of messages
> sent to the [email-masked] mailing list.
> 
> Is this something that can be fixed on the ietf.org side, perhaps by
> filtering out or transmuting some of the internal the IETF-added
> Received: lines to "X-Received:"?  That way the information is still
> there for debugging purposes, but it won't trip relatively naive
> anti-looping mechanisms, such as those currently in use at hotmail.
> 
> Also, has any other wg chairs who have their mailing lists homed at
> ietf.org noticed this?  If I had been automatically filter bounce
> messages that come from virii, I might not have noticed this bounce
> message.  Fortunately this was during a transition, so I was paying
> close attention in order to assure that everything was going smoothly,
> or it might have gotten filtered out and flushed.
> 
> Finally, folks at Toshiba might want to be warned that they may also
> want to do similar filtering.  Given that Toshiba is adding nine
> levels of Received: headers, and hotmail apparently bounces any
> messages with more than 10, my guess is that some number of messages
> from Toshiba may not be reaching their intended recipients.
> 
> 						- Ted
> 
> 
> Received: from inet-tsb.toshiba.co.jp ([202.33.96.40])
>         by ietf-mx with esmtp (Exim 4.12)
>         id 1BDkGP-00021d-00
>         for [email-masked]; Wed, 14 Apr 2004 09:17:13 -0400
> Received: from tsb-wall.toshiba.co.jp ([133.199.160.134])
>         by inet-tsb.toshiba.co.jp  with ESMTP id i3EDH8gH029360;
>         Wed, 14 Apr 2004 22:17:08 +0900 (JST)
> Received: (from root@localhost)
>         by tsb-wall.toshiba.co.jp  id i3EDH8Rc001649;
>         Wed, 14 Apr 2004 22:17:08 +0900 (JST)
> Received: from tis2 [133.199.160.66] by 
> tsb-wall.toshiba.co.jp with SMTP id YAA01648 ; Wed, 14 
> Apr2004 22:17:08 +0900
> Received: from mx4.toshiba.co.jp by tis2.tis.toshiba.co.jp
>         id WAA04448; Wed, 14 Apr 2004 22:17:07 +0900 (JST)
> Received: from tsb-sgw2.toshiba.co.jp by toshiba.co.jp id 
> WAA12933; Wed, 14 Apr 2004 22:17:07
> +0900 (JST)
> Received: from tsbpo1.po.toshiba.co.jp
>         by tsb-sgw2.toshiba.co.jp  with ESMTP id i3EDH6a3001756;
>         Wed, 14 Apr 2004 22:17:06 +0900 (JST)
> Received: from steelhead ([172.30.24.114]) by tsbpo1.po.toshiba.co.jp
>  (Sun Internet Mail Server sims.3.5.1999.01.13.19.49.p4)
>  with ESMTP id <[email-masked]>; Wed,
>  14 Apr 2004 22:17:05 +0900 (JST)
> Received: from ohba by steelhead with local (Exim 3.36 #1 (Debian))
>  id 1BDY7v-0003eB-00; Tue, 13 Apr 2004 17:19:39 -0700
>