Subject: Heads-up: we intend to tell people "new boilerplate please"

From: Harald Tveit Alvestrand <[email-masked]>
Date: Wed, 02 Jun 2004 16:26:07 -0700

We're currently in the process of (at last!) upgrading to support the new 
boilerplate (RFC 3667) only.

We're going to set a cutoff date for I-D submissions, saying that "after 
this date, ONLY I-Ds with new boilerplate will be accepted".

June 15 is our target date - but we're not firmly wedded to a date until we 
have all the guideline documents updated - and things are taking (too much) 
time!

               Harald

---

From: "W. Mark Townsley" <[email-masked]>
Date: Thu, 03 Jun 2004 09:47:36 +0200

In the spirit of being liberal in what you accept, I think it would be 
reasonable to accept old-style biolerplates until, say, after the next meeting 
(perhaps with a warning sent in response to the old-style submitter).

- Mark

Harald Tveit Alvestrand wrote:

> We're currently in the process of (at last!) upgrading to support the 
> new boilerplate (RFC 3667) only.
> 
> June 15 is our target date - but we're not firmly wedded to a date until 
> we have all the guideline documents updated - and things are taking (too 
> much) time!
> 
>               Harald
> 
> 
>

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Thu, 03 Jun 2004 07:06:24 -0700

I note that 1id-guidelines.txt still says to use RFC 2026 text.

At 04:26 PM 6/2/2004, Harald Tveit Alvestrand wrote:
>We're currently in the process of (at last!) upgrading to support the new boilerplate (RFC 3667) only.
>
>We're going to set a cutoff date for I-D submissions, saying that "after this date, ONLY I-Ds with new boilerplate will be accepted".
>
>June 15 is our target date - but we're not firmly wedded to a date until we have all the guideline documents updated - and things are taking (too much) time!
>
>              Harald
>

---

From: Barbara Fraser <[email-masked]>
Date: Thu, 3 Jun 2004 07:52:49 -0700

Hi Harald,

When you say "ONLY I-Ds with new boilerplate will be accepted" do you 
mean this to apply to -0 version I-Ds? Or, are you expecting all 
updates to existing drafts to have to be recast in the new boilerplate?

Barb

On Jun 2, 2004, at 4:26 PM, Harald Tveit Alvestrand wrote:

> We're going to set a cutoff date for I-D submissions, saying that 
> "after this date, ONLY I-Ds with new boilerplate will be accepted".
>
> June 15 is our target date - but we're not firmly wedded to a date 
> until we have all the guideline documents updated - and things are 
> taking (too much) time!
>
>               Harald
>
>

---

From: Harald Tveit Alvestrand <[email-masked]>
Date: Thu, 03 Jun 2004 07:53:57 -0700

I'm working on that.

---

From: Harald Tveit Alvestrand <[email-masked]>
Date: Thu, 03 Jun 2004 08:03:49 -0700

--On 3. juni 2004 07:52 -0700 Barbara Fraser <[email-masked]> wrote:

> mean this to apply to -0 version I-Ds? Or, are you expecting all updates
> to existing drafts to have to be recast in the new boilerplate?

Sooner or later, we need to tell all I-Ds to be published with the new 
boilerplate, no matter what version.

It's the simplest message if the cutoff date is the same for both -00 and 
non-00 drafts.

Do you think they should be different?

                            Harald

---

From: David Meyer <[email-masked]>
Date: Thu, 3 Jun 2004 11:09:56 -0700

>> Do you think they should be different?

I would think they should be the same. BTW, I'm not really sure
what the issue is, as updating with the new BP isn't really that
hard (or updating the BP for the next revision). 

Dave

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 04 Jun 2004 10:19:54 +0200

> hard (or updating the BP for the next revision). 

There are two issues.

One is that quite a few people believe that the new BP was not
properly reviewed in the IPR WG and is in fact broken. But that
is not a debate for this list.

The other is whether corporate lawyers will allow employees
to use the new text without considerable delay.

I advise either more notice or more wiggle room.

    Brian

---

From: David Meyer <[email-masked]>
Date: Fri, 4 Jun 2004 07:45:39 -0700

On Fri, Jun 04, 2004 at 10:19:54AM +0200, Brian E Carpenter wrote:
>> >>>It's the simplest message if the cutoff date is the same for both -00 
>> >>>and non-00 drafts.
>> >>>

	OK, that's certainly legitimate.

>> to use the new text without considerable delay.

	Also legitimate.

>> I advise either more notice or more wiggle room.

	Agree.

	Dave

---

From: Cullen Jennings <[email-masked]>
Date: Mon, 07 Jun 2004 08:43:21 -0700

Change, particularly change of legal contracts, is a very concerning thing
for people and it takes time for them to become comfortable with it. I think
we need some time to "debug the legalizes" in the new boiler plate. Or at
least debug peoples bizarre interpretation of what they mean. We have
already had some things in it that many people feel need clarification. I
really don't see the rush but perhaps no one will pay any attention to it
until a week before the hard cut off no matter what date we set the cut off.

Cullen

---

From: Harald Tveit Alvestrand <[email-masked]>
Date: Mon, 07 Jun 2004 16:08:51 -0700

--On 7. juni 2004 08:43 -0700 Cullen Jennings <[email-masked]> wrote:

> for people and it takes time for them to become comfortable with it. I
> think we need some time to "debug the legalizes" in the new boiler plate.
> Or at least debug peoples bizarre interpretation of what they mean. We
> have already had some things in it that many people feel need
> clarification. I really don't see the rush but perhaps no one will pay
> any attention to it until a week before the hard cut off no matter what
> date we set the cut off.

A hard cutoff definitely seems to be the way to get people's attention.

                    Harald