Subject: RE: Questions on 3667/8 and the current correct order of things.. .

From: Harald Tveit Alvestrand <[email-masked]>
Date: Sun, 18 Jul 2004 23:20:57 +0200

I know of at least one bug in 1id-guidelines, which I have promised to fix. 
There are probably more.

But we found one bug in the RFCs too, and the ipr-wg list spent some time 
debating that.

What I want to have is:

- RFCs that lay down a consistent set of rules
- 1id-guidelines that summarize those rules correctly
- xml2rfc tools that produce boilerplate matching the rules
- a secretariat that checks the important things against the rules

But at the moment, I don't even have the first one. I hope we can get this 
fixed "soon".
In the meantime .... that's why boilerplate checking @secretariat is turned 
off.

                   Harald

--On 29. juni 2004 13:27 -0400 Eastlake III Donald-LDE008 
<[email-masked]> wrote:

> Don't try to figure it out from the confusing RFCs. Just
> go to http://www.ietf.org/ietf/1id-guidelines.txt which
> is what the Secretariate actually enforces anyway.

---

From: Bob Braden <[email-masked]>
Date: Mon, 19 Jul 2004 10:38:52 -0700 (PDT)

Harald,

I just went through the task of satisfying (I think ;-)) the I-D rules
for IPR boilerplate, when I updated RFC2223bis to -08.  The instructions
in 1id-guidelines seemed clear enough to me.

[But note that the IPR rules are indeed a little complex;
unfortunately, we musdt assume that the Lawyers Rule in this one.]

Of course, the rules for an RFC are somewhat different from those for
an I-D.  We hope that the -08 draft of RFC2223bis clearly specifies
what an RFC requires.  (Although, in fact an RFC author probably does not
really care... if the I-D arrives at our door with the right stuff, we
will add/modify the boilerplate as needed.)

Bob Braden for the RFC Editor

  *> 
  *> Date: Sun, 18 Jul 2004 23:20:57 +0200
  *> From: Harald Tveit Alvestrand <[email-masked]>
  *> To: Eastlake III Donald-LDE008 <[email-masked]>, "'Russ White'" 
  *> <[email-masked]>, [email-masked]
  *> Subject: RE: Questions on 3667/8 and the current correct order of things.. .
  *> 
  *> I know of at least one bug in 1id-guidelines, which I have promised to fix. 
  *> There are probably more.
  *> 
  *> But we found one bug in the RFCs too, and the ipr-wg list spent some time 
  *> debating that.
  *> 
  *> What I want to have is:
  *> 
  *> - RFCs that lay down a consistent set of rules
  *> - 1id-guidelines that summarize those rules correctly
  *> - xml2rfc tools that produce boilerplate matching the rules
  *> - a secretariat that checks the important things against the rules
  *> 
  *> But at the moment, I don't even have the first one. I hope we can get this 
  *> fixed "soon".
  *> In the meantime .... that's why boilerplate checking @secretariat is turned 
  *> off.
  *> 
  *>                    Harald
  *> 
  *> --On 29. juni 2004 13:27 -0400 Eastlake III Donald-LDE008 
  *> <[email-masked]> wrote:
  *> 
  *> > Don't try to figure it out from the confusing RFCs. Just
  *> > go to http://www.ietf.org/ietf/1id-guidelines.txt which
  *> > is what the Secretariate actually enforces anyway.
  *> 
  *> 
  *> 
  *> 
  *> 
  *> 
  *> ------------- End Forwarded Message -------------
  *> 
  *>