Subject: RE: downgrading authors to contributors?

From: Andy Bierman <[email-masked]>
Date: Mon, 09 Aug 2004 15:24:05 -0700

At 02:28 PM 8/9/2004, Eastlake III Donald-LDE008 wrote:

Sounds like process-oriented disfunction to me...

So if person A writes a 99 page RFC, and years later
person B adds 1 new page, then person A will get
removed from the author list if they don't participate
in the AUTH48 process -- which BTW, is only related
to the 1 new page and not the 99 existing pages.

Sounds FUBAR to me...

Andy

>While we are required to credit people who made substantial contributions, exactly who appears in the upper right corner of the front page is just an artifact of our administrative system. As has already been pointed out, anyone who won't cooperate in the AUTH48 process or who objects to the new boilerplate automatically has to be removed from the "Author" list. I myself have been involved as one of two co-authors of an individual draft where the other co-author had to be moved to an acknowledgement when they persistently refused to respond in any way at AUTH48. While I agree that it is nice for the Author list to reflect those who made the largest contribution, that's just not always possible.
>
>Donald
>
>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]] On Behalf Of Andy Bierman
>Sent: Monday, August 09, 2004 3:56 PM
>To: Aaron Falk
>Cc: [email-masked]; Radia Perlman
>Subject: Re: downgrading authors to contributors?
>
>
>At 10:02 AM 8/9/2004, Aaron Falk wrote:
>
>>On Aug 8, 2004, at 12:04 AM, Radia Perlman wrote:
>>
>>>I asked the old authors who had pretty much disappeared
>>>for most of the writing, whether they wanted to still be involved, in which case they
>>>could give a careful review of the pretty much completed document, or wanted to
>>>be moved to the acknowledgement section. They volunteered to be moved to
>>>the acknowledgement section.
>>
>>I like what Radia has written as a good rule of thumb:
>>
>>1) explicit expression of continued interest
>>2) willingness to conduct careful reviews, say, at wglc and auth48
>
>I strongly object to the notion of removing existing authors
>when a specification is updated.  Let's say the original
>author wrote 99 of 100 pages for an RFC.  That person is
>no longer available to work on the new update.  Somebody
>else updates the document (adds 1 page, e.g., updates
>some detail to include IPv6 address support).
>
>It is inappropriate to delete the original author who
>wrote most of the RFC.  It's fine to add the new author(s)
>to the list -- even though it will appear the new people
>worked on all of the ideas in the RFC, but they just made
>minor updates instead.
>
>Andy
>
>
>
>>As Pekka points out, the document belongs to the working group.  So long as contributors are explicitly recognized, we should reward folks who are willing to make the commitment to take the document to completion.  Followthrough is hard.  And important.
>>
>>--aaron
>>
>>

---

From: Pekka Savola <[email-masked]>
Date: Tue, 10 Aug 2004 08:38:55 +0300 (EEST)

> to the 1 new page and not the 99 existing pages.

Luckily enough that's not the case (maybe it was earlier, but not
anymore in any case).  The AD can approve publication of (upcoming)
RFC at AUTH48 even if none of the authors are responding, so it's not
a showstopper.  This has happened a couple of times to me.

Undeniably, it causes more delay because it's still courteous to wait
for some time, but we've had RFCs published where none of the authors
were reachable.. (final editing was done by myself as chair, and I
didn't add myself to the author list.)

FWIW, I agree that the size of contribution counts.  If the original
spec was say 100 pages, the authors of that spec should definitely
stay as authors.

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings