Subject: RE: I-D submission tool draft

From: [email-masked]
Date: Tue, 14 Sep 2004 10:00:41 +0300

Pekka,

> Don't take vacations then.  That's why being a WG chair gives you the
> big bucks ;-).
> 
> But seriously, unless WG chairs/secretaries coordinate, having long
> vacations prior to the meetings is a recipe for disaster.  Maybe this
> calls for a slightly different meeting times, or just sacrifices wrt.  
> vacations from the chairs and WG participants..

Well, I generally push back on new processes or procedures unless there
is clearly reasons for the processes.  What is the problem that the new
process is trying to solve & is the burden of the new process significantly
less than the burden which the problem is currently causing - these are
always my first questions.	

The current draft says:

   .... No malicious
   impersonations or fake approvals have been reported to date however.

   Lack of authentication is not perceived as a serious problem,
   possibly because serious falsification are likely to be noticed
   before serious damage can be done.  Due to informal and manual nature
   of the submission mechanism, its massive automated abuse is unlikely
   to cause anything but a short denial of draft posting service and,
   hence, is probably not worth defending against.  However, future
   automation may result in a different trade off.

Which indicates to me that there is not a current problem, so at present
we don't need to burder WG chairs with more processes.  Interupting my
vacation does represent a burden to me.  Addionally, there is the possiblity
of disruption if WG drafts are not approved in time to make meeting
draft cut-offs.  This could impact upon the timely-ness of a WG to meet
its charter, if a draft misses one meeting cycle.

John

---

From: "Lars-Erik Jonsson (LU/EAB)" <[email-masked]>
Date: Tue, 14 Sep 2004 11:33:12 +0200

I share Magnus concerns about an implicit approval process for
new WG drafts, and I do not think it is a big issue for us
chairs to approve new WG drafts. It is a matter of 
communication between author(s) and chair(s), and if we can
have a pre-approval mechanism this should not at all be an
issue.

/L-E

> I am not agreeing with you on the implicit approval process. 
> At least in my WG (AVT) it is quite common that people are
> somewhat confused on the process and do not sufficiently
> understand the distinction between WG documents and
> individual submission. In addition we are allowed by the 
> AD as WG chairs to make the decision to approve RTP payload 
> formats as WG items. Thus I like to have the necessary
> control that no drafts gets available as WG items before our
> explicit approval.
> 
> If there is also a process where the WG chair can pre-approve
> WG drafts, it can work smoothly even before meetings or when
> the chair is on vacation. It then becomes a matter of the
> author to communicate with the WG chair if it really
> necessary to get it out ASAP. I hope such an interface would
> use a cut-off deadline based the submission, rather then the
> WG chairs approval. Although the chair should also have an
> deadline.

---

From: [email-masked]
Date: Tue, 14 Sep 2004 13:16:43 +0300

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On
> Behalf Of ext Henrik Levkowetz
> Sent: 14.September.2004 12:52
> To: [email-masked]
> Cc: [email-masked]; Jari Arkko
> Subject: Re: [Tools-discuss] Fw: I-D submission tool draft
> 
> 
> Hi Jari,
> 
> 	Thanks for the feedback!  Some notes inline...
> 
> Jari Arkko wrote:
> 
> > 
> > I like automation. I think it would be great if the
> > tools handled nits checking, file posting, IPR/copyright
> > confirmation and all that, probably getting the draft
> > to the web site in minutes. Compare this to the delay
> > we have now, which is days -- not bad compared to past
> > times but it would still speed up the process, let the
> > secretariat do other, more useful things. And it would
> > probably increase quality too, less accidents and more
> > formal checking during submission.
> > 
> > I think the tools should read things like author information
> > from the draft. People would hate typing all that in again.
> > But it may be fine for the tool to ask if the information
> > it has read is correct, as a confirmation. Or get a
> > confirmation that the user has read "Note well".
> 
> Agreed, on both counts.
> 
> > As for the chair approval part: when we automate processes,
> > we do not have to follow the current manual process, we
> > can do things in a different way if it makes sense. Just because
> > we can require a chair to sign off in the tool does not
> > mean that we should. In fact, in order to make things go
> > smoothly, I would propose that an optimistic security
> > mechanism be adopted as opposed to a prior or real-time
> > approval: give the chairs a function to remove a WG draft
> > if someone has fraudulently/erroneously submitted one.
> 
> !! That's an interesting idea, which we've not discussed in
> the team.  I like it :-)
> 

This is ok until the same draft is resubmitted a few months later with changes, but using the same name (since the first one was not approved, the name is not reserved). This results in 2 drafts with the same version number and different contents that the public has had access to. A draft should be approved before made public.

Regards,
Hisham