Subject: RE: Agenda is still incomplete

From: Eastlake III Donald-LDE008 <[email-masked]>
Date: Thu, 28 Oct 2004 11:04:13 -0400

In IEEE 802.11, for example, the largest and most complex of
all the 802 working group, the tentative agenda is posted
about a month before the meeting but is subject to change
at the opening and mid-week plenary sessions.

(802.11 runs very differently than IETF. Most everything is
done at meetings using Roberts Rules and there are complex
criteria for determining who can vote, etc. There are
many fewer Task Groups, etc., under 802.11 than there are
IETF Working Groups and they meet for many more hours
during the week. Someone would never qualify as a voter in
802.11 if they only showed up for a few days since you have
to have attended meetings during more than 75% of the
session slots at multiple meetings to become a voter.)

If you have Excel and want to see the 802.11 agenda for its
Meeting the week after the upcoming IETF meeting, go to
http://www.ieee802.org/11/Meetings/11-04-0993-00-0000-802.11-WG-Tentative-Agenda-November-2004.xls
and click on the "802.11 WLAN Graphic" tab at the bottom.

Donald

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Andy Bierman
Sent: Thursday, October 28, 2004 10:35 AM
To: Pekka Savola
Cc: [email-masked]
Subject: RE: Agenda is still incomplete

At 02:24 AM 10/28/2004, Pekka Savola wrote:
>On Thu, 28 Oct 2004, Lars-Erik Jonsson (LU/EAB) wrote:
>>>So I will make this pledge as a WG  chair - I will either submit my
>>>meeting request, or plan on not meeting within 2 weeks of the first
>>>agenda request message  coming out.
>>>
>>>Anyone else want to join me in this pledge ? (Don't flood the
>>>list with yes/no - just put yourself into a catagory in your head)
>>
>>Personally, I have concerns about such an approach, as I actually
>>do not know at that point whether the WG needs agenda time or not,
>>and if a meeting slot is needed, I would not be able to estimate the
>>time needed.
>
>Agree.  The chairs and ADs will have to decide whether they'll need to meet at all, and if yes, whether they'd want 1, 2, or 2.5 hours (if a single session), 2+1, 2.5+1, 2.5+2, 2.5+2.5, etc. (if two sessions) and so on.
>
>In many cases, I think it's relatively easy (in the busy WGs as least) to be able to say, "yes, we'll need at least one slot".  But it's often difficult to figure out a month or two in advance how long slots, and how many of them, would be needed.

Well we disagree on the level of difficulty involved.
Right now we have a system that is designed so a handful
of people can wait an extra two weeks before deciding if
they want a timeslot at the upcoming meeting, instead of
designing for the 2000 people who want the final agenda out.

I am curious what the norm is for other conferences.
Does anyone know how many days before the start of
a conference the final agenda is published for other
organizations like IEEE?

Andy

>These problems seem to stem from the fact that some folks want to be there only for a part of the meeting (and still book well in advance for cheap fares), e.g., attend for 1-3 days.  I guess that's understandable, but not supportable at the moment.
>
>-- 
>Pekka Savola                 "You each name yourselves king, yet the
>Netcore Oy                    kingdom bleeds."
>Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings

---

From: "Romascanu, Dan \(Dan\)" <[email-masked]>
Date: Thu, 28 Oct 2004 18:38:31 +0200

I attend IEEE 802 meetings on regular basis lately. It is quite difficult to compare. The Working Group that I am attending meets almost for the whole week - typically Monday through Thursday. There are some fixed milestones in the weekly schedule, like an opening session and a closing session. There is a schedule announced in advanced, a few weeks before the meeting. However changes happen sometimes, and ad-hoc meetings are being decided even during the week for specific focus sub-groups. 

There are some evening events - tutorials, or Calls For Interest - similar in a way with the IETF BOFs. These are announced typically a month before the meeting.  

Overall, in these meetings the assumption is that you are there for the whole week, and that you dedicate most of your time to attending the meetings. There also is a mandatory attendance requirement (two thirds of the half-day sessions during the week), if you are interested in becoming a voting member, or keeping the membership. 

Regards,

Dan

---

From: "Lars-Erik Jonsson (LU/EAB)" <[email-masked]>
Date: Fri, 29 Oct 2004 15:20:08 +0200

I'm not a big fan of rules that are stricter than they need to be.
Of course we should encourage and simplify participation also for
those who can not be present for the whole week, but on the other
hand I do think we should have processes that encourage whole-week
participation, as that stimulates cross-area involvement which is
an important factor for a successful IETF. We should also stimulate
"real-work" at our meetings, which means to use WG sessions for
things that are hard to resolve on our main work channel, the WG
mail list. I would not have a problem with moving the slot-request
deadline earlier, a week or so, but I am not sure if that in itself
would solve any problem(s). It may be a help, but let's not focus
on that only.

Some things I have observed when looking at how the agenda for this
meeting evolved are:
- First (?) agenda was published on IETF.org on Oct 5th. I do not
  think that is at all a useful publication. It only included a
  small subset of all WG's, and was clearly subject to changes.
- Next revision of the agenda got out on Oct 28. What was going
  on in the meantime? Scheduling is hard and Marcia is doing a
  great job, but I do think we could all help to do better,
  especially in figuring out what should be publicly announced.
- I sent my slot request on Oct 10, which I personally think is
  early as I did not at that time really know whether my WG would
  have a need for it. Still, I was not able to answer people who
  asked if/when we would meet, first on Oct 28 I could give a
  preliminary answer to the "when"-question.  

I think we should not publish the first preliminary agenda
before we have a rather complete one, which people who have to use
an agenda as a basis for travel planning could reasonably trust
to be rather stable and almost complete. Before that, the agenda
should be circulated in pre-versions on the WG-chairs list, where
we would resolve most conflicts before we publish anything.

This is not a simple problem, so let's not pretend it would. If
all WG's would always meet, things would be simpler. Curious
question to those who are addicted to statistics; do we have any
information on how many WG's are not always meeting??? For a WG
like AVT, making an early request is easy as they always (??) meet
during two long slots, as Magnus pointed out. I guess there are
also WGs that can handle almost all their issues on their mail
list and thus "never" meet physically, making scheduling "easy".
However, I would guess there are many WGs that do not match any
of these extremes, and even AVT might end up there at one point
(I recognize it was not that long ago when AVT actually discussed
whether they needed to meet, right?).

/L-E