Subject: Re: [Tools-discuss] Mangled Internet-Drafts

From: Albert Vezza <[email-masked]>
Date: Mon, 22 Nov 2004 17:36:39 -0500

After more testing we determined that a filter could be placed to 
intercept email sent to [email-masked] and 
[email-masked] and ensure email containing attachments sent to 
those addresses had a "Content-disposition: attachment" as part of 
the file header.

A preliminary filter changing "Content-disposition: inline" to 
"Content-disposition: attachment" was placed in service on 11/18/04. 
We will soon have a more comprehensive  filter in place that will 
also handle email from older composers that do not specify a 
"Content-disposition:".  I will send an update when that filter is in 
place.

We belive that this will take care of all three problems that have 
been observed:  concatenated files, extra linefeeds in IDs, and 
missing form-feed.  If such problems are found in the future please 
let us know so we can track down the problem.

Al
-- 
Albert Vezza
President
Foretec Seminars, Inc
1895 Preston White Drive
Suite 100
Reston, VA 20191-5434

Internet mail: [email-masked]
Tel: (703) 620-9053
Fax: (703) 620-9071

Natick, MA Office
Tel:  (508) 650 4020
Fax:  (508) 650 4639

---

From: Harald Tveit Alvestrand <[email-masked]>
Date: Tue, 23 Nov 2004 11:01:47 +0100

--On tirsdag, november 23, 2004 00:12:12 +0100 JORDI PALET MARTINEZ 
<[email-masked]> wrote:

> Hi Albert, all,
>
> As someone already indicated, it will be helpful anyway to allow sending
> zip and tar files.
>
> Some corporate email servers compress all the attachments, and actually is
> not so easy for some to tell their IT services not to compress attachments
> sent to IETF ;-)
>
> On the other way around, this doesn't harm to the process, right ?

Well, it did once....

I believe the ban on zip files was introduced a few years ago (between Nov 
2001 and Jan 2002, the Wayback Machine says) because of an incident where a 
zip file contained a virus....... virus detection (and procedures for 
opening zip files) may have improved by now, but I think it's up to the 
secretariat if they want to rescind this ban.

                     Harald

---

From: Pekka Savola <[email-masked]>
Date: Tue, 23 Nov 2004 23:01:49 +0200 (EET)

Hi,

On Mon, 22 Nov 2004, Albert Vezza wrote:
> We belive that this will take care of all three problems that have been 
> observed:  concatenated files, extra linefeeds in IDs, and missing form-feed. 
> If such problems are found in the future please let us know so we can track 
> down the problem.

For what it's worth, my I-Ds had been mangled in the past, but an I-D 
published today came through OK.  So I believe the fix has been 
effective.  Thanks!

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Tue, 23 Nov 2004 00:12:12 +0100

Hi Albert, all,

As someone already indicated, it will be helpful anyway to allow sending zip
and tar files.

Regards,
Jordi

> De: Albert Vezza <[email-masked]>
> Responder a: [email-masked]
> Fecha: Mon, 22 Nov 2004 17:36:39 -0500
> Para: IESG <[email-masked]>, WG Chairs <[email-masked]>, Tools Team
> Discussion <[email-masked]>
> CC: [email-masked], [email-masked], [email-masked], Scott Blomquist
> <[email-masked]>, [email-masked]
> Asunto: Re: [Tools-discuss] Mangled Internet-Drafts
> 
> _______________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/tools-discuss
> 

**********************************
Madrid 2003 Global IPv6 Summit
Presentations and videos on line at:
http://www.ipv6-es.com

This electronic message contains information which may be privileged or confidential. The information is intended to be for the use of the individual(s) named above. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, including attached files, is prohibited.