Subject: RE: [Tools-discuss] RE: Mangled Internet-Drafts

From: Eric Burger <[email-masked]>
Date: Fri, 5 Nov 2004 18:02:56 -0500

Let's take a page from the W3C, and Computer Science, for that matter.  The
User Interface should be separate from the Verification and Submission
Engine.  That's called Separation of Concerns.  It works.

> -----Original Message-----
> From: Alex Rousskov [mailto:[email-masked]]
> Sent: Thursday, November 04, 2004 10:56 AM
> To: [email-masked]; [email-masked];
> [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: Re: [Tools-discuss] RE: Mangled Internet-Drafts
> 
> 
> On Thu, 2004/11/04 (MST), <[email-masked]> wrote:
> 
> > I would rather submit drafts by email than by webpages.
> 
> John,
> 
> 	As I have stated in my response to Paul, the Tools team 
> is very aware  
> that many people prefer email submission. That is why both 
> email and web  
> interfaces are to be supported.
> 
> 	Personally, I believe that off-line submission 
> convenience is less  
> important than submission quality, and that the later is much 
> easier to  
> monitor and improve with interactive web interface.
> However, I am not going to jeopardize the fate of the ID 
> submission tool  
> by trying to force IETFers to do what I think is right. This 
> is not the  
> fight worth fighting, IMO. Again, the ID Submission draft 
> requires both  
> email and web interfaces to be supported.
> 
> Thanks,
> 
> Alex.
>

---

From: Alex Rousskov <[email-masked]>
Date: Fri, 5 Nov 2004 21:42:06 -0700 (MST)

On Fri, 5 Nov 2004, Eric Burger wrote:

> Let's take a page from the W3C, and Computer Science, for that 
> matter.  The User Interface should be separate from the Verification 
> and Submission Engine.  That's called Separation of Concerns.  It 
> works.

Eric,

 	I agree that Separation of Concerns often works well, but I am 
not sure what you are suggesting in this particular case. Could you 
elaborate? FWIW, the ID Submission draft does not merge User 
Interfaces and Verification and Submission Engines (whatever that 
would mean). The draft does contain both interface and processing 
requirements.

Thanks,

Alex.

>> 	As I have stated in my response to Paul, the Tools team is 
>> very aware that many people prefer email submission. That is why 
>> both email and web interfaces are to be supported.
>>
>> 	Personally, I believe that off-line submission convenience is 
>> less important than submission quality, and that the later is much 
>> easier to monitor and improve with interactive web interface. 
>> However, I am not going to jeopardize the fate of the ID submission 
>> tool by trying to force IETFers to do what I think is right. This 
>> is not the fight worth fighting, IMO. Again, the ID Submission 
>> draft requires both email and web interfaces to be supported.
>>
>> Thanks,
>>
>> Alex.