Subject: RE: Tools team work items

From: Eric Burger <[email-masked]>
Date: Thu, 18 Nov 2004 03:45:25 -0500

This is an excellent idea, both the 3667 stuff *and* being able to
automagically get diffs.

> -----Original Message-----
> From: Rohan Mahy [mailto:[email-masked]]
> Sent: Wednesday, November 17, 2004 8:39 PM
> To: Rohan Mahy
> Cc: WG Chairs; [email-masked]
> Subject: Re: Tools team work items
> 
> 
> Oh yeah,
> 
> One last thing.  In order to get write access to a particular project 
> on sipfoundry, the contributor needs to agree to the license terms of 
> that particular project.  For the "internet-drafts" project, that 
> license is RFC 3667.  That way, when someone checks in text, 
> there are 
> no questions about compliance with the IETF boilerplate, contributor 
> IPR disclosures, etc..
> 
> thx,
> -r
> 
> 
> On Nov 17, 2004, at 17:28, Rohan Mahy wrote:
> 
> > On Nov 17, 2004, at 15:50, Bill Sommerfeld wrote:
> >> one possibly missing piece: a change control repository 
> for document
> >> .xml sources (ideally including a cvsweb-like 
> history/change browser).
> >> "sourceforge for IETF".  use would of course be optional..
> >
> > A handful of folks active in the SIP community have been using the 
> > subversion repository at sipfoundry.org to store the XML source for 
> > our drafts. Using CVS or SVN makes shared editing much easier, and 
> > also allows someone with lots of comments to checkout a 
> copy, edit the 
> > source and either send a patch to the editor or just check in their 
> > proposed changes.  It also means that anyone with authorization 
> > (usually everyone) can *read* the source of these documents.  I 
> > consider this a great feature.
> >
> > thanks,
> > -rohan
> 
>

---

From: Bill Fenner <[email-masked]>
Date: Thu, 18 Nov 2004 10:18:01 -0500

I didn't get around to it for this meeting, but that was one
of the intended purposes of the content management system on
http://rtg.ietf.org/ -- allowing presenters to upload their
presentations right before the meeting and letting others
download them.  The PCE bof did do this, and I think it worked
well.

  Bill