Subject: Scheduling for Minneapolis - a proposal

From: Harald Tveit Alvestrand <[email-masked]>
Date: Wed, 15 Dec 2004 17:01:16 +0100

Based on many months' discussion about earlier schedule fixing, earlier 
scheduling, premature scheduling, last-minute changes and so on.... I 
looked at the (not yet announced) schedule for Minneapolis, and tried to 
look at an alternative.

The scheduling-important dates are:

December 22, Wednesday - Working Group and BOF scheduling begins
February 21, Monday - Working Group and BOF scheduling closes by 17:00 ET 
February 28, Monday - Working Group agendas due date by 12:00 ET (17:00 GMT)
March 6-11, 2005 – 62nd IETF Meeting in Minneapolis, MN

This gives us exactly 2 weeks from last scheduling request to start of 
meeting.

What if we added a few more dates?

December 22, Wednesday - Working Group and BOF scheduling begins
February 7, Monday - Working Group and BOF initial scheduling closes 17:00
February 14, Monday - Cutoff date for requests to reschedule meetings 08:00
February 21, Monday - Final WG and BOF scheduling closes by 17:00 ET
February 28, Monday - Working Group agendas due date by 12:00 ET (17:00 GMT)
March 6-11, 2005 – 62nd IETF Meeting in Minneapolis, MN

The theory would be (not making promises, but what we'd try):

- Before February 7, all goes as normal.
- On February 8, the provisional agenda shows ALL WGs and BOFs, except for 
those that for some weird reason *have* to be scheduled at the last minute
- We spend Feb 8-14 in the usual flurry of "but you can't make a conflict 
over this" messages and having WGs jump all over the week
- On Feb 15, the provisional agenda will have a sticker on it saying "THE 
GROUPS CURRENTLY LISTED WILL ONLY BE MOVED IN CASE OF INTERNATIONAL CRISES" 
or equivalent strong language
- We ALLOW scheduling of WGs and BOFs who request scheduling after February 
7. But we do NOT move other groups around to make room for them - they are 
"second class requests" when it comes to resolving conflicts.

Does this make sense?

And the hundred-dollar question: Would YOU be willing to cooperate in this 
by sending ALL routine requests for WG scheduling before February 7?

                           Harald

---

From: David Meyer <[email-masked]>
Date: Wed, 15 Dec 2004 08:46:02 -0800

>> "second class requests" when it comes to resolving conflicts.

	Sounds very reasonable.

>> by sending ALL routine requests for WG scheduling before February 7?

	Yes.

	Dave

---

From: "Joel M. Halpern" <[email-masked]>
Date: Wed, 15 Dec 2004 11:55:11 -0500

Yes, this would be a good idea.
Yours,
Joel

At 11:01 AM 12/15/2004, Harald Tveit Alvestrand wrote:
>March 6-11, 2005  62nd IETF Meeting in Minneapolis, MN
>
>March 6-11, 2005  62nd IETF Meeting in Minneapolis, MN
>
>GROUPS CURRENTLY LISTED WILL ONLY BE MOVED IN CASE OF INTERNATIONAL 
>CRISES" or equivalent strong language
>- We ALLOW scheduling of WGs and BOFs who request scheduling after 
>February 7. But we do NOT move other groups around to make room for them - 
>they are "second class requests" when it comes to resolving conflicts.
>
>Does this make sense?
>

---

From: "David B Harrington" <[email-masked]>
Date: Wed, 15 Dec 2004 12:19:36 -0500

Sounds good to me.

David Harrington
[email-masked]
co-chair, IETF Bridge WG

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Harald Tveit 
> Alvestrand
> Sent: Wednesday, December 15, 2004 11:01 AM
> To: [email-masked]
> Subject: Scheduling for Minneapolis - a proposal
> 
> March 6-11, 2005 - 62nd IETF Meeting in Minneapolis, MN
> 
> March 6-11, 2005 - 62nd IETF Meeting in Minneapolis, MN
>

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 15 Dec 2004 17:27:29 -0000

Yes.

Please implement this.

Adrian
----- Original Message ----- 
From: "Harald Tveit Alvestrand" <[email-masked]>
To: <[email-masked]>
Sent: Wednesday, December 15, 2004 4:01 PM
Subject: Scheduling for Minneapolis - a proposal

December 22, Wednesday - Working Group and BOF scheduling begins
February 21, Monday - Working Group and BOF scheduling closes by 17:00
ET
February 28, Monday - Working Group agendas due date by 12:00 ET (17:00
GMT)
March 6-11, 2005 - 62nd IETF Meeting in Minneapolis, MN

December 22, Wednesday - Working Group and BOF scheduling begins
February 7, Monday - Working Group and BOF initial scheduling closes
17:00
February 14, Monday - Cutoff date for requests to reschedule meetings
08:00
February 21, Monday - Final WG and BOF scheduling closes by 17:00 ET
February 28, Monday - Working Group agendas due date by 12:00 ET (17:00
GMT)
March 6-11, 2005 - 62nd IETF Meeting in Minneapolis, MN

- Before February 7, all goes as normal.
- On February 8, the provisional agenda shows ALL WGs and BOFs, except
for
those that for some weird reason *have* to be scheduled at the last
minute
- We spend Feb 8-14 in the usual flurry of "but you can't make a
conflict
over this" messages and having WGs jump all over the week
- On Feb 15, the provisional agenda will have a sticker on it saying
"THE
GROUPS CURRENTLY LISTED WILL ONLY BE MOVED IN CASE OF INTERNATIONAL
CRISES"
or equivalent strong language
- We ALLOW scheduling of WGs and BOFs who request scheduling after
February
7. But we do NOT move other groups around to make room for them - they
are
"second class requests" when it comes to resolving conflicts.

Does this make sense?

And the hundred-dollar question: Would YOU be willing to cooperate in
this
by sending ALL routine requests for WG scheduling before February 7?

                           Harald

---

From: Rohan Mahy <[email-masked]>
Date: Wed, 15 Dec 2004 09:29:14 -0800

Works for me.

thx,
-r

On Dec 15, 2004, at 8:01, Harald Tveit Alvestrand wrote:
> Based on many months' discussion about earlier schedule fixing, 
> earlier scheduling, premature scheduling, last-minute changes and so 
> on.... I looked at the (not yet announced) schedule for Minneapolis, 
> and tried to look at an alternative.
>
> ET February 28, Monday - Working Group agendas due date by 12:00 ET 
> (17:00 GMT)
> for those that for some weird reason *have* to be scheduled at the 
> last minute
> conflict over this" messages and having WGs jump all over the week
> "THE GROUPS CURRENTLY LISTED WILL ONLY BE MOVED IN CASE OF 
> INTERNATIONAL CRISES" or equivalent strong language
> February 7. But we do NOT move other groups around to make room for 
> them - they are "second class requests" when it comes to resolving 
> conflicts.
>
> Does this make sense?
>
> this by sending ALL routine requests for WG scheduling before February 
> 7?
>
>                           Harald
>
>
>

---

From: David R Oran <[email-masked]>
Date: Wed, 15 Dec 2004 12:54:35 -0500

This should work fine for me too.
Dave Oran - speechsc co-chair

> this by sending ALL routine requests for WG scheduling before February 
David R. Oran
Cisco Fellow
Cisco Systems
7 Ladyslipper Lane
Acton, MA 01720 USA
Tel: +1 978 264 2048
Email: [email-masked]

---

From: Adam Roach <[email-masked]>
Date: Wed, 15 Dec 2004 12:02:46 -0600

I like this plan. It seems a reasonable compromise between getting 
conflicts resolved in time to make travel plans and accommodating groups 
who don't realize they need meeting time until the last minute.

/a

Harald Tveit Alvestrand wrote:

> this by sending ALL routine requests for WG scheduling before February 7?
>
> Harald
>
>
>
>
>

---

From: Ralph Droms <[email-masked]>
Date: Wed, 15 Dec 2004 13:47:33 -0500

I am willing to get routine WG scheduling requests in before Feb 7.

- Ralph

---

From: Aaron Falk <[email-masked]>
Date: Wed, 15 Dec 2004 11:55:11 -0800

> Does this make sense?

yes.

> by sending ALL routine requests for WG scheduling before February 7?

yep.  I'd like to see buy-in by the IESG and IAB to move BoF requests
along in an expeditious manner.

--aaron

---

From: Jari Arkko <[email-masked]>
Date: Wed, 15 Dec 2004 22:20:40 +0200

Ok for me. --Jari

---

From: Sam Hartman <[email-masked]>
Date: Wed, 15 Dec 2004 12:29:03 -0500

I like the current procedure better, but can live with your proposal.
I think we may want to have some discussions about why/when we'd want
to reschedule groups.

I think this should be considered an experiment, not a permanent
change.  The thing I'd like to see out of the experiment is whether
say in 3 IETFs worth of running with this experiment we run into cases
where we could have better accomodated a scheduling request under the
old procedures.  I don't have a good proposal for how to evaluate the
advantages of this proposal.

I actually suspect that there will not be significant disadvantages,
and so the decision about whether the experiment is a success will be
reasonably obvious.

---

From: Simon Leinen <[email-masked]>
Date: Wed, 15 Dec 2004 18:48:49 +0100

Harald Tveit Alvestrand writes:
> [...] Does this make sense?

Yes.

> And the hundred-dollar question: Would YOU be willing to cooperate
> in this by sending ALL routine requests for WG scheduling before
> February 7?

Yes.
-- 
Simon.

---

From: Harald Tveit Alvestrand <[email-masked]>
Date: Thu, 16 Dec 2004 10:57:59 +0100

--On onsdag, desember 15, 2004 15:14:11 -0800 Sam Weiler 
<[email-masked]> wrote:

> On Wed, 15 Dec 2004, Harald Tveit Alvestrand wrote:
>
> Are (tentative) slots assigned as soon as a request is made?  If not,
> could we give the IETF proletariat a way to see what WGs have
> requested slots?  That way they can cajole their WG chairs into
> sending in requests early enough to be considered in the conflict
> run-off.

Those lists exist (the secretariat sends them to the IESG once in a while, 
in advance of the first draft agendas). I'll see if we can make them more 
widely available.

                    Harald

---

From: Sam Weiler <[email-masked]>
Date: Wed, 15 Dec 2004 15:14:11 -0800 (PST)

Yes.

-- Sam

---

From: George Swallow <[email-masked]>
Date: Wed, 15 Dec 2004 12:21:17 -0500

Do it!

...George

========================================================================
George Swallow             Cisco Systems                  (978) 936-1398
                           1414 Massachusetts Avenue
                           Boxborough, MA 01719

---

From: Andy Bierman <[email-masked]>
Date: Sun, 19 Dec 2004 14:52:13 -0800

At 08:01 AM 12/15/2004, Harald Tveit Alvestrand wrote:
>Based on many months' discussion about earlier schedule fixing, earlier scheduling, premature scheduling, last-minute changes and so on.... I looked at the (not yet announced) schedule for Minneapolis, and tried to look at an alternative.

of course I like this idea -- I was the one pushing for the 2 week stability.

It seems to me that if we are having a problem getting the
schedule out because so many WGs don't know if they even
need to meet or not, and the reason we optimize for late
decisions is that meeting slots are at such a premium,
then we should have more 1 hour slots than 4 on Tuesday afternoon.

What if, after the Feb. 7th cutoff, the only WG or BOF
slots available will be 1 hour slots.  If a WG can't decide
if it needs to meet at -1 month, then it probably won't need
more than an hour anyway.

Andy

>February 21, Monday - Working Group and BOF scheduling closes by 17:00 ET February 28, Monday - Working Group agendas due date by 12:00 ET (17:00 GMT)
>This gives us exactly 2 weeks from last scheduling request to start of meeting.
>
>- On February 8, the provisional agenda shows ALL WGs and BOFs, except for those that for some weird reason *have* to be scheduled at the last minute
>- We spend Feb 8-14 in the usual flurry of "but you can't make a conflict over this" messages and having WGs jump all over the week
>- On Feb 15, the provisional agenda will have a sticker on it saying "THE GROUPS CURRENTLY LISTED WILL ONLY BE MOVED IN CASE OF INTERNATIONAL CRISES" or equivalent strong language
>- We ALLOW scheduling of WGs and BOFs who request scheduling after February 7. But we do NOT move other groups around to make room for them - they are "second class requests" when it comes to resolving conflicts.
>
>Does this make sense?
>
>And the hundred-dollar question: Would YOU be willing to cooperate in this by sending ALL routine requests for WG scheduling before February 7?
>
>                          Harald
>