Subject: RE: Schedule for -00 WG drafts

From: "Jari Arkko (JO/LMF)" <[email-masked]>
Date: Thu, 23 Dec 2004 13:13:07 +0100

My thinking is that its important that the approvals
process does not introduce additional delays just
because of the process. Given that we allow the
approvals from the chairs to come either before or
after the author submits the draft, I think the
delays are already minimized.

I do not personally see a big need for me as a chair
to submit the -00 drafts. In fact, I would rather
have the authors handle that. But I know that occasionally
there are situations where someone else than the
main author ends up sending the e-mail to the
secretariat. Vacations, network connectivity, etc
force this sometimes. I don't recall a case where
a chair would have been forced to do this without
being an author of the document at the same time.
But it could happen. If you want to support this, 
you coulds define the authorization to submit a > 00
WG draft as something that comes either from the authors
or from the chairs. For 00, if the mail did
not come from the chairs you would need either
pre- or post approval from the chairs.

--Jari

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On
Behalf Of Harald Tveit Alvestrand
Sent: 23. joulukuuta 2004 0:18
To: [email-masked]
Subject: Schedule for -00 WG drafts

Hi,

the approval procedures for initial (-00) WG drafts (draft-ietf-wgname-) 
has seemed to cause a lot of confusion.

Let me see if I can attempt to say what the current procedure is, and then 
suggest a change to it.

The main point of the procedure is: An initial WG draft must be approved by 
the WG chair.

Outside of the "meeting crunch", the normal procedure is:

- Author sends in the draft
- The I-D publisher sends back a response to the author saying "you need 
your WG chair's approval"
- The WG chair sends an "I approve" message to the I-D publisher
- The draft is published

During the "meeting crunch", the secretariat tries to streamline as much as 
possible. So it has said to the WG chairs: "If you tell us the names of the 
initial WG drafts you expect to see, we can approve them without asking you 
- please send the list 1 week before the -00 deadline".

In this case, the procedure becomes:

- Author sends in the draft
- The I-D publisher checks it against the list
- If it's on the list, it's published. If not, revert to procedure above.

Clear so far?

Now the suggested modification to procedure:

- If the e-mail with the draft comes from a WG chair, it gets published.

This does NOT mean that the WG chair becomes an author. The normal case 
would be that the editor sends to the WG chair, and the WG chair forwards 
the message to the I-D publisher; the author is still the author.

But it removes the need for the WG chair to generate those lists.

Does it make sense to people to add this possibility?

And - if this makes sense - do we still need the two other procedures 
described above, can we remove one of them, or can we say "this is how all 
-00 WG drafts come out"?

Of course, this will all be changed once the online draft submission tool 
comes out....

                        Harald

---

From: [email-masked]
Date: Mon, 27 Dec 2004 06:51:15 +0200

Bill,

> >The other reason for the one week earlier deadline is to give people a
> >chance to read the document before the IETF meeting.
> 
> The last time we discussed this on wgchairs, that idea was loudly
> trounced - the assertion was that individual -00s have new ideas and
> wg -00s don't (since they come from an individual draft that's been
> discussed and accepted as a wg document).

I completely agree.  If the working group has not read a draft prior
to it becoming a WG draft, then we are in trouble here.  

John

---

From: Eastlake III Donald-LDE008 <[email-masked]>
Date: Mon, 27 Dec 2004 00:00:30 -0500

Not all working group drafts come from previous individual draft. Furthermore, the deadline requirement is not solely for the benefit of active working group member for the the benefit of all members of the IETF community who will be attending the IETF meeting.

Donald

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Sunday, December 26, 2004 11:51 PM
To: [email-masked]; [email-masked]
Cc: [email-masked]
Subject: RE: Schedule for -00 WG drafts

Bill,

John

---

From: [email-masked]
Date: Mon, 27 Dec 2004 13:22:15 +0200

Donald,

> Not all working group drafts come from previous individual 
> draft. Furthermore, the deadline requirement is not solely 
> for the benefit of active working group member for the the 
> benefit of all members of the IETF community who will be 
> attending the IETF meeting.

My biggest concern is that we are making procedural rules where
we have not identified the real issues and the rules have
enough ways to be circumvented as to be fairly meaningless.

I have seen many authors of a -00 WG draft miss the deadline,
so they just submit the draft as draft-author-wg- .... and
then tell everyone on the mailing list that this is indeed
the WG draft, but without the -00 name because the draft
deadline was missed.

For working group drafts that are created out of thin-air
and start life as draft-wg-xxx-00, one would hope that they
are submitted well before the draft cut-off date. 

Finally, as real work in the IETF really should take place
on the mailing list, I don't entirely buy the notion that
the advanced cut-off date for is for the benefit for non-wg
participants ...

I think the real issues is that any draft that gets mic time
at an IETF meeting should have had some discussion on a wg
mailing list, therefore should probably be announced long
before the cut-off date.  It is not unreasonable for a WG
chair to deny mic time to any draft that has not had a modest
level of discussion on the mailing list prior to an IETF 
meeting.

John

---

From: Ralph Droms <[email-masked]>
Date: Mon, 27 Dec 2004 09:58:11 -0500

I agree with John.  I'm further concerned that we are
incrementally engineering a process that has developed
from the simple need for the Internet Draft publication
process to confirm that a -00 WG draft has, in fact, been
accepted for publication as a WG work item draft.

Concerns about whether the WG has had time to read the new
draft before the WG face-to-face meeting or about whether
WG drafts come from individual submissions are, to my mind,
moot.  If drafts are being published as WG work items
in appropriately, let's leave that issue to the respective
WG chairs and ADs.  All we need to do is specify that the
draft secretary gets confirmation from one WG chair that
it's OK to publish the draft as a -00 WG draft.

If we need some specification of mechanism to streamline
the process for the draft secretary, OK.  Let's work backwards
from their requirements for draft publication - deadline
before IETF meeting, minimize outbound e-mail, whatever - and
specify a couple of rules that get the appropriate
authorization to the draft secretary.

I think it would be sufficient for the -00 rev authors to send
a copy of the publication request to the WG chairs, and then
the WG chairs follow up with "this draft is OK".  Minimizes
caching and e-mail generation on the part of the draft
secretary; it's up to the authors to get the draft ready in
time for the WG chairs to follow up, and it's up to the WG chairs
to confirm the acceptance.  No confirmation by draft publication
deadline -> draft is discarded.

- Ralph

---

From: "Lars-Erik Jonsson (LU/EAB)" <[email-masked]>
Date: Mon, 27 Dec 2004 22:55:50 +0100

I agree with John and Ralph!

> moot.  

This is also how I see it. Therefore I do not really think
two different deadlines are justified. -00 drafts should have
the same deadline as any draft, with the only difference that
to get published as a WG draft, a -00 draft must also be
confirmed by a WG chair before the deadline. 

/L-E