Subject: RE: Scheduling for Minneapolis - a proposal

From: [email-masked]
Date: Wed, 15 Dec 2004 08:20:32 -0800

I like this.

Elizabeth 

-----Original Message-----
From: Harald Tveit Alvestrand [mailto:[email-masked]] 
Sent: Wednesday, December 15, 2004 8:01 AM
To: [email-masked]
Subject: Scheduling for Minneapolis - a proposal

Based on many months' discussion about earlier schedule fixing, earlier 
scheduling, premature scheduling, last-minute changes and so on.... I 
looked at the (not yet announced) schedule for Minneapolis, and tried to 
look at an alternative.

The scheduling-important dates are:

December 22, Wednesday - Working Group and BOF scheduling begins
February 21, Monday - Working Group and BOF scheduling closes by 17:00 ET 
February 28, Monday - Working Group agendas due date by 12:00 ET (17:00 GMT)
March 6-11, 2005 - 62nd IETF Meeting in Minneapolis, MN

This gives us exactly 2 weeks from last scheduling request to start of 
meeting.

What if we added a few more dates?

December 22, Wednesday - Working Group and BOF scheduling begins
February 7, Monday - Working Group and BOF initial scheduling closes 17:00
February 14, Monday - Cutoff date for requests to reschedule meetings 08:00
February 21, Monday - Final WG and BOF scheduling closes by 17:00 ET
February 28, Monday - Working Group agendas due date by 12:00 ET (17:00 GMT)
March 6-11, 2005 - 62nd IETF Meeting in Minneapolis, MN

The theory would be (not making promises, but what we'd try):

- Before February 7, all goes as normal.
- On February 8, the provisional agenda shows ALL WGs and BOFs, except for 
those that for some weird reason *have* to be scheduled at the last minute
- We spend Feb 8-14 in the usual flurry of "but you can't make a conflict 
over this" messages and having WGs jump all over the week
- On Feb 15, the provisional agenda will have a sticker on it saying "THE 
GROUPS CURRENTLY LISTED WILL ONLY BE MOVED IN CASE OF INTERNATIONAL CRISES" 
or equivalent strong language
- We ALLOW scheduling of WGs and BOFs who request scheduling after February 
7. But we do NOT move other groups around to make room for them - they are 
"second class requests" when it comes to resolving conflicts.

Does this make sense?

And the hundred-dollar question: Would YOU be willing to cooperate in this 
by sending ALL routine requests for WG scheduling before February 7?

                           Harald

---

From: "Nelson, David" <[email-masked]>
Date: Wed, 15 Dec 2004 11:35:10 -0500

> by sending ALL routine requests for WG scheduling before February 7?

Yes.

-- Dave

---

From: [email-masked]
Date: Wed, 15 Dec 2004 20:25:12 +0200

Harald,

This is a fine proposal, and I'm willing to commit my time to get my
requests in early.  I think that this would be a process improvement.

John

> From: [email-masked] [mailto:[email-masked]]On
> Behalf Of ext Harald Tveit Alvestrand
> Sent: 15 December, 2004 18:01
> To: [email-masked]

---

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Thu, 16 Dec 2004 12:29:29 +0100

I think this is all great.

One IMPORTANT thing to note as well:

   IESG and other IETF members should also make sure they get any
   BOF requests scheduled EARLY. In the past, I have seen that those
   often come in (get decided on) very late and then cause havoc
   on the agenda!!

Bert

> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Harald Tveit Alvestrand
> Sent: Wednesday, December 15, 2004 17:01
> To: [email-masked]

---

From: Eric Burger <[email-masked]>
Date: Thu, 16 Dec 2004 16:59:41 -0500

On the WG chair side, count one (two?) more votes for the experiment.

On the BOF side, I personally have been blindsided by BOFs that show up the
week of the IETF.  Some are of critical interest to my work group, which
means I would want to go, and many of the folks in the work group would want
to go.  Some are of passing interest, where it would be nice to go.  Others
are, IMHO, brain dead, and I'd want to participate to make sure they don't
suck up IETF resources :)

I would offer that BOF requests must close a week before the WG request
deadline.  If you can't get your BOF together in time, I'd much rather give
WG *work* priority.

Given the very long lead times in the IETF, pushing a BOF slot 3-4 months to
the next meeting is just noise.  This is more especially so compared to
pushing off progress on an active work group.

> From: Wijnen, Bert (Bert) [mailto:[email-masked]]
> Sent: Thursday, December 16, 2004 6:29 AM
> To: 'Harald Tveit Alvestrand'; [email-masked]
> Subject: RE: Scheduling for Minneapolis - a proposal
> 
>

---

From: Eastlake III Donald-LDE008 <[email-masked]>
Date: Fri, 17 Dec 2004 13:53:33 -0500

People should keep in mind that earlier deadlines will mean more speculative reservations and more last minute cancellations. It's probably worth it to get a more stable schedule earlier but there are negative effects.

Donald

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Rohan Mahy
Sent: Thursday, December 16, 2004 7:00 PM
To: Jeffrey Altman
Cc: [email-masked]
Subject: Re: Scheduling for Minneapolis - a proposal

On Dec 16, 2004, at 15:01, Jeffrey Altman wrote:
> I don't have a problem with asking WGs and BOFs to make a decision
> regarding whether or not they want a meeting even two months before
> a meeting.  It is usually fairly clear from the work on the working
> groups charter and the progress which has been made whether or not
> a meeting is required.  What we usually do not know is what the
> content of the agenda will be.  I would be happy to submit the
> IETF 62 meeting request for the Kitten working group today.

likewise.  I would have no problem requesting agenda time *during* one 
IETF for the next.  Both of my working groups are likely to chug along 
for a few more meetings before I can even consider the great pleasure 
of closing them.

...

---

From: [email-masked]
Date: Fri, 17 Dec 2004 16:31:48 -0500

It's definitely worth it.  Instability of the schedule and
the resulting inability to confirm travel plans is a
recurring complaint from members of my WGs.  I have no
problem meeting the earlier deadline for scheduling
requests.  Do it!

Thanks,
--David
----------------------------------------------------
David L. Black, Senior Technologist
EMC Corporation, 176 South St., Hopkinton, MA  01748
+1 (508) 293-7953             FAX: +1 (508) 293-7786
[email-masked]        Mobile: +1 (978) 394-7754
----------------------------------------------------

> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Eastlake III 
> Donald-LDE008
> Sent: Friday, December 17, 2004 1:54 PM
> To: [email-masked]
> People should keep in mind that earlier deadlines will mean 
> more speculative reservations and more last minute 
> cancellations. It's probably worth it to get a more stable 
> schedule earlier but there are negative effects.
> 
> Donald
>

---

From: Eric Burger <[email-masked]>
Date: Tue, 21 Dec 2004 10:46:29 -0500

This is why I don't have a problem with saying that BOF's can wait four
extra months.  That is, if you don't get approval from the AD/IESG until
just before the IETF Meeting, push off until the next one.

Will this "set back" the work being considered?  I doubt it in practice, for
two reasons.

Reason #1:
If there is really work being done, it will get done with or without a
formal meeting at the IETF Meeting.  Worst thing that happens is the group
will finish 4 months earlier than a typical group.  [Yeah, right!]

Reason #2:
Four extra months of an announced BOF list, problem statement, list
discussion, etc. should help formulate and prove interest, expertise,
relevance, etc.

> From: Thomas Narten [mailto:[email-masked]]
> Sent: Friday, December 17, 2004 8:58 AM
> To: Jeffrey Altman
> Cc: [email-masked]
> > With regards to BOF requests things get much more 
> complicated.  A BOF
> > request cannot be submitted until an Area Director agrees to sponsor
> > its work and this decision is frequently made in consultation with
> > a significant subset of the IESG.
> 
> It's actually even a bit more complicated and open ended then
> that. Often, the first response I make to a BOF request is something
> like:
> 
>  - is there a mailing list with discussion?
>  - has the mailing list been advertised so that interested folk know
>    about it? 
>  - what IDs are there and have they been discussed on the list yet?
>  - is there  a clear (enough) problem statement?
>  - has the mailing list come to any sort of agreement on the problem
>    statement, scope of work, need for work, etc.?
> 
> etc. Giving the official go ahead for a BOF does not typically take
> place until a bunch of the above had taken place. I.e., intention to
> do the above is not sufficient. Thus, in practice, official approvals
> tend to come late, in part to ensure that the above really does take
> place prior  to the BOF.
> 
> Thomas
>