Subject: Re: Enforcement of Updated IPR Boilerplate

From: "Randy Presuhn" <[email-masked]>
Date: Mon, 4 Apr 2005 14:08:34 -0700

Hi -

Does anyone know when xml2rfc will support this?

Randy

> > From: "IETF Secretariat" <[email-masked]>
> > To: "IETF Announcement list" <[email-masked]>
> > Cc: <[email-masked]>; <[email-masked]>; <[email-masked]>
> > Sent: Monday, April 04, 2005 10:05 AM
> > Subject: Enforcement of Updated IPR Boilerplate
> >
> > As you may be aware, RFC 3667 (BCP 78), "IETF Rights in Contributions,"
> > has been obsoleted by RFC 3978 (BCP 78), which was published in March
> > 2005, and which bears the same title.  The major difference between the
> > two RFCs is that the IPR-related notices and disclaimers that the IETF
> > requires in all Internet-Drafts have been updated to correct anomalies.
> >
> > The updated versions of the required notices and disclaimers are specified
> > in Section 5, "Notices Required in IETF Documents," of RFC 3978, and in
> > Section 3, "IPR-Related Notices Required in Internet-Drafts," of the
> > recently revised "Guidelines to Authors of Internet-Drafts"
> > (http://www.ietf.org/ietf/1id-guidelines.html).  The "Guidelines" document
> > also provides additional guidance regarding the placement of these notices.
> >
> > Currently, the IETF Secretariat accepts and posts Internet-Drafts that
> > include *either* the RFC 3667 or the RFC 3978 version of these notices.
> > However, as of 17:00 ET on Friday May 6, 2005, the Secretariat will
> > accept *only* those Internet-Drafts that comply with the requirements
> > of RFC 3978, and with the most recent version of the "Guidelines"
> > document.
> >
> > Please note that the required notices and disclaimers must be reproduced
> > verbatim since they have been legally reviewed and formally adopted as part
> > of the IETF process.  The Secretariat will not accept deviations from the
> > specified text, nor will it correct the text.  Any documents that do not
> > comply with the requirements will be returned to the submitter.
> >
> > The IETF Secretariat
> >
> > _______________________________________________
> > IETF-Announce mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/ietf-announce

---

From: Baker Fred <[email-masked]>
Date: Mon, 4 Apr 2005 14:27:54 -0700

I just asked on the relevant list. Bill Fenner states that 1.29rc4 
already does and is being verified by the secretariat.

---

From: "Randy Presuhn" <[email-masked]>
Date: Mon, 4 Apr 2005 14:37:03 -0700

Hi -

Where is 1.29rc4 available?
At http://xml.resource.org/ is 1.28
BTW, what *is* the relevant list?

Randy

----- Original Message ----- 
> From: "Baker Fred" <[email-masked]>
> To: "Randy Presuhn" <[email-masked]>
> Cc: "Working Group Chairs" <[email-masked]>; <[email-masked]>
> Sent: Monday, April 04, 2005 2:27 PM
> Subject: Re: Enforcement of Updated IPR Boilerplate
>

---

From: Bill Fenner <[email-masked]>
Date: Mon, 4 Apr 2005 14:51:06 -0800

1.29rc4 is at http://xml.resource.org/authoring/xml2rfc-1.29rc4.tgz ;
however I'd recommend waiting for the actual release.  The release of
1.29 is just waiting for the secretariat to verify that the output is
acceptable under the new rules, which I expect this week.

Fred was referring to the xml2rfc mailing list, at the bottom
of the xml.resource.org top page -
http://lists.xml.resource.org/mailman/listinfo/xml2rfc

  Bill

---

From: "Randy Presuhn" <[email-masked]>
Date: Mon, 4 Apr 2005 14:55:45 -0700

Hi -

Thanks.

It seems that it would have made more sense to make sure
the tools were in place *before* making the announcement.

Randy

> From: "Bill Fenner" <[email-masked]>
> To: <[email-masked]>
> Cc: <[email-masked]>; <[email-masked]>
> Sent: Monday, April 04, 2005 3:51 PM

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 05 Apr 2005 10:14:59 +0200

Randy, the key date is May 6th and the idea is indeed to have
the tools (xml2rfc and idnits) fully up to date by then. We
announced it now to be sure that everything is resolved well before
the I-D cutoff for IETF63.

    Brian