Subject: Non-text attachments posted to list

From: "Mani, Mahalingam \(Mani\)" <[email-masked]>
Date: Mon, 6 Feb 2006 05:35:58 -0700

Hi,

What is the IETF position of posting (large or small) attachments to the
WG list?

And of the attachments being either powerpoint or word documents? Is
there a guideline on how big or small the file-sizes

should be?

We in CAPWAP had been suggesting such postings be text/pdf attachments
only - though some continue to show affinity towards above other
formats. Should we allow such "de-facto" common formats and large
file-sizes?

Are the reasons for keeping email sizes (there's currently a limit of
40k beyond which it requires the

approval of the list-admin/chair) obsolete today (besides concerns about
size-based spam-flood)?

What is the position chairs (should) generally take on powerpoint / word
attachments to list?

Regards,

-mani

======

---

From: "David B Harrington" <[email-masked]>
Date: Mon, 6 Feb 2006 08:09:01 -0500

Hi,
 
My personal opinions on this queston:
 
Powerpoint is frequently used in meeting materials so is acceptable on
mailing lists. It should be reserved primarily for meeting use
however; it would not generally be a good format for making technical
proposals because a picture-oriented format tends to be too high-level
for discussing the technical details (although slides can be helpful
when introducing the high-level concepts of a proposal). Since there
is a limit to the amount of text one can put onto a slide, Powerpoint
is not useful for writing technical proposals because it would require
way too many slides, and file sizes would be too large.
 
Some people like Word and PDF, but I don't like them used in WGs
because not everybody can read the Word document, and PDF is not a
good document for works in progress because it is difficult to cut and
paste from a PDF, which can make it difficult to perform detailed
reviews and include comments that show the text in question.
 
ASCII is the preferred format for IETF works in progress, because
everybody can read it, and it is easy to work with as a
work-in-progress. 

David Harrington

[email-masked]

  _____  

From: [email-masked] [mailto:[email-masked]] On
Behalf Of Mani, Mahalingam (Mani)
Sent: Monday, February 06, 2006 7:36 AM
To: [email-masked]
Subject: Non-text attachments posted to list

Hi,

What is the IETF position of posting (large or small) attachments to
the WG list?

should be?

approval of the list-admin/chair) obsolete today (besides concerns
about size-based spam-flood)?

What is the position chairs (should) generally take on powerpoint /
word attachments to list?

Regards,

-mani

======

---

From: Ólafur Guðmundsson <[email-masked]>
Date: Mon, 06 Feb 2006 12:15:00 -0500

My WG list has a limit of 20K and most attachments are silently stripped
off. We let txt, pdf, <office types> through, but most of these get
caught up in the size restriction.
Since we imposed this policy people have got much better at just posting
links to drafts, slides etc. than send the whole thing out.

IMHO size restriction is a good thing and 20K seems to work well.
We the chairs imposed this limit and all the feedback we gotten has
been positive.

         Olafur

At 08:09 06/02/2006, David B Harrington wrote:
>Powerpoint is frequently used in meeting 
>materials so is acceptable on mailing lists. It 
>should be reserved primarily for meeting use 
>however; it would not generally be a good format 
>for making technical proposals because a 
>picture-oriented format tends to be too 
>high-level for discussing the technical details 
>(although slides can be helpful when introducing 
>the high-level concepts of a proposal). Since 
>there is a limit to the amount of text one can 
>put onto a slide, Powerpoint is not useful for 
>writing technical proposals because it would 
>require way too many slides, and file sizes would be too large.
>
>Some people like Word and PDF, but I don't like 
>them used in WGs because not everybody can read 
>the Word document, and PDF is not a good 
>document for works in progress because it is 
>difficult to cut and paste from a PDF, which can 
>make it difficult to perform detailed reviews 
>and include comments that show the text in question.
>
>ASCII is the preferred format for IETF works in 
>progress, because everybody can read it, and it 
>is easy to work with as a work-in-progress.
>
>
>David Harrington
>
>[email-masked]
>
>
>
>
>
>----------
>From: [email-masked] 
>[mailto:[email-masked]] On Behalf Of Mani, Mahalingam (Mani)
>What is the IETF position of posting (large or 
>small) attachments to the WG list?
>
>And of the attachments being either powerpoint 
>or word documents? Is there a guideline on how big or small the file-sizes
>
>should be?
>
>
>
>We in CAPWAP had been suggesting such postings 
>be text/pdf attachments only – though some 
>continue to show affinity towards above other 
>formats. Should we allow such “de-facto” common formats and large file-sizes?
>
>
>
>Are the reasons for keeping email sizes (there’s 
>currently a limit of 40k beyond which it requires the
>
>approval of the list-admin/chair) obsolete today 
>(besides concerns about size-based spam-flood)?
>
>
>
>What is the position chairs (should) generally 
>take on powerpoint / word attachments to list?
>
>
>
>Regards,
>
>-mani
>
>======
>
>

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 11 Feb 2006 09:44:02 +0100

Mani,

Traditionally this was felt to be rude, and I think we must consider that
not all our participants have broadband connections. It's rare for me now,
but I remember the extreme frustration of receiving large attachments
when connected by modem in a hotel room. If we have active participants
in locations with poor connectivity, this may be a permanent problem for
them.

So I prefer the model where attachments are small and larger files
are posted to a web site. In particular, while preparing for an IETF
meeting, you now have the option of uploading draft meeting materials
to the IETF site.

I think there's a pretty strong argument against proprietary formats.
You can't assume that all participants have access to specific paid
software. That's why most people prefer to send PDF if for some
reason ASCII won't do. [See [email-masked] threads on RFC formats to
understand the level of emotion about this.]

But I don't believe this is an area where we should have an IETF rule.
It depends on what the participants in a given WG prefer, IMHO.

     Brian

---

From: "Randy Presuhn" <[email-masked]>
Date: Sat, 11 Feb 2006 11:18:52 -0800

Hi -

> From: "Brian E Carpenter" <[email-masked]>
> To: "Mani, Mahalingam (Mani)" <[email-masked]>
> Cc: <[email-masked]>
> Sent: Saturday, February 11, 2006 12:44 AM
> Subject: Re: Non-text attachments posted to list
...
> in locations with poor connectivity, this may be a permanent problem for
...

I recently returned from three weeks visiting in-laws in rural Viet Nam.
Although there is now a local internet cafe claiming to have ADSL
connectivity, the (lack of) bandwidth, loss rates, and delay were
such that even reading short text messages was a bother.  I'm glad
that I was spared the ordeal of pulling down large attachments.

Randy