Subject: Re: WG Chairs page update request

From: Brian E Carpenter <[email-masked]>
Date: Sun, 05 Feb 2006 14:03:59 +0100

Actually we don't just need the history of milestones; we need
the history of all changes to each charter, IMHO.  At least this
is useful when reviewing proposed charter updates.

But this isn't a trivial tool request, since it obviously requires
quite a bit of work to implement.

     Brian

[email-masked] wrote:
> Hi,
> 
> I fully agree that having the old milestone dates so it is obvious
> where we have missed our deadlines, by how much, and how many "resets"
> we've had would be tremendously useful for project management.
> 
> dbh
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Andy Bierman
> Sent: Friday, January 13, 2006 11:49 AM
> To: [email-masked]
> Cc: Working Group Chairs
> Subject: WG Chairs page update request
> 
> 
> Hi,
> 
> 1)  Please add links to the new meeting tools on the WG Chairs page:
>     http://www.ietf.org/IESG/wgchairs.html
> 
> 2) Item for consideration: 
>    The milestone section of the WG charter page would be a lot more
>    useful if we could somehow view the original target date
>    and any revised target dates, plus the actual completion date
> (mo/year).
>    Just the status (Done) is not enough data to do any real project 
> management.
> 
> 
> thanks,
> Andy
> 
> 
> 
> 
> 
>

---

From: Andy Bierman <[email-masked]>
Date: Sun, 05 Feb 2006 06:45:39 -0800

> quite a bit of work to implement.

Agreed -- but the problem doesn't have to be that hard.
IMO, this could be as simple as archiving the ASCII version
of each charter page in CVS.

It would be sufficient to be able to view older versions of a charter,
or compare 2 versions.  CVS does way more than that of course.
A custom WEB wrapper around CVS would require most of the effort.
It's possible the id-nits WEB checker page could be adapted for this 
purpose.

Andy

>> 2) Item for consideration:    The milestone section of the WG charter 
>> page would be a lot more

---

From: Ignacio Goyret <[email-masked]>
Date: Mon, 06 Feb 2006 13:27:36 -0800

>It's possible the id-nits WEB checker page could be adapted for this 

If you want to go the CVS route, check http://www.freebsd.org/projects/cvsweb.html
for a wonderful frontend to cvs.