Subject: Re: I-D examples wanted

From: "David Mitton" <[email-masked]>
Date: Tue, 14 Mar 2006 10:08:12 -0500

Jim,

     I'd be willing to donate the source of draft-mitton-diameter-radius-vsas-01 to the cause.

If I had a round tuit, I'd like to do a BCP on using groff (GNU troff) on doing I-D's and RFCs using MS macros and Perl post processing helpers.
RFC 4005 was done that way.

http://www.gnu.org/software/groff/groff.html

Precompiled binary kits for Windows platforms are available.  (which is what I use now)
http://gnuwin32.sourceforge.net/packages/groff.htm

Dave.

PS: Someone should automate the removal of NON-ASCII characters from I-D's.  I still see Word smart chars in recent IDs.

> ----- Original Message -----
> From: "James Carlson" <[email-masked]>
> To: [email-masked]
> Subject: I-D examples wanted
> Date: Tue, 14 Mar 2006 08:35:49 -0500
> 
> 
> One of the newer pppext participants had an idea to help I-D authors
> (and wg chairs as well), and I figured this would be a reasonable
> place to solicit comments and perhaps some help.
> 
> It seems that getting all of the newly-picky boilerplate and layout
> bits right is becoming a bit of a barrier, to the point where only a
> handful of people seem to get it right in the first shot, and most are
> sent back through hours of drudge work.
> 
> The idea was to have a set of example correctly-formed I-D sources (in
> various useful formats, say nroff and XML) on one of the I-D web pages
> (such as http://www.ietf.org/ietf/1id-guidelines.html or perhaps
> http://www.rfc-editor.org/formatting.html), so that authors could crib
> from something known to be right.  Better still if these could be kept
> up-to-date with each change to the process.  (It seems virtually
> certain to me that there'll be more changes in the future.)
> 
> The only referenced examples I could dig up directly were these:
> 
>    ftp://ftp.rfc-editor.org/in-notes/rfc-editor/2-nroff.template
>    ftp://ftp.rfc-editor.org/in-notes/rfc-editor/2-Word.template.rtf
> 
> which are both stale enough to be useless for this purpose.  Am I
> looking in the wrong place, or do we expect I-D authors to be
> illuminated manuscript writers as well?  ;-}
> 
> --
> James Carlson, KISS Network                    <[email-masked]>
> Sun Microsystems / 1 Network Drive         71.232W   Vox +1 781 442 2084
> MS UBUR02-212 / Burlington MA 01803-2757   42.496N   Fax +1 781 442 1677

---

From: James Carlson <[email-masked]>
Date: Tue, 14 Mar 2006 10:14:48 -0500

> PS: Someone should automate the removal of NON-ASCII characters from I-D's.  I still see Word smart chars in recent IDs.

I know.  It's horrible, and it seems that MS users have a uniformly
tough time removing the non-ASCII trash from their files.  Apparently,
asking the system for "ASCII" isn't sufficient.  (I don't know why
that might be, but since I don't use that OS ...)

---

From: Tony Hansen <[email-masked]>
Date: Tue, 14 Mar 2006 21:22:29 -0500

The RFC on converting MS-Word into an I-D contains a post processor that
didn't do a whole lot. However, the **updated** version of that post
processor in the latest I-D updating that RFC, does much more, including
checking for (and sometimes fixing) non-ASCII "trash".

Hopefully people who use MS-Word for writing I-Ds will move to the
updated post processor.

	Tony Hansen
	[email-masked]

James Carlson wrote:
> David Mitton writes:
>> PS: Someone should automate the removal of NON-ASCII characters
>> from I-D's.  I still see Word smart chars in recent IDs.
> 
> tough time removing the non-ASCII trash from their files.
> Apparently, asking the system for "ASCII" isn't sufficient.  (I don't
> know why that might be, but since I don't use that OS ...)