Subject: Re: advice on role of a WG Chair

From: Andy Bierman <[email-masked]>
Date: Wed, 28 Jun 2006 14:02:10 -0700

[email-masked] wrote:
> Andy,
>....
>> If we required running code + an I-D to start new protocol
>> work, instead of just an I-D, there would be less work,
>> but more than 10% of it would end up widely deployed.
>> (But that's a new rant ;-)
> 
> And an unproductive one, as requiring running code in all situations
> risks setting a de facto standard before IETF work gets started
> (and we get stuck with the resulting "bad ideas" forever ...).
> We choose ADs in part for their ability to exercise sound judgment
> in these sorts of situations.

You're right.

I think the IESG does a good job of starting WGs.
Getting them to finish is another story.

IMO, if we are only batting .100 on successful protocols
(maybe it's more like .230 ;-) then the question
"Do we really need this?" is not being answered correctly enough.

One way to tell if we need it is if operators are already
using products that do something "close enough" to the
proposed charter.  I don't know how heavily this should
weigh in the IESG charter decision.

(BTW, I am against any detailed written rules for the IESG to
make this type of decision.  People are selected for the IESG
because NomCom thinks they are capable of the job.  They shouldn't
be told how to make a decision.)

> Thanks,
> --David

Andy

> 
>> -----Original Message-----
>> From: Andy Bierman [mailto:[email-masked]] 
>> Sent: Wednesday, June 28, 2006 2:03 PM
>> To: Alexey Melnikov
>> Cc: Working Group Chairs
>> Subject: Re: advice on role of a WG Chair
>>
>> Alexey Melnikov wrote:
>>> Andy Bierman wrote:
>>>
>>>> IMO, WGs should be nuked if they don't finish on time.
>>> How many WG will be around after that?
>>> (Most WGs I participate in are late, but making progress)
>> What I am suggesting is that WGs take a more project-oriented
>> view of their work.  The charter milestones seem almost irrelevant
>> to many WGs -- because the Chairs know they can keep getting
>> extension after extension.
>>
>> If you know you have a 12 - 18 months to get done -- or else --
>> there would be more incentive to focus, keep it simple,
>> and get work done in useful increments.
>>
>> This is too simple of course and won't work, because vendors
>> who don't want a standard at all will just filibuster until
>> the clock expires and the standard dies.
>>
>> If we required running code + an I-D to start new protocol
>> work, instead of just an I-D, there would be less work,
>> but more than 10% of it would end up widely deployed.
>> (But that's a new rant ;-)
>>
>>
>>
>>>> That would wake a few people up.  The IESG does a good
>>>> job chartering WGs, but often WGs treat the charter and the
>>>> milestones as some sort of "wish list".  Force the WGs to make
>>>> tough choices, and make them quickly.  Force WGs to learn
>>>> how to complete finite work in finite time.
> 
>

---

From: [email-masked]
Date: Wed, 28 Jun 2006 16:45:08 -0400

Andy,

> and get work done in useful increments.

I run my WGs that way, with about 12-18 month timeframes, because
I *expect* my ADs to pull the plug if nothing happens in that sort
of time period due to WG inaction (e.g., delays in moving drafts
through ADs and the IESG don't count).  It is possible to overdo
that - there is such a thing as a draft that is fundamentally not
ready despite the quantity of heated technical discussion/debate/email
expended on it.  Interim meetings and design teams are among the
tools that can help with that sort of situation.

Do the ADs need to publicly close a WG that's going nowhere
"pour encourager les autres" ?

Thanks,
--David

---

From: Sam Hartman <[email-masked]>
Date: Wed, 28 Jun 2006 22:15:06 -0400

>>>>> "Black" == Black David <[email-masked]> writes:

    Black> Do the ADs need to publicly close a WG that's going nowhere
    Black> "pour encourager les autres" ?

I closed idwg for this reason.  I have two wgs on the targeted for
execution list for being disfunctional in various ways.

However before I'm willing to actually close the WG I have to take a
few steps.  Give a last warning, see if anyone wants to try replacing
the chair and doing a better job, decide how to dispose of drafts.
That actually takes time.

Strangely I have more important things to do with my time than prevent
work that isn't happening from happening.  I'll get to it eventually,
but shepherding my functional WGs, helping other WGs and coming to closure on discusses are all higher priority.

Now, arguably, if I could salvage the WGs that are disfunctional,
doing so as soon as possible would be really good.  And if I were
hearing complaints from authors or requests for help from anyone I'd
try to step in sooner.  But if all I'm hearing from a WG is silence,
well, no, it's not really a high priority for me.