Subject: Do drafts need to pass IDnits to be posted?

From: Alexey Melnikov <[email-masked]>
Date: Thu, 26 Jun 2008 14:02:43 +0100

Have I missed a change in rules requiring that all drafts need to pass 
IDnits (as opposed to just have a correct boilerplate)?

Subject: Re: Manual Post Requested for draft-ietf-lemonade-imap-notify
From: "IETF Drafts Team" <[email-masked]>
To: [email-masked]
Cc: [email-masked], [email-masked], [email-masked], [email-masked]
Date: Mon, 23 Jun 2008 13:59:57 -0700 (PDT)

Hi All,

Unfortunately this draft has an error of being over 15 pages long and not
having a table of contents.  Please add a table of contents and I will be
happy to post this draft.

Thank you,

IETF Secretariat

On Sat, June 21, 2008 9:51 am, IETF I-D Submission Tool wrote:
> Manual Posting Requested for following Internet-Draft:
>
> I-D Submission Tool URL:
> https://datatracker.ietf.org/idst/status.cgi?submission_id=7434
>
>
> Filename:	   draft-ietf-lemonade-imap-notify
> Version:	   06
> Staging URL:
> http://www3.ietf.org/proceedings/staging/draft-ietf-lemonade-imap-notify-06.txt
> Title:		   The IMAP NOTIFY Extension
> Creation_date:	   2008-06-21
> WG ID:		   lemonade
> Number_of_pages: 22
> Abstract:
> This document defines an IMAP extension which allows a client to
>  request specific kinds of unsolicited notifications for specified
>  mailboxes, such as messages being added to or deleted from
>  mailboxes.
>
>  [[Add Updates: RFC-CONTEXT to the headers]]
>
> Submitter: Alexey Melnikov ([email-masked])
>
> Author(s):
> Curtis King, [email-masked]
> Alexey Melnikov, [email-masked]
> Arnt Gulbrandsen, [email-masked]
>
>
> Comment:
> IDnits shouldn't care about page length, this issue is not essential for
> drafts and can easily be fixed by the RFC editor.
>
>
>

---

From: Brian Haberman <[email-masked]>
Date: Thu, 26 Jun 2008 09:16:13 -0400

I have wondered the same thing over the past few months.  The only ID 
nits rule that I am aware of is for advancing the draft to the IESG. 
But I have been snagged at least twice in the past 3 months by the ID 
nits check on drafts that are still be worked in my WG.

Regards,
Brian

Alexey Melnikov wrote:
> ------------------------------------------------------------------------
> 
> Subject:
> Re: Manual Post Requested for draft-ietf-lemonade-imap-notify
> From:
> "IETF Drafts Team" <[email-masked]>
> Date:
> CC:
> [email-masked], [email-masked], [email-masked], 
> [email-masked]
> 
> 
> Hi All,
>

---

From: Brian Haberman <[email-masked]>
Date: Thu, 26 Jun 2008 09:54:31 -0400

Hi Loa,
      I also verify that drafts pass ID-nits before submitting them to 
the IESG.  The rejections came on drafts that are still a 
work-in-progress in the WG.

Regards,
Brian

Loa Andersson wrote:
> Brian, all,
> 
> I'm not the process expert, but there are two documents that
> controls how IDs are formatted.
> 
> http://www.ietf.org/ietf/1id-guidelines.html among other things
> contains *rules* that needs to be followed for publication.
> 
> http://www.ietf.org/ID-Checklist.html
> 
> contains the nits, that needs to be sorted out before sending the
> document to IESG.
> 
> The current practice I used for a couple of years is to actually sort
> out the nits before sending the ID to working group last call.
> 
> /Loa
> 
> 
> 
> Brian Haberman wrote:
>>> Have I missed a change in rules requiring that all drafts need to 
>>> pass IDnits (as opposed to just have a correct boilerplate)?
>>>
>>>

---

From: "Mary Barnes" <[email-masked]>
Date: Thu, 26 Jun 2008 08:59:31 -0500

I have noticed that the online tool does not seem to catch as many nits
(e.g., long lines) as the manual posting process does, which in my mind,
is the inverse of what one would think.

Regards,
Mary. 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Brian Haberman
Sent: Thursday, June 26, 2008 8:16 AM
To: Alexey Melnikov
Cc: Working Group Chairs
Subject: Re: Do drafts need to pass IDnits to be posted?

Regards,
Brian

> Unfortunately this draft has an error of being over 15 pages long and 
> not having a table of contents.  Please add a table of contents and I 
> will be happy to post this draft.
> 
> Thank you,
> 
> IETF Secretariat
> 
> 
> 
> 
> 
> 
http://www3.ietf.org/proceedings/staging/draft-ietf-lemonade-imap-notify
-06.txt
>> Alexey Melnikov, [email-masked] Arnt Gulbrandsen, 
>> [email-masked]
>>
>>
>> Comment:
>> IDnits shouldn't care about page length, this issue is not essential 
>> for drafts and can easily be fixed by the RFC editor.
>>
>>
>>
> 
>

---

From: Alexey Melnikov <[email-masked]>
Date: Thu, 26 Jun 2008 15:04:26 +0100

> contains *rules* that needs to be followed for publication.

<http://www.ietf.org/ietf/1id-guidelines.html> says:

   If the Internet-Draft is longer than about 15 pages, please include, 
on the second page, a table of contents to make the document easier to 
reference.

This doesn't sound normative.

---

From: Jari Arkko <[email-masked]>
Date: Thu, 26 Jun 2008 17:48:15 +0300

There is no such rule, AFAIK. It should be just the boilerplate. I can 
take an action item to talk to the secretariat about this.

Jari

---

From: Alexey Melnikov <[email-masked]>
Date: Thu, 26 Jun 2008 15:50:12 +0100

> take an action item to talk to the secretariat about this.

Please.

A side note: It is just frustrating for drafts to be rejected for lack 
of TOC just before the submission deadline.
And I do agree that requiring TOC before sending to IESG is a reasonable 
requirement.

---

From: "Mary Barnes" <[email-masked]>
Date: Thu, 26 Jun 2008 09:54:22 -0500

Alexey, 

Per my note, the online tool does not appear to be as rigorous as the
humans (at least based on my experience several weeks back in submitting
a document for progression to IESG where I was assuming that the tool
made sure the doc passed IDNITS, which it did not - weird in my
opinion): https://datatracker.ietf.org/idst/upload.cgi

Also, the online tool gets your doc posted almost immediately.

Finally, out of curiousity, why are folks still finding the need to
submit manually?  Are there issues with the tool that need to be
addressed? Or, is there anything unusual about your document. I ask
because we still have authors submitting manually, as well, within our
WG, so I would like to understand the motivations for NOT using the
online tool (which I think is fabulous).

Regards,
Mary. 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Alexey Melnikov
Sent: Thursday, June 26, 2008 9:50 AM
To: Jari Arkko
Cc: Working Group Chairs
Subject: Re: Do drafts need to pass IDnits to be posted?

Please.

---

From: Alexey Melnikov <[email-masked]>
Date: Thu, 26 Jun 2008 16:03:53 +0100

Hi Mary,

>online tool (which I think is fabulous).
I have a document in nroff format. It was rejected by the web submission 
tool due to lack of TOC, which is annoying, but Okeyish.
This lead to manual submission, which was rejected due to lack of TOC...

---

From: "Mary Barnes" <[email-masked]>
Date: Thu, 26 Jun 2008 10:03:18 -0500

Thanks for the response. Then I wonder if the tools folks can add
support for nroff?  Just a thought, since I would imagine you are not
that small of a minority that work in that mode still? 

Mary. 

-----Original Message-----
From: Alexey Melnikov [mailto:[email-masked]] 
Sent: Thursday, June 26, 2008 10:04 AM
To: Barnes, Mary (RICH2:AR00)
Cc: Working Group Chairs
Subject: Re: Do drafts need to pass IDnits to be posted?

Hi Mary,

---

From: Al Morton <[email-masked]>
Date: Thu, 26 Jun 2008 11:20:48 -0400

At 10:54 AM 6/26/2008, Mary Barnes wrote:
>submit manually?

In my experience and at least one other wg member,
automated submission is not parsing the author list
of drafts that come from MSWord template(s).  According
to Henrik, this is a known bug and help (another tool)
is on the way. (I've been using XXE for years, but I
keep getting dragged back to Word...)

>Are there issues with the tool that need to be
>addressed?

If you start-out in the automated submission, but switch to
manual because you have to edit the meta-data (see above),
your draft can get stuck for a long time (week+) without getting posted.
I had to contact IETF-action about this more than once.

I found it was much faster to use e-mail, ~1 day posting time
when not close to the deadlines...

Al

---

From: Alexa Morris <[email-masked]>
Date: Thu, 26 Jun 2008 08:41:02 -0700

Alexey,

First, I'm sorry we (AMS) returned your draft to you for an illegitimate
reason. It is clear that we need to  clarify our own internal posting
procedures a bit.  One thing we will do in the next couple of weeks is put
together a reference document that details what is required, and what is
merely desired, for an ID submission. I'll circulate this with the
appropriate folks and verify that our understanding is correct, so that we
can be sure that everyone is on the same page moving forward.

Has your draft been posted yet? If not, please let me know the filename and
I will see that it is posted today.

Regards,
Alexa

-----------
Alexa Morris / Executive Director / IETF
48377 Fremont Blvd., Suite 117, Fremont, CA  94538
Phone: +1.510.492.4089 / Fax: +1.510.492.4001
Email: [email-masked]

Managed by Association Management Solutions (AMS)
Forum Management, Meeting and Event Planning
www.amsl.com <http://www.amsl.com/>

---

From: [email-masked]
Date: Thu, 26 Jun 2008 13:21:51 -0400

Mary,

I've also had the author list problem that Al describes (I
use the Word template, FWIW), including the experience of
having a meta data edit cause the tool to request manual
submission.  I have not had to resort to email.

Thanks,
--David
----------------------------------------------------
David L. Black, Distinguished Engineer
EMC Corporation, 176 South St., Hopkinton, MA  01748
+1 (508) 293-7953             FAX: +1 (508) 293-7786
[email-masked]        Mobile: +1 (978) 394-7754
----------------------------------------------------

> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Al Morton
> Sent: Thursday, June 26, 2008 11:21 AM
> To: Mary Barnes; Alexey Melnikov; Jari Arkko
> Cc: Working Group Chairs
> Subject: RE: Do drafts need to pass IDnits to be posted?
>

---

From: Dean Willis <[email-masked]>
Date: Thu, 26 Jun 2008 12:30:25 -0500

> online tool (which I think is fabulous).

The online tool does not let someone who does not claim to be one of  
the document authors submit a draft. We recently assigned a volunteer  
shepherd to a document, who (with the consent of authors) tried to  
upload a new document version to correct some typos. He was forced to  
use the manual process.

--
Dean

---

From: "Dan Wing" <[email-masked]>
Date: Thu, 26 Jun 2008 10:37:05 -0700

> keep getting dragged back to Word...)

I tracked this down for someone else -- it was caused by a space
after the author's name.  After removing that the online submission
tool was able to successfully and accurately parse the author's
name and author's email address.

-d

---

From: "Randy Presuhn" <[email-masked]>
Date: Thu, 26 Jun 2008 10:43:05 -0700

Hi -

I'm curious why people think using nroff to generate a document
should cause any difficulty with automatically generating a table
of contents.  It wasn't a problem for any of the nroff-source i-ds /
RFCs I've edited over the years.

Randy

----- Original Message ----- 
From: "Mary Barnes" <[email-masked]>
To: "Alexey Melnikov" <[email-masked]>
Cc: "Working Group Chairs" <[email-masked]>
Sent: Thursday, June 26, 2008 8:03 AM
Subject: RE: Do drafts need to pass IDnits to be posted?

Mary. 

-----Original Message-----
From: Alexey Melnikov [mailto:[email-masked]] 
Sent: Thursday, June 26, 2008 10:04 AM
To: Barnes, Mary (RICH2:AR00)
Cc: Working Group Chairs
Subject: Re: Do drafts need to pass IDnits to be posted?

Hi Mary,

---

From: Al Morton <[email-masked]>
Date: Thu, 26 Jun 2008 14:10:11 -0400

At 01:37 PM 6/26/2008, Dan Wing wrote:
> > of drafts that come ...
>...snip...
> >... bug and help (another tool)

Thanks, Dan. That seems to be part of the problem
(the extra space was present), and reformatting the
Table Properties will remove the space in the output,
but this particular file seems to have other problems.
(no worries, we're nearing approval)

Al

---

From: "Eastlake III Donald-LDE008" <[email-masked]>
Date: Thu, 26 Jun 2008 16:49:55 -0400

I use nroff and the meta information isn't ever parsed properly for me.
At a minimum, the submission tool can't figure out where the Abstract
ends and grabs stuff through the page footer and next header and claims
it is part of the abstract. So I have to edit the meta data. Of course,
I'm not aware of any documentation of how the tool parses out the meta
data.

Donald

PS: No problem with ToC, all my drafts have one.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Randy Presuhn
Sent: Thursday, June 26, 2008 1:43 PM
To: Working Group Chairs
Subject: Re: Do drafts need to pass IDnits to be posted?

Hi -

Randy

----- Original Message ----- 
From: "Mary Barnes" <[email-masked]>
To: "Alexey Melnikov" <[email-masked]>
Cc: "Working Group Chairs" <[email-masked]>
Sent: Thursday, June 26, 2008 8:03 AM
Subject: RE: Do drafts need to pass IDnits to be posted?

Mary. 

-----Original Message-----
From: Alexey Melnikov [mailto:[email-masked]] 
Sent: Thursday, June 26, 2008 10:04 AM
To: Barnes, Mary (RICH2:AR00)
Cc: Working Group Chairs
Subject: Re: Do drafts need to pass IDnits to be posted?

Hi Mary,

---

From: Bob Hinden <[email-masked]>
Date: Thu, 26 Jun 2008 15:45:56 -0700

Jari,

On Jun 26, 2008, at 7:48 AM, ext Jari Arkko wrote:

> There is no such rule, AFAIK. It should be just the boilerplate. I  
> can take an action item to talk to the secretariat about this.
>

Thank you!

It's a disturbing trend that tools that were created to increase  
productivity are now being used as a hurdle that reduces productivity.

I think it would be good if the draft submission tool had a mechanism  
where the author could tell it submit even if the IDnits came back  
with problems.  Around the time of the submission deadlines for IETF  
meetings, it more important to have a draft published than making it  
perfect.  It is, of course, the content we discuss at IETF meetings,  
not the boiler plate or TOC.

The TOC requirement is ironic as the percentage of a 15 page document  
that is required boiler plate is now pretty high.  It should be  
increased by at least the number of pages of boiler plate.  Further,  
it's not clear that a TOC is actually that important in the days of  
search engines, editors, etc.

Bob

---

From: "Randy Presuhn" <[email-masked]>
Date: Thu, 26 Jun 2008 17:41:19 -0700

Hi -

> From: "Bob Hinden" <[email-masked]>
> To: "Jari Arkko" <[email-masked]>
> Sent: Thursday, June 26, 2008 3:45 PM
...
> search engines, editors, etc.

A TOC is a great way to get a quick idea of a document's structure and
organization without plowing through the whole thing.  Other tools don't
do that very well.

Randy

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 26 Jun 2008 21:08:40 -0700

Bob,

> productivity are now being used as a hurdle that reduces productivity.

Isn't it more disturbing that it can be perceived this way, as 'being
used as a hurdle', implying there is someone who are actively causing
this?

It is now becoming clear that there has been a bug both in the submission
tool and in the routine used to handle submissions forwarded from the
tool for manual handling.  In both cases, idnits has been run without
the --submitcheck switch.  Running it without that switch makes it return
results which are not appropriate for a submission check, instead showing
the errors and warning appropriate for final submission for publication.

These are both bugs.  I traced down the latter earlier today, and will fix
the former with the help of Glen in the running-and-soon-to-be-replaced
version of the submission tool tomorrow morning.

I've also established today that email submissions directly to the
secretariat (not forwarded by the submission tool) has not had this
problem.

> with problems.

Let me emphatically disagree with this suggestion.  You fix a bug in a
tool or a procedure by fixing it, not by introducing another bug which
will surely come back and bite you later.

>  Around the time of the submission deadlines for IETF  

Then I propose we retire the submission requirements altogether.  If
we prefer to be able to post anything, the honest way would be to not
have requirements which we ignore at will.

<snip para about revising the 15-page TOC requirement>

	Henrik

---

From: "David Harrington" <[email-masked]>
Date: Fri, 27 Jun 2008 12:24:48 +0800

I do not believe we should lessen the requirements. 

David Harrington
[email-masked]
[email-masked]
[email-masked]

> [mailto:[email-masked]] On Behalf Of Henrik Levkowetz
> Sent: Friday, June 27, 2008 12:09 PM
> To: [email-masked]
> Cc: Working Group Chairs; Jari Arkko

---

From: "Spencer Dawkins" <[email-masked]>
Date: Fri, 27 Jun 2008 06:56:17 -0500

> organization without plowing through the whole thing.  Other tools don't

I completely agree that a TOC is a good thing. The question from this thread 
seems to be "is it such a good thing that we should bounce an ID submission 
until the draft includes a TOC, if ID-nits says it should have one?"

I'd say "no".

I note from the excellent tools page for MEDIACTRL drafts (just to pick on 
my own working groups) that 
http://tools.ietf.org/wg/mediactrl/draft-ietf-mediactrl-ivr-control-package/ 
includes a hyperlink for "nits". Perhaps one resolution is to allow a 
submitter to say "submit it anyway", and then include a note in ID 
announcements that says "this draft does not pass ID-nits, but the submitter 
chose to publish it anyway".

The ID-nits checklist is useful. Running it automatically at submission time 
is useful (please don't stop). Allowing a human to override the normal 
check, and providing an indication that this has been done, seems useful as 
well.

Thanks,

Spencer

---

From: Loa Andersson <[email-masked]>
Date: Fri, 27 Jun 2008 14:27:45 +0200

All,

I sent a few mails on this yesterday, but they don't seem to have
been posted.

At the risk of repeating myself.

Spencer Dawkins wrote:
> I completely agree that a TOC is a good thing. 

yes it is - it helps enhancing the quality of reviews

the entire idea of posting a draft is to get it reviewed

> The question from this 
> thread seems to be "is it such a good thing that we should bounce an ID 
> submission until the draft includes a TOC, if ID-nits says it should 
> have one?"

well there are two things here

the requirement of a ToC is not in ID-nits

the requirement of a ToC is in the ID guideline, together with
boilerplates and other such stuff

it is fairly fuzzily document, is says "if more than 15 pages, please
include a ToC"

> I'd say "no".
I'd say "it depends"

I'm not sure that 15 pages is the right figure, especially since the
boilerplate info has increased quite a bit since that figure were chosen

I'm fairly sure that large documents without a ToC is counter-productive
with respect to review

I'm very sure that I don't want to have a 150 pages document without
a ToC.

There might be possible to find a middle ground here

1. if we allow "no ToC" for a -00 version, but give a strong waring that
    the ToC needs to be included in the next version
2. require that the ToC in included for wg documents
3. have a look at what size of a document where we need to enforce a ToC
    (15 pages + boiler plate for -01 drafts, and 50 pages for all
    drafts ?)

> I note from the excellent tools page for MEDIACTRL drafts (just to pick 
> on my own working groups) that 
> announcements that says "this draft does not pass ID-nits, but the 
> submitter chose to publish it anyway".

yes with the rules above in place

> 
> The ID-nits checklist is useful. Running it automatically at submission 
> time is useful (please don't stop). Allowing a human to override the 
> normal check, and providing an indication that this has been done, seems 
> useful as well.

well - I'm almost as concerned about the humans as the automated process

my take is that we are here to produce good and sound standards, we
should not confuse this with "easy to submit"

Could we hear comments from the people who actually wrote the ID-nits
and the ID-guidelines?

/Loa

-- 
Loa Andersson

Principal Networking Architect
Acreo AB                           phone:  +46 8 632 77 14
Isafjordsgatan 22                  mobile: +46 739 81 21 64
Kista, Sweden                      email:  [email-masked]
                                            [email-masked]

---

From: Henrik Levkowetz <[email-masked]>
Date: Fri, 27 Jun 2008 06:55:49 -0700

Hi Spencer,

> until the draft includes a TOC, if ID-nits says it should have one?"

And it's a bug to bounce because of it, as the governing document
(http://www.ietf.org/ietf/1id-guidelines.txt) doesn't require it,
only suggests it.  And as I mentioned earlier, that bug will be
corrected in all submission paths later today.

> check, and providing an indication that this has been done, seems useful as 

The override path as defined in RFC 4228 is manual submission.  Possibly
we need to set up some way for the AMS people handling manual submissions to request human judgement from an IETF submission ombudsman or something like
that, if posting is explicitly requested for a document which doesn't confirm
to http://www.ietf.org/ietf/1id-guidelines.txt.  But the primary problem here
hasn't been the lack of override, it has been a definite bug regarding which
criteria has been applied in 2 of the submission paths, and I think that
fixing the bug for those paths will satisfy well-nigh all problematic cases.

After that is done, we might want to review 1id-guidelines.txt and find ways
to bring more human judgement into the manual submission procedure, but please,
let's first fix what is clear bugs and see how far that gets us.

	Henrik

---

From: Barry Leiba <[email-masked]>
Date: Fri, 27 Jun 2008 11:17:39 -0400

> increased by at least the number of pages of boiler plate.

I've been mulling this over for a bit, and I just looked at a draft that's 
currently in the RFC Editor queue.  Hey, we're talking about a page at the front 
and a page at the back.  It's not like the standard gorp has expanded to 5 or 10 
pages.  I think this point is a red herring.

Barry

--
Barry Leiba, DKIM working group chair  ([email-masked])
http://www.research.ibm.com/people/l/leiba
http://www.research.ibm.com/spam

---

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Fri, 27 Jun 2008 09:49:30 -0700

Just require every draft provide a TOC and have done.

________________________________

From: [email-masked] on behalf of Barry Leiba
Sent: Fri 6/27/2008 11:17 AM
To: Working Group Chairs
Subject: Re: Do drafts need to pass IDnits to be posted?

Barry