Subject: Using a WG Wiki

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 09 Jul 2008 18:32:20 +0200

Hi,

It's been pointed out to me that a Wiki can be used by a WG in various ways,
and if the use of a Wiki creates a second separate stream of communication,
in addition to the mailing list, it's bad.

A couple of examples of WGs which seem to have used the Wiki in a reasonable
way are here:

  http://wiki.tools.ietf.org/wg/sieve/trac/
  http://wiki.tools.ietf.org/wg/netconf/trac/

Currently the default is that both Issue and Wiki page creation is open to
anybody who has logged in.  Maybe I should change the wiki permission to
by default only permit page creation by the chairs?

	Henrik

---

From: Alexey Melnikov <[email-masked]>
Date: Wed, 09 Jul 2008 17:35:12 +0100

Hi Henrik,

> by default only permit page creation by the chairs?

Yes, this seems reasonable.

---

From: "Ersue, Mehmet (NSN - DE/Muenich)" <[email-masked]>
Date: Wed, 9 Jul 2008 18:42:20 +0200

> Yes, this seems reasonable.

Which can be extended if necessary.

Mehmet

---

From: "Spencer Dawkins" <[email-masked]>
Date: Wed, 9 Jul 2008 12:20:10 -0500

(extended to working group secretaries, for instance :-)

Spencer

---

From: "Dan Wing" <[email-masked]>
Date: Wed, 9 Jul 2008 10:10:46 -0700

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Henrik Levkowetz
> Sent: Wednesday, July 09, 2008 9:32 AM
> To: WG Chairs
> Subject: Using a WG Wiki
> 
> Hi,
> 

Yes.

-d

---

From: "Mani, Mahalingam (Mani)" <[email-masked]>
Date: Wed, 9 Jul 2008 11:20:58 -0600

Henrik,

I agree with your suggestion (on page-creation permission) as well.

-mani
===========================
[...]

Currently the default is that both Issue and Wiki page creation is open
to
anybody who has logged in.  Maybe I should change the wiki permission to
by default only permit page creation by the chairs?

	Henrik

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 09 Jul 2008 23:31:00 +0200

Hi,

There seem to be a strong consensus to permit Wiki page creation as default
only by the chairs (i.e., the Trac Admins).

Accordingly, I've removed the WIKI_CREATE permission from authenticated
users for the Trac instances in the following list, where the Wiki front
page remains untouched from the default.  For WGs where the wiki page has
been changes I assume that some thought has been given to the permissions,
so I haven't changed them.

The instances I've changed (in addition to fixing the default for future
instances) are:

16ng			manet				
6man			mediactrl		
ancp			mip6			
bliss			mipshop			
capwap			monami6			
csi			mpls			
dhc			netmod			
dna			opsawg			
drinks			opsec			
eai			p2psip			
ecrit			pcn			
emu			pmol			
enum			roll			
fecframe		sip			
hokey			speermint		
ipsecme			tictoc			
isms			tls			
keyprov			v6ops			
			vcarddav

Regards,

	Henrik