Subject: Re: [Trustees] Last Call for Comments: Proposed work-around to thePre-5378 Problem

From: [email-masked]
Date: Sun, 8 Feb 2009 22:53:57 +0000

Sorry for this Blackberry response. 

Neither 'wish' nor 'elects' is accaeptable to me because it seems to place a duty on the Contributor to ascertain the desires of the pre-5378 contributor, a tasking on the contributor that I wish to avoid with the language proposed. 

Ray 
Sent via BlackBerry by AT&T

-----Original Message-----
From: "Contreras, Jorge" <[email-masked]>

Date: Sun, 8 Feb 2009 17:52:46 
To: <[email-masked]>; <[email-masked]>; <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>; <[email-masked]>; <[email-masked]>; <[email-masked]>; <[email-masked]>
Subject: Re: [Trustees] Last Call for Comments: Proposed work-around to	thePre-5378 Problem

John - thanks for that clarification.  Would "elect" be less value-laden than "wish"?

 ----- Original Message -----
 From: John C Klensin <[email-masked]>
 To: Contreras, Jorge; Thomas Narten <[email-masked]>; Ray Pelletier <[email-masked]>
 Cc: Trustees <[email-masked]>; [email-masked] <[email-masked]>; [email-masked] <[email-masked]>; [email-masked] <[email-masked]>; [email-masked] <[email-masked]>; [email-masked] <[email-masked]>
 Sent: Sun Feb 08 17:38:10 2009
 Subject: RE: [Trustees] Last Call for Comments: Proposed work-around to thePre-5378 Problem

 --On Sunday, February 08, 2009 5:24 PM -0500 "Contreras, Jorge"
 <[email-masked]> wrote:
 
 > Sorry for jumping into this thread late, but I would recommend
 > leaving 6.c and 6.c.iii as proposed in the TLP draft that was
 > circulated.
 >
 > 6.c.iii
 >
 >> OLD:
 >>
 >> > iii. If a Contribution includes Pre-5378 Material and the
 >> >  Contributor does not wish to allow modifications of such
 >> >  Pre-5378 Material to be made outside the IETF Standards
 >> >  Process:
 >>
 >> "does not wish" is not right. The issue is that the current
 >> author of the document is unable (for whatever reason) to
 >> make assertions about the pre-5378 material.
 >
 > I think "does not wish" is right, as it gives the new
 > Contributor maximum flexibility in withholding the right to
 > make non-IETF derivative works if his Contribution includes
 > pre-5378 Material.  I don't see any of the proposed changes
 > making this clearer or better.
 >...
 
 Jorge,
 
 I think people are trying to make two specific points.  If you
 tell us that both are irrelevant, then I, for one, will accept
 that and move on.  The points are:
 
 (1) This language should not let a submitting author (a term
 that is a tad more precise than "Contributor" for this purpose,
 but substitute as you like) off the hook for compliance with the
 letter and intent of 5378 for his or her one new, post
 whenever-November-10-is, contribution.  If the Note Well, or
 5378 itself, or something else, takes care of that regardless of
 what the workaround text says, it would be helpful to clarify
 that somewhere.
 
 (2) As a submitting author, I may be so convinced that 5378 is a
 wonderful thing that I would dearly wish, with all of my might,
 that I could offer a document in full compliance with its text
 and intent.  But I may just not have enough rights to do that
 (something wishing is unlikely to cure)  and hence have to opt
 for IETF use only.   Some of us would like to avoid an assertion
 that we "wish" to not provide the broader rights as it may be
 counterfactual.   That distinction may make absolutely no
 difference from an IPR standpoint, but some of us have an
 allergy to IETF procedural rules that require people to assert
 things that aren't true.
 
     john

---

From: Ray Pelletier <[email-masked]>
Date: Sun, 8 Feb 2009 20:33:06 -0500

One more clarification ...
On Feb 8, 2009, at 5:24 PM, Contreras, Jorge wrote:

> Sorry for jumping into this thread late, but I would recommend leaving
> 6.c and 6.c.iii as proposed in the TLP draft that was circulated.
>
> <snip>

>
> 6.c
>
> OLD
>
> c. Derivative Works and Publication Limitations.  If a Contributor
> desires to limit the right to make modifications and derivative
> works of an IETF Contribution, or to limit its publication, one of
> the following notices must be included.
>
> PROPOSED
>> 	c. Derivative Works and Publication Limitations.  If a
>> 	Contributor desires to limit its publication, or the
>> 	Contribution includes pre-5378 Material that limits the right
>> 	to make modifications and derivative works of an IETF
>> 	Contribution, one of the following notices must be included.
>> 	The notices set forth in clauses (i) and (ii) below may not be
>> 	used with any standards-track document, nor with most working
>> 	group documents.

The 'or' clause requires a certainty that the Legend at 6.c.iii does  
not require.
I think it should read:

or the Contribution includes pre-5378 Material that limits
s/limits/ may limit
the right to make modifications and derivative works of an IETF
Contribution, one of the following notices must be included.

Ray

>>
>
> Same issue (other than the problem that there is no antecedent to the
> pronoun "its" in line 2).  Using "that limits" in line 3 implies that
> the new Contributor must make a legal determination about the rights  
> in
> pre-5378 Material, which I do not think is the desired approach.
>
>> From: [email-masked]
>> [mailto:[email-masked]] On Behalf Of Thomas Narten
>> Sent: Friday, February 06, 2009 2:02 PM
>> To: Ray Pelletier
>> Cc: Trustees; [email-masked]; [email-masked]; [email-masked];
>> [email-masked]; [email-masked]
>> Ray,
>>>> NEW:
>>>>   Contributor is unable (for whatever reason) to obtain the
>>>>   necessary permissions to allow modifications of such Pre-5378
>>>>   Material to be made outside the IETF Standards Process:
>>
>>> The language suggests a tasking to obtain 5378 licenses from
>>> contributors of pre-5378 material.  I think that is something we
>>> want to avoid.  I think the following language obtains the same
>>> results but with less stress on the participants.
>>
>> I agree, but that might also be seen to be getting closer to
>> overruling what RFC 5378 says, something that I understand to be out
>> of scope.
>>
>>> iii. If a Contribution includes Pre-5378 Material for which the
>>>    Contributor of the pre-5378 material has not or may not have
>>>    granted the necessary permissions to the IETF Trust to allow
>>>    modifications of such Pre-5378 Material to be made outside the
>>>    IETF Standards Process:
>>
>> IMO, this is improved wording I support it.
>>
>> Thanks,
>> Thomas
>> _______________________________________________
>> Trustees mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/trustees
>>