Subject: Example of Linked minutes, slides, and audio recordings

From: Cullen Jennings <[email-masked]>
Date: Wed, 15 Apr 2009 20:45:24 -0600

I thought folks might be interested in this as an example of what we  
could do with linking in the audio recordings for WGs. (Thanks Vijay)

Begin forwarded message:

> From: Dean Willis <[email-masked]>
> Date: April 15, 2009 4:24:18 PM MDT (CA)
> To: "[email-masked] List" <[email-masked]>
> Subject: [Sip] Linked minutes, slides, and audio recordings for SIP  
> at IETF 74
>
>
> Check out:
>
> http://www.softarmor.com/mediawiki/index.php/SIP_Audio_for_IETF_74
>
>
> I'd like to thank Vijay Gurbani for putting this all together.
>

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Thu, 16 Apr 2009 08:42:21 -0500

> could do with linking in the audio recordings for WGs. (Thanks Vijay)

Cullen: No problem.  I think this helps track resolutions and
meetings better.  I toyed with including the jabber log,
but as an archive, the official minutes are probably the best
(jabber being invaluable for remote users to trace in
real-time what is going.)

As a FYI, I currently do this for three working groups:

alto: http://trac.tools.ietf.org/wg/alto/trac/wiki
sip: http://www.softarmor.com/mediawiki/index.php/SIP_Audio_for_IETF_74
sipping: http://www.softarmor.com/sipping/meets/ietf74/audio/index.html

Cheers,

- vijay
-- 
Vijay K. Gurbani, Bell Laboratories, Alcatel-Lucent
1960 Lucent Lane, Rm. 9C-533, Naperville, Illinois 60566 (USA)
Email: vkg@{alcatel-lucent.com,bell-labs.com,acm.org}
Web:   http://ect.bell-labs.com/who/vkg/

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Thu, 16 Apr 2009 08:57:35 -0500

Phillip Hallam-Baker wrote:
> To make it work well it is going to have to require as little manual
> intervention as possible.

Having done it for the last two IETFs for the same WGs, I
have a set of heuristics that I use to minimize time.

That said, more automation would be a good idea.  We could put
track markers in the audio stream to make it easy for automated
tools to search the marker.  Alternatively, we could simply
provide the start and stop times of the discussions to a utility
that seeks into the media stream and extracts each set.  I have
toyed with writing such a utility -- but maybe in time for
the next IETF.

> Editing log files by hand is not going to work.

The edit is mostly on the mp3 file, not the log files.

Thanks,

- vijay