Subject: issue with the URLs in the ID boilerplate

From: Lars Eggert <[email-masked]>
Date: Fri, 23 Oct 2009 15:19:06 +0300

Hi,

the current ID boilerplate says:

>    The list of current Internet-Drafts can be accessed at
>    http://www.ietf.org/ietf/1id-abstracts.txt.

This URL is redirected to http://www.ietf.org/ietf-ftp/1id- 
abstracts.txt, which then produces a 404 error.

>    The list of Internet-Draft Shadow Directories can be accessed at
>    http://www.ietf.org/shadow.html.

This URL redirects to http://www.ietf.org/old/2009/shadow.html, which  
has a list of some FTP sites. Among those:

* ftp://mirror.switch.ch/mirror/ietf/ has a bunch of stuff but not  
actually any IDs (as far as I can tell)

* ftp.nic.it doesn't respond

* ftp://ftp.fccn.pt/pub/IETF/Internet-Drafts/ doesn't respond

* munnari.oz.au doesn't have anything newer than March 2006

* ftp.ietf.rnp.br doesn't exist in the DNS anymore

* ftp.kaist.ac.kr is listed twice

Not good!

Since I've seen zero complaints about this, I'm assuming nobody has  
actually bothered to try and retrieve the ID index in this way or is  
actually using these FTP mirrors anymore.

I'd hence like to propose that we remove those lines from the  
boilerplate to save five lines on the first page.

Thoughts?

Lars

---

From: <[email-masked]>
Date: Fri, 23 Oct 2009 14:47:56 +0200

Hi Lars.

I tend to agree with you about the shadow list. However, I would say
about the I-D list that, even if this information is useless for daily
IETFers, once updated it can still be useful for people who only handle
I-Ds once in a while.

Regards,

Julien

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Lars Eggert

Hi,

Not good!

Thoughts?

Lars

---

From: "Spencer Dawkins" <[email-masked]>
Date: Fri, 23 Oct 2009 07:49:48 -0500

Well, it DOES seem to me that anyone trying to find the shadows would be 
better served with a google search (and probably a lot more likely to start 
with a google search as well). I'd agree.

Anything that removes non-working and/or non-useful cruft is a good thing.

Thanks,

Spencer

> This URL is redirected to http://www.ietf.org/ietf-ftp/1id- abstracts.txt, 
> which then produces a 404 error.
>
> This URL redirects to http://www.ietf.org/old/2009/shadow.html, which  has 
> a list of some FTP sites. Among those:
>
> I'd hence like to propose that we remove those lines from the  boilerplate 
> to save five lines on the first page.
>
> Thoughts?
>
> Lars

---

From: Lars Eggert <[email-masked]>
Date: Fri, 23 Oct 2009 17:26:27 +0300

On 2009-10-23, at 15:49, Spencer Dawkins wrote:
> anyone trying to find the shadows would be
> better served with a google search

Yup.

If we wanted to, we could put a pointer to the main IETF site in there  
without wasting a line, e.g. by changing

>    Internet-Drafts are working documents of the Internet Engineering
>    Task Force (IETF), its areas, and its working groups.  Note that
>    other groups may also distribute working documents as Internet-
>    Drafts.

to

>    Internet-Drafts are working documents of the Internet Engineering
>    Task Force (IETF). The Internet-Draft repository is online at
>    https://datatracker.ietf.org/drafts/. Note that other groups may
>    also distribute working documents as Internet-Drafts.

Lars

---

From: Jeffrey Hutzelman <[email-masked]>
Date: Fri, 23 Oct 2009 10:48:01 -0400

--On Friday, October 23, 2009 07:49:48 AM -0500 Spencer Dawkins 
<[email-masked]> wrote:

> better served with a google search (and probably a lot more likely to
> start with a google search as well). I'd agree.
>

While removing cruft and shortening boilerplate are laudable goals, the 
_correct_ solution to having published ID's with URL's that no longer work, 
given that the namespace is under our control, is to FIX THE BROKEN PAGES!

There's no reason that http://www.ietf.org/ietf/1id-abstracts.txt, which 
has worked for a very long time and is published in lots of places, should 
not continue to return a copy of the _current_ I-D abstracts file.

-- Jeff

---

From: Paul Hoffman <[email-masked]>
Date: Fri, 23 Oct 2009 07:52:37 -0700

At 5:26 PM +0300 10/23/09, Lars Eggert wrote:
>If we wanted to, we could put a pointer to the main IETF site in there without wasting a line, e.g. by changing
>

Please swap the second and third sentences to give the paragraph better continuity, but then +1.

--Paul Hoffman, Director
--VPN Consortium

---

From: Paul Hoffman <[email-masked]>
Date: Fri, 23 Oct 2009 07:55:19 -0700

At 10:48 AM -0400 10/23/09, Jeffrey Hutzelman wrote:
>While removing cruft and shortening boilerplate are laudable goals, the _correct_ solution to having published ID's with URL's that no longer work, given that the namespace is under our control, is to FIX THE BROKEN PAGES!

If almost no one is using the URLs, then the correct solution is to get rid of them.

>There's no reason that http://www.ietf.org/ietf/1id-abstracts.txt, which has worked for a very long time and is published in lots of places, should not continue to return a copy of the _current_ I-D abstracts file.

Sure, but that does not explain why every reader of every Internet Draft needs to see the URL.

--Paul Hoffman, Director
--VPN Consortium

---

From: Jeffrey Hutzelman <[email-masked]>
Date: Fri, 23 Oct 2009 11:02:28 -0400

--On Friday, October 23, 2009 07:55:19 AM -0700 Paul Hoffman 
<[email-masked]> wrote:

>> has worked for a very long time and is published in lots of places,
>> should not continue to return a copy of the _current_ I-D abstracts file.
>

True.  I did not mean to imply that the boilerplate should not be updated 
in some way; only that the already-published links should be made to work 
again.

-- Jeff

---

From: John C Klensin <[email-masked]>
Date: Fri, 23 Oct 2009 10:40:41 -0400

Lars,

FWIW, I like your proposed change.

I think, however, that the main point we should derive from this
particular discovery is that very few people carefully read
boilerplate or pay serious attention to its contents.   Instead,
the tendency is that, once one has encountered a series
sufficiently to understand where the boilerplate is located, one
simply skips over it as irrelevant to one's particular
motivation in looking at the document.  That is something we
need to remember, IMO, as we consider the effect of any change
to, or insertion in, boilerplate material.   

It may, oddly, be one of the advantageous side effects of the
pending "move the Abstract up" changes: people in the IETF
community may actually read the boilerplate text for the first
time in years if only to discover where it begins and ends so
they can go back to ignoring it :-)

    john

--On Friday, October 23, 2009 17:26 +0300 Lars Eggert
<[email-masked]> wrote:

>...
 
> to
> 
>>    Internet-Drafts are working documents of the Internet
>>    Engineering Task Force (IETF). The Internet-Draft
>>    repository is online at
>>    https://datatracker.ietf.org/drafts/. Note that other
>>    groups may also distribute working documents as
>>    Internet-Drafts.
> 
> 
> Lars

---

From: John C Klensin <[email-masked]>
Date: Fri, 23 Oct 2009 11:01:25 -0400

--On Friday, October 23, 2009 07:55 -0700 Paul Hoffman
<[email-masked]> wrote:

>> While removing cruft and shortening boilerplate are laudable
>> goals, the _correct_ solution to having published ID's with
>> URL's that no longer work, given that the namespace is under
>> our control, is to FIX THE BROKEN PAGES!
> 

Agreed.   Given our nominal "expires in six months" provisions,
the above is, at most, an argument for making the URL work,
changing the boilerplate, waiting six months, and then undoing
the URL if we have reason to do that.  But, if almost no one is
using them, that seems like a lot of effort for very little
payoff.

>> There's no reason that
>> http://www.ietf.org/ietf/1id-abstracts.txt, which has worked
>> for a very long time and is published in lots of places,

Again, yes.   The fact that many of us have bookmarks and macros
with that URL in them is a much stronger argument for keeping
that link working than anything having to do with unreferenced
URLs in I-D boilerplate.

      john

---

From: Bob Hinden <[email-masked]>
Date: Fri, 23 Oct 2009 16:39:19 -0700

> simply skips over it as irrelevant to one's particular

Isn't that the definition of "boilerplate" :-)

Bob

---

From: "Martin J. Dürst" <[email-masked]>
Date: Sat, 24 Oct 2009 14:11:46 +0900

>> also distribute working documents as Internet-Drafts.

The last sentence is open to misunderstandings. It should say something 
like "Note that mirrors of this repository may be available elsewhere."

"other groups may also distribute working documents as Internet-Drafts" 
suggests that people can call things that are not submitted properly 
"Internet-Draft".

Regards,   Martin.

-- 
#-# Martin J. Dürst, Professor, Aoyama Gakuin University
#-# http://www.sw.it.aoyama.ac.jp   mailto:[email-masked]

---

From: Lars Eggert <[email-masked]>
Date: Mon, 26 Oct 2009 13:05:45 +0200

Hi,

> suggests that people can call things that are not submitted properly

I think the last sentence is actually supposed to mean "not all  
Internet-Drafts are working documents of the IETF", but I agree that  
my (too casual) edit probably destroyed that meaning. Here's a new  
attempt:

    Most Internet-Drafts are working documents of the Internet  
Engineering
    Task Force (IETF).  Note that other groups may also distribute
    working documents as Internet-Drafts. The Internet-Drafts repository
    can be accessed at http://datatracker.ietf.org/drafts/.

    Internet-Drafts are draft documents valid for a maximum of six  
months
    and may be updated, replaced, or obsoleted by other documents at any
    time.  It is inappropriate to use Internet-Drafts as reference
    material or to cite them other than as "work in progress."

    This Internet-Draft will expire on April 29, 2010.

All feedback I've seen so far on making this change has been positive;  
I'll take this up with the rest of the IESG once we have a final  
agreement on the text.

Lars

---

From: "Spencer Dawkins" <[email-masked]>
Date: Mon, 26 Oct 2009 06:29:19 -0500

Good morning, Lars,

I may still be asleep, but my sense of (IDs = IETF-IDs + Other-IDs) is that you're saying in the current text that the Internet-Draft repository contains all IDs, but it really contains IETF-IDs, right? 

If so, I'd suggest s/The Internet-Draft repository/The IETF Internet-Draft repository/.

Thanks,

Spencer
  ----- Original Message ----- 
  From: Lars Eggert 
  To: Martin J. Dürst 
  Cc: Spencer Dawkins ; Working Group Chairs 
  Sent: Monday, October 26, 2009 6:05 AM
  Subject: Re: issue with the URLs in the ID boilerplate

  Hi,

  Lars

---

From: Lars Eggert <[email-masked]>
Date: Mon, 26 Oct 2009 13:36:52 +0200

On 2009-10-26, at 13:29, Spencer Dawkins wrote:
> I may still be asleep, but my sense of (IDs = IETF-IDs + Other-IDs)  
> is that you're saying in the current text that the Internet-Draft  
> repository contains all IDs, but it really contains IETF-IDs, right?

Er, right.

How about:

   Most Internet-Drafts are working documents of the Internet  
Engineering
   Task Force (IETF).  Note that other groups may also distribute
   working documents as Internet-Drafts.  The IETF Internet-Drafts
   repository can be accessed at http://datatracker.ietf.org/drafts/.

   Internet-Drafts are draft documents valid for a maximum of six months
   and may be updated, replaced, or obsoleted by other documents at any
   time.  It is inappropriate to use Internet-Drafts as reference
   material or to cite them other than as "work in progress."

   This Internet-Draft will expire on <date>.

Lars

---

From: Peter Koch <[email-masked]>
Date: Mon, 26 Oct 2009 12:40:35 +0100

Hello,

> If so, I'd suggest s/The Internet-Draft repository/The IETF Internet-Draft repository/.

this might also be a lack of sleep, but what other groups do actually
distribute "Internet-Drafts"?  Is this to maintain the subtle distinction
between IETF, IAB, the Trust, and IRTF or is it to say that the term
"Internet-Draft" is generic rather than an IETF (or Trust, for that matter)
owned term?  Isn't it that all I-Ds processed are subject to the IETF's
I-D rules?
It's probably more important to emphasize that "working documents of the [...]
IETF" does not imply any support, endorsement or recognition by the IETF
or any of its WGs.

-Peter

---

From: Thomas Heide Clausen <[email-masked]>
Date: Mon, 26 Oct 2009 12:40:37 +0100

>  Internet-Drafts are draft documents valid for a maximum of six months

<nit-pick>

If we assume that IDs = IETF-IDs + Other-IDs, is it then appropriate  
(or even true?) to assume that also "Other-IDs" have a 6 month  
validity time?

Thomas

---

From: Lars Eggert <[email-masked]>
Date: Mon, 26 Oct 2009 13:53:28 +0200

> (or even true?) to assume that also "Other-IDs" have a 6 month

Let's try a different approach. Instead of saying "Internet-Drafts  
come from the IETF but maybe also elsewhere", let's go back to saying  
that IDs are IETF docs but others may write stuff that looks like IDs  
(but aren't). That solves that issue and is maybe also overall
cleaner:

   Internet-Drafts are working documents of the Internet Engineering
   Task Force (IETF).  Other groups may distribute documents that look
   like Internet-Drafts, but are not IETF documents.  The IETF
   Internet-Drafts repository is at http://datatracker.ietf.org/drafts/.

Lars

---

From: Lars Eggert <[email-masked]>
Date: Mon, 26 Oct 2009 16:34:12 +0200

Hi, John,

point taken. This was supposed to be a simple elimination of a few  
lines, but I went down the rathole of starting to tweak the  
boilerplate too much. (Never a good idea.) So let's do a minimal  
change compared to current text:

   Internet-Drafts are working documents of the Internet Engineering
   Task Force (IETF).  Note that other groups may also distribute
   working documents as Internet-Drafts.  The list of current
   Internet-Drafts is at http://datatracker.ietf.org/drafts/.

Compared to the version currently used, this:

(1) removes the "its areas, and its working groups" part from the  
first sentence
(2) appends "The list of current Internet-Drafts..." to the first  
paragraph
(3) removes the shadow repository pointers

See the attached diff for marked-up changes.

Lars

On 2009-10-26, at 15:29, John C Klensin wrote:

>
>
> --On Monday, October 26, 2009 13:53 +0200 Lars Eggert
>>> If we assume that IDs = IETF-IDs + Other-IDs, is it then
>>> appropriate (or even true?) to assume that also "Other-IDs"
>>> have a 6 month validity time?
>>
>> Let's try a different approach. Instead of saying
>> "Internet-Drafts come from the IETF but maybe also elsewhere",
>> let's go back to saying that IDs are IETF docs but others may
>> write stuff that looks like IDs (but aren't). That solves that
>> issue and is maybe also overall
>> cleaner:
>>
> I think this is missing the point.   Unless I'm mistaken, the
> reason for the "other groups..." language is that what we now
> call the IAB, IRTF, and Independent Submission streams all use
> the I-D publication mechanism without thereby making the
> documents "working documents of the Internet Engineering Task
> Force (IETF)".   Those documents may still be "IETF documents"
> (a term that has become important from an IETF Trust
> perspective), but are obviously not "working documents of the
> IETF" since, by definition, the IETF is not working on them.
>
> The issue isn't what others might produce that look like
> something we might produce.  That wouldn't require any special
> statement.
>
> Observation: as the topic moves from the broken URL problem to
> textual statements in the boilerplate, using the wg-chairs list
> to becomes, IMO, less and less the right place to be trying to
> make decisions on the questions involved.   First, the people
> with the history of how the current language came to be are
> Scott Bradner and maybe Dave Crocker.  I think one should at
> least understand that history and motivation before trying to
> make changes and, as far as I know, neither of them are active
> WG Chairs and hence on this list.  Second, the language used to
> describe I-Ds has both IPR implications ("what is an 'IETF
> document'" and  the use of I-D posting as a mechanism for
> requiring patent disclosures and securing RFC 5378 releases) and
> potentially other implications for the non-IETF RFC publication
> streams.  It seems unwise to me to contemplate making those
> changes without an early opportunity for those groups to
> evaluate probable consequences.
>
>     john
>
>
>
>

---

From: Jeffrey Hutzelman <[email-masked]>
Date: Mon, 26 Oct 2009 11:26:22 -0400

--On Monday, October 26, 2009 06:29:19 AM -0500 Spencer Dawkins 
<[email-masked]> wrote:

> Good morning, Lars,
>
> I may still be asleep, but my sense of (IDs = IETF-IDs + Other-IDs) is
> that you're saying in the current text that the Internet-Draft repository
> contains all IDs, but it really contains IETF-IDs, right?
>

<sigh>

No, _the_ Internet-Drafts repository contains _all_ I-D's.  Anyone can 
submit an I-D to the repository.  Not all I-D's are working drafts of the 
IETF; some may be working documents of other groups.  Hence the original 
language, which said, "other groups may also distribute working documents 
as Internet-Drafts".

It doesn't say "other groups may mirror the I-D repository", though that is 
certainly true.

It doesn't say "other groups may call their working documents 
'Internet-Drafts'", though I don't think we have any means to prevent that 
if someone wanted to do it.

What it does say is "other groups may distribute working documents _as_ 
Internet-Drafts" (emphasis mine); that is, via the same mechanisms used by 
people preparing working documents of the IETF.

I vote for leaving the language as it currently is, instead of trying to 
rewrite it to say something else.

-- Jeff

---

From: John C Klensin <[email-masked]>
Date: Mon, 26 Oct 2009 09:29:49 -0400

john

---

From: John C Klensin <[email-masked]>
Date: Mon, 26 Oct 2009 11:21:31 -0400

Lars,

Thanks.  This works for me.  I do suggest exposing it to a
broader community, e.g., on the IETF list and with notes to the
leadership of the other three streams, before making the change,
but I think this ought to be ok.

best,
    john

--On Monday, October 26, 2009 16:34 +0200 Lars Eggert
<[email-masked]> wrote:

> Hi, John,
> 
> point taken. This was supposed to be a simple elimination of a
> few lines, but I went down the rathole of starting to tweak
> the boilerplate too much. (Never a good idea.) So let's do a
> minimal change compared to current text:
> 
> (1) removes the "its areas, and its working groups" part from
> the first sentence
> (2) appends "The list of current Internet-Drafts..." to the
> first paragraph

---

From: Paul Hoffman <[email-masked]>
Date: Mon, 26 Oct 2009 09:16:22 -0700

I think we are (correctly) getting tripped up on "distribute". Other groups don't distribute Internet Drafts: they write them and let the IETF distribute them. Also, we don't know if "most" will be true forever, regardless of what we hope.

At 1:36 PM +0200 10/26/09, Lars Eggert wrote:
>  Most Internet-Drafts are working documents of the Internet Engineering

Proposed change:

  Many Internet-Drafts are working documents of the Internet Engineering
  Task Force (IETF); other groups and individuals create Internet-Drafts
  that are included in the repository that is maintained by the IETF.
  That repository is available at http://datatracker.ietf.org/drafts/.

--Paul Hoffman, Director
--VPN Consortium