Subject: How to reach WG secretaries

From: Adrian Farrel <[email-masked]>
Date: Thu, 14 Jan 2010 11:03:44 +0000

Hi WG chairs,

I was wondering aloud about how to reach WG secretaries with announcements 
such as "77th IETF - Working Group/BOF Scheduling". I got responses that 
indicated several possible solutions...

1. Add the secretaries to this (WG chairs list)
2. Make a separate list for secretaries
3. Have this list (WG chairs only) and a new list (chairs and secretaries)
4. Stop worrying and let the chairs forward stuff as necessary

Your thoughts?

Thanks,
Adrian

---

From: Andrew Sullivan <[email-masked]>
Date: Thu, 14 Jan 2010 11:34:41 -0500

> 4. Stop worrying and let the chairs forward stuff as necessary

I slightly prefer 3 over 2, strongly prefer 2 over 1, and don't really
like 4.  My preferences in this case are transitive.  Since not every
WG hasa secretary, one either has to do 3 all the time, or else
subscribe the chairs of those WGs without a secretary to the list
created in 2.

A

-- 
Andrew Sullivan
[email-masked]
Shinkuro, Inc.

---

From: "Andrew G. Malis" <[email-masked]>
Date: Thu, 14 Jan 2010 11:35:15 -0500

Add secretaries to the list. They may have good insights to the issues
discussed, and gives them training for moving them up the ladder (IETF
professional development - what a concept!).

Cheers,
Andy

---

From: Sean Turner <[email-masked]>
Date: Thu, 14 Jan 2010 11:35:40 -0500

How many WGs actually have secretaries?  I've not yet had a WG secretary 
for either WG I've co-chaired.  If there aren't many WGs with 
secretaries, then I think you should be leaning towards #4.

spt

Adrian Farrel wrote:
> Hi WG chairs,
> 
> I was wondering aloud about how to reach WG secretaries with 
> announcements such as "77th IETF - Working Group/BOF Scheduling". I got 
> responses that indicated several possible solutions...
>

---

From: Andrew Sullivan <[email-masked]>
Date: Thu, 14 Jan 2010 11:40:34 -0500

> professional development - what a concept!).

I didn't provide an argument why I don't like that idea, so here's
why.

This is a list for WG chairs.  If I want to reach other chairs, I know
how to do that.  If we make this a list for chairs and secretaries,
then there's actually no way to send a note only to chairs.  We might
then need to invent such a list, at which point we'd end up with
chairs@ and chairs-really-I-mean-it@, and that seems wrong.

As for the professional development argument, one could as easily
argue that everyone who subscribes to the IETF general list ought to
be moved along into greater participation, and that therefore we ought
to conduct all this business on the IETF list.  

A

-- 
Andrew Sullivan
[email-masked]
Shinkuro, Inc.

---

From: Sean Turner <[email-masked]>
Date: Thu, 14 Jan 2010 11:45:13 -0500

If I act as both WG chair and secretary, then I'd really rather not get 
duplicate emails (even though the delete key is easy to use).

spt

---

From: Jeffrey Hutzelman <[email-masked]>
Date: Thu, 14 Jan 2010 12:01:17 -0500

> to conduct all this business on the IETF list.

This list has a public archive, readable by anyone, so if you want to send 
something secret to chairs only, do it in private email.  Really, I can't 
imagine a discussion that is approprate for all WG chairs yet so secret 
that it's not appropriate for secretaries to know about it.

That said, it is my impression that it is fairly uncommon for working 
groups to have a separate secretary.  I think I've seen it happen all of 
once in all the WG's I've ever participated in or even just dropped in at a 
meeting.  So it seems like we're worrying over not very much.  Why not just 
assume that if a WG has a secretary, the chair(s) will make sure he/she 
gets any needed information that comes via this channel, as it has always 
been.

-- Jeff

---

From: Ross Callon <[email-masked]>
Date: Thu, 14 Jan 2010 12:01:02 -0500

Personally I think that we should add WG secretaries to this list. It is not as if this list is highly secretive. Having a second list for "chairs plus secretaries" also seems fine to me (assuming someone doesn't mind administering it). 

Ross

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Sean Turner
Sent: 14 January 2010 11:36
To: Adrian Farrel
Cc: [email-masked]
Subject: Re: How to reach WG secretaries

spt

---

From: "John G. Scudder" <[email-masked]>
Date: Thu, 14 Jan 2010 19:06:08 +0200

On Jan 14, 2010, at 7:01 PM, Jeffrey Hutzelman wrote:
> Why not just assume that if a WG has a secretary, the chair(s) will make sure he/she gets any needed information that comes via this channel, as it has always been.

Because if the chair was sufficiently organized to do that reliably then the secretary wouldn't be needed.

Agreed that not many groups have secretaries, but in the cases where they do as far as I'm concerned either option 1 or option 3 is fine.  Option 4 isn't optimal for the reason above.

--John

---

From: <[email-masked]>
Date: Thu, 14 Jan 2010 18:08:30 +0100

Currently, 18 WGs have secretaries (out of 120).

Best regards,
Pasi

> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> ext Sean Turner
> Sent: 14 January, 2010 18:36
> To: Adrian Farrel
> Cc: [email-masked]

---

From: Lars Eggert <[email-masked]>
Date: Thu, 14 Jan 2010 19:24:48 +0200

On 2010-1-14, at 18:35, Andrew G. Malis wrote:
> Add secretaries to the list.

+1

---

From: Loa Andersson <[email-masked]>
Date: Thu, 14 Jan 2010 18:31:40 +0100

All,

would tend to agree, and certainly won't havea problem
adding the mpls wg secretary.

However,are there a list charter somewhere. If the list
is for info and informative discussion it is all nice
and dandy, if the list has some kind of mandate we should
be careful.

/Loa

-- 

Loa Andersson                         email: [email-masked]
Sr Strategy and Standards Manager            [email-masked]
Ericsson Inc                          phone: +46 10 717 52 13
                                              +46 767 72 92 13

---

From: Richard Shockey <[email-masked]>
Date: Thu, 14 Jan 2010 12:38:15 -0500

[email-masked] wrote:

I would favor #1. I have always had Secretaries for all of my WG's. In 
general I think WG's should always  have Secretaries for any number of 
reasons including having a permanent designated scribe or jabber scribe 
for meetings.

 In addition it is a good way to increase the possible pool of 
management candidates for the IETF in general.  This is your classic HR 
101 issue that is applicable to any organization.

As any good manager would tell you make sure you have your replacements 
properly trained and in place, just in case. WG Secretary is IMHO the 
"entry level" position to IETF management. Collectively we (WG chairs 
and AD's) need to identify who that  next generation is going to be. 
Technical excellence or writing x number of RFC's is not necessarily the 
principal qualification you want in IETF management. "Cat herding" 
skills is far more important and the lack of those skills has caused 
untold grief in the past.

With that in mind adding Secretaries to the general WG Chair list 
exposes a larger group of people to the issues we have to generally 
confront. That is a "good thing" tm.

>>> announcements such as "77th IETF - Working Group/BOF Scheduling". I
>>>       
>> got
>>     
>>> 3. Have this list (WG chairs only) and a new list (chairs and
>>>       
>> secretaries)
>>

---

From: Marc Blanchet <[email-masked]>
Date: Thu, 14 Jan 2010 12:49:07 -0500

I agree with the Richard ideas (of increase pool of future candidates, 
visibility of discussions, ...), but don't agree with the conclusion. 
There are other ways to "include more" the secretaries. The "wgchairs" 
mailing list is for wg chairs: clear scope, clear participants, clear 
focus, has been useful as it is. Since we don't have that many 
secretaries, I'm not sure we need to do anything special about them. I 
don't see yet the real need and benefit of yet another mailing 
list/process/... for secretaries purpose.

Marc.

Richard Shockey a écrit :
> In addition it is a good way to increase the possible pool of management 
> candidates for the IETF in general.  This is your classic HR 101 issue 
> that is applicable to any organization.
>

---

From: Sean Turner <[email-masked]>
Date: Thu, 14 Jan 2010 12:55:38 -0500

Wow more than I thought.  In any event, I'd just add them to this list.

spt

---

From: Paul Hoffman <[email-masked]>
Date: Thu, 14 Jan 2010 09:56:28 -0800

At 11:03 AM +0000 1/14/10, Adrian Farrel wrote:
>Hi WG chairs,
>
>I was wondering aloud about how to reach WG secretaries with announcements such as "77th IETF - Working Group/BOF Scheduling". I got responses that indicated several possible solutions...
>

2 seems good. It would be nice for the few secretaries who exist to be able to talk about their jobs, their tools, and so on. Even if it is a small list, I think those folks would be better served to have their own forum.

--Paul Hoffman, Director
--VPN Consortium

---

From: Fred Baker <[email-masked]>
Date: Thu, 14 Jan 2010 10:51:29 -0800

not all working groups have secretaries. That said, for those that do,  
I think the charter should identify them, and they might be added to  
this list.

On Jan 14, 2010, at 3:03 AM, Adrian Farrel wrote:

> got responses that indicated several possible solutions...
>

http://www.ipinc.net/IPv4.GIF

---

From: Tom Taylor <[email-masked]>
Date: Thu, 14 Jan 2010 14:20:28 -0500

+1

---

From: Behcet Sarikaya <[email-masked]>
Date: Thu, 14 Jan 2010 11:34:07 -0800 (PST)

----- Original Message ----
> From: Adrian Farrel <[email-masked]>
> To: [email-masked]
> Sent: Thu, January 14, 2010 5:03:44 AM
> Subject: How to reach WG secretaries
> 
> Hi WG chairs,
> 
> I was wondering aloud about how to reach WG secretaries with announcements such 
> as "77th IETF - Working Group/BOF Scheduling". I got responses that indicated 
> several possible solutions...

At this age, who wants to be called secretary? Isn't that why we have Administrative Assistant?

> 4. Stop worrying and let the chairs forward stuff as necessary

My my suggestion is to not have any announcement special to secretaries. Just announce it to the chairs.

Regards,

Behcet

---

From: Jari Arkko <[email-masked]>
Date: Thu, 14 Jan 2010 21:54:40 +0200

Andrew G. Malis kirjoitti:
> discussed, and gives them training for moving them up the ladder 

+1

Jari

---

From: <[email-masked]>
Date: Thu, 14 Jan 2010 19:14:13 +0100

Hi.

I agree. #3 > #1 >> #2 >> #4 (I know Adrian can parse it!):
#4 seems to be inconsistent with the very reason why secretaries exist;
#2 would not be practical since it would often require to copy 2 lists,
knowing that the new one would sometimes be forgotten (back to #4?);
#3 is my favorite since it would leave the opportunity to see if the
actual use of a new chairs+secretaries list would be enough for every
case (i.e. enables a possible smooth move towards #1);
#1 would do the trick as well (with less processing) and I have nothing
against it.

Thanks for tackling this issue.

Julien

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Ross Callon

Personally I think that we should add WG secretaries to this list. It is
not as if this list is highly secretive. Having a second list for
"chairs plus secretaries" also seems fine to me (assuming someone
doesn't mind administering it). 

Ross

-----Original Message-----
Sean Turner

spt

got 
secretaries)
> 4. Stop worrying and let the chairs forward stuff as necessary

*********************************
This message and any attachments (the "message") are confidential and intended solely for the addressees. 
Any unauthorised use or dissemination is prohibited.
Messages are susceptible to alteration. 
France Telecom Group shall not be liable for the message if altered, changed or falsified.
If you are not the intended addressee of this message, please cancel it immediately and inform the sender.
********************************

---

From: "Scott Lawrence" <[email-masked]>
Date: Thu, 14 Jan 2010 15:29:57 -0500

> 1. Add the secretaries to this (WG chairs list)

+1 - Simple solutions are best.  

      * I don't recall seeing any traffic on this list that would have
        been inappropriate for any non-chairs, much less secretaries.

      * I like to follow the general rule that lists should not be
        subdivided until experience demonstrates that there is a usage
        conflict.

---

From: "Spencer Dawkins" <[email-masked]>
Date: Thu, 14 Jan 2010 14:46:08 -0600

Just trying to summarize a few points ...

Loa asked about the charter for this mailing list - it's at 
https://www.ietf.org/mailman/listinfo/wgchairs, and does say "working group 
chairs only". So if adding the secretaries is the right thing to do, it 
would be nice to mention that in the charter, just in case anyone ever reads 
it.

Someone said "wgchairs is clearly only working group chairs" - you would be 
surprised who's on the iesg mailing list. They aren't all ADs, and the 
people who aren't ADs are supposed to be helping the ADs (much like 
secretaries are supposed to be helping WG chairs. So that much is prior art.

The wgchair archives are public now.

I suppose there might be things for secretaries to talk about 
"semi-privately", but I'm not sure what that might be. Could the chairs with 
secretaries ask them what THEY would find useful? :D

I'd like to avoid two lists unless there's a demonstrated need. My 
experience is that we already forget to cc: bofchairs a fair percentage of 
the time.

Thanks,

Spencer

---

From: "Glen Zorn" <[email-masked]>
Date: Fri, 15 Jan 2010 08:56:11 +0700

Adrian Farrel [mailto://[email-masked]] writes:

> announcements

I'll take this one; I almost always find that I am happier when people stop
worrying, esp. about trivial crap like this (no offense ;-)...

---

From: Lars Eggert <[email-masked]>
Date: Fri, 15 Jan 2010 10:37:51 +0200

On 2010-1-14, at 22:46, Spencer Dawkins wrote:
> I'd like to avoid two lists unless there's a demonstrated need.

Yes, exactly.

> My experience is that we already forget to cc: bofchairs a fair percentage of 
> the time.

Well, we *could* ask the secretariat to subscribe the BOF chairs to the wgchairs list when they are selected, and unsubscribe them after the meeting...

Lars

---

From: "Spencer Dawkins" <[email-masked]>
Date: Fri, 15 Jan 2010 07:05:52 -0600

Lars,

OK, to be fair, my experience wasn't recent, but when I did a BOF (as a 
current WG chair) with a co-chair who wasn't already a current WG chair, we 
had several conversations that included the words "what did you think about 
that e-mail to all chairs?"/"what e-mail?".

That was a couple of secretariat changes ago, and our current secretariat 
seems pretty capable on administrative stuff, so your plan sounds better 
than what I remember.

Just as another data point, I got private followup mail from current WG 
chairs saying "what bofchairs list?", so at least some of the bofchairs 
might have been better served if we had been adding and deleting bofchairs 
on this list :D

Thanks,

Spencer

----- Original Message ----- 
From: "Lars Eggert" <[email-masked]>
To: "Spencer Dawkins" <[email-masked]>
Cc: "Scott Lawrence" <[email-masked]>; "Adrian Farrel" 
<[email-masked]>; <[email-masked]>
Sent: Friday, January 15, 2010 2:37 AM
Subject: Re: How to reach WG secretaries

Yes, exactly.

> My experience is that we already forget to cc: bofchairs a fair percentage 

Well, we *could* ask the secretariat to subscribe the BOF chairs to the 
wgchairs list when they are selected, and unsubscribe them after the 
meeting...

Lars

---

From: Lars Eggert <[email-masked]>
Date: Fri, 15 Jan 2010 15:15:15 +0200

Hi,

> that e-mail to all chairs?"/"what e-mail?".

oh, I fully understand why you'd want this!

> seems pretty capable on administrative stuff, so your plan sounds better 

Exactly. And it isn't any extra work, since they're already adding and removing the BOF chairs from the bofchairs@ list all the time - it'd just be wgchairs@ if we make the change.

Lars

---

From: Lou Berger <[email-masked]>
Date: Fri, 15 Jan 2010 09:39:12 -0500

+1.

Option 4 is fine with me too.  2&3 have too many negatives as has been 
covered in other mail...

---

From: "Spencer Dawkins" <[email-masked]>
Date: Fri, 15 Jan 2010 10:21:08 -0600

Hi, John,

I share your interest in transparency for discussions on policy and 
strategy, but I understood your note to also be saying that the archives for 
this mailing list are private - they are not.

Not only do Yahoo and Google both know about the archives of this mailing 
list (suggest "ietf wgchairs secretaries" as your test case - this thread 
pops up), but if you type "ietf wgchairs" into Google and click on "I'm 
feeling lucky", the response you get is 
https://www.ietf.org/mailman/listinfo/wgchairs, one click away from the open 
archives :-)

So there may be some security through obscurity going on, but nothing more 
than that.

Thanks,

Spencer

> +1
>
> I'd encourage people to think more generally about this list and
> the situation it creates.  I believe it needs to be _really_
> easy to get someone onto it and that the mechanism for doing
> that has to be widely known.  To add to Spencer's example, I've
> been asked on several occasions to lead a BOF or to fill in for
> a WG Chair who could not attend a particular meeting, only to
> discover that important information was transmitted via this
> list that I didn't have.  That suggests strongly to me that WG
> Secretaries, temporary/acting WG Chairs or co-chairs, BOF chairs
> (and many non-chair BOF-organizing leadership), etc., need to be
> on the list.    I'm happy to leave the question of which
> BOF-related personnel should be on the list to the discretion of
> the relevant AD, but encourage erring on the side of inclusion.
>
>
> The IAB members see  the contents of the list today, as I assume
> everyone knows.  Via the IAB list, the leadership of the IRTF,
> IANA, ISOC, and RFC Editor see it too, although we may want to
> be sure that the right people are getting the information as the
> environment evolves.
>
> One other observation: this list and the way it is structured
> are pragmatically useful as long as its purpose is to
> communicate IETF operational information to WG Chairs and others
> with equivalent need to know.  When it becomes a forum for
> discussing policy or strategy, it pretty clearly violates the
> intent of RFC 2026 and the associated documents: The WG Chairs
> group functions as an organization within the IETF process and
> even holds meetings, but the mailing list is secret (no public
> archives, no listing as a non-WG list, etc.), there is no
> transparency into its discussions, etc.  Preventing anyone but a
> WG Chair or AD from posting without permission is reasonable, an
> archive that was delayed by some days would be reasonable, but
> this level of effective secrecy is really pushing the boundaries
> of the rules and we should, IMO, be careful about what is
> discussed here that the community might reasonably believe it
> needs visibility into.
>
> Remember that the community has explicitly given the IAB and
> IESG permission to hold private discussions.  But that
> permission does not extend by default to other groups and their
> mailing lists, especially a group and mailing list the community
> doesn't even know about.
>
> best,
>   john
>
>
> --On Friday, January 15, 2010 15:15 +0200 Lars Eggert
> <[email-masked]> wrote:
>
>> Hi,
>>
>>> OK, to be fair, my experience wasn't recent, but when I did a
>>> BOF (as a  current WG chair) with a co-chair who wasn't
>>> already a current WG chair, we  had several conversations
>>> that included the words "what did you think about  that
>>> e-mail to all chairs?"/"what e-mail?".
>>
>>> That was a couple of secretariat changes ago, and our current
>>> secretariat  seems pretty capable on administrative stuff, so
>>> your plan sounds better  than what I remember.
>>
>> Exactly. And it isn't any extra work, since they're already
>> adding and removing the BOF chairs from the bofchairs@ list
>> all the time - it'd just be wgchairs@ if we make the change.
>>
>> Lars
>
>
>
>

---

From: John C Klensin <[email-masked]>
Date: Fri, 15 Jan 2010 10:49:07 -0500

+1

best, 
   john

---

From: Paul Hoffman <[email-masked]>
Date: Fri, 15 Jan 2010 08:43:35 -0800

It's seeming like most people want secretaries on this list, which seems fine. Some also want BoF chairs, which also seems fine. I propose that the name of the list be changed to "wg-leadership" to reflect that, and that the mailing list info be updated accordingly.

--Paul Hoffman, Director
--VPN Consortium

---

From: "Spencer Dawkins" <[email-masked]>
Date: Fri, 15 Jan 2010 10:50:57 -0600

That would work for me...

Spencer

----- Original Message ----- 
From: "Paul Hoffman" <[email-masked]>
To: "Adrian Farrel" <[email-masked]>; <[email-masked]>
Sent: Friday, January 15, 2010 10:43 AM
Subject: Re: How to reach WG secretaries

> It's seeming like most people want secretaries on this list, which seems 
> fine. Some also want BoF chairs, which also seems fine. I propose that the 
> name of the list be changed to "wg-leadership" to reflect that, and that 
> the mailing list info be updated accordingly.
>
> --Paul Hoffman, Director
> --VPN Consortium

---

From: Adrian Farrel <[email-masked]>
Date: Fri, 15 Jan 2010 16:51:53 +0000

Hi Paul,

I have *no*idea* how this sort of thing is supposed to happen, but I have 
put it on the agenda for the next IESG telechat (Thursday) on the assumption 
that if anyone can ask the Secretariat to make the change, the IESG can!

I guess that means that everyone should make their comments before that 
date.

To me it looks like the current consensus (with some mild dissent) is what 
you say (although the idea of changing the list name is a new comment).

Cheers,
Adrian

---

From: "Andrew G. Malis" <[email-masked]>
Date: Fri, 15 Jan 2010 12:00:15 -0500

+1

---

From: Andrew Sullivan <[email-masked]>
Date: Fri, 15 Jan 2010 13:09:29 -0500

On Fri, Jan 15, 2010 at 08:43:35AM -0800, Paul Hoffman wrote:
> propose that the name of the list be changed to "wg-leadership" to

I think that's a capital idea.

A

-- 
Andrew Sullivan
[email-masked]
Shinkuro, Inc.

---

From: Lou Berger <[email-masked]>
Date: Fri, 15 Jan 2010 14:27:51 -0500

As the Archives to the list are open, is there any reason not to also 
allow subscriptions to be open, i.e., anyone can subscribe?  (And yes, 
this only makes sense given a list name change?)

Lou

---

From: Paul Hoffman <[email-masked]>
Date: Fri, 15 Jan 2010 11:42:03 -0800

At 2:27 PM -0500 1/15/10, Lou Berger wrote:
>As the Archives to the list are open, is there any reason not to also allow subscriptions to be open, i.e., anyone can subscribe?  (And yes, this only makes sense given a list name change?)

Yes, there is plenty of reason. With open subscriptions, the first "here is an example of how a WG chair can screw over a WG participant" letter from said participant would arrive within the first few months, followed by others. A slightly more subtle version would be "do people here think that the following scenario is good one", again sent by an aggrieved participant.

Let's not make this list useless. Having additional folks from the WG leadership here is fine; having everyone in the IETF able to post would lower the value of the discussion significantly.

--Paul Hoffman, Director
--VPN Consortium

---

From: "James M. Polk" <[email-masked]>
Date: Fri, 15 Jan 2010 14:23:40 -0600

At 01:42 PM 1/15/2010, Paul Hoffman wrote:
> >As the Archives to the list are open, is there any reason not to 
> also allow subscriptions to be open, i.e., anyone can 
> subscribe?  (And yes, this only makes sense given a list name change?)
>
>Yes, there is plenty of reason. With open subscriptions, the first 
>"here is an example of how a WG chair can screw over a WG 
>participant" letter from said participant would arrive within the 
>first few months, followed by others. A slightly more subtle version 
>would be "do people here think that the following scenario is good 
>one", again sent by an aggrieved participant.
>
>Let's not make this list useless.

+1

I also don't see the need to change the list name, as we will all 
know that *wg-chairs* (as it is now) really means *all chairs* (i.e., 
wg or bof)... the distinction is unnecessary IMO.

>Having additional folks from the WG leadership here is fine; having 
>everyone in the IETF able to post would lower the value of the 
>discussion significantly.
>
>--Paul Hoffman, Director
>--VPN Consortium

---

From: Paul Hoffman <[email-masked]>
Date: Fri, 15 Jan 2010 12:55:42 -0800

At 2:23 PM -0600 1/15/10, James M. Polk wrote:
>I also don't see the need to change the list name, as we will all know that *wg-chairs* (as it is now) really means *all chairs* (i.e., wg or bof)... the distinction is unnecessary IMO.

The initial proposal was to add WG secretaries, not just BoF chairs. When Spencer and I ran the "WG leadership" Sunday tutorials a few years ago, we had a very good response from WG secretaries who attended, saying they learned things they wished their chairs knew. Making it clear that the secretaries are part of the leadership could be a Good Thing.

--Paul Hoffman, Director
--VPN Consortium

---

From: "James M. Polk" <[email-masked]>
Date: Fri, 15 Jan 2010 15:40:48 -0600

At 02:55 PM 1/15/2010, Paul Hoffman wrote:
> know that *wg-chairs* (as it is now) really means *all chairs* 
> (i.e., wg or bof)... the distinction is unnecessary IMO.
>
>The initial proposal was to add WG secretaries, not just BoF chairs.

of course, and I was too focused on the name change aspect, and not 
on the original purpose of the note... apologies.

>When Spencer and I ran the "WG leadership" Sunday tutorials a few 
>years ago, we had a very good response from WG secretaries who 
>attended, saying they learned things they wished their chairs knew. 
>Making it clear that the secretaries are part of the leadership 
>could be a Good Thing.

good point

Having more know more of the process and rules within a WG leadership 
is better than fewer knowing.  I've been talked into adding both 
bof-chairs and secretaries into the wg-chairs list, and changing the 
list name to wg-leadership.  I am also not a fan of letting anyone 
subscribe to this list, as Paul notes.

James

---

From: Lou Berger <[email-masked]>
Date: Fri, 15 Jan 2010 17:57:23 -0500

So your issue is with who can post, not who can read? (This is 
reasonable given that the list is already publicly archived.) So another 
option would be to allow anyone to subscribe, which helps with 
transparency and notification of interested readers w/o extra action 
(i.e., reading the archive), but restrict who can post.

This would solve your issue, increase transparency, and address Adrian's 
point without the previously raised multiple list issues.  This also 
means the list name can stay the same...

Lou

---

From: John C Klensin <[email-masked]>
Date: Fri, 15 Jan 2010 12:14:22 -0500

Spencer,

This is good to know.  However, if the list is public to those
who know where to look, I suggest that recent precedents and
discussions indicate that it should be listed on the non-WG
mailing lists list.   The searches you suggest imply that
someone needs to know the list exists and to be able to guess
what it is called -- transparency suggestions that we should be
avoiding obscurity as well as real secrecy.

I assume the IESG can tell the Secretariat to add the list to
the non-WG mailing lists page too.

    john

--On Friday, January 15, 2010 10:21 -0600 Spencer Dawkins
<[email-masked]> wrote:

> Hi, John,
> 
> I share your interest in transparency for discussions on
> policy and strategy, but I understood your note to also be
> saying that the archives for this mailing list are private -
> they are not.
> 
> Not only do Yahoo and Google both know about the archives of
> this mailing list (suggest "ietf wgchairs secretaries" as your
> test case - this thread pops up), but if you type "ietf
> wgchairs" into Google and click on "I'm feeling lucky", the
> response you get is
> https://www.ietf.org/mailman/listinfo/wgchairs, one click away
> from the open archives :-)
> 
> So there may be some security through obscurity going on, but
> nothing more than that.

---

From: John C Klensin <[email-masked]>
Date: Fri, 15 Jan 2010 18:34:30 -0500

--On Friday, January 15, 2010 11:42 -0800 Paul Hoffman
<[email-masked]> wrote:

>> As the Archives to the list are open, is there any reason not
>> to also allow subscriptions to be open, i.e., anyone can
> Yes, there is plenty of reason. With open subscriptions, the
> first "here is an example of how a WG chair can screw over a
> WG participant" letter from said participant would arrive
> within the first few months, followed by others. A slightly
> more subtle version would be "do people here think that the
> following scenario is good one", again sent by an aggrieved
> participant.
> 
> Let's not make this list useless. Having additional folks from
> the WG leadership here is fine; having everyone in the IETF
> able to post would lower the value of the discussion
> significantly.

Yes.  While I'm not sure there is a reason to do anything to
make the list's contents private, opening up posting to any
random irritated participant or troll in the community would be
a really stupid mistake... one might as well give up on the list
and just use the IETF discussion one.

   john

---

From: Paul Hoffman <[email-masked]>
Date: Fri, 15 Jan 2010 15:28:37 -0800

At 5:57 PM -0500 1/15/10, Lou Berger wrote:
>So your issue is with who can post, not who can read? (This is reasonable given that the list is already publicly archived.)

Exactly.

>So another option would be to allow anyone to subscribe, which helps with transparency and notification of interested readers w/o extra action (i.e., reading the archive), but restrict who can post.

That causes an admin headache for someone, and I bet it isn't for you or I.

>This would solve your issue, increase transparency,

This doesn't not add much transparency beyond "read the archives".

>and address Adrian's point without the previously raised multiple list issues.  This also means the list name can stay the same...

If we are inviting the WG secretaries and BoF chairs, we really should make the list name seem like they are full-class members.

--Paul Hoffman, Director
--VPN Consortium

---

From: Lou Berger <[email-masked]>
Date: Sun, 17 Jan 2010 12:18:07 -0500

> That causes an admin headache for someone, and I bet it isn't for you or I.

this can be done with fairly low overhead, either in mailman or as a 
sub-list.  So I don't think this should be a deciding factor.  That 
said, it seems like the simplest options are certain Adrian's #1 or #4.

> This doesn't not add much transparency beyond "read the archives".

Yes, but it allows secretaries and others who need or want to know 
what's being posted to see the information in a timely / low-overhead 
fashion.

Humm, rss works for this too. Are there rss feeds of ietf.org hosted 
mail lists already?

Lou