Subject: Latest IPR setting in XML2RFC

From: Tom Taylor <[email-masked]>
Date: Tue, 12 Jan 2010 13:35:02 -0500

Is ipr="trust200811" still the right setting for producing I-Ds? Where does one 
find out the permitted values?

Tom Taylor

---

From: "John G. Scudder" <[email-masked]>
Date: Tue, 12 Jan 2010 20:49:26 +0200

On Jan 12, 2010, at 8:35 PM, Tom Taylor wrote:
> Is ipr="trust200811" still the right setting for producing I-Ds? Where does one find out the permitted values?

idnits will whine at you if you use trust200811.  I generally grab the latest xml2rfc distro and look in rfc2629.dtd, where you will find:

          ipr         (full2026|noDerivativeWorks2026|none
                      |full3667|noModification3667|noDerivatives3667
                      |full3978|noModification3978|noDerivatives3978
                      |trust200811|noModificationTrust200811|noDerivativesTrust200811
                      |trust200902|noModificationTrust200902|noDerivativesTrust200902
                      |pre5378Trust200902)

There ought to be an even more transparent way but in this as so many other things, AFAICT the code is the documentation. :-(

--John

---

From: Behcet Sarikaya <[email-masked]>
Date: Tue, 12 Jan 2010 12:00:32 -0800 (PST)

----- Original Message ----
> From: John G. Scudder <[email-masked]>
> To: Tom Taylor <[email-masked]>
> Cc: Working Group Chairs <[email-masked]>
> Sent: Tue, January 12, 2010 12:49:26 PM
> Subject: Re: Latest IPR setting in XML2RFC
> 
> idnits will whine at you if you use trust200811.  I generally grab the latest 
> xml2rfc distro and look in rfc2629.dtd, where you will find:
> 

I used both trust200811 and trust200902 and had idnits to check it, I saw no difference in the results.

Is there anything else I should try?

Regards,

Behcet

---

From: Fred Baker <[email-masked]>
Date: Tue, 12 Jan 2010 15:44:16 -0800

Adding the xml2rfc mailer. What result are you seeing?

On Jan 12, 2010, at 12:00 PM, Behcet Sarikaya wrote:

>>> Is ipr="trust200811" still the right setting for producing I-Ds?  
>>> Where does
>> one find out the permitted values?
>>

http://www.ipinc.net/IPv4.GIF

---

From: Behcet Sarikaya <[email-masked]>
Date: Tue, 12 Jan 2010 16:03:11 -0800 (PST)

Basically idnits tool did not whine. I used the experimental.html page to compile.

Regards,

Behcet

----- Original Message ----
> From: Fred Baker <[email-masked]>
> To: Behcet Sarikaya <[email-masked]>; XML2RFC mailing list <[email-masked]>
> Cc: John G. Scudder <[email-masked]>; Tom Taylor <[email-masked]>; Working Group Chairs <[email-masked]>
> Sent: Tue, January 12, 2010 5:44:16 PM
> >> From: John G. Scudder 
> >> To: Tom Taylor 
> >> Cc: Working Group Chairs

---

From: Behcet Sarikaya <[email-masked]>
Date: Wed, 13 Jan 2010 07:52:58 -0800 (PST)

In short, trust200811 is now historic (although still accepted) and we should use 

trust200902.

Regards,

Behcet

----- Original Message ----
> From: Julian Reschke <[email-masked]>
> To: Fred Baker <[email-masked]>
> Cc: Behcet Sarikaya <[email-masked]>; XML2RFC mailing list <[email-masked]>; Tom Taylor <[email-masked]>; Working Group Chairs <[email-masked]>; John G. Scudder <[email-masked]>
> Sent: Wed, January 13, 2010 2:08:10 AM
> Subject: Re: [xml2rfc] Latest IPR setting in XML2RFC
> 
> This:
> 
> 
> 
> 
> should help.
> 
> Best regards, Julian
> 
> 
> Fred Baker wrote:
> > _______________________________________________
> > xml2rfc mailing list
> > [email-masked]
> > http://lists.xml.resource.org/mailman/listinfo/xml2rfc
> >