Subject: Re: XML2RFC updated to latest Trust provisions

From: =JeffH <[email-masked]>
Date: Mon, 05 Apr 2010 16:01:56 -0700

> The XML2RFC maintenance team has updated the tool so that the output contains
 > the latest boilerplate and passes idNits. Thanks to Julian Reshke and Tony
 > Hansen, with help from Henrik.
 >
 > I am currently working on updating the templates at
 > http://tools.ietf.org/tools/templates/ to reflect the latest ipr values.

that's super, thanks!

=JeffH

---

From: joel jaeggli <[email-masked]>
Date: Mon, 05 Apr 2010 20:17:58 -0400

So, if you want to make sure that xml2rfc gets better than best effort service, you should communicate with the iaoc and the iad, that some of the tools budget is expended accordingly.

I personally am shocked that the tool has keep up with with the document changes required since the process that produces the changes doesn't bear the cost (in human capital) associated with the reuirements they generate for the tool.

Peace
Joel

Tom Taylor <[email-masked]> wrote:

>XML2RFC was a volunteer development several years ago, and not part of the 
>"official" IETF tool set. The original authors have wearied of the task. A new 
>set of volunteers has moved in this year, set up a formal development 
>environment (svn) on the the IETF tools web site, and will probably be good for 
>a couple of years, anyway. We intend to keep tight version control, and the 
>people doing the work will set the priorities.
>
>There is an XML2RFC discussion list (list info at 
>http://lists.xml.resource.org/mailman/listinfo/xml2rfc, 
>mailto:[email-masked] to subscribe). I'm new to it 
>myself, and haven't gotten around to looking at the archives to see what people 
>said in the past.
>
>Blake Ramsdell wrote:
>> On Sun, Apr 4, 2010 at 5:54 PM, Tom Taylor <[email-masked]> wrote:
>>> The XML2RFC maintenance team has updated the tool so that the output
>>> contains the latest boilerplate and passes idNits. Thanks to Julian Reshke
>>> and Tony Hansen, with help from Henrik.
>> 
>> I'm not sure what's the right forum for this, and my apologies if this
>> has been covered. Public / private beatings welcome.
>> 
>> I have a WG member who relies on this tool for his drafts unable to
>> submit new versions until the tool was updated (submissions were
>> rejected due to old IPR statement).
>> 
>> Is there a plan to ensure that this doesn't happen again? And I'm not
>> trying to harp on the people maintaining the tool -- Tom, Julian,
>> Tony, I'm glad you put in the effort and were able to get the tool up
>> to date.
>> 
>> But it's not clear to me why we ended up in this state to begin with
>> -- shouldn't we keep the submission process compatible with the
>> current version of xml2rfc?
>> 
>> Blake
>> 
>> 
>