Subject: Re: 78th IETF DRAFT Agenda (fedauth - hasmat conflict?)

From: =JeffH <[email-masked]>
Date: Fri, 25 Jun 2010 16:35:49 -0700

Alexey Melnikov <[email-masked]> suggested many things in several 
msgs.  Here I'll try to coalesce what the agenda looks like with them applied 
(I'm only doing the below for the sessions I'm concerned about (sorry))...
 >
 > Swapping ALTO and HASMAT is Ok with me, as long as people are happy to live
 > with the possible PKIX or KITTEN conflict, as you say.

 > I can recommend swapping fedauth (9:00 on Monday) with krb-wg (17:40 on
 > Monday). Fedauth requested 2 hours (currently in 2.5 hours slot) and
 > krb-wg requested 1.5 hours (currently in 2 hour slot).
 > What Security ADs think abot that?

 > Ok, let's leave ALTO and HASMAT where they are.

 >  (I.e. HYBI
 > moves to EAI slot, EAI moves to Sieve slot, Sieve moves to HYBI slot.)

Am I right that the above changes yield the below partial schedule (for 
web-ish/http-ish sessions)?

I'm ok with it except for the unfortunate hasmat-fedauth conflict.

Is there any way to fix the latter?

I can propose moving hasmat from Mon Afternoon Session III, to replace 
httpstate in Tue Afternoon Session I, then move httpstate to Wed Afternoon 
Session I (90 min session, which is fine), but am unsure who might be 
willing/able to swap from Wed Aftn sess I, to Mon Aftn Sess III....

thanks,

=JeffH

MONDAY, July 26, 2010
0900-1130  Morning Session I
	APP 	apparea     	Applications Area Open Meeting

1300-1500  Afternoon Session I
	APP 	alto        	Application-Layer Traffic Optimization WG

1520-1720  Afternoon Session II
	APP 	httpbis     	Hypertext Transfer Protocol Bis WG

1740-1940  Afternoon Session III                                    <--- *!!!*
	SEC 	fedauth     	Federated Authentication Beyond the Web BOF
	APP 	hasmat      	HTTP App Security Minus Authn & Transp BOF

TUESDAY, July 27, 2010
0900-1130  Morning Session I
	APP 	hybi        	BiDirectional or Server-Initiated HTTP WG

1300-1500  Afternoon Session I
	APP 	httpstate   	HTTP State Management Mechanism WG

1520-1700  Afternoon Session II
	APP 	oauth       	Open Authentication Protocol WG

1710-1810  Afternoon Session III
	APP 	oauth       	Open Authentication Protocol WG

WEDNESDAY, July 28, 2010
0900-1015  Morning Session I
	APP 	core        	Constrained RESTful Environments WG

1030-1130  Morning Session II
	APP 	core        	Constrained RESTful Environments WG

1300-1530  Afternoon Session I
	? httpstate ?
         who swap from here to Mon Afternoon Session III ?

THURSDAY, July 29, 2010
1300-1500  Afternoon Session I
	APP 	eai         	Email Address Internationalization WG

FRIDAY, July 30, 2010
1300-1400  Afternoon Session I
	APP 	sieve       	Sieve Mail Filtering Language WG

1415-1515  Afternoon Session II
	APP 	sieve       	Sieve Mail Filtering Language WG

---
end

---

From: Sean Turner <[email-masked]>
Date: Mon, 28 Jun 2010 09:40:00 -0400

=JeffH wrote:
> Alexey Melnikov <[email-masked]> suggested many things in 
> several msgs.  Here I'll try to coalesce what the agenda looks like with 
> them applied (I'm only doing the below for the sessions I'm concerned 
> about (sorry))...
>  >

What I've proposed and it looks like all the chairs accepted is a swap 
for FEDUATH (Mon 9am) and IPsecME (Tuesday 9am).

spt

> httpstate in Tue Afternoon Session I, then move httpstate to Wed 
> Afternoon Session I (90 min session, which is fine), but am unsure who 
> might be willing/able to swap from Wed Aftn sess I, to Mon Aftn Sess 
> III....
> 
> thanks,
> 
> =JeffH
> 
> 
> MONDAY, July 26, 2010

---

From: Alexey Melnikov <[email-masked]>
Date: Mon, 28 Jun 2010 18:56:59 +0100

Sean Turner wrote:

>> several msgs.  Here I'll try to coalesce what the agenda looks like 
>> with them applied (I'm only doing the below for the sessions I'm 
>> concerned about (sorry))...
>>  >
>> Am I right that the above changes yield the below partial schedule 
>> (for web-ish/http-ish sessions)?
>>

Jeff,
As FEDAUTH and HYBI is also a conflict, HYBI will not be moving to the 
Tuesday morning slot.

---

From: Barry Leiba <[email-masked]>
Date: Mon, 28 Jun 2010 17:04:02 -0400

> As FEDAUTH and HYBI is also a conflict, HYBI will not be moving to the
...
> Assuming there is no [much] negative feedback, let's do that. (I.e. HYBI
> moves to EAI slot, EAI moves to Sieve slot, Sieve moves to HYBI slot.) There
> are other advantages of keeping PRECIS and EAI on the same day.

With all this moving and messing, I'm still not clear on whether we've
resolved the ftpext2 / hasmat conflict or not.  I think resolving that
is more important than moving hybi off of Friday.

Barry

---

From: Alexey Melnikov <[email-masked]>
Date: Mon, 28 Jun 2010 22:09:05 +0100

Barry Leiba wrote:

>resolved the ftpext2 / hasmat conflict or not.
>
No, I don't see a way to resolve this. But maybe I missed an alternative.

>I think resolving that is more important than moving hybi off of Friday.
>  
>

---

From: Peter Saint-Andre <[email-masked]>
Date: Mon, 28 Jun 2010 15:39:09 -0600

> No, I don't see a way to resolve this. But maybe I missed an alternative.

Alexey and I just chatted about this at length. The best we could was to
swap hasmat and httpstate. Objections?

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: Barry Leiba <[email-masked]>
Date: Mon, 28 Jun 2010 17:50:36 -0400

> swap hasmat and httpstate. Objections?

That goes from this:

hasmat + ftpext2

httpstate + decade

to this:

httpstate + ftpext2

hasmat + decade

That's probably a bit of an improvement, and I think I prefer the
change.  But does it create a worse conflict for anyone else?  I'd
still rather see one of the BOFs move in with alto, but we're out of
rooms in that slot unless we can move something from another area.

Ron, Dan... is it possible for either v6ops or netconf to move into
the same slot as opsec?  Or do both of those have conflicts with
opsec?  If we could swap one of the apps BOFs (ftpext2 or hasmat) with
either v6ops or netconf, life would be grand.

Barry

---

From: Peter Saint-Andre <[email-masked]>
Date: Mon, 28 Jun 2010 15:54:49 -0600

>> swap hasmat and httpstate. Objections?

Correct.

> rooms in that slot unless we can move something from another area.

That's the best we could find within apps. I prefer not to pester folks
in other areas if we don't need to.

Also I really should be in alto (since I blew it off last time because
of residual WG-chairing commitments) so I'd prefer not to have hasmat
and alto conflict.

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: Alexey Melnikov <[email-masked]>
Date: Mon, 28 Jun 2010 22:56:03 +0100

Barry Leiba wrote:

>change.  But does it create a worse conflict for anyone else?
>
Yes, it does. We can't move alto into hasmat/ftpext slot, this would 
create alto/p2psip conflict for alto people.

>I'd still rather see one of the BOFs move in with alto, but we're out of