Subject: latest missing replaced-by information

From: Eggert Lars (Nokia-NRC/Espoo) <[email-masked]>
Date: Tue, 24 Aug 2010 11:33:41 +0300

Hi,

here's my current report of potentially missing "replaced-by" relationships in the IETF datatracker. WG chairs are encouraged to check whether these are accurate for their WGs, and if so, send a ticket to the secretariat instructing them to "record in the database that draft X replaced draft Y".

As always, double-check before reporting to the secretariat. Also, see list of possible inconsistencies at the end of the report.

(Note that the IPR disclosure search tool uses these replaced-by relationships, so keeping them up-to-date is actually useful and not just WG hygiene.)

Lars

PS: This report is generated by a new version of the tool that uses all_id2.txt rather than screen-scraping the datatracker. In other words, check the output even more carefully than normally.

-----------------------------------------------------------------
APP Area
-----------------------------------------------------------------
CORE Working Group, APP Area
   draft-shelby-core-coap POTENTIALLY REPLACED BY draft-ietf-core-coap

DECADE Working Group, APP Area
   draft-song-decade-problem-statement POTENTIALLY REPLACED BY draft-ietf-decade-problem-statement

EAI Working Group, APP Area
   draft-yao-eai-rfc5336bis POTENTIALLY REPLACED BY draft-ietf-eai-rfc5336bis

SIEVE Working Group, APP Area
   draft-george-sieve-autoreply POTENTIALLY REPLACED BY draft-ietf-sieve-autoreply
   draft-george-sieve-notify-presence POTENTIALLY REPLACED BY draft-ietf-sieve-notify-presence

-----------------------------------------------------------------
INT Area
-----------------------------------------------------------------
6MAN Working Group, INT Area
   draft-hui-6man-rpl-option POTENTIALLY REPLACED BY draft-ietf-6man-rpl-option
   draft-hui-6man-rpl-routing-header POTENTIALLY REPLACED BY draft-ietf-6man-rpl-routing-header
   draft-joshi-6man-neighbor-inform POTENTIALLY REPLACED BY draft-ietf-6man-neighbor-inform

AUTOCONF Working Group, INT Area
   draft-baccelli-autoconf-adhoc-addr-model POTENTIALLY REPLACED BY draft-ietf-autoconf-adhoc-addr-model

CSI Working Group, INT Area
   draft-jiang-csi-dhcpv6-cga-ps POTENTIALLY REPLACED BY draft-ietf-csi-dhcpv6-cga-ps
   draft-rgaglian-csi-send-name-type-registry POTENTIALLY REPLACED BY draft-ietf-csi-send-name-type-registry

DHC Working Group, INT Area
   draft-jiang-dhc-secure-dhcpv6 POTENTIALLY REPLACED BY draft-ietf-dhc-secure-dhcpv6

DNSEXT Working Group, INT Area
   draft-dolmatov-dnsext-dnssec-gost POTENTIALLY REPLACED BY draft-ietf-dnsext-dnssec-gost
   draft-wang-dnsext-newzone-notify POTENTIALLY REPLACED BY draft-ietf-dnsext-newzone-notify

HIP Working Group, INT Area
   draft-camarillo-hip-via POTENTIALLY REPLACED BY draft-ietf-hip-via
   draft-henderson-hip-rfc5206-bis POTENTIALLY REPLACED BY draft-ietf-hip-rfc5206-bis
   draft-keranen-hip-over-hip POTENTIALLY REPLACED BY draft-ietf-hip-over-hip
   draft-keranen-hip-reload-instance POTENTIALLY REPLACED BY draft-ietf-hip-reload-instance
   draft-moskowitz-hip-rfc4423-bis POTENTIALLY REPLACED BY draft-ietf-hip-rfc4423-bis
   draft-moskowitz-hip-rfc5201-bis POTENTIALLY REPLACED BY draft-ietf-hip-rfc5201-bis
   draft-nikander-hip-hiccups POTENTIALLY REPLACED BY draft-ietf-hip-hiccups

LISP Working Group, INT Area
   draft-farinacci-lisp-lig POTENTIALLY REPLACED BY draft-ietf-lisp-lig

MIP4 Working Group, INT Area
   draft-gundavelli-mip4-multiple-tunnel-support POTENTIALLY REPLACED BY draft-ietf-mip4-multiple-tunnel-support

MIPSHOP Working Group, INT Area
   draft-xia-mipshop-fmip-ptp POTENTIALLY REPLACED BY draft-ietf-mipshop-fmip-ptp

NETEXT Working Group, INT Area
   draft-korhonen-netext-redirect POTENTIALLY REPLACED BY draft-ietf-netext-redirect

NETLMM Working Group, INT Area
   draft-cui-netlmm-mip-interactions POTENTIALLY REPLACED BY draft-ietf-netlmm-mip-interactions
   draft-glenn-netlmm-pmipv6-mib POTENTIALLY REPLACED BY draft-ietf-netlmm-pmipv6-mib

SOFTWIRE Working Group, INT Area
   draft-gundavelli-softwire-gateway-init-ds-lite POTENTIALLY REPLACED BY draft-ietf-softwire-gateway-init-ds-lite

TRILL Working Group, INT Area
   draft-zebrose-trill-rbridge-mib POTENTIALLY REPLACED BY draft-ietf-trill-rbridge-mib

-----------------------------------------------------------------
OPS Area
-----------------------------------------------------------------
BMWG Working Group, OPS Area
   draft-asati-bmwg-reset POTENTIALLY REPLACED BY draft-ietf-bmwg-reset

DIME Working Group, OPS Area
   draft-zorn-dime-rfc4005bis POTENTIALLY REPLACED BY draft-ietf-dime-rfc4005bis

DNSOP Working Group, OPS Area
   draft-morris-dnsop-dnssec-key-timing POTENTIALLY REPLACED BY draft-ietf-dnsop-dnssec-key-timing

IPFIX Working Group, OPS Area
   draft-boschi-ipfix-anon POTENTIALLY REPLACED BY draft-ietf-ipfix-anon
   draft-gupta-ipfix-reliability-template-ext POTENTIALLY REPLACED BY draft-ietf-ipfix-reliability-template-ext

OPSAWG Working Group, OPS Area
   draft-mizrahi-opsawg-oam-overview POTENTIALLY REPLACED BY draft-ietf-opsawg-oam-overview

RADEXT Working Group, OPS Area
   draft-lourdelet-radext-ipv6-access POTENTIALLY REPLACED BY draft-ietf-radext-ipv6-access

V6OPS Working Group, OPS Area
   draft-jiang-v6ops-incremental-cgn POTENTIALLY REPLACED BY draft-ietf-v6ops-incremental-cgn

-----------------------------------------------------------------
RAI Area
-----------------------------------------------------------------
BLISS Working Group, RAI Area
   draft-procter-bliss-call-park-extension POTENTIALLY REPLACED BY draft-ietf-bliss-call-park-extension

CODEC Working Group, RAI Area
   draft-valin-codec-requirements POTENTIALLY REPLACED BY draft-ietf-codec-requirements

DRINKS Working Group, RAI Area
   draft-cartwright-drinks-sppp-over-soap POTENTIALLY REPLACED BY draft-ietf-drinks-sppp-over-soap

ECRIT Working Group, RAI Area
   draft-wolf-ecrit-lost-servicelistboundary POTENTIALLY REPLACED BY draft-ietf-ecrit-lost-servicelistboundary

GEOPRIV Working Group, RAI Area
   draft-rosen-geopriv-prefix POTENTIALLY REPLACED BY draft-ietf-geopriv-prefix
   draft-thomson-geopriv-held-measurements POTENTIALLY REPLACED BY draft-ietf-geopriv-held-measurements
   draft-thomson-geopriv-relative-location POTENTIALLY REPLACED BY draft-ietf-geopriv-relative-location
   draft-winterbottom-geopriv-held-identity-extensions POTENTIALLY REPLACED BY draft-ietf-geopriv-held-identity-extensions

P2PSIP Working Group, RAI Area
   draft-maenpaa-p2psip-self-tuning POTENTIALLY REPLACED BY draft-ietf-p2psip-self-tuning
   draft-maenpaa-p2psip-service-discovery POTENTIALLY REPLACED BY draft-ietf-p2psip-service-discovery

SIPREC Working Group, RAI Area
   draft-rehor-siprec-req POTENTIALLY REPLACED BY draft-ietf-siprec-req

SOC Working Group, RAI Area
   draft-hilt-soc-overload-design POTENTIALLY REPLACED BY draft-ietf-soc-overload-design

XMPP Working Group, RAI Area
   draft-barnes-xmpp-dna POTENTIALLY REPLACED BY draft-ietf-xmpp-dna
   draft-saintandre-xmpp-address POTENTIALLY REPLACED BY draft-ietf-xmpp-address
   draft-saintandre-xmpp-e2e-requirements POTENTIALLY REPLACED BY draft-ietf-xmpp-e2e-requirements

-----------------------------------------------------------------
RTG Area
-----------------------------------------------------------------
CCAMP Working Group, RTG Area
   draft-kern-ccamp-rsvp-te-sdh-otn-oam-ext POTENTIALLY REPLACED BY draft-ietf-ccamp-rsvp-te-sdh-otn-oam-ext
   draft-lee-ccamp-wson-signal-compatibility-ospf POTENTIALLY REPLACED BY draft-ietf-ccamp-wson-signal-compatibility-ospf
   draft-sun-ccamp-dpm POTENTIALLY REPLACED BY draft-ietf-ccamp-dpm
   draft-zhang-ccamp-gmpls-g709-framework POTENTIALLY REPLACED BY draft-ietf-ccamp-gmpls-g709-framework

FORCES Working Group, RTG Area
   draft-haleplidis-forces-implementation-experience POTENTIALLY REPLACED BY draft-ietf-forces-implementation-experience

L3VPN Working Group, RTG Area
   draft-marques-l3vpn-ibgp POTENTIALLY REPLACED BY draft-ietf-l3vpn-ibgp
   draft-rosen-l3vpn-mvpn-infra-addrs POTENTIALLY REPLACED BY draft-ietf-l3vpn-mvpn-infra-addrs
   draft-rosen-l3vpn-mvpn-spmsi-joins POTENTIALLY REPLACED BY draft-ietf-l3vpn-mvpn-spmsi-joins

MANET Working Group, RTG Area
   draft-cole-manet-report-mib POTENTIALLY REPLACED BY draft-ietf-manet-report-mib
   draft-herberg-manet-packetbb-sec POTENTIALLY REPLACED BY draft-ietf-manet-packetbb-sec

MPLS Working Group, RTG Area
   draft-boutros-mpls-tp-fault POTENTIALLY REPLACED BY draft-ietf-mpls-tp-fault
   draft-chen-mpls-return-path-specified-lsp-ping POTENTIALLY REPLACED BY draft-ietf-mpls-return-path-specified-lsp-ping
   draft-wijnands-mpls-mldp-in-band-signaling POTENTIALLY REPLACED BY draft-ietf-mpls-mldp-in-band-signaling

OSPF Working Group, RTG Area
   draft-hartman-ospf-analysis POTENTIALLY REPLACED BY draft-ietf-ospf-analysis
   draft-nguyen-ospf-lls POTENTIALLY REPLACED BY draft-ietf-ospf-lls

PCE Working Group, RTG Area
   draft-lee-pce-wson-routing-wavelength POTENTIALLY REPLACED BY draft-ietf-pce-wson-routing-wavelength

PIM Working Group, RTG Area
   draft-venaas-pim-registry POTENTIALLY REPLACED BY draft-ietf-pim-registry

PWE3 Working Group, RTG Area
   draft-martini-pwe3-p2mp-pw POTENTIALLY REPLACED BY draft-ietf-pwe3-p2mp-pw

ROLL Working Group, RTG Area
   draft-levis-roll-trickle POTENTIALLY REPLACED BY draft-ietf-roll-trickle
   draft-tsao-roll-security-framework POTENTIALLY REPLACED BY draft-ietf-roll-security-framework

SIDR Working Group, RTG Area
   draft-huston-sidr-rpki-algs POTENTIALLY REPLACED BY draft-ietf-sidr-rpki-algs
   draft-manderson-sidr-usecases POTENTIALLY REPLACED BY draft-ietf-sidr-usecases
   draft-pmohapat-sidr-pfx-validate POTENTIALLY REPLACED BY draft-ietf-sidr-pfx-validate

-----------------------------------------------------------------
SEC Area
-----------------------------------------------------------------
HOKEY Working Group, SEC Area
   draft-wang-hokey-erp-aak POTENTIALLY REPLACED BY draft-ietf-hokey-erp-aak
   draft-wu-hokey-ldn-discovery POTENTIALLY REPLACED BY draft-ietf-hokey-ldn-discovery

PKIX Working Group, SEC Area
   draft-cooper-pkix-rfc5280-clarifications POTENTIALLY REPLACED BY draft-ietf-pkix-rfc5280-clarifications

SMIME Working Group, SEC Area
   draft-dusse-smime-cert POTENTIALLY REPLACED BY draft-ietf-smime-cert
   draft-dusse-smime-msg POTENTIALLY REPLACED BY draft-ietf-smime-msg

TLS Working Group, SEC Area
   draft-rescorla-tls-suiteb POTENTIALLY REPLACED BY draft-ietf-tls-suiteb
   draft-seggelmann-tls-dtls-heartbeat POTENTIALLY REPLACED BY draft-ietf-tls-dtls-heartbeat

-----------------------------------------------------------------
TSV Area
-----------------------------------------------------------------
BEHAVE Working Group, TSV Area
   draft-liu-behave-ftp64 POTENTIALLY REPLACED BY draft-ietf-behave-ftp64

IPPM Working Group, TSV Area
   draft-geib-ippm-metrictest POTENTIALLY REPLACED BY draft-ietf-ippm-metrictest

MPTCP Working Group, TSV Area
   draft-ford-mptcp-multiaddressed POTENTIALLY REPLACED BY draft-ietf-mptcp-multiaddressed
   draft-raiciu-mptcp-congestion POTENTIALLY REPLACED BY draft-ietf-mptcp-congestion

PCN Working Group, TSV Area
   draft-karagiannis-pcn-signaling-requirements POTENTIALLY REPLACED BY draft-ietf-pcn-signaling-requirements

TCPM Working Group, TSV Area
   draft-ananth-tcpm-persist POTENTIALLY REPLACED BY draft-ietf-tcpm-persist
   draft-gont-tcpm-tcp-timestamps POTENTIALLY REPLACED BY draft-ietf-tcpm-tcp-timestamps

TSVWG Working Group, TSV Area
   draft-tuexen-tsvwg-sctp-chunk-flags POTENTIALLY REPLACED BY draft-ietf-tsvwg-sctp-chunk-flags

-----------------------------------------------------------------
Potential Inconsistencies
-----------------------------------------------------------------
draft-ietf-6lowpan-nd may replace one or more of 2 individual IDs - check this
draft-ietf-avt-rtp-gsm-hr may replace one or more of 3 individual IDs - check this
draft-ietf-avt-rtp-svc may replace one or more of 2 individual IDs - check this
draft-ietf-dhc-dhcpv4-bulk-leasequery may replace one or more of 2 individual IDs - check this
draft-ietf-ipfix-biflow may replace one or more of 2 individual IDs - check this
draft-ietf-l2tpext-tdm may replace one or more of 2 individual IDs - check this
draft-ietf-mpls-tp-fault may replace one or more of 2 individual IDs - check this

---

From: Peter Koch <[email-masked]>
Date: Tue, 24 Aug 2010 19:53:34 +0200

> here's my current report of potentially missing "replaced-by" relationships in the IETF datatracker. WG chairs are encouraged to check whether these are accurate for their WGs, and if so, send a ti…

thanks for the report, Lars.

On a related issue: the replacement information also appears at the end of
the WG page on the tools site under "Related Active Documents (not working
group documents)".  This list includes drafts that have long since expired
(and have or have not been replaced/adopted).  Is this intentional or is there
another magic to unmark the "Active" flag for these drafts?

-Peter

---

From: Loa Andersson <[email-masked]>
Date: Mon, 30 Aug 2010 12:29:58 +0200

Lars,

I'd like to up level this a bit, would it be possible
to add this as a step in the tool when we accept the
initial wg draft?

It would save at least a bit of extra work.

I've asked for it before, but never really found anyone
that wants to own the problem.

/Loa

-- 

Loa Andersson                         email: [email-masked]
Sr Strategy and Standards Manager            [email-masked]
Ericsson Inc                          phone: +46 10 717 52 13
                                              +46 767 72 92 13

---

From: Ed Juskevicius <[email-masked]>
Date: Tue, 31 Aug 2010 04:20:39 -0400

Loa, if I understand correctly what you have been asking for (per below),
then some requirements to enhance the IDST and the Datatracker to address
your requests may now be in the pipeline for coding.

Please see Section 6.2 of
https://datatracker.ietf.org/doc/draft-juskevicius-datatracker-wgdocstate-reqts/

and Section 6.4, and in particular the following requirement:

   The Datatracker SHOULD also prompt the WG Chair to input, confirm or
   correct the filename of the I-D being replaced (if any) by each new
   version-00 WG I-D when the Chair approves the posting of the new
   I-D. (R-078)

Regards,

Ed  J.

---------------
On Mon, Aug 30, 2010 at 6:29 AM, Loa Andersson <[email-masked]> wrote:

>>    draft-chen-mpls-return-path-specified-lsp-ping POTENTIALLY REPLACED BY
>> draft-ietf-mpls-return-path-specified-lsp-ping

---

From: Loa Andersson <[email-masked]>
Date: Tue, 31 Aug 2010 12:56:00 +0200

Ed,

OK, thanks - obviously this filtered into the requirements - I'm
happy :).

/Loa

On 2010-08-31 10:20, Ed Juskevicius wrote:
> Loa, if I understand correctly what you have been asking for (per
> below), then some requirements to enhance the IDST and the Datatracker
> to address your requests may now be in the pipeline for coding.
> On Mon, Aug 30, 2010 at 6:29 AM, Loa Andersson <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>     Lars,
>
>             draft-chen-mpls-return-path-specified-lsp-ping POTENTIALLY
>         REPLACED BY draft-ietf-mpls-return-path-specified-lsp-ping
>             draft-wijnands-mpls-mldp-in-band-signaling POTENTIALLY
>         REPLACED BY draft-ietf-mpls-mldp-in-band-signaling
>
>
>     --
>
>
>     Loa Andersson                         email:
>     [email-masked] <mailto:[email-masked]>
>     Sr Strategy and Standards Manager [email-masked] <mailto:[email-masked]>

--

---

From: Bernie Hoeneisen <[email-masked]>
Date: Tue, 31 Aug 2010 14:30:55 +0200 (CEST)

Hi Ed

>    version-00 WG I-D when the Chair approves the posting of the new

Nice to see that this is addressed.
[It was driving me almost crazy investigating about all the missing 
"Replaced By" information for the ENUM documents, but eventually I got 
there...]

Some questions:

1) Is there also a requirement to provide a field (or choice) for the 
_submitter_ of the I-D to indicate, which I-D it is replacing?

2) Have the following corner-cases also been considered:
    a) One (-00) I-D replaces many I-D (merger)
    b) Several (-00) I-Ds replace one I-D (split); (should be trivial)
    c) A merger happing later than at -00, but numbering is not restarted
    d) A split happing later than at -00, one only partly replaces an I-D
    e) All these cases could happen before an I-D gets a WG document

Have fun thinking about these corner-cases!

cheers,
  Bernie

--

http://ucom.ch/
Tech Consulting for Internet Standardization

---

From: "David Harrington" <[email-masked]>
Date: Tue, 31 Aug 2010 08:51:16 -0400

Hi,

we had a problem a while back when an author published a document
using the same name as a WG draft.
Authors don't always understand IETF process.

The "replaced-by" info must be approved hy a chair, since the chair is
responsible for WG drafts.
If the tool allows an author to specify which draft is being replaced,
that info should be passed onto a chair for approval, not simply
accepted from an author.

my $.02
dbh

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Bernie Hoeneisen
> Sent: Tuesday, August 31, 2010 8:31 AM
> To: Ed Juskevicius
> Cc: [email-masked]
> Subject: Re: Replaced by information Was: (latest missing 
> replaced-byinformation)
> 
> Hi Ed
> 
> >    The Datatracker SHOULD also prompt the WG Chair to 
> input, confirm 
> > or
> [It was driving me almost crazy investigating about all the 
> missing "Replaced By" information for the ENUM documents, but 
> eventually I got there...]
> 
> Some questions:
> 
> 1) Is there also a requirement to provide a field (or choice) 
> for the _submitter_ of the I-D to indicate, which I-D it is
replacing?

---

From: 'Bernie Hoeneisen' <[email-masked]>
Date: Tue, 31 Aug 2010 15:14:13 +0200 (CEST)

Hi Dave

> using the same name as a WG draft.

I also found such cases in ENUM.

[Very confusing and time-consuming for a WG chair to sort those out after 
several years; I even got some questions of confused/concerned authors, as 
they got some "strange" notification email, while adding the "Replaced By" 
information to the tracker...]

Thus, I fully support the requirement to add "Replaced By" information at 
submission/approval time of an I-D.

> that info should be passed onto a chair for approval, not simply

This is exactely what I meant:
The submitter proposes and the chair approves (or corrects it).

cheers,
  Bernie

---

From: Ed Juskevicius <[email-masked]>
Date: Tue, 31 Aug 2010 12:46:36 -0400

Henrik, please see Bernie's questions (below).  I believe they pertain to
the I-D Submission Tool (IDST), and I'd like your advice on who to forward
this to, for consideration in the coding of new capabilities for the IDST.

Thanks in advance,

Ed  J.

---------- Forwarded message ----------
From: Bernie Hoeneisen <[email-masked]>
Date: Tue, Aug 31, 2010 at 8:30 AM
Subject: Re: Replaced by information Was: (latest missing replaced-by
information)
To: Ed Juskevicius <[email-masked]>
Cc: "[email-masked]" <[email-masked]>

Hi Ed

Some questions:

cheers,
 Bernie

--

http://ucom.ch/