Subject: CC on mailing lists

From: Ben Campbell <[email-masked]>
Date: Mon, 27 Sep 2010 16:44:16 -0500

I'm seeing something strange with CC headers on the SIMPLE list. Messages I send with multiple CC header entries are getting some entries stripped out. For example, here's the CC header on a message I sent. The original message was sent by Mail.app Version 4.3 (1081) on OS X 10.6.4.

> Cc: Hisham Khartabil <[email-masked]>,
> "Richard L. Barnes" <[email-masked]>,
> Alan Johnston <[email-masked]>

And here's the CC header on the version forwarded out by the list server:

> Cc: Alan Johnston <[email-masked]>

Here's another:

> Cc: [email-masked],
> Hisham Khartabil <[email-masked]>

... was changed to:

> Cc: [email-masked]

Any thoughts, other than maybe mailman is mad at Hisham :-) If there's a syntax error there, my eyeballs are missing it.

---

From: "Dan Wing" <[email-masked]>
Date: Mon, 27 Sep 2010 15:14:47 -0700

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Ben Campbell
> Sent: Monday, September 27, 2010 2:44 PM
> To: WG Chairs
> Cc: Glen Barney (AMS)
> Subject: CC on mailing lists
> 
> I'm seeing something strange with CC headers on the SIMPLE list.
> Messages I send with multiple CC header entries are getting some
> entries stripped out. For example, here's the CC header on a message I
> sent. The original message was sent by Mail.app Version 4.3 (1081) on
> OS X 10.6.4.
> 
> 
> Any thoughts, other than maybe mailman is mad at Hisham :-) If there's
> a syntax error there, my eyeballs are missing it.

Line continuations need to start with one (or more) spaces or tab
characters.  Thus, these two lines have a syntax error, the second line is
interpreted as a mal-formed header field starting with "Hisham":

  1.Cc: [email-masked],
  2.Hisham Khartabil <[email-masked]>

to be interpreted as expected, the second line has to start with one (or
more) 
spaces or tab characters, like so:

  1.Cc: [email-masked],
  2. Hisham Khartabil <[email-masked]>
....^
....^
   note the " "

-d

---

From: Donald Eastlake <[email-masked]>
Date: Mon, 27 Sep 2010 18:19:43 -0400

I have seen something similar. I think that when you send mail to a
mailing list and cc individuals, those individuals who are subscribed
to the mailing list may get stripped as cc's.

Thanks,
Donald

---

From: "Laganier, Julien" <[email-masked]>
Date: Mon, 27 Sep 2010 17:58:35 -0700

The person that are stripped from CC: have probably enabled the following Mailman feature in their account settings:

"Avoid duplicate copies of message? When you are listed explicitly in the To: or Cc: headers of a list message, you can opt to not receive another copy from the mailing list. Select Yes to avoid receiving copies from the mailing list; select No to receive copies. ( ) No. (X) Yes. [ ] Set Globally"

HTH,

--julien

---

From: Ben Campbell <[email-masked]>
Date: Mon, 27 Sep 2010 22:16:32 -0500

Yep, I bet that's it. You learn something new every day.

Thanks!

Ben.

---

From: Ben Campbell <[email-masked]>
Date: Mon, 27 Sep 2010 22:20:13 -0500

On Sep 27, 2010, at 5:14 PM, "Dan Wing" <[email-masked]> wrote:

[...]

>  2. Hisham Khartabil <[email-masked]>

Actually, the space is there, it just got obscured by the cut and paste rendering. Note that in the first example, the surviving entry was the third one.

---

From: Barry Leiba <[email-masked]>
Date: Tue, 28 Sep 2010 13:24:08 -0400

On Mon, Sep 27, 2010 at 8:58 PM, Laganier, Julien <[email-masked]> wrote:
> The person that are stripped from CC: have probably enabled the following
> Mailman feature in their account settings:
>
> "Avoid duplicate copies of message? When you are listed explicitly in the
> To: or Cc: headers of a list message, you can opt to not receive another
> copy from the mailing list. Select Yes to avoid receiving copies from the
> mailing list; select No to receive copies. ( ) No. (X) Yes. [ ] Set Globally"

I don't think that's the answer.  I *think* (though I'm not certain)
that Mailman handles this not by stripping CCs (which wouldn't help,
because you have already sent the CCs directly to those people), but
by *not* sending the mailing-list entry to them, because it assumes
that they've already gotten their copies through the CC entries.

That seems to mean that Mailman is stripping these CCs incorrectly,
which might be related to the Reply-To issue that I've raised.

Barry

---

From: Ben Campbell <[email-masked]>
Date: Tue, 28 Sep 2010 13:26:25 -0500

> which might be related to the Reply-To issue that I've raised.

I was thinking that it might strip CCs so that replies are less likely to have CC or To entries that duplicate list entries. I have no knowledge as to whether it does that, it's just something I can imagine someone coming up with.

---

From: Peter Koch <[email-masked]>
Date: Wed, 29 Sep 2010 12:35:33 +0200

> that they've already gotten their copies through the CC entries.

You're right on the suppression part, but it does both IIRC to prevent
future occurences of the same issue -- and growing CC lines.

I'm not really happy that this feature is on by default on IETF lists
(so, yes, I do switch it off "globally" every now and then).
It is likely to cause/support mail loss and makes List-ID or envelope from based
filtering harder.

-Peter