Subject: latest missing replaced-by information

From: Eggert Lars (Nokia-NRC/Espoo) <[email-masked]>
Date: Wed, 27 Oct 2010 13:57:34 +0300

Hi,

with the drafts for IETF-79 submitted, here's the latest report of potentially missing "replaced-by" relationships in the IETF datatracker. WG chairs are encouraged to check whether these are accurate for their WGs, and if so, send a ticket to the secretariat instructing them to "record in the database that draft X replaced draft Y".

As always, double-check before reporting to the secretariat. Also, see list of possible inconsistencies at the end of the report.

(Note that the IPR disclosure search tool uses these replaced-by relationships, so keeping them up-to-date is actually useful and not just WG hygiene.)

Lars

PS: This report is generated by a new version of the tool that uses all_id2.txt rather than screen-scraping the datatracker. In other words, check the output even more carefully than normally.

-----------------------------------------------------------------
APP Area
-----------------------------------------------------------------
CORE Working Group, APP Area
   draft-shelby-core-link-format POTENTIALLY REPLACED BY draft-ietf-core-link-format

DECADE Working Group, APP Area
   draft-gu-decade-reqs POTENTIALLY REPLACED BY draft-ietf-decade-reqs
   draft-rahman-decade-survey POTENTIALLY REPLACED BY draft-ietf-decade-survey
   draft-song-decade-problem-statement POTENTIALLY REPLACED BY draft-ietf-decade-problem-statement
   draft-song-decade-survey POTENTIALLY REPLACED BY draft-ietf-decade-survey

EAI Working Group, APP Area
   draft-yao-eai-rfc5336bis POTENTIALLY REPLACED BY draft-ietf-eai-rfc5336bis

IRI Working Group, APP Area
   draft-hansen-iri-4395bis-irireg POTENTIALLY REPLACED BY draft-ietf-iri-4395bis-irireg

PRECIS Working Group, APP Area
   draft-blanchet-precis-problem-statement POTENTIALLY REPLACED BY draft-ietf-precis-problem-statement

SIEVE Working Group, APP Area
   draft-george-sieve-autoreply POTENTIALLY REPLACED BY draft-ietf-sieve-autoreply
   draft-george-sieve-notify-presence POTENTIALLY REPLACED BY draft-ietf-sieve-notify-presence

-----------------------------------------------------------------
INT Area
-----------------------------------------------------------------
6MAN Working Group, INT Area
   draft-arifumi-6man-rfc3484-revise POTENTIALLY REPLACED BY draft-ietf-6man-rfc3484-revise
   draft-joshi-6man-neighbor-inform POTENTIALLY REPLACED BY draft-ietf-6man-neighbor-inform

AUTOCONF Working Group, INT Area
   draft-baccelli-autoconf-adhoc-addr-model POTENTIALLY REPLACED BY draft-ietf-autoconf-adhoc-addr-model

CSI Working Group, INT Area
   draft-jiang-csi-dhcpv6-cga-ps POTENTIALLY REPLACED BY draft-ietf-csi-dhcpv6-cga-ps
   draft-rgaglian-csi-send-name-type-registry POTENTIALLY REPLACED BY draft-ietf-csi-send-name-type-registry

DHC Working Group, INT Area
   draft-jiang-dhc-secure-dhcpv6 POTENTIALLY REPLACED BY draft-ietf-dhc-secure-dhcpv6

DNSEXT Working Group, INT Area
   draft-dolmatov-dnsext-dnssec-gost POTENTIALLY REPLACED BY draft-ietf-dnsext-dnssec-gost
   draft-wang-dnsext-newzone-notify POTENTIALLY REPLACED BY draft-ietf-dnsext-newzone-notify

HIP Working Group, INT Area
   draft-camarillo-hip-via POTENTIALLY REPLACED BY draft-ietf-hip-via
   draft-henderson-hip-rfc5206-bis POTENTIALLY REPLACED BY draft-ietf-hip-rfc5206-bis
   draft-jokela-hip-rfc5202-bis POTENTIALLY REPLACED BY draft-ietf-hip-rfc5202-bis
   draft-keranen-hip-native-nat-traversal POTENTIALLY REPLACED BY draft-ietf-hip-native-nat-traversal
   draft-keranen-hip-over-hip POTENTIALLY REPLACED BY draft-ietf-hip-over-hip
   draft-keranen-hip-reload-instance POTENTIALLY REPLACED BY draft-ietf-hip-reload-instance
   draft-moskowitz-hip-rfc4423-bis POTENTIALLY REPLACED BY draft-ietf-hip-rfc4423-bis
   draft-moskowitz-hip-rfc5201-bis POTENTIALLY REPLACED BY draft-ietf-hip-rfc5201-bis
   draft-nikander-hip-hiccups POTENTIALLY REPLACED BY draft-ietf-hip-hiccups

NETEXT Working Group, INT Area
   draft-korhonen-netext-redirect POTENTIALLY REPLACED BY draft-ietf-netext-redirect
   draft-krishnan-netext-pmip-lr POTENTIALLY REPLACED BY draft-ietf-netext-pmip-lr
   draft-melia-netext-logical-interface-support POTENTIALLY REPLACED BY draft-ietf-netext-logical-interface-support

SAVI Working Group, INT Area
   draft-vogt-savi-framework POTENTIALLY REPLACED BY draft-ietf-savi-framework

SOFTWIRE Working Group, INT Area
   draft-maglione-softwire-dslite-radius-ext POTENTIALLY REPLACED BY draft-ietf-softwire-dslite-radius-ext

-----------------------------------------------------------------
OPS Area
-----------------------------------------------------------------
BMWG Working Group, OPS Area
   draft-asati-bmwg-reset POTENTIALLY REPLACED BY draft-ietf-bmwg-reset

DIME Working Group, OPS Area
   draft-zorn-dime-rfc4005bis POTENTIALLY REPLACED BY draft-ietf-dime-rfc4005bis

GROW Working Group, OPS Area
   draft-manderson-grow-geomrt POTENTIALLY REPLACED BY draft-ietf-grow-geomrt

IPFIX Working Group, OPS Area
   draft-boschi-ipfix-anon POTENTIALLY REPLACED BY draft-ietf-ipfix-anon
   draft-gupta-ipfix-reliability-template-ext POTENTIALLY REPLACED BY draft-ietf-ipfix-reliability-template-ext

NETCONF Working Group, OPS Area
   draft-bierman-netconf-access-control POTENTIALLY REPLACED BY draft-ietf-netconf-access-control

OPSAWG Working Group, OPS Area
   draft-mizrahi-opsawg-oam-overview POTENTIALLY REPLACED BY draft-ietf-opsawg-oam-overview

RADEXT Working Group, OPS Area
   draft-dekok-radext-dtls POTENTIALLY REPLACED BY draft-ietf-radext-dtls
   draft-lourdelet-radext-ipv6-access POTENTIALLY REPLACED BY draft-ietf-radext-ipv6-access

-----------------------------------------------------------------
RAI Area
-----------------------------------------------------------------
ATOCA Working Group, RAI Area
   draft-rosen-atoca-cap POTENTIALLY REPLACED BY draft-ietf-atoca-cap
   draft-schulzrinne-atoca-requirements POTENTIALLY REPLACED BY draft-ietf-atoca-requirements

BLISS Working Group, RAI Area
   draft-procter-bliss-call-park-extension POTENTIALLY REPLACED BY draft-ietf-bliss-call-park-extension

ECRIT Working Group, RAI Area
   draft-rosen-ecrit-additional-data POTENTIALLY REPLACED BY draft-ietf-ecrit-additional-data
   draft-rosen-ecrit-data-only-ea POTENTIALLY REPLACED BY draft-ietf-ecrit-data-only-ea
   draft-schulzrinne-ecrit-psap-callback POTENTIALLY REPLACED BY draft-ietf-ecrit-psap-callback
   draft-schulzrinne-ecrit-unauthenticated-access POTENTIALLY REPLACED BY draft-ietf-ecrit-unauthenticated-access
   draft-tschofenig-ecrit-trustworthy-location POTENTIALLY REPLACED BY draft-ietf-ecrit-trustworthy-location

XMPP Working Group, RAI Area
   draft-barnes-xmpp-dna POTENTIALLY REPLACED BY draft-ietf-xmpp-dna

-----------------------------------------------------------------
RTG Area
-----------------------------------------------------------------
CCAMP Working Group, RTG Area
   draft-berger-ccamp-assoc-info POTENTIALLY REPLACED BY draft-ietf-ccamp-assoc-info
   draft-bernstein-ccamp-wson-signaling POTENTIALLY REPLACED BY draft-ietf-ccamp-wson-signaling
   draft-kern-ccamp-rsvp-te-sdh-otn-oam-ext POTENTIALLY REPLACED BY draft-ietf-ccamp-rsvp-te-sdh-otn-oam-ext
   draft-lee-ccamp-wson-signal-compatibility-ospf POTENTIALLY REPLACED BY draft-ietf-ccamp-wson-signal-compatibility-ospf
   draft-li-ccamp-lmp-behavior-negotiation POTENTIALLY REPLACED BY draft-ietf-ccamp-lmp-behavior-negotiation
   draft-sun-ccamp-dpm POTENTIALLY REPLACED BY draft-ietf-ccamp-dpm
   draft-zhang-ccamp-gmpls-g709-framework POTENTIALLY REPLACED BY draft-ietf-ccamp-gmpls-g709-framework

FORCES Working Group, RTG Area
   draft-haleplidis-forces-implementation-experience POTENTIALLY REPLACED BY draft-ietf-forces-implementation-experience
   draft-ogawa-forces-ceha POTENTIALLY REPLACED BY draft-ietf-forces-ceha

IDR Working Group, RTG Area
   draft-dong-idr-fsm-subcode POTENTIALLY REPLACED BY draft-ietf-idr-fsm-subcode

MPLS Working Group, RTG Area
   draft-boutros-mpls-tp-li-lb POTENTIALLY REPLACED BY draft-ietf-mpls-tp-li-lb
   draft-wijnands-mpls-mldp-recurs-fec POTENTIALLY REPLACED BY draft-ietf-mpls-mldp-recurs-fec

OSPF Working Group, RTG Area
   draft-hartman-ospf-analysis POTENTIALLY REPLACED BY draft-ietf-ospf-analysis
   draft-nguyen-ospf-lls POTENTIALLY REPLACED BY draft-ietf-ospf-lls

PCE Working Group, RTG Area
   draft-king-pce-inter-area-as-applicability POTENTIALLY REPLACED BY draft-ietf-pce-inter-area-as-applicability
   draft-lee-pce-wson-routing-wavelength POTENTIALLY REPLACED BY draft-ietf-pce-wson-routing-wavelength
   draft-margaria-pce-gmpls-pcep-extensions POTENTIALLY REPLACED BY draft-ietf-pce-gmpls-pcep-extensions

ROLL Working Group, RTG Area
   draft-dt-roll-p2p-rpl POTENTIALLY REPLACED BY draft-ietf-roll-p2p-rpl
   draft-gnawali-roll-minrank-hysteresis-of POTENTIALLY REPLACED BY draft-ietf-roll-minrank-hysteresis-of
   draft-levis-roll-trickle POTENTIALLY REPLACED BY draft-ietf-roll-trickle
   draft-tsao-roll-security-framework POTENTIALLY REPLACED BY draft-ietf-roll-security-framework

SIDR Working Group, RTG Area
   draft-huston-sidr-keyroll POTENTIALLY REPLACED BY draft-ietf-sidr-keyroll
   draft-huston-sidr-rpki-algs POTENTIALLY REPLACED BY draft-ietf-sidr-rpki-algs
   draft-manderson-sidr-usecases POTENTIALLY REPLACED BY draft-ietf-sidr-usecases
   draft-pmohapat-sidr-pfx-validate POTENTIALLY REPLACED BY draft-ietf-sidr-pfx-validate
   draft-weiler-sidr-publication POTENTIALLY REPLACED BY draft-ietf-sidr-publication

-----------------------------------------------------------------
SEC Area
-----------------------------------------------------------------
DKIM Working Group, SEC Area
   draft-lindsey-dkim-mailinglists POTENTIALLY REPLACED BY draft-ietf-dkim-mailinglists

HOKEY Working Group, SEC Area
   draft-hoeper-hokey-arch-design POTENTIALLY REPLACED BY draft-ietf-hokey-arch-design
   draft-wu-hokey-rfc5296bis POTENTIALLY REPLACED BY draft-ietf-hokey-rfc5296bis

PKIX Working Group, SEC Area
   draft-cooper-pkix-rfc2560bis POTENTIALLY REPLACED BY draft-ietf-pkix-rfc2560bis
   draft-cooper-pkix-rfc5280-clarifications POTENTIALLY REPLACED BY draft-ietf-pkix-rfc5280-clarifications

TLS Working Group, SEC Area
   draft-rescorla-tls-suiteb POTENTIALLY REPLACED BY draft-ietf-tls-suiteb
   draft-seggelmann-tls-dtls-heartbeat POTENTIALLY REPLACED BY draft-ietf-tls-dtls-heartbeat

-----------------------------------------------------------------
TSV Area
-----------------------------------------------------------------
BEHAVE Working Group, TSV Area
   draft-liu-behave-ftp64 POTENTIALLY REPLACED BY draft-ietf-behave-ftp64

DCCP Working Group, TSV Area
   draft-renker-dccp-tfrc-rtt-option POTENTIALLY REPLACED BY draft-ietf-dccp-tfrc-rtt-option

IPPM Working Group, TSV Area
   draft-geib-ippm-metrictest POTENTIALLY REPLACED BY draft-ietf-ippm-metrictest

NFSV4 Working Group, TSV Area
   draft-alexrn-nfsv4-ipv6 POTENTIALLY REPLACED BY draft-ietf-nfsv4-ipv6
   draft-eisler-nfsv4-minorversion-2-requirements POTENTIALLY REPLACED BY draft-ietf-nfsv4-minorversion-2-requirements
   draft-faibish-nfsv4-pnfs-access-permissions-check POTENTIALLY REPLACED BY draft-ietf-nfsv4-pnfs-access-permissions-check

PCN Working Group, TSV Area
   draft-karagiannis-pcn-signaling-requirements POTENTIALLY REPLACED BY draft-ietf-pcn-signaling-requirements

PPSP Working Group, TSV Area
   draft-zhang-ppsp-problem-statement POTENTIALLY REPLACED BY draft-ietf-ppsp-problem-statement
   draft-zong-ppsp-reqs POTENTIALLY REPLACED BY draft-ietf-ppsp-reqs

TCPM Working Group, TSV Area
   draft-hkchu-tcpm-initcwnd POTENTIALLY REPLACED BY draft-ietf-tcpm-initcwnd

-----------------------------------------------------------------
Potential Inconsistencies
-----------------------------------------------------------------
draft-ietf-6lowpan-nd may replace one or more of 2 individual IDs - check this
draft-ietf-avt-rtp-gsm-hr may replace one or more of 3 individual IDs - check this
draft-ietf-avt-rtp-svc may replace one or more of 2 individual IDs - check this
draft-ietf-decade-survey may replace one or more of 2 individual IDs - check this
draft-ietf-dhc-dhcpv4-bulk-leasequery may replace one or more of 2 individual IDs - check this
draft-ietf-ipfix-biflow may replace one or more of 2 individual IDs - check this
draft-ietf-l2tpext-tdm may replace one or more of 2 individual IDs - check this
draft-ietf-mpls-tp-fault may replace one or more of 2 individual IDs - check this

---

From: Ben Campbell <[email-masked]>
Date: Thu, 28 Oct 2010 12:55:15 -0500

Do we need to take any action if the report lists a potential replaced-by relationship that is not accurate?

---

From: Adam Roach <[email-masked]>
Date: Thu, 28 Oct 2010 13:10:42 -0500

> Do we need to take any action if the report lists a potential replaced-by relationship that is not accurate?

I don't think so. The only consumers of this information, as far as I 
know, are WG chairs.

Which also implies that chairs *do* need to take action on any 
*accurate* replaced-by relationships.

/a

---

From: Lars Eggert <[email-masked]>
Date: Fri, 29 Oct 2010 07:28:17 +0300

> *accurate* replaced-by relationships.

Both points correct.

Lars