Subject: Re: Tracker etiquette

From: Cullen Jennings <[email-masked]>
Date: Sat, 6 Nov 2010 21:35:07 -0600

It took me awhile to track this down. It seems the emails were lost getting to me but the tracker didd send them as other people had them. I can not figure out if I was temporary off the list, or my corporate email servers lost them, or I ate them or whatever but I'm not worried about this type of case - email  losses are rare and there were other copies.  Regardless, what is going on in siprec is not really the issue. 

The issue is what is our policy here.  I think the conversation has made it pretty clear that not all WGs would be happy with all the traffic going to the list and I thought we were discussing what we were doing with these. Regardless of how anyone thinks IT should and is run, I do not believe the IETF is making any long term commitment to be able to restore backups of any of the trackers. That's about the summary of where we are. 

On Oct 7, 2010, at 9:12 AM, Elwell, John wrote:

> Cullen,
> 
> In SIPREC, where you raised this question, the tracker is configured to send every change as a message to the SIPREC mailing list, so everything is archived and backed up. I had forgotten that there is an option to turn this off, but by having it turned on we solve the archive and back-up problems, and also have the whole archive for the WG, in one place. The issue then reduces to:
> - how to use the tracker so that it serves its prime purpose (keeping track of issues) but does not make life hard for the WG participants in general, or those examining the archives;
> - what possible enhancements to the tracker would help in achieving the above.
> 
> John
> 
> 
>> -----Original Message-----
>> From: [email-masked] 
>> [mailto:[email-masked]] On Behalf Of Cullen Jennings
>> Sent: 02 October 2010 14:03
>> To: Ted Lemon
>> Cc: IETF WG Chairs; Henrik Levkowetz
>> Subject: Re: Tracker etiquette
>> 
>> 
>> On Oct 1, 2010, at 5:48 PM, Ted Lemon wrote:
>> 
>>> On Oct 1, 2010, at 5:48 PM, "Carsten Bormann" <[email-masked]> wrote:
>>> 
>>>> (I don't buy the argument that the mailing list would be 
>> overwhelmed by this.  Yes, it can be a bit noisy when someone 
>> opens and then fixes 30 tickets in one day, but the resulting 
>> messages can be rather easily ticked off by an uninterested 
>> mailing list member.  I also don't buy a legitimate member in 
>> the WG even could be uninterested.)
>>> 
>>> That's not the issue.  The issue is that unlike regular 
>> mail, it is a lot of work to evaluate each message to see 
>> that it either is or is not of interest, because it's not 
>> generated in the usual way and doesn't have the usual tags. 
>> E.g. I think the subject line is an issue number.
>>> 
>> 
>> One way that would meet both my goals and Teds would be for a 
>> WG like martini to have all tracker output go to a a separate 
>> email lists, say martini-noise. People like my could 
>> subscribe to both, or at least both would be archived, and 
>> others could not subscribe to the noise.

---

From: Bernard Aboba <[email-masked]>
Date: Sat, 6 Nov 2010 21:26:21 -0800

At this point, TRAC is being used by quite a few WGs, so I had assumed (perhaps naively) that it was fully supported IT infrastructure, which would include backups. 

This leads me to wonder what other aspects of IETF infrastructure are not backed up. 

For example, I use the tools on tools.ietf.org quite a bit, and would be impacted substantially were this site to disappear.   I understand this site is not really "official" but I would still hope that it is being backed up.   Is that silly of me?

> From: [email-masked]
> Date: Sat, 6 Nov 2010 21:35:07 -0600
> To: [email-masked]
> CC: [email-masked]
> 
>

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 09 Nov 2010 23:56:23 +0800

Hi,

On 2010-11-07 13:26 Bernard Aboba said the following:
> At this point, TRAC is being used by quite a few WGs, so I had
> assumed (perhaps naively) that it was fully supported IT
> infrastructure, which would include backups.

Other people have said earlier in this thread that the WG Trac instances
are being backed up, and I've said so before, so I'm not sure why people
keep coming back to this incorrect idea that they aren't...

The Trac instances on tools.ietf.org _are_ being backed up.  And more --
see below.

> For example, I use the tools on tools.ietf.org quite a bit, and would
> be impacted substantially were this site to disappear.   I understand
> this site is not really "official" but I would still hope that it is
> being backed up.   Is that silly of me?

In addition to backing up important data, the tools site and its data is
replicated on 5 servers in order to safeguard not only the data but the
service.

Regards,

	Henrik