Subject: WG chair lunch -> how to run meeting efficiently?

From: Benoit Claise <[email-masked]>
Date: Fri, 12 Nov 2010 23:59:31 +0800

Margaret,

Nice presentation during the WG chair lunch.
What would be helpful is a 10 points (or whatever number) summary email, 
which could be sent to new and potentially existing WGs about "how to 
run a meeting efficiently". In this particular case, I'm mainly 
interested in the participant interactions, a kind of do/don't list. 
Simple things such as: don't present editorial changes, use the time to 
discuss open issues, post the slides 1 day in advance, discuss your 
draft on the mailing before present, etc...
For example, I co-chair the EMAN WG, which is brand new and therefore 
contains many newcomers to the IETF. Such a summary would have been 
helpful.

Regards, Benoit.

---

From: Olafur Gudmundsson <[email-masked]>
Date: Sat, 13 Nov 2010 06:20:23 +0800

> contains many newcomers to the IETF. Such a summary would have been

This brings up one of my ideas on how to run the IETF better.

New WG chairs should have access to an experienced WG chair as a mentor.

The role of the mentor is simply to answer questions, give 
ideas/pointers, observe meetings, review postings
before sending them out, help out with managing AD's.

	Comments, if people think this is useful and we can create a list of 
volunteers. I have no clue as how to allocate mentors, but in general I 
think it would be helpful if the mentors came from different areas, but 
not always the case.

	Olafur

---

From: Jeffrey Hutzelman <[email-masked]>
Date: Fri, 12 Nov 2010 20:54:10 -0500

> New WG chairs should have access to an experienced WG chair as a mentor.

New WG chairs should really be paired with an experienced co-chair.

---

From: Flemming Andreasen <[email-masked]>
Date: Sat, 13 Nov 2010 09:59:56 +0800

Sounds like a good idea. In most cases, I suspect new WG chairs will be 
co-chairing with a more experienced chair, however having a mentor 
observe from the WG point of view is probably helpful anyway. Come to 
think of it, I think many WGs could benefit from such feedback in general.

Thanks

-- Flemming

---

From: "David Harrington" <[email-masked]>
Date: Sat, 13 Nov 2010 17:42:39 +0800

Hi,

The mentor approach is a nice idea, but I think it has been overtaken
by events - this would be especially useful if the new chair was
alone, but most WGs now get two chairs.

I think most ADs try to pair a new chair with an experienced chair, so
the new chair gets on the job training. 

dbh

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Olafur Gudmundsson
> Sent: Saturday, November 13, 2010 6:20 AM
> To: [email-masked]
> Subject: Re: WG chair lunch -> how to run meeting efficiently?
>

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Sun, 14 Nov 2010 23:09:02 +0100

I must admit I thought much of this was happening already.

Every new chair in the RAI area seems to have got paired with an experienced chair.

And I am pretty certain that when I took over a SIP WG co-chair position a number of years back, as well as Dean being the experienced co-chair I was paired with, that Spencer Dawkins was doing some sort of monitoring role in the background, informal or formal, although noone ever said anything.

And of course all WGs have a responsible AD, many of whom have considerable experience of chairing WGs as well.

regards

Keith

> [mailto:[email-masked]] On Behalf Of Jeffrey Hutzelman
> Sent: Saturday, November 13, 2010 1:54 AM
> To: Olafur Gudmundsson; [email-masked]
> --On Saturday, November 13, 2010 06:20:23 AM +0800 Olafur 
> Gudmundsson <[email-masked]> wrote:
> 
> >> What would be helpful is a 10 points (or whatever number) summary 
> >> email, which could be sent to new and potentially existing 
> WGs about 
> >> "how to run a meeting efficiently". In this particular case, I'm 
> >> mainly interested in the participant interactions, a kind 
> of do/don't list.
> >> Simple things such as: don't present editorial changes, 
> use the time 
> >> to discuss open issues, post the slides 1 day in advance, discuss 
> >> your draft on the mailing before present, etc...

---

From: Fred Baker <[email-masked]>
Date: Mon, 15 Nov 2010 06:40:28 +0800

As I was sitting in the meeting, I found myself reflecting on how different various working groups can be. In BMWG on Thursday, we spent probably a good half hour in a discussion of a draft I had filed and I walked away with a lot to think about. In v6ops Friday, we had a knock-out-drag-down discussion and ten shorter presentations/discussions. In both cases, having prepared slides to illustrate points and manage discussions was, I thought, useful. Yes, nobody wants a report on the status of a topic, but having a picture to point at without taking time to draw it on a white board can be very useful. And for folks in which English is not their primary language or that are not used to public speaking, words on a screen can help them get their points across.

I don't want to argue for "death by powerpoint", but the idea of precluding its use seemed over the top.

---

From: Fred Baker <[email-masked]>
Date: Mon, 15 Nov 2010 11:47:41 +0800

On Nov 15, 2010, at 11:19 AM, Glen Zorn wrote:

> Fred Baker [mailto://[email-masked]] writes:
> 
>> As I was sitting in the meeting, I found myself reflecting on how
>> different various working groups can be. In BMWG on Thursday, we spent
>> probably a good half hour in a discussion of a draft I had filed and I
>> walked away with a lot to think about. In v6ops Friday, we had a knock-
>> out-drag-down discussion and ten shorter presentations/discussions. In
>> both cases, having prepared slides to illustrate points and manage
>> discussions was, I thought, useful. Yes, nobody wants a report on the
>> status of a topic, but having a picture to point at without taking time
>> to draw it on a white board can be very useful. 
> 
> Yes, assuming that the presenter knew in advance what the sticky parts would
> be (for example, if there had previously been serious discussion of the
> draft on the list).

Definitely required. 

>> And for folks in which
>> English is not their primary language or that are not used to public
>> speaking, words on a screen can help them get their points across.
> 
> The lack of English language expertise is a good argument (though I would
> note that in many cases the slides are as indecipherable to a native English
> reader as an extemporaneous comment might be) but IMHO WG meetings aren't
> public speaking engagements.

One could argue that every geek's first language is "geek", and English is at best a second language. At least that's what the RFC Editor tells us. :-)

No, they are not public speaking in the sense of giving a sermon or a keynote. That said, most people (you may be an exception) *become* comfortable standing in front of a group, and it takes practice. I have had my share of people standing in the front of v6ops and other meetings feeling like their pants were around their ankles. 

> I don't recall suggesting that we preclude the use of PowerPoint (though
> it's not that bad of an idea); what I did suggest is changing the default
> from slides to no slides.

It came across to me as "don't allow powerpoint at all". If I misunderstood, I apologize.

---

From: "Glen Zorn" <[email-masked]>
Date: Mon, 15 Nov 2010 10:19:06 +0700

---

From: Yaakov Stein <[email-masked]>
Date: Mon, 15 Nov 2010 08:16:48 +0000

> what I did suggest is changing the default from slides to no slides.

I think that would be a very poor idea.

Putting together a concise slide deck forces the speaker to think ahead of time
of what he/she wants to say, to shorten the presentation to the essentials,
and to remain focused on them while speaking.

As mentioned before, slide decks are very important for people whose English language skills are lacking
(sometimes it is the only way I understand what is being said).

It also lets the chairs know beforehand what the speaker wants to say,
and how much time to allocate for this topic.
I agree that we don't need a last slide that says "I propose making this draft a WG item"
to which the chair always replies "take it to the list".
But a last slide that says "I think the WG must decide right now between method 1 and method 2"
tells the chairs that time needs to be allocated for discussion at the mike.

Y(J)S

---

From: Andrew Sullivan <[email-masked]>
Date: Mon, 15 Nov 2010 09:49:17 -0500

> and to remain focused on them while speaking.

If that in fact happened, then I would agree with you.  The slides I
too often see, however, do not actually do this.  Sometimes there are
whole paragraphs on the screen.  And there is the lamentable practice
of putting whole propositions up and then reading them to the audience
-- a presentation that would, as a matter of fact, be better prepared
as an email.
 
> As mentioned before, slide decks are very important for people whose
> English language skills are lacking (sometimes it is the only way I
> understand what is being said).

Again, if that is the case, why isn't it better sent as an email to
the list?  If you can better understand what you are reading than what
you are hearing -- i.e. if the presentation is more about putting
across one point of view than about hammering out agreement on a
particular item -- then I think the WG meeting time is being used less
well than it could be.

And I say all of this deeply conscious of a couple presentations in
DNSEXT last week that violated all those precepts.  (In my defence,
I'll note that we ended up assigned more time than we actually needed
and asked for.  Two of the presentations resulted in enough questions
that we took the remaining time and got actual work done on the drafts
in small breakout sessions in the room.  So at least that part
worked.)

A

-- 
Andrew Sullivan
[email-masked]
Shinkuro, Inc.

---

From: Yaakov Stein <[email-masked]>
Date: Mon, 15 Nov 2010 15:04:31 +0000

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Andrew Sullivan
Sent: Monday, November 15, 2010 16:49
To: [email-masked]
Subject: Re: WG chair lunch -> how to run meeting efficiently?

> whole paragraphs on the screen.  

If the WG chair believes that the slides are a waste of session time,
he/she should tell the presenter that, and even take back the presenter's slot.

> And there is the lamentable practice

Once again, it is the chair's call.

> particular item -- then I think the WG meeting time is being used less

I don't understand the connection.
Why do you believe that people who are not proficient in English
do not have important items to raise, and that people who speak well
all use session time optimally ?

I was talking about people with important issues requiring WG decisions, 
who just happen to have strong accents or problems in expressing themselves in English.

> in small breakout sessions in the room.  So at least that part

I am definitely in favor of forming design teams to work during the IETF week or afterwards.
However, such work then should be presented to the WG, preferably in a few well-crafted slides.

Y(J)S

---

From: Andrew Sullivan <[email-masked]>
Date: Mon, 15 Nov 2010 10:23:19 -0500

> However, such work then should be presented to the WG, preferably in a few well-crafted slides.

In our case, we intend that the work is presented to the WG in the
form of a well-crafted Internet Draft.

A

-- 
Andrew Sullivan
[email-masked]
Shinkuro, Inc.

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Mon, 15 Nov 2010 19:42:35 +0100

> If the WG chair believes that the slides are a waste of 
> session time, he/she should tell the presenter that, and even 
> take back the presenter's slot.
>

And there we have the problem of people not providing the slides in time for chairs to get them up on the server, let alone review them properly.

Even threatening to put them in the same position in the room as they cause the remote participants to be in, i.e. doing the work without slides, doesn't seem to work.

And some of the worst people at this are people who are IETF regulars, and even WG chairs.

This meeting was not too bad for my group, but I well remember a few people coming to me with a stick after the agenda had been bashed.

Keith 

> [mailto:[email-masked]] On Behalf Of Yaakov Stein
> Sent: Monday, November 15, 2010 3:05 PM
> To: Andrew Sullivan; [email-masked]
> Subject: RE: WG chair lunch -> how to run meeting efficiently?
> 
> [mailto:[email-masked]] On Behalf Of Andrew Sullivan
> >> Putting together a concise slide deck forces the speaker to think 
> >> ahead of time of what he/she wants to say, to shorten the 
> >> presentation to the essentials, and to remain focused on 
> them while speaking.
> 
> If the WG chair believes that the slides are a waste of 
> session time, he/she should tell the presenter that, and even 
> take back the presenter's slot.
> 
> Why do you believe that people who are not proficient in 
> English do not have important items to raise, and that people 
> who speak well all use session time optimally ?
> 
> I was talking about people with important issues requiring WG 
> decisions, who just happen to have strong accents or problems 
> in expressing themselves in English.
>

---

From: "Joel M. Halpern" <[email-masked]>
Date: Mon, 15 Nov 2010 14:54:33 -0500

No matter what approach we use, there will be some bad presentations.
There also always be some working groups that are run in a fashion that 
other WG chairs think is wrong.

With regard to slides, I find them useful for multiple purposes.
1) As a chair, when I get the slides in advance, I can send them back 
and say "this does not fit for these reasons.  If what you want to do is 
X, that would be reasonable and here is how to do it."
1') It also lets me make sure my presenter has gotten the message 
"short, sweet, and to the point."

As a presenter, not only does putting the slides together help me 
organize my thoughts, but when I am presenting it helps me remember what 
order I wanted to cover which points in.  No, I don't read my slides.
The diagrams issue is often important, although I draw such bad 
diagrams, with or without tools, that I just tend to stay away from them 
for my own presentations.

Someone did actually suggest to me that we should go back to foils. 
Please,no.  I hated using those.  They were a pain to prepare, a pain to 
use, and tended to have all sorts of interesting problems.  And no, 
marking them up on the fly was NOT as easy as some folks remember it.  I 
hated having to do so.
Similarly, while white boards or poster boards sound nice, please 
remember the size of the room.  Almost no one will be able to see what 
is drawn on a poster board.
Sorry, we can not pretend we are in rooms of a dozen people, all of whom 
are very knowledgeable and very skilled.

And do remember that for many purposes, context setting is very helpful. 
  You as the presenter of a current document can of course remember all 
of teh discussion, and exactly what state the email list left things. 
The participants, even the active ones, are focused on lots of things. 
Getting folks on track is often important if we are going to make 
progress.  No, we should not waste time on long rehashes of the agreed 
protocol and approach.  But a sentence or two reminding people of what 
the problem is, what the approach is, and where the WG stands can often 
help keep everyone on the same page.

Yours,
Joel M. Halpern

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 16 Nov 2010 10:35:21 +0700

> and to remain focused on them while speaking.

In the ideal world, maybe; in mine, the slide decks expand to include all
forms of basically useless nonsense, 90% of which can be gleaned from other
sources with very minor effort.

> English language skills are lacking

Of course, this can't be done.

> tells the chairs that time needs to be allocated for discussion at the

Unless your idea of a WG is some kind of speaker's bureau (kind of sounds
like it), this is the only slide necessary.

---

From: Yaakov Stein <[email-masked]>
Date: Tue, 16 Nov 2010 05:01:29 +0000

> And no, marking them up on the fly was NOT as easy as some folks remember it.  
> I hated having to do so.
> Similarly, while white boards or poster boards sound nice, 
> please remember the size of the room.  
> Almost no one will be able to see what is drawn on a poster board.

The solution to both of these problems, a solution common in other SDOs
and which I have occasionally seen in the IETF as well,
is to open a document (slides or text) on the chair's machine,
and edit it in real-time.  Assuming the chair can type reasonably quickly.

Y(J)S

---

From: Yaakov Stein <[email-masked]>
Date: Tue, 16 Nov 2010 05:18:11 +0000

> like it), this is the only slide necessary.

How many WGs do you attend that work the way you describe ?

All the chairs I have seen allow the presenter to explain the problem
(even if this means a bit of review to refresh the memory of attendees)
before putting up the slide with "issues to be resolved".

And I think this is the right thing to do. 
And apparently so do most of the other chairs.

Y(J)S

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 16 Nov 2010 12:28:18 +0700

Joel M. Halpern [mailto://[email-masked]] writes:

...

> are very knowledgeable and very skilled.

There's no need to pretend: usually we _are_ in a room with a dozen (or
less) people who are knowledgeable and skilled.  I guess that the real
question is how much we want to pander to the hundred or so people in the
room who are neither,

> help keep everyone on the same page.

OK, and this requires PowerPoint, an expensive projector, the associated
set-up time, etc. because...

> ahead of time

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 16 Nov 2010 13:01:14 +0700

> (even if this means a bit of review to refresh the memory of attendees)

Another basic question: is the intended audience "attendees" (i.e., anybody
willing to part with the price of a ticket) or "participants" (those brave
few who have actually read the draft and thought at least a little bit about
it).

> before putting up the slide with "issues to be resolved".

A large percentage of the slide shows I've seen don't even contain a slide
with "issues to be resolved" and if they do, a large percentage of those
issues are minor things that could be dealt with easily on the mailing list.
Just to make myself clear, I am _not_ making a blanket condemnation of PP
usage in WG meetings: it is undoubtedly the perfect tools in some
situations.  My contention is that those situations are far outnumbered by
others in which a slide show is at best a waste of time.  It may come down
to a very basic question: are we physically present together to work on
things that require f2f interaction or not?  If not, let the shows go on...

---

From: Marshall Eubanks <[email-masked]>
Date: Tue, 16 Nov 2010 01:13:57 -0500

> few who have actually read the draft and thought at least a little bit about

You seem to be assuming that this is a binary division, but it is more commonly a continuum. 

A little bit of explanation of the issue at hand (which is not generally the same as 
the draft in question) can help move some people up the curve towards the "participant" 
category, which can be a good investment of time.

As always, YMMV.

Regards
Marshall

---

From: Yaakov Stein <[email-masked]>
Date: Tue, 16 Nov 2010 06:13:22 +0000

> few who have actually read the draft and thought at least a little bit about

Yes, that is the question. I think that we have to admit that in every room of 100+ attendees
there are 10-20 people who have actually read most of the drafts,
and the rest are there because they have nowhere else to sit and do their email.

There are two things we can do regarding this problem.
1) We (the IETF) can provide more chairs outside the meeting rooms and smaller meeting rooms
2) We (the chairs) can do more to get more people involved in our work.

> issues are minor things that could be dealt with easily on the mailing list.

That goes back to my first email. 
In such cases the chair should simply retract the slot,
unless it serves another purpose 
(e.g., increasing the interest level so that next meeting more people will have read the drafts).

Y(J)S

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 16 Nov 2010 15:44:42 +0700

Marshall Eubanks [mailto:[email-masked]] writes:

> You seem to be assuming that this is a binary division, 

Actually, I'm not but it certainly _could_ be: for example, a certain level
of common knowledge (say, having actually read at least one of the drafts
under discussion) might be required to qualify as a participant.

> but it is more
> commonly a continuum.

Once again, how much marketing do you want to do in the precious f2f time
you have?  Apparently more than I...

---

From: Joel Jaeggli <[email-masked]>
Date: Tue, 16 Nov 2010 20:03:42 +0800

On 11/16/10 2:42 AM, DRAGE, Keith (Keith) wrote:
>> If the WG chair believes that the slides are a waste of session
>> time, he/she should tell the presenter that, and even take back the
>> presenter's slot.
>> 
> 
> And there we have the problem of people not providing the slides in
> time for chairs to get them up on the server, let alone review them
> properly.
> 
> Even threatening to put them in the same position in the room as they
> cause the remote participants to be in, i.e. doing the work without
> slides, doesn't seem to work.
> 

We're responsible for running the meeting, so we start by leading by
example, with the agenda, and the minutes. We enforce deadlines for
deliverables, and we use discrition sparingly. Being an IETF oldtimer is
not carte blanche to abuse the WG process in fact the opposite is should
be true.

> This meeting was not too bad for my group, but I well remember a few
> people coming to me with a stick after the agenda had been bashed.
>