Subject: How to add a draft to the "Related Documents" section of the datatracker?

From: Ben Niven-Jenkins <[email-masked]>
Date: Fri, 25 Feb 2011 08:45:09 +0000

Fellow WG chairs,

In L3VPN the chairs have had a request by an author to add two drafts to the "Related Documents" section of the WG's datatracker page.

One draft wasn't picked up automatically because the author hasn't followed the normal naming convention and didn't include l3vpn in the document filename (but the document is now on revision -04 so renaming would be non-ideal).

The other is owned by a different WG but does have applicability to L3VPN.

Does anyone know how (or if) I can add them to the list of related documents?

Thanks in advance
Ben

---

From: Peter Musgrave <[email-masked]>
Date: Fri, 25 Feb 2011 05:42:54 -0500

Hi Ben, 

I did some work in that code on the last code sprint. As far as I remember the search is keying off the WG name. 

I can put in a ticket on this for the next sprint in March.  

I have also CCed Henrick. Perhaps he has better insight...

Regards, 

Peter Musgrave

---

From: Brian Haberman <[email-masked]>
Date: Fri, 25 Feb 2011 07:51:39 -0500

On 2/25/11 5:42 AM, Peter Musgrave wrote:
> Hi Ben,
> 
> I did some work in that code on the last code sprint. As far as I
> remember the search is keying off the WG name.
> 

Just thinking off of the top of my head, and with the caveat that it is
early in the morning... Would it make sense to have a mechanism in the
draft submission tool that allows an author to indicate WGs that their
draft may be related too?

Brian

>> In L3VPN the chairs have had a request by an author to add two
>> drafts to the "Related Documents" section of the WG's datatracker
>> page.
>> 
>> One draft wasn't picked up automatically because the author hasn't
>> followed the normal naming convention and didn't include l3vpn in
>> the document filename (but the document is now on revision -04 so
>> renaming would be non-ideal).
>> 
>> Thanks in advance Ben

---

From: "David Harrington" <[email-masked]>
Date: Fri, 25 Feb 2011 11:21:06 -0500

Hi,

That capability already exists by including the WG name in the
filename.

I do not think it would be good to add an option where the author gets
to declare their draft is applicable to a whole bunch of WGs. This
might encourage WG shopping, trying to find a WG that would take an
interest in the draft. Currently, the author needs to decide in
advance which WG is an appropriate venue for their proposal (which
means they need to do some homework first). I would be concerned about
(inadvertent or deliberate) abuse of this option by authors.

It might make sense to me to allow WG chairs to add a draft as
relevant, but how important is this? A WG can always look at
individual drafts, and when the WG decides it really is relevant, they
can adopt it as a WG draft.  IIRC, datatracker extensions for WG
Chairs will have the ability to mark a draft as "being considered" by
a WG. 

dbh

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Brian Haberman
> Sent: Friday, February 25, 2011 7:52 AM
> To: [email-masked]
> Subject: Re: How to add a draft to the "Related Documents" 
> section of thedatatracker?
> 
> >> The other is owned by a different WG but does have applicability
to
> >> L3VPN.
> >> 
> >> Does anyone know how (or if) I can add them to the list of
related
> >> documents?

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 25 Feb 2011 17:31:52 +0100

On Feb 25, 2011, at 17:21, David Harrington wrote:

> might encourage WG shopping,

+1.

Allowing the WG chair to add a draft to the WG would be a good new function.

Gruesse, Carsten

---

From: Ben Niven-Jenkins <[email-masked]>
Date: Fri, 25 Feb 2011 16:33:27 +0000

David,

On 25 Feb 2011, at 16:21, David Harrington wrote:
> relevant, but how important is this?

As I kicked off the thread...

I don't think it's that important. As it was requested by an author and that author is an experienced IETFer I just assumed the capability already existed and I didn't know how to access it.

Ben

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Sat, 26 Feb 2011 16:57:36 +0100

In my view, the related documents section should be the list of documents where respective author considers this is the WG to adopt the draft. As such any such draft should only ever appear in one WGs related documents list.

And as such, there is an easy existing way for the author to control that happening!

Regards

Keith

> [mailto:[email-masked]] On Behalf Of David Harrington
> Sent: 25 February 2011 16:21
> To: 'Brian Haberman'; [email-masked]
> Subject: RE: How to add a draft to the "Related Documents" 
> That capability already exists by including the WG name in 
> the filename.
> 
> I do not think it would be good to add an option where the 
> author gets to declare their draft is applicable to a whole 
> bunch of WGs. This might encourage WG shopping, trying to 
> find a WG that would take an interest in the draft. 
> Currently, the author needs to decide in advance which WG is 
> an appropriate venue for their proposal (which means they 
> need to do some homework first). I would be concerned about 
> It might make sense to me to allow WG chairs to add a draft 
> as relevant, but how important is this? A WG can always look 
> at individual drafts, and when the WG decides it really is 
> relevant, they can adopt it as a WG draft.  IIRC, datatracker 
> extensions for WG Chairs will have the ability to mark a 
> draft as "being considered" by a WG. 
> 
> dbh
> 
> 
> > Just thinking off of the top of my head, and with the 
> caveat that it 
> > is early in the morning... Would it make sense to have a 
> mechanism in
> the

---

From: Adam Roach <[email-masked]>
Date: Sat, 26 Feb 2011 17:35:44 -0600

I'll admit that it was more the exception than the rule, but we did have 
a couple of documents go through -- RFCs 3486 and 5049 -- that were 
quite legitimately related equally to the SIP and ROHC working groups. 
If we were doing that kind of work presently, I would think it very much 
should appear in both lists.

It would be nice if the tools didn't get in the way of doing so.

/a

---

From: Barry Leiba <[email-masked]>
Date: Sun, 27 Feb 2011 13:37:08 -0500

> couple of documents go through -- RFCs 3486 and 5049 -- that were quite
> legitimately related equally to the SIP and ROHC working groups. If we were
> doing that kind of work presently, I would think it very much should appear
> in both lists.
>

Agreed.  I would very much like a way for the chairs (not the authors)
to mark a document as "related".  I'd similarly like a way for the
chairs to *unmark* a document, even if the author has put the WG name
in the filename.

Barry

---

From: Carsten Bormann <[email-masked]>
Date: Sun, 27 Feb 2011 20:25:25 +0100

> chairs to *unmark* a document, even if the author has put the WG name

+1

Now if we had a way to mark a non-WG document as replaced-by a WG document (this is often not a 1:1 relationship) without going through the secretariat...

Gruesse, Carsten

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Mon, 28 Feb 2011 01:38:38 +0100

I believe by the time we reached that stage, it was already a WG item in one group with some relation in the other. 

There is possibly more call for a separate section that is WG items of another group that are of direct interest to this group.

Regards

Keith 

> From: Adam Roach [mailto:[email-masked]] 
> Sent: 26 February 2011 23:36
> To: DRAGE, Keith (Keith)
> Cc: David Harrington; 'Brian Haberman'; [email-masked]
> I'll admit that it was more the exception than the rule, but 
> we did have a couple of documents go through -- RFCs 3486 and 
> 5049 -- that were quite legitimately related equally to the 
> SIP and ROHC working groups. 
> If we were doing that kind of work presently, I would think 
> it very much should appear in both lists.
> 
> > In my view, the related documents section should be the 
> list of documents where respective author considers this is 
> the WG to adopt the draft. As such any such draft should only 
> ever appear in one WGs related documents list.
> >
> >> I do not think it would be good to add an option where the author 
> >> gets to declare their draft is applicable to a whole bunch of WGs. 
> >> This might encourage WG shopping, trying to find a WG that 
> would take 
> >> an interest in the draft.
> >> Currently, the author needs to decide in advance which WG is an 
> >> appropriate venue for their proposal (which means they need to do 
> >> some homework first). I would be concerned about (inadvertent or 
> >> deliberate) abuse of this option by authors.
> >>
> >> individual drafts, and when the WG decides it really is relevant, 
> >> they can adopt it as a WG draft.  IIRC, datatracker 
> extensions for WG