Subject: WG Charter Milestones

From: Russ Housley <[email-masked]>
Date: Thu, 14 Apr 2011 12:43:38 -0400

IETF WG Chairs:

During the IESG evaluation of draft-ietf-genarea-charter-tool, the IESG talked about the best way to handle WG charter milestones.  One suggestion is that the IESG completely delegate milestone management to WG chairs.  Is this an idea that WG Chairs would embrace?

Russ

---

From: Andrew Sullivan <[email-masked]>
Date: Thu, 14 Apr 2011 12:51:39 -0400

> During the IESG evaluation of draft-ietf-genarea-charter-tool, the IESG talked about the best way to handle WG charter milestones.  One suggestion is that the IESG completely delegate milestone man…

I'm of two minds about this.

On the one hand, much of the work (at least in every case with which
I'm familiar) is already delegated to chairs, because the ADs expect
the chairs to be on top of this.  On the other hand, I worry that
without the check of ADs on chairs to push for realism and to insist
on measurable goals, the tendency of WGs to move their milestones in a
sort of perpetual rollover might be made worse.

A

-- 
Andrew Sullivan
[email-masked]
Shinkuro, Inc.

---

From: Jari Arkko <[email-masked]>
Date: Thu, 14 Apr 2011 19:57:35 +0300

We've gone through different approaches to following and enforcing 
milestones. The approach that seems to work best from my perspective is 
just attempting to keep them as best current estimates of what documents 
will be produced and when. Updating frequently if needed. If we start 
from that perspective then it makes sense to keep the process as 
lightweight and easy as possible.

The current system is that chairs propose updates, ADs approve, and 
secretariat makes the actual change. For me, I approve almost all of the 
proposals from my chairs. If there are questions its usually in the form 
of a question from the chair: can we do X or is this kind of a document 
split from one work item still OK from the point of view of the charter.

My opinion is that we should eliminate the AD and the secretariat from 
the loop and let the chairs do their job. The ADs can intervene as they 
see the events go by, but they should not be on the critical path to 
approve something. Eliminating secretariat from the loop would of course 
require some new tool support, perhaps to be done in the same time as we 
produce the charter management tool.

Jari

---

From: Scott Brim <[email-masked]>
Date: Thu, 14 Apr 2011 12:59:16 -0400

On Thu, Apr 14, 2011 at 12:51, Andrew Sullivan <[email-masked]> wrote:

> > During the IESG evaluation of draft-ietf-genarea-charter-tool, the IESG
> talked about the best way to handle WG charter milestones.  One suggestion
> is that the IESG completely delegate milestone management to WG chairs.  Is
> this an idea that WG Chairs would embrace?
>

Therefore IMHO "milestone management" should be done by the chairs.  The ADs
monitor, guide and approve, but do not manage directly.

Scott

---

From: marcelo bagnulo braun <[email-masked]>
Date: Thu, 14 Apr 2011 19:01:59 +0200

this makes sense to me.

El 14/04/11 18:57, Jari Arkko escribió:
> milestones. The approach that seems to work best from my perspective 
> is just attempting to keep them as best current estimates of what 
> documents will be produced and when. Updating frequently if needed. If 
> we start from that perspective then it makes sense to keep the process 
> as lightweight and easy as possible.
>
> secretariat makes the actual change. For me, I approve almost all of 
> the proposals from my chairs. If there are questions its usually in 
> the form of a question from the chair: can we do X or is this kind of 
> a document split from one work item still OK from the point of view of 
> the charter.
>
> the loop and let the chairs do their job. The ADs can intervene as 
> they see the events go by, but they should not be on the critical path 
> to approve something. Eliminating secretariat from the loop would of 
> course require some new tool support, perhaps to be done in the same 
> time as we produce the charter management tool.
>
> Jari
>
>

---

From: Joe Touch <[email-masked]>
Date: Thu, 14 Apr 2011 10:08:35 -0700

Hi, all,

Although Jari's proposal works when the WG chairs are already managing 
things, it doesn't provide the necessary oversight for things like 
schedule creep, scope creep, etc. - which are best managed in advance, 
rather than corrected post-facto, IMO.

I think the current mechanism is good, and presumably it works smoothest 
when the WG chairs drive the process and creep doesn't need correction. 
However, IMO there still needs to be accountability and enforcement of a 
broad oversight at the AD level to ensure this happens.

I.e., I'd leave the current mechanism, but work to ensure that the 
common case is Jari's - where only cursory review is required and most 
changes are approved.

Joe

---

From: "Andrew G. Malis" <[email-masked]>
Date: Thu, 14 Apr 2011 13:19:48 -0400

In the PWE3 WG, my co-chair and I recently updated the milestones. We
did a draft ourselves, and then had a call to discuss the proposed
revisions with our AD. We found the discussion to be very valuable,
and we ended up with a better set of milestones as a result.

Cheers,
Andy

On Thu, Apr 14, 2011 at 1:08 PM, Joe Touch <[email-masked]> wrote:
> things, it doesn't provide the necessary oversight for things like schedule
> creep, scope creep, etc. - which are best managed in advance, rather than
> corrected post-facto, IMO.
>
> I.e., I'd leave the current mechanism, but work to ensure that the common
> case is Jari's - where only cursory review is required and most changes are
> approved.
>
> Joe
>

---

From: Al Morton <[email-masked]>
Date: Thu, 14 Apr 2011 13:25:47 -0400

Russ, all,

I'd like to see the process assisted through web automation,
even if it remains in current the approval cycle.
Preparing the e-mail by copying existing milestones,
making changes, finding the right secretariat address
(yes, it's on a web page, somewhere...) all takes more
time than it should.
(if this is the point of draft-*-charter-tool, great!
  that's another one I haven't made time to read...)

Other approval model:
   WG Chairs can revise dates, ADs get notice.
   (is the above the scope of what was meant by "milestone management"?)
   WG Chairs can *add/remove* a milestone, with AD approval.

regards,
Al

At 01:08 PM 4/14/2011, Joe Touch wrote:
>Hi, all,
>
>Although Jari's proposal works when the WG chairs are already 
>managing things, it doesn't provide the necessary oversight for 
>things like schedule creep, scope creep, etc. - which are best 
>managed in advance, rather than corrected post-facto, IMO.
>
>I think the current mechanism is good, and presumably it works 
>smoothest when the WG chairs drive the process and creep doesn't 
>need correction. However, IMO there still needs to be accountability 
>and enforcement of a broad oversight at the AD level to ensure this happens.
>
>common case is Jari's - where only cursory review is required and 
>most changes are approved.
>
>Joe
>

---

From: Jari Arkko <[email-masked]>
Date: Thu, 14 Apr 2011 20:25:27 +0300

Joe,

> rather than corrected post-facto, IMO.

I'll just point out that its really the charter text part that restricts 
the scope. If you are chartered to work on Bar, the chairs can split 
milestones up and reschedule documents relating to Bar, e.g., from one 
document to multiple, reflect the current estimated schedule, etc. But 
they should not suddenly add a milestone for Foo. It would be a 
violation of their charter.

That being said, if they are intent on adding inappropriate work on Foo, 
they could authorize WG drafts, presentation slots, and allow list 
discussion on Foo. That is, if I wasn't paying attention. So I'm not 
sure the milestone is the critical thing where we need advance 
authorization. Not because none of this ever happens -- it does happen 
now and then. But some of these other things are IMO more important than 
the milestone list, and I think we all can use our time in better ways, 
such as commenting on documents rather than milestones...

Jari

---

From: Ross Callon <[email-masked]>
Date: Thu, 14 Apr 2011 13:27:59 -0400

I think that there are two parts to this:

 1) What tasks/documents are listed in the milestones

 2) The specific date listed for each milestone

If we allowed chairs to put any document or task into a milestone that they wanted to, then the chairs could pretty much add anything to their charter by just adding a milestone (what would happen if the new milestone was blatantly in opposition to the written text of the charter is tbd -- but presumably there would be a check against this of some sort). This would seem to increase the possibility of overlap between different WGs. I think that the ADs should continue to need to approve any new milestone (ie, adding a milestone that wasn't already there -- at least by confirming that it is consistent with the existing WG text). 

Regarding changing the dates: I could go either way. First of all dates seem to mostly be chosen with the assumption that we have people signed up to do the work and agreement on precisely what work needs to be done, and that authors won't get pulled away by other unforeseen tasks. Thus dates are almost always quite optimistic. If a WG doesn't meet its dates, we don't generally do anything other than eventually change the dates, or possibly the ADs gently prod the WG chairs to try to speed things up. 

Occasionally the dates can be used by ADs to threaten a WG. This can be quite effective in cases where it is very difficult to get a WG to come to agreement on work, but where all concerned want *some* useful work to happen. 

Back when I was AD, I recall that nearly all ADs were at some point behind in some aspect(s) of their work. This is understandable considering how much time and energy the AD job consumes. However, updating the dates on milestones in my recollection was not the part of the job that took up time nor energy (with the understanding that energy can often be a bigger challenge than time). 

Thus I guess mulling this over I don't see a motivation for a change. 

Ross

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Jari Arkko
Sent: Thursday, April 14, 2011 12:58 PM
To: Russ Housley
Cc: IETF WG Chairs
Subject: Re: WG Charter Milestones

Jari

---

From: Joe Touch <[email-masked]>
Date: Thu, 14 Apr 2011 10:29:42 -0700

Hi, Jari,

> violation of their charter.

Sure... but the enforcement of that. or perhaps a "conservative" 
interpretation of the scope of the charter, often happens by AD pushback ;-)

> such as commenting on documents rather than milestones...

The charter is updated very slowly (if at all), the milestones a bit 
less slowly; I don't think the milestones should be changing every IETF 
- if the load there is high, the AD pushback should be "stop shifting 
the milestones" or "the milestones aren't realistic".

Joe

---

From: Marc Blanchet <[email-masked]>
Date: Thu, 14 Apr 2011 13:58:07 -0400

> During the IESG evaluation of draft-ietf-genarea-charter-tool, the IESG talked about the best way to handle WG charter milestones.  One suggestion is that the IESG completely delegate milestone man…

yes. current process is too heavy. just get a web interface to update 
the milestones by the wg chairs, and have the AD receive an email 
notification of changes: to be informed, to catch some issues.

Marc.

-- 
=========
IPv6 book: Migrating to IPv6, Wiley. http://www.ipv6book.ca
Stun/Turn server for VoIP NAT-FW traversal: http://numb.viagenie.ca
DTN Implementation: http://postellation.viagenie.ca
NAT64-DNS64 Opensource: http://ecdysis.viagenie.ca

---

From: <[email-masked]>
Date: Thu, 14 Apr 2011 18:07:43 +0000

+1

On 4/14/11 12:58 PM, "ext Marc Blanchet" <[email-masked]> wrote:

>>talked about the best way to handle WG charter milestones.  One
>>suggestion is that the IESG completely delegate milestone management to
>>WG chairs.  Is this an idea that WG Chairs would embrace?
>>
>

---

From: "Dan Wing" <[email-masked]>
Date: Thu, 14 Apr 2011 11:31:13 -0700

+1.

-d

> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of [email-masked]
> Sent: Thursday, April 14, 2011 11:08 AM
> To: [email-masked]; [email-masked]

---

From: Sumanth Channabasappa <[email-masked]>
Date: Thu, 14 Apr 2011 13:57:21 -0600

+1

---

From: "Bert Wijnen \(IETF\)" <[email-masked]>
Date: Thu, 14 Apr 2011 20:11:28 +0200

I would think that that is fien.
If the responsibel AD gets a notification when a milestone is
changed, then he/she can always intervene (guide gently ;-))
if things get out of hand.

Bert
----- Original Message ----- 
From: "Russ Housley" <[email-masked]>
To: "IETF WG Chairs" <[email-masked]>
Sent: Thursday, April 14, 2011 6:43 PM
Subject: WG Charter Milestones

IETF WG Chairs:

During the IESG evaluation of draft-ietf-genarea-charter-tool, the IESG talked 
about the best way to handle WG charter milestones.  One suggestion is that the 
IESG completely delegate milestone management to WG chairs.  Is this an idea 
that WG Chairs would embrace?

Russ=

---

From: Glen Zorn <[email-masked]>
Date: Fri, 15 Apr 2011 09:12:57 +0700

> During the IESG evaluation of draft-ietf-genarea-charter-tool, the IESG talked about the best way to handle WG charter milestones.  One suggestion is that the IESG completely delegate milestone man…

What exactly does that mean?

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Thu, 14 Apr 2011 22:32:10 -0400

Since the WG chairs serve at the pleasure of the AD, I don't see a problem
here.

But in general my beef with WG milestones is that they are almost always set
too aggressively and on occasion are abused.

To take a non IETF example. I once went to an SDMI meeting. We had about
200-300 people in the room and it was imperative that the protocol be
standardized in time to get goods on the shelves by Xmas.

So no use cases, no requirements and a product proposal that no consumer was
ever going to buy.

And I am the lone voice saying 'hey guys, your problem here is how to
develop a market for making money from your content.'

SDMI folded fairly quickly, but I have been told countless times in a
variety of forums (including but not exclusive to IETF) that 'we have to do
X in Y months or the world as we know it will end' where (8 < Y < 18). And
not a single one of those has ever met the goal or come close to it (other
than WS-Security which had a different pathology).

This becomes pathological when the arbitrary timeframe is used to justify
cutting corners on the use cases and requirements, or as sometimes happens
to skew the requirements to keep out certain use cases or constraints that
are critical.

I think that part of the solution here has to be to force quite a few WGs to
spend more time on use cases and requirements and to grade them for how long
they take rather than how quickly they can pull a justification for their
pre-chosen scheme.

Cutting corners on the prep work does not make the process go any faster.
And the worst case scenario is not to be late with a spec, its to produce a
spec that nobody can deploy because it fails to meet critical constraints or
nobody wants to adopt because it does not meet their use cases.

Throwing the cat out the door as fast as possible should not be the only
measure we focus on.

The IETF is meant to be structured to encourage people working on different
parts of the IP stack to work together. Yet somehow we managed to have the
Internet Directory (DNS) and the Internet Directory based PKI more or less
ignoring each other for a decade. And now we have a group thats meant to be
bridging the gap that does not want to really engage with the contraints
imposed by either.

The reason that I think we need to rethink this 'faster-better' idea is that
in my view it is much better to produce a general framework that meets a
large number of use cases in two years than produce a one off special case
in a year. Yes, I know about the 80-20 rule, but let us imagine that DKIM
had been required to develop a story for how other security protocols could
pull keys from DNS. Not a complete worked spec, for every other protocol,
but a story.

Would that constraint have caused the work to take longer? I don't think so.
The reason I like constraints is that they take options off the table. And
the process of standards making is to eliminate options, not generate them.
So I don't think it would have slowed the work, it might have made it go
faster.

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Fri, 15 Apr 2011 12:43:19 +0200

I'm in favour of more flexibility.

However some working groups do have a habit of endorsing all and every proposal for work as a new milestone, and therefore end up with too many milestones and not enough focus on core issues of the work they already have.

On proposal may be for the AD to set a limit for a particular WG on the number of milestones it is allowed to have without reference back to the AD, creation beyond that limit requires AD review (possible of the whole set of milestones) and approval.

Regards

Keith

> Behalf Of Russ Housley
> Sent: 14 April 2011 17:44
> To: IETF WG Chairs
> is that the IESG completely delegate milestone management to WG chairs.
> Is this an idea that WG Chairs would embrace?
> 
> Russ

---

From: Klaas Wierenga <[email-masked]>
Date: Fri, 15 Apr 2011 12:55:47 +0200

On 4/15/11 12:43 PM, DRAGE, Keith (Keith) wrote:
> However some working groups do have a habit of endorsing all and
> every proposal for work as a new milestone, and therefore end up with
> too many milestones and not enough focus on core issues of the work
> they already have.
> 
> On proposal may be for the AD to set a limit for a particular WG on
> the number of milestones it is allowed to have without reference back
> to the AD, creation beyond that limit requires AD review (possible of
> the whole set of milestones) and approval.

But I am guessing that the AD is following the WG he is responsible for,
and changing milestones would require WG consensus I presume anyway, so
it is not as if changing milestones would go unnoticed. Wouldn't that
give the AD enough tools to influnce that kind of creep already?

Klaas

---

From: Jari Arkko <[email-masked]>
Date: Fri, 15 Apr 2011 15:06:48 +0300

Klaas,

> give the AD enough tools to influnce that kind of creep already?

Indeed. And if the chairs do silly things then the problem is not that 
the tools allow that, its that you hired the wrong guys :-)

Jari

---

From: Julien Meuric <[email-masked]>
Date: Fri, 15 Apr 2011 14:30:07 +0200

Or that you don't pay them enough... ;-)

Anyway, I would support moving to a more direct process for milestone 
updates: once deployed, the time saved is obvious and the drawbacks are 
not specific to that task.

Thanks,

Julien

---

From: Linda Dunbar <[email-masked]>
Date: Thu, 14 Apr 2011 22:18:11 +0000

+1

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Thursday, April 14, 2011 1:08 PM
To: [email-masked]; [email-masked]
Subject: Re: WG Charter Milestones

+1

---

From: "James M. Polk" <[email-masked]>
Date: Fri, 15 Apr 2011 13:52:57 -0500

+1

At 05:18 PM 4/14/2011, Linda Dunbar wrote:
>From: [email-masked] 
>[mailto:[email-masked]] On Behalf Of [email-masked]

---

From: Tina Tsou <[email-masked]>
Date: Fri, 15 Apr 2011 14:56:07 -0700

We keep our promises with one another – no matter what!

Best Regards,
Tina TSOU
http://tinatsou.weebly.com/contact.html

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Julien Meuric
Sent: Friday, April 15, 2011 5:30 AM
To: [email-masked]
Subject: Re: WG Charter Milestones

Or that you don't pay them enough... ;-)
[Pay them the respect from the community...]

Anyway, I would support moving to a more direct process for milestone 
updates: once deployed, the time saved is obvious and the drawbacks are 
not specific to that task.
[More direct, more efficiency.]

Thanks,

Julien

---

From: Fred Baker <[email-masked]>
Date: Fri, 15 Apr 2011 17:25:22 -0700

> During the IESG evaluation of draft-ietf-genarea-charter-tool, the IESG talked about the best way to handle WG charter milestones. One suggestion is that the IESG completely delegate milestone mana…

in my case, yes. The idea that I have to fundamentally think about rewording the reason I'm here to add a new working group document is simply not real in my part of the world. 

I could imagine that we somehow interlock an instruction from the WG Chair to the I-D folks to accept a draft-ietf-<wg> document with having a plan for the document. I could imagine acceptance of the plan for the document as being predicated on a conversation with the relevant AD. But those two done, yes, I think the conversation re the document should be between the secretariat and the WG Chair, perhaps using the materials manager or some variation on the data tracker.

---

From: Dean Willis <[email-masked]>
Date: Sat, 16 Apr 2011 17:45:41 -0500

On Apr 15, 2011, at 7:06 AM, Jari Arkko wrote:
> 
> Indeed. And if the chairs do silly things then the problem is not that the tools allow that, its that you hired the wrong guys :-)
> 

If the chairs aren't doing silly things, then they're clearly taking this whole IETF thing too seriously!

I propose all chairs wear tuxedo-print T-shirts for the Quebec City meetings. Can we get a milestone for that?

--
Dean

---

From: "David Harrington" <[email-masked]>
Date: Mon, 18 Apr 2011 09:09:03 -0400

Hi,

I prefer the current approach, where the chairs decide what the
milestones should be (within scope of the charter), but the AD
approves them BEFORE they are posted. 

I think the tool could allow chairs to enter updated milestones, and
then the AD is notified and needs to push an "approved" button.
I think this is FAR BETTER than having chairs publish a milestone that
the AD might disagree with, and then the AD has to fight to reject the
milestone. 

I recently had a situation where a WG wanted to add a milestone that
was consistent with some interpretations of the charter text. It
expanded the scope just slightly, in a manner that was somewhat
anticipated in the charter text. But the IESG was in discussions of
how to handle related technology directions. The chairs did not have
insight into those incomplete IESG discussions; the AD did have that
insight. If the chairs had been allowed to add the milestone without
AD approval, and accept WG drafts against that milestone, undoing this
would have been time-consuming for ADs and others, confusing to
participants, and irritating for all involved (and might lead to
time-consuming flame wars). The amount of work involved to undo this
would have greatly exceeded the time need for an AD to review the
proposal and push an approved button before publication.

I think the current approach works, and works well. It could be
enhanced by better tool support. I do not see a strong reason to
change the approach.

David Harrington
Director, IETF Transport Area
[email-masked] (preferred for ietf)
[email-masked]
+1 603 828 1401 (cell)

> [mailto:[email-masked]] On Behalf Of Jari Arkko

---

From: Donald Eastlake <[email-masked]>
Date: Mon, 18 Apr 2011 09:12:31 -0400

I tend to agree with David's tool proposal, much as it might be easier
for me as a WG chair to be able to directly set milestones to what I
wanted...

Thanks,
Donald
=============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 155 Beaver Street
 Milford, MA 01757 USA
 [email-masked]

---

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 18 Apr 2011 09:07:15 -0700 (PDT)

+1

>talked about the best way to handle WG charter milestones.  One suggestion  is 
>that the IESG completely delegate milestone management to WG chairs.  Is  this 
>an idea that WG Chairs would embrace?
> > 
> 
> yes. current process  is too heavy. just get a web interface to update the 
>milestones by the wg  chairs, and have the AD receive an email notification of 
>changes: to be  informed, to catch some issues.
> 
> Marc.

---

From: Robert Sparks <[email-masked]>
Date: Wed, 20 Apr 2011 10:37:18 -0500

At a minimum, the current method of modifying milestones encourages chairs and ADs
to talk about the milestone before it's added to the charter page.  This is an important
checkpoint, and it would be a mistake to skip it.

RjS

---

From: Robert Sparks <[email-masked]>
Date: Wed, 20 Apr 2011 10:40:51 -0500

When we start to work on a tool to manage milestones, we need to talk about more than just
how to encode the approval process into the tool. There have been proposals in the past to make it
easier to map documents to milestones for instance. What other features should be part of this discussion?

RjS

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Wed, 20 Apr 2011 18:04:19 +0200

I agree it would be useful to introduce a milestone / document mapping. This will generally be one to one, but could (in my view less usefully with exceptions) be one to many.

One thing I would like if we get such a mapping in place is that the milestone automatically gets marked as done when the mapped documents get publication requested (assuming the milestone is one of "Submit to IESG ..." category).

>From my perspective, this mapping should only exist for i-ds that are working group drafts. I think mapping author drafts to milestones will introduce a lot of other complexities we probably don't want to touch.

By the way - not everything about milestones needs AD checkpoint, changing the delivery dates doesn't need this at the moment in my understanding.

Regards

Keith

> Behalf Of Robert Sparks
> Sent: 20 April 2011 16:41
> To: Russ Housley
> Cc: IETF WG Chairs
> Subject: Additional topics related to managing WG Charter Milestones
>

---

From: Robert Sparks <[email-masked]>
Date: Wed, 20 Apr 2011 11:07:51 -0500

> By the way - not everything about milestones needs AD checkpoint, changing the delivery dates doesn't need this at the moment in my understanding.

Good point.

---

From: Adam Roach <[email-masked]>
Date: Wed, 20 Apr 2011 11:13:08 -0500

> I agree it would be useful to introduce a milestone / document mapping. This will generally be one to one, but could (in my view less usefully with exceptions) be one to many.

And, to be clear, the relationship can be one milestone to many 
documents, or one document to many milestones. I've seen it work both 
ways. I've yet to see a many-to-many setup, but I think it would be 
inappropriate for the tool to preclude such a relationship if the 
working group/chairs/ADs thought such a relationship made the most sense.

So, if we're talking schema restraints here, we need to ensure that a 
milestone can be linked to multiple documents, and that a document can 
be linked to multiple milestones.

/a

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Wed, 20 Apr 2011 18:21:01 +0200

Accepted.

However I would suggest that we should probably still work with a default of one-to-one in cases where there is not a real exception. Where work splits into two documents - it will generally be better to split the milestones as well.

Keith

> From: Adam Roach [mailto:[email-masked]]
> Sent: 20 April 2011 17:13
> To: DRAGE, Keith (Keith)
> Cc: Robert Sparks; Russ Housley; IETF WG Chairs
> Subject: Re: Additional topics related to managing WG Charter Milestones
> 
> > I agree it would be useful to introduce a milestone / document mapping.
> This will generally be one to one, but could (in my view less usefully
> with exceptions) be one to many.
>

---

From: "Richard L. Barnes" <[email-masked]>
Date: Wed, 20 Apr 2011 13:00:54 -0400

+1

---

From: <[email-masked]>
Date: Wed, 20 Apr 2011 13:01:51 -0400

Is that still the case when the two documents are the protocol or protocol changes and associated management interface or changes (e.g., MIB)?

Thanks,
--David

> From: [email-masked] [mailto:[email-masked]] On Behalf Of DRAGE, Keith (Keith)
> Sent: Wednesday, April 20, 2011 12:21 PM
> To: Adam Roach
> Cc: IETF WG Chairs; Russ Housley
> Subject: RE: Additional topics related to managing WG Charter Milestones
> 
> Accepted.
> 
> However I would suggest that we should probably still work with a default of one-to-one in cases
> where there is not a real exception. Where work splits into two documents - it will generally be
> better to split the milestones as well.
> 
> Keith
>

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Wed, 20 Apr 2011 13:15:45 -0400

This also matches my experience, where discussion of our proposal proved very valuable. The actual management can be done by chairs, modulo tool support, but I would hate to miss the chair-AD discussion. 

Thanks,

Carlos P.

---

From: Russ Housley <[email-masked]>
Date: Wed, 20 Apr 2011 13:46:49 -0400

Robert:

When i was a WG Chair, all of my milestones were about documents.  But you are right, that the milestones often talked about the document title since they were written before there was a draft name to reference.  One thing we could easily do is add a pointer to the document once it is known.

Russ

---

From: "Spencer Dawkins" <[email-masked]>
Date: Wed, 20 Apr 2011 16:06:05 -0500

David,

You'd think so, wouldn't you? But even with the same editors, when there are 
two or more documents, the reasons for being late can diverge ;-)

Spencer

----- Original Message ----- 
From: <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>
Sent: Wednesday, April 20, 2011 12:01 PM
Subject: RE: Additional topics related to managing WG Charter Milestones

Is that still the case when the two documents are the protocol or protocol 
changes and associated management interface or changes (e.g., MIB)?

Thanks,
--David

> Behalf Of DRAGE, Keith (Keith)

---

From: "Dan Wing" <[email-masked]>
Date: Wed, 20 Apr 2011 18:12:02 -0700

> Sent: Wednesday, April 20, 2011 9:04 AM
> To: Robert Sparks; Russ Housley
> Cc: IETF WG Chairs

It can be 1:1 (obvious), 1:N (e.g., framework document and a separate
specification document), and 1:0 (no document is created, e.g., 
"determine WG consensus on <technical issue>").

> One thing I would like if we get such a mapping in place is that the
> milestone automatically gets marked as done when the mapped documents
> get publication requested (assuming the milestone is one of "Submit to
> IESG ..." category).

+1.

And mark things red that are late.  

-d

> From my perspective, this mapping should only exist for i-ds that are
> working group drafts. I think mapping author drafts to milestones will
> introduce a lot of other complexities we probably don't want to touch.
> 
> By the way - not everything about milestones needs AD checkpoint,
> changing the delivery dates doesn't need this at the moment in my
> understanding.
> 
> Regards
> 
> Keith
> 
> > easier to map documents to milestones for instance. What other
> features
> > should be part of this discussion?
> >
> > RjS
> >
> suggestion

---

From: Jeffrey Hutzelman <[email-masked]>
Date: Thu, 21 Apr 2011 09:12:18 -0400

--On Wednesday, April 20, 2011 06:04:19 PM +0200 "DRAGE, Keith (Keith)" 
<[email-masked]> wrote:

> milestone automatically gets marked as done when the mapped documents get
> publication requested (assuming the milestone is one of "Submit to IESG
> ..." category).
>

At the wgchairs lunch in Prague, a number of new tracker features were 
demonstrated which are intended to make it possible to track the status of 
working group documents.  It seems like the obvious thing to do would be to 
attach a document and tracker state to a milestone, such that the milestone 
is automatically marked "done" when the document reaches that state.  This 
would allow for automatic handling of milestones in a way that actually 
corresponds to how each WG works.

-- Jeff