Subject: New command-line tool for IETF documents

From: Paul Hoffman <[email-masked]>
Date: Wed, 6 Jul 2011 16:57:45 -0700

Please see <http://trac.tools.ietf.org/tools/ietf-cli/>. I suspect WG chairs will use this more aggressively than others.

--Paul Hoffman

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 7 Jul 2011 11:31:12 +1000

Nice!

Have you considered packaging it up with setuptools and sticking it on pypi, so it's easier to install and keep up-to-date?

Also, it'd be great to get a copy of the repository on github, so that those of us that are inclined can hack on it more easily.

Cheers,

--
Mark Nottingham   http://www.mnot.net/

---

From: Paul Hoffman <[email-masked]>
Date: Wed, 6 Jul 2011 18:36:16 -0700

> Have you considered packaging it up with setuptools and sticking it on pypi, so it's easier to install and keep up-to-date?

Not yet, because it is fairly site-specific. But I can certainly do a setuptools bundling of it if folks start to use it much.

> Also, it'd be great to get a copy of the repository on github, so that those of us that are inclined can hack on it more easily.

The page includes a link to the svn repository from the IETF Tools Team; why would github be better than that? (Oh, no, I see a probably-useful thread on Subversion vs. git about to start...)

--Paul Hoffman

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 7 Jul 2011 11:37:57 +1000

> The page includes a link to the svn repository from the IETF Tools Team; why would github be better than that? (Oh, no, I see a probably-useful thread on Subversion vs. git about to start...)

:)

The friction to forking something, making a contribution, and getting it merged back in is much lower. 

Not saying "vs." here, just "in addition to."

Cheers,

---

From: Aaron Stone <[email-masked]>
Date: Wed, 6 Jul 2011 18:55:00 -0700

> Not yet, because it is fairly site-specific. But I can certainly do a setuptools bundling of it if folks start to use it much.

That's ok, I think PyPi does accept material like that. The tool is of
general use to engineers who work with standards-based systems, which
includes many people outside of IETF circles.

---

From: Cullen Jennings <[email-masked]>
Date: Wed, 6 Jul 2011 20:46:23 -0600

I like it  - and works on planes. Remind me to buy you beer.  Thanks.

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Wed, 6 Jul 2011 19:53:30 -0700

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Paul Hoffman
> Sent: Wednesday, July 06, 2011 4:58 PM
> To: IETF WG chairs
> Subject: New command-line tool for IETF documents
> 
> Please see <http://trac.tools.ietf.org/tools/ietf-cli/>. I suspect WG
> chairs will use this more aggressively than others.

Very nice!

Is there a page someplace where suggestions and/or feature requests can be submitted?  I'd love to be able to submit drafts from a command line, for example.

---

From: Paul Hoffman <[email-masked]>
Date: Thu, 7 Jul 2011 07:19:21 -0700

On Jul 6, 2011, at 7:53 PM, Murray S. Kucherawy wrote:

> Is there a page someplace where suggestions and/or feature requests can be submitted?  

Here on this list is fine, or straight to me, as some folks have done.

> I'd love to be able to submit drafts from a command line, for example.

I *think* that would require expect-style receiving of the forms data, which is probably not a good idea. But I'll ask if there is a one-shot submission URL and, if so, add it to the tool.

--Paul Hoffman

---

From: "John Levine" <[email-masked]>
Date: 7 Jul 2011 16:37:08 -0000

>I *think* that would require expect-style receiving of the forms
>data, which is probably not a good idea. But I'll ask if there is a
>one-shot submission URL and, if so, add it to the tool.

I took a look, you'd have to do one POST to send the doc and a second
to confirm the address to which to send the mail.  It's not quite as
bad as expect, since you get the whole web page at once in which to
search for the useful bits.

If enough people want this (count me in), it'd probably be better to
ask the web tools people to provide a one-shot URL that could be
embedded into other places.  I'm sure the emacs crowd would use it.

R's,
John

---

From: Paul Hoffman <[email-masked]>
Date: Wed, 13 Jul 2011 17:04:37 -0700

> Have you considered packaging it up with setuptools and sticking it on pypi, so it's easier to install and keep up-to-date?

Later on the schedule (I need to brush up on setuptools again...).

> Also, it'd be great to get a copy of the repository on github, so that those of us that are inclined can hack on it more easily.

Now at <https://github.com/paulehoffman/ietf-cli>. Please be patient with the merge requests: I'm new at this.

--Paul Hoffman

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 14 Jul 2011 10:24:34 +1000

> Now at <https://github.com/paulehoffman/ietf-cli>. Please be patient with the merge requests: I'm new at this.

Cool!

I'm working on a setup.py. 

Can you put an explicit license of some sort on it? 

Cheers,

---

From: Paul Hoffman <[email-masked]>
Date: Wed, 13 Jul 2011 17:47:13 -0700

> I'm working on a setup.py. 

Cool.

> Can you put an explicit license of some sort on it? 

Oh, goody: licensing religion. Can't we talk about something less contentious like world politics or NATs?

I'll slap something into 1.3 and will try not to be snide about the need.

--Paul Hoffman

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 14 Jul 2011 10:48:38 +1000

I have no particular requirements, just need to fill the slot. Sorry.

Cheers,

---

From: Cullen Jennings <[email-masked]>
Date: Tue, 19 Jul 2011 18:27:44 -0700

I've been using the tool a bunch and it's been working well for me. Thanks

---

From: Paul Hoffman <[email-masked]>
Date: Tue, 19 Jul 2011 20:01:21 -0700

> I've been using the tool a bunch and it's been working well for me. Thanks

More to come once Mark Nottingham does his work on packaging. "rfc" will also automatically open RFCs that obsolete and update the one you asked for, and will also open errata. Maybe more too. Suggestions welcome.

--Paul Hoffman