Subject: etherpad used

From: Marc Blanchet <[email-masked]>
Date: Thu, 17 Nov 2011 12:13:35 +0800

just a small comment on the etherpad "service": we used it during iri this morning, and I found it fantastic and efficient. 3 people contributed to the pad and we had the minutes done by the end of the meeting, and now posted to the proceedings. will certainly try it for other of my wg meetings.

Thanks for offering the service.

Marc.

---

From: Sean Turner <[email-masked]>
Date: Thu, 17 Nov 2011 12:27:31 +0800

We use this on w3c/ietf liaison calls and I think it's kewl.

spt

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 17 Nov 2011 14:01:54 +0800

Hmm. Not so much here.

I experimented with it just a little before the meeting, and experienced 
a number of disconnect errors. Still, I asked for a note taker volunteer 
in CLUE WG to try it. They did use it, but reported also having a number 
of disconnect errors. These can be recovered, but are annoying because a 
small bit of typing is lost. The note taker commented that he would 
prefer not to use it in the future.

(We didn't have anyone else concurrently adding to the notes.)

I don't consider this a definitive test, but a data point.

	Thanks,
	Paul

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 17 Nov 2011 14:18:32 +0800

Hi Paul,

Thanks for the feedback.  What I've noticed myself, when keeping an eye on
the use of this, is that with the current setup, which uses one instance of
the server node for all the pads, you get a 'disconnected' notice on one
pad as soon as you access any other pad.  The server node will only let you
access one etherpad at a time (at least within one browser instance).

I plan to fix this for the next meeting by having a separate instance of
the server node for each session in the same meeting slot, or even one
instance for each separate WG.

Best regards,

	Henrik

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 17 Nov 2011 14:20:22 +0800

Hi Mark, Sean,

Thanks for the feedback.  I'm glad it worked well for you.  I'm aware
of one potential problem (see my email to Paul just now) and believe
I have a fix for that; and of course the more people indicate that this
is a service which it's worthwhile to offer, the more time I'll be happy
to spend fixing weak spots :-)

Best regards,

	Henrik

---

From: Peter Saint-Andre <[email-masked]>
Date: Thu, 17 Nov 2011 14:26:25 +0800

> to spend fixing weak spots :-)

I think one of the major benefits is what Marc mentioned: when you
finish the meeting, the minutes are done (aside from a bit of typo
fixing and such). Given that so many working groups are late in
submitting minutes to the Secretariat, this is a big win.

It also makes scribing easier, gets more people involved, helps reduce
bugs in the minutes, and is actually kind of fun. :)

Peter

--
Peter Saint-Andre
https://stpeter.im/

---

From: Ray Bellis <[email-masked]>
Date: Thu, 17 Nov 2011 06:38:56 +0000

> bugs in the minutes, and is actually kind of fun. :)

+1 to all that.

One (hopefully) minor concern I have - the Etherpad appears to be completely unprotected.

What mechanism is there to revert back to previous versions of the text if someone unknown to us visits the page and vandalises the content or even erases it completely before it has been committed ?

Ray

---

From: Peter Saint-Andre <[email-masked]>
Date: Thu, 17 Nov 2011 14:48:59 +0800

On 11/17/11 2:38 PM, Ray Bellis wrote:
>> It also makes scribing easier, gets more people involved, helps
>> reduce bugs in the minutes, and is actually kind of fun. :)
> 
> +1 to all that.
> 
> What mechanism is there to revert back to previous versions of the
> text if someone unknown to us visits the page and vandalises the
> content or even erases it completely before it has been committed ?

Some versions of etherpad do save changes periodically.

/psa

---

From: Dave Thaler <[email-masked]>
Date: Thu, 17 Nov 2011 06:55:24 +0000

I see a clock-shaped icon, and that seems to show a history.

-Dave

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Peter Saint-Andre
> Sent: Thursday, November 17, 2011 2:49 PM
> To: Ray Bellis
> Cc: Working Group Chairs
> Subject: Re: etherpad used
>

---

From: Ray Bellis <[email-masked]>
Date: Thu, 17 Nov 2011 06:56:59 +0000

> Some versions of etherpad do save changes periodically.

Yes - I've since discovered the "view history" mode, which allows you to see all the previous revisions.

That notwithstanding, should we consider requiring a "tools" login to permit editing?  As it stands there would seem to be a risk of it getting abused.

Ray

---

From: Warren Kumari <[email-masked]>
Date: Thu, 17 Nov 2011 15:02:15 +0800

This was used in one of my sessions and appeared to go well….

For the other session, the minutes taker didn't want the peanut-gallery seeing his poor typing skillz and so took minutes in something else (Word?!) and sent them to me sometime after…

I found the etherpad option to be better, as I could a: confirm that the minute taker was doing *something* and b: the minutes were instantly available.

Having a simple "Post" button that the chairs could click after the session was done would make this even easier (the whole Ctrl-A, Copy, Save, Click "Upload minutes", browse, select, click post sequence leads to chairs procrastinating and minutes end up getting posted late…)

W

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 17 Nov 2011 15:03:48 +0800

On Nov 17, 2011, at 14:56, Ray Bellis wrote:

> As it stands there would seem to be a risk of it getting abused.

Quoting a famous AD:

"Security can always be added later."

<ducks>

(But I really think that is the right thing to do here.)

Grüße, Carsten

---

From: Robert Sparks <[email-masked]>
Date: Thu, 17 Nov 2011 15:35:18 +0800

Is it easy to see who contributed to the end content?
AFAICT, it's possible (and it's the default state) to end up with a bunch of "Unknown" contributors.
For the groups that used it, did the result turn out that way?

RjS

---

From: Marc Blanchet <[email-masked]>
Date: Thu, 17 Nov 2011 15:39:14 +0800

> For the groups that used it, did the result turn out that way?

- I did not care about who wrote, while I knew already 2 of the 3 contributors. I just took the content as a blob and then edit it after the session. The good news is that I had no editing to do after... ;-)

Marc.

---

From: Peter Saint-Andre <[email-masked]>
Date: Thu, 17 Nov 2011 16:02:50 +0800

> - I did not care about who wrote, while I knew already 2 of the 3 contributors. I just took the content as a blob and then edit it after the session. The good news is that I had no editing to do af…

In my experience, it doesn't matter if the contributors are unknown, as
long as the results are accurate, which tends to be assured by the fact
that with many eyeballs, all bugs are shallow.

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: Lou Berger <[email-masked]>
Date: Thu, 17 Nov 2011 16:14:00 +0800

We used this during the first ccamp session and it was great.  Real &
instant value.  I plan to continue to use it as long as it's available.

Thank you!
Lou

PS tools login and text attribution is probably a good idea in the long
run.  The current (lack of) security is just fine for the current test...

---

From: Marc Blanchet <[email-masked]>
Date: Thu, 17 Nov 2011 16:16:11 +0800

> run.  The current (lack of) security is just fine for the current test...

+1

Marc.

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 17 Nov 2011 17:13:46 +0800

Hi Lou,

On 2011-11-17 16:14 Lou Berger said the following:
> We used this during the first ccamp session and it was great.  Real&

Ah.  Right.  That probably means putting it behind a proxy, which will
be a test on its own -- I have no idea whether it performs well or not
deployed like that, but will try to set it up that way for next time.

Best regards,

	Henrik

---

From: Peter Saint-Andre <[email-masked]>
Date: Thu, 17 Nov 2011 17:17:36 +0800

> deployed like that, but will try to set it up that way for next time.

I'd be happy to help with testing.

In the CORE WG session right now, we did once experience a race
condition when two people tried to scribe the same thing at the same
time, but it was easy to resolve and the only reason we had the problem
was because we had so many people helping take the minutes. That's a
great problem to have.

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: Cullen Jennings <[email-masked]>
Date: Thu, 17 Nov 2011 18:37:39 +0800

As a chair, it was great to have "live" minutes. On points that I thought were critical to make in the minutes, I could glance at the web page see that they had made it in. At another point I was trying to correlate an email messages on list to the current speaker - I knew the name of who sent the email but was not sure about the face and wanted to know if it was the same person that sent the email. Live updates of minutes told me the speakers name even when I missed it at the mic. 

The live collaborative minutes are a huge move forward and I love them. 

Need to fix the disconnects and I also want to be able to see the names or handles for each persons "color" when typing.

---

From: Gonzalo Camarillo <[email-masked]>
Date: Thu, 17 Nov 2011 19:00:46 +0800

Hi,

the meetecho suite already has a text tab, but edition is token based
(only one editor at a time). If having multiple editors is a useful
feature to have, maybe the meetecho team could integrate it in their
system ;-)

Cheers,

Gonzalo

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 17 Nov 2011 21:45:17 +0800

> What mechanism is there to revert back to previous versions of the text if someone unknown to us visits the page and vandalises the content or even erases it completely before it has been committed…

I forgot to mention:

Our single notes taker using this for the first time inadvertently and 
unknowingly deleted most of the notes, leaving only the last line.
(I don't know how this happened - it was discovered later.)

The good news was that it was recovered from by rolling back.

	Thanks,
	Paul

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 17 Nov 2011 23:35:33 +0800

Hi Cullen,

On 2011-11-17 18:37 Cullen Jennings said the following:
>
> As a chair, it was great to have "live" minutes. On points that I
> thought were critical to make in the minutes, I could glance at the
> web page see that they had made it in. At another point I was trying
> to correlate an email messages on list to the current speaker - I
> knew the name of who sent the email but was not sure about the face
> and wanted to know if it was the same person that sent the email.
> Live updates of minutes told me the speakers name even when I missed
> it at the mic.
>

:-)

> Need to fix the disconnects and I also want to be able to see the
> names or handles for each persons "color" when typing.

I think we should be able to get that either with the proxying with
login, or using the etherpad-lite API which I've read up on today.

Best regards,

	Henrik

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 18 Nov 2011 01:27:52 +0800

> run.  The current (lack of) security is just fine for the current test...

The lesson from the Web is that increasing the threshold slightly decreases the participation mightily.
It is the ease with which people can participate that makes this tool most useful.

I use Etherpads a lot at the university, and the only security feature we use is keeping the link within the group that uses it.  In the IETF use, the link is indeed findable for potential bad guys*).  Countermeasure: To evade a disturber, we could simply open a new Etherpad (just as I did for our cross-layer hallway meeting today) and not tell the disturber.  (If the disturber is actually sitting in the meeting, well, yes.  Most of us act mostly professional.)

The only thing that the tools login could really bring to the table is automatic attribution.  Nice, but as StPeter said, not really needed that much.  Maybe Etherpad could be hacked to change the initial value of "Unknown" into the IP address...

Grüße, Carsten

*) Yes, some disturbed individuals do come to mind here…

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 17 Nov 2011 11:49:15 -0600

+1 to everything below. There are LOTS of ether pads on the Web, and abuse is not really a problem for the vast majority.

On 17/11/2011, at 11:27 AM, Carsten Bormann wrote:

> The only thing that the tools login could really bring to the table is automatic attribution.  Nice, but as StPeter said, not really needed that much.  Maybe Etherpad could be hacked to change the initial value of "Unknown" into the IP address…

--
Mark Nottingham
http://www.mnot.net/