Subject: RE: Validating an XML schema

From: "Worley, Dale R (Dale)" <[email-masked]>
Date: Wed, 18 Jan 2012 11:14:10 -0500

At 12:06 23-12-2011, Worley, Dale R (Dale) wrote:
>As part of the document shepherd writeup of an I-D, I am supposed
>to run a proposed XML schema through an automated validator.
>The problem being that I don't know of an automated validator.

OK, I've been given links to a couple of validation tools, but it seems
to be beyond me to figure out exactly how they want their input.

Is there someone who has used one of these tools to validate a
schema who is willing to tell me exactly what needs to be done?

Thanks,

Dale

---

From: Peter Saint-Andre <[email-masked]>
Date: Wed, 18 Jan 2012 09:18:28 -0700

On 1/18/12 9:14 AM, Worley, Dale R (Dale) wrote:
> OK, I've been given links to a couple of validation tools, 

Yes, there are links from here:

http://trac.tools.ietf.org/area/app/trac/wiki

> but it seems

I use http://www.w3.org/2001/03/webdata/xsv by creating a standalone
.xsd file, uploading it to my personal website, and pointing the
validator to that URL.

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: Brian Trammell <[email-masked]>
Date: Wed, 18 Jan 2012 17:44:23 +0100

Hi, Dale,

I've used xmllint, which comes with libxml2 and is therefore available on most modern Linux distributions, to validate a given bit of XML against a given schema. Its output can be rather cryptic when the schema is invalid -- and you do need some example XML to validate against the schema -- but if it works, the schema is good.

Cheers,

Brian

---

From: <[email-masked]>
Date: Wed, 18 Jan 2012 11:49:45 -0500

If it is my schema, I used Oxygen to validate it, a colleague used the W3C tool already mentioned.  I am not sure what tool Brian Trammell used, but he also validated it.  Oxygen is easy to use, I can walk you through that.  XMLSpy is another free tool, I have this on my system if you want instructions for this tool.

If you want to validate the examples to the schema, you need to link them locally within the tool since the updated schema has not been posted yet by IANA.

In Oxygen, the option is in the 'Document' part of the menu.  Any issues are noted at the bottom of the window for the tool.

I can also send the schema file as that will be the one given to IANA and was pasted into the most recent draft version to avoid the need to cut out headers and possibly run into  white space issues when you validate. 

Thanks,
Kathleen 

Sent from my iPhone

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 18 Jan 2012 17:55:40 +0100

> I can also send the schema file as that will be the one given to IANA and was pasted into the most recent draft version to avoid the need to cut out headers and possibly run into  white space issue…

Well, that defeats about 1/2 of the reason to validate a language subdocument in an RFC-to-be -- did it make it into the document without harm?

I believe that including anything but completely trivial snippets of language into an RFC-to-be without also including instructions how to extract them in a fully automatic way is inviting failure.

Grüße, Carsten

---

From: "Worley, Dale R (Dale)" <[email-masked]>
Date: Wed, 18 Jan 2012 12:02:48 -0500

I thank the people who have commented, but I haven't been clear:

"I have an XSD file.  What do I do next?"

It appears that the various tools have various restrictions and rules.
Naively, I assume that I can feed the XSD into the tool.
But various things need to be tweaked very specifically to actually
work, and none of that is documented for the naive user.  For instance,
I see no need for xs:import elements, as the only namespaces which
my XSD refers to are integral parts of XML.  But the tools seem to
want xs:import elements for those things, it's not clear what their values
should be, and worse, the tools seem to want to see schemas for
parts of XML.

Dale

________________________________________
From: [email-masked] [[email-masked]] On Behalf Of Worley, Dale R (Dale) [[email-masked]]
Sent: Wednesday, January 18, 2012 11:14 AM
To: [email-masked]
Subject: RE: Validating an XML schema

Thanks,

Dale

---

From: Tom Taylor <[email-masked]>
Date: Wed, 18 Jan 2012 13:59:43 -0500

I recently changed my E-mail address. Thanks to the global change 
interface at

https://www.ietf.org/mailman/options/<wgname>/<your E-mail address>

(login required per our monthly reminder E-mails), it was quick and easy 
to change my address for all the lists to which I am subscribed. I've 
also updated my address when submitting updates to the drafts I'm 
working on. However, the Datatracker E-mail aliases for those drafts 
still seem to reflect my old address, and I'm now failing to receive 
messages from ADs or the system relating to them.

Is this a process glitch?

Tom Taylor

---

From: Fred Baker <[email-masked]>
Date: Wed, 18 Jan 2012 13:00:44 -0800

On Jan 18, 2012, at 10:59 AM, Tom Taylor wrote:

> I recently changed my E-mail address. Thanks to the global change interface at
> 
> (login required per our monthly reminder E-mails), it was quick and easy to change my address for all the lists to which I am subscribed. I've also updated my address when submitting updates to the drafts I'm working on. However, the Datatracker E-mail aliases for those drafts still seem to reflect my old address, and I'm now failing to receive messages from ADs or the system relating to them.
> 

Copying tools-discuss@. The datatracker.ietf.org and tools.ietf.org are different systems with different databases. Sounds like an API glitch between them.

---

From: Loa Andersson <[email-masked]>
Date: Wed, 18 Jan 2012 22:55:43 +0100

Tom, All,

the data tracker aliases reflects what is the drafts. I've seen this
discussion before and after thinking a bit I believe it as it should be.
The easiest way to change what is in the data tracker aliases is to
update the draft.

My take is that some that sends to a data tracker alias should have
a chance to know where goes, it might be a difference to send to
[email-masked] as compared to have the mail show up at
[email-masked].

/Loa

-- 

Loa Andersson                         email: [email-masked]
Sr Strategy and Standards Manager            [email-masked]
Ericsson Inc                          phone: +46 10 717 52 13
                                              +46 767 72 92 13

---

From: <[email-masked]>
Date: Wed, 18 Jan 2012 17:01:13 -0500

The email addresses in the drafts really should be correct for Authors 48 hours review.
As a GenART reviewer, I always copy the author email addresses from the draft instead
of using a tools alias, and have occasionally caught out-of-date email addresses.

Thanks,
--David

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Loa Andersson
> Sent: Wednesday, January 18, 2012 4:56 PM
> To: [email-masked]
> Subject: Re: Updating of Datatracker E-mail aliases
> 
> Tom, All,
>

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 18 Jan 2012 22:05:12 -0000

If you want to know where aliases point to at any moment in time...

http://tools.ietf.org/ad/aliases

A

> Sent: 18 January 2012 21:56
> To: [email-masked]

---

From: Tom Taylor <[email-masked]>
Date: Wed, 18 Jan 2012 20:03:03 -0500

The thing is, I did update the drafts (as I mentioned below). The 
E-mails are still going to the wrong address, I think. (I ran an 
experiment with one of them and got nothing back.)

---

From: Ross Callon <[email-masked]>
Date: Wed, 18 Jan 2012 22:56:28 -0500

I have never trusted the Internet-Draft-specific email address for the simple reason that I can't know for sure who it is really going to. I therefore tend to copy the email addresses from the I.D. when sending email that needs to go to the authors.  

Ross

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 19 Jan 2012 16:19:53 +0100

Hi Tom, Fred,

> Copying tools-discuss@. The datatracker.ietf.org and tools.ietf.org are different systems with different databases. Sounds like an API glitch between them.

There's no coupling from email changes for the Mailman lists and email
changes for drafts in general.

I've checked the draft alias list, and for a number of drafts, the aliases
reflect the new <[email-masked]>, but there are still some where
the old address is present.  I've now added an entry to my fixup-table so
that on the next generation of the alias list the old <[email-masked]>
address will be replaced with the new one.

Best regards,

	Henrik

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 19 Jan 2012 16:38:06 +0100

Hi Ross,

On 2012-01-19 04:56 Ross Callon said:
> I have never trusted the Internet-Draft-specific email address for
> the simple reason that I can't know for sure who it is really going
> to. I therefore tend to copy the email addresses from the I.D. when
> sending email that needs to go to the authors.

The draft alias list can be inspected here:

  http://mail.tools.ietf.org/draft/aliases
	
The page requires login to prevent harvesting.

Best regards,

	Henrik

---

From: Ross Callon <[email-masked]>
Date: Fri, 20 Jan 2012 12:35:14 -0500

Cool! Thanks. This didn't exactly display in the most user friendly format, but the information does indeed seem to all be there. 

If we happen to notice an old obsolete email address in this list (multiple times), and know the correct updated email address for the same person, is there an easy way to get this fixed? 

Thanks, Ross

-----Original Message-----
From: Henrik Levkowetz [mailto:[email-masked]] 
Sent: Thursday, January 19, 2012 10:38 AM
To: Ross Callon
Cc: Tom Taylor; Loa Andersson; [email-masked]
Subject: Re: Updating of Datatracker E-mail aliases

Hi Ross,

	

Best regards,

	Henrik

---

From: Henrik Levkowetz <[email-masked]>
Date: Fri, 20 Jan 2012 18:57:05 +0100

Hi Ross,

On 2012-01-20 18:35 Ross Callon said the following:
> Cool! Thanks. This didn't exactly display in the most user friendly
> format, but the information does indeed seem to all be there.

Yes, it's just the alias file as-is.

> If we happen to notice an old obsolete email address in this list
> (multiple times), and know the correct updated email address for the
> same person, is there an easy way to get this fixed?

I have a fixup table from old to new addresses, but no web interface
to it.  It's easy enough for me to add such, though, and if it should
happen that I get a lot of requests, I'm sure I will put in place a
self-service page to handle it :-)

For now, let me know and I'll add the old -> new entries needed
manually.

Best regards,

	Henrik

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Mon, 23 Jan 2012 08:50:28 -0800

While we're on the topic, I would be happy++ if the datatracker had a way to subscribe to specific draft aliases.  Right now if I want to be notified of activity regarding drafts that are of particular interest but don't list me as author, AD or shepherd, I need to go back and check on it manually from time to time.

-MSK

---

From: "Andrew G. Malis" <[email-masked]>
Date: Mon, 23 Jan 2012 13:02:34 -0500

Talk about a walk down memory lane ... it looks like every draft I've
worked on since the mid-90s or so is in here. :-)

Cheers,
Andy

---

From: Dave CROCKER <[email-masked]>
Date: Mon, 23 Jan 2012 10:52:52 -0800

> While we're on the topic, I would be happy++ if the datatracker had a way to subscribe to specific draft aliases.  Right now if I want to be notified of activity regarding drafts that are of partic…

I'd recommend an rss feed, rather than a mailing list mechanism.

this moves the entire task of keeping the associations up to date over to the 
subscriber.

d/

-- 

   Dave Crocker
   Brandenburg InternetWorking
   bbiw.net

---

From: Russ Housley <[email-masked]>
Date: Mon, 23 Jan 2012 15:04:22 -0500

The equivalent of this capability is in the works.  Anyone will be able to list the document that they care about and be notified of datatracker changes.  This capability is of interest to many people, not just WG chairs.

See http://www.rfc-editor.org/rfc/rfc6293.txt

Russ

On Jan 23, 2012, at 11:50 AM, Murray S. Kucherawy wrote:

>  I would be happy++ if the datatracker had a way to subscribe to specific draft aliases.