Subject: IETF/IRTF mailman & S/MIME

From: "Eggert, Lars" <[email-masked]>
Date: Wed, 8 Feb 2012 18:24:55 +0000

Hi,

by default, the IETF/IRTF mailman is configured to add a footer to all emails that go through it, e.g.,

> _______________________________________________
> tcpm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tcpm

The way in which this is done breaks S/MIME. This causes emails from those of us who use it to be flagged as tampered with:

As a chair, if you want to be nice to us S/MIME users, the easy fix is to turn off the generation of that footer in the mailman settings for the list. Go to the the "Non-digest options" settings page and clear out the "msg_footer" field.

Or click here after replacing LISTNAME with your list name: https://www.ietf.org/mailman/admin/LISTNAME/?VARHELP=nondigest/msg_footer

Lars

---

From: Dave CROCKER <[email-masked]>
Date: Wed, 08 Feb 2012 10:37:38 -0800

On 2/8/2012 10:24 AM, Eggert, Lars wrote:
> As a chair, if you want to be nice to us S/MIME users, the easy fix is to turn
> off the generation of that footer in the mailman settings for the list. Go to
> the the "Non-digest options" settings page and clear out the "msg_footer" field.

That might be a good idea, if the footer contained nothing useful.  In fact 
there is discussion about adding to it with even more useful stuff...

The underlying problem is that a mailing list is creating a new message.  S/MIME 
is residue of the original message that it is based on.

The right solution is to remove the remnants of s/mime, when it's functionality 
no long applies.  Or to not include s/mime when it isn't needed.

d/

-- 

   Dave Crocker
   Brandenburg InternetWorking
   bbiw.net

---

From: "Eggert, Lars" <[email-masked]>
Date: Wed, 8 Feb 2012 18:42:57 +0000

On Feb 8, 2012, at 10:37, Dave CROCKER wrote:
> That might be a good idea, if the footer contained nothing useful.

At the moment, it doesn't contain anything that the mail headers added by mailman wouldn't include.

>  In fact there is discussion about adding to it with even more useful stuff...

Is there? Could you elaborate a bit?

Thanks,
Lars

---

From: "John R. Levine" <[email-masked]>
Date: 8 Feb 2012 13:47:14 -0500

There is some way to tell Mailmain to wrap the message in a 
multipart/something and make the footer a separate part, so S/MIME 
clients* can still validate the signature.

Dunno what it is, since I don't run Mailman, but I've been on lists that 
do that.

Regards,
John Levine, [email-masked], Primary Perpetrator of "The Internet for Dummies",
Please consider the environment before reading this e-mail. http://jl.ly

* - well, the competent ones, which in my experience is about half of them

---

From: Dave CROCKER <[email-masked]>
Date: Wed, 08 Feb 2012 10:52:48 -0800

> At the moment, it doesn't contain anything that the mail headers added by mailman wouldn't include.

There is a debate about whether invisible header fields are a sufficient 
alternative to text visible in the footer.  I of course wish it were, but the 
reality of current mail client software creates a problem.

Worse is that adding something meant to be a formal notice requires assurance 
that the user is likely to see it.

>>   In fact there is discussion about adding to it with even more useful stuff...

A pointer to NOTE WELL, or somesuch.

I should emphasize that it's an idea, not a plan.  To my knowledge, the idea has 
no formal status and is not listed on anyone's agenda.

d/

-- 

   Dave Crocker

---

From: Leif Johansson <[email-masked]>
Date: Wed, 08 Feb 2012 20:03:48 +0100

> clients* can still validate the signature.

multipart/footer? argh.

---

From: "John R. Levine" <[email-masked]>
Date: 8 Feb 2012 14:27:00 -0500

I see that the MAAWG lists add footers in a way that preserves S/MIME 
signatures.  If you want, I can ask how they're set up.

Regards,

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Thu, 9 Feb 2012 03:25:35 +0100

Both SIP and SIPPING in the past have used the footer to add information on the scope of various mailing lists to use, if the vague hope that it helps people not repost to the inappropriate list.

Keith

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Dave CROCKER
> Sent: 08 February 2012 18:53
> To: Eggert, Lars
> Cc: [email-masked]; Internet Research Steering Group
> Subject: Re: IETF/IRTF mailman & S/MIME
> 
> 
>