Subject: Re: Diff2 from RFC -> individual RFCbis document -> WG RFCbis document

From: Jeffrey Hutzelman <[email-masked]>
Date: Tue, 13 Mar 2012 13:08:51 -0400

On Tue, 2012-03-13 at 11:08 +0100, Benoit Claise wrote:
> Dear all,
> 
> I'm wondering how to do, with the IETF tools, a diff between a WG 
> document "RFC bis" and the "RFC" in the following example:
> 
>      1. RFC 5101 was published
>      2. And individual draft was published to update it 
> http://tools.ietf.org/html/draft-claise-ipfix-protocol-rfc5101bis-02
>      3. 
> http://tools.ietf.org/html/draft-ietf-ipfix-protocol-rfc5101bis-01 was 
> accepted as a WG document
> 
> The tools 
> (http://tools.ietf.org/html/draft-ietf-ipfix-protocol-rfc5101bis-01) 
> allows the diffs between the 2. and 3.. And I would like the automatic 
> diff between 1. and .3
> 
> Any other ways than loading the different versions in 
> http://www.ietf.org/tools/rfcdiff/?

As you probably know, the tools page for an internet-draft, like
http://tools.ietf.org/html/draft-ietf-ipfix-protocol-rfc5101bis-01
includes links for jumping from one version to the next, and for showing
the differences between the version you're viewing and the previous
version.  When one document succeeds another, such as a WG document
replacing an individual one or, in this case, the individual document
being the start of a revision of RFC5101, those links inlcude the
ability to jump from one document to the next, and to compare the first
version of one document with the last version of the document before it.

So, if you go to the page for draft-claise-ipfix-protocol-rfc5101bis-00
and click the "Diff1" link, you'll see differences in that document
since RFC5101.

As far as I know, there is no "friendly" way to click on something and
see differences between two documents that are not immediately adjacent
versions.  However, you can fairly easily edit the URL to get what you
want.  Simply bring up the diff page for the later document, and add
"&url1=XXX" to the end of the URL, where XXX is the document you want to
compare against.  Acceptable forms include draft-foo-bar-00 and rfcXXXX.

So, to see the differences between the most recent rfc5101bis and the
original rfc5101, try this:

http://tools.ietf.org/rfcdiff?url2=draft-ietf-ipfix-protocol-rfc5101bis-01.txt&url1=rfc5101

-- Jeff

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 13 Mar 2012 13:24:23 -0400

On a related note, I've been wishing that the I-D Action announcement 
messages provided more convenient access to info about the draft.
A link to the diff with the previous version would be nice,
as would a link to the html version of the document in the tools area 
(which in turn has links to all sorts of renditions of the doc.)

I find that the link that is currently provided is rarely the one I 
want, so I'm always having to copy the name, and then search for the 
form I want. Its easier to just click. :-)

	Thanks,
	Paul

---

From: Warren Kumari <[email-masked]>
Date: Tue, 13 Mar 2012 14:10:20 -0600

On Mar 13, 2012, at 11:24 AM, Paul Kyzivat wrote:

> On a related note, I've been wishing that the I-D Action announcement messages provided more convenient access to info about the draft.
> as would a link to the html version of the document in the tools area (which in turn has links to all sorts of renditions of the doc.)
> 
> I find that the link that is currently provided is rarely the one I want, so I'm always having to copy the name, and then search for the form I want. Its easier to just click. :-)
> 

It you use Chrome, I have written an extension that does jus this… 
It is linked to from the Tools page (http://tools.ietf.org/), or a direct link: https://chrome.google.com/webstore/detail/aiccdpabeagpjcebilebhlifplfkinao

This simply watches for a URL of the form http://www.ietf.org/id/foo-04.txt and replaces it with http://tools.ietf/org/html/foo (or, if you change the default in the options page, datatracker.ietf.org).

W

--
Don't be impressed with unintelligible stuff said condescendingly.
    -- Radia Perlman.

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 13 Mar 2012 16:18:48 -0400

> It you use Chrome, I have written an extension that does jus this…

Nope. I'm using Thunderbird and Firefox. Maybe I'll switch to Chrome at 
some point.

	Thanks,
	Paul

---

From: Jari Arkko <[email-masked]>
Date: Tue, 13 Mar 2012 22:27:13 +0200

The thing is, I have trouble understanding any situation where the www.ietf.org link would be preferable to the tools.ietf.org. I certainly always use the latter, and often have to edit URLs to get there.

Maybe it is now time to end once and for all the weird separation that we've been having between www and tools parts. I know they were at least a while ago managed separately, but maybe those issues could just be solved. From a user point of view, the tools interface is the one that you'd want.

Jari

---

From: Pete Resnick <[email-masked]>
Date: Tue, 13 Mar 2012 15:32:22 -0500

On 3/13/12 3:27 PM, Jari Arkko wrote:
> The thing is, I have trouble understanding any situation where the 
> www.ietf.org link would be preferable to the tools.ietf.org. I 
> certainly always use the latter, and often have to edit URLs to get 
> there.

But I do understand wanting the datatracker.ietf.org link. It's got all 
of the info on the document, including a tools.ietf.org link. I prefer 
the datatracker link.

I agree that the www.ietf.org link is almost useless.

pr

-- 
Pete Resnick<http://www.qualcomm.com/~presnick/>
Qualcomm Incorporated - Direct phone: (858)651-4478, Fax: (858)651-1102

---

From: Jari Arkko <[email-masked]>
Date: Tue, 13 Mar 2012 22:37:10 +0200

Pete,

> of the info on the document, including a tools.ietf.org link. I prefer

I understand it as well. I'll just note that there are links in both directions, so either one would work for me. I'm a little more inclined to think that reading a doc is more likely action than looking at tracker page (even for an AD, let alone others), and the tools default view is better for reading, so that's why I said the tools page. But I could live with this either way.

Jari

---

From: "Andrew G. Malis" <[email-masked]>
Date: Tue, 13 Mar 2012 21:38:33 +0100

The tools and datatracker versions cross-link each other, so it's very easy
to get from one to the other. I prefer the tools version because of the
live links in the draft, including in the TOC, and you don't have to click
at the bottom to get the whole draft.

Cheers,
Andy

On Tue, Mar 13, 2012 at 9:32 PM, Pete Resnick <[email-masked]> wrote:

>> www.ietf.org link would be preferable to the tools.ietf.org. I certainly
>> always use the latter, and often have to edit URLs to get there.
>>
>
> Pete Resnick<http://www.qualcomm.**com/~presnick/<http://www.qualcomm.com/%7Epresnick/>
> >

---

From: Jeffrey Hutzelman <[email-masked]>
Date: Tue, 13 Mar 2012 16:45:42 -0400

On Tue, 2012-03-13 at 22:37 +0200, Jari Arkko wrote:
> I understand it as well. I'll just note that there are links in both
>  directions, so either one would work for me. I'm a little more
>  inclined to think that reading a doc is more likely action than
>  looking at tracker page (even for an AD, let alone others), and the
>  tools default view is better for reading, so that's why I said the
>  tools page. But I could live with this either way.

I could wish that the default tracker view would show the entire
document, or perhaps the first 50 pages, instead of just one page.
But yes, links to either the tracker or tools pages would better than
the www.ietf.org link we get now.

-- Jeff

---

From: Pete Resnick <[email-masked]>
Date: Tue, 13 Mar 2012 15:47:06 -0500

On 3/13/12 3:38 PM, Andrew G. Malis wrote:
> you don't have to click at the bottom to get the whole draft.

I thought that so long as you are logged in, that state is sticky: Once 
you expand one thing, everything stay expanded. I certainly never have 
to click at the bottom anymore. Robert, how does that work?

pr

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Tue, 13 Mar 2012 20:48:14 +0000

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Jeffrey Hutzelman
> Sent: Tuesday, March 13, 2012 1:46 PM
> To: Jari Arkko
> Cc: Pete Resnick; [email-masked]; [email-masked]
> Subject: Re: Easier access to diffs, etc.
> 
> > > But I do understand wanting the datatracker.ietf.org link. It's got
> > > all of the info on the document, including a tools.ietf.org link. I
> > > prefer the datatracker link.

+1

> the www.ietf.org link we get now.

I'm fine with anything that is either the datatracker link or one click away from it.

-MSK

---

From: Robert Sparks <[email-masked]>
Date: Tue, 13 Mar 2012 15:51:52 -0500

It's set as a cookie.
See <http://datatracker.ietf.org/cookies/>

On 3/13/12 3:47 PM, Pete Resnick wrote:
> I thought that so long as you are logged in, that state is sticky: 
> Once you expand one thing, everything stay expanded. I certainly never 
> have to click at the bottom anymore. Robert, how does that work?
>
> pr
>

---

From: "Andrew G. Malis" <[email-masked]>
Date: Tue, 13 Mar 2012 21:53:40 +0100

Thanks - that was easy!

On Tue, Mar 13, 2012 at 9:51 PM, Robert Sparks <[email-masked]> wrote:

> It's set as a cookie.
> See <http://datatracker.ietf.org/**cookies/<http://datatracker.ietf.org/cookies/>
> >
>
>
>> you expand one thing, everything stay expanded. I certainly never have to
>> click at the bottom anymore. Robert, how does that work?
>>
>> pr
>>
>>

---

From: Yaron Sheffer <[email-masked]>
Date: Tue, 13 Mar 2012 22:54:54 +0200

For people who are not "IETF professionals", a link to the tools site 
makes much more sense. I am sure there are many of these on the 
i-d-announce list.

Thanks,
	Yaron

---

From: Jari Arkko <[email-masked]>
Date: Tue, 13 Mar 2012 22:57:50 +0200

The datatracker's mode of showing either the beginning or the full document is sticky. So you can configure it to do what you want.

The tracker and tools are very similar. My personal slight preference for reading docs in the tools page is mostly due to its optimal use of the vertical screen real estate, and its default mode of having clickable contents pages.

In any case, lets not turn this thread into a preference discussion between the tracker and the tools. The point was: the old style ID format URLs are pretty useless, could we switch to one of the modern versions instead, wherever links to IDs are being used in the IETF web and e-mail systems?

Jari

---

From: Pete Resnick <[email-masked]>
Date: Tue, 13 Mar 2012 16:03:09 -0500

On 3/13/12 3:57 PM, Jari Arkko wrote:

> In any case, lets not turn this thread into a preference discussion 
> between the tracker and the tools. The point was: the old style ID 
> format URLs are pretty useless, could we switch to one of the modern 
> versions instead, wherever links to IDs are being used in the IETF web 
> and e-mail systems?

Yup. There was also a recent discussion of what goes in the 
From/Sender/To/CC fields of announcement messages as well. Is someone 
tracking these discussions so that the appropriate magic can happen. Or 
are we just all yammering on the chairs list to each other and nobody 
who makes the changes is actually listening? :-)

pr

---

From: Jari Arkko <[email-masked]>
Date: Tue, 13 Mar 2012 23:20:48 +0200

> Yup. There was also a recent discussion of what goes in the From/Sender/To/CC fields of announcement messages as well. Is someone tracking these discussions so that the appropriate magic can happen. Or are we just all yammering on the chairs list to each other and nobody who makes the changes is actually listening? :-)
>
>

I heard that there is this steering group or something that might be able to make decisions like that. I've requested the matter to put to their meeting next Thursday.

Jari

---

From: Robert Sparks <[email-masked]>
Date: Tue, 13 Mar 2012 17:29:18 -0500

There's also an instance of trac that anyone can use to report bugs/ 
request changes.

There's a link to it at the bottom of navbar on the left of any 
datatracker page.

Folks might also find this useful:
<http://trac.tools.ietf.org/tools/ietfdb/wiki/EnhancementIdeas>, to see 
what we might be working
on at codesprints (please add what you see missing).

RjS

On 3/13/12 4:20 PM, Jari Arkko wrote:
>> tracking these discussions so that the appropriate magic can happen. 
>> Or are we just all yammering on the chairs list to each other and 
>> nobody who makes the changes is actually listening? :-)
>>
>>
>
> I heard that there is this steering group or something that might be 
> able to make decisions like that. I've requested the matter to put to 
> their meeting next Thursday.
>
> Jari
>

---

From: Robert Sparks <[email-masked]>
Date: Tue, 13 Mar 2012 17:40:34 -0500

Popping back in the thread several messages:

I agree that the announcement / revised-id messages should point to 
better places.

Warren's redirect is interesting. I've seen a suggestion that stopped 
just short of asking that
we configure www.ietf.org to do exactly that kind of redirect on 
/id/<blah>. That would
produce unexpected results.

One thing to keep in mind -  What if you really are looking for the .txt 
version of the document
(to feed into some other tool for instance). What link do you use?

Warren - Your plugin probably does the right thing, but if you haven't 
tested it already you might want
to check - if you have the default you point to below set to 
datatracker.ietf.org, does the right thing
happen when you click the "plain text" link in the first block of a 
datatracker's main view for a document?

RjS

---

From: Jari Arkko <[email-masked]>
Date: Wed, 14 Mar 2012 00:43:00 +0200

>
> One thing to keep in mind -  What if you really are looking for the .txt version of the document

You keep those pages still up at the usual place, but don't point to them from the e-mail messages or elsewhere.

Jari

---

From: Martin Thomson <[email-masked]>
Date: Tue, 13 Mar 2012 15:45:35 -0700

On 13 March 2012 15:40, Robert Sparks <[email-masked]> wrote:
> redirect... right thing..."plain text"

HTTP has this wonderful conneg property.  You could serve a redirect
from /id/ if the Accept header indicated a preference for HTML.

Oh, this is that suggestion you were talking about, isn't it?

--Martin

p.s., Of course, conneg and "right thing" have no business in the same
sentence if you listen to some people.

---

From: Adam Roach <[email-masked]>
Date: Tue, 13 Mar 2012 21:29:24 -0500

On 3/13/12 17:45, Mar 13, Martin Thomson wrote:
> On 13 March 2012 15:40, Robert Sparks<[email-masked]>  wrote:

Yeah, how about you show me what knob to turn on Firefox to make this 
happen according to my preferences. Or MSIE. Or Chrome. Or Safari. Or Opera.

Heck, I can't even figure out how to make it work with wget unless I use 
wget 1.10 or later and combine information from its man page with HTTP 
protocol information gleaned from RFCs.

It's fine considering obscure protocol features when you're working on a 
protocol. It's pretty much nonsense *deploying* obscure protocol 
features in a way that's not supported by any of the clients your target 
audience uses.

/a

---

From: Warren Kumari <[email-masked]>
Date: Tue, 13 Mar 2012 21:19:52 -0600

On Mar 13, 2012, at 4:40 PM, Robert Sparks wrote:

> I agree that the announcement / revised-id messages should point to better places.
> 
> Warren's redirect is interesting. I've seen a suggestion that stopped just short of asking that
> we configure www.ietf.org to do exactly that kind of redirect on /id/<blah>. That would
> Warren - Your plugin probably does the right thing, but if you haven't tested it already you might want
> to check - if you have the default you point to below set to datatracker.ietf.org, does the right thing
> happen when you click the "plain text" link in the first block of a datatracker's main view for a document?

Yes, but only if I define "the right thing" to be to redirect you back to the datatracker interface -- I guess I could claim that this is the right thing to do because it provides entertainment, especially if you are (like me) easily entertained…

I will get around to spinning a new version soon that deals with this. I originally wrote this for personal use only, and so it is not particularity polished…

W

---

From: Martin Thomson <[email-masked]>
Date: Wed, 14 Mar 2012 07:00:11 -0700

On 13 March 2012 19:29, Adam Roach <[email-masked]> wrote:
> Yeah, how about you show me what knob to turn on Firefox to make this happen
> according to my preferences. Or MSIE. Or Chrome. Or Safari. Or Opera.

You'll notice that I said "redirect".  That means that the text/plain
version has its own URL.  That's fairly easy to plug into your
favourite client.  I'll also point out that a default for clients like
wget/curl of text/plain also reduces the possibility of surprise.

--Martin

p.s., in Firefox, about:config > network.http.accept.default :p

---

From: Dean Willis <[email-masked]>
Date: Wed, 14 Mar 2012 15:12:22 -0500

> (to feed into some other tool for instance). What link do you use?

I believe I take the HTML version and convert it to text via cut-and-paste, because I get a more toolable text file than the rather baroque IETF TXT format that way. I'm usually doing this to do something like validate ABNF or XML, and I don't use an automated approach.

But it would be certainly interesting to be able to get clickable "raw" versions of embedded formal-language sections out of the structured document. I can even envision a restful API and applications to make use of it -- like post-submission pre-approval validators. This would really help with accidental RFC-ed mungling of formal-language sections.

--
Dean