Subject: Changed behaviour of the draft-* aliases on tools.ietf.org for AD-sponsored drafts

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 06 Mar 2012 11:42:17 +0100

Hi,

The draft aliases on tools.ietf.org now adds all the chairs of an area
as recipients of AD-sponsored drafts in that area.  I don't know if
this is good or bad; it's an unanticipated effect of the database schema
transition.

Background:

With the transition to the new datatracker schema, a lot of things have
been normalized to function in a more consistent manner -- this was in
a sense an effect of the reduction of essential tables from ~80 to ~30.

One change is that groups are now much more generic than before, which
permits groups to have parents and children, and permits us to have
multiple types and trees of groups.  The areas are groups, with WGs as
children, the ietf itself is a group, the irtf is a group, and so on.

Documents processed by the IESG now always has an association with a group.
For regular WG documents, the group is the WG to which they belong, but
for AD sponsored documents, they are associated with an area.  This is
not necessarily the area of the sponsoring AD; any area can be set.

An effect of this is that with an area set as the group for a draft, the
draft email aliases on tools.ietf.org will include the <area>-chairs in
the alias list for the draft, so that for instance all the int-area chairs
will be copied on notifications for AD-sponsored drafts belonging in the
int area.

Question:

As said above, I don't know if this is good; it's easy to change,
but I thought I'd better ask you if you want to keep this or not?

Best regards,

	Henrik

---

From: Yaakov Stein <[email-masked]>
Date: Tue, 6 Mar 2012 11:55:48 +0000

Henrik

I think that the side effect of WG chairs being notified of AD-sponsored IDs is useful.
I normally only find out about such things at meetings,
i.e., with several months of delay.
Assuming that there are not that many of them,
I would prefer to see and delete something unimportant to me, 
than to find out about something important very late in the day.

Your explanation of the hierarchy does raise a question - 
Will an IETF-chair sponsored document (e.g., on the number of maturity levels or such)
be announced to all ADs? Recursively to all WG chairs ? 
or just to those in the "General Area" (of which there are presently none) ?

Y(J)S

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Henrik Levkowetz
Sent: Tuesday, March 06, 2012 12:42
To: WG Chairs; IESG
Subject: Changed behaviour of the draft-* aliases on tools.ietf.org for AD-sponsored drafts

Hi,

Background:

Question:

Best regards,

	Henrik

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 06 Mar 2012 13:39:39 +0100

Hi Yaakov,

On 2012-03-06 12:55 Yaakov Stein said:
> Henrik
> 
> I think that the side effect of WG chairs being notified of
> AD-sponsored IDs is useful. I normally only find out about such
> things at meetings, i.e., with several months of delay. Assuming that
> there are not that many of them, I would prefer to see and delete
> something unimportant to me, than to find out about something
> important very late in the day.
Ok.

> Your explanation of the hierarchy does raise a question - Will an
> IETF-chair sponsored document (e.g., on the number of maturity levels
> or such) be announced to all ADs? Recursively to all WG chairs ? or
> just to those in the "General Area" (of which there are presently
> none) ?

If the document's group was set to 'gen', it would go to the gen-chairs
list (currently empty); if it was set to 'ietf', it would not go to any
chairs because I don't generate an ietf-chairs list currently.

I can easily do so, if desired; I can also tweak the generation of
'gen-chairs' to include all WG chairs if desired.

Best regards,

	Henrik

---

From: Sean Turner <[email-masked]>
Date: Tue, 06 Mar 2012 07:52:29 -0500

Henrik,

I replied to a message that had a [email-masked] alias 
and all the WG chairs in the SEC area got a copy.  Are you saying that 
the .all alias is now set based on the area - but that's just for 
AD-sponsored drafts? For WG based docs, the .all alias will still just 
be the ADs and anybody in the "send notices to" datatracker entry?

spt

On 3/6/12 5:42 AM, Henrik Levkowetz wrote:
> draft email aliases on tools.ietf.org will include the<area>-chairs in

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 06 Mar 2012 14:38:45 +0100

Hi Sean,

On 2012-03-06 13:52 Sean Turner said:
> AD-sponsored drafts?

Yes.

Both the [email-masked] and [email-masked]
aliases will list the area's WG chairs for AD-sponsored drafts.  (The area
will be that which is set for the document, which is not necessarily the
area of the sponsoring AD.)

> For WG based docs, the .all alias will still just 

Yes, correct.

Best regards,

	Henrik

---

From: Paul Hoffman <[email-masked]>
Date: Tue, 6 Mar 2012 07:07:48 -0800

> but I thought I'd better ask you if you want to keep this or not?

It is *not* good. There are things that I would say to the authors and ADs about a document that I don't necessarily want to be shared with the entire community. Given that the name on the left of the @ describes something, having messages sent there be much more widely distributed will lead to people not wanting to use those addresses.

Similarly, there are plenty of drafts that Sean and Stephen sponsor that I have absolutely no interest in.

--Paul Hoffman

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 06 Mar 2012 16:42:34 +0100

Hi Paul,

> It is *not* good. There are things that I would say to the authors and ADs about a document that I don't necessarily want to be shared with the entire community. Given that the name on the left of…

The following aliases exist on tools.ietf.org for drafts:

	draft-xxx		Goes to authors only today -- could be redefined
				if desired.  Including the shepherd has been
				suggested.
	draft-xxx.authors	Goes to authors only
	draft-xxx.notify	Goes to addresses in the notification field for
				  the draft in the datatracker
	draft-xxx.ad		Goes to the ADs
	draft-xxx.chairs	Goes to the WG chairs
	draft-xxx.all		Goes to all the above

Only the .chairs and the .all aliases have changed, and only for AD-sponsored
documents.  Sorry if that wasn't clear from my initial notice.

Ok.

	Henrik

---

From: Paul Hoffman <[email-masked]>
Date: Tue, 6 Mar 2012 07:47:27 -0800

> documents.  Sorry if that wasn't clear from my initial notice.

Still, if I send a message to something called "all" for a document, I would not expect my message to be read by one or two dozen WG chairs that have absolutely nothing to do with the document. It's like a Bcc I didn't even know about.

--Paul Hoffman

---

From: Yaron Sheffer <[email-masked]>
Date: Tue, 06 Mar 2012 17:53:14 +0200

Having been surprised by one of these emails, +1!

---

From: Dave Crocker <[email-masked]>
Date: Tue, 06 Mar 2012 07:55:54 -0800

> documents.  Sorry if that wasn't clear from my initial notice.

I'm not sure what the precise set should be for each of these.  I am, however, 
quite certain that people will not remember the precise sets and will get 
surprised sometimes.

On the other hand, people do learn conventions over time, as long as it is easy 
enough for them to find out the details when they can't remember.  Of course it 
also helps to try to make the sets 'intuitive'.

That list of choices you've defined and the current distributions for them make 
sense to me.  On the average, when I see an "all" qualifier, I assume that I 
should treat what I write as fully public, simply because the term 'all' is 
unbounded, other than inviting a sense of expansive scope.

authors, ad and chairs all seem unlikely to be misunderstood or used incorrectly.

d/

-- 

   Dave Crocker
   Brandenburg InternetWorking
   bbiw.net

---

From: Warren Kumari <[email-masked]>
Date: Tue, 6 Mar 2012 11:40:42 -0500

On Mar 6, 2012, at 10:55 AM, Dave Crocker wrote:

> I'm not sure what the precise set should be for each of these.  I am, however, quite certain that people will not remember the precise sets and will get surprised sometimes.
> 
> On the other hand, people do learn conventions over time, as long as it is easy enough for them to find out the details when they can't remember.  Of course it also helps to try to make the sets 'intuitive'.
> 
> That list of choices you've defined and the current distributions for them make sense to me.  On the average, when I see an "all" qualifier, I assume that I should treat what I write as fully public, simply because the term 'all' is unbounded, other than inviting a sense of expansive scope.
> 

<bikeshed>
How about adding yet another alias -- draft-xxx.area	Goes to all the chairs in the area ? This would allow chairs to find out about AD sponsored docs, but is still clear enough where it will go...
</bikeshed>

W

---

From: Marshall Eubanks <[email-masked]>
Date: Tue, 6 Mar 2012 12:28:56 -0500

> How about adding yet another alias -- draft-xxx.area    Goes to all the chairs in the area ? This would allow chairs to find out about AD sponsored docs, but is still clear enough where it will go.…

Would that be above "all," or would "all" include "area" ?

Regards
Marshall

---

From: Jeffrey Hutzelman <[email-masked]>
Date: Tue, 06 Mar 2012 12:33:49 -0500

> than to find out about something important very late in the day.

I agree that it would be nice to find out quickly and automatically
about documents sponsored by ADs in my area.

But, I don't think this is the mechanism for it.
The .chairs alias is supposed to go to the chairs of the WG whose
product the document is.  If a document is not a WG product, then that
set is empty, not all of the chairs in an area.  I understand how the
change came about, but it is nonetheless a bug and should be fixed.

-- Jeff

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 06 Mar 2012 18:45:54 +0100

Hi Warren,

> How about adding yet another alias -- draft-xxx.area	Goes to all the chairs in the area ? This would allow chairs to find out about AD sponsored docs, but is still clear enough where it will go...

I'm not sure that's a replacement for the current behaviour.  Surely .area would
always go to all the area; not only for AD-sponsored documents?

Best regards,

	Henrik

---

From: John C Klensin <[email-masked]>
Date: Tue, 06 Mar 2012 13:26:28 -0500

FWIW, I completely agree with Paul about this.  If an alias for
all of the chairs in an area is needed, let's make one (I have
doubts that it is).  But silent expansion of an alias that
appears to designate something else or that requires me to
remember complex rules about what goes where is just not a good
idea.

    john

--On Tuesday, March 06, 2012 07:07 -0800 Paul Hoffman
<[email-masked]> wrote:

>> As said above, I don't know if this is good; it's easy to
>> change, but I thought I'd better ask you if you want to keep
>> this or not?
> 
> 
> It is *not* good. There are things that I would say to the
> authors and ADs about a document that I don't necessarily want
> to be shared with the entire community. Given that the name on
> the left of the @ describes something, having messages sent
> there be much more widely distributed will lead to people not
> wanting to use those addresses.
> 
> Similarly, there are plenty of drafts that Sean and Stephen
> sponsor that I have absolutely no interest in.

---

From: Brian Haberman <[email-masked]>
Date: Tue, 06 Mar 2012 14:09:22 -0500

Maybe my brain is dusty/rusty/musty, but I seem to recall there being an 
int-chairs alias that included all the chairs within the INT area. 
Perhaps it was not a tools-based alias...

Regards,
Brian

---

From: Yaakov Stein <[email-masked]>
Date: Tue, 6 Mar 2012 20:11:59 +0000

I don't need to receive all the internal correspondence regarding an AD-sponsored draft.
But I do want to see the announcement.

So defining a "all chairs in area" alias is fine with me, 
as long as it is added to ID announcements of such drafts.

Y(J)S

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of John C Klensin
Sent: Tuesday, March 06, 2012 20:26
To: Paul Hoffman; Henrik Levkowetz
Cc: WG Chairs
Subject: Re: Changed behaviour of the draft-* aliases on tools.ietf.org for AD-sponsored drafts

    john

---

From: Robert Sparks <[email-masked]>
Date: Tue, 06 Mar 2012 17:00:51 -0600

That alias is there.

See
<http://tools.ietf.org/ad/aliases>

The current expansion for the various draft aliases is at
<http://tools.ietf.org/draft/aliases>

On 3/6/12 1:09 PM, Brian Haberman wrote:
> Maybe my brain is dusty/rusty/musty, but I seem to recall there being 
> an int-chairs alias that included all the chairs within the INT area.

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 07 Mar 2012 10:08:49 +0100

So, trying to sum things up so far, what I'm hearing is that most people
don't want to be copied on discussions regarding AD-sponsored drafts in
their area, but would like to get announcements regarding them.

I'll change the generation of draft-xxxx.chairs and draft-xxx.all aliases
for AD-sponsored drafts accordingly, and add the desire for announcements
to the area to the ToDo list (as that will be new functionality).

Thanks, and best regards,

	Henrik

---

From: Ondřej Surý <[email-masked]>
Date: Mon, 12 Mar 2012 09:37:46 +0100

+1 for me

As somebodey said in the thread - announcement is great, all communication for draft I have no interest in is very bothersome.

Also I think we will not be able to communicate the change to general public, so it also might breach a privacy of some emails.

O.

--
 Ondřej Surý
 vedoucí výzkumu/Head of R&D department
 -------------------------------------------
 CZ.NIC, z.s.p.o.    --    Laboratoře CZ.NIC
 Americka 23, 120 00 Praha 2, Czech Republic
 mailto:[email-masked]    http://nic.cz/
 tel:+420.222745110       fax:+420.222745112
 -------------------------------------------