Subject: The past hour at the IETF technical plenary

From: Paul Hoffman <[email-masked]>
Date: Wed, 28 Mar 2012 19:27:03 +0200

...has been about how WG chairs ask for too many conflicts for meeting slots, and about how poorly we run our meetings. We should discuss this more. Many people are pretty unhappy about negative side-effects of how we are doing our jobs.

--Paul Hoffman

---

From: Cullen Jennings <[email-masked]>
Date: Wed, 28 Mar 2012 19:35:03 +0200

hmm … seemed like many people at the mic where chairs :-)