Subject: Re: Etherpad for collaborative note-taking

From: Lou Berger <[email-masked]>
Date: Wed, 21 Mar 2012 08:40:04 -0400

Henrik,
	Will the same etherpad setup be available for this IETF?  We found it
*very* useful at the last meeting (even with the minor hiccups).

Much thanks,
Lou

On 11/9/2011 5:43 AM, Henrik Levkowetz wrote:
> Hi,
> 
> Acting on a recent suggestion from Peter Saint-Andre (on [email-masked]),
> I've now set up an instance of Etherpad Lite (http://etherpad.org/) on
> one of the tools servers, and used it to make a collaborative notes
> document available for all WGs with a posted agenda for IETF-82.
> 
> You'll find it both linked in and embedded in the minutes page for your WG
> on tools.ietf.org; for an example see http://tools.ietf.org/wg/clue/minutes
> 
> The note documents will be visible on the minutes page until you submit
> official minutes for the meeting, at which time they will be replaced
> by the minutes.  The etherpad documents will still be accessible directly
> at the etherpad URL for some time after the meeting, but will be archived
> and replaced by new empty documents before the next meeting.
> 
> Comments and suggestions are welcome!
> 
> 
> Best regards,
> 
> 	Henrik
> 
> 
> 
>

---

From: Peter Saint-Andre <[email-masked]>
Date: Wed, 21 Mar 2012 08:18:31 -0600

+1

On 3/21/12 6:40 AM, Lou Berger wrote:
> Henrik, Will the same etherpad setup be available for this IETF?
> We found it *very* useful at the last meeting (even with the minor
> hiccups).
> 
> Much thanks, Lou
> 
>> Acting on a recent suggestion from Peter Saint-Andre (on
>> [email-masked]), I've now set up an instance of Etherpad Lite
>> (http://etherpad.org/) on one of the tools servers, and used it
>> to make a collaborative notes document available for all WGs with
>> a posted agenda for IETF-82.
>> 
>> You'll find it both linked in and embedded in the minutes page
>> for your WG on tools.ietf.org; for an example see
>> http://tools.ietf.org/wg/clue/minutes
>> 
>> The note documents will be visible on the minutes page until you
>> submit official minutes for the meeting, at which time they will
>> be replaced by the minutes.  The etherpad documents will still be
>> accessible directly at the etherpad URL for some time after the
>> meeting, but will be archived and replaced by new empty documents
>> before the next meeting.
>>

---

From: Behcet Sarikaya <[email-masked]>
Date: Wed, 21 Mar 2012 10:19:07 -0500

Hi Henrik,

>>>>> http://tools.ietf.org/wg/clue/minutes

Sorry, I don't see any link for Etherpad in mine?

Regards,

Behcet

---

From: Behcet Sarikaya <[email-masked]>
Date: Wed, 21 Mar 2012 11:52:13 -0500

Oops, I saw it.

Pls ignore this mail.

Behcet

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 21 Mar 2012 17:58:20 +0100

Hi Lou,

> *very* useful at the last meeting (even with the minor hiccups).

That is the plan, yes.  I haven't verified that everything still works as
intended, but I will.

Best regards,

	Henrik

---

From: Tina TSOU <[email-masked]>
Date: Wed, 21 Mar 2012 17:06:46 +0000

That's really useful, hope it will not freeze the screen sometimes like other tool.

Sent from my iPad

---

From: Lou Berger <[email-masked]>
Date: Wed, 21 Mar 2012 13:46:34 -0400

Henrik,
	I really appreciate (a position shared by many, I'm sure) your
contribution to the IETF.  As is typical, you not only responded to my
mail quickly, you already have the requested function available!

If I forget, please remind me to buy you a drink in Paris.

Lou

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 26 Mar 2012 01:13:20 +0200

Hi,

The etherpad deployment for the previous meeting had all the etherpad
documents running on the same server instance.

However, as etherpad seems to be unwilling to let you have multiple
connections to the same server open in the same browser, this results
in it not being possible to follow the notes from two parallel sessions
at the same time.

I don't know how big a problem this is, but for this meeting I planned
to set up as many parallel instances as there are session rooms, and
distribute the wg sessions on the servers according to the room.

I now have this implemented, and it seems to be working (even if testing
is a bit hard here in the meeting hotel at the moment, with between
30% and 50% packet loss...)

The 8 separate instances are running on port numbers from 9001 to 9008,
for instance (for the clue wg):
  http://grenache.tools.ietf.org:9006/p/notes-ietf-83-clue

However, as I've got this in place only now, Sunday evening, I'd like to
ask you to please refresh your tools.ietf.org/wg/*/minutes browser page
before starting to use the etherpad, to make sure you pick up the appropriate
port number for your WG.

Please let me know if you have any trouble with this, so I can fix it.

Best regards,

	Henrik

---

From: Ray Bellis <[email-masked]>
Date: Mon, 26 Mar 2012 12:30:26 +0000

> Please let me know if you have any trouble with this, so I can fix it.

I've refreshed my page (homenet) but don't see any etherpad link, let alone one running on a new port...

Does the link only appear nearer the session?

Ray

---

From: Ray Bellis <[email-masked]>
Date: Mon, 26 Mar 2012 12:47:43 +0000

> Does the link only appear nearer the session?

Ah, I see what's happened.

There was some foul up after IETF 82 (I don't recall how it happened) that ended up with our minutes appearing as if they were for IETF 83.

Hence the system thinks we already met...

Ray

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 26 Mar 2012 14:49:02 +0200

Hi Ray,

> Does the link only appear nearer the session?

The link (and inline frame) only appears when the tools server has found
an agenda for the meeting, and there's not yet minutes in place.  Some
glitch has resulted in there being minutes in place already for IETF-83
for homenet.  I'll fix that.

Best regards,

	Henrik

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 26 Mar 2012 14:54:58 +0200

Hi Ray,

> Hence the system thinks we already met...

Right :-)

Fixed now.

Best regards,

	Henrik

---

From: Ray Bellis <[email-masked]>
Date: Mon, 26 Mar 2012 17:33:10 +0000

> Fixed now.

Thanks, as ever :)

Ray

---

From: Simon Perreault <[email-masked]>
Date: Sat, 31 Mar 2012 10:31:51 +0200

Henrik,

I used Etherpad as a minute taker and overall loved it. FYI, I found two 
minor annoyances, don't know if they are already known:

- About every 30 minutes (not exactly sure), it "disconnects" and asks 
me to reconnect. The button is above the page cut (I have a small 
netbook) so it took me a while to notice it. When I clicked it I got 
reconnected without data loss.

- The "chat" button at the bottom right is in the way when typing. It 
would be better if it was somewhere else.

Simon
-- 
DTN made easy, lean, and smart --> http://postellation.viagenie.ca
NAT64/DNS64 open-source        --> http://ecdysis.viagenie.ca
STUN/TURN server               --> http://numb.viagenie.ca

---

From: John C Klensin <[email-masked]>
Date: Sat, 31 Mar 2012 08:57:15 -0400

(copying vmeet)

--On Saturday, March 31, 2012 10:31 +0200 Simon Perreault
<[email-masked]> wrote:

> Henrik,
> 
> I used Etherpad as a minute taker and overall loved it. FYI, I
> found two minor annoyances, don't know if they are already
> known:
> 
> - About every 30 minutes (not exactly sure), it "disconnects"
> and asks me to reconnect. The button is above the page cut (I
> have a small netbook) so it took me a while to notice it. When
> I clicked it I got reconnected without data loss.
> 
> - The "chat" button at the bottom right is in the way when
> typing. It would be better if it was somewhere else.

Let me add two things from the perspective of the remote
participant.

	- I had to manually scroll the window after every lines
	that were typed at the meeting.   Attempts to work
	around that by having the minute taker insert a "this is
	the bottom line" (or equivalent) line and then type
	above it didn't help consistently.   Minor annoyance if
	one is trying to track only the Etherpad but, if one
	needs to also track a Jabber room while paging through a
	slide deck, the behavior becomes enough of a problem to
	make remote viewing of the Etherpad much less useful.

	 - There were a number of WGs in which the Etherpad
	 never came up remotely. Clicking on the link brought
	 up only the "type here..." screen and refreshing
	 didn't change anything.  I had no way to know whether
	 that was some sort of connection problem or whether
	 that particular WG just wasn't using the tool.  I was
	 so busy fighting with other problems that I didn't
	 even bother asking about that on Jabber.

>From the perspective of longer-term RPS use, this suggests
another three "operational" observations (with the same "if it
isn't practically usable for operational reasons, it doesn't
make any difference what the tools are" comment I've made
before).  

(1) If we are going to have a variety of these services floating
around, most of which are optional (I think that at present only
streaming audio and Jabber are not optional) we need to get much
better about telling remote folks that something is not planned
for use in a particular WG.  I'd much rather have links
(preferably from a consolidated agenda rather than a "remote
participation" page) for WebEx and Meetecho that often lead to
"not scheduled for this session" pages than to try to deduce
that from the absence of mention in a table and hoping that I
didn't miss an email message indicating that one or the other
was scheduled late and is expected after all.  Such links can be
updated if needed; then the most the remote participant needs to
do is to reload the agenda page frequently.  

(2) If a WG is not going to use Etherpad, then either the
Chair(s) need to tell the Secretariat (or whomever) that they
don't intend to use it so _that_ link can be pointed to a "not
using this" page or ask someone to explicitly type "WG foo is
not using Etherpad for its minutes" into the Etherpad page,
preferably both.  The latter would permit the remote user to
easily distinguish between intentional non-use (the above
caption) and connectivity/ transmission issues (the "start
typing here" caption) so that the latter could be reported and,
one hopes, fixed.

(3) Just as we have an ongoing discussion about how early slides
need to be posted, but (I believe) no disagreement that they
should be posted, I think we should look at how early a WG's
leadership is expected to get organized about what remote
participation features (including Etherpad) it intends to use.
My recommendation is that we make it part of the meeting request
template and process, making the same procedures for updating
the information that we make for updating agendas and/or the
requests themselves.   I can see very little reason why at least
the intentions of WG Chairs should not be available far enough
in advance of the meeting (previous Monday? Wednesday? Friday?)
to avoid a fire drill during the meeting week.  There will
always be exceptions --if we can change our minds about whether
to hold a meeting or when it will be held after IETF starts, we
should certainly be able to change our minds about a remote
participation tool-- but they should be infrequent enough that
the two suggestions above should be sufficient.

thanks,
     john