Subject: pre-approving -00 drafts

From: Donald Eastlake <[email-masked]>
Date: Fri, 6 Apr 2012 13:15:49 -0400

When I try to go to
https://datatracker.ietf.org/cgi-bin/wg/wg_init_rev_approval.cgi,
which, for example, is linked off the
http://www.ietf.org/wg/chairs-page.html Working Group Chairs' Page, I
seem to just get immediately re-directed to the datatracker. Is there
some new trick?

Thanks,
Donald
=============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 155 Beaver Street, Milford, MA 01757 USA
 [email-masked]

---

From: S Moonesamy <[email-masked]>
Date: Fri, 06 Apr 2012 10:25:54 -0700

Hi Donald,
>https://datatracker.ietf.org/cgi-bin/wg/wg_init_rev_approval.cgi,

It should be https://datatracker.ietf.org/wg/wg-name/  I was told the 
pre-approval is not working correctly due to a bug in the datatracker.

Regards,
S. Moonesamy

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Fri, 6 Apr 2012 17:38:32 +0000

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Donald Eastlake
> Sent: Friday, April 06, 2012 10:16 AM
> To: Working Group Chairs
> Subject: pre-approving -00 drafts
> 
> When I try to go to

After you log in to the datatracker, you should see an "Adopt in WG" link for any document that's not a WG document.  I think that's the new way to do it, via a "Call for Adoption" step.  However, I haven't actually tried it to see if, after that, it offers you a way to create -00 working group documents.

We've discovered that you don't even get the "Adopt in WG" link if an individual submission is in "AD is watching" state, so there are possibly multiple obstacles here.

The bug has been reported, but we haven't heard anything back yet.

-MSK

---

From: Donald Eastlake <[email-masked]>
Date: Fri, 6 Apr 2012 14:17:49 -0400

Hi Murray,

> After you log in to the datatracker, you should see an "Adopt in WG" link for any document that's not a WG document.  I think that's the new way to do it, via a "Call for Adoption" step.  However,…

Well, if you click on that you then get to choose which of your WGs
you want to move towards adopting it and there is an ominous button
labeled "Call for adoption". Will that automatically post email to the
WG mailing list or something? And, at least through that stage, there
has been no opportunity to specify the file name for the WG draft
which might be different from the individual draft file name. And what
about drafts that start their life as a WG draft because they come out
of extensive discussions and consensus? As far as I know, there isn't
an IETF required process for making a draft a WG draft but one seems
to be assumed here...

I suppose if I get the WG draft version and this hasn't been
straightened out, I'll just ask internet-drafts to post it and note
that it replaces the individual version.

Thanks,
Donald

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Fri, 6 Apr 2012 18:25:54 +0000

> From: Donald Eastlake [mailto:[email-masked]]
> Sent: Friday, April 06, 2012 11:18 AM
> To: Murray S. Kucherawy
> Cc: Working Group Chairs
> Subject: Re: pre-approving -00 drafts
> 
> Well, if you click on that you then get to choose which of your WGs you
> want to move towards adopting it and there is an ominous button labeled
> "Call for adoption". Will that automatically post email to the WG
> mailing list or something? And, at least through that stage, there has
> been no opportunity to specify the file name for the WG draft which
> might be different from the individual draft file name. And what about
> drafts that start their life as a WG draft because they come out of
> extensive discussions and consensus? As far as I know, there isn't an
> IETF required process for making a draft a WG draft but one seems to be
> assumed here...
> 

You're about where I am.  I'm tempted to post a dummy draft to use as a guinea pig and walk it through the implicit datatracker process.  I have a working group about to shut down so the experiment wouldn't be too disruptive if I did it over there.

It would be nice if the tools team would explain or document this.  I was hoping they'd have talked about it in Paris, but then I didn't actually ask for that either.

But it is becoming a pain point that creating -00 documents is either not available or not obvious right now.

-MSK