Subject: Formats for WG and BOF Agendas

From: Russ Housley <[email-masked]>
Date: Tue, 17 Apr 2012 15:00:14 -0400

Some WG and BOF chairs have been posting agendas in many different formats, including text, html, pdf, ppt, and pptx.  Until recently, only .txt and .html files were supported  for session minutes and agendas.  In fact the support for the other formats was never announced, but you guys found the new capability without any announcement.

Magnus Westerlund has asked that links to meeting agendas and minutes be long-term persistent.  He would like a URL that works regardless of the format.  I support this request, and the Secretariat tells me that it would not difficult to support, especially if text and html are the only formats that we accept.  It is possible to make this approach work for PDF and PPT files as well, but the Secretariat feels that .txt and .html files integrate into the website better than the other formats.  In addition, Henrik points out that the use of PDF and PPT files will make it harder to provide inline agendas in the Datatracker.

I propose that we to revert to supporting only .txt and .html file types for session minutes and agendas.  Then, using Apache's content negotiation, the Secretariat can link to them with an extension-less URL.  Apache will set the appropriate content-type.  This way the URLs will be persistent and consistent across supported file formats.

Does anyone have concerns with the proposed way forward?

Russ

---

From: "John G. Scudder" <[email-masked]>
Date: Tue, 17 Apr 2012 15:42:43 -0400

> Does anyone have concerns with the proposed way forward?

Au contraire, sounds like a fine thing. 

--John

---

From: Karen O'Donoghue <[email-masked]>
Date: Tue, 17 Apr 2012 15:48:14 -0400

Sounds fine to me as well...

Karen

On 4/17/12 3:42 PM, John G. Scudder wrote:
> On Apr 17, 2012, at 3:00 PM, Russ Housley<[email-masked]>  wrote:
>

---

From: Adam Roach <[email-masked]>
Date: Tue, 17 Apr 2012 14:49:06 -0500

> Does anyone have concerns with the proposed way forward?

Speaking as a chair who works on the tools during code sprints (and 
agenda-related tools in particular), I _strongly_ support the proposal 
to re-impose the restriction that agendas can be text and HTML only.

/a

---

From: John C Klensin <[email-masked]>
Date: Tue, 17 Apr 2012 16:19:16 -0400

--On Tuesday, April 17, 2012 15:00 -0400 Russ Housley
<[email-masked]> wrote:

> Some WG and BOF chairs have been posting agendas in many
> different formats, including text, html, pdf, ppt, and pptx.
> Until recently, only .txt and .html files were supported  for
> session minutes and agendas.  In fact the support for the
> other formats was never announced, but you guys found the new
> capability without any announcement.
> 
> Magnus Westerlund has asked that links to meeting agendas and
> minutes be long-term persistent.  He would like a URL that
> works regardless of the format.  I support this request, and
> the Secretariat tells me that it would not difficult to
> support, especially if text and html are the only formats that
> we accept.  It is possible to make this approach work for PDF
> and PPT files as well, but the Secretariat feels that .txt and
> .html files integrate into the website better than the other
> formats.  In addition, Henrik points out that the use of PDF
> and PPT files will make it harder to provide inline agendas in
> the Datatracker.
> 
> I propose that we to revert to supporting only .txt and .html
> file types for session minutes and agendas.  Then, using
> Apache's content negotiation, the Secretariat can link to them
> with an extension-less URL.  Apache will set the appropriate
> content-type.  This way the URLs will be persistent and
> consistent across supported file formats.

Russ, while I think we can safely do without PPT (or anything
else proprietary), I'm concerned that prohibiting PDF would
accidentally prevent the use of artwork when artwork is
appropriate.  I think that is especially a matter of concern if
this principle and format limitation were in the future to be
expanded to minutes.  Now, perhaps we don't need artwork/ images
in agendas: if everyone else is comfortable with that, then I am
too and have no objection to restricting them to plain text and
simple (one file) HTML.

best,
    john

---

From: Stephen Kent <[email-masked]>
Date: Tue, 17 Apr 2012 16:15:55 -0400

At 3:00 PM -0400 4/17/12, Russ Housley wrote:
>...

I have no problem with text or HTML agendas.  As for minutes, I used
to always provide HTML, but have found that MS Word produces output
that is hard for me to control, and is somewhat unpredictable. I posted
minutes as PDF this time and found the result was much more predictable.

Steve

---

From: "James M. Polk" <[email-masked]>
Date: Tue, 17 Apr 2012 16:22:35 -0500

good idea

At 02:48 PM 4/17/2012, Karen O'Donoghue wrote:
>>>I propose that we to revert to supporting only .txt and .html file 
>>>types for session minutes and agendas.  Then, using Apache's 
>>>content negotiation, the Secretariat can link to them with an 
>>>extension-less URL.  Apache will set the appropriate 
>>>content-type.  This way the URLs will be persistent and consistent 
>>>across supported file formats.
>>>

---

From: Glen Zorn <[email-masked]>
Date: Wed, 18 Apr 2012 08:55:44 +0700

> Does anyone have concerns with the proposed way forward?

Seems perfectly reasonable to me (less is more!).

---

From: Yaakov Stein <[email-masked]>
Date: Wed, 18 Apr 2012 05:03:42 +0000

I can easily go along with plain text for agendas.
In general, topics for discussion should be describable in plain text.

However, minutes may need diagrams, equations, international characters, etc.

Minutes should only be required to conform to the same format as RFCs.
For the time being this means pure text
(and thus the tools will work and the content will be as persistent as RFCs are).
However, if we do eventually decide on some new format for RFCs
then minutes would immediately be able to enjoy the new capabilities.

Y(J)S

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Russ Housley
Sent: Tuesday, April 17, 2012 22:00
To: IETF WG Chairs
Cc: Ryan Cross; Henrik Levkowetz
Subject: Formats for WG and BOF Agendas

Russ

---

From: Melinda Shore <[email-masked]>
Date: Tue, 17 Apr 2012 21:07:59 -0800

> then minutes would immediately be able to enjoy the new capabilities.

This is outside the scope of the question (to which my answer is
"Yay!"), but I have to say that as a matter of general principle,
anything that makes it slower and/or more work to get minutes out
is not a good thing.

Melinda

---

From: Salvatore Loreto <[email-masked]>
Date: Wed, 18 Apr 2012 08:55:35 +0300

> Does anyone have concerns with the proposed way forward?
I support the proposal

/Sal

---

From: "Joel M. Halpern" <[email-masked]>
Date: Wed, 18 Apr 2012 12:05:28 -0400

Pardon my lack of imagination, but why would minutes need diagrams?
Minutes are descriptions of what was discussed / resolved.  They are not 
intended to capture the details of the issues at the level that requires 
diagrams.

It seems to me a stretch even to need equations in minutes, although I 
suppose that is [possible.  My guess is that a crude approximation of 
the equation would suffice for minuting purposes in almost all cases.

Getting people's names right is a more meaningful issue.

Yours,
Joel

---

From: Andrew Sullivan <[email-masked]>
Date: Wed, 18 Apr 2012 12:10:27 -0400

On Wed, Apr 18, 2012 at 12:05:28PM -0400, Joel M. Halpern wrote:

> It seems to me a stretch even to need equations in minutes

Oh, I dunno.  A lot of WG discussions are probably most easily
summarized with something like

    A & ~A

I note, however, that you can still do that using ASCII.  So maybe we
don't need other formal logic symbols.

Best,

A

-- 
Andrew Sullivan
[email-masked]

---

From: Yaakov Stein <[email-masked]>
Date: Wed, 18 Apr 2012 16:16:27 +0000

For example, we want to capture in the minutes that it was decided that
the protocol should work this way <diagram> rather than the other proposal <diagram>.

Of course if Mr. <string of non-Latin characters> proposed that
the first parameter in <equation> should be determined by <equation>,
we would also need more than plain text.

Y(J)S

-----Original Message-----
From: Joel M. Halpern [mailto:[email-masked]] 
Sent: Wednesday, April 18, 2012 19:05
To: Yaakov Stein
Cc: IETF WG Chairs
Subject: Re: Formats for WG and BOF Agendas

Yours,
Joel

---

From: "Joel M. Halpern" <[email-masked]>
Date: Wed, 18 Apr 2012 12:23:06 -0400

Frankly, if I am taking minutes, I would much prefer to capture
The working group selected the diagram on slide 4 as a better 
description than the one on slide 5, rather than trying to figure out 
how the heck I was going to write the figure.

--  Yes, we have lost the ability to do diagrams and much of any other 
development work on the fly in working group sessions.  That is not the 
minutes problem.

Similarly for the equation, I would not want to try to recreate the 
equation in the minutes.  In both cases, if you are cutting and pasting 
from elsewhere, it is more than sufficient to put a reference to the 
"where" in the minutes.  The minutes are not themselves a working document.

I do think we should try to capture names properly, and that can be done 
by after-the-fact repairs.

Yours,
Joel

On 4/18/2012 12:16 PM, Yaakov Stein wrote:
> the protocol should work this way<diagram>  rather than the other proposal<diagram>.
>
> Of course if Mr.<string of non-Latin characters>  proposed that
> the first parameter in<equation>  should be determined by<equation>,

---

From: Yaakov Stein <[email-masked]>
Date: Wed, 18 Apr 2012 16:26:10 +0000

I completely agree that what you suggest is easier to do,
assuming that everyone us using fancy slides.
But what happens when we use the good old fashioned method of drawing up something on a whiteboard ?
(yes, I know it is heretical to actually work on something in a WG session)

Y(J)S

-----Original Message-----
From: Joel M. Halpern [mailto:[email-masked]] 
Sent: Wednesday, April 18, 2012 19:23
To: Yaakov Stein
Cc: IETF WG Chairs
Subject: Re: Formats for WG and BOF Agendas

Yours,
Joel

---

From: "Joel M. Halpern" <[email-masked]>
Date: Wed, 18 Apr 2012 12:30:25 -0400

I don't think the minutes are the place to capture the drawing, if you 
can actually succeed in working that way.  I can think of several ways 
to deal with it, depending upon other choices.  But not the minutes. 
The simple reason is that youa re going to need to capture the diagram 
somewhere else so that the working group can actually work with it.

Yours,
Joel

---

From: Fred Baker <[email-masked]>
Date: Wed, 18 Apr 2012 10:44:48 -0700

> too and have no objection to restricting them to plain text and

I personally think that HTML is preferred, as it is not proprietary (PDF actually is, although it is commonly used and doesn't change too much) and allows me to put in links. I'd be hard pressed to say why images were needed in an agenda. The agendas I post, such as the attached, are the simplest possible HTML that I can think of. Yes, it's program-generated, from 1id-index.txt and the names of the Internet Drafts that will be discussed, and then edited with an HTML editor such as SeaMonkey. 

I could see something a little more complex for minutes. We basically want a header for each discussion and then commentary on it, capturing important discussions, actions taken, and outcomes. I could imagine a lot of things, but one that would make sense to be were we to support it with a tool would be to start from an agenda like this and add links from each agenda item to slides used if any, a recording of the discussion, and a text summary. I would want PDF for the slides, mp4-or-whatever for the audio stream, and something not a lot more complicated than a text file for the minutes of that discussion. There are no doubt other ways to handle that as well, but that's one I might suggest.

To Russ's question, I have no problem with the proposal.

---

From: Adam Roach <[email-masked]>
Date: Wed, 18 Apr 2012 12:50:54 -0500

On 4/18/12 12:44 PM, Fred Baker wrote:
> I could see something a little more complex for minutes. We basically want a header for each discussion and then commentary on it, capturing important discussions, actions taken, and outcomes. I could imagine a lot of things, but one that would make sense to be were we to support it with a tool would be to start from an agenda like this and add links from each agenda item to slides used if any, a recording of the discussion, and a text summary. I would want PDF for the slides, mp4-or-whatever for the audio stream, and something not a lot more complicated than a text file for the minutes of that discussion.

Something like this?

http://www.ietf.org/proceedings/75/minutes/sipcore.html

It's not too hard to assemble something like that by hand, and HTML is 
very much up to the task. I'm not sure we really need anything more than 
the allowance of HTML as a minuting format.

/a

---

From: Fred Baker <[email-masked]>
Date: Wed, 18 Apr 2012 10:52:39 -0700

> But what happens when we use the good old fashioned method of drawing up something on a whiteboard ?

I'm very much in favor of white boards. However, if we were to try to include them in minutes, I think the right way to do that would either be to use a whiteboard that can print-to-pdf its contents, or take a photo of it. I have used both. 

That said, v6ops is probably a worst case, but many WGs I work in have the problem of "OK, we have 30 minutes to discuss <> and come to a resolution". In a ten person design team, it's useful to have a white board or whatever in the room to work through issues. With 100 people in the room, that can quickly become unmanageable, and can't be seen by all of the participants - especially remote ones. From my perspective, the value of slides is that they are thought through in advance and don't have to be sketched on the fly.

---

From: Fred Baker <[email-masked]>
Date: Wed, 18 Apr 2012 11:10:08 -0700

On Apr 18, 2012, at 10:50 AM, Adam Roach wrote:

> It's not too hard to assemble something like that by hand, and HTML is very much up to the task. I'm not sure we really need anything more than the allowance of HTML as a minuting format.

Pretty much.

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Wed, 18 Apr 2012 13:54:51 -0500

On 04/18/2012 12:44 PM, Fred Baker wrote:
> I could imagine a lot of things, but one that would make sense to be
> were we to support it with a tool would be to start from an agenda
> like this and add links from each agenda item to slides used if any,
> a recording of the discussion, and a text summary. I would want PDF
> for the slides, mp4-or-whatever for the audio stream, and something
> not a lot more complicated than a text file for the minutes of that
> discussion.

Fred: I have been providing exactly what you write above ---
including PDF slides and individual MP3 recordings corresponding
to each agenda item discussed during the WG meeting --- for the working
groups I chair and participate in for quite a while now.  See [1,2] for
examples.

This seem to work out well.  The minutes file has links to the
drafts, slides, and individual MP3 recording corresponding to
each WG agenda slot.  People can only download the MP3 for
a session they are interested in following instead of downloading
a large 75-400M file corresponding to the recording of the
entire session and seeking for the correct place in the recording
to find the relevant discussion of interest.

I have also worked with the folks at Meetecho to have them
split their streams into individual chunks corresponding to each
WG agenda discussion.  However, at least for now, I am still
splicing the raw MP3 audio file since (a) Meetecho does not cover
all IETF WGs, and (b) HTML5 support (for Meetecho) is not ubiquitous
across all platforms yet.  When Meetecho is available, I usually
provide both the Meetecho URLs as well as URLs to the spliced
audio; see [3] for an example.

[1] http://www.ietf.org/proceedings/83/minutes/minutes-83-alto.html
[2] http://www.ietf.org/proceedings/78/minutes/sipcore.html
[3] http://www.ietf.org/proceedings/83/minutes/minutes-83-i2aex.html

Thanks,

- vijay
-- 
Vijay K. Gurbani, Bell Laboratories, Alcatel-Lucent
1960 Lucent Lane, Rm. 9C-533, Naperville, Illinois 60563 (USA)
Email: vkg@{bell-labs.com,acm.org} / [email-masked]
Web:   http://ect.bell-labs.com/who/vkg/

---

From: S Moonesamy <[email-masked]>
Date: Wed, 18 Apr 2012 12:17:38 -0700

Hi Vijay,
>to find the relevant discussion of interest.

It's an impressive piece of work.  I am curious to see (off-list) the 
raw notes taken by
Sreekanth and Markus Isomaki.  Did you use some form of 
timecoding?  How long did you take to get this work done?

Regards,
S. Moonesamy

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Wed, 18 Apr 2012 15:06:27 -0500

On 04/18/2012 02:17 PM, S Moonesamy wrote:
>  raw notes taken by Sreekanth and Markus Isomaki.

SM: Absolutely.  I will send these to you in private email.

> Did you use some form of timecoding?

Unfortunately, no.  It would be good if automatic markers could be
placed in the media stream, but right now that is not the case.
Most of this, right now, is manual work (more below).

I have had chats with the IETF Secretariat on automating this, but
I understand that this is a work in progress.  I have automated
some aspects of the generating the per-agenda-item MP3 file, and
I have shared the Perl scripts I wrote, and the open-source tools
I use to split/join the MP3 file etc. with the Secretariat already.

> How long did you take to get this work done?

Well, since I have been doing this for a while, it takes me < 1/2 hour
or so --- with my semi-automated tools --- to finish this.  For the WGs
that I participate in and the WGs I chair, I usually annotate start and
stop times during the WG session and these allow me to recreate easily
when a discussion started and when it ended.

For a neophyte WG chair who has never done this before, the worst case
time involvement would be equal to the time spent on hearing the large
raw MP3 audio file (usually, 1-2.5 hours) and annotating the start and
stop times of each discussion item.  Once these times are annotated, my
simple Perl script will take them as input and chop the large MP3 file
into its constituents.

Thanks,

- vijay

---

From: John C Klensin <[email-masked]>
Date: Wed, 18 Apr 2012 17:02:35 -0400

--On Wednesday, April 18, 2012 10:44 -0700 Fred Baker
<[email-masked]> wrote:

>> appropriate.  I think that is especially a matter of concern
>> if this principle and format limitation were in the future to
>> be expanded to minutes.  Now, perhaps we don't need artwork/
>> images in agendas: if everyone else is comfortable with that,
>> then I am too and have no objection to restricting them to
>> plain text and simple (one file) HTML.
> 
> I personally think that HTML is preferred, as it is not
> proprietary (PDF actually is, although it is commonly used and
> doesn't change too much) and allows me to put in links. I'd be
> hard pressed to say why images were needed in an agenda. The
> agendas I post, such as the attached, are the simplest
> possible HTML that I can think of. Yes, it's
> program-generated, from 1id-index.txt and the names of the
> Internet Drafts that will be discussed, and then edited with
> an HTML editor such as SeaMonkey. 

Fred,

PDF was once, but is no longer.  As I understand it, the spec
was released to ISO some years ago along with full change
control. That makes it about as proprietary as, say, ASCII
(which also had its origins in a spec/proposal from one
company).  Like HMTL, Standard PDF is afflicted with a great
many proprietary extensions.  One of the thing that worries me
about HTML is that we are unlikely to be able and inclined to
impose and enforce conformance rules that keep files that are
"best viewed with version 1.2.3 of the FooBar browser" out of
our archives.  From the PDF side, a narrow "no extensions or
callouts allowed" definition is part of what PDF/A is all about.

HTML has one big advantage over PDF, which is that it is
plausible to assemble a relatively simple HTML file by hand,
while PDF essentially has to be compiled from some other format.
It also has one disadvantage, which is accessibility from a wide
variety of current and older tools as the standard evolves.
While absolute archival stability is the other important design
goal for PDF/A, I can only imagine what would occur if a simple,
HTML 3 or 4, rendering engine were suddenly confronted with an
input file that used many of the advanced features of HTML 5.  

If our goals for agendas include making them accessible to as
large a fraction of the community as possible, even those of us
who sometimes (or often) use older equipment and software, then
neither "PDF" nor "HTML" is a sufficient specification: for
either, we would need to specify a profile and be serious about
it, with "single file" being just the beginning.  In fairness,
that is also true of plain ASCII text because it is good to
specify line lengths and line-ending conventions and, e.g., "no
non-spacing control characters".  But that seems a little less
complex to me.

 best,
    john

---

From: Jeffrey Hutzelman <[email-masked]>
Date: Thu, 19 Apr 2012 02:58:06 -0400

> non-spacing control characters".  But that seems a little less

It seems to me we are overthinking this.

For _agendas_ plain text should certainly be more than enough.  For
minutes (which, as I understand it, were not actually at issue in Russ's
original post), plain text should _still_ be enough.  It's enough for
the vast majority of our actual standards documents; it certainly ought
to be enough for minutes, which are simply a record of what happened
during a meeting(*).

Note that I didn't say plain _ASCII_.  It is certainly appropriate to
use, say, UTF-8, particularly since plenty of people's names cannot be
correctly spelled without it.  But that doesn't have to mean also
allowing all (or some) sorts of markup.

That said, the situation for some time has been that both plain text and
HTML were accepted for both agendas and minutes, and recently the tools
have started accepting things like PDF and (ugh) PowerPoint.  It
certainly seems reasonably to me to restore the previous constraint,
which after all was not lifted deliberately.

(*) Minutes are not a transcript of the meeting, or a recording of the
meeting.  They do not need to contain the content of everything that was
discussed, proposed, or adopted in the meeting.  That is what we have
internet-drafts, mailing messages, and even slides for.

Minutes should record the topics of discussion, points or issues raised
(and by whom) and how they were resolved, decisions and actions taken or
promised, and the like.

-- Jeff

---

From: Yaakov Stein <[email-masked]>
Date: Thu, 19 Apr 2012 08:26:00 +0000

> (and by whom) and how they were resolved, decisions and actions taken or

Precisely.  However, if you could describe how an issue was resolved in plain text,
then plain text would be sufficient for RFCs as well.
And a lot of us believe that it is not (at least not ALWAYS).

Y(J)S

---

From: Yoav Nir <[email-masked]>
Date: Thu, 19 Apr 2012 12:22:07 +0300

Hi Jeffrey

> allowing all (or some) sorts of markup.

I have no objection to UTF-8 instead of ASCII, but I disagree with the statement that plenty of people's names cannot be spelled without it.

Sure, I would be thrilled if a mention of my name uses the correct characters, but here's a bit from the IPsecME minutes from Paris, which I modified to support UTF-8:

	# 219 Star topology as an admin choice
		People don't need to use this if they don't want to
		Say this in the security considerations
		יואב ניר:
			Has to be a requirement that any solution can implement different policies
		ירון שפר:
			Agrees with יואב, maybe becomes a use case
			Take this to the list

Is this readable to you?  Would a bunch of Cyrillic, Greek, Chinese or Arabic characters be any better?  The agendas and minutes are in English, so we're anyway going to render the names in English. Sure, somebody from france named François may prefer that his name not be spelled Francois, but that's just because the English rendition looks so close to the French, not because French people need their names rendered properly more than Chinese people.

I have no preference for ASCII as opposed to UTF-8.

Yoav

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 19 Apr 2012 12:20:15 +0100

I have read this thread and strongly support agendas being limited to text or
html. I encourage chairs to use html so that links to I-Ds and slides can be
embedded to make the meeting easier to participate in.

I also support minutes being limited to text or html. I hear the claim that
diagrams or equations may need to be captured in minutes, but I have not
experienced this need in my time at the IETF and I suspect that:
- it is rare
- it can usually be handled by ASCII-art
- it is not a big deal for the exceptional case to be handled through
   the submission of in I-D with a PDF variant

Thanks,
Adrian

> From: [email-masked] [mailto:[email-masked]] On Behalf Of Russ
> Housley
> Sent: 17 April 2012 20:00
> To: IETF WG Chairs
> Some WG and BOF chairs have been posting agendas in many different formats,
> including text, html, pdf, ppt, and pptx.  Until recently, only .txt and .html
files
> were supported  for session minutes and agendas.  In fact the support for the
> other formats was never announced, but you guys found the new capability
> without any announcement.
> 
> Magnus Westerlund has asked that links to meeting agendas and minutes be
> long-term persistent.  He would like a URL that works regardless of the
format.  I
> support this request, and the Secretariat tells me that it would not difficult
to
> support, especially if text and html are the only formats that we accept.  It
is
> possible to make this approach work for PDF and PPT files as well, but the
> Secretariat feels that .txt and .html files integrate into the website better
than
> the other formats.  In addition, Henrik points out that the use of PDF and PPT
files
> will make it harder to provide inline agendas in the Datatracker.
> 
> I propose that we to revert to supporting only .txt and .html file types for
session
> minutes and agendas.  Then, using Apache's content negotiation, the
Secretariat
> can link to them with an extension-less URL.  Apache will set the appropriate
> content-type.  This way the URLs will be persistent and consistent across
> supported file formats.
>

---

From: John C Klensin <[email-masked]>
Date: Thu, 19 Apr 2012 08:43:44 -0400

--On Thursday, April 19, 2012 12:20 +0100 Adrian Farrel
<[email-masked]> wrote:

> I have read this thread and strongly support agendas being
> limited to text or html. I encourage chairs to use html so
> that links to I-Ds and slides can be embedded to make the
> meeting easier to participate in.

Just an observation about the "so links can be embedded" reason
for permitting HTML...  I have never had any trouble putting
URIs into text files, nor with using those links once they are
inserted.  As a trivial example, http://www.ietf.org/ goes
perfectly well into this text/plain message.  

I'm not opposed to html if we impose a fairly simple profile on
its use.  Certainly it has advantages over plain text including
flexible formatting.  I just don't want to force readers into
use of browsers to read agendas nor to exaggerate the advantages.

    john

---

From: Jeffrey Hutzelman <[email-masked]>
Date: Thu, 19 Apr 2012 10:03:18 -0400

> then plain text would be sufficient for RFCs as well.

Not necessarily.  Minutes should record that a resolution was reached,
and which one, but should _not_ contain a detailed description of the
resolution.  Save that for the internet-draft and resulting RFC.

If _that_ requires more than plain text, so be it.  I'll argue against
relying too heavily on non-textual information in RFCs and especially in
protocol specifications, but I won't argue for prohibiting it.

-- Jeff

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 19 Apr 2012 10:08:34 -0400

Changing the subject to match the content

> allowing all (or some) sorts of markup.

My concern is that we minimize the hassle of both taking raw notes and 
assembling them into minutes.

In the groups I chair, and those I frequent and take notes for, we have 
not put any particular or strong requirements on the tools and formats 
that notes takers use. Some do it in text in the body of a mail message. 
Some use html in the body of an email. Some use other tools, including 
Word. Its easier to get note takers if they can use the tools they are 
comfortable with, and the notes are probably better that way too.

At ietf meetings I personally use MSWord to take my own notes. I prep in 
advance of the meeting, deriving a template doc from the agendas for the 
sessions I plan to attend. That makes it easier to keep up with live 
discussion. I find Word preferable here because its easier for me to 
delineate things, make lists, etc. When I am designated note taker for a 
session I take notes in the same way, but with more care than otherwise. 
Then after the meeting I tidy it up a bit to be readable by someone 
other than me, snip out the notes for the session and send them in - 
usually converted to text.

When assembling minutes for a session I chair, I have been assembling 
the raw notes from note takers, into a Word document, reformat and tweak 
as necessary, and then exporting that as an html document. I have been 
using Word because its fairly easy to import whatever notes I get into 
it and its fairly easy to reformat. I do however appreciate that there 
are a lot of options in going from Word to html that can affect how good 
the html is. And I may not be doing that optimally.

It would be more work to take that stuff and reformat it into raw text.

The above is not as easy as I might hope, but it isn't a large job. I'd 
appreciate something that was easier, but not rules that make it harder.

	Thanks,
	Paul

---

From: "Randy Presuhn" <[email-masked]>
Date: Thu, 19 Apr 2012 08:35:57 -0700

Hi -

> From: "Yaakov Stein" <[email-masked]>
> To: "Jeffrey Hutzelman" <[email-masked]>
> Cc: "IETF WG Chairs" <[email-masked]>
> Sent: Thursday, April 19, 2012 1:26 AM
> Subject: RE: Formats for WG and BOF Agendas
>

To me it seems that if the resolution cannot be described in plain text,
it's not adequately understood, and should be recorded as an action item
for the person or design team claiming to understand the resolution to post
that understanding to the WG mailing list.

Randy

---

From: Bob Hinden <[email-masked]>
Date: Thu, 19 Apr 2012 21:47:34 -0700

> Sounds fine to me as well...

+1

Bob

---

From: Jeffrey Hutzelman <[email-masked]>
Date: Fri, 20 Apr 2012 12:07:36 -0400

> perfectly well into this text/plain message.

... and when I click on it, the IETF web site pops up.

---

From: Russ Housley <[email-masked]>
Date: Fri, 20 Apr 2012 12:55:20 -0400

This is the consensus that I am hearing:

(1) The format independent URLs are desirable.  Let's make that happen.

(2) Agendas should be limited to text and html.

(3) Minutes should be limited to text, html, and pdf.

Russ

---

From: Yaakov Stein <[email-masked]>
Date: Sun, 22 Apr 2012 09:51:09 +0000

> that understanding to the WG mailing list.

... and assuming that someone can post to the list in any format, that solves the problem!
But at the price of making the minutes meaningless without reading all of these emails
in formats that will not persist.

I also don't agree with your statement that a statement that can't be captured
in plain text is not adequately understood. 
From a theoretical standpoint, nothing in natural human language can be completely understood. 
More importantly from a practical standpoint I have seen minutes that say 
"option 3 was considered the best by the group"
only to discover a year later that some thought this meant option 3A and others 3B. 

Y(J)S

---

From: Peter Koch <[email-masked]>
Date: Mon, 23 Apr 2012 09:26:34 +0200

> (3) Minutes should be limited to text, html, and pdf.

I'd support this without the PDF option.

On a related issue, we increasingly see the agendas and minutes only
posted to the materials site, which means there is no copy available
in the mail archives. Maybe that ought to change back.

-Peter

---

From: Dave Crocker <[email-masked]>
Date: Mon, 23 Apr 2012 07:27:46 -0700 (PDT)

when posted to the site, minutes should be auto-posted to the wg mailing list (and not just a link)?  

That sounds reasonable to me.

/d

--

Dave Crocker
bbiw.net

-----Original Message-----
From: Peter Koch <[email-masked]>
To: IETF WG Chairs <[email-masked]>
Sent: Mon, 23 Apr 2012 12:26 AM
Subject: Re: Formats for WG and BOF Agendas

-Peter

---

From: Russ Housley <[email-masked]>
Date: Mon, 23 Apr 2012 10:32:28 -0400

Not me.  Many times a WG chair posts them and then asks for comments.  Some chairs post edits as the comments come in.  That could lead to many postings, but the practice does reduce the number of times you get the same comment.

Russ

---

From: Julien Meuric <[email-masked]>
Date: Mon, 23 Apr 2012 16:57:27 +0200

Hi.

I agree. My experience with auto-mailing linked to document versioning 
will keep me away from that idea. If associated to auto-posting, I will 
tend to edit comments only on a local file which will be uploaded much 
later... (or sometimes even forgotten).

Anyway, an option (a button) allowing the chair/secretary to easily 
request an auto-generated announce could be a useful feature.

Julien

Le 23/04/2012 16:32, Russ Housley a écrit :
> Not me.  Many times a WG chair posts them and then asks for comments. 
>  Some chairs post edits as the comments come in.  That could lead to 
> many postings, but the practice does reduce the number of times you 
> get the same comment.
>
> Russ
>
>
>> _That_ sounds reasonable to me.
>>
>>
>> /d
>>
>> --
>>
>> Dave Crocker
>> bbiw.net <http://bbiw.net/>
>>
>>
>>
>>
>> From: Peter Koch <[email-masked] <mailto:[email-masked]>>
>> To: IETF WG Chairs <[email-masked] <mailto:[email-masked]>>