Subject: approval for initial document

From: "Murphy, Sandra" <[email-masked]>
Date: Wed, 27 Jun 2012 21:07:29 +0000

There was a discussion in March that the new tools don't make it easy to *pre*-approve -00 drafts.  I don't see anything in the archive that resolved that.  And I don't see a way on the datatracker page for my wg that would accomplish that.

The important dates ask that wg chairs approve -00 drafts by 2 July, with the -00 submission due by 9 July.

So the approvals are "appreciated" before submission.

What is the best way to do pre-approval?  Email to [email-masked]?

--Sandy

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 28 Jun 2012 12:34:47 +0200

Hi Sandy,

> What is the best way to do pre-approval?  Email to [email-masked]?

A pre-approval tool was deployed in the datatracker v4.21 release, dated
June 21.  Go to the datatracker, log in, and click on 'Submit a draft'
in the lefthand menubar.  On the next page, you should have a link in the
top (horizontal) menubar which says 'Approvals', where you can approve
already done submissions for your WG, and add pre-approvals.

Sorry for not announcing this more widely at the time.

Best regards,

	Henrik

---

From: "Murphy, Sandra" <[email-masked]>
Date: Thu, 28 Jun 2012 13:42:55 +0000

When I go to the datatracker, log in, go to approvals, I see a list about approvals including pre-approvals made, but no place to *make* a pre-approval.

Should I look somewhere else?

This is what I see:

Submissions you can approve

You don't have any submissions to approve.

Pre-approved drafts not yet submitted

No pre-approvals within your jurisdiction found.

Approved drafts within the past 30 days

No drafts approved.

--Sandy

________________________________________
From: Henrik Levkowetz [[email-masked]]
Sent: Thursday, June 28, 2012 6:34 AM
To: Murphy, Sandra
Cc: [email-masked]
Subject: Re: approval for initial document

Hi Sandy,

Best regards,

        Henrik

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 28 Jun 2012 15:56:07 +0200

Hi Sandy,

The page text you quote below looks like what I see when I'm not
logged in.  When I'm logged in (as mip4 chair) I see the following:

--------

You can add a pre-approval.

No drafts approved.
--------

Which login do you use?  Does it match the email associated with
your WG chair position?

Best regards,

	Henrik

---

From: "Murphy, Sandra" <[email-masked]>
Date: Thu, 28 Jun 2012 14:02:28 +0000

You are right.  I logged in on a different tab, and then switched to this tab.

Thanks.

--Sandy 
________________________________________
From: Henrik Levkowetz [[email-masked]]
Sent: Thursday, June 28, 2012 9:56 AM
To: Murphy, Sandra
Cc: [email-masked]
Subject: Re: approval for initial document

Hi Sandy,

--------

No drafts approved.
--------

Best regards,

        Henrik

---

From: Dave Crocker <[email-masked]>
Date: Thu, 28 Jun 2012 07:28:18 -0700

> logged in.  When I'm logged in (as mip4 chair) I see the following:

Is it worth exploring the possibility of having disabled commands being 
displayed as greyed-out, to show that they exist but are not (currently) 
accessible?

It's a common user interface trick and might help folk realize they need 
to be logged in.

d/
-- 
  Dave Crocker
  Brandenburg InternetWorking
  bbiw.net

---

From: Paul Hoffman <[email-masked]>
Date: Thu, 28 Jun 2012 07:38:19 -0700

On Jun 28, 2012, at 7:28 AM, Dave Crocker wrote:

> Is it worth exploring the possibility of having disabled commands being displayed as greyed-out, to show that they exist but are not (currently) accessible?
> 
> It's a common user interface trick and might help folk realize they need to be logged in.

+1

--Paul Hoffman

---

From: John C Klensin <[email-masked]>
Date: Thu, 28 Jun 2012 15:35:08 -0400

--On Thursday, June 28, 2012 07:28 -0700 Dave Crocker
<[email-masked]> wrote:

>> The page text you quote below looks like what I see when I'm
>> not logged in.  When I'm logged in (as mip4 chair) I see the
>> following:
> 
> 
> Is it worth exploring the possibility of having disabled
> commands being displayed as greyed-out, to show that they
> exist but are not (currently) accessible?
> 

+1

Or a heading on the page that says explicitly "Logged in as XXX"
or "Not logged in".  But I think I'd prefer Dave's suggestion if
it is feasible.

   john

---

From: Jeffrey Hutzelman <[email-masked]>
Date: Thu, 28 Jun 2012 16:17:58 -0400

> or "Not logged in".  But I think I'd prefer Dave's suggestion if

That appears, at the top-right corner: You get either a username or a
"Sign in" link.  However, it doesn't exactly jump out at you.

Sometimes showing greyed-out options is appropriate.  But sometimes it's
just confusing, and will lead users to spend time trying to figure out
how to enable an option that in fact they will never be able to use.

I expect it is probably the case that most people using the datatracker
don't have accounts and won't ever be able to make any changes.  So the
question is, is it worth potentially confusing all of those people in
order to help remind the much smaller number of people on this list that
they need to log in?

-- Jeff

---

From: John C Klensin <[email-masked]>
Date: Thu, 28 Jun 2012 16:30:17 -0400

--On Thursday, June 28, 2012 16:17 -0400 Jeffrey Hutzelman
<[email-masked]> wrote:

> That appears, at the top-right corner: You get either a
> username or a "Sign in" link.  However, it doesn't exactly
> jump out at you.
> 
> Sometimes showing greyed-out options is appropriate.  But
> sometimes it's just confusing, and will lead users to spend
> time trying to figure out how to enable an option that in fact
> they will never be able to use.
> 
> I expect it is probably the case that most people using the
> datatracker don't have accounts and won't ever be able to make
> any changes.  So the question is, is it worth potentially
> confusing all of those people in order to help remind the much
> smaller number of people on this list that they need to log in?

Jeff,

Two observations:

* I don't see any problem at all optimizing the site for those
who have to use it to do work rather that those for whom it is
an important convenience.

* The specific problem you are concerned about could be solved
by putting "(WG Chairs and ADs Only)" or equivalent at the end
of the relevant line and _then_ greying it out as needed.
Much better idea than secret options.  And, of course, if it
convinced even one more qualified person to volunteer to be a WG
Chair, that would be a net win.

Isn't design by committee fun?  :-(

    john

---

From: "Worley, Dale R (Dale)" <[email-masked]>
Date: Thu, 28 Jun 2012 18:28:21 -0400

> It's a common user interface trick and might help folk realize they need 

Speaking as someone who is a WG chair but does "chair" things in the
datatracker only rarely, the advantage of the greyed-out command is that
it tells me that I have found the right location in the user interface
but that I have not done the right thing to perform the operation.
Otherwise, I spend a great deal of time clicking on every link I can
find trying to find the right page...

Dale

---

From: "Worley, Dale R (Dale)" <[email-masked]>
Date: Thu, 28 Jun 2012 18:33:07 -0400

On Thu, 2012-06-28 at 13:42 +0000, Murphy, Sandra wrote:
> When I go to the datatracker, log in, go to approvals, I see a list
> about approvals including pre-approvals made, but no place to *make* a
> pre-approval.
> 

If this is truly what Sandy sees when she is not logged in, this is a
very poor interface design, because all of these items imply that she
*might* be able to approve things (in her current state), but no things
to approve happen to exist.  E.g., "Submissions you can approve / You
don't have any submissions to approve" should instead be "You are not
logged in / You cannot approve things".  The design rule being to not
only state that the user cannot approve anything, but to correctly imply
*why* the user cannot approve anything.

In this case, if Sandy brought up this page while not logged in, then
she logged in on another tab, and then went back to this tab, she would
quickly realize that the page contents were obsolete.

Dale

---

From: <[email-masked]>
Date: Fri, 29 Jun 2012 07:45:12 +0000

Hi,

It strikes me that, in fact, putting what is related to drafts approvals 
under a section called "submit a draft" is very misleading. As a WG 
chair, when I have in mind that I need to approve or pre-approve a 
draft, what is more natural to me is to login as chair, and go to the 
datatracker page for the corresponding working group. I don't have in 
mind that I am goind to "submit a draft", I've got no idea that it is 
there that I would find what I want ; "submit a draft" looks like a 
section of the tool for draft authors and/or editors.

So, it seems to me that it would be really good/right to access the 
approvals page under the WG page.
That could be a link in the blue bar of the WG page. WG Chairs that have 
used the datatracker already know that when this bar has nothing about 
actions reserved to chairs, it just means that they are not logged in yet.
(It may have the additional side benefit that the draft name text area 
could be pre-filled with draft-ietf-<wgname>-...)

I guess that the approvals section should also be accessible for non WG 
chairs, e.g. ADs, that sometimes need to do these actions for non WG 
drafts. But I don't see it as a problem if it is accessible from more 
than one place.

-Thomas
_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
France Telecom - Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, France Telecom - Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Dave Thaler <[email-masked]>
Date: Fri, 29 Jun 2012 22:54:33 +0000

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of [email-masked]
> Sent: Friday, June 29, 2012 12:45 AM
> To: [email-masked]
> Subject: approval ands pre-approvals -> under WG page ?
> 
> Hi,
> 
> It strikes me that, in fact, putting what is related to drafts approvals under a
> section called "submit a draft" is very misleading. As a WG chair, when I have
> in mind that I need to approve or pre-approve a draft, what is more natural
> to me is to login as chair, and go to the datatracker page for the
> corresponding working group. I don't have in mind that I am goind to "submit
> a draft", I've got no idea that it is there that I would find what I want ; "submit
> a draft" looks like a section of the tool for draft authors and/or editors.
> 
> So, it seems to me that it would be really good/right to access the approvals
> page under the WG page.
> That could be a link in the blue bar of the WG page. WG Chairs that have used
> the datatracker already know that when this bar has nothing about actions
> reserved to chairs, it just means that they are not logged in yet.
> (It may have the additional side benefit that the draft name text area could
> be pre-filled with draft-ietf-<wgname>-...)
> 
> chairs, e.g. ADs, that sometimes need to do these actions for non WG drafts.
> But I don't see it as a problem if it is accessible from more than one place.

I agree that hiding it under "submit a draft" is not really discoverable.  I note
that one path where it is discoverable is from http://www.ietf.org :
"WG Chairs' Page" -> "IETF Internet-Draft Submission Status" -> "Approvals"

(I see the approvals link now shows up even when you're not signed in, thanks!)

-Dave