Subject: What should happen when a WG adopts an individual I-D?

From: Russ Housley <[email-masked]>
Date: Thu, 27 Sep 2012 13:35:57 -0400

Before the datatracker, when an individual I-D was adopted by a WG, the Secretariat replaced the individual I-D with a tombstone that pointed to the WG version of the same document.

Today, the datatracker database contains the replaced-by relationship.  As a result, using the datatracker to search for the individual I-D will lead to the WG one.  However, both are actually present in the I-D Repository.

In addition, the https://datatracker.ietf.org/doc/draft-ietf-wg-.../ link will find the document, but similar URL for the individual I-D shows a page says that the document is no longer active. 

Example:
   http://www.ietf.org/id/draft-narten-nvo3-overlay-problem-statement-04.txt
   http://www.ietf.org/id/draft-ietf-nvo3-overlay-problem-statement-00.txt
   https://datatracker.ietf.org/doc/draft-narten-nvo3-overlay-problem-statement/
   https://datatracker.ietf.org/doc/draft-ietf-nvo3-overlay-problem-statement/

There seems to be several possible ways to proceed:

(1) Do nothing.

(2) Install a tombstone when the replaced-by action is taken in the datatracker.

(3) Remove the individual I-D when the replaced-by action is taken in the datatracker.

Which one best meets the community needs?

Russ

---

From: Paul Hoffman <[email-masked]>
Date: Thu, 27 Sep 2012 10:39:02 -0700

> Which one best meets the community needs?

2. People who are looking at a message or article that links directly to the individual I-D should be able to see what happened to it.

--Paul Hoffman

---

From: Ted Hardie <[email-masked]>
Date: Thu, 27 Sep 2012 10:51:57 -0700

Hi Russ,

Forgive the top post, but I want to re-frame the question slightly.
My personal experience has been that it is common for the replacement
document to have other changes from the individual ID (it's a handy
time to write out the contents of the edits buffer, after all).  That
means that relationship between the individual and working group draft
is closer to a draft-mumble-0N.txt to draft-mumble-0N+1.txt
relationship than a straight-up replacement.  So I'd personally
support a tombstone being put in the working group drafts directory
*if it revved the version number*, but not if replaced the original
draft's text.  That has an impact on how you construct a useful diff
tool against whatever archive, but I think it gets the best set of
overall results.

regards,

Ted Hardie

---

From: "Andrew G. Malis" <[email-masked]>
Date: Thu, 27 Sep 2012 13:52:04 -0400

I agree with Paul. If someone really needs to read the original individual
draft then they can find it in the tools database.

Cheers,
Andy

On Thu, Sep 27, 2012 at 1:39 PM, Paul Hoffman <[email-masked]> wrote:

> > Before the datatracker, when an individual I-D was adopted by a WG, the
> Secretariat replaced the individual I-D with a tombstone that pointed to
> the WG version of the same document.
> >
> > Today, the datatracker database contains the replaced-by relationship.
>  As a result, using the datatracker to search for the individual I-D will
> lead to the WG one.  However, both are actually present in the I-D
> Repository.
> >
> > In addition, the https://datatracker.ietf.org/doc/draft-ietf-wg-.../link will find the document, but similar URL for the individual I-D shows a
> page says that the document is no longer active.
> >
> > Example:
> >
> 2. People who are looking at a message or article that links directly to
> the individual I-D should be able to see what happened to it.
>
> --Paul Hoffman

---

From: Benson Schliesser <[email-masked]>
Date: Thu, 27 Sep 2012 12:55:22 -0500

> 2. People who are looking at a message or article that links directly to the individual I-D should be able to see what happened to it.

Agreed, +1.

And for clarification: Right now, if I want to mark an individual draft 
"replaced-by" a WG draft, I send a message to the Secretariat. Is this 
also possible via the Datatracker web interface? (I might be overlooking 
it... but if it's not there, can we add it?)

Cheers,
-Benson

---

From: James Polk <[email-masked]>
Date: Thu, 27 Sep 2012 16:00:36 -0500

>tool against whatever archive, but I think it gets the best set of

with respect, I (think I) disagree with Ted for at least two reasons.

#1 - once a WG adopts an individual draft and the authors are told to 
submit a draft-ietf-..-00 version, they tend to change a little or a 
lot of text that the WG didn't necessarily agree to, or was even made 
aware of. This is usually caught if the next meeting has a preso on 
the same draft-ietf-...-00.txt ID, but if it has been revved again 
between meetings, it becomes a case of individuals tracking where 
certain things were inserted - and I don't like that, especially if 
I'm not embedded in the work, but more casual but interested in the work.

#2 - some draft-ietf-...-00.txt drafts come directly from other WGs, 
sometimes with no mention of

- from where
- how long it was there as a WG item
- how long it was there as an individual
- etc

This used to happen to me a LOT in SIP/SIPPING/ECRIT/GEOPRIV days in 
Transport and RAI. I had a doc sustain life for 6.5 years and be a WG 
item in 4 different WGs - and it's now an RFC. I know this is an 
extreme case, but clearly being able to track a doc's evolution in 
one page would be really nice.

I think I'm reading that 1 or more of Russ's suggestions would not do that.

Another point to #1 that I'd really prefer to see the IETF adopt is 
to have every draft-ietf-...-00.txt be a copy of what the WG agreed 
to (i.e., equals everything in the last individual version, minus 
what the WG didn't or hasn't yet agreed to) with ZERO ADDITIONS, only 
subtractions of text. I've believe this for a while, and the current 
Subject: line would fit that requirement as well...

James

> > Before the datatracker, when an individual I-D was adopted by a 
> WG, the Secretariat replaced the individual I-D with a tombstone 
> that pointed to the WG version of the same document.
> >
> > Today, the datatracker database contains the replaced-by 
> relationship.  As a result, using the datatracker to search for the 
> individual I-D will lead to the WG one.  However, both are actually 
> present in the I-D Repository.
> >
> > In addition, the 
> https://datatracker.ietf.org/doc/draft-ietf-wg-.../ link will find 
> the document, but similar URL for the individual I-D shows a page 
> says that the document is no longer active.
> >
> > Example:
> >

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 27 Sep 2012 17:41:13 -0400

I don't like automatically linking to a doc other than the one 
requested, for reasons that have already been stated.

The datatracker already shows "Replaces: draft-individual-wg-..." in the 
status of draft-ietf-wg-... But it *doesn't* show "Replaced by: 
draft-ietf-wg-..." when displaying the individual draft. It ought to.

There is precedent. When RFCXXXbis is published as RFCYYY, the 
datatracker shows "Obsoleted by RFCYYY" for RFCXXX, and shows "Obsoletes 
RFCXXX" for RFCYYY.

Such a change would IMO be a sufficient fix for the stated problem.

It would also help if we could clean up some of the insanity and overlap 
between tools.ietf.org and datatracker.ietf.org regarding drafts, and 
other places within ietf.org where drafts reside. It would be helpful if 
all mailings that reference RFCs used a consistent URL form for 
referencing drafts - one that provides the metadata *and* navigation to 
all the other forms. Perhaps a union of the information in the headers 
of tools.ietf.org/html/foo and datatracker.ietf.org/doc/foo.

	Thanks,
	Paul

---

From: Donald Eastlake <[email-masked]>
Date: Thu, 27 Sep 2012 20:21:19 -0400

Hi,

>> tool against whatever archive, but I think it gets the best set of

I support Ted.

> #1 - once a WG adopts an individual draft and the authors are told to submit
> a draft-ietf-..-00 version, they tend to change a little or a lot of text
> that the WG didn't necessarily agree to, or was even made aware of. This is
> usually caught if the next meeting has a preso on the same
> draft-ietf-...-00.txt ID, but if it has been revved again between meetings,
> it becomes a case of individuals tracking where certain things were inserted
> - and I don't like that, especially if I'm not embedded in the work, but
> more casual but interested in the work.

Your experiences may differ but more often in my experience adoption
as a WG draft just means that the WG is interested in working in the
area of the draft and currently thinks the general approach is
reasonable. There are usually improvements supported during the call
for adoption and there is no reason those shouldn't be made as part of
the transition to a WG document. If you have to cycle the personal
draft until you have total consensus on every word, you are getting
close to moving WG LC to be on the personal draft rather than the WG
draft.

Thanks,
Donald
=============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 155 Beaver Street, Milford, MA 01757 USA
 [email-masked]

> Transport and RAI. I had a doc sustain life for 6.5 years and be a WG item
> in 4 different WGs - and it's now an RFC. I know this is an extreme case,
> but clearly being able to track a doc's evolution in one page would be
> really nice.
>
> Another point to #1 that I'd really prefer to see the IETF adopt is to have
> every draft-ietf-...-00.txt be a copy of what the WG agreed to (i.e., equals
> everything in the last individual version, minus what the WG didn't or
> hasn't yet agreed to) with ZERO ADDITIONS, only subtractions of text. I've
> believe this for a while, and the current Subject: line would fit that
> requirement as well...
>
> James
>
>
>
>> regards,
>>
>> Ted Hardie
>>
>> > Secretariat replaced the individual I-D with a tombstone that pointed to the
>> > WG version of the same document.
>> >
>> > In addition, the https://datatracker.ietf.org/doc/draft-ietf-wg-.../
>> > link will find the document, but similar URL for the individual I-D shows a

---

From: Loa Andersson <[email-masked]>
Date: Fri, 28 Sep 2012 11:33:49 +0200

Donald,

On 2012-09-28 02:21, Donald Eastlake wrote:
<snip>

> close to moving WG LC to be on the personal draft rather than the WG

The MPLS working group has the long-established practice when a document
has been adopted as a wg document to tell the authors to publish the -00
version of the wg document with no other changes tha file name, dates
and version number.

We do that for tracking purpose and it it works just fine.

The comment received during the poll is incorporated into version -01,
after the normal comment resolution process.

/Loa

-- 

Loa Andersson                         email: [email-masked]
Sr Strategy and Standards Manager            [email-masked]
Ericsson Inc                          phone: +46 10 717 52 13
                                              +46 767 72 92 13

---

From: "Joel M. Halpern" <[email-masked]>
Date: Fri, 28 Sep 2012 09:55:27 -0400

That is generally what I, as chair or participant, expect.  I know of 
one case where a WG had to direct authors to revise-backwards their 
draft so that the WG document matched what the WG approved.

Procedurally, I think that document consistency should be expected.
There are some working groups where the editor / author is allowed to 
make more changes, but even there the changes need to be discussed with 
the WG before submission of WG document revisions.  The WG owns the 
document, not the author / editor.

Yours,
Joel

---

From: Ted Lemon <[email-masked]>
Date: Fri, 28 Sep 2012 17:12:17 +0000

On Sep 28, 2012, at 9:55 AM, Joel M. Halpern <[email-masked]> wrote:
> There are some working groups where the editor / author is allowed to make more changes, but even there the changes need to be discussed with the WG before submission of WG document revisions.  The WG owns the document, not the author / editor.

At document adoption time there is no agreement in the working group that the document as adopted is what the working group wants as the final version.   That agreement occurs when the document passes working group last call.   So there's nothing essentially wrong about the authors making changes in the -00 version of the draft; usually these changes are in fact done as a result of comments on the mailing list, but I don't see why they would have to be.

The DHC working group hasn't (at least since I've been co-chair) attempted any sort of discipline of keeping the -00 working group draft the same as the last individual submission.   This hasn't been by design, but simply because it's rare that there isn't an edit to do between these two versions.

If there's some technical reason why this is the right thing to do, then we should just change the process so that the initial working group draft is submitted by reference to the last individual submission, rather than by submitting a text file.   As a nice side effect, this would take all the guessing out of the current system for noticing that one draft is a replacement for another.

---

From: "Joel M. Halpern" <[email-masked]>
Date: Fri, 28 Sep 2012 13:34:20 -0400

I would say that there is a technical reason for the approach I ahve 
seen and prefer.
The reason is that the working group agreed to adopt specific text as 
its starting point.  While that text is usually quite different from the 
final document, the changes are the remit of the working group, not the 
editor.

As such, making changes to the document, that do not reflect working 
group agreement, between the acceptance and the submission, seems to me 
to violate the spirit of the rules.

Now, if the working group agreed to adopt with specific changes, then 
those should be made.  Equally, if there is discussion after the 
decision, and there is working group agreement on changes, then those 
can be included.

In some working groups the editors are sensitive enough and in tune with 
the group enough, that we do not make a big deal of this distinction. 
But as a matter of structure, it is very important.  Editor's have been 
replaced for making excessive unilateral changes or refusing to make WG 
agreed changes.

Yours,
Joel

On 9/28/2012 1:12 PM, Ted Lemon wrote:
>> There are some working groups where the editor / author is allowed
>> to make more changes, but even there the changes need to be
>> discussed with the WG before submission of WG document revisions.
>> The WG owns the document, not the author / editor.
>
> At document adoption time there is no agreement in the working group
> that the document as adopted is what the working group wants as the
> final version.   That agreement occurs when the document passes
> working group last call.   So there's nothing essentially wrong about
> the authors making changes in the -00 version of the draft; usually
> these changes are in fact done as a result of comments on the mailing
> list, but I don't see why they would have to be.
>
> The DHC working group hasn't (at least since I've been co-chair)
> attempted any sort of discipline of keeping the -00 working group
> draft the same as the last individual submission.   This hasn't been
> by design, but simply because it's rare that there isn't an edit to
> do between these two versions.
>
> If there's some technical reason why this is the right thing to do,
> then we should just change the process so that the initial working
> group draft is submitted by reference to the last individual
> submission, rather than by submitting a text file.   As a nice side
> effect, this would take all the guessing out of the current system
> for noticing that one draft is a replacement for another.
>
>

---

From: Ted Lemon <[email-masked]>
Date: Fri, 28 Sep 2012 17:43:59 +0000

On Sep 28, 2012, at 1:34 PM, "Joel M. Halpern" <[email-masked]>
 wrote:
> The reason is that the working group agreed to adopt specific text as its starting point.  While that text is usually quite different from the final document, the changes are the remit of the working group, not the editor.

We probably shouldn't keep talking about this, but just to be clear, I was specifically disagreeing with this statement in my previous message.   Until the working group last call finishes, the working group has not in any sense agreed on the text in the document; only that the document needs to be worked on by the working group.

---

From: Melinda Shore <[email-masked]>
Date: Fri, 28 Sep 2012 10:06:49 -0800

> final document, the changes are the remit of the working group, not the

This is my feeling, as well.

Melinda

---

From: Donald Eastlake <[email-masked]>
Date: Fri, 28 Sep 2012 14:42:47 -0400

Hi,

> We do that for tracking purpose and it it works just fine.

I'm sure it does. All this does is show that different WG work is
somewhat different ways, which is also fine.

Thanks,
Donald

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 28 Sep 2012 22:06:54 +0200

> We probably shouldn't keep talking about this, but just to be clear, I was specifically disagreeing with this statement in my previous message.   Until the working group last call finishes, the wor…

Just to be very very clear, both statements are completely true; they are not contradicting at all.

The WG agreed to adopt specific text.  This does not mean it agreed the text, just that it agreed to adopt it.

All further changes should then be easily trackable by the WG.
The WG chairs trust the document editors to only make changes that the WG wants, but I'm with Lenin (or Ronald Reagan, depending on whom you ask) on this one.
So the better our tools to track changes, the more honest we can keep the document editors.

Grüße, Carsten

---

From: Dave Crocker <[email-masked]>
Date: Fri, 28 Sep 2012 13:19:02 -0700

On 9/28/2012 1:06 PM, Carsten Bormann wrote:
> The WG agreed to adopt specific text.  This does not mean it agreed
> the text, just that it agreed to adopt it.

I apologize, but I don't know what this means.

What does it mean "to adopt specific text" but "not mean it agreed to 
the text"?

I guess I don't know what it means to adopt something but not agree to it.

d/

-- 
  Dave Crocker
  Brandenburg InternetWorking
  bbiw.net

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 28 Sep 2012 22:29:06 +0200

On Sep 28, 2012, at 22:19, Dave Crocker <[email-masked]> wrote:

> What does it mean "to adopt specific text" but "not mean it agreed to the text"?
> 

If there were no difference, we wouldn't need WG documents, but could just last-call the individual contributions and be done.

It is useful to identify text as "this is text the WG has agreed to work on".
This doesn't mean that the text doesn't have egregious errors or gaping holes in it, otherwise we could just last-call it.
It actually just means "WG is watching", maybe with some slightly more positive connotations about a certain readiness of the WG to invest work in fixing the bugs.
With the WGLC, we can then judge whether the WG actually agrees with all the details in the text.

My point was that a "WG is watching" state requires the WG to be able to watch, and the watching starts from the adopted individual document, not from the draft-ietf-*-00.
I personally prefer if the -00 is identical to the adopted document, but I have had cases where that wasn't very practical, in particular when the decision of adoption included the decision to lose certain parts of the document.

Grüße, Carsten

---

From: Ted Lemon <[email-masked]>
Date: Fri, 28 Sep 2012 20:35:18 +0000

> I guess I don't know what it means to adopt something but not agree to it.

I think we are splitting hairs here; the point is that there isn't consensus on what it means to adopt a document.   I think the view I don't agree with is perfectly valid, but it isn't how the DHC working group operates, and it sounds like several other working groups also don't operate that way.

I have absolutely no problem with making a rule that the way we adopt documents is to tell the tools to make a specific individual submission document into a working group document at -00 with no changes, but I don't see any point in half measures—I think the main utility in doing it this way would simply be better automation.

---

From: Dave Crocker <[email-masked]>
Date: Fri, 28 Sep 2012 13:38:57 -0700

> If there were no difference, we wouldn't need WG documents, but could just last-call the individual contributions and be done.
...

OK.  Thanks.

"Agree to work on" vs "agree to use as the final text".

d/

---

From: James Polk <[email-masked]>
Date: Fri, 28 Sep 2012 16:46:12 -0500

At 03:38 PM 9/28/2012, Dave Crocker wrote:

>>If there were no difference, we wouldn't need WG documents, but 
>>could just last-call the individual contributions and be done.
>...
>
>
>OK.  Thanks.
>

that also means the authors, now WG doc editors, aren't supposed to 
add or change any new features or functions as specified in the last 
individual version - which is what the WG agreed to work on. All 
changes should be agreed to by the WG before showing up in a WG draft text.

James

---

From: Dave Crocker <[email-masked]>
Date: Fri, 28 Sep 2012 14:57:36 -0700

On 9/28/2012 2:46 PM, James Polk wrote:
> that also means the authors, now WG doc editors, aren't supposed to add
> or change any new features or functions as specified in the last
> individual version - which is what the WG agreed to work on. All changes
> should be agreed to by the WG before showing up in a WG draft text.

I think I have seen working groups vary on this.  Some treat the 
incorporation action as tolerating changes and some don't.  I'm not 
aware of any explicit rules except -- as usual -- working group consensus.

d/

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Fri, 28 Sep 2012 20:41:06 -0400

Quite often there is a difference between WG decides to adopt a draft and
WG decides to adopt an idea.

It is quite common for a WG to say something like 'we want to work on this
50% of the document and lose these extensions'.

Alternatively it might be a 2 docs to 1 merger as happened recently to a
document I worked on and someone else had a nearly identical proposal.

I think it is useful to track these changes but I do not want to see any
data removed from the ID repository ever. The existence of data on a
particular date is often critical to establishing prior art in patent
disputes. I have next to zero interest in RFCs, a little more interest in
drafts and a LOT of interest in mailing lists. OK so the opposite of the
usual practice but that is how it goes.

On Fri, Sep 28, 2012 at 4:35 PM, Ted Lemon <[email-masked]> wrote:

> I think we are splitting hairs here; the point is that there isn't
> consensus on what it means to adopt a document.   I think the view I don't
> agree with is perfectly valid, but it isn't how the DHC working group
> operates, and it sounds like several other working groups also don't
> operate that way.
>
> I have absolutely no problem with making a rule that the way we adopt
> documents is to tell the tools to make a specific individual submission
> document into a working group document at -00 with no changes, but I don't
> see any point in half measures—I think the main utility in doing it this
> way would simply be better automation.
>
>

-- 
Website: http://hallambaker.com/

---

From: "Martin J. Dürst" <[email-masked]>
Date: Sun, 30 Sep 2012 21:19:55 +0900

[for a summary of my conclusions, see the very end of this mail]

On 2012/09/29 5:35, Ted Lemon wrote:
> On Sep 28, 2012, at 4:19 PM, Dave Crocker<[email-masked]>
>   wrote:

I agree it's perfectly fine if different WGs have different ways of 
doing this.

The way of doing this may not only depend on the WG, but on how the call 
for adoption is worded. For a 'late' adoption, where the chair's message 
is indicating that the expectation is to spend relatively little time in 
the WG before a WG last call, a (close to) identical submission should 
be expected. On the other hand, when adopting something that's less 
polished (technically and/or editorially), the call may say so, and the 
expectations will be somewhat different.

> I have absolutely no problem with making a rule that the way we adopt documents is to tell the tools to make a specific individual submission document into a working group document at -00 with no c…

Well, yes, but on the other hand, imagine the author of a personal 
draft. At any point, s/he may have fixed some details (may be only 
typos) internally. This may be as a result of comments during discussing 
the adoption, as a result of mails that reach the author(s) personally, 
or just as a result of looking over the document and noticing something 
that can be improved without changing the technical nature of the 
document,...

Then the author(s) are told to submit as a WG draft. Should they 
backpedal on all those changes (99% or more just harmless improvements), 
submit a -00 version, and then start to bother the WG for permission to 
fix obvious glitches? Or should they backpedal, submit -00, then pedal 
forward again, and submit -01, so that the glitches are fixed? All this 
is quite tedious and annoying clerical work, even if modern versioning 
systems can help to some intent.

What is more, the tools site provides very convenient diffs for checking 
what has changed, so for those inclined, a confirmation that nothing (or 
only irrelevant stuff) has changed is just a few clicks away. As I have 
said, I don't want to tell other WGs how to conduct their business, but 
forcing everybody to be more paranoid than necessary is clearly 
counterproductive.

As an example, I'd like to look at a document that I am heavily involved 
that was adopted by the IRI WG. If you look at the diff 
(http://tools.ietf.org//rfcdiff?url1=http://tools.ietf.org/id/draft-duerst-iri-bis-07.txt&url2=http://tools.ietf.org/id/draft-ietf-iri-3987bis-00.txt), 
you will find that the biggest changes where the order of abstract and 
copyright boilerplate. While we hope such changes are rare, they put the 
notion of "exactly the same" into serious question. The next biggest 
change was the addition of a changelog section documenting the adoption 
of the draft. The third biggest change was in the abstract, to adjust to 
the status. Then the section titles in the changelog were changed to 
avoid confusion between those sections that related to the individual 
draft and those sections relating to the WG draft. The next biggest 
change (it's really small) is in the "open issues" section, also 
relating to the adoption.

[While we are at it, I was expecting that a diff from the -00 version 
back in tools (for the above case, 
http://tools.ietf.org/rfcdiff?url2=draft-ietf-iri-3987bis-00.txt) would 
be against the (individual) draft that is noted as the previous version. 
Instead at least in this case, it's against the RFC that is being 
revised. I wonder how this works in other cases, e.g. those where 
there's a previous individual draft but no RFC.]

To summarize:

1) The idea that an adopted draft will be identical to an individual 
draft is questionable because there may be all kinds of places in the 
draft that need one or the other kind of adjustment, and there may be 
external changes (boilerplate,...) on top of that.

2) Given 2), the idea that the accepted draft can be produced at the 
push of a [Accept this draft] button is also highly questionable. Of 
course, if somebody wants to prove this wrong by a nifty implementation, 
I'm open to be convinced of the contrary.

3) On top of 1) and 2), it's very unproductive if there is a requirement 
for "exactly identical" versions while the author(s) may be accumulating 
some edits such as typo fixes.

Regards,   Martin.

---

From: Ralph Droms <[email-masked]>
Date: Sun, 30 Sep 2012 09:00:31 -0400

> We do that for tracking purpose and it it works just fine.

I like this practice and I think it would be good to adopt as an IETF-wide recommendation.  In my opinion, it simplifies and clarifies the process of WG adoption, leaves an accurate history of changes to the doc once it has been adopted by the WG and avoids any issues of changes being introduced by the authors that have not been reviewed by the WG.

I understand that, in some cases, this process may result in an extra rev of the draft (personal-0n -> WG-00 (unchanged) -> WG-01 (with the edit buffer copied into the draft).  Drafts are cheap and this extra step ensures transparency.

- Ralph

---

From: Ted Lemon <[email-masked]>
Date: Sun, 30 Sep 2012 13:11:09 +0000

On Sep 30, 2012, at 8:19 AM, "Martin J. Dürst" <[email-masked]>
 wrote:
> Then the author(s) are told to submit as a WG draft. Should they backpedal on all those changes (99% or more just harmless improvements), submit a -00 version, and then start to bother the WG for permission to fix obvious glitches?

Wow, do IETF working groups actually operate this way?   A consensus call on every edit?   How do you ever get anything done?

Anyway, if a -00 is needed and the master copy has changed, just download the .txt of the final individual submission version and resubmit it as a -00 (with appropriate tweaks, of course).

---

From: Stephen Farrell <[email-masked]>
Date: Sun, 30 Sep 2012 14:43:33 +0100

Hi Ralph,

> I understand that, in some cases, this process may result in an extra rev of the draft (personal-0n -> WG-00 (unchanged) -> WG-01 (with the edit buffer copied into the draft).  Drafts are cheap and…

I disagree with you that this ought be forced. If
someone or some WG want to work that way, that's
just fine, but I don't think the benefit is enough
to justify the cost of forcing this to be done
for all WG -00 drafts, and checking it was done,
and recovering when it wasn't done, and arguing
about this that and the other...;-)

Cheers,
S.

---

From: Ralph Droms <[email-masked]>
Date: Sun, 30 Sep 2012 09:46:22 -0400

On Sep 30, 2012, at 9:43 AM 9/30/12, Stephen Farrell wrote:

> I disagree with you that this ought be forced.

Yup, doesn't need to be another process point to argue about.  I wrote: "it would be good to adopt as an IETF-wide recommendation."

- Ralph

> If

---

From: John C Klensin <[email-masked]>
Date: Sun, 30 Sep 2012 10:36:18 -0400

--On Sunday, September 30, 2012 14:43 +0100 Stephen Farrell
<[email-masked]> wrote:

>> I understand that, in some cases, this process may result in
>> an extra rev of the draft (personal-0n -> WG-00 (unchanged)
>> -> WG-01 (with the edit buffer copied into the draft).
>> Drafts are cheap and this extra step ensures transparency.
> 

+1
Yes.  Telling people that this is often (or even "usually")
useful and making clear that it is ok seems entirely reasonable.
Turning it into another rule... Not.

   john

---

From: "Martin J. Dürst" <[email-masked]>
Date: Mon, 01 Oct 2012 10:24:09 +0900

Hello Ted,

On 2012/09/30 22:11, Ted Lemon wrote:
> On Sep 30, 2012, at 8:19 AM, "Martin J. Dürst"<[email-masked]>
>   wrote:
> Wow, do IETF working groups actually operate this way?

I hope not! But when people say that they want a -00 version with not 
even any editorial change from the previous individual draft, I start to 
suspect that the WGs who insist on this practice work in such a way, or 
close to it.

> A consensus call on every edit?   How do you ever get anything done?
>

With the example I gave, I tried to show that the "appropriate tweaks" 
may be more than simple tweaks. In particular, for people (like me) who 
work with xml2rfc (or a similar tool), figuring out in the .txt version 
what stuff needs changing may be quite a bit of work. On top of that, it 
means that some edits have to be done twice, once on the .txt version to 
create the -00 draft, and once on the editing copy that is used to 
create the rest of the drafts.

We have this great diff tool that allows anybody to very quickly check 
the differences between any two drafts. I personally don't see the 
advantage of having a -00 and -01 as above, because it means that those 
who want to check have to check two times: First, they have to check 
that there are absolutely not material or editorial changes between the 
individual draft and the -00 draft. Second, they have to look at what 
what changes the author(s)/editor(s) made when they made a resubmit to 
empty their edit buffer. So to me it just looks like *more work for 
everybody*.

Regards,   Martin.