Subject: Re: v6ops - Requested sessions have been scheduled for IETF 85

From: joel jaeggli <[email-masked]>
Date: Fri, 05 Oct 2012 05:42:56 -0700

I'm not terribly enthused by meeting for 4 hours back to back.

I realize that it does happen.

It seems like wednesday at 0900 looks more or less conflict free and the 
same room we're scheduled for on thursday (salon d) appears presently 
uncomitted.

On 10/4/12 1:05 PM, "IETF Secretariat" wrote:
> Dear Fred Baker,
>
> The session(s) that you have requested have been scheduled.
> Below is the scheduled session information followed by
> the original request.
>
> v6ops Session 1 (2:00:00)
>      Thursday, Afternoon Session I 1300-1500
>      Room Name: Salon D
>      ---------------------------------------------
>      v6ops Session 2 (2:00:00)
>      Thursday, Afternoon Session II 1510-1710
>      Room Name: Salon D
>      ---------------------------------------------
>      
>
>
> Request Information:
>
>
> ---------------------------------------------------------
> Working Group Name:
> Area Name:
> Session Requester:
>
> Number of Sessions: 2
> Length of Session(s):  2 Hours, 2 Hours
> Number of Attendees: 300
> Conflicts to Avoid:
>   First Priority: 6man behave homenet softwire opsarea opsawg pcp
>   Second Priority: 6renum
>
>
>
> Special Requests:
>    
> ---------------------------------------------------------
>
>

---

From: Mark Townsley <[email-masked]>
Date: Fri, 5 Oct 2012 18:49:31 +0200

On Oct 5, 2012, at 2:42 PM, joel jaeggli wrote:

> It seems like wednesday at 0900 looks more or less conflict free and the same room we're scheduled for on thursday (salon d) appears presently uncomitted.

In another thread, homenet is shooting for 0900 due to various conflicts.  

Scheduling is a nightmare.

- Mark

---

From: Andrew Sullivan <[email-masked]>
Date: Fri, 5 Oct 2012 13:29:34 -0400

> I'm not terribly enthused by meeting for 4 hours back to back.

With all due respect to the participants, is it posible the problem in
this case is one of controlling meeting time?  I am pretty sure I can
countthe number of times in my life I have been in a four hour meeting
of more than 50 people where a lot got done, and still not get to "50
times".  I wasn't at a v6ops session the last two IETF meetings, but
the last time I went to one I felt there was rather more presentation
of material already drafts I had read than I thought was reasonable.
My feeling was really that we were getting short lectures or
conference presentations, and not meeting presentations.

Alternatively, is it possible v6ops needs a more tightly constrained
charter?  If the scope of work is such that presentations are really
needed of that length (because nobody can keep all the details in mind
of everything), maybe the charter is too broad and it's impossible for
all participants to follow the different permutations of work?

I don't know the answer to any of these questions I'm asking (and I'm
only using this v6ops case as a proxy); but, if we don't get a handle
on the growth of meeting time the IETF meetings are going to expand to
fit two weeks (once we get into the second Saturday, it will be
effectively nothing to add Sunday, and once people are away for two
weekends in a row the entire second week will get added pretty fast, I
bet).

Best,

A

-- 
Andrew Sullivan
[email-masked]

---

From: joel jaeggli <[email-masked]>
Date: Fri, 05 Oct 2012 10:43:39 -0700

On 10/5/12 10:29 AM, Andrew Sullivan wrote:
> this case is one of controlling meeting time?
I think if you had been there you'd find the we run a tight schedule.

We have trimed the schedule to 2 meetings per ietf rather than 3 that 
we  needed prior to that.

We impose discussion and interest mailing list requirements on items 
scheduled on the program.

giving sufficient time for discussion (not presentation) to 10-15 drafts 
per meeting does take some time.

I generally think of v6ops as efficient user of time in area where there 
is currently a lot of activity.
>    I am pretty sure I can

---

From: Andrew Sullivan <[email-masked]>
Date: Fri, 5 Oct 2012 15:08:39 -0400

> I think if you had been there you'd find the we run a tight schedule.

Given the chairs in question, this doesn't surprise me.

> giving sufficient time for discussion (not presentation) to 10-15
> drafts per meeting does take some time.

But this returns me to my other question.  If there are really 10-15
drafts, is the WG's scope really constrained enough?  Are there
subspecies of WG here that could be hived off?

To be clear, I'm not trying to say that's the right answer.  I really
don't know.  I felt for some time that DNSEXT was too amorphous and so
we tended to be a holdall group for a bunch of different problems,
each of which would have received better review by a small committed
group of people.  I'm asking -- not suggesting, just asking -- whether
there might be a similar problem in other WGs.  On the other hand, I
can see a strong argument that 10 WGs all on the same broad problem
just turns into a new kind of pain.  (For a concrete example of this,
consider the division of labour between behave and softwire a couple
years ago.) 

I'm just wondering whether there is something that we as chairs might
do usefully to try to shave some meeting time and still get work done.
I wish I had a useful suggestion.

Best,

A

-- 
Andrew Sullivan
[email-masked]

---

From: John C Klensin <[email-masked]>
Date: Fri, 05 Oct 2012 15:39:53 -0400

--On Friday, October 05, 2012 10:43 -0700 joel jaeggli
<[email-masked]> wrote:

> We have trimed the schedule to 2 meetings per ietf rather than
> 3 that we  needed prior to that.
> 
> We impose discussion and interest mailing list requirements on
> items scheduled on the program.
>...

Joel,

In addition to the issue Andrew raises, there is another problem
with this much activity in v6ops, especially when added to the
activity of the various IPv6 transition and other closely
related WGs. Over the years, I've heard many organizations who
are contemplating when and how to deploy IPv6 say "if there is
that much activity in the IETF, the protocol and associated
operational models are still not stable; let us know when they
are".    Perhaps by this time almost everyone making that claim
is just looking for an excuse to delay, but it has definitely
been sincere in the past and I suspect may still be for some
organizations.

I don't know what to do about it, but I wish we were sending a
clearer and better message about full understanding and
stability than multiple WGs with many drafts and long agendas.

   john

---

From: Ted Lemon <[email-masked]>
Date: Fri, 5 Oct 2012 19:49:10 +0000

On Oct 5, 2012, at 3:39 PM, John C Klensin <[email-masked]> wrote:
> if there is that much activity in the IETF, the protocol and associated operational models are still not stable; let us know when they are

In fact, the heavy activity in v6ops is the result of people learning new things about the protocol suite and how to operate it, so on the one hand this does indicate a certain degree of immaturity, but on the other hand it indicates that this is a good time to get started, because a lot of people are up to speed on it and can help you.

---

From: John C Klensin <[email-masked]>
Date: Fri, 05 Oct 2012 16:08:39 -0400

--On Friday, October 05, 2012 19:49 +0000 Ted Lemon
<[email-masked]> wrote:

>> if there is that much activity in the IETF, the protocol and
>> associated operational models are still not stable; let us
>> know when they are
> 
> In fact, the heavy activity in v6ops is the result of people
> learning new things about the protocol suite and how to
> operate it, so on the one hand this does indicate a certain
> degree of immaturity, but on the other hand it indicates that
> this is a good time to get started, because a lot of people
> are up to speed on it and can help you.

I can certainly buy that.

Certainly it is better to do a lot of concentrated and
productive work now than to artificially drag the process out so
that we are still firming things up four or five years hence.
 
The organizations who are trying to operate on the "let someone
else make the mistakes and have the 'learning experiences'"
model will focus on the immaturity part... and congratulate
themselves on not being foolish enough to try to transition a
few years ago when we, ISOC, IPv6 Forum, and others were telling
them they should.

My comment was, however, just an observation about interactions
between behavior "out there" and what we are doing.  While I
think the community would benefit if we all kept in mind, it was
not a effort to start a discussion thread nor to argue for
changing behavior between now and IETF 85.

   john

---

From: Leif Johansson <[email-masked]>
Date: Sat, 6 Oct 2012 11:02:41 +0200

> stability than multiple WGs with many drafts and long agendas.

Oh c'mon

PKI lived and (arguably) died as a technology while PKIX has been
happily finding things to keep itself busy.