Subject: Re: What should happen when a WG adopts an individual I-D?

From: Stephen Farrell <[email-masked]>
Date: Mon, 01 Oct 2012 10:26:47 +0100

On 09/30/2012 02:46 PM, Ralph Droms wrote:
> 
> On Sep 30, 2012, at 9:43 AM 9/30/12, Stephen Farrell wrote:
> 
>>
>> Hi Ralph,
>>
>> On 09/30/2012 02:00 PM, Ralph Droms wrote:
>>>
>>> I understand that, in some cases, this process may result in an extra rev of the draft (personal-0n -> WG-00 (unchanged) -> WG-01 (with the edit buffer copied into the draft).  Drafts are cheap and this extra step ensures transparency.
>>
>> I disagree with you that this ought be forced.
> 
> Yup, doesn't need to be another process point to argue about.  I wrote: "it would be good to adopt as an IETF-wide recommendation."

Ah fair enough, I misread your mail, sorry,
S.

> - Ralph
> 
>> If
>> someone or some WG want to work that way, that's
>> just fine, but I don't think the benefit is enough
>> to justify the cost of forcing this to be done
>> for all WG -00 drafts, and checking it was done,
>> and recovering when it wasn't done, and arguing
>> about this that and the other...;-)
>>
>> Cheers,
>> S.
> 
> 
> 
>

---

From: Sam Hartman <[email-masked]>
Date: Mon, 01 Oct 2012 14:54:12 -0400

>>>>> "Stephen" == Stephen Farrell <[email-masked]> writes:

    Stephen> Hi Ralph,

    Stephen> On 09/30/2012 02:00 PM, Ralph Droms wrote:
    >> 
> I understand that, in some cases, this process may result in an extra
    >> rev of the draft (personal-0n -> WG-00 (unchanged) -> WG-01 (with
    >> the edit buffer copied into the draft).  Drafts are cheap and
    >> this extra step ensures transparency.

    Stephen> I disagree with you that this ought be forced. If someone
    Stephen> or some WG want to work that way, that's just fine, but I
    Stephen> don't think the benefit is enough to justify the cost of
    Stephen> forcing this to be done for all WG -00 drafts, and checking
    Stephen> it was done, and recovering when it wasn't done, and
    Stephen> arguing about this that and the other...;-)

+1 I think that the chairs should be able to clearly point to what the
WG had consensus to adopt, because the question of whether you already
had consensus for something becomes important when you are trying to
evaluate consensus requirements for a change.  However, I think having
rules IETF-wide on what is done to figure this out don't make sense.

As an AD, if you need to give chairs rules on this topic, that's up to
you. Please only do it if necessary.

---

From: John C Klensin <[email-masked]>
Date: Mon, 01 Oct 2012 16:01:02 -0400

--On Monday, October 01, 2012 14:54 -0400 Sam Hartman
<[email-masked]> wrote:

> +1 I think that the chairs should be able to clearly point to
> what the WG had consensus to adopt, because the question of
> whether you already had consensus for something becomes
> important when you are trying to evaluate consensus
> requirements for a change.  However, I think having rules
> IETF-wide on what is done to figure this out don't make sense.
> 
> As an AD, if you need to give chairs rules on this topic,
> that's up to you. Please only do it if necessary.

Sam's note inspired an additional thought.  Perhaps we should be
concentrating more energy on the usual "Changes Since the
Previous Version" section/appendix.  That has never been
required and, at the level of rules, probably shouldn't be.  But
having such a section in WG drafts that replace individual ones
and having the first entry say "except for name, this document
is identical to draft-foo-bar-baz-17, which it replaces" or
"this draft replaces draft-bar-foo-baz-19 but has been
considerably revised to reflect WG decisions" would, IMO, go a
huge way toward resolving the many diverse opinions in this
thread by making it clear what one should look for and where.   

It isn't a substitute for information in the tracker, but,
because the document editor for the WG version knows exactly
what she did and can use prose rather than just a pointer, it
might be a lot more useful when there are questions.

    john

---

From: "Joel M. Halpern" <[email-masked]>
Date: Mon, 01 Oct 2012 16:32:12 -0400

For the LISP working group, he authors were consistent about preparing 
and including the "changes" section in the draft.
In addition, before the draft was posted, the changes section was sent 
to th list for review.
This worked very well.  (And no, it is t needed in all WGs, and I wold 
not want there to be a rule requiring it.)

Yours,
Joel

---

From: Ned Freed <[email-masked]>
Date: Mon, 01 Oct 2012 13:22:17 -0700 (PDT)

> > that's up to you. Please only do it if necessary.

+1 on the last point. There are many variations in the "adopt an existing
document" process, too many to come up with a one-size-fits-all set of rules.

Some documents are adopted in toto, in other cases only a small part of the
original is retained. There are others with a mandatory set of starting
changes. Others with required excision of non-IETF material. And still others
come in from sources other than Internet-Drafts, where the cost of producing an
initial Internet-Draft form of the source document would be completely
prohibitive if not impossible (e.g., graphics).

Being able to compare the WG document with the original source document is nice
to be sure, but not when it costs someone a lot of time and the result is it
still doesn't work very well.

> might be a lot more useful when there are questions.

Absolutely. It may make total sense to require such a section, possibly even in
the published RFC. Or it may make no sense at all. It's totally dependent
on circumstance.

				Ned