Subject: Posting with psudonyms...

From: Warren Kumari <[email-masked]>
Date: Mon, 17 Jun 2013 11:05:11 -0400

Hi all,

So, over in DANE we have someone posting as "Bry8 Star <[email-masked]>" -- it seems fairly clear that he is not a regular IETF participant.

I have asked that folk do not post from to the DANE list from identities that are *obviously* pseudonyms. I feel that this is important both for the Note Well / IPR considerations, but also to try and prevent Sybil attacks. I also feel that having people known by a "real name"[0] makes them likely to behave better, but I realize there is much history / views here!

So, I'm guessing there are likely to be a bunch of views on this, including:
1: How do you know who *anyone* is? Why do you believe that my name is *really* Warren Kumari? Have you seen my passport / birth-certificate?
2: What if someone claiming to be "Tarquin Fin-tim-lin-bin-whin-bim-lim-bus-stop-F'tang-F'tang-Olé-Biscuitbarrel" posts? (There is one: http://en.wikipedia.org/wiki/Election_Night_Special). Different cultures / countries have different naming schemes, how do you decide what is a pseudonym?
3: Everyone has the right to be know as whatever they want.

So, what's your views on this? Allow any old name? If someone is well known in the community as "John Smith" it doesn't really matter what their actual name is? If someone comes along and says "My actual name is Henry Smith, but I'd like to be known as "Candy-apple Red" then that is ok because we still know who is behind the identity?  Don't touch this (too late!)? Something more subtle?

Here is the DANE thread: http://www.ietf.org/mail-archive/web/dane/current/msg05853.html

Warren (or something) Kumari.

[0]: Oh gods!

--
"Have you got any previous convictions?"

"Well, I dunno... I suppose I used to believe very firmly that a penny saved is a penny earned--"
-- Terry Pratchett

---

From: Olafur Gudmundsson <[email-masked]>
Date: Mon, 17 Jun 2013 11:11:29 -0400

Strongly discourage, but gently by simply asking them to either 
change posting line, or provide chairs with the info as who they are, or even ask them to 
co-edit a ID.

	Olafur

---

From: Alan DeKok <[email-masked]>
Date: Mon, 17 Jun 2013 11:14:42 -0400

> So, what's your views on this? Allow any old name? If someone is well known in the community as "John Smith" it doesn't really matter what their actual name is? If someone comes along and says "My…

  Do they do good work?  If so, who cares what their name is.  If they
don't do good work, why care who they are?

  Noam Chomsky has a comment on this.  He goes to some conferences, and
they say "We don't care what you think, because you didn't study under
wonderful Professor X, and you don't have the right credentials".  These
areas of knowledge tend to not get anything done, and are over-run by
woo-woo ideas.

  When he goes to science / math conferences, no one cares what his
background is.  All they care about is whether or not he's making sense.

  I think the same should apply here.

  Alan DeKok.

---

From: Mary Barnes <[email-masked]>
Date: Mon, 17 Jun 2013 10:22:10 -0500

I think you can nicely ask.  But, I'm not sure there's anything you
can do beyond that.

---

From: Dave Crocker <[email-masked]>
Date: Mon, 17 Jun 2013 08:36:27 -0700

> I think you can nicely ask.  But, I'm not sure there's anything you

For people who passively observe IETF activity, it probably doesn't matter.

For anyone who "contributes" I believe the IETF's IPR rules imply a 
requirement to divulge one's true identity.

d/

-- 
Dave Crocker
Brandenburg InternetWorking
bbiw.net

---

From: Yaakov Stein <[email-masked]>
Date: Mon, 17 Jun 2013 16:12:48 +0000

Well, one problem with not knowing who people are is that we try to judge rough consensus on the list.

If there are 50 sock puppets making slightly different derogatory remarks on some draft,
do we bury it for lack of consensus ?
If the WG chairs are allowed to simply ignore participants, what does rough consensus mean ?

Y(J)S

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Alan DeKok
Sent: 17 June, 2013 18:15
To: Warren Kumari
Cc: WG Chairs
Subject: Re: Posting with psudonyms...

> So, what's your views on this? Allow any old name? If someone is well known in the community as "John Smith" it doesn't really matter what their actual name is? If someone comes along and says "My…

  Do they do good work?  If so, who cares what their name is.  If they don't do good work, why care who they are?

  Noam Chomsky has a comment on this.  He goes to some conferences, and they say "We don't care what you think, because you didn't study under wonderful Professor X, and you don't have the right credentials".  These areas of knowledge tend to not get anything done, and are over-run by woo-woo ideas.

  When he goes to science / math conferences, no one cares what his background is.  All they care about is whether or not he's making sense.

  Alan DeKok.

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Mon, 17 Jun 2013 16:03:46 +0000

The aspect missing from the discussion is whether there is an intent to mislead or not.

If someone always posts and speaks in the IETF community as person A, even if their passport says person B, then I see little possibility of misleading.

If someone is active in the IETF community using both personas, and the IETF community as a whole is unable to understand the relationship between the two personas, then that would imply at least an intent to mislead, and that should be regarded more seriously.

Of course policing that is not necessarily easy, nor are there any rules that say we have to police it.

Regards

Keith

P.S. On the IPR there is only a requirement to disclose any IPR you know of. As far as I am aware, I don't have to tell you it is my IPR, nor is there any rule for you to check whether I am lying or not.

> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Mary Barnes
> Sent: 17 June 2013 16:22
> To: Warren Kumari
> Cc: WG Chairs
> > So, over in DANE we have someone posting as "Bry8 Star
> <[email-masked]>" -- it seems fairly clear that he is not a
> regular IETF participant.
> >
> > I have asked that folk do not post from to the DANE list from identities
> that are *obviously* pseudonyms. I feel that this is important both for
> the Note Well / IPR considerations, but also to try and prevent Sybil
> attacks. I also feel that having people known by a "real name"[0] makes
> them likely to behave better, but I realize there is much history / views
> here!
> >
> > 1: How do you know who *anyone* is? Why do you believe that my name is
> *really* Warren Kumari? Have you seen my passport / birth-certificate?
> > 2: What if someone claiming to be "Tarquin Fin-tim-lin-bin-whin-bim-lim-
> bus-stop-F'tang-F'tang-Olé-Biscuitbarrel" posts? (There is one:
> http://en.wikipedia.org/wiki/Election_Night_Special). Different cultures /
> countries have different naming schemes, how do you decide what is a
> pseudonym?
> > So, what's your views on this? Allow any old name? If someone is well
> known in the community as "John Smith" it doesn't really matter what their
> actual name is? If someone comes along and says "My actual name is Henry
> Smith, but I'd like to be known as "Candy-apple Red" then that is ok
> because we still know who is behind the identity?  Don't touch this (too
> late!)? Something more subtle?
> >

---

From: Pete Resnick <[email-masked]>
Date: Mon, 17 Jun 2013 11:25:32 -0500

> If the WG chairs are allowed to simply ignore participants, what does rough consensus mean ?

I unabashedly refer you to draft-resnick-on-consensus. (I need to put 
out a version -03 when I have two minutes to rub together.)

pr

-- 
Pete Resnick<http://www.qualcomm.com/~presnick/>
Qualcomm Technologies, Inc. - +1 (858)651-4478

---

From: Yaakov Stein <[email-masked]>
Date: Mon, 17 Jun 2013 16:41:22 +0000

> I unabashedly refer you to draft-resnick-on-consensus. 

Actually, I've seen it.

If I remember correctly you say that 100 people for and 5 against is not necessarily rough consensus
and 5 for and 100 against may be.

What if the 5 are not people at all ?

I was not talking about "voting", or the common "+1".
I specifically said that the sock puppets raised slightly different arguments.

I frequently find several problems with a draft. 
If I decide to assume several aliases each presenting one problem, I am sure that this would have more (psychological) effect on the rest of the list.
Actually, I frequently think that just using any name other than my own might make some people pay more attention :)

Y(J)S

---

From: "Murphy, Sandra" <[email-masked]>
Date: Mon, 17 Jun 2013 16:46:04 +0000

I would appreciate some response to the "sybil" concern Warren raised.   How is consensus to be judged if one member has multiple identities?

--Sandy

________________________________________
From: [email-masked] [[email-masked]] on behalf of Mary Barnes [[email-masked]]
Sent: Monday, June 17, 2013 11:22 AM
To: Warren Kumari
Cc: WG Chairs
Subject: Re: Posting with psudonyms...

---

From: Warren Kumari <[email-masked]>
Date: Mon, 17 Jun 2013 12:49:18 -0400

> P.S. On the IPR there is only a requirement to disclose any IPR you know of. As far as I am aware, I don't have to tell you it is my IPR, nor is there any rule for you to check whether I am lying o…

Sure, but let's say you are strongly supporting a protocol for rapid updates of geo coordinates.
A few weeks after the WG decides to support rapid updates of geo info using the solution you've been pushing, someone find a necessary patent by Wile E. Coyote of the Acme Guided Anvil Corp.

If you are known as Wile E. Coyote, you'll have a hard time explaining this away -- if you participate as Sk8 CoolM@n[0] though (and no one really knows who that is), this might get less scrutiny…

W

[0]: or something less stupid, like Anthony Steward.

-- 
Never criticize a man till you've walked a mile in his shoes.  Then if he didn't like what you've said, he's a mile away and barefoot.

---

From: Pete Resnick <[email-masked]>
Date: Mon, 17 Jun 2013 11:50:02 -0500

> What if the 5 are not people at all ?

Section 6 (5 for, 100 against) does not require that the 100 against are 
real people.

> If I decide to assume several aliases each presenting one problem, I am sure that this would have more (psychological) effect on the rest of the list.

Yes, this is why I say in that section that this is probably the hardest 
call for the chair to make. I agree, it's got a *huge* psychological 
effect to overcome, but the correct outcome is to call the sock puppets 
"in the rough". (Notice I didn't say "ignore the sock puppets". Even 
sock puppets might have a legitimate argument. But once an argument has 
been dismissed as in the rough, it shouldn't matter how many people -- 
or non-people -- pile on.) And yes, if one or two people work hard at 
creating sock puppets, it can make things quite painful; that's why I 
call it the pathological case. Luckily, most sock puppets I've 
encountered are as loony and technically uninformed as their puppet 
masters, so getting them into the rough is not as bad as you'd think.

> Actually, I frequently think that just using any name other than my own might make some people pay more attention :)

That can be said for a lot of us crusty old folks. :-)

pr

---

From: Yaakov Stein <[email-masked]>
Date: Mon, 17 Jun 2013 16:53:40 +0000

So, what you are saying that is there is no such thing as rough consensus of PEOPLE,
rather rough consensus of IDEAS.

The WG chair should make a table of reasons PRO and reasons CON,
and forget about the people participating in the WG.

I have a lot of sympathy for that approach
but I don't think it is what most IETF'ers think that rough consensus means.

Y(J)S

-----Original Message-----
From: Pete Resnick [mailto:[email-masked]] 
Sent: 17 June, 2013 19:50
To: Yaakov Stein
Cc: WG Chairs
Subject: Re: Posting with psudonyms...

On 6/17/13 11:41 AM, Yaakov Stein wrote:
> If I remember correctly you say that 100 people for and 5 against is 
> not necessarily rough consensus and 5 for and 100 against may be.
>

Section 6 (5 for, 100 against) does not require that the 100 against are real people.

> If I decide to assume several aliases each presenting one problem, I am sure that this would have more (psychological) effect on the rest of the list.

Yes, this is why I say in that section that this is probably the hardest call for the chair to make. I agree, it's got a *huge* psychological effect to overcome, but the correct outcome is to call the sock puppets "in the rough". (Notice I didn't say "ignore the sock puppets". Even sock puppets might have a legitimate argument. But once an argument has been dismissed as in the rough, it shouldn't matter how many people -- or non-people -- pile on.) And yes, if one or two people work hard at creating sock puppets, it can make things quite painful; that's why I call it the pathological case. Luckily, most sock puppets I've encountered are as loony and technically uninformed as their puppet masters, so getting them into the rough is not as bad as you'd think.

> Actually, I frequently think that just using any name other than my 
> own might make some people pay more attention :)
>    

pr

---

From: Ted Lemon <[email-masked]>
Date: Mon, 17 Jun 2013 16:58:38 +0000

> but I don't think it is what most IETF'ers think that rough consensus means.

Hence Pete's document!   :)

---

From: Yaakov Stein <[email-masked]>
Date: Mon, 17 Jun 2013 17:05:12 +0000

> Hence Pete's document!   :)

But the question remains as to which definition of rough consensus is to be used
regarding the acceptance of Pete's document ...

Y(J)S

---

From: Warren Kumari <[email-masked]>
Date: Mon, 17 Jun 2013 13:10:06 -0400

On Jun 17, 2013, at 12:50 PM, Pete Resnick <[email-masked]> wrote:

> Yes, this is why I say in that section that this is probably the hardest call for the chair to make. I agree, it's got a *huge* psychological effect to overcome, but the correct outcome is to call the sock puppets "in the rough". (Notice I didn't say "ignore the sock puppets". Even sock puppets might have a legitimate argument. But once an argument has been dismissed as in the rough, it shouldn't matter how many people -- or non-people -- pile on.) And yes, if one or two people work hard at creating sock puppets, it can make things quite painful; that's why I call it the pathological case. Luckily, most sock puppets I've encountered are as loony and technically uninformed as their puppet masters,

Um. How do you know? 
Isn't what you are saying here is that: Most of the sock puppets that you've encountered *and identified as sock puppets* are loony?

How do you know I'm not secretly Chris Morrow's puppet[0]? He met me one evening in a railroad cafe and has been paying for me to come the the IETF for years. I don't know nothin' about this fancy technology stuff[1], I'm just a simple glass-blower from Eastborn who happens to do side work as an amateur actor.

W
[0]: Insert obligatory "Well, that just proves Pete's point :-P" here.
[1]: Well, this part at least is true!

> so getting them into the rough is not as bad as you'd think.
> 

--
It's a mistake trying to cheer up camels. You might as well drop meringues into a black hole. -- Terry Prachett

---

From: Melinda Shore <[email-masked]>
Date: Mon, 17 Jun 2013 09:34:31 -0800

> regular IETF participant.

I think that at this point it's safe to say that he or she
is a regular mailing list participant.

I'm not in love with how this situation has been handled so
far, to be honest.  I'm suspicious that this would not be
raised as an issue if Bry8 Star weren't such an annoying git,
although it's probably pretty clear that this Bry8 Star is
not going to be contributing much let alone something
covered by IPR claims, while a less irritating Bry8 Star
might.

I'd probably let it go and deal with the situation head-
on (and without name calling - Viktor needs an etiquette
lesson).

Melinda

---

From: Ted Lemon <[email-masked]>
Date: Mon, 17 Jun 2013 17:34:40 +0000

> regarding the acceptance of Pete's document ...

Pete's document is Pete's document, not an IETF consensus document.   There is no document that says how rough consensus is determined; Pete is merely documenting a tradition that he feels many have not understood.   So if you agree with Pete's definition of rough consensus, you just use it when you do consensus calls.   If you disagree, you don't.

But since we _know_ that we don't vote, we know that the mere fact that 50 sockpuppets or meatpuppets stood up for a particular draft doesn't mean the draft has consensus.  In the absence of that, how we determine consensus is either an open question, or is answered by Pete's document.   I happen to think Pete's document answers the question, but I don't know if it would get consensus in the IETF.

---

From: Warren Kumari <[email-masked]>
Date: Mon, 17 Jun 2013 13:55:36 -0400

On Jun 17, 2013, at 1:34 PM, Melinda Shore <[email-masked]> wrote:

> far, to be honest.

Yup, we have done a less than spectacular job with this -- we both got sidetracked / were traveling during the critical bits and the conversation went sideways…

>  I'm suspicious that this would not be

Yup, two participants who rub each other (and often other folk) the wrong way. We have had some off-list conversations, but the "what's the right thing to do with pseudonyms?" conversation seems useful to have.

I really wanted to make sure that I wasn't off in the weeds, and have a useful response (even if it is just "We've discussed this and decided it is OK") if the IPR lawyers come knocking…

W

-- 
There are only 10 types of people in this world -- those who understand binary arithmetic and those who don't.

---

From: "Gunter Van de Velde (gvandeve)" <[email-masked]>
Date: Mon, 17 Jun 2013 18:06:17 +0000

I am not looking forward to police people whit strange names to become member on the list.
I do desire that when people contribute to discussion to do that under a real name and not as [email-masked]

The email list they carry has less interest to me.

G/

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Warren Kumari
Sent: 17 June 2013 17:05
To: WG Chairs
Subject: Posting with psudonyms...

Hi all,

[0]: Oh gods!

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 17 Jun 2013 14:55:33 -0400

In general one must register before being allowed to post to lists.
Of course a person could register multiple pseudonyms. I think that is 
actually pretty common because some people use different email addresses 
depending upon context. But maybe we should make it possible to separate 
identity from email address when registering. Then we could establish a 
policy of consensus being based on persons, rather than email addresses.

That is entirely separate from enforcement. I think we could expect 
voluntary compliance and deal with violations if/when detected.

	Thanks,
	Paul

---

From: Pete Resnick <[email-masked]>
Date: Mon, 17 Jun 2013 13:57:49 -0500

I (Pete) don't think that consensus should be based on either email 
addresses or persons. That's voting. Bad thing. Consensus should be 
based on ideas.

pr

On 6/17/13 1:55 PM, Paul Kyzivat wrote:
> actually pretty common because some people use different email 
> addresses depending upon context. But maybe we should make it possible 
> to separate identity from email address when registering. Then we 
> could establish a policy of consensus being based on persons, rather 
> than email addresses.
>
>> I would appreciate some response to the "sybil" concern Warren 
>> raised.   How is consensus to be judged if one member has multiple 
>> identities?

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 17 Jun 2013 15:09:48 -0400

> addresses or persons. That's voting. Bad thing. Consensus should be

Yes, I've read your doc, and in general I agree with it.

But it would still be helpful to have a reasonable expectation that 
people weren't participating as multiple sock puppets. If they choose to 
participate as *one* sock puppet, that is ok with me.

What if someone consults to multiple organizations, and "represents" 
their interests"? Is it acceptable for them to use a different pseudonym 
depending on whose position they are representing?

(AFAIK its official policy that people participate in ietf as 
individuals, not as representatives of corporate entities. Does that 
make sense if one individual is representing himself as multiple entities?)

	Thanks,
	Paul

---

From: Pete Resnick <[email-masked]>
Date: Mon, 17 Jun 2013 15:02:17 -0500

On 6/17/13 2:09 PM, Paul Kyzivat wrote:
> people weren't participating as multiple sock puppets. If they choose 
> to participate as *one* sock puppet, that is ok with me.

Oh, absolutely. When it comes to how we interact in order to *achieve* 
consensus, I prefer to know real people and to interact with them as 
such. This is a social activity, ill-socialized engineers 
notwithstanding, and people making believe that they are other people 
(or many other people) corrupts the social interaction. But that doesn't 
mean that we should change our view of consensus to deal with that: 
Consensus shouldn't be about counting hands, or noses, or socks, or 
souls for that matter. It should be about the ideas.

> their interests"? Is it acceptable for them to use a different 
> pseudonym depending on whose position they are representing?

Acceptable? Maybe. Pleasant? No.

> make sense if one individual is representing himself as multiple 

Oh, I've always taken the "participate as individuals" ideology to mean 
that you cannot claim to be representing the views of of someone other 
than yourself. That is, I can't say, "Qualcomm believes X, therefore the 
document must say Y". I've got to take responsibility for the assertion 
and give an argument for it. But that's simply to say that I can't 
appeal to authority. I am surely within spec to say, "In my work at 
Qualcomm, we did some prototypes and my colleagues and I found that X is 
the case, therefore I believe the document should say Y". And in that 
sense, if I choose to use different email address to say such things, I 
don't see a particular harm. Mind you, I think it's goofy, in the same 
way I think people going to the mic during face-to-face meetings and 
saying "Pete Resnick, Qualcomm" is goofy, because I think it's subtly 
trying to persuade people based on the affiliation rather than actually 
making their case. And I think we ought to discourage that. But I think 
as far as how to judge consensus, we should be ignoring all of it and 
see whether the claim is valid, not how many people, or non-people, (let 
alone from how many companies) said it.

pr

---

From: S Moonesamy <[email-masked]>
Date: Mon, 17 Jun 2013 13:13:52 -0700

Hi Paul,
At 11:55 17-06-2013, Paul Kyzivat wrote:
>Of course a person could register multiple pseudonyms. I think that 
>is actually pretty common because some people use different email 
>addresses depending upon context. But maybe we should make it 
>possible to separate identity from email address when registering. 
>Then we could establish a policy of consensus being based on 
>persons, rather than email addresses.

A message to an IETF mailing list hit the moderation queue.  The 
person sent a message to the mailing list moderators with a 
suggestion similar to the above.  One of the mailing list moderators 
suggested discussing that suggestion on the ietf@ mailing list.  The 
person did not follow up on that.

Regards,
S. Moonesamy

---

From: Barry Leiba <[email-masked]>
Date: Wed, 19 Jun 2013 16:13:12 -0400

> I have asked that folk do not post from to the DANE list from identities that are
> *obviously* pseudonyms. I feel that this is important both for the Note Well / IPR
> considerations, but also to try and prevent Sybil attacks. I also feel that having
> people known by a "real name"[0] makes them likely to behave better, but I realize
> there is much history / views here!

The problem I have with paying too much[1] attention to this sort of
thing is that your[2] hackles get raised when the pseudonym is "Bry8
Star", but not when it's "George Eliot", "John Le Carré", or "Cary
Grant".[3]  Warren talks about "obvious" pseudonyms, but with the
variety of names in the world, how's one to know whether "Ford
Prefect" is a pseudonym or someone's real name?  Is "SM" a pseudonym?
He's been accused of it.  What makes something "obviously" a
pseudonym, and why should we treat obvious ones differently to ones
that aren't obvious?  An American might think that "U Nu" is a
pseudonym.  So?

I think this is a very bad slope to start descending.

[I'll also note that the now-closed vwrap working group, which tried
to develop a standardized version of the sort of protocols used in
Second Life, had a number of participants using Second Life names.
For most of them, we knew both names and the participants used them
somewhat interchangeably.  There were a few, though, whom we knew
*only* from their Second Life names.  They claimed to have no IPR
related to the work, and that was all we felt we needed to know.]

Barry

[1] Read: "any".

[2] Not "you" as in Warren, but "you" as in, you know, all y'all.

[3] These are all pseudonyms of real people, as I'm sure most of you
know.  They could just as well have been their "real" names. Who would
know?

---

From: Yaakov Stein <[email-masked]>
Date: Thu, 20 Jun 2013 05:28:31 +0000

> They claimed to have no IPR related to the work, and that was all we felt we needed to know.

Are you sure that wasn't the Second Life resident claiming not to hold a patent in a virtual jurisdiction ?

Y(J)S