Subject: Re: Draft editors getting changes from the WG using DVCS systems

From: "Cullen Jennings (fluffy)" <[email-masked]>
Date: Sat, 8 Jun 2013 06:05:46 +0000

FWIW …

I and several people I work with are doing most our new drafts in github and sending changes as pull requests in github as github gives a web interface for comments before someone merges the pull request. 

On May 8, 2013, at 11:35 PM, Paul Hoffman <[email-masked]> wrote:

> Greetings again. When a WG member asks for changes in a draft, it usually does so on one of two ways:
> 
> a) Text messages that list specific changes such as "in Section 3.2, second paragraph, change the last sentence to use MUST"
> 
> b) Editing the current version of the draft to make it look like what the WG member wants, and then submitting it through a system like Git, Subversion, or Mercurial
> 
> For this thread, I'm only interested in (b), distributed version control systems. If you have folks in your WG using (b):
> 
> 1) Which system do they use?
> 
> 2) Are there written instructions for the steps a WG member must take to submit changes?
> 
> 3) What sort of feedback are you getting?
> 
> This is not an effort to find which is "best" or to make a new IETF process, but just to see what's out there and how well documented it is.
> 
> --Paul Hoffman

---

From: Stephen Farrell <[email-masked]>
Date: Sat, 08 Jun 2013 15:01:39 +0100

Would this be a good WG chairs topic for Berlin or later? (Sorry if
someone's already suggested that or has something else cooking.)

If so, anyone who's been doing it wanna volunteer to run the show?

S.

---

From: Paul Hoffman <[email-masked]>
Date: Sat, 8 Jun 2013 07:58:36 -0700

> someone's already suggested that or has something else cooking.)

As I been looking at this more, there are multiple threads intertwined. It might be good to deal with them separately, even though many folks mash them together.

- SVN vs. git for version control. For some, this is "need to pull before commit vs. don't worry about local and remote", for some this is "the GUI tools for X are better than the GUI tools for Y", and probably other considerations

- Hosting: should the editing repository be private for the co-authors or public. Setting up a private SVN server is easier than setting up a private git server, unless you are willing to let anyone have an SSH-able account on your server for the latter. That seems to be changing now that git's support of HTTP is getting better, but the documentation for the later is inconsistent. Some folks want private because they don't want the WG nit-picking on proposed changes before a draft is ready, others want the WG participating directly in the editing.

- Private branches that get merged vs. everyone working in the master branch. This is a working style issue, but there is a lot of diversity of preference here.

- Diffing tools. When the central editor has to decide which proposed changes to pull in, having a tool that shows diffs between current and proposed is very valuable. There are a bunch of good ones for some platforms, and some are cross-platform. (I started a list for Mac tools, and need to put it somewhere...)

--Paul Hoffman