Subject: An acceptable use for Internet-Drafts?

From: Warren Kumari <[email-masked]>
Date: Mon, 1 Jul 2013 18:19:42 -0400

Hi all,

So, I recently published a draft ( "A questionable method for mitigating namespace collisions" -   http://www.ietf.org/internet-drafts/draft-wkumari-dnsop-defense-collision-mitigate-00.txt ) purely so that the idea is documented somewhere, and hopefully someone won't go off and try patent it.

As you can guess from the title I don't think that this is a particularity good idea (AKA, Bad Idea Fairy was visiting when I wrote it), but I think that if *anyone* tries to do this, then *everyone* should be free to try do it.

In order to try and make this more clear, I put the word -defense- in the draft name. 
Does this seem like an acceptable use of the ID system? If so, should we try and make having -defense- or -defensive- in the draft name be an unwritten convention that we use?
I figured best to chat about this here first, and then, possibly, on -discuss if folk think it is worth broader discussion.

W
-- 
With Feudalism, it's your Count that votes.

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Mon, 1 Jul 2013 22:56:04 +0000

Internet-drafts are essentially a step to something else.

Otherwise while they may be retained in the tools archive, they officially disappear six months after issue.

So I would not regard it as a valid usage. The function you desire is one of the RFC types, probably not IETF track.

Keith

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Warren Kumari
> Sent: 01 July 2013 23:20
> To: WG Chairs
> Subject: An acceptable use for Internet-Drafts?
> 
> Hi all,
> 
> So, I recently published a draft ( "A questionable method for mitigating
> namespace collisions" -   http://www.ietf.org/internet-drafts/draft-
> wkumari-dnsop-defense-collision-mitigate-00.txt ) purely so that the idea
> is documented somewhere, and hopefully someone won't go off and try patent
> it.
> 
> As you can guess from the title I don't think that this is a particularity
> good idea (AKA, Bad Idea Fairy was visiting when I wrote it), but I think
> that if *anyone* tries to do this, then *everyone* should be free to try
> do it.
> 
> Does this seem like an acceptable use of the ID system? If so, should we
> try and make having -defense- or -defensive- in the draft name be an
> unwritten convention that we use?
> I figured best to chat about this here first, and then, possibly, on -
> discuss if folk think it is worth broader discussion.
> 
> W
> --

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Mon, 1 Jul 2013 23:33:37 +0000

One uses Internet Drafts to provide a document to the ISE to publish, if the objective is publication as an RFC. So an Internet Draft is *necessary*.

Since Internet Drafts have a lifetime beyond the stipulated 6 months (take a look at http://tools.ietf.org/id/draft-ietf-mpsnmp-overipx-00.txt), they are useful for prior art searches. If the objective is to post prior art to prevent patent rights, it is a library that i used.

As to "bad idea", I would suggest putting it as seeking "experimental status" and say up front that this is an idea that is NOT RECOMMENDED, and give reasons for not recommending it.

---

From: "John Levine" <[email-masked]>
Date: 1 Jul 2013 23:38:34 -0000

>So I would not regard it as a valid usage. The function you desire is one of the RFC types, probably not IETF track.

We all know in reality that I-D's may expire, but they don't
disappear, so I think we're OK there.

I also think there is some benefit to the IETF of writing up known bad
ideas, to speed up the discussion when they come around again and
again.  If they're discoverable prior art, so much the better.

When I was running the ASRG, I set up a wiki at http://wiki.asrg.sp.am
where we could document anti-spam techniques, both the good ones and
the bad ones.  It's been somewhat helpful as people reinvent stuff.

R's,
John

---

From: Paul Hoffman <[email-masked]>
Date: Mon, 1 Jul 2013 16:45:20 -0700

> As to "bad idea", I would suggest putting it as seeking "experimental status" and say up front that this is an idea that is NOT RECOMMENDED, and give reasons for not recommending it.

That seems like overkill. A statement of the author's actual intention in the Abstract ("I am publishing this to maybe establish prior art, but not to have anyone implement it") is the honest and sufficient thing to do. If the author changes his mind and later wants to get the idea used, he or she simply issues a new draft in the same series with a different Abstract, again giving the actual intention.

--Paul Hoffman

---

From: Ted Lemon <[email-masked]>
Date: Mon, 1 Jul 2013 23:48:01 +0000

> So I would not regard it as a valid usage. The function you desire is one of the RFC types, probably not IETF track.

Having openly published something, it is no longer (in principle) patentable.   So this would _work_ from a legal perspective, as long as evidence that it had been published isn't lost, which I think it probably wouldn't be.   However, Keith is right that you might as well publish it; you can use the Independent Stream for documents of this sort, at least in theory.

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 2 Jul 2013 02:14:19 +0200

On Jul 2, 2013, at 00:19, Warren Kumari <[email-masked]> wrote:

> So, I recently published a draft purely so that the idea is documented somewhere, and hopefully someone won't go off and try patent it.

I do this all the time.  I didn't ask for permission, and don't see why I should.

We have discussed this before...
http://www.ietf.org/mail-archive/web/ietf/current/msg77642.html

Recently, I keep a document that serves as the container (now at -25) together with useful stuff, so I don't even need to alert people that a defensive public disclosure just occurred.

Grüße, Carsten

---

From: Eric Burger <[email-masked]>
Date: Wed, 3 Jul 2013 07:56:35 -0400

On a related note, I am starting a project (so far unfunded) to collect presentations from the voice over IP trade shows for the purposes of establishing a data bank of prior art references. Anyone have old CD's or DVD's or, better yet, your own presentations to share, please let me know.

---

From: Benoit Claise <[email-masked]>
Date: Mon, 08 Jul 2013 09:53:55 +0200

Fred,
> Since Internet Drafts have a lifetime beyond the stipulated 6 months (take a look athttp://tools.ietf.org/id/draft-ietf-mpsnmp-overipx-00.txt), they are useful for prior art searches. If the objective is to post prior art to prevent patent rights, it is a library that i used.
With the first to file change in patent policy, does it still make sense 
these days?
http://gigaom.com/2013/03/18/first-to-file-patent-law-starts-today-what-it-means-in-plain-english/

Regards, Benoit
> On Jul 1, 2013, at 3:56 PM, "DRAGE, Keith (Keith)"<[email-masked]>  wrote:
>
>>> From:[email-masked]  [mailto:[email-masked]] On
>>> Behalf Of Warren Kumari
>>> Sent: 01 July 2013 23:20
>>> To: WG Chairs
>>> namespace collisions" -http://www.ietf.org/internet-drafts/draft-

---

From: "Martin J. Dürst" <[email-masked]>
Date: Mon, 08 Jul 2013 19:47:23 +0900

Hello Benoit,

On 2013/07/08 16:53, Benoit Claise wrote:
> Fred,
>> One uses Internet Drafts to provide a document to the ISE to publish,
>> if the objective is publication as an RFC. So an Internet Draft is
>> *necessary*.
>>
>> Since Internet Drafts have a lifetime beyond the stipulated 6 months
>> (take a look
>> athttp://tools.ietf.org/id/draft-ietf-mpsnmp-overipx-00.txt), they are
>> useful for prior art searches. If the objective is to post prior art
>> to prevent patent rights, it is a library that i used.

IANAL, but I'd assume that independent of "first to file" or "first to 
invent", prior art publication still trumps both.

Regards,   Martin.

---

From: "ietfdbh" <[email-masked]>
Date: Mon, 8 Jul 2013 09:52:14 -0400

Don't miss this section in the description you pointed to:
"America has a special rule that will help inventors in many cases. The rule
says that if you disclose the invention at a conference or elsewhere, you
have a one year grace period to file a patent for it. This means that your
disclosure will prevent someone else from getting a patent on your invention
(but it could also harm your chances to get patents in other countries)."

So "establishing prior art" might only be useful regarding US patents, and
only good for a year, but it still could be important.

David Harrington
[email-masked]
+1-603-828-1401

> Behalf Of Benoit Claise
> Sent: Monday, July 08, 2013 3:54 AM
> To: Fred Baker (fred)
> Cc: WG Chairs
> Subject: Re: An acceptable use for Internet-Drafts?
> 
> Fred,
> > One uses Internet Drafts to provide a document to the ISE to publish, if
the
> objective is publication as an RFC. So an Internet Draft is *necessary*.
> >
(take
> a look athttp://tools.ietf.org/id/draft-ietf-mpsnmp-overipx-00.txt), they
are
> useful for prior art searches. If the objective is to post prior art to
prevent
> patent rights, it is a library that i used.
these
> days?
http://gigaom.com/2013/03/18/first-to-file-patent-law-starts-today-what-it-
> means-in-plain-english/
> 
> Regards, Benoit
> > As to "bad idea", I would suggest putting it as seeking "experimental
> status" and say up front that this is an idea that is NOT RECOMMENDED, and
> give reasons for not recommending it.
> >
> >> Otherwise while they may be retained in the tools archive, they
officially
> disappear six months after issue.
> >>
> >> So I would not regard it as a valid usage. The function you desire is
one of
> the RFC types, probably not IETF track.
> >>
> >> Keith
> >>
> >>> From:[email-masked]  [mailto:[email-masked]]
> >>> On Behalf Of Warren Kumari
> >>> Sent: 01 July 2013 23:20
> >>> To: WG Chairs
> >>> So, I recently published a draft ( "A questionable method for
> >>> mitigating namespace collisions"
> >>> -http://www.ietf.org/internet-drafts/draft-
> >>> wkumari-dnsop-defense-collision-mitigate-00.txt ) purely so that the
> >>> idea is documented somewhere, and hopefully someone won't go off
> and
> >>> try patent it.
> >>>
> >>> As you can guess from the title I don't think that this is a
> >>> particularity good idea (AKA, Bad Idea Fairy was visiting when I
> >>> wrote it), but I think that if *anyone* tries to do this, then
> >>> *everyone* should be free to try do it.
> >>>
> >>> Does this seem like an acceptable use of the ID system? If so,
> >>> should we try and make having -defense- or -defensive- in the draft
> >>> name be an unwritten convention that we use?
> >>> I figured best to chat about this here first, and then, possibly, on
> >>> - discuss if folk think it is worth broader discussion.
> >>>
> >>> W
> >>> --

---

From: "John Levine" <[email-masked]>
Date: 8 Jul 2013 16:27:58 -0000

>With the first to file change in patent policy, does it still make sense these days?

First to file only affects priority between two applications for the same thing.

Prior art affects whether something can be patented at all.  So yes,
disclosing prior art is still very useful.

R's,
John

---

From: "John Levine" <[email-masked]>
Date: 8 Jul 2013 16:31:46 -0000

>only good for a year, but it still could be important.

No, that's something else.

The point of making a public disclosure about something you've
invented and aren't planning to patent, or that you are aware of but
isn't written down anywhere, is that once it's disclosed, nobody else
can patent it, ever.*  This is a fundamental rule of patent law in the U.S.
and, I am fairly sure, in all other countries.

R's,
John

* - well, unless they can prove that they invented it before you
disclosed it but still file within the one year window, and that's
pretty rare