Subject: WG Agendas to submit only 2 days after -00 submission cut-off date

From: <[email-masked]>
Date: Tue, 16 Jul 2013 12:07:22 +0000

Hi everyone,

It is not unusual that people wait for having submitted their drafts 
before asking for presentation slots.

With the change in -00/-01 draft submission cut-off dates, this time we 
have have only two days during which we will be able to examine requests 
for presentations slots and prepare our agenda.

Am I the only one to see a difficulty here ?

Practically speaking I expect that many initial agendas will be even 
less close to the final agendas than they usually were.
Wouldn't it make sense to (officially) set the agenda submission date 
one week later, or at least a few days later ?

-Thomas
_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Yoav Nir <[email-masked]>
Date: Tue, 16 Jul 2013 12:14:56 +0000

> one week later, or at least a few days later ?

That's one way to solve this. Another is to tell people that if they spring a surprise -00 draft on you a mere 2 weeks before the meeting, they don't get a slot.

They don't have to submit the -00 earlier, just let you know that they are going to.

I think it is in the interest of the general attendee population that they know two weeks in advance what they need to read, and it is in the interest of those making presentations to have over a week to create them. I'm not going to start a presentation when my time slot could change significantly, so I'm not going to start before the agenda is published.

Yoav

---

From: Benoit Claise <[email-masked]>
Date: Tue, 16 Jul 2013 14:20:20 +0200

> That's one way to solve this. Another is to tell people that if they spring a surprise -00 draft on you a mere 2 weeks before the meeting, they don't get a slot.
Not sure if you're not causing another problem.
What I've seen recently is:
A: "WG, I will be posting a draft-XXX-00"
B: "How is this different than the draft-YYY?"
So basically, there is the risk that we start discussing the content of 
virtual drafts.

Regards, Benoit

---

From: <[email-masked]>
Date: Tue, 16 Jul 2013 12:32:48 +0000

Hi Yoav,

2013-07-16, Yoav Nir:
>
> That's one way to solve this. Another is to tell people that if they
> spring a surprise -00 draft on you a mere 2 weeks before the meeting,
> they don't get a slot.
>

I would echo Benoit's comment: how does this help ? a draft name does 
not carry much content, right?

> I think it is in the interest of the general attendee population that
> they know two weeks in advance what they need to read, and it is in
> the interest of those making presentations to have over a week to
> create them.

I would agree with this.

But then, what would be most consistent is to choose the one submission 
deadline as what the deadline was in the past for -00 revisions, and not 
one week later.

-Thomas

---

From: Yoav Nir <[email-masked]>
Date: Tue, 16 Jul 2013 12:33:38 +0000

On Jul 16, 2013, at 3:20 PM, Benoit Claise <[email-masked]>
 wrote:

> So basically, there is the risk that we start discussing the content of virtual drafts.

They might. But I think this worked OK:

http://www.ietf.org/mail-archive/web/ipsec/current/msg08450.html

---

From: Yoav Nir <[email-masked]>
Date: Tue, 16 Jul 2013 12:42:26 +0000

> not carry much content, right?

No, but I mean that they should tell you in advance, "I'm working on a draft for a new encoding for FOO objects in the BAR protocol. I'll have it ready by the submission deadline. Can I have a slot?"

Of course, they may miss the deadline, or submit something that's really bad, but it's not too bad usually.

As for whether the correct deadline is 2 or 3 weeks, I don't know.

---

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 16 Jul 2013 13:44:58 +0100

Hi Thomas,

> before asking for presentation slots.

Shouldn't it be unusual that people are granted presentation slots except for the discussion and resolution of issues that have arisen on the mailing list and need face-to-face time.  

While discussion of new ideas (documented in -00 drafts) at the face-to-face meeting is not such a bad thing, people who post -00 drafts so close to the meeting can reasonably be asked to generate some discussion on the mailing list and come back at the next meeting.

Adrian

---

From: <[email-masked]>
Date: Tue, 16 Jul 2013 12:58:25 +0000

Hi Adrian,

2013-07-16, Adrian Farrel:
>> It is not unusual that people wait for having submitted their
>> drafts before asking for presentation slots.
>
> Shouldn't it be unusual that people are granted presentation slots
> except for the discussion and resolution of issues that have arisen
> on the mailing list and need face-to-face time.
>
> While discussion of new ideas (documented in -00 drafts) at the
> face-to-face meeting is not such a bad thing, people who post -00
> drafts so close to the meeting can reasonably be asked to generate
> some discussion on the mailing list and come back at the next
> meeting.

If we don't first have a change in practices, applying this as a rule 
may lead to nearly empty agendas for some working groups, for a few 
IETFs... ;-)

To encourage this virtuous practice, I think that it may be better *not* 
to set the -00 deadline later than it was.

-Thomas

---

From: "Howard, Lee" <[email-masked]>
Date: Tue, 16 Jul 2013 09:32:50 -0400

>spring a surprise -00 draft on you a mere 2 weeks before the meeting,

So the deadline for -00 should be more than two weeks before the meeting.
The contents of (nearly) all -00 drafts are a surprise.

>They don't have to submit the -00 earlier, just let you know that they

That doesn't help us know whether the WG is interested in discussing it,
since we don't know what it says.  It also doesn't help evaluate how much
time the draft might require, either to present/explain, or to discuss.

>they know two weeks in advance what they need to read, and it is in the
>interest of those making presentations to have over a week to create
>them. I'm not going to start a presentation when my time slot could
>change significantly, so I'm not going to start before the agenda is
>published.

I think it is in the interest of the general population to spread the work
across more than six weeks a year (the meetings, and the week prior when
they might do reading).  Even if you have two weeks to read drafts to find
which are interesting, and even if you have time to send comments to the
WG list, you won't have time to keep up with the discussion.  Unless you
are following only a small handful of working groups, which looks uncommon
to me.

In other words, I like having new work submitted further in advance of
meetings, where revisions may be submitted less far in advance.

Lee

>Yoav

This E-mail and any of its attachments may contain Time Warner Cable proprietary information, which is privileged, confidential, or subject to copyright belonging to Time Warner Cable. This E-mail is intended solely for the use of the individual or entity to which it is addressed. If you are not the intended recipient of this E-mail, you are hereby notified that any dissemination, distribution, copying, or action taken in relation to the contents of and attachments to this E-mail is strictly prohibited and may be unlawful. If you have received this E-mail in error, please notify the sender immediately and permanently delete the original and any copy of this E-mail and any printout.

---

From: Thomas Nadeau <[email-masked]>
Date: Tue, 16 Jul 2013 10:57:26 -0400

> While discussion of new ideas (documented in -00 drafts) at the face-to-face meeting is not such a bad thing, people who post -00 drafts so close to the meeting can reasonably be asked to generate…

	I agree. Slots (as I recall) were supposed to be used for people to discuss issues around drafts, and not in order to present or use as a tutorial/summarization session. Discussion on the list ahead of time is a very good thing.

	--Tom

---

From: Ted Lemon <[email-masked]>
Date: Tue, 16 Jul 2013 14:59:49 +0000

> one week later, or at least a few days later ?

This is a matter of choice for working group chairs.   You are free to announce that no drafts initially submitted after a certain date will be on the agenda.   If you add things to the agenda late, you risk pushback from people who will not have time to read the documents prior to the IETF meeting.

The decision to merge the two deadlines was really just us being realistic: if someone wants to submit a -00 late, they just submit a -00 with minimal content before the -00 deadline, and then submit the real -00 as a -01 before the -01 deadline.   So the extra deadline creates churn and noise, but provides no benefit.

It's certainly not the case that someone submitting a -00 before either deadline does not already know that they want to discuss it at IETF; if they submit their agenda request late, you should just say no, and then they will know better for next time.

---

From: Ted Lemon <[email-masked]>
Date: Tue, 16 Jul 2013 15:05:16 +0000

> may lead to nearly empty agendas for some working groups, for a few 

Not discussing stuff the working group doesn't know about at IETF is a feature, not a bug.   Working group agendas often have a lot of fat in them that could be trimmed, and which, if trimmed, would result in a more productive meeting.

---

From: "Howard, Lee" <[email-masked]>
Date: Tue, 16 Jul 2013 11:15:10 -0400

On 7/16/13 10:59 AM, "Ted Lemon" <[email-masked]> wrote:

>This is a matter of choice for working group chairs.   You are free to
>announce that no drafts initially submitted after a certain date will be
>on the agenda.   If you add things to the agenda late, you risk pushback
>from people who will not have time to read the documents prior to the
>IETF meeting.

I like this suggestion:  WG chairs may declare a draft-00 deadline that is
earlier than the "official" deadline.

>
>The decision to merge the two deadlines was really just us being
>realistic: if someone wants to submit a -00 late, they just submit a -00
>with minimal content before the -00 deadline, and then submit the real
>-00 as a -01 before the -01 deadline.   So the extra deadline creates
>churn and noise, but provides no benefit.

At least minimal content is *some* content.  The current situation is
potentially *no* content.

>
>It's certainly not the case that someone submitting a -00 before either
>deadline does not already know that they want to discuss it at IETF; if
>they submit their agenda request late, you should just say no, and then
>they will know better for next time.

But how do I, as a chair, evaluate their request to discuss something, if
I don't know what it is?
Teaching lessons through hard knocks means giving hard knocks to IETF
participants.  Rather, we should be supporting them in creating the best
possible document, and providing ample (and timely) opportunities for
review and discussion, both online and in person.

Lee

---

From: Stephen Kent <[email-masked]>
Date: Tue, 16 Jul 2013 11:17:35 -0400

Adrian,

I think different WGs have different criteria in this regard. While PKIX 
always gave
priority to discussions of extant WG items, we also allowed time (at the 
end) for presentations
on new topics that were being proposed as WG items. On occaison we ran 
out of time and the
speakers near the end didn't get to present.

Steve

---

From: <[email-masked]>
Date: Tue, 16 Jul 2013 15:19:41 +0000

Hi Ted,

2013-07-16, Ted Lemon:
>> If we don't first have a change in practices, applying this as a
>> rule may lead to nearly empty agendas for some working groups, for
>> a few IETFs... ;-)
>
> Not discussing stuff the working group doesn't know about at IETF is
> a feature, not a bug.   Working group agendas often have a lot of fat
> in them that could be trimmed, and which, if trimmed, would result in
> a more productive meeting.

Again, people being who they are and acting like people, an earlier -00 
deadline would actually be a practical way to encourage early discussions.

-Thomas

---

From: <[email-masked]>
Date: Tue, 16 Jul 2013 15:20:48 +0000

> earlier than the "official" deadline.

Well, the final goal is sensible, but we lose the simplicity of having 
one deadline. As a contributor I wouldn't like to deal with X working 
groups having possibly X different deadlines...

-Thomas

---

From: <[email-masked]>
Date: Tue, 16 Jul 2013 15:24:56 +0000

2013-07-16, Ted Lemon:
> realistic: if someone wants to submit a -00 late, they just submit a
> -00 with minimal content before the -00 deadline, and then submit the
> real -00 as a -01 before the -01 deadline.   So the extra deadline
> creates churn and noise, but provides no benefit.

The extra deadline could provide a benefit if very recently submitted 
-00 drafts where excluded from having the possibility to post between 
the -00 deadline and the -01 deadline. E.g posting after -00 and before 
the -01 deadline would be allowed only for -01 draft if the -00 draft is 
at least one month old.

-Thomas

---

From: Ted Lemon <[email-masked]>
Date: Tue, 16 Jul 2013 15:35:43 +0000

> But how do I, as a chair, evaluate their request to discuss something, if

You say "no."

> review and discussion, both online and in person.

I don't think I'd characterize this as hard knocks.   How hard a knock is it to be told "you waited too long to inform the working group about this, please inform the working group about this in time for the next meeting and we will schedule you on the agenda then?"   I mean, why is getting your draft into the consciousness of working group members harder than, say, buying a plane ticket and making a hotel reservation, all of which we usually do well before the draft submission cutoff?

Having said that, I think one thing that might work well and that I would like to see tried is a five or ten minute "lightning talk" on the agendas of working groups that get a lot of new work.   People who want to raise awareness of work within the working group would be encouraged to come up with a one-minute elevator pitch for their work, which they would be asked to rehearse and size so that they can present it at a slow-to-normal talking speed, so that we don't get auctioneer patter during each presentation.   Maximum of, say, four slides, fifteen seconds per slide.

If the working group doesn't know about your work, you get a one-minute slot, and you make your pitch.

I don't know, maybe this is a crazy idea?

---

From: Ted Lemon <[email-masked]>
Date: Tue, 16 Jul 2013 15:42:40 +0000

> groups having possibly X different deadlines...

This is no problem.   All you have to do to avoid this is to get your drafts in well before the deadline, and accept that if you miss a deadline, you'll have to wait until next time or beg the working group chair for forgiveness.

Personally, I would argue strongly against having any deadline at all, because I think it creates a useless artificial flurry of submissions too close to IETF, on the one hand, and inconveniences people who just want to publish a new version of their draft but don't intend to present it at IETF, on the other.

I really would encourage working group chairs to consider IETF agenda submission deadlines to be an important part of their work.   Working group f2f meeting time is extraordinarily expensive, and when I attend working group sessions, I get the very strong impression that a great deal of it is wasted.   If you never say no to an agenda request, either you have an unusually disciplined working group, or you are doing something wrong.

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Tue, 16 Jul 2013 16:35:14 +0000

I agree with everything you have said here.

However human nature responds to deadlines, and if we had no submission deadline, the consequence would virtually all the documents submitted on the Monday of the meeting with an expectation they would be discussed.

In your rational, that would be met by a WG chairs applying a bar, but to avoid confusion among those working in multiple working groups, that needs to be a consistent bar. That bar is currently expressed by the submission deadline(s).

Regards

Keith

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Ted Lemon
> Sent: 16 July 2013 16:43
> To: <[email-masked]>
> Cc: [email-masked]
> Subject: Re: WG Agendas to submit only 2 days after -00 submission cut-off
> date
> 
> This is no problem.   All you have to do to avoid this is to get your
> drafts in well before the deadline, and accept that if you miss a deadline,
> you'll have to wait until next time or beg the working group chair for
> forgiveness.
> 
> Personally, I would argue strongly against having any deadline at all,
> because I think it creates a useless artificial flurry of submissions too
> close to IETF, on the one hand, and inconveniences people who just want to
> publish a new version of their draft but don't intend to present it at
> IETF, on the other.
> 
> I really would encourage working group chairs to consider IETF agenda
> submission deadlines to be an important part of their work.   Working
> group f2f meeting time is extraordinarily expensive, and when I attend
> working group sessions, I get the very strong impression that a great deal
> of it is wasted.   If you never say no to an agenda request, either you
> have an unusually disciplined working group, or you are doing something
> wrong.

---

From: joel jaeggli <[email-masked]>
Date: Tue, 16 Jul 2013 10:06:56 -0700

> The contents of (nearly) all -00 drafts are a surprise.
Back when I was a v6ops chair, fred and I demanded discussion/interest a 
a precondition for agenda time. so while the document submission 
deadline is a deadline, you really have to work to lay claim to an 
agenda slot on the basis of a submission that late. I am personally as a 
Chair/AD quite comfortable excluding something from the agenda on the 
basis that the wg hasn't been exposed to it.

---

From: Andrew Sullivan <[email-masked]>
Date: Tue, 16 Jul 2013 13:30:03 -0400

On Tue, Jul 16, 2013 at 10:06:56AM -0700, joel jaeggli wrote:

> Back when I was a v6ops chair, fred and I demanded
> discussion/interest a a precondition for agenda time. so while the
> document submission deadline is a deadline, you really have to work
> to lay claim to an agenda slot on the basis of a submission that
> late.

I strongly agree with this filter (and try to use the same approach
myself).  Note that it allows for some late-breaking -00 to take up a
very significant chunk of agenda if it is addressing something people
think to be important, and it still means that the natural filtering
it imposes reduces the frequency with which you get 20 minute
presentations of a new draft.

I _do_ think having some room (in an active WG) for 1-minute lightning
talk-style "here's my draft and here's why you should read it" is not
a bad thing (and I've seen that be successful).

Best,

A

-- 
Andrew Sullivan
[email-masked]

---

From: Spencer Dawkins <[email-masked]>
Date: Tue, 16 Jul 2013 15:36:31 -0500

> a bad thing (and I've seen that be successful).

The Lovely Mary Barnes and Equally Lovely Cullen Jennings can correct 
me, but I'm remembering that the DISPATCH chairs would offer to put up 
one slide on drafts that had suddenly descended from the sky, too 
suddenly to have generated mailing list traffic, if requested to do so, 
in order to familiarize interested working group participants with 
potential future work. I thought that was helpful.

If a working group has the agenda time to allow lightning talks that 
last over a minute, I think that would be fine; for what I saw in 
DISPATCH. 3 minutes would have been plenty.

Thanks,

Spencer

---

From: Mary Barnes <[email-masked]>
Date: Tue, 16 Jul 2013 15:56:56 -0500

Thank you Spencer.  Yes, that's been our usual approach for documents that
weren't given agenda time for a variety of reasons.  We ask the individual
for a slide (in rare cases two) and if there were any questions comments,
then the individual could speak from the floor microphone.   We use this
approach as we learned in running the SIPPING WG that lightening talks
didn't work well at all.  If you have more than a few of these,  it ends up
more like the gong show.  It also tends to set the expectation that if you
submit a draft, you at least get one of these short slots.

Of course, we also set earlier deadlines in DISPATCH to allow additional
time for discussion before the meeting and we only give agenda time in
cases where there has been discussion or sufficient interest expressed.
 However, that's because all the DISPATCH work items are new.  It is more
difficult to do that for regular WGs as there can be value in giving agenda
time for a -00 document if it really hits on something key to the WG.   So,
I personally, thinks it's entirely up to the discretion of the chairs.

I do agree that the latter deadline for -00 makes it a tad more
challenging, but I still think it's doable as a chair.

Mary.

On Tue, Jul 16, 2013 at 3:36 PM, Spencer Dawkins <
[email-masked]> wrote:

>> talk-style "here's my draft and here's why you should read it" is not a bad
>> thing (and I've seen that be successful).
>>
>
> The Lovely Mary Barnes and Equally Lovely Cullen Jennings can correct me,
> but I'm remembering that the DISPATCH chairs would offer to put up one
> slide on drafts that had suddenly descended from the sky, too suddenly to
> have generated mailing list traffic, if requested to do so, in order to
> familiarize interested working group participants with potential future
> work. I thought that was helpful.
>
> If a working group has the agenda time to allow lightning talks that last
> over a minute, I think that would be fine; for what I saw in DISPATCH. 3
> minutes would have been plenty.
>
> Thanks,
>
> Spencer
>

---

From: Flemming Andreasen <[email-masked]>
Date: Wed, 17 Jul 2013 00:03:27 -0400

> This is a matter of choice for working group chairs.   You are free to announce that no drafts initially submitted after a certain date will be on the agenda.   If you add things to the agenda late…
You risk a lot of other pushback when you start making up your own 
WG-specific rules (and rightfully so).

> The decision to merge the two deadlines was really just us being realistic: if someone wants to submit a -00 late, they just submit a -00 with minimal content before the -00 deadline, and then subm…
In practice, this has not been an issue though and in cases where it did 
happen, people seemed to understand it was bending the process, and that 
it was a good idea to discuss it with the chairs first if you expected 
to get on the agenda. I disagree completely that it did not provide any 
benefit; drafts were spaced better and -00 deadline enforced more timely 
raising of issues and new agenda requests.

> It's certainly not the case that someone submitting a -00 before either deadline does not already know that they want to discuss it at IETF; if they submit their agenda request late, you should jus…
All true in theory, but this is not how it happens and works in 
practice. I prefer being pragmatic. It worked reasonably well the way it 
was before; it's not working well the way it's being done now.

Thanks

-- Flemming

---

From: Ted Lemon <[email-masked]>
Date: Wed, 17 Jul 2013 04:14:14 +0000

On Jul 16, 2013, at 9:03 PM, Flemming Andreasen <[email-masked]> wrote:
> You risk a lot of other pushback when you start making up your own WG-specific rules (and rightfully so).

It's hard to understand what you might mean by this.

> All true in theory, but this is not how it happens and works in practice. I prefer being pragmatic. It worked reasonably well the way it was before; it's not working well the way it's being done now.

Can you cite an example of an actual problem that has occurred because of this change?

---

From: Yaakov Stein <[email-masked]>
Date: Wed, 17 Jul 2013 05:24:12 +0000

>from people who will not have time to read the documents prior to the 

A chair can certainly decide not discuss new drafts if (s)he thinks the
discussion would not be an informed one.

OTOH, when a new item is truly important and relevant,
then the chair can decide it is in the best interests of the WG to discuss it.

Declaring ahead of time a strict policy of no time for late submission
would rule this out (or at least force the chair to have to apologize to
others who WERE locked out who believe that their drafts are more important).

If you really want to announce a strict rule about this, 
then announce locking out all drafts save one,
and give that one new idea a generous slot.

This will at least incentivize late submitters to propose something important.

Y(J)S

---

From: Benoit Claise <[email-masked]>
Date: Wed, 17 Jul 2013 09:40:07 +0200

> However human nature responds to deadlines, and if we had no submission deadline, the consequence would virtually all the documents submitted on the Monday of the meeting with an expectation they w…
Exactly.
A 4th meeting per year would increase the productivity by 1/3, simply 
because there are extra deadlines.
Note: I'm not proposing to add an extra meeting
> In your rational, that would be met by a WG chairs applying a bar, but to avoid confusion among those working in multiple working groups, that needs to be a consistent bar. That bar is currently ex…
+1

Regards, Benoit

---

From: Tim Chown <[email-masked]>
Date: Wed, 17 Jul 2013 08:58:08 +0100

On 17 Jul 2013, at 08:40, Benoit Claise <[email-masked]> wrote:

> A 4th meeting per year would increase the productivity by 1/3, simply because there are extra deadlines.

Are we largely working to three major impulses per year?

Individual WGs can hold their own interim meetings, physical or via the network, to help push work forward. I recall discussion of coordinated interim meetings last year (around a RIPE65?) but I don't know how well that worked out. Is that something we should be looking to repeat?

>> In your rational, that would be met by a WG chairs applying a bar, but to avoid confusion among those working in multiple working groups, that needs to be a consistent bar. That bar is currently e…

The volume of submissions over the weekend was, as expected, very large.

I think a more relevant question is perhaps whether the pace at which the important work gets done is deemed sufficient? Is important protocol work for solutions to problems that are needed today happening as fast as we'd like it to? 

Tim

---

From: joel jaeggli <[email-masked]>
Date: Wed, 17 Jul 2013 01:03:52 -0700

> Individual WGs can hold their own interim meetings, physical or via the network, to help push work forward. I recall discussion of coordinated interim meetings last year (around a RIPE65?) but I do…
http://tools.ietf.org/html/draft-jaeggli-interim-observations-04

---

From: Benoit Claise <[email-masked]>
Date: Wed, 17 Jul 2013 10:45:55 +0200

> Are we largely working to three major impulses per year?
If the metric is the draft publication rate, I guess so:
http://www.arkko.com/tools/stats/pubdistr.html

Regards, Benoit

---

From: Tim Chown <[email-masked]>
Date: Wed, 17 Jul 2013 11:55:19 +0100

> http://www.arkko.com/tools/stats/pubdistr.html

I assume the counting method has changed for Jari's chart?

Tim

---

From: Stig Venaas <[email-masked]>
Date: Wed, 17 Jul 2013 11:28:31 -0700

> Can you cite an example of an actual problem that has occurred because of this change?

As a chair I can't, but as an individual participant I do. It gives me
less time to read up on new proposals. Before I had an extra week for
those new proposals.

I read there were cases when people uploaded a 00 as a place order,
cheating the system, but I think the majority of the 00s had real
content.

I don't mind a single deadline, but I'm wondering if it's better to
make the deadline for all drafts earlier (that is move the deadline
for updates, rather than the deadline for initial drafts).

Stig

---

From: Ted Lemon <[email-masked]>
Date: Wed, 17 Jul 2013 18:43:51 +0000

> less time to read up on new proposals. Before I had an extra week for

Wouldn't it be better to have, say, six months, rather than only two weeks, to read up on proposals before attending IETF?   I don't mean to minimize the issue, but as an AD I typically read a dozen documents every two weeks, sometimes hundreds of pages.   My experience is that this actually requires something like 16 to 24 working hours, and I could probably do it faster if I didn't get distracted by email.

This seems like a time management problem to me—there is no way you can't get through the documents you need to read in the two weeks prior to IETF if you make it a priority, but of course like everyone else you have other demands on your time.

I don't think there is one right answer to this question, and I certainly wouldn't want it to be the case that I didn't find out what documents would be discussed until the Friday before IETF, but the difference between two weeks and three doesn't seem that significant to me—that is, it doesn't meet the criterion of being an actual problem, but more like a matter of personal preference.

---

From: Flemming Andreasen <[email-masked]>
Date: Wed, 17 Jul 2013 19:27:48 -0400

> It's hard to understand what you might mean by this.
When you have a single set of consistent rules that are written down, 
it's easy for everybody to understand and accept. When the rules are WG 
specific and are created at the discretion of the WG chairs it becomes 
more of a challange:
1) Chairs now have the ability to define rules that influence desired 
outcomes (which is not to say they will)
2) People may believe that chairs in fact exercise 1), especially when 
things don't go as they like.

Neither is desirable.
> Can you cite an example of an actual problem that has occurred because of this change?
Sure. I'm travelling this week and had to scramble last night to look at 
several -00 drafts that were requested to be on the agenda. I had to get 
on a 5:30 am call this morning to coordinate the draft agenda with my 
co-chair due to the impending draft agenda deadline. The result feels a 
bit rushed with little time to dig into exactly what the issues are in 
the drafts and hence what to prioritize and with how much time allocated.

Another example involves a -00 draft that was submitted a little more 
than a week ago to DISPATCH. The authors weren't quite sure which group 
it belonged to, asked for an MMUSIC slot, and it then bounced around 
between several WG chairs. By the time we all agreed it indeed did 
belong to DISPATCH, it was all too late because DISPATCH hadn't received 
an agenda request in time.

We can all agree that none of this would happen if people submitted 
their drafts earlier. Human nature and work commitments being what they 
are, earlier draft deadlines seem to work a lot better at facilitating 
that.

Thanks

-- Flemming

---

From: Flemming Andreasen <[email-masked]>
Date: Wed, 17 Jul 2013 19:31:50 -0400

> Are we largely working to three major impulses per year?
Yes.
> Individual WGs can hold their own interim meetings, physical or via the network, to help push work forward. I recall discussion of coordinated interim meetings last year (around a RIPE65?) but I do…
Getting Interim meetings (even virtual ones) scheduled for specific 
topics with enough key participants for a single WG turns out to be 
surprisingly difficult. I can only imagine how hard it would be with 
multiple WGs.

> I think a more relevant question is perhaps whether the pace at which the important work gets done is deemed sufficient? Is important protocol work for solutions to problems that are needed today h…
Clearly not. How to actually fix that is a much harder question though.

Thanks

-- Flemming

---

From: Ted Lemon <[email-masked]>
Date: Wed, 17 Jul 2013 23:50:59 +0000

On Jul 17, 2013, at 4:27 PM, Flemming Andreasen <[email-masked]> wrote:
> We can all agree that none of this would happen if people submitted their drafts earlier. Human nature and work commitments being what they are, earlier draft deadlines seem to work a lot better at facilitating that.

No, we can't all agree to that.   This is purely situational.  You aren't describing problems with the policy—you are describing situations that came up that related to the policy, and that went wrong for reasons having to do with circumstances.   Someone published a -00 draft two weeks before IETF with no idea which working group it should be presented in.  This is great: it shouldn't be presented in _any_ working group at the upcoming IETF, because it's too late.   Unless it's really important, in which case presumably we already know where it will be presented.

You were traveling and had to scramble.   That's because you were traveling at the time of the deadline; if the deadline had been a week earlier, someone else's travel would have overlapped it, and it would have been a problem for them.   There is no deadline that occurs at a time when nobody is traveling.

As for your pushback answer, the fact is that people can see patterns in tea leaves and think that they predict the future.   It's always possible for someone to interpret your actions as a working group chair as biased in some way.   Chances are your actions _are_ biased sometimes.   None of us are perfect.   So if someone accuses you of bias, that's just something you need to deal with as a working group chair; the deadline has nothing to do with it.

---

From: Flemming Andreasen <[email-masked]>
Date: Wed, 17 Jul 2013 20:31:46 -0400

> No, we can't all agree to that.   This is purely situational.  You aren't describing problems with the policy—you are describing situations that came up that related to the policy, and that went wr…
Why do we have a draft deadline if people meeting that deadline can't 
have their documents discussed at the meeting because they submitted 
their documents "too late" ?

> You were traveling and had to scramble.   That's because you were traveling at the time of the deadline; if the deadline had been a week earlier, someone else's travel would have overlapped it, and…
True, but the point here is that with with a window of only 2 days, it 
is very difficult to work around such conflicts when they occur. This is 
different from having a deadline known ahead of time where you could 
actually have done the work beforehand.

> As for your pushback answer, the fact is that people can see patterns in tea leaves and think that they predict the future.   It's always possible for someone to interpret your actions as a working…
No, but falling back on WG chairs having to come up with their own 
deadline rules because the draft deadline for IETF meeting X doesn't 
actually work for drafts to be potentially discussed at meeting X seems 
backwards and only invites people to perceive such bias. Why wouldn't 
there be a consistent set of IETF rules ?

I fail to see what benefits we have achieved with these -00 cutoff 
dates, but I do see problems.

Thanks

-- Flemming

---

From: Pete Resnick <[email-masked]>
Date: Wed, 17 Jul 2013 20:45:35 -0500

> their documents "too late" ?

Well, the question for some of us is, "Why have an IETF-wide draft 
deadline at all?" Since we automated draft submission and it no longer 
requires by-hand processing, I've never thought that such a deadline was 
needed. But I understand that some chairs like the ability for "the 
system" to default to "no" for a set number of weeks before the meeting. 
I can live with that, but I think we need some flexibility. See below:

> actually work for drafts to be potentially discussed at meeting X 
> seems backwards and only invites people to perceive such bias. Why 
> wouldn't there be a consistent set of IETF rules ?

Because different WGs operate differently. In some high-volume WGs, it 
might be very disruptive to have drafts discussed at the meeting that 
haven't been available at least since the last meeting. For some smaller 
WGs, the ability to post up until a week before the meeting might be 
perfectly reasonable. The point is that one deadline is not sensible for 
all groups.

I've said before: I think the submission tool should always accept 
submissions, but during the IETF-wide embargo period (which could be 
even longer if we made this tool change) they would go into a holding 
area, not posted. Chairs would get a notification and could release them 
if they chose to do so. ADs could also release them. If you wanted to 
get fancy, perhaps documents for WGs that aren't meeting would auto-release.

I don't buy the perceived bias problem. So long as the chair sets up 
reasonable and consistent rules ahead of time, and is fair in making 
exceptions to those rules, there shouldn't be a problem. If there is a 
problem, it's probably time to fire the chair.

pr

-- 
Pete Resnick<http://www.qualcomm.com/~presnick/>
Qualcomm Technologies, Inc. - +1 (858)651-4478

---

From: "Black, David" <[email-masked]>
Date: Wed, 17 Jul 2013 22:50:11 -0400

> their documents "too late" ?

Melinda Shore recently sent a cogent answer on that to the OPSAWG list:

  We've been getting a lot of requests for time on the agenda for
  the upcoming meeting to "present" drafts which haven't been
  discussed on the mailing list.  This is a reminder that the purpose
  of meetings is face-to-face discussion of issues that haven't
  been able to make progress on the mailing list, and to progress
  deliverables.  The IETF is somewhat different from other standards
  bodies in that meeting time is generally not used for presentation
  of new material, and that the work of the organization is primarily
  done via working group mailing lists.  The most reliable way to
  get time on a meeting agenda is to have a lively discussion on
  the mailing list prior to the meeting.

There is a common misperception that meeting the draft submission
deadline "entitles" a draft to "presentation" time in the WG meeting.
The IETF simply does not work that way ...

If a "too late" draft generates lively (and appropriate) mailing list
discussion, I have no problem bashing the WG agenda at the start of
the meeting to spend time on that topic.

Thanks,
--David

> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Flemming Andreasen
> Sent: Wednesday, July 17, 2013 8:32 PM
> To: Ted Lemon
> Cc: [email-masked]
> >> We can all agree that none of this would happen if people submitted their
> drafts earlier. Human nature and work commitments being what they are, earlier
> draft deadlines seem to work a lot better at facilitating that.
> > No, we can't all agree to that.   This is purely situational.  You aren't
> describing problems with the policy-you are describing situations that came up
> that related to the policy, and that went wrong for reasons having to do with
> circumstances.   Someone published a -00 draft two weeks before IETF with no
> idea which working group it should be presented in.  This is great: it
> shouldn't be presented in _any_ working group at the upcoming IETF, because
> it's too late.   Unless it's really important, in which case presumably we
> already know where it will be presented.
> > You were traveling and had to scramble.   That's because you were traveling
> at the time of the deadline; if the deadline had been a week earlier, someone
> else's travel would have overlapped it, and it would have been a problem for
> them.   There is no deadline that occurs at a time when nobody is traveling.
> > As for your pushback answer, the fact is that people can see patterns in tea
> leaves and think that they predict the future.   It's always possible for
> someone to interpret your actions as a working group chair as biased in some
> way.   Chances are your actions _are_ biased sometimes.   None of us are
> perfect.   So if someone accuses you of bias, that's just something you need
> to deal with as a working group chair; the deadline has nothing to do with it.

---

From: Andrew Sullivan <[email-masked]>
Date: Thu, 18 Jul 2013 02:32:27 -0400

> the meeting to spend time on that topic.

Exactly.  And if the complaint on the part of chairs is that making
these sorts of decisions exposes them to too much criticism, my
response is then, "Please give the chair to someone else."  That's why
we have the dot: to make those decisions and take the heat for them.

I am very much more in favour of chairs exercising this sort of
discipline over meeting time than I am in favour of adding Friday
afternoon and even Saturday sessions to the agenda.  And let's not
misunderstand: those are the current live options.  Either we, all of
us chairs, make meetings both more efficient and more productive; or,
the IETF meeting as a whole will last more than a week when travel is
counted.  I suggest that the time between, "meeting goes Sunday
through Sunday" and "let's stop having One Big IETF Meeting" will be
measurable in deciseconds.  I think that will be a shame, because the
only remaining thread connecting us to cross-area review will be cut.

Best,

A

-- 
Andrew Sullivan
[email-masked]

---

From: Dave Crocker <[email-masked]>
Date: Thu, 18 Jul 2013 07:15:23 -0700

> afternoon and even Saturday sessions to the agenda.

That's the essence of the disparity here:  Sustaining an artificial, 
universal, inflexible deadline on everyone, vs. requiring that WG Chairs 
to actually manage their working groups, including setting whatever 
limits on the meeting agenda make sense for the working group.

I'm for the latter.  It's not exactly an onerous task, and if the wg is 
problematic enough so that the task /is/ onerous, the wg has bigger 
problems...

d/

-- 
Dave Crocker
Brandenburg InternetWorking
bbiw.net

---

From: Stephen Kent <[email-masked]>
Date: Thu, 18 Jul 2013 11:23:03 -0400

+1
> universal, inflexible deadline on everyone, vs. requiring that WG 
> Chairs to actually manage their working groups, including setting 
> whatever limits on the meeting agenda make sense for the working group.
>
> I'm for the latter.  It's not exactly an onerous task, and if the wg 
> is problematic enough so that the task /is/ onerous, the wg has bigger 
> problems...
>
> d/
>

---

From: Mary Barnes <[email-masked]>
Date: Thu, 18 Jul 2013 10:39:36 -0500

Yep - I fully agree.

On Thu, Jul 18, 2013 at 9:15 AM, Dave Crocker <[email-masked]> wrote:

> universal, inflexible deadline on everyone, vs. requiring that WG Chairs to
> actually manage their working groups, including setting whatever limits on
> the meeting agenda make sense for the working group.
>

---

From: Mary Barnes <[email-masked]>
Date: Thu, 18 Jul 2013 13:27:59 -0500

I have on comment below on an example cited as to the problems with the
single deadline.

Mary.

On Wed, Jul 17, 2013 at 6:27 PM, Flemming Andreasen <[email-masked]>wrote:

> When you have a single set of consistent rules that are written down, it's
> easy for everybody to understand and accept. When the rules are WG specific
> and are created at the discretion of the WG chairs it becomes more of a
> challange:
>  All true in theory, but this is not how it happens and works in practice.
>>> I prefer being pragmatic. It worked reasonably well the way it was before;
>>> it's not working well the way it's being done now.
>>>
> several -00 drafts that were requested to be on the agenda. I had to get on
> a 5:30 am call this morning to coordinate the draft agenda with my co-chair
> due to the impending draft agenda deadline. The result feels a bit rushed
> with little time to dig into exactly what the issues are in the drafts and
> hence what to prioritize and with how much time allocated.
>
> Another example involves a -00 draft that was submitted a little more than
> a week ago to DISPATCH. The authors weren't quite sure which group it
> belonged to, asked for an MMUSIC slot, and it then bounced around between
> several WG chairs. By the time we all agreed it indeed did belong to
> DISPATCH, it was all too late because DISPATCH hadn't received an agenda
> request in time.
>
[MB] This one is not a particularly good example in terms of problems
caused by the deadlines.  This is an example of someone not following the
RAI/DISPATCH WG process.  It should have been no surprise to the authors
that the document should be discussed first in the DISPATCH WG, as that is
our basic process unless it's beyond obvious that it is related
specifically to an existing chartered WG.  In addition, these authors (one
of whom is not an inexperienced IETFer) should have been aware of how we
were handling documents of a similar nature as we dispatched several at the
last IETF meeting.  I think this is an example of WG shopping and not of
too late deadlines.  In particular given that the DISPATCH deadline
required that notification of intent to submit a document and desire to
discuss a topic in dispatch was June 24th, with charter proposals/problem
statements due July 1st. This document was submitted well over a week after
the last deadline.  There's nothing wrong with a WG chair flat out saying
that a document wasn't submitted in time to garner enough consideration to
warrant agenda time at the f2f meeting.  Again, the RAI/DISPATCH process
allows progression of documents without ever having been discussed at a f2f
meeting.  We should continue discussion of situations like this on the RAI
area list where there is discussion of process/structural issues that are
currently being encountered:
http://www.ietf.org/mail-archive/web/rai/current/msg01384.html
It is unfortunate for you (and not at all your fault) that your WG is in
the middle of the concerns raised, but I think the draft deadlines are the
least of your problems.
[/MB]

> drafts earlier. Human nature and work commitments being what they are,
> earlier draft deadlines seem to work a lot better at facilitating that.
>
> Thanks
>
> -- Flemming
>
>
>
>
>
>

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Thu, 18 Jul 2013 19:10:36 +0000

Sorry - not buying this.

Your comment is only applicable if you buy the argument that all new proposals, whether in scope or out of scope of another RAI working group, go to DISPATCH, and that currently does not appear to be the case. So there is the case of a document being submitted, and then some evaluation occurs that maybe it ought to have been in DISPATCH, after the DISPATCH deadlines have passed.

Even I am not sure if a document should be in DISPATCH or not. If I read follow the DISPATCH charter alone, then there are a number of other items on the MMUSIC agenda that have never been dispatched to MMUSIC (or anywhere else), and therefore ought to be in DISPATCH. They do fall in scope of the MMUSIC agenda. I could point this out in a number of other working groups. ECRIT even has stuff on the agenda that is not in the scope of ECRIT, has never been through DISPATCH and so on.

If the deadlines for DISPATCH had not been different, then maybe there would have been different issues, but at least it is the different DISPATCH deadlines that have currently ruled out the discussion of this document in Berlin.

Regards

Keith

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Mary Barnes
Sent: 18 July 2013 19:28
To: Flemming Andreasen
Cc: [email-masked]
Subject: Re: WG Agendas to submit only 2 days after -00 submission cut-off date

I have on comment below on an example cited as to the problems with the single deadline.

Mary.

On Wed, Jul 17, 2013 at 6:27 PM, Flemming Andreasen <[email-masked]<mailto:[email-masked]>> wrote:

On 7/17/13 12:14 AM, Ted Lemon wrote:
On Jul 16, 2013, at 9:03 PM, Flemming Andreasen <[email-masked]<mailto:[email-masked]>> wrote:
You risk a lot of other pushback when you start making up your own WG-specific rules (and rightfully so).
It's hard to understand what you might mean by this.
When you have a single set of consistent rules that are written down, it's easy for everybody to understand and accept. When the rules are WG specific and are created at the discretion of the WG chairs it becomes more of a challange:
1) Chairs now have the ability to define rules that influence desired outcomes (which is not to say they will)
2) People may believe that chairs in fact exercise 1), especially when things don't go as they like.

Neither is desirable.

Sure. I'm travelling this week and had to scramble last night to look at several -00 drafts that were requested to be on the agenda. I had to get on a 5:30 am call this morning to coordinate the draft agenda with my co-chair due to the impending draft agenda deadline. The result feels a bit rushed with little time to dig into exactly what the issues are in the drafts and hence what to prioritize and with how much time allocated.

Another example involves a -00 draft that was submitted a little more than a week ago to DISPATCH. The authors weren't quite sure which group it belonged to, asked for an MMUSIC slot, and it then bounced around between several WG chairs. By the time we all agreed it indeed did belong to DISPATCH, it was all too late because DISPATCH hadn't received an agenda request in time.
[MB] This one is not a particularly good example in terms of problems caused by the deadlines.  This is an example of someone not following the RAI/DISPATCH WG process.  It should have been no surprise to the authors that the document should be discussed first in the DISPATCH WG, as that is our basic process unless it's beyond obvious that it is related specifically to an existing chartered WG.  In addition, these authors (one of whom is not an inexperienced IETFer) should have been aware of how we were handling documents of a similar nature as we dispatched several at the last IETF meeting.  I think this is an example of WG shopping and not of too late deadlines.  In particular given that the DISPATCH deadline required that notification of intent to submit a document and desire to discuss a topic in dispatch was June 24th, with charter proposals/problem statements due July 1st. This document was submitted well over a week after the last deadline.  There's nothing wrong with a WG chair flat out saying that a document wasn't submitted in time to garner enough consideration to warrant agenda time at the f2f meeting.  Again, the RAI/DISPATCH process allows progression of documents without ever having been discussed at a f2f meeting.  We should continue discussion of situations like this on the RAI area list where there is discussion of process/structural issues that are currently being encountered:
http://www.ietf.org/mail-archive/web/rai/current/msg01384.html
It is unfortunate for you (and not at all your fault) that your WG is in the middle of the concerns raised, but I think the draft deadlines are the least of your problems.
[/MB]

Thanks

-- Flemming

---

From: Mary Barnes <[email-masked]>
Date: Thu, 18 Jul 2013 14:28:03 -0500

On Thu, Jul 18, 2013 at 2:10 PM, DRAGE, Keith (Keith) <
[email-masked]> wrote:

> ********
> Sorry – not buying this.
[MB] Then you should raise the issue to the ADs.  I'm the implementer of a
process that is in place for managing work in their area. [/MB]

> ****
>
> ** **
>
> Your comment is only applicable if you buy the argument that all new
> proposals, whether in scope or out of scope of another RAI working group,
> go to DISPATCH, and that currently does not appear to be the case. So there
> is the case of a document being submitted, and then some evaluation occurs
> that maybe it ought to have been in DISPATCH, after the DISPATCH deadlines
> have passed.
>
[MB] As I said previously, in cases where documents are clearly under the
purview for a specific WG, then it's not an issue to go directly to the WG.
 BTW, I have no idea what document you're referring to. And, keep in mind
that the process requires notifying the chairs, so it may not be visible to
you what discussions might occur offline. [/MB]

> Even I am not sure if a document should be in DISPATCH or not. If I read
> follow the DISPATCH charter alone, then there are a number of other items
> on the MMUSIC agenda that have never been dispatched to MMUSIC (or anywhere
> else), and therefore ought to be in DISPATCH. They do fall in scope of the
> MMUSIC agenda. I could point this out in a number of other working groups.
> ECRIT even has stuff on the agenda that is not in the scope of ECRIT, has
> never been through DISPATCH and so on.
>
[MB]  I only see one document on the MMUSIC WG agenda that probably should
have first gone to DISPATCH and actually, the MMUSIC chairs could have
raised that issue and suggested such to the document authors rather than
give agenda time when they certainly do have really high priority, critical
items to discuss.   The document I am referring to relates to at least two
different WGs (including one that is now closed) and wasn't at all an
obvious fit for MMUSIC.    In addition, as I said, it should have been
obvious that there was a fairly clear expectation that  the websocket and
alternate transport docs are first discussed in  DISPATCH - e.g., BFCPbis,
mrsp websocket document, etc.
[/MB]

> ****
>
> ** **
>
> If the deadlines for DISPATCH had not been different, then maybe there
> would have been different issues, but at least it is the different DISPATCH
> deadlines that have currently ruled out the discussion of this document in
> ****Berlin****.
>
[MB] That's absolutely correct - that's the whole intent of the DISPATCH
deadlines - these authors simply had to send an email to the DISPATCH WG
chairs by June 24th indicating they were putting together a draft that was
an alternative to a previously discussed draft.  They didn't do so.  If
they had submitted the draft by July 1st, there would have been some
flexibility, but that wasn't the case.  There were other people that did
so, that also requested agenda time that were not given agenda time because
it wasn't deemed necessary. AGain, you can progress work without discussing
at a f2f meeting.

 If you have issues with the DISPATCH process, then please bring those to
the DISPATCH WG or better yet RAI area mailing list.  We've had this
process in place for 4 years so the concept of notifying the chairs several
weeks before draft deadlines has been there the whole time. Indeed, we had
the dates for IETF-87 much later than usual.   Keep in mind as well that
there is NOTHING in the DISPATCH/RAI process that requires a document to
have f2f discussion.  Additionally, keep in mind that the document in
question has normative dependencies such that this document cannot be
published until those docs are completed. [/MB]

> ****
>
> ** **
>
> Regards****
>
> ** **
>
> Keith****
>
> ** **
>   ------------------------------
>
> *From:* [email-masked] [mailto:[email-masked]] *On
> Behalf Of *Mary Barnes
> *Sent:* 18 July 2013 19:28
> *To:* Flemming Andreasen
>
> *Cc:* [email-masked]
> *Subject:* Re: WG Agendas to submit only 2 days after -00 submission
> cut-off date
> ****
>
>  ** **
>
> single deadline. ****
> ** **
> Mary.****
> ** **
> On Wed, **Jul 17, 2013** at **6:27 PM**, Flemming Andreasen <
> [email-masked]> wrote:****
>
>
> On **7/17/13** **12:14 AM**, Ted Lemon wrote:****
>
> On **Jul 16, 2013**, at **9:03 PM**, Flemming Andreasen <
> [email-masked]> wrote:****
>
> WG-specific rules (and rightfully so).****
>
> It's hard to understand what you might mean by this.****
>
> Neither is desirable.****
>
> ** **
>
> it's not working well the way it's being done now.****
>
> ****
> a **5:30 am** call this morning to coordinate the draft agenda with my
> co-chair due to the impending draft agenda deadline. The result feels a bit
> rushed with little time to dig into exactly what the issues are in the
> drafts and hence what to prioritize and with how much time allocated.
>
> request in time.****
> currently being encountered:****
>
> http://www.ietf.org/mail-archive/web/rai/current/msg01384.html****
>
> least of your problems. ****
>
> [/MB]****
>
> ** **
>
>
> ****
>  ** **

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Sun, 21 Jul 2013 17:55:25 +0000

What I am not buying is your contention that confusion does not exist because dispatch has different deadlines.

I'd note the words

"in cases where documents are clearly under the purview for a specific WG, then it's not an issue to go directly to the WG"

Do not actually appear in the DISPATCH charter - which refers generally to "new work" without any further clarification.

So we are left having to interpret the overlap between charters of existing WG, which presumably have some ownership and DISPATCH.

So for discussions that fall in this overlap, the fact that DISPATCH has different deadlines adds to the confusion.

And I can list a number of documents in the past where the author has wavered between DISPATCH and other working groups, and apparently ended up going for the wrong working group.

Keith

________________________________
From: Mary Barnes [mailto:[email-masked]]
Sent: 18 July 2013 20:28
To: DRAGE, Keith (Keith)
Cc: Flemming Andreasen; [email-masked]
Subject: Re: WG Agendas to submit only 2 days after -00 submission cut-off date

On Thu, Jul 18, 2013 at 2:10 PM, DRAGE, Keith (Keith) <[email-masked]<mailto:[email-masked]>> wrote:
Sorry - not buying this.
[MB] Then you should raise the issue to the ADs.  I'm the implementer of a process that is in place for managing work in their area. [/MB]

Your comment is only applicable if you buy the argument that all new proposals, whether in scope or out of scope of another RAI working group, go to DISPATCH, and that currently does not appear to be the case. So there is the case of a document being submitted, and then some evaluation occurs that maybe it ought to have been in DISPATCH, after the DISPATCH deadlines have passed.
[MB] As I said previously, in cases where documents are clearly under the purview for a specific WG, then it's not an issue to go directly to the WG.  BTW, I have no idea what document you're referring to. And, keep in mind that the process requires notifying the chairs, so it may not be visible to you what discussions might occur offline. [/MB]
Even I am not sure if a document should be in DISPATCH or not. If I read follow the DISPATCH charter alone, then there are a number of other items on the MMUSIC agenda that have never been dispatched to MMUSIC (or anywhere else), and therefore ought to be in DISPATCH. They do fall in scope of the MMUSIC agenda. I could point this out in a number of other working groups. ECRIT even has stuff on the agenda that is not in the scope of ECRIT, has never been through DISPATCH and so on.
[MB]  I only see one document on the MMUSIC WG agenda that probably should have first gone to DISPATCH and actually, the MMUSIC chairs could have raised that issue and suggested such to the document authors rather than give agenda time when they certainly do have really high priority, critical items to discuss.   The document I am referring to relates to at least two different WGs (including one that is now closed) and wasn't at all an obvious fit for MMUSIC.    In addition, as I said, it should have been obvious that there was a fairly clear expectation that  the websocket and alternate transport docs are first discussed in  DISPATCH - e.g., BFCPbis, mrsp websocket document, etc.
[/MB]

If the deadlines for DISPATCH had not been different, then maybe there would have been different issues, but at least it is the different DISPATCH deadlines that have currently ruled out the discussion of this document in Berlin.
[MB] That's absolutely correct - that's the whole intent of the DISPATCH deadlines - these authors simply had to send an email to the DISPATCH WG chairs by June 24th indicating they were putting together a draft that was an alternative to a previously discussed draft.  They didn't do so.  If they had submitted the draft by July 1st, there would have been some flexibility, but that wasn't the case.  There were other people that did so, that also requested agenda time that were not given agenda time because it wasn't deemed necessary. AGain, you can progress work without discussing at a f2f meeting.

 If you have issues with the DISPATCH process, then please bring those to the DISPATCH WG or better yet RAI area mailing list.  We've had this process in place for 4 years so the concept of notifying the chairs several weeks before draft deadlines has been there the whole time. Indeed, we had the dates for IETF-87 much later than usual.   Keep in mind as well that there is NOTHING in the DISPATCH/RAI process that requires a document to have f2f discussion.  Additionally, keep in mind that the document in question has normative dependencies such that this document cannot be published until those docs are completed. [/MB]

Regards

Keith

________________________________
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Mary Barnes
Sent: 18 July 2013 19:28
To: Flemming Andreasen

Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: WG Agendas to submit only 2 days after -00 submission cut-off date

Mary.

Neither is desirable.

Thanks

-- Flemming

---

From: Mary Barnes <[email-masked]>
Date: Sun, 21 Jul 2013 17:30:08 -0500

On Sun, Jul 21, 2013 at 12:55 PM, DRAGE, Keith (Keith) <
[email-masked]> wrote:

> ********
>
> What I am not buying is your contention that confusion does not exist
> because dispatch has different deadlines.****
>
> ** **
>
> I’d note the words ****
>
> ** **
>
> “in cases where documents are clearly under the purview for a specific
> WG, then it's not an issue to go directly to the WG” ****
>
> ** **
>
> Do not actually appear in the DISPATCH charter – which refers generally to
> “new work” without any further clarification. ****
>
> ** **
>
> So we are left having to interpret the overlap between charters of
> existing WG, which presumably have some ownership and DISPATCH.****
>
> ** **
>
> So for discussions that fall in this overlap, the fact that DISPATCH has
> different deadlines adds to the confusion.****
>
> ** **
>
> And I can list a number of documents in the past where the author has
> wavered between DISPATCH and other working groups, and apparently ended up
> going for the wrong working group.
>
[MB] And, that's why if you are uncertain, then bring it to DISPATCH.  It's
also *extremely* useful to follow the naming convention and include
-dispatch - it makes it much easier for the chairs to notice and keep an
eye on new work.

DISPATCH has had different deadlines for 4+ years.  The reason we
implemented DISPATCH is because the SIPPING WG clearly showed us that it is
extremely ineffective to have a kitchen sink WG.  And, WG shopping just
wastes everyone's time, which is what we had ALOT of before we chartered
DISPATCH  We've done quite well with the WGs that we've chartered for
discrete work items.

You are correct that there can be lack of clarity when things *might* look
like SIPCORE or MMUSIC or AVT/EXT, etc.  In those cases, unless you've
talked to the ADs and they've said to take the item to a specific WG, you
should bring it to DISPATCH.   The motivation behind the early deadline is
there is often little value in discussing a draft that is submitted at the
-00 deadline as there is rarely enough time to determine if there is any
interest in the topic.  The whole point was to get away from allocating
agenda time just because someone submitted a draft.  Perhaps you've
forgotten the insanity we had in SIPPING prior to DISPATCH - it was insane.
 We had WG items with 5 minutes of agenda time, we had work items that
totally languished, etc.  If you have better suggestions as to how to
manage the volume of new work that comes into the RAI area, including work
items that overlap WGs, then please post those on the RAI area mailing list
where that discussion has already been started.
[/MB]

> *From:* Mary Barnes [mailto:[email-masked]]
> *Sent:* 18 July 2013 20:28
> *To:* DRAGE, Keith (Keith)
> *Cc:* Flemming Andreasen; [email-masked]
>
> On Thu, **Jul 18, 2013** at **2:10 PM**, DRAGE, Keith (Keith) <
> [email-masked]> wrote:****
>
>  Sorry – not buying this.****
>
>  [MB] Then you should raise the issue to the ADs.  I'm the implementer of
> a process that is in place for managing work in their area. [/MB] ****
>
>   ****
>
> have passed.****
>  [MB] As I said previously, in cases where documents are clearly under
> the purview for a specific WG, then it's not an issue to go directly to the
> WG.  BTW, I have no idea what document you're referring to. And, keep in
> mind that the process requires notifying the chairs, so it may not be
> visible to you what discussions might occur offline. [/MB] ****
>
> never been through DISPATCH and so on.****
>
>  [MB]  I only see one document on the MMUSIC WG agenda that probably
> should have first gone to DISPATCH and actually, the MMUSIC chairs could
> have raised that issue and suggested such to the document authors rather
> than give agenda time when they certainly do have really high priority,
> critical items to discuss.   The document I am referring to relates to at
> least two different WGs (including one that is now closed) and wasn't at
> all an obvious fit for MMUSIC.    In addition, as I said, it should have
> been obvious that there was a fairly clear expectation that  the websocket
> and alternate transport docs are first discussed in  DISPATCH - e.g.,
> BFCPbis, mrsp websocket document, etc.     ****
>
> [/MB]****
>
>   ****
>
> ****Berlin****.****
> at a f2f meeting. ****
> published until those docs are completed. [/MB] ****
>
>   ****
>
> Regards****
>
>  ****
>
> Keith****
>
>  ****
> *To:* Flemming Andreasen****
>
>
> *Cc:* [email-masked]
> cut-off date****
> Can you cite an example of an actual problem that has occurred because of
> this change?****
>
> a ** 5:30 am** call this morning to coordinate the draft agenda with my

---

From: Flemming Andreasen <[email-masked]>
Date: Mon, 22 Jul 2013 11:34:11 -0400

On 7/18/13 3:28 PM, Mary Barnes wrote:
> On Thu, Jul 18, 2013 at 2:10 PM, DRAGE, Keith (Keith) 
> <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     Even I am not sure if a document should be in DISPATCH or not. If
>     I read follow the DISPATCH charter alone, then there are a number
>     of other items on the MMUSIC agenda that have never been
>     dispatched to MMUSIC (or anywhere else), and therefore ought to be
>     in DISPATCH. They do fall in scope of the MMUSIC agenda. I could
>     point this out in a number of other working groups. ECRIT even has
>     stuff on the agenda that is not in the scope of ECRIT, has never
>     been through DISPATCH and so on.
>
> should have first gone to DISPATCH and actually, the MMUSIC chairs 
> could have raised that issue and suggested such to the document 
> authors rather than give agenda time when they certainly do have 
> really high priority, critical items to discuss.   The document I am 
> referring to relates to at least two different WGs (including one that 
> is now closed) and wasn't at all an obvious fit for MMUSIC.    In 
> addition, as I said, it should have been obvious that there was a 
> fairly clear expectation that  the websocket and alternate transport 
> docs are first discussed in  DISPATCH - e.g., BFCPbis, mrsp websocket 
> document, etc.
> [/MB]
The MMUSIC agenda is a draft agenda at this point. If you have concerns 
with it, please raise those on the MMUSIC mailing list.

>     If the deadlines for DISPATCH had not been different, then maybe
>     there would have been different issues, but at least it is the
>     different DISPATCH deadlines that have currently ruled out the
>     discussion of this document in Berlin.
>
> [MB] That's absolutely correct - that's the whole intent of the 
> DISPATCH deadlines - these authors simply had to send an email to the 
> DISPATCH WG chairs by June 24th indicating they were putting together 
> a draft that was an alternative to a previously discussed draft.  They 
> didn't do so.  If they had submitted the draft by July 1st, there 
> would have been some flexibility, but that wasn't the case.  There 
> were other people that did so, that also requested agenda time that 
> were not given agenda time because it wasn't deemed necessary. AGain, 
> you can progress work without discussing at a f2f meeting.
>
>  If you have issues with the DISPATCH process, then please bring those 
> to the DISPATCH WG or better yet RAI area mailing list.  We've had 
> this process in place for 4 years so the concept of notifying the 
> chairs several weeks before draft deadlines has been there the whole 
> time. Indeed, we had the dates for IETF-87 much later than usual.   
> Keep in mind as well that there is NOTHING in the DISPATCH/RAI process 
> that requires a document to have f2f discussion.  Additionally, keep 
> in mind that the document in question has normative dependencies such 
> that this document cannot be published until those docs are completed. 
> [/MB]
The different points raised in this thread only reaffirms my view that 
having a single set of consistent procedures shared by the WGs would be 
useful. I also understand this view is not shared by all, so belaboring 
the point is probably not going to be productive.

Thanks

-- Flemming

---

From: Mary Barnes <[email-masked]>
Date: Mon, 22 Jul 2013 11:06:36 -0500

On Mon, Jul 22, 2013 at 10:34 AM, Flemming Andreasen <[email-masked]>wrote:

>   Even I am not sure if a document should be in DISPATCH or not. If I
>> read follow the DISPATCH charter alone, then there are a number of other
>> items on the MMUSIC agenda that have never been dispatched to MMUSIC (or
>> anywhere else), and therefore ought to be in DISPATCH. They do fall in
>> scope of the MMUSIC agenda. I could point this out in a number of other
>> working groups. ECRIT even has stuff on the agenda that is not in the scope
>> of ECRIT, has never been through DISPATCH and so on.
>>
[MB] My point was not a criticism of your agenda.  My point was that there
was a request to the MMUSIC WG to discuss a document that really should
first be dealt with in DISPATCH WG (per the RAI process) - that's what
Keith was using as the reason why we all need the same deadlines.  I think
it would have been a bad idea to give that document agenda time, as I noted
MMUSIC WG has a lot of higher priority work (I don't think anyone will
debate that point).  I see that your current agenda is geared towards the
latter, with documents that aren't high priority noted as "time allows".
That's good. [/MB]

>> Berlin.
> to the DISPATCH WG or better yet RAI area mailing list.  We've had this
> useful. I also understand this view is not shared by all, so belaboring the
> point is probably not going to be productive.
>

[MB] The specific points I am raising about deadlines with regards to
DISPATCH is the RAI process for new work that we implemented over 4+ years
ago.  I think aligning the issues one sees with the deadlines set by the
RAI process with this thread of document deadlines in general is a red
herring. As I noted, there is a discussion with regards to the RAI process
overall, including how to handle WGs that have very tight coupling.  I
don't think the deadlines have any relation whatsoever to the issues around
the latter point and should be discussed on the RAI area list.

As to my opinion with regards to the general idea that we need a rigid
process defining deadlines that all the WGs apply across all areas use,  I
don't think that solves any real problems with managing work in WGs.  If
folks can't follow a mailing list close enough to know the expectations of
chairs in terms of deadlines for planning their meetings (or progressing
work in general), then as others have noted, the WG has a much bigger
problem than draft deadlines.  Chairs have always been able to make
exceptions for documents that miss the deadlines.  There are good reasons
why this happens sometimes, I think the process needs to remain flexible
enough for chairs to deal with that.  If WG members don't tolerate any
changes in concepts or problems to be solved for 2-3 weeks before the
meetings, then we end up with 6-9 weeks of the year (about 2 months) where
we limit progress.  As a chair, I have allowed discussion of drafts (even
individual ones) that missed the deadline in cases where the document
updates where significant enough that it could help with WG progress.  Yes,
people did complain, but again I believe WG chairs must have flexibility in
how they manage their WGs.    [/MB]

---

From: "Cullen Jennings (fluffy)" <[email-masked]>
Date: Fri, 26 Jul 2013 17:15:35 +0000

> the meeting to spend time on that topic.

+1 Melinda. That text could be added to the wg chair training templates ….