Subject: Draft submission deadline/moratorium tool proposal

From: Pete Resnick <[email-masked]>
Date: Fri, 19 Jul 2013 12:11:55 -0500

Given the talk over the last week, I'd like to make a proposal. I have 
suggested something like this before. If the chairs generally think this 
is a good idea, then maybe we take it to the IETF list. (I have not 
passed this by other ADs; they can pipe up as they see fit.)

Proposal for draft submission deadline/moratorium:

1. The draft submission tool never shuts down. Everyone is *always* 
allowed to submit drafts to the tool. However, they are not always posted.

2. For X weeks before an IETF plenary meeting and during the week of the 
meeting, all submitted drafts are queued but not posted. The draft 
deadline is announced as X weeks. (I personally don't care what X is; 
suggestions welcome.)

3. Queued WG drafts can be approved for posting by an AD or the chair(s) 
of that WG.

4. Queued individual submission drafts can be approved for posting by an AD.

5. At the completion of the IETF meeting, all queued drafts are released 
from the queue.

(Other features that might be desirable, but I'm not sure about)

6a. Drafts that are in IESG-Evaluation are not queued.
...or...
6b. Drafts that are in IESG-Evaluation are always queued, regardless of 
moratorium. An AD must release them.

7. Chairs can pre-approve draft posting during the moratorium, just as 
they do for -00 drafts.

8. Chairs can put a moratorium on a particular WG (for instance, before 
an interim meeting).

Thoughts?

pr

-- 
Pete Resnick<http://www.qualcomm.com/~presnick/>
Qualcomm Technologies, Inc. - +1 (858)651-4478

---

From: Dave Crocker <[email-masked]>
Date: Fri, 19 Jul 2013 10:19:14 -0700

> allowed to submit drafts to the tool. However, they are not always posted.

You've just increased the workload of ADs and chairs.  Although the 
design you propose is logical, it really creates a significant hassle 
for the principals in the process.

I'll suggest something a bit different:

      All submissions are accepted and posted and announced.

      However, they are not integrated into the working group document 
page during the quiet period.  (If you want to add AD/Chair authority to 
override this selectively, fine.)

d/
-- 
Dave Crocker
Brandenburg InternetWorking
bbiw.net

---

From: Pete Resnick <[email-masked]>
Date: Fri, 19 Jul 2013 12:27:44 -0500

On 7/19/13 12:19 PM, Dave Crocker wrote:
> You've just increased the workload of ADs and chairs.

This only changes the workload if the ADs and chairs even look at the 
queue. There is no requirement that they do so.

ADs already get email to approve posting after the deadline. This might 
increase the number of requests to do so.

And how many drafts do you think any given WG chair will have to look 
at, even if they chose to look at the queue?

Color me unconvinced.

> I'll suggest something a bit different:

I suspect your proposal will get a similar amount of pushback that the 
simpler "No deadline at all" proposal got. And I'd prefer to discuss the 
merits of this proposal on its own and see if it can get some consensus 
before discussing alternatives.

pr

---

From: Dave Crocker <[email-masked]>
Date: Fri, 19 Jul 2013 10:35:34 -0700

> queue. There is no requirement that they do so.

Oh.  You don't understand.

I just posted my draft and it's not showing up.  I want it released NOW.

Negotiation ensues.  Everyone is hassled.

Yes, there's another well-behaved scenario, but we know the other kind 
will happen frequently.

> before discussing alternatives.

I offered comments on the merits, as justifying the alternative.  Less 
workload for ADs and Chairs.

d/

---

From: Richard Barnes <[email-masked]>
Date: Fri, 19 Jul 2013 14:02:37 -0400

I pretty much agree with Dave here.

Yes, we need a forcing function to get people to submit drafts.  The
meeting is one such deadline.  We could even have an advisory deadline.

Locking down the tool is overkill.

--Richard

---

From: Pete Resnick <[email-masked]>
Date: Fri, 19 Jul 2013 13:10:19 -0500

> I just posted my draft and it's not showing up.  I want it released NOW.

Ah, I think you've just defined a feature clarification:

2. For X weeks before an IETF plenary meeting and during the week of the 
meeting, the submission tool says, "Posting deadline passed. No drafts 
will be posted without chair/AD approval." All submitted drafts are 
queued but not posted.

> Negotiation ensues.  Everyone is hassled.

I'd like to hear from other chairs, but I am surprised that you would 
suggest that there would be negotiation. I would expect you would either 
say, "No" or "Yes". End of negotiation. No hassle. If there is 
negotiation, fire the document editor. Seriously.

> Yes, there's another well-behaved scenario, but we know the other kind 

Still unconvinced.

> I offered comments on the merits...

You did. As I said, I'd like to hear from other chairs before we move on 
to alternatives. Jumping to alternatives forks the discussion.

pr

---

From: Paul Hoffman <[email-masked]>
Date: Fri, 19 Jul 2013 11:10:51 -0700

> 4. Queued individual submission drafts can be approved for posting by an AD.

This conflates "Internet Drafts" with "IETF work" in a way I think is inappropriate. My previous attempts at making this distinction have garnered little interest, but I'll try again.

Counter-proposal: only draft-ietf-* are queued; all individual submission and IAB stream and IRTF stream documents are passed through.

Someone who uses individual submission to try to get a draft in front of a WG should be slapped down by the WG chair (or allowed through, if the chair agrees).

This focuses the problem exactly where it should be.

FWIW, Dave's suggestion is silly because so few people look at the WG page in the Datatracker that it would be indistinguishable from "no restriction".

--Paul Hoffman

---

From: Pete Resnick <[email-masked]>
Date: Fri, 19 Jul 2013 13:30:02 -0500

On 7/19/13 1:10 PM, Paul Hoffman wrote:
> Counter-proposal

These sound like fine "friendly amendments".

> only draft-ietf-* are queued; all individual submission and IAB stream and IRTF stream documents are passed through.
>    

Yeah, I thought about adding that. All draft-iab-* and draft-irtf-* are 
not queued (unless either of them wants a moratorium too). Added as "9".

> Someone who uses individual submission to try to get a draft in front of a WG should be slapped down by the WG chair (or allowed through, if the chair agrees).

Many WGs keep things as individual submissions during initial 
discussions, so I wanted to account for that. But I guess I don't 
understand if that modifies my proposal in any way. Do you mean to add 
to 4 "or chair"?

pr

---

From: Richard Barnes <[email-masked]>
Date: Fri, 19 Jul 2013 14:32:13 -0400

On Fri, Jul 19, 2013 at 2:30 PM, Pete Resnick <[email-masked]>wrote:

>  only draft-ietf-* are queued; all individual submission and IAB stream
>> and IRTF stream documents are passed through.
>>
>>
>

This constraint is unnecessarily broad as well.  For example: I just went
to publish a 4-line patch to a WG doc to fix some late WGLC comments, and
got hit by the embargo.  That document isn't up for discussion at the
meeting; there's no reason to embargo it.

Publication should not be a block.  Inclusion in the meeting should be, at
the discretion of the chairs.

--Richard

>
>
>  Someone who uses individual submission to try to get a draft in front of
>> a WG should be slapped down by the WG chair (or allowed through, if the
>> chair agrees).
>>
>>
>
> Many WGs keep things as individual submissions during initial discussions,
> so I wanted to account for that. But I guess I don't understand if that
> modifies my proposal in any way. Do you mean to add to 4 "or chair"?
>
>
> pr
>
> --
> Pete Resnick<http://www.qualcomm.**com/~presnick/<http://www.qualcomm.com/~presnick/>
> >

---

From: Paul Hoffman <[email-masked]>
Date: Fri, 19 Jul 2013 11:52:41 -0700

On Jul 19, 2013, at 11:30 AM, Pete Resnick <[email-masked]> wrote:

> Yeah, I thought about adding that. All draft-iab-* and draft-irtf-* are not queued (unless either of them wants a moratorium too). Added as "9".

I think it would be much cleaner to change 2 to say "all draft-ietf-* drafts are queued" and leave the rest of the rules alone. That is, narrow the scope of the queuing to just those things that always affect WGs.

> Many WGs keep things as individual submissions during initial discussions, so I wanted to account for that.

And in doing so you have made the protocol much more complicated. Leave dealing with this up to the chairs of the WGs affected, don't force it on all of us.

On Jul 19, 2013, at 11:32 AM, Richard Barnes <[email-masked]> wrote:

> This constraint is unnecessarily broad as well.  For example: I just went to publish a 4-line patch to a WG doc to fix some late WGLC comments, and got hit by the embargo.  That document isn't up for discussion at the meeting; there's no reason to embargo it.  

You are assuming that the chairs do not want to bring that patch to the WG.

It seems nearly harmless to tell chairs "during what used to be the silent period, you might get messages for drafts in your WG, and you can decide how to deal with them".

--Paul Hoffman

---

From: Ted Lemon <[email-masked]>
Date: Fri, 19 Jul 2013 19:23:04 +0000

> I just posted my draft and it's not showing up.  I want it released NOW.

Didn't I just hear you arguing in favor of chairs managing their working groups?

---

From: Spencer Dawkins <[email-masked]>
Date: Fri, 19 Jul 2013 14:24:53 -0500

> Counter-proposal: only draft-ietf-* are queued; all individual submission and IAB stream and IRTF stream documents are passed through.

I'll let my chairs comment on what works for their working groups, but 
as a semi-retired IAB-stream document editor, I would have loved to be 
able to submit and post draft-iab docs during the quiet period ...

I'm thinking that research group chairs are all on the Internet Research 
Steering Group <[email-masked]> mailing list, but most are not on this 
list (some research group chairs are also working group chairs, but not 
nearly all). It would be good to run a question about draft-irtf past them.

Spencer

---

From: "Black, David" <[email-masked]>
Date: Fri, 19 Jul 2013 16:05:18 -0400

> > only draft-ietf-* are queued; all individual submission and IAB stream and
> IRTF stream documents are passed through.
> >

I'd make one change, as I'm involved in WGs where a lot of individual drafts
targeted at the WG show up, and the advance deadline for posting those is
useful.

So, in addition to draft-ietf-* being queued, draft-*-<wgname>-*
also needs to be queued.  The latter sort of drafts should be releasable by
the chairs of <wgname>.

Then someone who end-runs that by not putting <wgname> in their individual
submission draft and trying to get the result on a WG agenda does truly
deserve to be slapped around.

Thanks,
--David

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Pete Resnick
> Sent: Friday, July 19, 2013 2:30 PM
> To: Paul Hoffman
> Cc: WG Chairs
> Subject: Re: Draft submission deadline/moratorium tool proposal
> 
> > only draft-ietf-* are queued; all individual submission and IAB stream and
> IRTF stream documents are passed through.
> >
> 
> > Someone who uses individual submission to try to get a draft in front of a
> WG should be slapped down by the WG chair (or allowed through, if the chair
> agrees).
> >
>

---

From: Salvatore Loreto <[email-masked]>
Date: Fri, 19 Jul 2013 22:11:57 +0200

it seems a reasonable proposal,
that could speed up the progress and help the discussion during the 
meeting of some important/critical draft

I would suggest that for the point #4, also the chairs should be in 
charge to approve individual submission!

/Salvatore

On 7/19/13 7:11 PM, Pete Resnick wrote:
> suggested something like this before. If the chairs generally think 
> this is a good idea, then maybe we take it to the IETF list. (I have 
> not passed this by other ADs; they can pipe up as they see fit.)
>
> 2. For X weeks before an IETF plenary meeting and during the week of 
> the meeting, all submitted drafts are queued but not posted. The draft 
> 3. Queued WG drafts can be approved for posting by an AD or the 
> chair(s) of that WG.
>
> 5. At the completion of the IETF meeting, all queued drafts are 
> released from the queue.
>
> 6b. Drafts that are in IESG-Evaluation are always queued, regardless 
> of moratorium. An AD must release them.
>
> 8. Chairs can put a moratorium on a particular WG (for instance, 
> before an interim meeting).
>
> Thoughts?
>
> pr
>

-- 
Salvatore Loreto, PhD
www.sloreto.com

---

From: Michael Richardson <[email-masked]>
Date: Fri, 19 Jul 2013 16:23:44 -0400

I like your proposal, with the addition of the draft-ietf-*
and draft-FOO-WG-* reduction, however....

A concern I have is about implementation constraints.

I'd like the chairs, and I think anyone logged in, in particular, any of the
authors, to be able to use the ID diff tool.  I'm pretty sure that it can
only diff drafts which are "posted".

I would propose a modification to the policy based upon where the cork can
easily be placed: drafts are posted into the  datatracker, and can be found
through the datatracker.  The rsync/FTP/HTTP/mirror server is, however, corked.
(Yes, announcements would be suppressed, so you have to know to look at it)

This also likely gets around most complaints about WGLC edits and Auth48
edits to document in progress.

--
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        | network architect  [
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

--
Michael Richardson <[email-masked]>, Sandelman Software Works

---

From: Yoav Nir <[email-masked]>
Date: Fri, 19 Jul 2013 20:31:59 +0000

> deserve to be slapped around.

The convention of calling drafts that are intended for a working group draft-someone-foowg-foo-mib-00 is quite common by now, but it's not documented in the guidelines (http://www.ietf.org/ietf/1id-guidelines.txt). Not everyone knows about it.

The only reference to it is in the Tao:

    If a draft is an individual submission but relates to a particular Working Group, authors sometimes follow their name with the name of the Working Group, such as "draft-smith-smime-keying-00.txt".

Note the word sometimes. I don't think newbies take away from this that they have to name their documents thus to get the chairs to consider them. I know I didn't follow this convention for the first drafts that I posted.

Yoav

---

From: Peter Koch <[email-masked]>
Date: Fri, 19 Jul 2013 22:47:02 +0200

> allowed to submit drafts to the tool. However, they are not always posted.

what problem are we trying to solve and why does it help to accept and
withhold the draft instead of either rejecting it or posting it right away?
What prevents people more or less than today from sending the draft
to the wg list instead?  How many drafts can be staggered in the queue?

> 3. Queued WG drafts can be approved for posting by an AD or the chair(s) 

Sure chairs can manage and 'just say no', but on the other hand we're all
encouraged to be pragmatic, flexible, and inclusive. Isn't it great that
we usually have two co-chairs so we can play the 'good cop - bad cop' game?

We don't need more process, we need more quality review.  Give people
credit for those and in return they can post drafts whenever they want.

-Peter

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Sat, 20 Jul 2013 00:25:22 +0000

Much of this works for me.

However it puts a lot of responsibility on the chairs protecting the interests of the WG members.

For example we seem to have some chairs who seem very interested in getting the latest version before the meeting, such that documents get updated when the draft submission reopens on Monday, and then on Tuesday or Wednesday these chairs expect us to work with the new version in the meeting.

How would I as a member of the WG stop that happening, without having to waste 10 minutes of WG time at the start of the WG meeting having discovered that the agenda was updated while my back was turned.

Keith

> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Pete Resnick
> Sent: 19 July 2013 18:12
> To: WG Chairs
> Subject: Draft submission deadline/moratorium tool proposal
>

---

From: Ted Lemon <[email-masked]>
Date: Sat, 20 Jul 2013 00:34:11 +0000

> How would I as a member of the WG stop that happening, without having to waste 10 minutes of WG time at the start of the WG meeting having discovered that the agenda was updated while my back was t…

I am highly sympathetic to this concern.   However, I do wonder: would you rather the update _didn't_ happen?   Would you rather discuss the previous version of the document?   I think this is something that chairs and authors should avoid, and I would certainly not be happy if one of the working groups for which I am responsible AD did this.   However, in practice if the changes are small, rfcdiff is actually a very quick way to familiarize yourself with changes, if you are already familiar with the draft.

So much as I want to agree with you that this sort of behavior is inappropriate, I am hard pressed to do so.   A better way to characterize it is "poorly timed."   If the working group chairs want the draft to be discussed at the meeting, they should make damned sure that the working group is made aware of the update, and the working group is well within its rights to say "look, we haven't had time to review this, let's drop it from the agenda until the next meeting."

And the way you effect that is to get up at the mic during agenda bashing and say so.

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Sat, 20 Jul 2013 01:54:47 +0000

I think there would be some value in this; I personally would rather make the tool manage a queue than make people do it. Unfortunately, it introduces inconsistency and workload; I suspect that a likely change will be that people will now ignore the deadline and assume they can get their working group chair to approve a draft as "special". That, of course, means that I am likely to start receiving a series of requests for special treatment during the days following the start of queuing, and different chairs will take more or less hard-line positions. Note that *that* already happens as well; my tools look for the text "-v6ops-" in the draft moniker, and I get requests to schedule drafts that are not in fact labelled as submissions to v6ops.

In v6ops, we have another factor; I really try to only put on the agenda things that have seen positive mailing list discussion, which is a rule I would potentially have to modify, as I can't test the temperature without breaking the draft free from the moratorium queue. 

For my working group, I think this would come down to "if you post after the deadline, your draft will pop out after the IETF meeting". And by the way, I do mean "the Monday after"; if it pops out the Monday of the meeting, which it does now, we already have people trying to game that system, and the one time I allowed it, it created some confusion.

An additional point; when I'm thinking about my agenda, one of my rules is that any draft we might discuss must have been posted since the past meeting. Determination of that is straightforward today; the last draft posted for this meeting actually posted a few minutes after midnight UTC, which is to say "on July 16", or was one of three drafts that somehow slipped through on the 17th or 18th (perhaps posted manually after being mailed in); I can simply ask whether the draft was posted after July 27. If drafts are queued such as you suggest, I would humbly hope that their posting date (the date that shows up in the draft and in the ls -l line in my mirror as a result of rsync) would be considered the date on which they came out of the queue, not the date they went in. I think I just called for some text modification in the holding queue, or for the draft queue to hold the .xml and recreate the .txt file when posting.

For this meeting, I posted a draft agenda on 8 July indicating that there were a number of drafts I expected updates on, and that there was some probability of another -00 draft snaking through. Then the -00 deadline was extended. I have two later -00 drafts, one that came in on the 10th and one on the 15th. Neither of those got much list commentary due to timing, and I felt that I had to step away from the objective rule to a more subjective one in deciding what to include; the problems addressed were both real and timely, so I included them. My rule is there because of a DDOS that occurred a few years ago; for the Beijing meeting, I had 42 drafts to ask the question about, of which I actually scheduled half and should have scheduled 1/3.

So, all things considered, I think I would rather hold the -00 and -later deadlines firm, having drafts that arrive after the deadline queued to pop out (and at least in the directory dated on) the Monday after the IETF meeting. You do what you need to do with IESG processing; in my working group, if the IETF can't hold a deadline, I may find it necessary to impose my own for order's sake.

On Jul 19, 2013, at 6:11 PM, Pete Resnick <[email-masked]> wrote:

> Given the talk over the last week, I'd like to make a proposal. I have suggested something like this before. If the chairs generally think this is a good idea, then maybe we take it to the IETF list. (I have not passed this by other ADs; they can pipe up as they see fit.)
> 
> 1. The draft submission tool never shuts down. Everyone is *always* allowed to submit drafts to the tool. However, they are not always posted.
> 
> 2. For X weeks before an IETF plenary meeting and during the week of the meeting, all submitted drafts are queued but not posted. The draft deadline is announced as X weeks. (I personally don't care what X is; suggestions welcome.)
> 
> 3. Queued WG drafts can be approved for posting by an AD or the chair(s) of that WG.
> 
> 5. At the completion of the IETF meeting, all queued drafts are released from the queue.
> 
> 6b. Drafts that are in IESG-Evaluation are always queued, regardless of moratorium. An AD must release them.
> 
> 7. Chairs can pre-approve draft posting during the moratorium, just as they do for -00 drafts.
> 
> 8. Chairs can put a moratorium on a particular WG (for instance, before an interim meeting).
> 
> Thoughts?
> 
> pr
> 
> --

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Sat, 20 Jul 2013 05:33:31 +0000

> Note the word sometimes. I don't think newbies take away from this that they have to name their documents thus to get the chairs to consider them. I know I didn't follow this convention for the fir…

In fairness, they don't *have* to. What they *do* have to do is bring them to the chair's attention. In my case, and in the case of tools like https://datatracker.ietf.org/doc/search/?name=v6ops&rfcs=on&activeDrafts=on&search_submit=, putting the working group name into the draft name pretty quickly gets the chair's attention. In my case, I even have some tooling behind that. I have a daily bot that updates a mirror and some files internal to Cisco. My bot notices a new -00 draft to v6ops, sends a note to the authors wondering what it's about and how it relates to the charter with a reply-to of the chairs, and it sends a note to the working group inviting discussion. We often get some pretty quick early discussion as a result, and that discussion often figures into whether the draft is discussed f2f. When they don't put the working group moniker in there, they have to do that themselves.

But I do agree that it would be useful to *say* that in the guidelines.

---

From: Leif Johansson <[email-masked]>
Date: Sat, 20 Jul 2013 10:16:32 +0200

On 07/19/2013 07:27 PM, Pete Resnick wrote:
> ADs already get email to approve posting after the deadline. This
> might increase the number of requests to do so.
>
I don't think it will be that bad either but I'm not sure what problem
is being solved really - what happens today is that late submissions
are "pre-released" directly to the mailing list for discussion.
> simpler "No deadline at all" proposal got. And I'd prefer to discuss
> the merits of this proposal on its own and see if it can get some
> consensus before discussing alternatives.
>
> pr
>

---

From: "MORTON JR., ALFRED C (AL)" <[email-masked]>
Date: Sat, 20 Jul 2013 11:03:11 -0400

I think Peter K's point on review is particularly relevant
in my experience:
...
> On Fri, Jul 19, 2013 at 12:11:55PM -0500, Pete Resnick wrote:
...
> credit for those and in return they can post drafts whenever they want.

Working until the deadline and submitting a draft then reduces
the probability of a quality review, just on the basis of volume.  
I continue to encourage authors to work toward interim releases
that folks can review when they have time - it also leaves more time to foster a
review "barter system". But I can live with a lot of Pete R's proposals
as they may help to move the work forward in some WGs, recognizing
that we all work a little differently.

just 2 cents more,
Al

---

From: Dave Crocker <[email-masked]>
Date: Sat, 20 Jul 2013 16:08:30 +0100

> However it puts a lot of responsibility on the chairs protecting the interests of the WG members.

It requires chairs to do the basics of managing their working group.

The task of deciding what documents (and what versions of those 
documents) will be reviewed at the meeting and what the submission 
deadline needs to be for the docs is not unusual or onerous, within the 
scope of managing a collaborative group.

If the chair or the wg have a problem doing that, the working group has 
bigger problems than just the meeting a submission deadline.

If, for example, the chair fails to do the scheduling or fails to do it 
collaboratively enough with the wg, then the wg needs to fix the chair 
or replace them.

d/

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Sun, 21 Jul 2013 16:58:24 +0000

I would rather the update happened with time for chairs and WG membership to absorb the changes.

Looks to me like any proposal such as this should be accompanied with some guidance to the chairs.

My view is leaning heavily towards updates after the deadline should not need to happen - either the changes are so minor that they can be explained in the presentation and the revision provided later, or they are so major that noone would have a change to absorb them no matter how much presentation time was allowed.

And in the way this is presented, the default behaviour for the chairs should be to ignore impacted submissions unless a really good case is presented for releasing them.

I certainly am in favour of the moratorium not applying at all to documents; i.e. those that are not on the agenda for the meeting should not need to be held. Conversely, I would like in some ways to establish a selective moratorium for interim meetings.

And finally, I begin to think I liked the 3 week moratorium for new documents. This at least forced the submitter to identify what a potential document would be about (and therefore gave more time to discuss whether it might need an agenda slot) - I worry less about such a document going from -00 to -01 in a few days (i.e. between 3 weeks and 2 weeks) because the submitter added content later.

Keith

> From: Ted Lemon [mailto:[email-masked]]
> Sent: 20 July 2013 01:34
> To: DRAGE, Keith (Keith)
> Cc: Pete Resnick; WG Chairs
> > How would I as a member of the WG stop that happening, without having to
> waste 10 minutes of WG time at the start of the WG meeting having
> discovered that the agenda was updated while my back was turned.
> 
> I am highly sympathetic to this concern.   However, I do wonder: would you
> rather the update _didn't_ happen?   Would you rather discuss the previous
> version of the document?   I think this is something that chairs and
> authors should avoid, and I would certainly not be happy if one of the
> working groups for which I am responsible AD did this.   However, in
> practice if the changes are small, rfcdiff is actually a very quick way to
> familiarize yourself with changes, if you are already familiar with the
> draft.
> 
> So much as I want to agree with you that this sort of behavior is
> inappropriate, I am hard pressed to do so.   A better way to characterize
> it is "poorly timed."   If the working group chairs want the draft to be
> discussed at the meeting, they should make damned sure that the working
> group is made aware of the update, and the working group is well within
> its rights to say "look, we haven't had time to review this, let's drop it
> from the agenda until the next meeting."
>

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Sun, 21 Jul 2013 17:01:35 +0000

You seem to be assuming that WG chairs have lots of spare time in order to do this.

At least in the RAI area, we are short of chairs, and many of the existing ones have many other commitments. 

Any tools that handle things automatically save the WG chair devoting cycles.

The -00 and -xx deadlines at least made sure (in a very heavy handed manner) that all documents to be considered for the meeting where much more easily identified, without constant prompting from the chairs.

Regards

Keith

> From: Dave Crocker [mailto:[email-masked]]
> Sent: 20 July 2013 16:09
> To: DRAGE, Keith (Keith)

---

From: "Reinaldo Penno (repenno)" <[email-masked]>
Date: Sun, 21 Jul 2013 17:55:01 +0000

One of the problems I faced multiple times while attending IETF remotely
is last minute changes. Presentation and draft not in synch with each
other, discussion on topics that were added to the draft at the last
revision during IETF, presentations uploaded or changed 10 seconds before
it starts, etc.. 

I think some deadline is useful to promote a smoother virtual attendance
and give people time to familiarize with the material.

On 7/21/13 1:58 PM, "DRAGE, Keith (Keith)"
<[email-masked]> wrote:

>My view is leaning heavily towards updates after the deadline should not
>need to happen - either the changes are so minor that they can be
>explained in the presentation and the revision provided later, or they
>are so major that noone would have a change to absorb them no matter how
>much presentation time was allowed.
>
>And in the way this is presented, the default behaviour for the chairs
>should be to ignore impacted submissions unless a really good case is
>presented for releasing them.
>
>I certainly am in favour of the moratorium not applying at all to
>documents; i.e. those that are not on the agenda for the meeting should
>not need to be held. Conversely, I would like in some ways to establish a
>selective moratorium for interim meetings.
>
>And finally, I begin to think I liked the 3 week moratorium for new
>documents. This at least forced the submitter to identify what a
>potential document would be about (and therefore gave more time to
>discuss whether it might need an agenda slot) - I worry less about such a
>document going from -00 to -01 in a few days (i.e. between 3 weeks and 2
>weeks) because the submitter added content later.
>
>Keith
>
>> On Jul 19, 2013, at 7:25 PM, "DRAGE, Keith (Keith)"
>><keith.drage@alcatel-
>> lucent.com> wrote:
>> And the way you effect that is to get up at the mic during agenda
>>bashing
>> and say so.
>

---

From: Dave Crocker <[email-masked]>
Date: Mon, 22 Jul 2013 07:26:16 +0100

> You seem to be assuming that WG chairs have lots of spare time in

No.  I'm assuming that it is reasonable to expect chairs to manage their
groups and that the tasks of management have some substance.

> At least in the RAI area, we are short of chairs, and many of the
> existing ones have many other commitments.

The ability to recruit a reasonable array of participants -- including 
those who will do working group management, document writing, 
shepherding, etc, is a de facto filter on whether the work has enough 
community interest to justify pursuit in the IETF.

So you are citing a problem that is far more basic, and far more 
serious, than the current issue.

> The -00 and -xx deadlines at least made sure (in a very heavy handed
> manner) that all documents to be considered for the meeting where
> much more easily identified, without constant prompting from the
> chairs.

A working group that has so many documents active at one time that it is 
difficult to keep track of them probably has deeper management problems 
than we are talking about here.

In any event, the idea that a Procrustean rule is justified because it 
makes the life of a wg chair easier -- rather than because it's needed 
and appropriate in its own right -- ought to bother us,

d/

---

From: "Howard, Lee" <[email-masked]>
Date: Mon, 22 Jul 2013 07:57:55 -0400

>community interest to justify pursuit in the IETF.

Two separate points here:
1) We only want volunteer managers (WG chairs, ADs, etc.) who aren't busy.
2) We only support work undertaken by people who aren't busy.
I agree that this is currently the intake filter.  I believe this to be a
flaw.
"Busy" can include fixing outages, preparing budgets by deadline, being on
summer vacation, or anything else that is time-sensitive in the weeks
before an IETF meeting.  I think we need to find ways to make the IETF
accessible to busy people, and that busy people can be the best
contributors--including management roles, if we can find ways to
accommodate them.

>than we are talking about here.

"Active" can mean a great many things; I don't think WG agendas are, or
should be, limited to documents already adopted by the WG.  The fact that
many people have something to say on a topic is a sign of health, and
potentially a sign of a need to recharter.  The participants in the WG
need to review the documents and decide by consensus on whether WG
time--that is, mailing list threads and meeting discussion time--should be
spent working on each one.

>and appropriate in its own right -- ought to bother us,

Agreed--we should adopt rules that keep barriers to participation low;
that is, make it easy for knowledgeable people to participate.  For me,
that means agendas need to be posted well enough in advance that
participants have time to read the drafts (for all of the WGs in which
they participate), and drafts need to be posted well enough in advance
that chairs know which ones to include in the agenda (preferably, based on
list discussion).

Lee

This E-mail and any of its attachments may contain Time Warner Cable proprietary information, which is privileged, confidential, or subject to copyright belonging to Time Warner Cable. This E-mail is intended solely for the use of the individual or entity to which it is addressed. If you are not the intended recipient of this E-mail, you are hereby notified that any dissemination, distribution, copying, or action taken in relation to the contents of and attachments to this E-mail is strictly prohibited and may be unlawful. If you have received this E-mail in error, please notify the sender immediately and permanently delete the original and any copy of this E-mail and any printout.

---

From: Olafur Gudmundsson <[email-masked]>
Date: Mon, 22 Jul 2013 10:58:55 -0400

Pete, 
Sorry for the top post, I read all the replies and thought about my experiences as WG chair. 

Having a publication deadline is a good thing, thus I do not support in general to get rid of that 
there are few exceptions to this general rule, on the other hand I support the hold feature of submitted drafts 
in the week before the meeting and that all of them are released at the beginning of the meeting with one exception. 
	Documents that are in IESG review should be updatable at any time if AD and/or Chair approves, this is
	critical around the spring meeting when WG are fighting the deadline of AD leaving the IESG and avoiding having
	the "new" IESG reviewing the document(s) again. 

In short my proposal is document cutoff 2 weeks before meeting, documents can be submitted after that but held until 03:00 on 
Monday/Tuesday meeting local time. 

The only exception is that documents in following states can be posted if AD and/or Chair approves: 
	IESG Evaluation 
	AD Followup
	Point Raised 

	Olafur