Subject: Adding WG Secretaries to the <wg>[email-masked] aliases?

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 11 Sep 2013 09:12:37 +0200

Hi,

I've had a request to add one WG's Secretary to the <wg>[email-masked]
alias.  As these aliases are auto-generated from datatracker data, it would be
a much nicer change to generally include WG secretaries in the -chairs alias,
than to do a special code path for one individual WG.

So the question is, what do people think of including the WG secretaries (for
WGs that have secretaries) in the -chairs alias?  Is this something that would
generally be desirable, or quite the opposite?

Best regards,

	Henrik

---

From: Martin Vigoureux <[email-masked]>
Date: Wed, 11 Sep 2013 09:25:11 +0200

Henrik,

a long time ago, for some reason I have forgotten, I had been added to 
the [email-masked] alias. Sometime after I was removed from it.

Being added has some value, especially if the Secretary works closely 
with the chairs. However, the name of the alias is such that a sender 
might believe he/she is only sending an e-mail to the chairs and for 
certain reasons he/she might effectively want to send an e-mail only to 
the chairs. Similarly, the chairs might want to use the alias for 
communicating between them to discuss elements which are of no 
importance to the Secretary.

So, in short, I do not think adding the Secretaries to 
<wg>[email-masked] is such a good idea.
Defining a new alias which includes the Secretary and which gives a 
clearer indication of who are the recipients would potentially meet the 
expectations.

Best regards,
Martin

---

From: "Gunter Van de Velde (gvandeve)" <[email-masked]>
Date: Wed, 11 Sep 2013 07:26:16 +0000

I am not sure what the ultimate goal would be and what benefit it offers?
Is it in that case not just more fair to make that secretary a WG chair? When he/she is doing Chair work then imho there should be credit for the work by a formal assignment. 

I am quite neutral on this, but I do wiggle with my eyebrows trying to understand the goal.

G/

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Henrik Levkowetz
Sent: 11 September 2013 09:13
To: WG Chairs
Subject: Adding WG Secretaries to the <wg>[email-masked] aliases?

Hi,

I've had a request to add one WG's Secretary to the <wg>[email-masked] alias.  As these aliases are auto-generated from datatracker data, it would be a much nicer change to generally include WG secretaries in the -chairs alias, than to do a special code path for one individual WG.

So the question is, what do people think of including the WG secretaries (for WGs that have secretaries) in the -chairs alias?  Is this something that would generally be desirable, or quite the opposite?

Best regards,

	Henrik

---

From: Loa Andersson <[email-masked]>
Date: Wed, 11 Sep 2013 10:37:07 +0200

Henrik,

I think this is a good idea. While secretaries are not doing "doing
Chair work" generally, they are a staff function. It is not uncommon
in any organization to keep staff "in the loop so they can keep track
of what is going on and prepare agendas for meetings.

However - there is one thing that I'm concerned about. When you send a
mail to an alias that says "<wg>-chairs" you should be sure who
actually receives the mail.

I'd say we should do this, but we also need to make it known in the
IETF that this is the case.

/Loa

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Huawei Technologies (consultant)     phone: +46 739 81 21 64

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 11 Sep 2013 10:46:03 +0200

On Wed, Sep 11, 2013 at 09:25:11AM +0200, Martin Vigoureux wrote:
 
> clearer indication of who are the recipients would potentially meet
> the expectations.

+1

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Loa Andersson <[email-masked]>
Date: Wed, 11 Sep 2013 10:50:16 +0200

wfm

/Loa

--

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 11 Sep 2013 11:41:09 +0200

Hi Gunter,

> I am not sure what the ultimate goal would be and what benefit it

The idea is as follows:  Draft authors, the iesg, the rfc-editor, iana, and
others often communicate with the chairs using the <wg>[email-masked]
alias.  Since the function of a WG secretary is in part to offload the WG
chairs by taking care of administrative chores, these communications will
often be relevant to his/her work, and relieving the WG chairs from the task
of again and again forwarding such emails could be helpful.

> Is it in that case not just more fair to make that secretary a WG
> chair?

No, the idea is not to make the secretary responsible for leading the WG work,
just to relieve the chairs of the need to act as email forwarders.

> When he/she is doing Chair work then imho there should be
> credit for the work by a formal assignment.

If that was the case, then of course what you say is right.  However, that's
not the idea here.

> I am quite neutral on this, but I do wiggle with my eyebrows trying

Understood.  I hope the comments above are helpful.

Best regards,

	Henrik

---

From: "Andrew G. Malis" <[email-masked]>
Date: Wed, 11 Sep 2013 06:05:14 -0400

Henrik et al,

Even if we eventually decide to not add WG secretaries to <wg>-
[email-masked], I think it would be very advantageous to add them to
the [email-masked] list, so that they can stay in the loop and
contribute to such topics as datatracker and tools improvements (since many
of them are as heavy users of these systems as the WG chairs). I also think
that WG secretaries should be invited to the WG Chairs training lunch on
Wednesdays of IETF week.

BTW, I'm also in favor of adding WG secretaries to <wg>-
[email-masked], and just advertising that to IETF participants so
they are aware of it.

Thanks,
Andy

On Wed, Sep 11, 2013 at 5:41 AM, Henrik Levkowetz <[email-masked]>wrote:

> > I've had a request to add one WG's Secretary to the <wg>-
> [email-masked] alias.  As these aliases are auto-generated from
> datatracker data, it would be a much nicer change to generally include WG
> secretaries in the -chairs alias, than to do a special code path for one
> individual WG.
> >
> > So the question is, what do people think of including the WG secretaries
> (for WGs that have secretaries) in the -chairs alias?  Is this something
> that would generally be desirable, or quite the opposite?
> >
> >
> >
> > Best regards,
> >
> >       Henrik
> >
>

---

From: Loa Andersson <[email-masked]>
Date: Wed, 11 Sep 2013 13:25:03 +0200

Andy,

Oddly enough I'm less in favor of adding the secretaries to the
wgchairs than I'm to adding them to <wg>[email-masked].

So far it is mostly a feeling, but I guess this is because to what
I think the lists are for

- wgchairs is for discussions among the the wg chairs, as Henrik
   put it - among folks that are appointed to lead working in working
   groups
- <wg>-chairs are for communication to and between folks that need to
   know what happens in the administration of the working group, e.g.
   I think that the mpls-chairs routinely copies and our secretary
   on any such mails. Normally I wouldn't copy our secretary on mails
   wgchairs.

/Loa

On 2013-09-11 12:05, Andrew G. Malis wrote:
> Henrik et al,
>
> Even if we eventually decide to not add WG secretaries to
> <wg>[email-masked] <mailto:[email-masked]>, I think it
> would be very advantageous to add them to the [email-masked]
> <mailto:[email-masked]> list, so that they can stay in the loop and
> contribute to such topics as datatracker and tools improvements (since
> many of them are as heavy users of these systems as the WG chairs). I
> also think that WG secretaries should be invited to the WG Chairs
> training lunch on Wednesdays of IETF week.
>
> BTW, I'm also in favor of adding WG secretaries to
> <wg>[email-masked] <mailto:[email-masked]>, and just
> advertising that to IETF participants so they are aware of it.
>
> Thanks,
> Andy
>
>
>
>
> On Wed, Sep 11, 2013 at 5:41 AM, Henrik Levkowetz <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>     Hi Gunter,
>
>     others often communicate with the chairs using the
>     <wg>[email-masked] <mailto:[email-masked]>
>      > From: [email-masked]
>     <mailto:[email-masked]> [mailto:[email-masked]
>     <mailto:[email-masked]>] On Behalf Of Henrik Levkowetz
>      > Subject: Adding WG Secretaries to the <wg>[email-masked]
>     <mailto:[email-masked]> aliases?
>      >
>      > Hi,
>      >
>      > I've had a request to add one WG's Secretary to the
>     <wg>[email-masked] <mailto:[email-masked]> alias.  As
>     these aliases are auto-generated from datatracker data, it would be
>     a much nicer change to generally include WG secretaries in the
>     -chairs alias, than to do a special code path for one individual WG.
>      >
>      > So the question is, what do people think of including the WG
>     secretaries (for WGs that have secretaries) in the -chairs alias?
>       Is this something that would generally be desirable, or quite the
>     opposite?
>      >
>      >
>      >
>      > Best regards,
>      >
>      >       Henrik
>      >
>
>

--

---

From: Mark Townsley <[email-masked]>
Date: Wed, 11 Sep 2013 13:26:04 +0200

+2, one for each point Andy makes here.

But first, and this is important, we should ask the secretaries, rather than making the decision here without them in the room. There may be some secretaries that respond with "sorry, I didn't sign up for even implied WG chair responsibility or SPAM. I'm here just to help with the minutes and blue sheets, no more." - if these are few and far between, I'm sure Henrik can find a way to opt them out of the script that includes them (e.g., a non-machine-parseable email representation on the website for starters). If I know Henrik, he'll respond to this by creating a wg-secretaries alias just so we can send email to it in order to generate the discussion with them before collapsing everyone back into wgchairs. 

- Mark (the former AD that asked Henrik to build all these -chairs, -ads, etc. aliases in the first place as I got darn sick of looking it up all the time.... Thanks Henrik!)

On Sep 11, 2013, at 12:05 PM, Andrew G. Malis wrote:

> Henrik et al,
> 
> Even if we eventually decide to not add WG secretaries to <wg>[email-masked], I think it would be very advantageous to add them to the [email-masked] list, so that they can stay in the loop and contribute to such topics as datatracker and tools improvements (since many of them are as heavy users of these systems as the WG chairs). I also think that WG secretaries should be invited to the WG Chairs training lunch on Wednesdays of IETF week.
> 
> BTW, I'm also in favor of adding WG secretaries to <wg>[email-masked], and just advertising that to IETF participants so they are aware of it.
> 
> Thanks,
> Andy
> 
> 
> 
> 
> On Wed, Sep 11, 2013 at 5:41 AM, Henrik Levkowetz <[email-masked]> wrote:
> Hi Gunter,
>

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Wed, 11 Sep 2013 08:01:55 -0400

To me, the problem is partly the actual alias <wg>[email-masked]
Even if we explain this includes secretaries, there will be mistakes.

If I wanted to contact chairs and secretaries, I'd look for
another alias, something like <wg>-management@...

chairs is chairs, simple,
Al

From: [email-masked] [mailto:[email-masked]] On Behalf Of Mark Townsley
Sent: Wednesday, September 11, 2013 7:26 AM
To: Andrew G. Malis
Cc: WG Chairs; Henrik Levkowetz
Subject: Re: Adding WG Secretaries to the <wg>[email-masked] aliases?

Henrik et al,
Even if we eventually decide to not add WG secretaries to <wg>[email-masked]<mailto:[email-masked]>, I think it would be very advantageous to add them to the [email-masked]<mailto:[email-masked]> list, so that they can stay in the loop and contribute to such topics as datatracker and tools improvements (since many of them are as heavy users of these systems as the WG chairs). I also think that WG secretaries should be invited to the WG Chairs training lunch on Wednesdays of IETF week.
BTW, I'm also in favor of adding WG secretaries to <wg>[email-masked]<mailto:[email-masked]>, and just advertising that to IETF participants so they are aware of it.

Thanks,
Andy

On Wed, Sep 11, 2013 at 5:41 AM, Henrik Levkowetz <[email-masked]<mailto:[email-masked]>> wrote:
Hi Gunter,

others often communicate with the chairs using the <wg>[email-masked]<mailto:[email-masked]>

Best regards,

        Henrik

> From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Henrik Levkowetz
> Subject: Adding WG Secretaries to the <wg>[email-masked]<mailto:[email-masked]> aliases?
>
> Hi,
>
> I've had a request to add one WG's Secretary to the <wg>[email-masked]<mailto:[email-masked]> alias.  As these aliases are auto-generated from datatracker data, it would be a much nicer change to generally include WG secretaries in the -chairs alias, than to do a special code path for one individual WG.
>

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 11 Sep 2013 14:31:31 +0200

Hi Al,

> another alias, something like <wg>-management@...

True, but the intended use of this is the other way around: even if people
don't explicitly think of including WG secretaries, see to it that they
receive a copy of the messages anyway.  The question is if chairs who have
secretaries for their WGs would like to have it set up this way.

Best regards,

	Henrik

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Wed, 11 Sep 2013 14:38:13 +0000

I support both the original proposal of adding WG Secretaries to the <wg-shortname>[email-masked]<mailto:[email-masked]>, as well as Andy's additional proposal to add Secretaries to the [email-masked]<mailto:[email-masked]> alias.

When I was a Secretary for a WG, it was both relevant for the job as well as instructional to see and participate in the discussions on this list. It gave me a view that was very educational. Having being a secretary maybe I am paying particular attention, but I recall the second proposal being discussed at least twice on this list. In fact, I thought secretaries are already on this list (which matches the description at http://www.ietf.org/list/nonwg.html).

"The wgchairs mailing list is for discussion by WG Chairs, Secretaries, the IESG, the IAB and BOF Chairs on any IETF related topic."

Context on doc discussions and automated notifications that happen at the <wg-shortname>[email-masked]<mailto:[email-masked]> are absolutely relevant to the secretary role, a gap if those are missed, and misplaced expectations to have chairs forward or Cc every email manually. Notifying the community about it should suffice.

Thanks,

Thumb typed by Carlos Pignataro.
Excuze typofraphicak errows

On Sep 11, 2013, at 8:31 AM, "Henrik Levkowetz" <[email-masked]<mailto:[email-masked]>> wrote:

Hi Al,

On 2013-09-11 14:01 MORTON, ALFRED C (AL) said:
To me, the problem is partly the actual alias <wg>[email-masked]<mailto:[email-masked]>
Even if we explain this includes secretaries, there will be mistakes.

Best regards,

 Henrik

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Mark Townsley
Sent: Wednesday, September 11, 2013 7:26 AM
To: Andrew G. Malis
Cc: WG Chairs; Henrik Levkowetz
Subject: Re: Adding WG Secretaries to the <wg>[email-masked]<mailto:[email-masked]> aliases?

Henrik et al,
Even if we eventually decide to not add WG secretaries to <wg>[email-masked]<mailto:[email-masked]><mailto:[email-masked]>, I think it would be very advantageous to add them to the [email-masked]<mailto:[email-masked]><mailto:[email-masked]> list, so that they can stay in the loop and contribute to such topics as datatracker and tools improvements (since many of them are as heavy users of these systems as the WG chairs). I also think that WG secretaries should be invited to the WG Chairs training lunch on Wednesdays of IETF week.
BTW, I'm also in favor of adding WG secretaries to <wg>[email-masked]<mailto:[email-masked]><mailto:[email-masked]>, and just advertising that to IETF participants so they are aware of it.

Thanks,
Andy

On Wed, Sep 11, 2013 at 5:41 AM, Henrik Levkowetz <[email-masked]<mailto:[email-masked]><mailto:[email-masked]>> wrote:
Hi Gunter,

On 2013-09-11 09:26 Gunter Van de Velde (gvandeve) said:
I am not sure what the ultimate goal would be and what benefit it
offers?
The idea is as follows:  Draft authors, the iesg, the rfc-editor, iana, and
others often communicate with the chairs using the <wg>[email-masked]<mailto:[email-masked]><mailto:[email-masked]>
alias.  Since the function of a WG secretary is in part to offload the WG
chairs by taking care of administrative chores, these communications will
often be relevant to his/her work, and relieving the WG chairs from the task
of again and again forwarding such emails could be helpful.

I am quite neutral on this, but I do wiggle with my eyebrows trying
to understand the goal.
Understood.  I hope the comments above are helpful.

Best regards,

     Henrik

G/

-----Original Message-----
From: [email-masked]<mailto:[email-masked]><mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Henrik Levkowetz
Sent: 11 September 2013 09:13
To: WG Chairs
Subject: Adding WG Secretaries to the <wg>[email-masked]<mailto:[email-masked]><mailto:[email-masked]> aliases?

Hi,

I've had a request to add one WG's Secretary to the <wg>[email-masked]<mailto:[email-masked]><mailto:[email-masked]> alias.  As these aliases are auto-generated from datatracker data, it would be a much nicer change to generally include WG secretaries in the -chairs alias, than to do a special code path for one individual WG.

Best regards,

   Henrik

---

From: Robert Sparks <[email-masked]>
Date: Wed, 11 Sep 2013 09:42:22 -0500

My 2 cents:

I don't think secretaries should be added to the -chair alias.
That alias sometimes gets used for the people management side of the 
chair role - people approaching chairs with situations they are very 
upset about.
They would be surprised by having more than the chairs copied, and the 
secretaries would be pulled through things they don't need to be.
I much prefer the separate -secretary alias, and making sure the 
secretaries are in -all.

RjS

---

From: Samuel Weiler <[email-masked]>
Date: Wed, 11 Sep 2013 10:44:35 -0400 (EDT)

>  put it - among folks that are appointed to lead working in working

This cat is already out of the bag (or so it seems).

When I was appointed as a WG secretary, I was automatically added to this 
list.

Besides, the wgchairs archives are public, so I'm not sure I see the point 
of limiting subscriptions.

-- Sam

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Wed, 11 Sep 2013 10:48:14 -0400

Yes Robert, that's one of my concerns too, though understated below.
Al
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Robert Sparks
...
> >> chairs is chairs, simple,
...

---

From: Samuel Weiler <[email-masked]>
Date: Wed, 11 Sep 2013 10:54:42 -0400 (EDT)

On Wed, 11 Sep 2013, Mark Townsley wrote:

> But first, and this is important, we should ask the secretaries, rather 
> than making the decision here without them in the room.

In the case of SIDR, with only a couple of months experience, the chairs 
and I have reached the tentative conclusion that I need to see enough of 
the things sent to -chairs that it's better to have me see all of them 
than have the chairs miss forwarding useful bits -- on our phone calls the 
question "did you see the note from X" keeps coming up, with the answer so 
often being "no".

So we have asked for this feature, at least in our case.  Henrick's 
question, as I understand it, is "do the other WGs with secretaries also 
want this done, in which case we can do it generally rather than as a 
special case?"

As Mark suggests, it would be interesting to hear from other WG 
secretaries as well as the chairs of those WGs.

-- Sam, SIDR secretary

---

From: Marc Blanchet <[email-masked]>
Date: Wed, 11 Sep 2013 11:00:33 -0400

Le 2013-09-11 à 10:42, Robert Sparks <[email-masked]> a écrit :

> That alias sometimes gets used for the people management side of the chair role - people approaching chairs with situations they are very upset about.
> They would be surprised by having more than the chairs copied, and the secretaries would be pulled through things they don't need to be.
> I much prefer the separate -secretary alias, and making sure the secretaries are in -all.

+1. Marc.

---

From: Derek Atkins <[email-masked]>
Date: Wed, 11 Sep 2013 11:10:21 -0400

Samuel Weiler <[email-masked]> writes:

>> But first, and this is important, we should ask the secretaries,
>> rather than making the decision here without them in the room.
>
> In the case of SIDR, with only a couple of months experience, the
> chairs and I have reached the tentative conclusion that I need to see
> enough of the things sent to -chairs that it's better to have me see
> all of them than have the chairs miss forwarding useful bits -- on our
> phone calls the question "did you see the note from X" keeps coming
> up, with the answer so often being "no".
>
> question, as I understand it, is "do the other WGs with secretaries
> also want this done, in which case we can do it generally rather than
> as a special case?"
>

Would it make sense to have this be a flag that the chairs can set in
the datatracker for their WG, so it gets set on a WG-by-WG basis?  This
way it's a "general feature", but each WG can decide to opt-in (or
opt-out, depending on the default setting for the flag) of this feature.

> -- Sam, SIDR secretary

-derek

-- 
       Derek Atkins                 617-623-3745
       [email-masked]             www.ihtfp.com
       Computer and Internet Security Consultant

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Wed, 11 Sep 2013 15:10:47 +0000

>> I much prefer the separate -secretary alias, and making sure the secretaries are in -all.

This does not solve the issue of traffic that naturally gets sent (by people or by scripts) to -chairs that needs to be seen by Secretaries.

It has the additional draw-back of the fact that many WGs do not have Secretaries, while all the WGs have chairs. This has potentially problematic implications: if I receive an undeliverable, is is that there is no alias, or a technical problem?

Consequently, -1 to this. Too fine of a granularity to be useful.

Regarding the "-all" statement, you are confusing things. There is no <wg>-all alias. There is a <draft-name>.all (and it appears that secretaries are not in that one, although should be, as this is intended to be authors + WG leadership). There is a <draft-name>.chairs as well.

-- Carlos.

---

From: Robert Sparks <[email-masked]>
Date: Wed, 11 Sep 2013 10:19:07 -0500

> Consequently, -1 to this. Too fine of a granularity to be useful.
then perhaps both a -chair and a -chair-sec

>
> Regarding the "-all" statement, you are confusing things.
Conflating, yes.
>   There is no <wg>-all alias. There is a <draft-name>.all (and it appears that secretaries are not in that one, although should be,
that should be was my point.
>   as this is intended to be authors + WG leadership). There is a <draft-name>.chairs as well.
>
> -- Carlos.
>
>> +1. Marc.
>>
>>
>>> RjS
>>>

---

From: Samuel Weiler <[email-masked]>
Date: Wed, 11 Sep 2013 11:24:59 -0400 (EDT)

A3: Please.
Q3: Should I avoid top posting on this mailing list?

A2: Because, by reversing the order of a conversation, it leaves the
     reader without much context, and makes them read a message in an
     unnatural order.
Q2: Why is top posting irritating?

A1: It is the practice of putting your reply to a message before the
     quoted message, instead of after the (trimmed) message.
Q1: What is top posting?

Also, please trim as much as possible from messages you are quoting in 
replies, keeping only the sections needed to maintain context for the 
reader.

Credit to Perry Metzger.

-- Sam

---

From: Marc Blanchet <[email-masked]>
Date: Wed, 11 Sep 2013 11:26:08 -0400

I'm having a problem with yet another mailing list. There are already too many mailing lists, and that would add yet another process to update when the secretaries need to be changed, etc...  We already have a pretty heavy (but very useful) tools/emails/process: there should be a high cost to add more.  

 One suggestion to the chairs that want to have secretaries receive the chairs mails:  just add a rule in their mail client or server to do automatic forward to their secretary.

Marc.

---

From: Lou Berger <[email-masked]>
Date: Wed, 11 Sep 2013 11:31:47 -0400

On 09/11/2013 11:19 AM, Robert Sparks wrote:
>>>> They would be surprised by having more than the chairs copied, and
>>>> the secretaries would be pulled through things they don't need to be.
>> This does not solve the issue of traffic that naturally gets sent (by
>> people or by scripts) to -chairs that needs to be seen by Secretaries.
>>
>> It has the additional draw-back of the fact that many WGs do not have
>> Secretaries, while all the WGs have chairs. This has potentially
>> problematic implications: if I receive an undeliverable, is is that
>> there is no alias, or a technical problem?
>>

I agree that a secretaries only alias has dubious value.  I do agree
with Martin & others that a chairs+secretary alias does have value.

how about <wg>-admin?

Lou

---

From: "Joel M. Halpern" <[email-masked]>
Date: Wed, 11 Sep 2013 11:34:26 -0400

Please do not demand that your preferred approach to reading email be 
used by all participants in IEtF email lists.

> replies, keeping only the sections needed to maintain context for the

Because there are multiple constraints, and sometimes, and for some 
people, other approaches work better

Yours,
Joel

---

From: Mary Barnes <[email-masked]>
Date: Wed, 11 Sep 2013 10:39:26 -0500

I agree with Joel.   When I am responding to specific points in an email
thread, then I will embed my comments directly in the response point by
point. If I'm making a general response, top posting is much more efficient
for me.  I will snip if I remember to, but I often prefer the whole
messages because if I print it out to read carefully or to provide a
checklist when I'm updating documents, I'd much rather print a single email
than have to print an entire thread.

Mary.

On Wed, Sep 11, 2013 at 10:34 AM, Joel M. Halpern <[email-masked]>wrote:

> Please do not demand that your preferred approach to reading email be used
> by all participants in IEtF email lists.
>
>

---

From: "Andrew G. Malis" <[email-masked]>
Date: Wed, 11 Sep 2013 11:53:34 -0400

The gmail web interface makes top posting really easy and anything else
much more difficult, which is why you see it so much from gmail users like
me. :-)

It also makes reading top-posted replies much more efficient because the
default is to only display the new text on top.

Cheers,
Andy

---

From: Mark Townsley <[email-masked]>
Date: Wed, 11 Sep 2013 17:58:35 +0200

This is a very convincing argument, particularly as our official guidelines for appeals includes going to working group chairs first, then ADs, before going to the I* with a formal filing. Carlos' is convincing as well though.

What about wg-chairs@tools... and wg-chairs-only@tools... ? 

This matches, for example, [email-masked] and [email-masked] which similarly doesn't include admin functions, and is used when you *really* only need to have the appointed IESG members on the list for some specific reason.

- Mark

---

From: Stewart Bryant <[email-masked]>
Date: Wed, 11 Sep 2013 17:03:58 +0100

Because most mail clients by default display the top rather than the 
bottom, top posting is often more efficient for the reader, particularly 
as the context needed in a thread is often just the subject line, with 
the body as a convenient aide memoir if needed.

However top, middle or bottom are all useful in different contexts, and 
we should allow the writer to do whatever they feel will communicate 
with greatest clarity and efficiency on a case by case basis.

Stewart

On 11/09/2013 16:53, Andrew G. Malis wrote:
> The gmail web interface makes top posting really easy and anything 
> else much more difficult, which is why you see it so much from gmail 
> users like me. :-)
>
> It also makes reading top-posted replies much more efficient because 
> the default is to only display the new text on top.
>
> Cheers,
> Andy
>
> On Wed, Sep 11, 2013 at 11:39 AM, Mary Barnes 
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>     I agree with Joel.   When I am responding to specific points in an
>     email thread, then I will embed my comments directly in the
>     response point by point. If I'm making a general response, top
>     posting is much more efficient for me.  I will snip if I remember
>     to, but I often prefer the whole messages because if I print it
>     out to read carefully or to provide a checklist when I'm updating
>     documents, I'd much rather print a single email than have to print
>     an entire thread.
>
>     Mary.
>
>

-- 
For corporate legal information go to:

http://www.cisco.com/web/about/doing_business/legal/cri/index.html

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Wed, 11 Sep 2013 16:08:21 +0000

> What about wg-chairs@tools... and wg-chairs-only@tools... ? 

To me, this is the most effective proposal yet -- it allows for secretaries to receive information that is needed without depending on any (human or machine) external per-wg change, and for the corner case to be a corner case. 

Thanks,

-- Carlos.

---

From: Dave Crocker <[email-masked]>
Date: Wed, 11 Sep 2013 10:27:33 -0700

ack.

-- 
Dave Crocker
Brandenburg InternetWorking
bbiw.net

---

From: Dave Crocker <[email-masked]>
Date: Wed, 11 Sep 2013 10:32:06 -0700

> with greatest clarity and efficiency on a case by case basis.

Allow, yes.  But educate, too.

As already noted in this thread, there are reasons for the differences. 
A simple ack/+1/or-the-like is really better at the top.  However 
participation in real group dialogue is almost always better with 
in-line bottom-ish posting, for the reasons cited.

If we give no guidance, people will produce a random, often-thoughtless 
mix that can hurt discussion.  Guidance isn't the same as a 'rule', of 
course.  A rule would be Procrustean, and we musn't have that...

d/

---

From: "Stewart Bryant (stbryant)" <[email-masked]>
Date: Wed, 11 Sep 2013 22:21:21 +0000

Sent from my iPad

On 11 Sep 2013, at 18:32, "Dave Crocker" <[email-masked]> wrote:

> As already noted in this thread, there are reasons for the differences. A simple ack/+1/or-the-like is really better at the top.  However participation in real group dialogue is almost always better with in-line bottom-ish posting, for the reasons cited.
> 
> If we give no guidance, people will produce a random, often-thoughtless mix that can hurt discussion.  Guidance isn't the same as a 'rule', of course.  A rule would be Procrustean, and we musn't have that...
> 
> d/
> 
> -- 
> Dave Crocker

Would you rather have f/b at the wrong end of the email, or no f/b?

Stewart

---

From: Dave Crocker <[email-masked]>
Date: Wed, 11 Sep 2013 15:22:48 -0700

> Would you rather have f/b at the wrong end of the email, or no f/b?

Can't answer that right now.  It's going to take me awhile to deal with 
the suggestion that email has a 'wrong' end...

d/

---

From: Warren Kumari <[email-masked]>
Date: Wed, 11 Sep 2013 19:51:45 -0400

On Sep 11, 2013, at 6:22 PM, Dave Crocker <[email-masked]> wrote:

> Can't answer that right now.  It's going to take me awhile to deal with the suggestion that email has a 'wrong' end…

It does -- in the same way you can get the wrong end of the stick, I often get the wrong end of the email.

W

--
"Build a man a fire, and he'll be warm for a day. Set a man on fire, and he'll be warm for the rest of his life." -- Terry Pratchett

---

From: Christopher Morrow <[email-masked]>
Date: Wed, 11 Sep 2013 20:37:59 -0400

On Wed, Sep 11, 2013 at 11:53 AM, Andrew G. Malis <[email-masked]> wrote:
> The gmail web interface makes top posting really easy and anything else much
> more difficult, which is why you see it so much from gmail users like me.
> :-)

that's crazy talk... you can properly post comments in gmail (say
here) or most other MUAs.

> default is to only display the new text on top.

sure... but searching through the conjoined threads is a pita, and
keeping state on a complex topic is harder in that instance.

-chris
(also, mime use in email was the death of the internet, news at 11)

---

From: Yaakov Stein <[email-masked]>
Date: Thu, 12 Sep 2013 05:31:54 +0000

I receive between 500 and 800 emails a day.
My mail client displays the first few lines and enables me to quickly decide if I can delete the mail.
If 25% of people would avoid top posting then I would have no time for anything other than reading mail 
(or more probably would stop using email as a tool).

Please do NOT hide anything you want me to read under a ton of old mail,
and interleave answers ONLY when they are detailed back-and-forth answers
on technical issues.

Y(J)S

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Samuel Weiler
Sent: 11 September, 2013 18:25
To: WG Chairs
Subject: Please trim quotes and avoid top posting

A3: Please.

Also, please trim as much as possible from messages you are quoting in replies, keeping only the sections needed to maintain context for the reader.

Credit to Perry Metzger.

-- Sam

---

From: Yaakov Stein <[email-masked]>
Date: Thu, 12 Sep 2013 05:40:10 +0000

> sure... but searching through the conjoined threads is a pita, and keeping state on a complex topic is harder in that instance.

There are at least 2 good reasons to leave the previous content intact and not to trim.
1) I have a complex system of rules to sort my emails.
   When I see a new thread in a folder that I monitor every other day (or once a week)
   I go to the last email in it, and working up from the bottom can understand the entire give and take.
   I can then delete all the previous emails in the thread.
2) I can save a single email summarizing the thread.

Y(J)S

---

From: "George, Wes" <[email-masked]>
Date: Thu, 12 Sep 2013 09:11:59 -0400

> It's going to take me awhile to deal with

[WEG] Seriously. This entire thread is an impressive waste of everyone's time, especially for those who feel the need to tell us how many emails they get.
Reminds me a lot of the "you can't change the current 1970s tty format of the I-Ds because it breaks my workflow, and mine is the only right one, consarnit" debates over on rfc-interest.

Postel's "law" -- it's not just for protocols.

Wes

Anything below this line has been added by my company's mail server, I have no control over it.
-----------------

This E-mail and any of its attachments may contain Time Warner Cable proprietary information, which is privileged, confidential, or subject to copyright belonging to Time Warner Cable. This E-mail is intended solely for the use of the individual or entity to which it is addressed. If you are not the intended recipient of this E-mail, you are hereby notified that any dissemination, distribution, copying, or action taken in relation to the contents of and attachments to this E-mail is strictly prohibited and may be unlawful. If you have received this E-mail in error, please notify the sender immediately and permanently delete the original and any copy of this E-mail and any printout.

---

From: Acee Lindem <[email-masked]>
Date: Thu, 12 Sep 2013 13:17:06 +0000

Agree totally with Wes. 
Acee

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Thu, 12 Sep 2013 13:25:23 +0000

On Sep 12, 2013, at 9:11 AM, "George, Wes" <[email-masked]>
 wrote:
> [WEG] Seriously.

Indeed.

> Postel's "law" -- it's not just for protocols.

+1!

Carlos.

---

From: Tim Chown <[email-masked]>
Date: Thu, 12 Sep 2013 14:31:02 +0100

Indeed.

---

From: Ted Lemon <[email-masked]>
Date: Thu, 12 Sep 2013 13:33:47 +0000

> 2) I can save a single email summarizing the thread.

Essentially what you are saying is that your MUA sucks (for the purpose to which you put it, anyway!).

---

From: Yoav Nir <[email-masked]>
Date: Thu, 12 Sep 2013 13:41:06 +0000

> My mail client displays the first few lines and enables me to quickly decide if I can delete the mail.

My mail client displays the first few lines that are not quoted, regardless of whether the non-quoted part is at the top or the bottom. Granted, this is based on some heuristic, and might fail if people quote in interesting ways, but it does work for email forwarded or replied-to normally in Outlook, Mail.app and Gmail.

---

From: Mary Barnes <[email-masked]>
Date: Thu, 12 Sep 2013 08:42:06 -0500

Sure. And, you all can very easily just delete the thread and not add to
the noise with your responses.    Many of us responded because someone
suggested we should set a procedure or agree a policy for formats when
responding to emails.  The consensus I took away from this thread is that
there are good reasons why folks use different approaches, so just get used
to it.

We have this discussion almost as often as we discuss how cold meeting
rooms are.  As always, there are different opinions and if you think it is
a waste of time, you just hit that nice little delete button.

Mary.

On Thu, Sep 12, 2013 at 8:31 AM, Tim Chown <[email-masked]> wrote:

> > [WEG] Seriously. This entire thread is an impressive waste of everyone's
> time, especially for those who feel the need to tell us how many emails
> they get.
> > Reminds me a lot of the "you can't change the current 1970s tty format
> of the I-Ds because it breaks my workflow, and mine is the only right one,
> consarnit" debates over on rfc-interest.
>
> Indeed.
>
>

---

From: "Howard, Lee" <[email-masked]>
Date: Thu, 12 Sep 2013 09:43:08 -0400

>the suggestion that email has a 'wrong' end...

My experience is that there seems to be no end to email.

Yes, I'm contributing to the problem.

ObContribution:  I miss elm.  Ever since Microsoft got into the email
client business, mail has looked strange and poorly organized to me.
Sometimes, I wish the world were different.  When I care enough, I write
an internet-draft describing how the world should be.  If I get consensus,
sometimes the world changes in that direction.

Lee

---

From: "George, Wes" <[email-masked]>
Date: Thu, 12 Sep 2013 09:54:22 -0400

Sure. And, you all can very easily just delete the thread and not add to the noise with your responses.    Many of us responded because someone suggested we should set a procedure or agree a policy for formats when responding to emails.  The consensus I took away from this thread is that there are good reasons why folks use different approaches, so just get used to it.

We have this discussion almost as often as we discuss how cold meeting rooms are.  As always, there are different opinions and if you think it is a waste of time, you just hit that nice little delete button.

[WEG] and now the thread has come full circle, with a condescending response about the delete key when someone makes a snarky comment about the whining that started the thread in the first place
Guess we all can move on with our lives now that IETF Stupid/Trivial Argument Hash Protocol (aka STAHP) has been followed to the end of the infinite loop and reached the sleep(x) command

Wes, with tongue firmly in cheek

________________________________
This E-mail and any of its attachments may contain Time Warner Cable proprietary information, which is privileged, confidential, or subject to copyright belonging to Time Warner Cable. This E-mail is intended solely for the use of the individual or entity to which it is addressed. If you are not the intended recipient of this E-mail, you are hereby notified that any dissemination, distribution, copying, or action taken in relation to the contents of and attachments to this E-mail is strictly prohibited and may be unlawful. If you have received this E-mail in error, please notify the sender immediately and permanently delete the original and any copy of this E-mail and any printout.

---

From: Peter Koch <[email-masked]>
Date: Thu, 12 Sep 2013 16:44:26 +0200

> [WEG] Seriously. This entire thread is an impressive waste of everyone's time, especially for those who feel the need to tell us how many emails they get.

[...]

> Postel's "law" -- it's not just for protocols.

I'm sorry but what you're proposing here is an abuse of the robustness
principle.  Unfortunately we are seeing the pattern "if you were more
liberal in what you accept, you wouldn't complain about me not being
conservative in my submission" increasingly on the protocol/ops side, as well.
That doesn't meet the spirit in my books.

-Peter

---

From: "George, Wes" <[email-masked]>
Date: Thu, 12 Sep 2013 10:54:23 -0400

> That doesn't meet the spirit in my books.

[WEG] nor was it what I was implying. Both sides are a problem.

Wes

---

From: Ted Lemon <[email-masked]>
Date: Thu, 12 Sep 2013 15:26:21 +0000

On Sep 12, 2013, at 9:54 AM, "George, Wes" <[email-masked]> wrote:
> and now the thread has come full circle, with a condescending response about the delete key when someone makes a snarky comment about the whining that started the thread in the first place

It would be nice if we could all accept that IETFers argue about things.  I could as easily complain about the dozen +1s that followed the observation that we shouldn't be arguing about this.   There is absolutely no reason for us to be catty to each other about this.

---

From: Dave Crocker <[email-masked]>
Date: Thu, 12 Sep 2013 08:32:38 -0700

> It would be nice if we could all accept that IETFers argue about things.  I could as easily complain about the dozen +1s that followed the observation that we shouldn't be arguing about this.   The…

So, in addition to everything else, you want us to eliminate the 
entertainment component?

d/