Subject: "I support as a co-author"

From: Melinda Shore <[email-masked]>
Date: Mon, 09 Sep 2013 11:18:04 -0800

Why are we getting these messages during wg last calls?
I'm leaning towards asking people to stop - aside from the
fact that it looks like voting, is there some value to
these messages, am I correct in thinking that it carries
no weight (of course an author supports publication)?

Melinda

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 9 Sep 2013 21:22:35 +0200

It seems to me this one is a simple misunderstanding about the process by this one author; a personal mail explaining this might be in order.
(Of course, once people are doing this, others might imitate that misunderstanding, so maybe a message to the list might become necessary.)

[Then, of course, drafts sometimes do have authors listed that don't actually support them... Different problem.]

Grüße, Carsten

---

From: Warren Kumari <[email-masked]>
Date: Mon, 9 Sep 2013 15:23:40 -0400

> no weight (of course an author supports publication)?

Yup, it *should* carry no weight, but it *does* seem to generate the perception that there is more consensus than there is…

I just went back through the WGLC for a document that I hadn't been following, and even though I tried to discount the "support as an author" comments it still *felt* like there was more support than if those hadn't been posted.

Funny monkeys and all that…

W

-- 
No man is an island, But if you take a bunch of dead guys and tie them together, they make a pretty good raft.
                --Anon.

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Mon, 9 Sep 2013 19:23:38 +0000

I assume it is peculiar to your working group.

I would encourage statements along the line "I have read the document and have no comments", but from a co-author that would be pretty meaningless - I would assume that was the case.

Keith

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Melinda Shore
> Sent: 09 September 2013 20:18
> To: [email-masked]
> Subject: "I support as a co-author"
>

---

From: Edward Crabbe <[email-masked]>
Date: Mon, 9 Sep 2013 12:22:43 -0700

IMO it's implied and carries no weight what so ever.

It's been my observation that it does provide some small inertia,
increasing message count for the thread and in turn the overall number
of non-author responses.  Humans are strange creatures.

---

From: Peter Koch <[email-masked]>
Date: Mon, 9 Sep 2013 21:28:32 +0200

> these messages, am I correct in thinking that it carries

I'd read this as a disclosure of potential bias.

> no weight (of course an author supports publication)?

In addition to that people should refer to themselves as editors
it might be helpful to know the editors see no issues.
Strictly speaking though, in real academic theory,
document editors implement the directions received from the
WG, so they could be in the rough. Not "as editors", however.

-Peter

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Mon, 9 Sep 2013 19:29:42 +0000

By the time you get to WGLC the document should have consensus.

All open issues should have been closed, and absence of consensus on all or any part of the document would seem to indicate against that.

So with that, indications of consensus are meaningless.

What WGLC should be telling you is that people have reviewed it and the document is ready for publication request (once any comments have been fixed).

Keith

> Behalf Of Warren Kumari
> Sent: 09 September 2013 20:24
> To: Melinda Shore
> Cc: [email-masked]
> Subject: Re: "I support as a co-author"
> 
> 
> Yup, it *should* carry no weight, but it *does* seem to generate the
> perception that there is more consensus than there is...
> 
> I just went back through the WGLC for a document that I hadn't been
> following, and even though I tried to discount the "support as an author"
> comments it still *felt* like there was more support than if those hadn't
> been posted.
> 
> Funny monkeys and all that...
> 
> W
> 
> >
> > Melinda
> >
> 
> --

---

From: Ted Lemon <[email-masked]>
Date: Mon, 9 Sep 2013 20:04:57 +0000

> no weight (of course an author supports publication)?

It's probably my fault—I used to ask co-authors to indicate support so that I could consider their support in the consensus call.   But I was doing a poor job of determining consensus, and I think your interpretation is at least half correct: an author expressing support without giving a reason isn't very useful.

OTOH, an author expressing support by making a material point in favor of adopting or publishing a draft certainly is in scope, precisely _because_ we are not voting.   Authors' arguments about the value of drafts are just as valid as non-authors' arguments.

---

From: Benoit Claise <[email-masked]>
Date: Mon, 09 Sep 2013 22:11:46 +0200

Hi Melinda,

There is no value for these types of messages, and we should educate people.
I've also seen people going to microphone, with the same message.

Regards, Benoit

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Mon, 9 Sep 2013 16:21:34 -0400

I totally agree with Benoit. for years I've been telling people (humorously) that its bloody obvious that they support the doc as they'll wrote it!

Tom 

Von meinem iPhone gesendet

---

From: Mary Barnes <[email-masked]>
Date: Mon, 9 Sep 2013 15:25:25 -0500

In my experience, there are fairly often times where co-authors don't
review all the versions of the document and actually may not have reviewed
any versions of the WG document.  I had one co-author submit significant
changes during AUTH48 - it was quite clear he hadn't read the document for
several years. IMHO, these folks should ask to have their names removed
from the author list.  But, it seems vanity doesn't allow that.

Mary.

On Mon, Sep 9, 2013 at 3:21 PM, Thomas D. Nadeau <[email-masked]>wrote:

> I totally agree with Benoit. for years I've been telling people
> (humorously) that its bloody obvious that they support the doc as they'll
> wrote it!
>
> Tom
>
>

---

From: "Randy Presuhn" <[email-masked]>
Date: Mon, 9 Sep 2013 13:42:23 -0700

Hi -

> From: "Thomas D. Nadeau" <[email-masked]>
> To: "Benoit Claise" <[email-masked]>
> Cc: <[email-masked]>
> Sent: Monday, September 09, 2013 1:21 PM
...

> I totally agree with Benoit. for years I've been telling people (humorously)
> that its bloody obvious that they support the doc as they'll wrote it!

Speaking from personal experience...
At least in the case of WG documents, it ain't necessarily so.
It's not that unusual for *editors* to find themselves directed
to put into a document things with which they do not agree.

Randy

---

From: Benoit Claise <[email-masked]>
Date: Mon, 09 Sep 2013 22:47:34 +0200

> to put into a document things with which they do not agree.
The cases we face in OPSAWG these days is a reply to WGLC such as:

    Yes, support the publication as an informational RFC
    (i am a co-author). Thanks.

No added value.

Regards, Benoit

---

From: Yoav Nir <[email-masked]>
Date: Mon, 9 Sep 2013 21:03:02 +0000

> to put into a document things with which they do not agree.

Sure, that happens. But WGLC is for a fresh re-read of the document by people who haven't read it in a while, for a first read by people who can't spare the time to read something before it's mature enough, and for the wallflowers to stop waiting for someone else to raise the objection they have been sitting on for months.

None of these should apply to editors. A "I support publication" statement means "Now that I've read this draft, it looks OK to me". That is an absurd statement for an editor. If they had objections and were forced to enter stuff they didn't agree with, they had every opportunity of speaking up (and they usually do). Saying that they don't object to the document is stating the obvious. OTOH saying "I think this should not progress, because…" does have content, but (a) probably should have been raised earlier, and (b) equally has meaning if said by a non-editor.

Yoav

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Mon, 9 Sep 2013 17:14:37 -0400

Another similarly useless response is to just "support" without any reason why,
from non-authors. some wgs
have explicitly asked those saying "support" why.

Tom

---

From: "Randy Presuhn" <[email-masked]>
Date: Mon, 9 Sep 2013 16:03:15 -0700

Hi -

> From: "Yoav Nir" <[email-masked]>
> To: "Randy Presuhn" <[email-masked]>
> Cc: <[email-masked]>
> Sent: Monday, September 09, 2013 2:03 PM
...
> None of these should apply to editors. A "I support publication" statement
> means "Now that I've read this draft, it looks OK to me". That is an absurd
> statement for an editor. If they had objections and were forced to enter stuff
> they didn't agree with, they had every opportunity of speaking up (and they
> usually do). Saying that they don't object to the document is stating the
> obvious. OTOH saying "I think this should not progress, because…" does
> have content, but (a) probably should have been raised earlier, and (b)
> equally has meaning if said by a non-editor.

I still disagree.  An editor may end up on the rough side of WG consensus.
I know I have.

Bringing up lost battles at the last call seems to be generally considered
bad form.  For some documents I'm sure the editors' positions might be
better summarized as "I've read this in careful detail; some of my objections
have not been addressed, but in the interest of progress I'm not going to
raise an objection to publishing this document."  Consequently, for me at
least, for a document editor to say "I support publication" *does* have content.

Randy

---

From: "ietfdbh" <[email-masked]>
Date: Tue, 10 Sep 2013 00:27:43 -0400

Hi,

Having been an editor for documents where my opinion about technical choices
was in the rough, I still supported publication of the document because I
felt it represented WG consensus, and wasn't "broken".
Having been a co-author for documents where I did not do the final editing
passes on the document, I read the updated document and supported the
document as ready for publication.
Having been a co-author where I did do the final editing passes because the
other editors were called away for day-job responsibilities, I appreciated
that they read the document and expressed support for the latest version as
named co-authors (even if they might have felt they were in the rough).

I think it *does* have meaningful content to say that one supports the
document as a co-author/editor.

I agree that such statements would be MUCH more useful if they stated "I
read the document and believe it represents WG consensus" or "I read the
document and believe it is ready for publication".
I think we should educate people that that type of statement of support is
far more valuable than one that just says "I support the document".
I think we should NOT educate people that "if you are a co-author, then a
statement of your opinion is worthless".

Chairs are in the unenviable position of determining whether a co-author's
statement of support is based on actual support for the reviewed document or
some type of political statement of support, and whether to consider their
statement as part of determining consensus.
I do not think chairs should abdicate those responsibilities by simply
deciding all co-authors' statements of support should be ignored - ask for a
more detailed statement if "I support the document" does not seem
informative enough.

David Harrington
[email-masked]
+1-603-828-1401

> Behalf Of Randy Presuhn
> Sent: Monday, September 09, 2013 7:03 PM
> To: [email-masked]
> > obvious. OTOH saying "I think this should not progress, because." does

---

From: Melinda Shore <[email-masked]>
Date: Mon, 09 Sep 2013 20:31:03 -0800

> more detailed statement if "I support the document" does not seem

They're not ignored.  If they had concerns about the
document moving forward, they'd be taken very seriously
indeed.

Melinda

---

From: Yaakov Stein <[email-masked]>
Date: Tue, 10 Sep 2013 05:43:46 +0000

One situation I have been in involves a document that is a compromise
between two different approaches that had been presented to the WG.

Having the authors tell the group that they now truly support the details of the compromise approach
after having attacked many of the very same details, IS useful.

In another situation my name was left on a document that I had not seen for years.
When informed that I was still on the first page I asked the editor why,
and was told that there were still ideas of mine there.
In that particular case I asked for my name to be moved to the acknowledgements section,
but I might have ended up expressing support, or lack thereof, for that document.

I realize that these are corner cases, but they aren't exceedingly rare.

Y(J)S

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of ietfdbh
Sent: 10 September, 2013 07:28
To: 'Randy Presuhn'; [email-masked]
Subject: RE: "I support as a co-author"

Hi,

Having been an editor for documents where my opinion about technical choices was in the rough, I still supported publication of the document because I felt it represented WG consensus, and wasn't "broken".
Having been a co-author for documents where I did not do the final editing passes on the document, I read the updated document and supported the document as ready for publication.
Having been a co-author where I did do the final editing passes because the other editors were called away for day-job responsibilities, I appreciated that they read the document and expressed support for the latest version as named co-authors (even if they might have felt they were in the rough).

I think it *does* have meaningful content to say that one supports the document as a co-author/editor.

I agree that such statements would be MUCH more useful if they stated "I read the document and believe it represents WG consensus" or "I read the document and believe it is ready for publication".
I think we should educate people that that type of statement of support is far more valuable than one that just says "I support the document".
I think we should NOT educate people that "if you are a co-author, then a statement of your opinion is worthless".

Chairs are in the unenviable position of determining whether a co-author's statement of support is based on actual support for the reviewed document or some type of political statement of support, and whether to consider their statement as part of determining consensus.
I do not think chairs should abdicate those responsibilities by simply deciding all co-authors' statements of support should be ignored - ask for a more detailed statement if "I support the document" does not seem informative enough.

David Harrington
[email-masked]
+1-603-828-1401

---

From: "Tschofenig, Hannes (NSN - FI/Espoo)" <[email-masked]>
Date: Tue, 10 Sep 2013 06:35:18 +0000

I have seen this in many working groups; both with working group last calls but also with the initial WG adoption. 

Here it gets tricky: 

Imagine you got 5 different folks to agree on something and they become co-authors. That's already something compared to have one person writing the document on his own.  

Of course, you can now say that the 5 document authors do not need to state again that they agree with the content but the perception on the mailing list will be very different. 

I have had cases where the document authors actually didn't agree with the content for a long time. As soon as they did they did the noticed that they disagreed. Of course they discovered that fairly late the process (Auth48) and so there were some issues...

I guess it is hard to derive a general rule since we have folks involved who are so different in their behavior. I guess everything falls back to the chairs to sort these things out. 

Ciao
Hannes

> Behalf Of ext DRAGE, Keith (Keith)
> Sent: Monday, September 09, 2013 10:24 PM
> To: Melinda Shore; [email-masked]
> I would encourage statements along the line "I have read the document
> and have no comments", but from a co-author that would be pretty
> meaningless - I would assume that was the case.
> 
> Keith
>

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 10 Sep 2013 06:59:03 +0000

Hi,

If co-authors don't figure out until AUTH48 that they don't agree with the draft content I don't think the problem is in the process - the problem is in the co-authors...

Regards,

Christer

________________________________________
From: [email-masked] [[email-masked]] on behalf of Tschofenig, Hannes (NSN - FI/Espoo) [[email-masked]]
Sent: Tuesday, 10 September 2013 9:35 AM
To: ext DRAGE, Keith (Keith); Melinda Shore; [email-masked]
Subject: RE: "I support as a co-author"

Here it gets tricky:

Ciao
Hannes

---

From: "Tschofenig, Hannes (NSN - FI/Espoo)" <[email-masked]>
Date: Tue, 10 Sep 2013 07:00:41 +0000

It was just an extreme example but you get the idea. Just assuming that everyone reads all the documents all the time is probably not realistic (even among document authors).

Ciao
Hannes

> From: ext Christer Holmberg [mailto:[email-masked]]
> Sent: Tuesday, September 10, 2013 9:59 AM
> To: Tschofenig, Hannes (NSN - FI/Espoo); ext DRAGE, Keith (Keith);
> Melinda Shore; [email-masked]
> If co-authors don't figure out until AUTH48 that they don't agree with
> the draft content I don't think the problem is in the process - the
> problem is in the co-authors...
> 
> Regards,
> 
> Christer
> 
> From: [email-masked] [[email-masked]] on behalf
> of Tschofenig, Hannes (NSN - FI/Espoo) [[email-masked]]
> I have seen this in many working groups; both with working group last
> calls but also with the initial WG adoption.
> 
> Here it gets tricky:
> 
> Imagine you got 5 different folks to agree on something and they become
> co-authors. That's already something compared to have one person
> writing the document on his own.
> 
> Of course, you can now say that the 5 document authors do not need to
> state again that they agree with the content but the perception on the
> mailing list will be very different.
> 
> I have had cases where the document authors actually didn't agree with
> the content for a long time. As soon as they did they did the noticed
> that they disagreed. Of course they discovered that fairly late the
> process (Auth48) and so there were some issues...
> 
> I guess it is hard to derive a general rule since we have folks
> involved who are so different in their behavior. I guess everything
> falls back to the chairs to sort these things out.
> 
> Ciao
> Hannes
>

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 10 Sep 2013 07:40:06 +0000

Hi,

>It was just an extreme example but you get the idea. Just assuming that everyone reads all the documents all the time is probably not realistic (even among document authors).

It's not about having to read the documents all the time - it's about the co-authors communicating with each other, and informing each other what changes are suggested etc.

Being a document co-author should come with some commitment and responsibility.

Regards,

Christer

> Imagine you got 5 different folks to agree on something and they 
> become co-authors. That's already something compared to have one 
> person writing the document on his own.
> 
> > From: [email-masked] [mailto:[email-masked]] 
> > On Behalf Of ext DRAGE, Keith (Keith)
> > I would encourage statements along the line "I have read the 
> > document and have no comments", but from a co-author that would be 
> > pretty meaningless - I would assume that was the case.
> >
> > Keith
> >
> > > I'm leaning towards asking people to stop - aside from the fact 
> > > that it looks like voting, is there some value to these messages, 
> > > am I correct in thinking that it carries no weight (of course an 
> > > author supports publication)?
> > >
> > > Melinda

---

From: Mark Townsley <[email-masked]>
Date: Tue, 10 Sep 2013 09:42:12 +0200

I think y(j)s and dbh make very salient points.

Bottom line, between our 120+ WGs and multitudes of documents passing through each, there can be no single hard and fast rule. This thread has been a good reminder to chairs that we need to take author/editorship as well as named acknowledgement into account, not only when judging consensus but perhaps when calling for it as well. That's as far as I think we can and should go (i.e., any type of "process" to limit or blankly assume the voice of authors would surely fail). 

- Mark

---

From: Jouni Korhonen <[email-masked]>
Date: Tue, 10 Sep 2013 10:55:34 +0300

On Sep 9, 2013, at 11:25 PM, Mary Barnes <[email-masked]> wrote:

> In my experience, there are fairly often times where co-authors don't review all the versions of the document and actually may not have reviewed any versions of the WG document.  I had one co-author submit significant changes during AUTH48 - it was quite clear he hadn't read the document for several years. IMHO, these folks should ask to have their names removed from the author list.  But, it seems vanity doesn't allow that.  

I've seen this happening several times and I really dislike such behavior. Occasionally I have managed to put aside my frustration because the "sleeping co-author" actually brought valuable feedback, albeit very late in the process. And usually the very late feedback originate from an implementer somewhere deep in the product unit who had issues implementing some parts, for example, due ambiguous text.. (yes, not everybody implements every part of the spec in the first run so there are likely risks for grey areas).

- Jouni

> Mary. 
> 
> 
> On Mon, Sep 9, 2013 at 3:21 PM, Thomas D. Nadeau <[email-masked]> wrote:

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Tue, 10 Sep 2013 11:08:33 +0000

But perhaps that should have been established before WGLC was started?

Keith

> Behalf Of Yaakov Stein
> Sent: 10 September 2013 06:44
> To: [email-masked]
> Behalf Of ietfdbh
> Having been an editor for documents where my opinion about technical
> choices was in the rough, I still supported publication of the document
> because I felt it represented WG consensus, and wasn't "broken".
> Having been a co-author where I did do the final editing passes because
> the other editors were called away for day-job responsibilities, I
> appreciated that they read the document and expressed support for the
> latest version as named co-authors (even if they might have felt they were
> in the rough).
> 
> statement of support is based on actual support for the reviewed document
> or some type of political statement of support, and whether to consider
> their statement as part of determining consensus.
> deciding all co-authors' statements of support should be ignored - ask for
> a more detailed statement if "I support the document" does not seem
> informative enough.
> 
> David Harrington
> [email-masked]
> +1-603-828-1401

---

From: Ted Lemon <[email-masked]>
Date: Tue, 10 Sep 2013 11:51:36 +0000

> It was just an extreme example but you get the idea. Just assuming that everyone reads all the documents all the time is probably not realistic (even among document authors).

A disagreement like the one you described, occurring in AUTH48, would no doubt require changes that would require a new working group consensus call anyway.

---

From: Mary Barnes <[email-masked]>
Date: Tue, 10 Sep 2013 09:14:37 -0500

On Tue, Sep 10, 2013 at 1:59 AM, Christer Holmberg <
[email-masked]> wrote:

> Hi,
>
> If co-authors don't figure out until AUTH48 that they don't agree with the
> draft content I don't think the problem is in the process - the problem is
> in the co-authors...
>
[MB] No, it's not just a problem with the co-authors.  The
co-authors/editor make changes based upon WG consensus.  The WG then
reviews the document and decides whether they think the changes reflect WG
consensus. Often text is carefully crafted to address concerns. There is
nothing in the process that requires a specific co-author to sign off on a
document other than AUTH48.  So, maybe we need to ensure all the document
authors have signed off on a document during/after WGLC and prior to the
document being forwarded to the IESG - similar to the fact that we now must
get a response from each author wrt IPR.  So, the authors posting that they
agree with the document on the WG mailing list during WGLC is actually a
good thing based on my experiences.  In the case of the particular document
I'm referring to,  the co-author that sent comments during AUTH48, was made
aware of all changes - he just didn't bother reviewing the draft during the
WG revisions.   The vast majority of the comments were editorial and based
more on the fact that some of the co-authors were non-native English
speakers, so the text was not grammatically perfect (but understandable).

[/MB]

> From: [email-masked] [[email-masked]] on behalf of
> Tschofenig, Hannes (NSN - FI/Espoo) [[email-masked]]
> co-authors. That's already something compared to have one person writing
> the document on his own.
>
> I have had cases where the document authors actually didn't agree with the
> content for a long time. As soon as they did they did the noticed that they
> disagreed. Of course they discovered that fairly late the process (Auth48)
> and so there were some issues...
>
> I guess it is hard to derive a general rule since we have folks involved
> who are so different in their behavior. I guess everything falls back to
> the chairs to sort these things out.
>
> Ciao
> Hannes
>

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 10 Sep 2013 16:25:59 +0200

On Sep 10, 2013, at 16:14, Mary Barnes <[email-masked]> wrote:

> must get a response from each author wrt IPR

Good point.  
It seems easy to add an "please agree that this document is ready, and..." to the IPR check routine.

Grüße, Carsten