Subject: Project Tracking in WGs

From: Adam Montville <[email-masked]>
Date: Thu, 24 Oct 2013 17:09:45 +0000

Hi All...

As a new WG chair, I'm finding it somewhat difficult to "manage" the overall project(s) of the WG.  In my particular case (sacm) we're just getting started with Use Case and Requirements documents, and we're already behind schedule from that which we agreed on the list after Berlin.

I've thought about using the Trac system for this, but have heard conflicting opinions as to its value for general project tracking vs. issue tracking.

Do any of you have useful advice?

Regards,

Adam

. . .

---

From: Melinda Shore <[email-masked]>
Date: Thu, 24 Oct 2013 09:18:39 -0800

On 10/24/13 9:09 AM, Adam Montville wrote:
> I've thought about using the Trac system for this, but have heard
> conflicting opinions as to its value for general project tracking vs.
> issue tracking.

Trac's an issue tracker and I don't think it's that useful for
overall project planning.  We've got an opsawg chairs wiki page
that we use sporadically, and when we use it I think it's useful
for staying on top of the state of drafts and meeting plans, etc.

Melinda

---

From: Dave Crocker <[email-masked]>
Date: Thu, 24 Oct 2013 13:20:43 -0400

On 10/24/2013 1:09 PM, Adam Montville wrote:
> As a new WG chair, I'm finding it somewhat difficult to "manage" the overall project(s) of the WG.

What specific project management functions do you want to perform with a 
tool?

d/

-- 
Dave Crocker
Brandenburg InternetWorking
bbiw.net

---

From: Mary Barnes <[email-masked]>
Date: Thu, 24 Oct 2013 12:22:08 -0500

We have been using Trac on the wiki for specific issues related to specific
documents.  It's not at all an ideal tool, but it's good enough.  As far as
a project plan with more intermediate milestones and details that can be
quite useful for tracking progress, I have found an excel spreadsheet to
work fairly well. You can see the one we're using for the CLUE WG here:
http://trac.tools.ietf.org/wg/clue/trac/wiki  (click on CLUE WG Project
Plan link to download the .xls.

Regards,
Mary.

On Thu, Oct 24, 2013 at 12:09 PM, Adam Montville <
[email-masked]> wrote:

> Hi All...
>
> As a new WG chair, I'm finding it somewhat difficult to "manage" the
> overall project(s) of the WG.  In my particular case (sacm) we're just
> getting started with Use Case and Requirements documents, and we're already
> behind schedule from that which we agreed on the list after Berlin.
>
> conflicting opinions as to its value for general project tracking vs. issue
> tracking.
>

---

From: Michael Richardson <[email-masked]>
Date: Thu, 24 Oct 2013 13:55:07 -0400

Adam Montville <[email-masked]> wrote:
    > getting started with Use Case and Requirements documents, and we're
    > already behind schedule from that which we agreed on the list after
    > Berlin.

    > conflicting opinions as to its value for general project tracking
    > vs. issue tracking.

I think that the usefulness of it depends upon who, other than the WG chairs,
you want to have interact with the tracker, and their willingness to do so.

I think that Trac can be very usefully used,  but you need to have some core
group of people doing that.  the ROLL secretary has been doing an awesome job
at keeping the Trac up to date, and this has helped signficantly, but I'm
not sure it's gotten our milestones done faster.  (Perhaps only, we aren't
further behind...)

--
Michael Richardson <[email-masked]>, Sandelman Software Works

---

From: Adam Montville <[email-masked]>
Date: Thu, 24 Oct 2013 18:41:52 +0000

> -----Original Message-----
> From: Dave Crocker [mailto:[email-masked]]
> Sent: Thursday, October 24, 2013 12:21 PM
> To: Adam Montville; [email-masked]
> Subject: Re: Project Tracking in WGs
> 
> overall project(s) of the WG.
> 
> 

Certainly a fair question.  I want to be able to have non-charter-specific milestones in support of a charter-specific milestone.  I'd like to be able to enter document issues, provide a deadline, and view some progress against that date. It would be nice to associate a set of issues with a milestone, so we know when we've actually met the milestone.  All of this information should be in plain view of anyone who has an interest in the WG's work and progress.

There are, of course, many ways to accomplish this, but I'd like to leverage the tools available rather than bake something new.  At the same time, I recognize that a lot depends on the group's willingness to leverage a tool and in getting help to maintain it.  I could do all the maintenance work myself, but then I'd probably be unemployed...

> ...

. . .

---

From: Adam Montville <[email-masked]>
Date: Thu, 24 Oct 2013 18:44:51 +0000

> From: Michael Richardson [mailto:[email-masked]]
> Sent: Thursday, October 24, 2013 12:55 PM
> To: Adam Montville
> Cc: [email-masked]
> I think that the usefulness of it depends upon who, other than the WG
> chairs, you want to have interact with the tracker, and their willingness to do
> so.

That makes sense.  I run into this same issue every day at CIS - the process is only as good as the execution.

> group of people doing that.  the ROLL secretary has been doing an awesome
> job at keeping the Trac up to date, and this has helped signficantly, but I'm

I like the idea of having a group secretary.  We've not established that role yet.

. . .

---

From: Mary Barnes <[email-masked]>
Date: Thu, 24 Oct 2013 13:51:40 -0500

On Thu, Oct 24, 2013 at 12:55 PM, Michael Richardson
<[email-masked]>wrote:

> chairs,
> group of people doing that.

[MB] Absolutely. For the CLUE WG we made the decision that only the chairs
could
update the tracker.  I had a nightmare experience in another WG when an
individual discovered
the tracker and decided that each and every comment on my document should
have a separate issue,
including editorial nits such as a space before a period, etc. In the CLUE
WG, we don't add issues until there's been
some discussion as some issues can be quickly resolved and don't need
tracking for any period of time.  The tool
is a tad cumbersome IMHO as there's a lot of fields you don't need if you
are just tracking issues
in a document.  But, there may be a way to customize the fields you see.
[/MB]

>  the ROLL secretary has been doing an awesome job

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 24 Oct 2013 22:09:40 +0200

On 24 Oct 2013, at 20:41, Adam Montville <[email-masked]> wrote:

>  I want to be able to have non-charter-specific milestones in support of a charter-specific milestone.  I'd like to be able to enter document issues, provide a deadline, and view some progress against that date. It would be nice to associate a set of issues with a milestone, so we know when we've actually met the milestone.  All of this information should be in plain view of anyone who has an interest in the WG's work and progress.

Trac can do some of that.  You might want to explore the “admin” tab for creating those milestones.
(The display options aren’t that great, admittedly.  It’s not Redmine...)

Grüße, Carsten