Subject: Fwd: New datatracker release: v4.83

From: Robert Sparks <[email-masked]>
Date: Wed, 06 Nov 2013 12:57:20 -0800

Chairs -

The sprint produced a _lot_ of good changes for the datatracker this week.

I wanted to call particular attention to a new feature you have - you 
can now edit
the Replaces relationships for your working group documents directly instead
of asking the secretariat to do so for you. Look for the Replaces: row 
near the top
of each document's main page. Please let us know if you run into any 
trouble with it
by filing a bug report here: 
<http://trac.tools.ietf.org/tools/ietfdb/newticket>
(and feel free to send me a note).

Please also take a few moments to look through the other improvements 
called out below.

RjS

--------

Hi,

This is an automatic notification about a new datatracker release,
v4.83, generated when running the mkrelease script.

Release notes:

ietfdb (4.83) ietf; urgency=high
   This release provides the code from the IETF-88 code sprint, and also
   a number of fixes to things reported during the IETF.
   The number of enhancements coming out of the sprint this time is impressive;
   this may actually have been the most successful sprint till now.
   Of particular note is the new ability for chairs and others who has the
   permission to edit a document's state, to edit replaced-by information for
   documents; and the introduction of information about which documents a given
   document references, for all documents.  Future enhancements will display
   this information as diagrams and textually, and use it to re-introduce the
   dependency diagrams originally provide by Bill Fenner in his stand-alone
   dependency graph application.
   From [email-masked]:
   * Changed draft replaces action: move document to archive directory
   From [email-masked]:
   * Allow wgchairs to edit document replacement relationships.
     This actually allows anyone with can_edit_stream_info permission
     to edit the list. This does draft name completion, but does not
     currently filter those names for likely replacements. Styling is
     also basically non-existent.  Fixes #1002
   * Added 'Track this document' link on drafts.  Fixes #1085.
   * Mark concluded BoFs as BoFs, not Concluded WGs.  Fixes #1169.
   From [email-masked]:
   * Added the new version of the shepherd writeup as a comment when it's edited.
     The new version works like this:
      -  Any shepherd writeups done before the document is submitted for
	publication are not disclosed in the history.
      -  When the document is submitted for publication the available writeup (if
	available) is added to history.
      -  Any further writeups after the document has been submitted for publication
	are disclosed in the history.
   From [email-masked]:
   * Refactored the mails sent when state is changed along with annotation tags.
     Don't send emails for only comment changes, just add a history entry.  For
     state changes and annotation changes, only send one email, containing
     information about both state changes and annotation tag changes.
     Fixes issue #1127.
   From [email-masked]:
   * Included confirmation addresses in ID-Submission success notice.
     Fixes issue #1097.
   * Added document titles to status change request email.  Fixes issue #1069.
   * Added \'Last Call Issued:\' to front of last call atom feed entry subjects.
   * Fixed conflict review text for irtf docs to reference RFC 5743.
   * Added the last call expiration date to the document header, and remove
     duplicate code for producing the iest state summary.
   From [email-masked]:
   * Added .csv export from private community lists.  Fixes #1074
   * Took care of #841 by moving <span> correctly outside <a> altogether.
   From [email-masked]:
   * Fixed #1153: Fixes IPR disclosures being counted multiple times and
     counting of \'not yet approved\' IPR disclosures.
   From [email-masked]:
     Refined Bill Fenner's regex based search through documents for references.
     This populates RelatedDocument with relations for references for each type
     draft Document; replaces these reference relationships with updated
     copies upon draft submission.  Note to deployer: There is a script to run in
     patches/fill_in_references.py that does the work of bringing the database
     up to date. It takes around 10 minutes to complete on a fast development
     laptop.  Fixes bug #1173
   Other changes:
   * Tweaked the style used on the nomcom feedback pages a bit, to give people
     a bit more room to write in the feedback field.
   * It turns out that the get_user_email is called for every nominee listed on
     a feedback page, which is insane.  But until the template can be rewritten
     to do this in a more sane way, we cache the lookup result.
   * Changed things so the left-side navbar doesn't jump to full page width in
     the instant before the main content is loaded.  NB: Cleanup action needed:
     replace all px dimensions with em, consistently.
   * Included the IAOC update session in the training section of the agenda.
   * By preference, show the same email for a logged-in user as his login, if
     it exists; otherwise show the newest active email address.
   * Many minor fixes to agenda templates and the known-good agenda test files.

The new version is available through SVN checkout, with
   'svn checkout http://svn.tools.ietf.org/svn/tools/ietfdb/tags/4.83'

Regards,

	Henrik
	(via the mkrelease script)

---

From: "Eggert, Lars" <[email-masked]>
Date: Thu, 7 Nov 2013 02:17:37 +0000

You guys rock!

On 06 Nov 2013, at 12:57, Robert Sparks <[email-masked]> wrote:

> I wanted to call particular attention to a new feature you have - you can now edit
> of asking the secretariat to do so for you. Look for the Replaces: row near the top
> of each document's main page. Please let us know if you run into any trouble with it
> by filing a bug report here: <http://trac.tools.ietf.org/tools/ietfdb/newticket>
> Please also take a few moments to look through the other improvements called out below.
> 
> RjS
> 
> --------
> 
> Hi,
> 
> <Attached Message Part.txt>

---

From: "Eggert, Lars" <[email-masked]>
Date: Thu, 7 Nov 2013 02:34:43 +0000

Hi,

On 06 Nov 2013, at 12:57, Robert Sparks <[email-masked]> wrote:
> of each document's main page.

so you guys can now fix all of these by yourself! Awesome!

WG and RG chairs are encouraged to check whether these are accurate for their groups, and if so, FIX THEM IN THE DATATRACKER per above.

As always, double-check before doing this. Also, see list of possible inconsistencies at the end of the report.

(Note that the IPR disclosure search tool uses these replaced-by relationships, so keeping them up-to-date is actually useful and not just WG hygiene.)

The source code for this tool is at http://eggert.org/software/find-replaced-by

Lars

-----------------------------------------------------------------
APP Area
-----------------------------------------------------------------
CORE Working Group, APP Area
   draft-castellani-core-http-mapping POTENTIALLY REPLACED BY draft-ietf-core-http-mapping

HTTPBIS Working Group, APP Area
   draft-rpeon-httpbis-header-compression POTENTIALLY REPLACED BY draft-ietf-httpbis-header-compression
   draft-unicorn-httpbis-http2 POTENTIALLY REPLACED BY draft-ietf-httpbis-http2

HYBI Working Group, APP Area
   draft-tyoshino-hybi-permessage-compression POTENTIALLY REPLACED BY draft-ietf-hybi-permessage-compression

PAWS Working Group, APP Area
   draft-das-paws-protocol POTENTIALLY REPLACED BY draft-ietf-paws-protocol
   draft-probasco-paws-problem-stmt-usecases-rqmts POTENTIALLY REPLACED BY draft-ietf-paws-problem-stmt-usecases-rqmts
   draft-sbi-paws-protocol POTENTIALLY REPLACED BY draft-ietf-paws-protocol
   draft-vchen-paws-protocol POTENTIALLY REPLACED BY draft-ietf-paws-protocol

SCIM Working Group, APP Area
   draft-zeltsan-scim-use-cases POTENTIALLY REPLACED BY draft-ietf-scim-use-cases

WEBSEC Working Group, APP Area
   draft-hodges-websec-framework-reqs POTENTIALLY REPLACED BY draft-ietf-websec-framework-reqs
   draft-williams-websec-session-continue-prob POTENTIALLY REPLACED BY draft-ietf-websec-session-continue-prob

-----------------------------------------------------------------
CONCLUDED Area
-----------------------------------------------------------------
ATOMPUB Working Group, CONCLUDED Area
   draft-snell-atompub-autodiscovery POTENTIALLY REPLACED BY draft-ietf-atompub-autodiscovery

EAI Working Group, CONCLUDED Area
   draft-duerst-eai-mailto POTENTIALLY REPLACED BY draft-ietf-eai-mailto
   draft-yao-eai-rfc5336bis POTENTIALLY REPLACED BY draft-ietf-eai-rfc5336bis

FTPEXT2 Working Group, CONCLUDED Area
   draft-liu-ftpext2-ftp64 POTENTIALLY REPLACED BY draft-ietf-ftpext2-ftp64

HTTP Working Group, CONCLUDED Area
   draft-wallis-http-digest-auth-a3a8 POTENTIALLY REPLACED BY draft-ietf-http-digest-auth-a3a8

IDNABIS Working Group, CONCLUDED Area
   draft-faltstrom-idnabis-tables POTENTIALLY REPLACED BY draft-ietf-idnabis-tables

IMAP Working Group, CONCLUDED Area
   draft-crispin-imap-compat POTENTIALLY REPLACED BY draft-ietf-imap-compat

TFTPEXTS Working Group, CONCLUDED Area
   draft-malkin-tftpexts-blksize-opt POTENTIALLY REPLACED BY draft-ietf-tftpexts-blksize-opt
   draft-malkin-tftpexts-option-ext POTENTIALLY REPLACED BY draft-ietf-tftpexts-option-ext
   draft-malkin-tftpexts-options POTENTIALLY REPLACED BY draft-ietf-tftpexts-options

XMPP Working Group, CONCLUDED Area
   draft-barnes-xmpp-dna POTENTIALLY REPLACED BY draft-ietf-xmpp-dna
   draft-miller-xmpp-e2e POTENTIALLY REPLACED BY draft-ietf-xmpp-e2e

CSI Working Group, CONCLUDED Area
   draft-jiang-csi-dhcpv6-cga-ps POTENTIALLY REPLACED BY draft-ietf-csi-dhcpv6-cga-ps
   draft-rgaglian-csi-send-name-type-registry POTENTIALLY REPLACED BY draft-ietf-csi-send-name-type-registry

DNSEXT Working Group, CONCLUDED Area
   draft-wang-dnsext-newzone-notify POTENTIALLY REPLACED BY draft-ietf-dnsext-newzone-notify

MIPSHOP Working Group, CONCLUDED Area
   draft-xia-mipshop-fmip-ptp POTENTIALLY REPLACED BY draft-ietf-mipshop-fmip-ptp

NETLMM Working Group, CONCLUDED Area
   draft-cui-netlmm-mip-interactions POTENTIALLY REPLACED BY draft-ietf-netlmm-mip-interactions
   draft-glenn-netlmm-pmipv6-mib POTENTIALLY REPLACED BY draft-ietf-netlmm-pmipv6-mib
   draft-xia-netlmm-lma-discovery POTENTIALLY REPLACED BY draft-ietf-netlmm-lma-discovery

SEND Working Group, CONCLUDED Area
   draft-arkko-send-cga POTENTIALLY REPLACED BY draft-ietf-send-cga
   draft-arkko-send-ndopt POTENTIALLY REPLACED BY draft-ietf-send-ndopt

SHIM6 Working Group, CONCLUDED Area
   draft-garcia-shim6-applicability POTENTIALLY REPLACED BY draft-ietf-shim6-applicability

ARMD Working Group, CONCLUDED Area
   draft-dunbar-armd-problem-statement POTENTIALLY REPLACED BY draft-ietf-armd-problem-statement

ATOCA Working Group, CONCLUDED Area
   draft-rosen-atoca-cap POTENTIALLY REPLACED BY draft-ietf-atoca-cap

BLISS Working Group, CONCLUDED Area
   draft-elwell-bliss-ach-analysis POTENTIALLY REPLACED BY draft-ietf-bliss-ach-analysis
   draft-poetzl-bliss-call-completion POTENTIALLY REPLACED BY draft-ietf-bliss-call-completion
   draft-procter-bliss-call-park-extension POTENTIALLY REPLACED BY draft-ietf-bliss-call-park-extension
   draft-rosenberg-bliss-problem-statement POTENTIALLY REPLACED BY draft-ietf-bliss-problem-statement

SIGTRAN Working Group, CONCLUDED Area
   draft-anil-sigtran-dua POTENTIALLY REPLACED BY draft-ietf-sigtran-dua

SIP Working Group, CONCLUDED Area
   draft-arkko-sip-sec-agree POTENTIALLY REPLACED BY draft-ietf-sip-sec-agree
   draft-biggs-sip-replaces POTENTIALLY REPLACED BY draft-ietf-sip-replaces
   draft-pashalidis-sip-saml POTENTIALLY REPLACED BY draft-ietf-sip-saml

SIPPING Working Group, CONCLUDED Area
   draft-drage-sipping-service-identification POTENTIALLY REPLACED BY draft-ietf-sipping-service-identification
   draft-elwell-sipping-update-pai POTENTIALLY REPLACED BY draft-ietf-sipping-update-pai
   draft-hilt-sipping-overload-design POTENTIALLY REPLACED BY draft-ietf-sipping-overload-design
   draft-petrie-sipping-profile-datasets POTENTIALLY REPLACED BY draft-ietf-sipping-profile-datasets
   draft-rosenberg-sipping-service-identification POTENTIALLY REPLACED BY draft-ietf-sipping-service-identification
   draft-zhang-sipping-overlap POTENTIALLY REPLACED BY draft-ietf-sipping-overlap

SPEERMINT Working Group, CONCLUDED Area
   draft-meyer-speermint-reqs-and-terminology POTENTIALLY REPLACED BY draft-ietf-speermint-reqs-and-terminology
   draft-niccolini-speermint-voipthreats POTENTIALLY REPLACED BY draft-ietf-speermint-voipthreats

XCON Working Group, CONCLUDED Area
   draft-barnes-xcon-ccmp POTENTIALLY REPLACED BY draft-ietf-xcon-ccmp
   draft-barnes-xcon-examples POTENTIALLY REPLACED BY draft-ietf-xcon-examples

DKIM Working Group, CONCLUDED Area
   draft-lindsey-dkim-mailinglists POTENTIALLY REPLACED BY draft-ietf-dkim-mailinglists

HOKEY Working Group, CONCLUDED Area
   draft-wu-hokey-rfc5296bis POTENTIALLY REPLACED BY draft-ietf-hokey-rfc5296bis

PKIX Working Group, CONCLUDED Area
   draft-cooper-pkix-rfc2560bis POTENTIALLY REPLACED BY draft-ietf-pkix-rfc2560bis
   draft-cooper-pkix-rfc5280-clarifications POTENTIALLY REPLACED BY draft-ietf-pkix-rfc5280-clarifications
   draft-santesson-pkix-certimage POTENTIALLY REPLACED BY draft-ietf-pkix-certimage

SACRED Working Group, CONCLUDED Area
   draft-arsenault-sacred-reqs POTENTIALLY REPLACED BY draft-ietf-sacred-reqs

SASL Working Group, CONCLUDED Area
   draft-zeilenga-sasl-crammd5 POTENTIALLY REPLACED BY draft-ietf-sasl-crammd5
   draft-zeilenga-sasl-rfc2222bis POTENTIALLY REPLACED BY draft-ietf-sasl-rfc2222bis

SECSH Working Group, CONCLUDED Area
   draft-moonesamy-secsh-filexfer POTENTIALLY REPLACED BY draft-ietf-secsh-filexfer

SMIME Working Group, CONCLUDED Area
   draft-dusse-smime-cert POTENTIALLY REPLACED BY draft-ietf-smime-cert
   draft-dusse-smime-msg POTENTIALLY REPLACED BY draft-ietf-smime-msg

BEHAVE Working Group, CONCLUDED Area
   draft-liu-behave-ftp64 POTENTIALLY REPLACED BY draft-ietf-behave-ftp64

DECADE Working Group, CONCLUDED Area
   draft-alimi-decade-arch POTENTIALLY REPLACED BY draft-ietf-decade-arch
   draft-chen-decade-integration-example POTENTIALLY REPLACED BY draft-ietf-decade-integration-example
   draft-huang-decade-integration-example POTENTIALLY REPLACED BY draft-ietf-decade-integration-example

DIFFSERV Working Group, CONCLUDED Area
   draft-baker-diffserv-mib POTENTIALLY REPLACED BY draft-ietf-diffserv-mib

FECFRAME Working Group, CONCLUDED Area
   draft-roca-fecframe-ldpc POTENTIALLY REPLACED BY draft-ietf-fecframe-ldpc
   draft-roca-fecframe-simple-rs POTENTIALLY REPLACED BY draft-ietf-fecframe-simple-rs

PCN Working Group, CONCLUDED Area
   draft-karagiannis-pcn-signaling-requirements POTENTIALLY REPLACED BY draft-ietf-pcn-signaling-requirements

RSVP Working Group, CONCLUDED Area
   draft-berger-rsvp-refresh-reduct POTENTIALLY REPLACED BY draft-ietf-rsvp-refresh-reduct

-----------------------------------------------------------------
INT Area
-----------------------------------------------------------------
6MAN Working Group, INT Area
   draft-cooper-6man-ipv6-address-generation-privacy POTENTIALLY REPLACED BY draft-ietf-6man-ipv6-address-generation-privacy
   draft-droms-6man-multicast-scopes POTENTIALLY REPLACED BY draft-ietf-6man-multicast-scopes

ANCP Working Group, INT Area
   draft-lefaucheur-ancp-mc-extensions POTENTIALLY REPLACED BY draft-ietf-ancp-mc-extensions

DHC Working Group, INT Area
   draft-lemon-dhc-topo-conf POTENTIALLY REPLACED BY draft-ietf-dhc-topo-conf

HIP Working Group, INT Area
   draft-camarillo-hip-via POTENTIALLY REPLACED BY draft-ietf-hip-via
   draft-henderson-hip-rfc5206-bis POTENTIALLY REPLACED BY draft-ietf-hip-rfc5206-bis
   draft-jokela-hip-rfc5202-bis POTENTIALLY REPLACED BY draft-ietf-hip-rfc5202-bis
   draft-keranen-hip-native-nat-traversal POTENTIALLY REPLACED BY draft-ietf-hip-native-nat-traversal
   draft-keranen-hip-over-hip POTENTIALLY REPLACED BY draft-ietf-hip-over-hip
   draft-keranen-hip-reload-instance POTENTIALLY REPLACED BY draft-ietf-hip-reload-instance
   draft-moskowitz-hip-rfc4423-bis POTENTIALLY REPLACED BY draft-ietf-hip-rfc4423-bis
   draft-moskowitz-hip-rfc5201-bis POTENTIALLY REPLACED BY draft-ietf-hip-rfc5201-bis
   draft-nikander-hip-hiccups POTENTIALLY REPLACED BY draft-ietf-hip-hiccups

INTAREA Working Group, INT Area
   draft-boucadair-intarea-nat-reveal-analysis POTENTIALLY REPLACED BY draft-ietf-intarea-nat-reveal-analysis

LWIG Working Group, INT Area
   draft-arkko-lwig-cellular POTENTIALLY REPLACED BY draft-ietf-lwig-cellular

MULTIMOB Working Group, INT Area
   draft-hui-multimob-fast-handover POTENTIALLY REPLACED BY draft-ietf-multimob-fast-handover
   draft-schmidt-multimob-fmipv6-pfmipv6-multicast POTENTIALLY REPLACED BY draft-ietf-multimob-fmipv6-pfmipv6-multicast
   draft-schmidt-multimob-pmipv6-source POTENTIALLY REPLACED BY draft-ietf-multimob-pmipv6-source
   draft-wu-multimob-igmp-mld-tuning POTENTIALLY REPLACED BY draft-ietf-multimob-igmp-mld-tuning
   draft-zuniga-multimob-pmipv6-ropt POTENTIALLY REPLACED BY draft-ietf-multimob-pmipv6-ropt

NETEXT Working Group, INT Area
   draft-bernardos-netext-pmipv6-flowmob POTENTIALLY REPLACED BY draft-ietf-netext-pmipv6-flowmob
   draft-krishnan-netext-pmip-lr POTENTIALLY REPLACED BY draft-ietf-netext-pmip-lr
   draft-krishnan-netext-update-notifications POTENTIALLY REPLACED BY draft-ietf-netext-update-notifications
   draft-liebsch-netext-pmip6-qos POTENTIALLY REPLACED BY draft-ietf-netext-pmip6-qos
   draft-melia-netext-logical-interface-support POTENTIALLY REPLACED BY draft-ietf-netext-logical-interface-support
   draft-wakikawa-netext-pmip-cp-up-separation POTENTIALLY REPLACED BY draft-ietf-netext-pmip-cp-up-separation
   draft-zhou-netext-pd-pmip POTENTIALLY REPLACED BY draft-ietf-netext-pd-pmip

PCP Working Group, INT Area
   draft-bpw-pcp-dhcp POTENTIALLY REPLACED BY draft-ietf-pcp-dhcp
   draft-bpw-pcp-proxy POTENTIALLY REPLACED BY draft-ietf-pcp-proxy
   draft-bpw-pcp-upnp-igd-interworking POTENTIALLY REPLACED BY draft-ietf-pcp-upnp-igd-interworking
   draft-cheshire-pcp-anycast POTENTIALLY REPLACED BY draft-ietf-pcp-anycast
   draft-reddy-pcp-optimize-keepalives POTENTIALLY REPLACED BY draft-ietf-pcp-optimize-keepalives
   draft-wasserman-pcp-authentication POTENTIALLY REPLACED BY draft-ietf-pcp-authentication

SAVI Working Group, INT Area
   draft-bi-savi-mix POTENTIALLY REPLACED BY draft-ietf-savi-mix

SOFTWIRE Working Group, INT Area
   draft-cui-softwire-mesh-mib POTENTIALLY REPLACED BY draft-ietf-softwire-mesh-mib
   draft-despres-softwire-4rd POTENTIALLY REPLACED BY draft-ietf-softwire-4rd
   draft-guo-softwire-6rd-radius-attrib POTENTIALLY REPLACED BY draft-ietf-softwire-6rd-radius-attrib
   draft-ieft-softwire-dslite-deployment POTENTIALLY REPLACED BY draft-ietf-softwire-dslite-deployment
   draft-lee-softwire-dslite-deployment POTENTIALLY REPLACED BY draft-ietf-softwire-dslite-deployment
   draft-maglione-softwire-dslite-radius-ext POTENTIALLY REPLACED BY draft-ietf-softwire-dslite-radius-ext
   draft-mdt-softwire-map-deployment POTENTIALLY REPLACED BY draft-ietf-softwire-map-deployment
   draft-murakami-softwire-4rd POTENTIALLY REPLACED BY draft-ietf-softwire-4rd
   draft-qin-softwire-multicast-prefix-option POTENTIALLY REPLACED BY draft-ietf-softwire-multicast-prefix-option
   draft-vautrin-softwire-4rd POTENTIALLY REPLACED BY draft-ietf-softwire-4rd
   draft-xu-softwire-mesh-multicast POTENTIALLY REPLACED BY draft-ietf-softwire-mesh-multicast

SUNSET4 Working Group, INT Area
   draft-perreault-sunset4-noipv4 POTENTIALLY REPLACED BY draft-ietf-sunset4-noipv4

TICTOC Working Group, INT Area
   draft-davari-tictoc-1588overmpls POTENTIALLY REPLACED BY draft-ietf-tictoc-1588overmpls
   draft-mizrahi-tictoc-security-requirements POTENTIALLY REPLACED BY draft-ietf-tictoc-security-requirements
   draft-vinay-tictoc-ptp-mib POTENTIALLY REPLACED BY draft-ietf-tictoc-ptp-mib

-----------------------------------------------------------------
IRTF Area
-----------------------------------------------------------------
DTNRG Working Group, IRTF Area
   draft-lindgren-dtnrg-prophet POTENTIALLY REPLACED BY draft-irtf-dtnrg-prophet
   draft-symington-dtnrg-bundle-metadata-block POTENTIALLY REPLACED BY draft-irtf-dtnrg-bundle-metadata-block
   draft-symington-dtnrg-bundle-retrans-block POTENTIALLY REPLACED BY draft-irtf-dtnrg-bundle-retrans-block

HIPRG Working Group, IRTF Area
   draft-ahrenholz-hiprg-dht POTENTIALLY REPLACED BY draft-irtf-hiprg-dht

MOBOPTS Working Group, IRTF Area
   draft-koki-mobopts-l2-abstractions POTENTIALLY REPLACED BY draft-irtf-mobopts-l2-abstractions
   draft-ohba-mobopts-mpa-framework POTENTIALLY REPLACED BY draft-irtf-mobopts-mpa-framework
   draft-schmidt-mobopts-mmcastv6-ps POTENTIALLY REPLACED BY draft-irtf-mobopts-mmcastv6-ps
   draft-weniger-mobopts-mip6-cnlocpriv POTENTIALLY REPLACED BY draft-irtf-mobopts-mip6-cnlocpriv

P2PRG Working Group, IRTF Area
   draft-gurbani-p2prg-simulation-survey POTENTIALLY REPLACED BY draft-irtf-p2prg-simulation-survey

-----------------------------------------------------------------
IRTF-CONCLUDED Area
-----------------------------------------------------------------
HIPRG Working Group, IRTF-CONCLUDED Area
   draft-ahrenholz-hiprg-dht POTENTIALLY REPLACED BY draft-irtf-hiprg-dht

MOBOPTS Working Group, IRTF-CONCLUDED Area
   draft-koki-mobopts-l2-abstractions POTENTIALLY REPLACED BY draft-irtf-mobopts-l2-abstractions
   draft-ohba-mobopts-mpa-framework POTENTIALLY REPLACED BY draft-irtf-mobopts-mpa-framework
   draft-schmidt-mobopts-mmcastv6-ps POTENTIALLY REPLACED BY draft-irtf-mobopts-mmcastv6-ps
   draft-weniger-mobopts-mip6-cnlocpriv POTENTIALLY REPLACED BY draft-irtf-mobopts-mip6-cnlocpriv

P2PRG Working Group, IRTF-CONCLUDED Area
   draft-gurbani-p2prg-simulation-survey POTENTIALLY REPLACED BY draft-irtf-p2prg-simulation-survey

-----------------------------------------------------------------
OPS Area
-----------------------------------------------------------------
DIME Working Group, OPS Area
   draft-tschofenig-dime-e2e-sec-req POTENTIALLY REPLACED BY draft-ietf-dime-e2e-sec-req

DNSOP Working Group, OPS Area
   draft-jabley-dnsop-as112-dname POTENTIALLY REPLACED BY draft-ietf-dnsop-as112-dname

EMAN Working Group, OPS Area
   draft-tychon-eman-applicability-statement POTENTIALLY REPLACED BY draft-ietf-eman-applicability-statement

GROW Working Group, OPS Area
   draft-dimitri-grow-rss POTENTIALLY REPLACED BY draft-ietf-grow-rss
   draft-manderson-grow-geomrt POTENTIALLY REPLACED BY draft-ietf-grow-geomrt

IPFIX Working Group, OPS Area
   draft-gupta-ipfix-reliability-template-ext POTENTIALLY REPLACED BY draft-ietf-ipfix-reliability-template-ext

LMAP Working Group, OPS Area
   draft-akhter-lmap-framework POTENTIALLY REPLACED BY draft-ietf-lmap-framework
   draft-eardley-lmap-framework POTENTIALLY REPLACED BY draft-ietf-lmap-framework
   draft-folks-lmap-framework POTENTIALLY REPLACED BY draft-ietf-lmap-framework
   draft-linsner-lmap-use-cases POTENTIALLY REPLACED BY draft-ietf-lmap-use-cases

MBONED Working Group, OPS Area
   draft-asaeda-mboned-mtrace-v2 POTENTIALLY REPLACED BY draft-ietf-mboned-mtrace-v2
   draft-asaeda-mboned-session-announcement-req POTENTIALLY REPLACED BY draft-ietf-mboned-session-announcement-req
   draft-bipi-mboned-ip-multicast-pm-requirement POTENTIALLY REPLACED BY draft-ietf-mboned-ip-multicast-pm-requirement
   draft-tsou-mboned-multrans-addr-acquisition POTENTIALLY REPLACED BY draft-ietf-mboned-multrans-addr-acquisition
   draft-venaas-mboned-mcaddrdoc POTENTIALLY REPLACED BY draft-ietf-mboned-mcaddrdoc
   draft-venaas-mboned-ssmping POTENTIALLY REPLACED BY draft-ietf-mboned-ssmping

NETCONF Working Group, OPS Area
   draft-chisholm-netconf-monitoring POTENTIALLY REPLACED BY draft-ietf-netconf-monitoring

OPSAWG Working Group, OPS Area
   draft-chen-opsawg-capwap-extension POTENTIALLY REPLACED BY draft-ietf-opsawg-capwap-extension
   draft-krishnan-opsawg-large-flow-load-balancing POTENTIALLY REPLACED BY draft-ietf-opsawg-large-flow-load-balancing
   draft-shao-opsawg-capwap-hybridmac POTENTIALLY REPLACED BY draft-ietf-opsawg-capwap-hybridmac

OPSEC Working Group, OPS Area
   draft-gont-opsec-ipv6-nd-security POTENTIALLY REPLACED BY draft-ietf-opsec-ipv6-nd-security

RADEXT Working Group, OPS Area
   draft-perez-radext-radius-fragmentation POTENTIALLY REPLACED BY draft-ietf-radext-radius-fragmentation

V6OPS Working Group, OPS Area
   draft-hilliard-v6ops-ipv6-discard-prefix POTENTIALLY REPLACED BY draft-ietf-v6ops-ipv6-discard-prefix
   draft-rgaglian-v6ops-v6inixp POTENTIALLY REPLACED BY draft-ietf-v6ops-v6inixp
   draft-vandevelde-v6ops-ra-guard POTENTIALLY REPLACED BY draft-ietf-v6ops-ra-guard
   draft-wbeebee-v6ops-ipv6-cpe-router-bis POTENTIALLY REPLACED BY draft-ietf-v6ops-ipv6-cpe-router-bis

WPKOPS Working Group, OPS Area
   draft-barreira-wpkops-trustmodel POTENTIALLY REPLACED BY draft-ietf-wpkops-trustmodel

-----------------------------------------------------------------
RAI Area
-----------------------------------------------------------------
CLUE Working Group, RAI Area
   draft-even-clue-rtp-mapping POTENTIALLY REPLACED BY draft-ietf-clue-rtp-mapping
   draft-presta-clue-data-model-schema POTENTIALLY REPLACED BY draft-ietf-clue-data-model-schema
   draft-romanow-clue-framework POTENTIALLY REPLACED BY draft-ietf-clue-framework
   draft-romanow-clue-telepresence-requirements POTENTIALLY REPLACED BY draft-ietf-clue-telepresence-requirements
   draft-romanow-clue-telepresence-use-cases POTENTIALLY REPLACED BY draft-ietf-clue-telepresence-use-cases

CODEC Working Group, RAI Area
   draft-valin-codec-guidelines POTENTIALLY REPLACED BY draft-ietf-codec-guidelines
   draft-valin-codec-results POTENTIALLY REPLACED BY draft-ietf-codec-results

DRINKS Working Group, RAI Area
   draft-channabasappa-drinks-usecases-requirements POTENTIALLY REPLACED BY draft-ietf-drinks-usecases-requirements

ECRIT Working Group, RAI Area
   draft-forte-ecrit-service-urn-policy POTENTIALLY REPLACED BY draft-ietf-ecrit-service-urn-policy

GEOPRIV Working Group, RAI Area
   draft-barnes-geopriv-policy-uri POTENTIALLY REPLACED BY draft-ietf-geopriv-policy-uri
   draft-mayrhofer-geopriv-geo-uri POTENTIALLY REPLACED BY draft-ietf-geopriv-geo-uri
   draft-winterbottom-geopriv-local-civic POTENTIALLY REPLACED BY draft-ietf-geopriv-local-civic

INSIPID Working Group, RAI Area
   draft-kaplan-insipid-session-id POTENTIALLY REPLACED BY draft-ietf-insipid-session-id

MMUSIC Working Group, RAI Area
   draft-holmberg-mmusic-udptl-dtls POTENTIALLY REPLACED BY draft-ietf-mmusic-udptl-dtls
   draft-ivov-mmusic-trickle-ice POTENTIALLY REPLACED BY draft-ietf-mmusic-trickle-ice
   draft-keranen-mmusic-rfc5245bis POTENTIALLY REPLACED BY draft-ietf-mmusic-rfc5245bis
   draft-petithuguenin-mmusic-ice-sip-sdp POTENTIALLY REPLACED BY draft-ietf-mmusic-ice-sip-sdp

P2PSIP Working Group, RAI Area
   draft-bryan-p2psip-reload POTENTIALLY REPLACED BY draft-ietf-p2psip-reload
   draft-petithuguenin-p2psip-access-control POTENTIALLY REPLACED BY draft-ietf-p2psip-access-control
   draft-zong-p2psip-drr POTENTIALLY REPLACED BY draft-ietf-p2psip-drr
   draft-zong-p2psip-rpr POTENTIALLY REPLACED BY draft-ietf-p2psip-rpr

PAYLOAD Working Group, RAI Area
   draft-ramalho-payload-g7110 POTENTIALLY REPLACED BY draft-ietf-payload-g7110
   draft-rea-payload-rtp-aptx POTENTIALLY REPLACED BY draft-ietf-payload-rtp-aptx
   draft-schierl-payload-rtp-h265 POTENTIALLY REPLACED BY draft-ietf-payload-rtp-h265
   draft-westin-payload-vp8 POTENTIALLY REPLACED BY draft-ietf-payload-vp8

RTCWEB Working Group, RAI Area
   draft-jesup-rtcweb-data-protocol POTENTIALLY REPLACED BY draft-ietf-rtcweb-data-protocol

SIPCORE Working Group, RAI Area
   draft-roach-sipcore-priority POTENTIALLY REPLACED BY draft-ietf-sipcore-priority

SIPREC Working Group, RAI Area
   draft-ram-siprec-callflows POTENTIALLY REPLACED BY draft-ietf-siprec-callflows

SOC Working Group, RAI Area
   draft-noel-soc-overload-rate-control POTENTIALLY REPLACED BY draft-ietf-soc-overload-rate-control
   draft-shen-soc-load-control-event-package POTENTIALLY REPLACED BY draft-ietf-soc-load-control-event-package

STIR Working Group, RAI Area
   draft-peterson-stir-threats POTENTIALLY REPLACED BY draft-ietf-stir-threats

STRAW Working Group, RAI Area
   draft-kaplan-straw-b2bua-loop-detection POTENTIALLY REPLACED BY draft-ietf-straw-b2bua-loop-detection
   draft-kaplan-straw-b2bua-taxonomy POTENTIALLY REPLACED BY draft-ietf-straw-b2bua-taxonomy
   draft-kaplan-straw-sip-traceroute POTENTIALLY REPLACED BY draft-ietf-straw-sip-traceroute

XMPP Working Group, RAI Area
   draft-barnes-xmpp-dna POTENTIALLY REPLACED BY draft-ietf-xmpp-dna
   draft-miller-xmpp-e2e POTENTIALLY REPLACED BY draft-ietf-xmpp-e2e

XRBLOCK Working Group, RAI Area
   draft-asaeda-xrblock-rtcp-xr-synchronization POTENTIALLY REPLACED BY draft-ietf-xrblock-rtcp-xr-synchronization
   draft-clark-xrblock-rtcp-xr-qoe POTENTIALLY REPLACED BY draft-ietf-xrblock-rtcp-xr-qoe
   draft-huang-xrblock-rtcp-xr-decodability POTENTIALLY REPLACED BY draft-ietf-xrblock-rtcp-xr-decodability
   draft-singh-xrblock-rtcp-xr-bytes-discarded-metric POTENTIALLY REPLACED BY draft-ietf-xrblock-rtcp-xr-bytes-discarded-metric

-----------------------------------------------------------------
RTG Area
-----------------------------------------------------------------
BFD Working Group, RTG Area
   draft-bhatia-bfd-hmac-sha POTENTIALLY REPLACED BY draft-ietf-bfd-hmac-sha
   draft-mmm-bfd-on-lags POTENTIALLY REPLACED BY draft-ietf-bfd-on-lags

FORCES Working Group, RTG Area
   draft-haleplidis-forces-implementation-experience POTENTIALLY REPLACED BY draft-ietf-forces-implementation-experience
   draft-haleplidis-forces-model-extension POTENTIALLY REPLACED BY draft-ietf-forces-model-extension

I2RS Working Group, RTG Area
   draft-liu-i2rs-architecture POTENTIALLY REPLACED BY draft-ietf-i2rs-architecture

IDR Working Group, RTG Area
   draft-mitchell-idr-as-private-reservation POTENTIALLY REPLACED BY draft-ietf-idr-as-private-reservation
   draft-rosen-idr-extcomm-iana POTENTIALLY REPLACED BY draft-ietf-idr-extcomm-iana

ISIS Working Group, RTG Area
   draft-chopps-isis-bfd-tlv POTENTIALLY REPLACED BY draft-ietf-isis-bfd-tlv
   draft-chunduri-isis-extended-sequence-no-tlv POTENTIALLY REPLACED BY draft-ietf-isis-extended-sequence-no-tlv
   draft-ginsberg-isis-fs-lsp POTENTIALLY REPLACED BY draft-ietf-isis-fs-lsp
   draft-ginsberg-isis-genapp POTENTIALLY REPLACED BY draft-ietf-isis-genapp
   draft-ginsberg-isis-udl POTENTIALLY REPLACED BY draft-ietf-isis-udl
   draft-previdi-isis-mi POTENTIALLY REPLACED BY draft-ietf-isis-mi
   draft-previdi-isis-te-metric-extensions POTENTIALLY REPLACED BY draft-ietf-isis-te-metric-extensions
   draft-shen-isis-oper-enhance POTENTIALLY REPLACED BY draft-ietf-isis-oper-enhance

L2VPN Working Group, RTG Area
   draft-allan-l2vpn-spbm-evpn POTENTIALLY REPLACED BY draft-ietf-l2vpn-spbm-evpn
   draft-henderickx-l2vpn-vpls-multihoming POTENTIALLY REPLACED BY draft-ietf-l2vpn-vpls-multihoming
   draft-kompella-l2vpn-vpls-multihoming POTENTIALLY REPLACED BY draft-ietf-l2vpn-vpls-multihoming

MANET Working Group, RTG Area
   draft-dearlove-manet-nhdp-olsrv2-tlv-extension POTENTIALLY REPLACED BY draft-ietf-manet-nhdp-olsrv2-tlv-extension
   draft-dearlove-manet-olsrv2-rmpr-optimization POTENTIALLY REPLACED BY draft-ietf-manet-olsrv2-rmpr-optimization
   draft-herberg-manet-nhdp-olsrv2-sec POTENTIALLY REPLACED BY draft-ietf-manet-nhdp-olsrv2-sec
   draft-herberg-manet-nhdp-sec POTENTIALLY REPLACED BY draft-ietf-manet-nhdp-sec
   draft-herberg-manet-nhdp-sec-threats POTENTIALLY REPLACED BY draft-ietf-manet-nhdp-sec-threats
   draft-herberg-manet-rfc6622-bis POTENTIALLY REPLACED BY draft-ietf-manet-rfc6622-bis

MPLS Working Group, RTG Area
   draft-liu-mpls-tp-ring-protection POTENTIALLY REPLACED BY draft-ietf-mpls-tp-ring-protection

NVO3 Working Group, RTG Area
   draft-bl-nvo3-dataplane-requirements POTENTIALLY REPLACED BY draft-ietf-nvo3-dataplane-requirements
   draft-chen-nvo3-gap-analysis POTENTIALLY REPLACED BY draft-ietf-nvo3-gap-analysis
   draft-rekhter-nvo3-vm-mobility-issues POTENTIALLY REPLACED BY draft-ietf-nvo3-vm-mobility-issues
   draft-zu-nvo3-security-requirements POTENTIALLY REPLACED BY draft-ietf-nvo3-security-requirements

OSPF Working Group, RTG Area
   draft-acee-ospf-rfc6506bis POTENTIALLY REPLACED BY draft-ietf-ospf-rfc6506bis
   draft-nguyen-ospf-lls POTENTIALLY REPLACED BY draft-ietf-ospf-lls
   draft-ogier-ospf-dbex-opt POTENTIALLY REPLACED BY draft-ietf-ospf-dbex-opt

PCE Working Group, RTG Area
   draft-dhody-pce-pcep-service-aware POTENTIALLY REPLACED BY draft-ietf-pce-pcep-service-aware
   draft-lee-pce-wson-rwa-ext POTENTIALLY REPLACED BY draft-ietf-pce-wson-rwa-ext
   draft-tang-pce-stateful-pce POTENTIALLY REPLACED BY draft-ietf-pce-stateful-pce
   draft-zhang-pce-hierarchy-extensions POTENTIALLY REPLACED BY draft-ietf-pce-hierarchy-extensions
   draft-zhang-pce-stateful-pce-app POTENTIALLY REPLACED BY draft-ietf-pce-stateful-pce-app

PIM Working Group, RTG Area
   draft-venaas-pim-hierarchicaljoinattr POTENTIALLY REPLACED BY draft-ietf-pim-hierarchicaljoinattr

RTGWG Working Group, RTG Area
   draft-litkowski-rtgwg-lfa-manageability POTENTIALLY REPLACED BY draft-ietf-rtgwg-lfa-manageability

-----------------------------------------------------------------
SEC Area
-----------------------------------------------------------------
ABFAB Working Group, SEC Area
   draft-wei-abfab-usecases POTENTIALLY REPLACED BY draft-ietf-abfab-usecases
   draft-winter-abfab-eapapplicability POTENTIALLY REPLACED BY draft-ietf-abfab-eapapplicability

DANE Working Group, SEC Area
   draft-dukhovni-dane-ops POTENTIALLY REPLACED BY draft-ietf-dane-ops

IPSECME Working Group, SEC Area
   draft-kivinen-ipsecme-oob-pubkey POTENTIALLY REPLACED BY draft-ietf-ipsecme-oob-pubkey
   draft-smyslov-ipsecme-ikev2-fragmentation POTENTIALLY REPLACED BY draft-ietf-ipsecme-ikev2-fragmentation

KITTEN Working Group, SEC Area
   draft-williams-kitten-channel-bound-flag POTENTIALLY REPLACED BY draft-ietf-kitten-channel-bound-flag

MILE Working Group, SEC Area
   draft-montville-mile-enum-reference-format POTENTIALLY REPLACED BY draft-ietf-mile-enum-reference-format

OAUTH Working Group, SEC Area
   draft-jones-oauth-jwt-bearer POTENTIALLY REPLACED BY draft-ietf-oauth-jwt-bearer
   draft-lodderstedt-oauth-revocation POTENTIALLY REPLACED BY draft-ietf-oauth-revocation
   draft-mortimore-oauth-assertions POTENTIALLY REPLACED BY draft-ietf-oauth-assertions
   draft-zeltsan-oauth-use-cases POTENTIALLY REPLACED BY draft-ietf-oauth-use-cases

SACM Working Group, SEC Area
   draft-dbh-sacm-terminology POTENTIALLY REPLACED BY draft-ietf-sacm-terminology
   draft-waltermire-sacm-use-cases POTENTIALLY REPLACED BY draft-ietf-sacm-use-cases

TLS Working Group, SEC Area
   draft-harkins-tls-pwd POTENTIALLY REPLACED BY draft-ietf-tls-pwd
   draft-kanno-tls-camellia POTENTIALLY REPLACED BY draft-ietf-tls-camellia
   draft-rescorla-tls-suiteb POTENTIALLY REPLACED BY draft-ietf-tls-suiteb
   draft-seggelmann-tls-dtls-heartbeat POTENTIALLY REPLACED BY draft-ietf-tls-dtls-heartbeat

-----------------------------------------------------------------
TSV Area
-----------------------------------------------------------------
ALTO Working Group, TSV Area
   draft-song-alto-server-discovery POTENTIALLY REPLACED BY draft-ietf-alto-server-discovery
   draft-stiemerling-alto-deployments POTENTIALLY REPLACED BY draft-ietf-alto-deployments

CDNI Working Group, TSV Area
   draft-bertrand-cdni-logging POTENTIALLY REPLACED BY draft-ietf-cdni-logging
   draft-cjlmw-cdni-metadata POTENTIALLY REPLACED BY draft-ietf-cdni-metadata
   draft-jenkins-cdni-metadata POTENTIALLY REPLACED BY draft-ietf-cdni-metadata
   draft-ma-cdni-metadata POTENTIALLY REPLACED BY draft-ietf-cdni-metadata
   draft-watson-cdni-use-cases POTENTIALLY REPLACED BY draft-ietf-cdni-use-cases

CONEX Working Group, TSV Area
   draft-krishnan-conex-destopt POTENTIALLY REPLACED BY draft-ietf-conex-destopt
   draft-kuehlewind-conex-tcp-modifications POTENTIALLY REPLACED BY draft-ietf-conex-tcp-modifications
   draft-kutscher-conex-mobile POTENTIALLY REPLACED BY draft-ietf-conex-mobile
   draft-mathis-conex-abstract-mech POTENTIALLY REPLACED BY draft-ietf-conex-abstract-mech
   draft-moncaster-conex-concepts-uses POTENTIALLY REPLACED BY draft-ietf-conex-concepts-uses

IPPM Working Group, TSV Area
   draft-bi-ippm-ipsec POTENTIALLY REPLACED BY draft-ietf-ippm-ipsec
   draft-mathis-ippm-model-based-metrics POTENTIALLY REPLACED BY draft-ietf-ippm-model-based-metrics
   draft-morton-ippm-2330-update POTENTIALLY REPLACED BY draft-ietf-ippm-2330-update
   draft-morton-ippm-lmap-path POTENTIALLY REPLACED BY draft-ietf-ippm-lmap-path

NFSV4 Working Group, TSV Area
   draft-alexrn-nfsv4-ipv6 POTENTIALLY REPLACED BY draft-ietf-nfsv4-ipv6
   draft-dnoveck-nfsv4-migration-issues POTENTIALLY REPLACED BY draft-ietf-nfsv4-migration-issues
   draft-eisler-nfsv4-minorversion-2-requirements POTENTIALLY REPLACED BY draft-ietf-nfsv4-minorversion-2-requirements
   draft-haynes-nfsv4-minorversion2 POTENTIALLY REPLACED BY draft-ietf-nfsv4-minorversion2
   draft-haynes-nfsv4-minorversion2-dot-x POTENTIALLY REPLACED BY draft-ietf-nfsv4-minorversion2-dot-x
   draft-quigley-nfsv4-labreqs POTENTIALLY REPLACED BY draft-ietf-nfsv4-labreqs

PPSP Working Group, TSV Area
   draft-cruz-ppsp-base-tracker-protocol POTENTIALLY REPLACED BY draft-ietf-ppsp-base-tracker-protocol
   draft-gu-ppsp-peer-protocol POTENTIALLY REPLACED BY draft-ietf-ppsp-peer-protocol
   draft-gu-ppsp-survey POTENTIALLY REPLACED BY draft-ietf-ppsp-survey

TCPM Working Group, TSV Area
   draft-zimmermann-tcpm-tcp-rfc4614bis POTENTIALLY REPLACED BY draft-ietf-tcpm-tcp-rfc4614bis

-----------------------------------------------------------------
Potential Inconsistencies
-----------------------------------------------------------------
draft-ietf-6lowpan-nd may replace one or more of 2 individual IDs - check this
draft-ietf-armd-problem-statement may replace one or more of 2 individual IDs - check this
draft-ietf-avt-rtp-gsm-hr may replace one or more of 3 individual IDs - check this
draft-ietf-avt-rtp-svc may replace one or more of 2 individual IDs - check this
draft-ietf-bmwg-ipflow-meth may replace one or more of 2 individual IDs - check this
draft-ietf-cdni-metadata may replace one or more of 3 individual IDs - check this
draft-ietf-cdni-use-cases may replace one or more of 2 individual IDs - check this
draft-ietf-decade-integration-example may replace one or more of 2 individual IDs - check this
draft-ietf-decade-survey may replace one or more of 2 individual IDs - check this
draft-ietf-dhc-dhcpv4-bulk-leasequery may replace one or more of 2 individual IDs - check this
draft-ietf-forces-tmlsp may replace one or more of 2 individual IDs - check this
draft-ietf-i2rs-architecture may replace one or more of 2 individual IDs - check this
draft-ietf-insipid-session-id may replace one or more of 2 individual IDs - check this
draft-ietf-ipfix-biflow may replace one or more of 2 individual IDs - check this
draft-ietf-l2tpext-tdm may replace one or more of 2 individual IDs - check this
draft-ietf-l2vpn-vpls-multihoming may replace one or more of 2 individual IDs - check this
draft-ietf-lmap-framework may replace one or more of 3 individual IDs - check this
draft-ietf-mmusic-latching may replace one or more of 2 individual IDs - check this
draft-ietf-mpls-moving-iana-registries may replace one or more of 2 individual IDs - check this
draft-ietf-mpls-tp-fault may replace one or more of 2 individual IDs - check this
draft-ietf-mpls-tp-ring-protection may replace one or more of 2 individual IDs - check this
draft-ietf-netconf-monitoring may replace one or more of 2 individual IDs - check this
draft-ietf-netlmm-lma-discovery may replace one or more of 2 individual IDs - check this
draft-ietf-netlmm-mip-interactions may replace one or more of 2 individual IDs - check this
draft-ietf-nvo3-gap-analysis may replace one or more of 2 individual IDs - check this
draft-ietf-nvo3-security-requirements may replace one or more of 2 individual IDs - check this
draft-ietf-paws-protocol may replace one or more of 3 individual IDs - check this
draft-ietf-payload-rtp-aptx may replace one or more of 2 individual IDs - check this
draft-ietf-pce-stateful-pce may replace one or more of 2 individual IDs - check this
draft-ietf-sip-saml may replace one or more of 2 individual IDs - check this
draft-ietf-sipping-service-identification may replace one or more of 2 individual IDs - check this
draft-ietf-softwire-4rd may replace one or more of 3 individual IDs - check this
draft-ietf-softwire-dslite-deployment may replace one or more of 2 individual IDs - check this
draft-ietf-trill-rbridge-arch may replace one or more of 2 individual IDs - check this
draft-ietf-xmpp-dna may replace one or more of 2 individual IDs - check this

---

From: Dave Thaler <[email-masked]>
Date: Thu, 7 Nov 2013 03:19:20 +0000

> so you guys can now fix all of these by yourself! Awesome!

Thanks to the tools folks that added this feature, I agree this is awesome,
and I'll definitely be using it starting immediately.

Future feature request: Is there a way to mark something as not-replaces
so it disappears from the report?  Alternatively, the heuristics used by the
report could be improved to have fewer false positives.

>    draft-liu-behave-ftp64 POTENTIALLY REPLACED BY draft-ietf-behave-ftp64

While the filename has the same suffix, the draft versions have overlapping dates:
(8/19/09  - 7/10/10) vs (12/17/09 - 7/8/11)
They also have very different titles and authors, but I would think that the date
overlap heuristic could be used to improve the duplicate heuristic fairly reliably.

If such cases continue to appear on the reports in the future, we'll still have
continuous accretion of more and more noise in the report.

Not a big deal but since we've made so much great progress on this recently,
I thought I'd throw this out for the future tools improvements list.

-Dave

---

From: "Eggert, Lars" <[email-masked]>
Date: Fri, 8 Nov 2013 19:46:34 +0000

Hi,

> report could be improved to have fewer false positives.

this comes up almost every time I sent out a report. The heuristics are just dumb string matching on ID name suffixes. Nothing else. 

For me personally, it's not a big deal to filter the false positives out mentally, which is why my motivation for doing something here is low.

If folks want to tweak the code, it's available (bash script) at http://eggert.org/software/find-replaced-by

Lars

PS: It's not an IETF or tools-team tool, it's my own little script, so don't blame either of those fine folks for the shortcomings.

---

From: "Timothy B. Terriberry" <[email-masked]>
Date: Fri, 08 Nov 2013 15:09:47 -0800

> PS: It's not an IETF or tools-team tool, it's my own little script, so don't blame either of those fine folks for the shortcomings.

Thanks for making this available. It's actually on my TODO list to 
incorporate the same "dumb string matching" into the auto-completion 
suggestions when you go to enter the replaced-by information.

---

From: Ulrich Herberg <[email-masked]>
Date: Mon, 11 Nov 2013 09:48:07 -0800

Great thing!

I have a question about how the "replaced-by" is used. In my WG, we moved
draft-ietf-6lowpan-btle from the sunsetting 6lowpan WG to
draft-ietf-6lo-btle. I was instructed to ask the authors to resubmit their
draft as draft-ietf-6lo-btle-00, and I updated the replaces info. However,
on http://tools.ietf.org/html/draft-ietf-6lo-btle-00
there is no info regarding the IESG evaluation, the history of
draft-ietf-6lowpan-btle, or the IESG status. The only way of getting that
is to follow the link "replaces" to the old draft. Moreover, when clicking
on http://tools.ietf.org/html/draft-ietf-6lo-btle-00, there is no info
about the replaced draft. People just looking at that page would not
necessarily understand that the draft replaces another. Is that intended
like that? Or is there another step that I missed?

Thanks
Ulrich

On Wed, Nov 6, 2013 at 6:34 PM, Eggert, Lars <[email-masked]> wrote:

> WG and RG chairs are encouraged to check whether these are accurate for
> their groups, and if so, FIX THEM IN THE DATATRACKER per above.
>
> As always, double-check before doing this. Also, see list of possible
> inconsistencies at the end of the report.
>
> (Note that the IPR disclosure search tool uses these replaced-by
> relationships, so keeping them up-to-date is actually useful and not just
> WG hygiene.)
>
> The source code for this tool is at
> http://eggert.org/software/find-replaced-by
>
> Lars
>
>
>    draft-probasco-paws-problem-stmt-usecases-rqmts POTENTIALLY REPLACED BY
> draft-ietf-paws-problem-stmt-usecases-rqmts
>    draft-drage-sipping-service-identification POTENTIALLY REPLACED BY
> draft-ietf-sipping-service-identification
>    draft-rosenberg-sipping-service-identification POTENTIALLY REPLACED BY
> draft-ietf-sipping-service-identification
>    draft-meyer-speermint-reqs-and-terminology POTENTIALLY REPLACED BY
> draft-ietf-speermint-reqs-and-terminology
>    draft-cooper-6man-ipv6-address-generation-privacy POTENTIALLY REPLACED
> BY draft-ietf-6man-ipv6-address-generation-privacy
>    draft-schmidt-multimob-fmipv6-pfmipv6-multicast POTENTIALLY REPLACED BY
> draft-ietf-multimob-fmipv6-pfmipv6-multicast
>    draft-melia-netext-logical-interface-support POTENTIALLY REPLACED BY
> draft-ietf-netext-logical-interface-support
>    draft-qin-softwire-multicast-prefix-option POTENTIALLY REPLACED BY
> draft-ietf-softwire-multicast-prefix-option
>    draft-gupta-ipfix-reliability-template-ext POTENTIALLY REPLACED BY
> draft-ietf-ipfix-reliability-template-ext
>
>    draft-asaeda-mboned-session-announcement-req POTENTIALLY REPLACED BY
> draft-ietf-mboned-session-announcement-req
>    draft-bipi-mboned-ip-multicast-pm-requirement POTENTIALLY REPLACED BY
> draft-ietf-mboned-ip-multicast-pm-requirement
>    draft-tsou-mboned-multrans-addr-acquisition POTENTIALLY REPLACED BY
> draft-ietf-mboned-multrans-addr-acquisition
>    draft-krishnan-opsawg-large-flow-load-balancing POTENTIALLY REPLACED BY
> draft-ietf-opsawg-large-flow-load-balancing
>    draft-romanow-clue-telepresence-requirements POTENTIALLY REPLACED BY
> draft-ietf-clue-telepresence-requirements
>    draft-channabasappa-drinks-usecases-requirements POTENTIALLY REPLACED
> BY draft-ietf-drinks-usecases-requirements
>
>    draft-shen-soc-load-control-event-package POTENTIALLY REPLACED BY
> draft-ietf-soc-load-control-event-package
>
>    draft-asaeda-xrblock-rtcp-xr-synchronization POTENTIALLY REPLACED BY
> draft-ietf-xrblock-rtcp-xr-synchronization
>    draft-singh-xrblock-rtcp-xr-bytes-discarded-metric POTENTIALLY REPLACED
> BY draft-ietf-xrblock-rtcp-xr-bytes-discarded-metric
>
>    draft-haleplidis-forces-implementation-experience POTENTIALLY REPLACED
> BY draft-ietf-forces-implementation-experience
>    draft-dearlove-manet-nhdp-olsrv2-tlv-extension POTENTIALLY REPLACED BY
> draft-ietf-manet-nhdp-olsrv2-tlv-extension
>    draft-dearlove-manet-olsrv2-rmpr-optimization POTENTIALLY REPLACED BY
> draft-ietf-manet-olsrv2-rmpr-optimization
>    draft-eisler-nfsv4-minorversion-2-requirements POTENTIALLY REPLACED BY
> draft-ietf-nfsv4-minorversion-2-requirements

---

From: Barry Leiba <[email-masked]>
Date: Mon, 11 Nov 2013 12:59:45 -0500

> Moreover, when clicking on
> http://tools.ietf.org/html/draft-ietf-6lo-btle-00, there is no info about
> the replaced draft. People just looking at that page would not necessarily
> understand that the draft replaces another.

Right; they should look at the datatracker pages instead of the tools pages:
https://datatracker.ietf.org/doc/draft-ietf-6lo-btle/

That does have the "replaces" information.

We can (the tools team can) tweak the tools pages.  Or we can just
accept that the tools pages were there when the datatracker
information wasn't as good, and we can all start using the datatracker
pages as the definitive source of information.

That said, it's true that it's not always easy to find -- or to know
to look for -- all the information necessary.  One thing that would
help is a comment in the datatracker history for the 6lo document that
says that understanding the history of the 6lowpan document is
critical here.  The comment might even mention the dependency on
BT-SIG.  Someone still would have to look at the history to know that
(it won't be on the front page), but the information would be there.

We have the tools we need, but they can't perfectly deal with every
situation (and this one is relatively unusual).

Barry

---

From: Ulrich Herberg <[email-masked]>
Date: Mon, 11 Nov 2013 10:47:56 -0800

Barry,

thanks for the explanations. I agree that this case is not very common, and
it should not be a big deal, since the draft in question is already in a
very late stage.

There was a similar case in another WG, where a draft was renamed (from
draft-ietf-manet-dymo to draft-ietf-manet-aodvv2). In that case, the
replace-by information is shown in the tools page of the new draft (in
"Versions"), so there must be some possibility to add that info.

Regards
Ulrich