Subject: ID checklist page

From: Jari Arkko <[email-masked]>
Date: Thu, 12 Dec 2013 23:03:00 +0200

In IESG discussion today it was pointed out that the ID checklist page (http://www.ietf.org/id-info/checklist.html) is somewhat out of date. For instance, it points to RFCs that have been replaced by newer ones.

Before we deciding what to do about this (update this ourselves, turn it into a wiki page, etc) we wanted to understand how widely the page is being used and how it is used. Do you use it, and do you find it useful? How would you like to use it?

Jari

---

From: "Andrew G. Malis" <[email-masked]>
Date: Thu, 12 Dec 2013 16:24:52 -0500

Jari,

I haven't looked at that page in years, I just run idnits. :-)

Cheers,
Andy

On Thu, Dec 12, 2013 at 4:03 PM, Jari Arkko <[email-masked]> wrote:

> In IESG discussion today it was pointed out that the ID checklist page (
> http://www.ietf.org/id-info/checklist.html) is somewhat out of date. For
> instance, it points to RFCs that have been replaced by newer ones.
>
> Before we deciding what to do about this (update this ourselves, turn it
> into a wiki page, etc) we wanted to understand how widely the page is being
> used and how it is used. Do you use it, and do you find it useful? How
> would you like to use it?
>
> Jari
>
>

---

From: Jari Arkko <[email-masked]>
Date: Thu, 12 Dec 2013 23:52:59 +0200

> I haven't looked at that page in years, I just run idnits. :-)

Seems to match my experience, then…

Jari

---

From: Ralph Droms <[email-masked]>
Date: Thu, 12 Dec 2013 16:58:24 -0500

> Seems to match my experience, then…

...and use xml2rfc, starting with a favorite blank template.

- Ralph

---

From: Jeffrey Haas <[email-masked]>
Date: Thu, 12 Dec 2013 17:26:13 -0500

> Before we deciding what to do about this (update this ourselves, turn it into a wiki page, etc) we wanted to understand how widely the page is being used and how it is used. Do you use it, and do y…

I believe I pointed this out. :-)

I no longer recall by which path I got there.  Google suggests it's embedded
a lot of places.  I got to it as part of doing my document shepherd work.

The fun thing is I paid almost no attention to this document until I got to
the shepherd work.  The I-D nits tool, xml2rfc and other things were doing
their job and it was the web page that was out of date.

My suggestion is that it should be revised due to the number of links that
lead to it.

-- Jeff

---

From: Warren Kumari <[email-masked]>
Date: Thu, 12 Dec 2013 17:28:04 -0500

On Dec 12, 2013, at 4:03 PM, Jari Arkko <[email-masked]> wrote:

> Before we deciding what to do about this (update this ourselves, turn it into a wiki page, etc) we wanted to understand how widely the page is being used and how it is used. Do you use it, and do you find it useful?

Huh? We have an ID checklist page?!

> How would you like to use it?

It would make a great paper plane… or a hat… 

W 
(Yes, I knew about that page. No, I haven’t looked at it in years. The ID nits tool does everything needed)

> Jari

In fact, the mere act of opening the box will determine the state of the cat, although in this case there were three determinate states the cat  could be in: these being Alive, Dead, and Bloody Furious. 
-- Schrodinger's Moggy explained 
(Terry Pratchett, Lords and Ladies)

---

From: Mary Barnes <[email-masked]>
Date: Thu, 12 Dec 2013 16:51:55 -0600

I personally don't use the checklist - like others, I just run idnits.  I
have pointed folks that are new to writing drafts to that page
occasionally, but there are probably better references.

Mary.

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 13 Dec 2013 00:29:07 +0100

> I haven't looked at that page in years, I just run idnits. :-)

I assume the smiley was acknowledging that this isn’t quite the right thing to do.

If that page is ever revised, it would probably help if it were structured into three parts:
— things xml2rfc already does for you, so you can completely ignore them unless you use MS-Word,
— things idnits finds for you, so a rookie might occasionally need some explanation why it is being checked and how to fix it,
— things that really need to be done manually.

Only the third list (which should be much shorter) is something that actually needs to be run as a checklist before takeoff.

Grüße, Carsten

---

From: "Andrew G. Malis" <[email-masked]>
Date: Thu, 12 Dec 2013 18:32:06 -0500

Carsten,

More seriously, it would be great if between the combination of xml2rfc and
idnits, the third category would be the null set!

Cheers,
Andy

On Thu, Dec 12, 2013 at 6:29 PM, Carsten Bormann <[email-masked]> wrote:

> — things idnits finds for you, so a rookie might occasionally need some
> explanation why it is being checked and how to fix it,
> Only the third list (which should be much shorter) is something that
> actually needs to be run as a checklist before takeoff.
>
> Grüße, Carsten
>
>

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Fri, 13 Dec 2013 00:56:14 +0000

Since idnits gained the add ons to check Ipv4 and IPv6 are equally covered, and that the security considerations make sense, who needs to do anything more?

Keith

> -----Original Message-----
> From: WGChairs [mailto:[email-masked]] On Behalf 
> Of Jari Arkko
> Sent: 12 December 2013 21:53
> To: Andrew G. Malis
> Cc: Working Group Chairs
> Subject: Re: ID checklist page
> 
> 
> Seems to match my experience, then...
> 
> Jari
> 
>

---

From: Loa Andersson <[email-masked]>
Date: Fri, 13 Dec 2013 14:42:11 +0800

yes - do the same as Andy, ID Nits takes its inout from that page,
right?

/Loa

On 2013-12-13 05:24, Andrew G. Malis wrote:
> On Thu, Dec 12, 2013 at 4:03 PM, Jari Arkko <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>     In IESG discussion today it was pointed out that the ID checklist
>     page (http://www.ietf.org/id-info/checklist.html) is somewhat out of
>     date. For instance, it points to RFCs that have been replaced by
>     newer ones.
>
>     Before we deciding what to do about this (update this ourselves,
>     turn it into a wiki page, etc) we wanted to understand how widely
>     the page is being used and how it is used. Do you use it, and do you
>     find it useful? How would you like to use it?
>
>     Jari
>
>

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Huawei Technologies (consultant)     phone: +46 739 81 21 64

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 13 Dec 2013 08:15:39 +0100

Yes, but there are things on that page that can’t be done automatically, e.g.:

> 	• Use network byte order in diagrams, see section 5.2 in http://www.rfc-editor.org/rfc-style-guide/rfc-style-manual-08.txt 

(Well, OK, that would be noticed outside this process)

> 	• IANA Considerations

These really need to be checked.  Even long-time contributors get them wrong.

> Abstract 
> 
> A.
> Should be meaningful to someone not versed in the technology; most abbreviations must be expanded on first use.

I think ID nits can’t check those…  etc.

> Use of formal languages should be in conformance with the IESG statement on the use of formal languages - 

(MIB modules, ABNF, XML, …)

> References
> A.
> All references must be stable and resolvable.
> B.

and

> Avoid text that will become outdated after RFC is published. 

etc.

I know that we all defer to ID nits instead of doing tedious checks ourselves; having a short list of things that need to be done by a human being might help us getting these things done.  Nobody is going to apply a long checklist where (at least in the first items) nearly everything is already automatically checked.

Grüße, Carsten

---

From: Jari Arkko <[email-masked]>
Date: Sun, 15 Dec 2013 12:36:59 -0500

> — things that really need to be done manually.

This was a helpful suggestion. Thanks.

Jari

---

From: Magnus Westerlund <[email-masked]>
Date: Mon, 16 Dec 2013 13:42:19 +0100

> Before we deciding what to do about this (update this ourselves, turn it into a wiki page, etc) we wanted to understand how widely the page is being used and how it is used. Do you use it, and do y…

I actually use it in each shepherd write-up to verify that I don't
forget to check things manually. I think Carsten's suggestion was excellent.

Cheers

Magnus Westerlund

----------------------------------------------------------------------
Multimedia Technologies, Ericsson Research EAB/TVM
----------------------------------------------------------------------
Ericsson AB                | Phone  +46 10 7148287
Färögatan 6                | Mobile +46 73 0949079
SE-164 80 Stockholm, Sweden| mailto: [email-masked]
----------------------------------------------------------------------

---

From: Karen O'Donoghue <[email-masked]>
Date: Mon, 16 Dec 2013 10:38:26 -0500

I think we are possibly asking the wrong group of people if they use 
this page. Another perspective might be if you stumbled upon it as as a 
new ID author would it be helpful or harmful. Along those lines, I think 
it should be revised and simplified where possible. I think Carsten's 
approach seems reasonable.

Karen