Subject: question on data tracker and "Adopt in Group"

From: Jouni Korhonen <[email-masked]>
Date: Wed, 26 Mar 2014 15:01:53 +0200

Hi,

Someone explain me how this is supposed to work. If I click the
thing the doc goes into "Call for Adoption by WG Issued" state.
After that if the adoption succeeds I can change the state to
"WG document". But the document name remain and does not change
to draft-ietf-*-00 which would be preferable. On the other hand
if the adoption fails, there is no state to move it back to an
individual document, right? Or does "-----" mean the same? I
can set the tag "Polled for WG adoption but not adopted" but
will that move the document again to free individual territory?

- Jouni

---

From: Ines Robles <[email-masked]>
Date: Wed, 26 Mar 2014 10:31:42 -0300

* Hi Jouni, What I know about this, You set ""Call for Adoption by WG
Issued" to let the people know that the draft is in this call If the
adoption succeeds: 1. The author should submit a new draft with
draft-ietf-*-00 2. The chair should accept it, you will get an emai with
this subject 1. New draft waiting for approval: draft-ietf-**** Hi, Chair
approval is needed for posting of draft-ietf-***-00. To approve the draft,
go to this URL (note: you need to login to be able to approve): 1. When it
is approved, you should go to the new document and edit in the "Replaces"
1. Document type: Active Internet-Draft (roll WG
<https://datatracker.ietf.org/wg/roll/>) Replaces: "put the old one"
<https://datatracker.ietf.org/doc/draft-doi-roll-mpl-parameter-configuration/>
1. Automatically the old one is going to dissapear form Related
Internet-Drafts list. and in the old one you will find something like: This
Internet-Draft is no longer active. Unofficial copies of old
Internet-Drafts can be found here: http://tools.ietf.org/id/
<http://tools.ietf.org/id/draft-doi-roll-mpl-parameter-configuration>... If
the call is not succeed, I'm not sure, because I have not faced that
situation yet, but  I think, you could put the state as "Dead WG Document",
and in the comment "This is not a WG Document, but the call for adoption
was not succeed. " or something like that. or you can put "Waiting for WG
Chair go Ahead" and you should contact secretariat
[email-masked] <[email-masked]>.*

* I hope this help Best, Ines. *

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 26 Mar 2014 14:34:04 +0100

Hi Jouni,

On 2014-03-26 14:01 Jouni Korhonen said:
> to draft-ietf-*-00 which would be preferable.

*The action you take, you take on a specific document.*

If you want to adopt a draft-ietf-*-00, that document needs to exist
in the system first.

If you really want to adopt the individual document, and later replace
it with one named draft-ietf-*-00, you can do that, of course.

> On the other hand
> individual document, right?

Correct.  That's a bug.

> Or does "-----" mean the same? I

No.  We need to make it possible to move a draft back to individual.

Best regards,

	Henrik

---

From: Jouni Korhonen <[email-masked]>
Date: Wed, 26 Mar 2014 15:45:04 +0200

Hi,

On Mar 26, 2014, at 3:31 PM, Ines  Robles <[email-masked]> wrote:

> Hi Jouni,
> 
> What I know about this,
> 
> You set “"Call for Adoption by WG Issued” to let the people know that the draft is in this call
> If the adoption succeeds:
> 	• The author should submit a new draft with draft-ietf-*-00
> 	• The chair should accept it, you will get an emai with this subject 
> 		• New draft waiting for approval: draft-ietf-****

This will confuse the system (been there done that). The tools page and issue tracker will have issues after this. Well issues in a sense that something happened you did not expect and you cannot assign tickets to draft-ietf-* document. Look for example Dime WG tools page ;-)

- Jouni

> Hi,
> 
> Chair approval is needed for posting of draft-ietf-***-00.
> 
> To approve the draft, go to this URL (note: you need to login to be able to approve):
> 
> 	• When it is approved, you should go to the new document and edit in the “Replaces”
> 	• Document type:
> Active Internet-Draft (roll WG)
> Replaces: “put the old one”
> 	• Automatically the old one is going to dissapear form Related Internet-Drafts list. and in the old one you will find something like:
> 		This Internet-Draft is no longer active. Unofficial copies of old Internet-Drafts can be found here: http://tools.ietf.org/id/...
> 
> If the call is not succeed, I’m not sure, because I have not faced that situation yet, but  I think, you could put the state as “Dead WG Document”, and in the comment “This is not a WG Document, but the call for adoption was not succeed. ” or something like that. or you can put "Waiting for WG Chair go Ahead" and you should contact secretariat [email-masked].
> 
> I hope this help 
> 
> Best,
> 
> Ines.
> 
> 
> 
> 
> 
> 
> 
> 
>

---

From: Jouni Korhonen <[email-masked]>
Date: Wed, 26 Mar 2014 15:45:31 +0200

Thanks Henrik.

- JOuni

---

From: Ines Robles <[email-masked]>
Date: Wed, 26 Mar 2014 11:09:27 -0300

Hi Jouni,

Thanks, I got your point :-), you meant, for example, draft-docdt-dime-ovli
with Candidate for WG Adoption status.

Yes, I see the issue now.

Best,

Ines

2014-03-26 10:45 GMT-03:00 Jouni Korhonen <[email-masked]>:

> > You set ""Call for Adoption by WG Issued" to let the people know that
> the draft is in this call
> >       * The author should submit a new draft with draft-ietf-*-00
> >       * The chair should accept it, you will get an emai with this
> subject
> >               * New draft waiting for approval: draft-ietf-****
>
> This will confuse the system (been there done that). The tools page and
> issue tracker will have issues after this. Well issues in a sense that
> something happened you did not expect and you cannot assign tickets to
> draft-ietf-* document. Look for example Dime WG tools page ;-)
>
> - Jouni
>
>
>
> > Hi,
> >
> >       * When it is approved, you should go to the new document and edit
> in the "Replaces"
> >       * Document type:
> > Replaces: "put the old one"
> >       * Automatically the old one is going to dissapear form Related
> Internet-Drafts list. and in the old one you will find something like:
> >               This Internet-Draft is no longer active. Unofficial copies
> of old Internet-Drafts can be found here: http://tools.ietf.org/id/...
> >
> > If the call is not succeed, I'm not sure, because I have not faced that
> [email-masked].
> >
> > I hope this help
> >
> > Best,
> >
> > Ines.
> >
> >
> >
> >
> >
> >
> >
> >
> >

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 26 Mar 2014 11:19:38 -0400

On 3/26/14 9:31 AM, Ines Robles wrote:

> 3. When it is approved, you should go to the new document
>    and edit in the “Replaces”
>    a. Document type: Active Internet-Draft (roll WG)

How does this work? Initially it says "Replaces: None !", where the "!" 
links to a page to change this. But that page is very cryptic! It has a 
"replaces" box and a "comment" box. No hint of what format is expected.

I've tried just using the filename of the prior version, with version 
and .txt and without any directory or url prefix. I've also tried the 
full datatracker URL of the old one.

Neither got any complaint, and neither caused any observable change.

Not very user friendly.

	Thanks,
	Paul

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Wed, 26 Mar 2014 15:23:22 +0000

This box is indeed a bit 'tricky'. If you start typing the name of the
draft, it will give you a list of drafts that match and you can select one.

The first time I tried to use it, I pasted in the name of the draft and
this ended up not working well because it doesn't seem to let you select
it when there is a full match (or perhaps I had the .txt there).

Anyway, I found that if you just delete some of the last characters and
let it bring up the list of draft names (even if just one), and you select
(click on) the correct draft it works fine.

- Bernie

On 3/26/14 11:19 AM, "Paul Kyzivat" <[email-masked]> wrote:

>>    and edit in the ³Replaces²
>>                      Replaces: ³put the old one²
>

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 26 Mar 2014 11:35:10 -0400

> (click on) the correct draft it works fine.

That is *weird*. Now that I know, I guess I won't have trouble again.
But it is definitely non-intuitive.

	Thanks,
	Paul

---

From: Robert Sparks <[email-masked]>
Date: Thu, 27 Mar 2014 16:20:01 -0500

I captured a ticket for improving this.

RjS