Subject: Process on expired draft, waiting on MISSREF?

From: Warren Kumari <[email-masked]>
Date: Thu, 13 Mar 2014 13:31:05 +0000

Hi all,

I did poke around and couldn't find an answer, so I'm asking here...

I have a draft that was approved, but is stuck in the RFC Ed queue,
waiting on a missing reference.
The draft "expired" a while back, and I'm not sure when the reference
will be published.

Is is acceptable to submit a new version with just the dates changed,
to keep it current? Or should I not touch it?

W

---

From: Stephen Farrell <[email-masked]>
Date: Thu, 13 Mar 2014 13:32:25 +0000

> to keep it current? Or should I not touch it?

I think leaving it be is fine. Stuff can be in the
RFC editor queue for ages on a bad MISREF so they're
used to that.

S.

---

From: Warren Kumari <[email-masked]>
Date: Thu, 13 Mar 2014 13:38:25 +0000

> RFC editor queue for ages on a bad MISREF so they're

Yeah, the RFC Editor understands that, but some other folk get confused.

What prompted this question was someone who looked at the draft, saw
the date had expired and asked if we could rev it to make it current.
I fixed this particular issue by pointing out that it is in the editor
queue (and the tracker doesn't list it as expired), and they are fine
with that. Just wondering if other folk are also assuming that docs in
the past are expired, while they are actually in limbo / purgatory.

W

W

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Thu, 13 Mar 2014 13:46:19 +0000

The tracker is correct. Once publication is requested, documents do not expire.

The "mistake" is getting a MISSREF that does not rapidly complete in the first place.

Keith 

> -----Original Message-----
> From: WGChairs [mailto:[email-masked]] On Behalf 
> Of Warren Kumari
> Sent: 13 March 2014 13:38
> To: Stephen Farrell
> Cc: WG Chairs
> Subject: Re: Process on expired draft, waiting on MISSREF?
> 
> > I think leaving it be is fine. Stuff can be in the RFC editor queue 
> > for ages on a bad MISREF so they're used to that.
> 
> What prompted this question was someone who looked at the 
> draft, saw the date had expired and asked if we could rev it 
> to make it current.
> I fixed this particular issue by pointing out that it is in 
> the editor queue (and the tracker doesn't list it as 
> expired), and they are fine with that. Just wondering if 
> other folk are also assuming that docs in the past are 
> expired, while they are actually in limbo / purgatory.
> 
> W
> 
> W
> 
> >
> > S.
> >
> >>
> >> W
> >>
> >>
> >>
> 
>

---

From: Barry Leiba <[email-masked]>
Date: Tue, 18 Mar 2014 12:50:10 -0400

> to keep it current? Or should I not touch it?

It's never acceptable to rev a draft that's in the RFC Editor queue
without first clearing it with the RFC Editor.  If the RFC Editor and
your responsible AD both think it's OK, that's the approval you need.

(I'm in the camp that thinks it's not necessary to freshen up such
documents, but I do understand that having the expiration date in the
draft itself does confuse some people.)

Barry

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 18 Mar 2014 17:54:26 +0100

On 18 Mar 2014, at 17:50, Barry Leiba <[email-masked]> wrote:

> I do understand that having the expiration date in the
> draft itself does confuse some people.

Or is actively used against the IETF to confuse people.

Data point:
Given the heavy marketing of random protocols for IoT, some marketers are running around out there claiming that CoAP “has expired”.

(The fix is not to re-spin, but to get rid of those 6+ months MISSREF process failures.)

Grüße, Carsten

---

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 18 Mar 2014 17:03:16 -0000

The missref is not a process failure, it is a contribution failure!

If the referenced document is not needed, then don't reference it.
If the referenced document is needed then make active contributions to get it
completed.

A

> From: iesg [mailto:[email-masked]] On Behalf Of Carsten Bormann
> Sent: 18 March 2014 16:54
> To: Barry Leiba
> Cc: WG Chairs
> Given the heavy marketing of random protocols for IoT, some marketers are
> running around out there claiming that CoAP “has expired”.
>

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Tue, 18 Mar 2014 17:38:58 +0000

> to keep it current? Or should I not touch it?

Let me relay how I have dealt with a MISSREF recently. v6ops has a document that has been sitting waiting for something from 6man for something on the order of a couple of years. In the meantime, the document it refers to was scrapped and rewritten, and is now an RFC by another name, and another document went to RFC. As shepherd, I have asked the authors and the 6man chairs about it a couple of times over that interval, and gotten answers that led me to “go back to sleep". I haven’t worried much about it, as one of the authors is definitely active in 6man; I figured he would be on top of this. A couple of months ago, I got sufficiently puzzled to figure out exactly what the issues were and go back to the authors and the RFC Editor with a specific set of proposed changes. The authors agreed with me on the changes, and the draft is (as of a few days ago) in AUTH48.

Someone said that if the draft is reposted, it should be with the agreement of the RFC Editor. I think it also needs at least the tacit approval of the AD, as there was an IESG decision on it. But there are essentially two ways the MISSREF can be cleared - the referenced document can arrive, or the document in MISSREF can be changed so that it is no longer a dangling normative reference. Sometimes that’s as simple as moving the bibliographic line from “normative” to “informative”, in cases in which it arguably should have been informative in the first place. I expect the more common case, as in the one I just mentioned, is a little more surgical. Simply reposting the draft doesn’t accomplish much - the new version is still waiting on the reference.